[Risolto]-Al click del mouse su una riga dell'indice il testo scorre di uno step verso l'alto

Problemi riscontrati nell'uso del forum, suggerimenti e critiche per migliorare il servizio.
Avatar utente
et4beta
Rampante Reduce
Rampante Reduce
Messaggi: 7519
Iscrizione: mercoledì 9 gennaio 2008, 10:15
Desktop: Gnome
Distribuzione: 18.04-20.04-20.10 (NO UEFI)
Località: Ancona

[Risolto]-Al click del mouse su una riga dell'indice il testo scorre di uno step verso l'alto

Messaggio da et4beta » martedì 19 maggio 2020, 15:46

Non tratto questo argomento su "Errori nel forum", perché non so se si tratti di un problema del forum o mio, anche se solo nel sito del forum di Ubuntu ho notato questo fatto.
Non è un grosso handicap ma da parecchio tempo mi accade, indifferentemente dall'OS che uso(Ubuntu o Win) che quando uso il forum se clicco col tasto sx del mouse su una riga dell'indice generale o di una sezione per visualizzare i post della discussione relativa, al click istantaneamente tutte le righe della pagina fanno lo scatto di uno spazio verso l'alto cosicché la riga su cui ho cliccato, e che col puntatore sopra si era debitamente evidenziata, scatti insieme al tutto sfuggendo da sotto il puntatore e mandando il click a vuoto.
Questo non accade sempre, ma quasi sempre dopo essere uscito dalla visualizzazione di una discussione con la freccia del browser(Firefox) "pagina indietro" ed aver poi fatto il refresh della pagina dell'indice per aggiornarla.
Ho provato anche ad andare sulla riga, che si evidenzia immediatamente, aspettare e poi cliccare, ma nessuna differenza perché sfugge comunque.
Ho detto quasi sempre perché effettivamente alcune volte la cosa non accade, ma molto raramente.
Succede solo a me o c'è qualcun altro che ha riscontrato questo fatto nel suo sistema?
Ultima modifica di et4beta il giovedì 21 maggio 2020, 17:49, modificato 2 volte in totale.
Linux User #485103 - Ubuntu User #38220 - Desktop: MoBo Asus X99-A - Intel i7 5820K - RAM G.Skill Ripjaws V DDR4 32 Gb - GPU Asus STRIX Nvidia GTX 970 - Monitor Asus MG278Q - SSD Samsung 970 EVO Plus M.2 PCIe NVMe 500 Gb - SSD Samsung 850 EVO 500 Gb + 3 HDD (2 Seagate 2Tb+ 1 WD 2Tb) - / - Asus TUF Gaming FX705GE - i7 8750H - RAM 16 Gb - / - Asus K55VD i7 3610QM RAM 8Gb.

Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 21058
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 20.04 e 20.10 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: Al click del mouse su una riga dell'indice il testo scorre di un step verso l'alto

Messaggio da trekfan1 » mercoledì 20 maggio 2020, 13:26

A me non succede, non è che potrebbe essere che c'è qualche sfregamento del pulsante sx con la rotellina?

Avatar utente
Janvitus
Amministratore
Amministratore
Messaggi: 18103
Iscrizione: lunedì 25 aprile 2005, 15:52
Desktop: GNOME Shell / Xfce
Sesso: Maschile
Località: Potenza
Contatti:

Re: Al click del mouse su una riga dell'indice il testo scorre di un step verso l'alto

Messaggio da Janvitus » mercoledì 20 maggio 2020, 14:49

Io non ho capito dov'è il problema...
+Fedora 32 • +Xubuntu 20.04

Avatar utente
et4beta
Rampante Reduce
Rampante Reduce
Messaggi: 7519
Iscrizione: mercoledì 9 gennaio 2008, 10:15
Desktop: Gnome
Distribuzione: 18.04-20.04-20.10 (NO UEFI)
Località: Ancona

Re: Al click del mouse su una riga dell'indice il testo scorre di un step verso l'alto

Messaggio da et4beta » mercoledì 20 maggio 2020, 15:21

Il "problema" è semplice ma non così facile da spiegare a chi non lo può vedere.
Provo a ripetere che cosa mi succede da lungo tempo. Preciso anche che quanto espongo mi capita soltanto sul sito del forum di Ubuntu, assolutamente mai in altri siti.

Gli eventi:
Accedo al sito del forum di Ubuntu e mi trovo sull'indice generale, clicco su una sezione qualsiasi e poi sul titolo di una discussione. Me la leggo e poi esco dalla visualizzazione cliccando su tasto freccia a sx del menu del browser tornando all'indice con i titoli della sezione, clicco sul tasto refresh del browser per fare un refresh dei titoli e mettere in stato di "hold" quello appena letto e poi mi sposto col puntatore su un altro titolo che non appena ha il puntatore sopra si sottolinea, a questo punto se clicco, invece di passare alla visualizzazione dei post della discussione, avviene che tutte le righe dell'indice fanno uno scatto verso l'alto e quella su cui ho cliccato, insieme alle altre, si toglie da sotto il puntatore e l'unico effetto della cliccata è quello di far scorrete tutto di uno step verso l'alto. Debbo perciò tornare con puntatore sulla riga precedentemente cliccata e ricliccare, e questa seconda volta va tutto a buon fine.
Questo non avviene il 100% della volte ma almeno il 97/98%,

@trekfan1 ci avevo pensato ma la non plausibilità della causa ha due ottime ragioni: la prima è che se fosse il mouse(che per inciso va perfettamente) lo farebbe anche in altri siti, la seconda è che la rotellina del mouse è configurata per effettuare lo scroll di tre step per scatto, mentre il movimento che ho io è di un solo step.

Per diverso tempo non ci ho fatto caso pensando che fossi io a sbagliare la "mira" col puntatore, ma quando mi è venuto il sospetto che non fosse così ed ho iniziato a fare delle prove ho constatato con precisione come avveniva il fenomeno, ma non sono riuscito a trovare una spiegazione.
Sarebbe anche molto probabile che non sia il solo a d avere questo "difetto" ma siccome è facile farci l'abitudine, altri potrebbero non averlo notato e conviverci tranquillamente, come del resto ho fatto anche io fino ad oggi.

Non so se possa essere importante, ma ho il mouse configurato, sia in Ubuntu che in Win, per aprire i link ed i file con un solo clic, ma questa è una configurazione più del gestore file che non del browser.
Spero di essermi fatto comprendere, e ripeto che il fatto costituisce un "problema" proprio tra virgolette, ma siccome una delle mie fisse è voler capire, avrei soddisfazione nel poter dare una spiegazione anche a questo.
Linux User #485103 - Ubuntu User #38220 - Desktop: MoBo Asus X99-A - Intel i7 5820K - RAM G.Skill Ripjaws V DDR4 32 Gb - GPU Asus STRIX Nvidia GTX 970 - Monitor Asus MG278Q - SSD Samsung 970 EVO Plus M.2 PCIe NVMe 500 Gb - SSD Samsung 850 EVO 500 Gb + 3 HDD (2 Seagate 2Tb+ 1 WD 2Tb) - / - Asus TUF Gaming FX705GE - i7 8750H - RAM 16 Gb - / - Asus K55VD i7 3610QM RAM 8Gb.

Avatar utente
Janvitus
Amministratore
Amministratore
Messaggi: 18103
Iscrizione: lunedì 25 aprile 2005, 15:52
Desktop: GNOME Shell / Xfce
Sesso: Maschile
Località: Potenza
Contatti:

Re: Al click del mouse su una riga dell'indice il testo scorre di un step verso l'alto

Messaggio da Janvitus » mercoledì 20 maggio 2020, 19:06

Non riscontro questo problema, forse è un'estensione del browser o altro. Prova con un browser nativo, Epiphany su usi gnome, falkon se usi kde.
+Fedora 32 • +Xubuntu 20.04

Avatar utente
et4beta
Rampante Reduce
Rampante Reduce
Messaggi: 7519
Iscrizione: mercoledì 9 gennaio 2008, 10:15
Desktop: Gnome
Distribuzione: 18.04-20.04-20.10 (NO UEFI)
Località: Ancona

Re: Al click del mouse su una riga dell'indice il testo scorre di un step verso l'alto

Messaggio da et4beta » mercoledì 20 maggio 2020, 20:51

Fatto un po' di prove ed il problema si è "ristretto".
Purtroppo non ricordo con quale versione di Ubuntu avessi fatto le prove precedenti, mentre quelle fatte poco fa erano, oltre che in Windows 10, nella 20.04.
In Windows il problema è legato a Firefox perché con Edge(che però uso molto raramente non lo fa).
In Ubuntu 20.04 con Firefox non sono per ora riuscito a riprodurre il difetto, ho provato anche con Epiphany Browser e nessun problema neanche con quello.

Nota OT: non so se fosse un momento particolare ma ho avuto l'impressione che con Epiphany nel forum di Ubuntu la navigazione fosse molto più fluida che con Firefox. Però è da prendere come un'impressione tratta da prove molto veloci, quindi con il modesto valore che ne deriva.

Edit:
Riprovato con Firefox su Ubuntu 20.04 ed ora il problema si presenta identico a come è su Firefox con Win.
Con Epiphany invece nulla. Almeno per ora.
Se non sopravvengono altre "sorprese" sembrerebbe legato a al browser Firefox.
Linux User #485103 - Ubuntu User #38220 - Desktop: MoBo Asus X99-A - Intel i7 5820K - RAM G.Skill Ripjaws V DDR4 32 Gb - GPU Asus STRIX Nvidia GTX 970 - Monitor Asus MG278Q - SSD Samsung 970 EVO Plus M.2 PCIe NVMe 500 Gb - SSD Samsung 850 EVO 500 Gb + 3 HDD (2 Seagate 2Tb+ 1 WD 2Tb) - / - Asus TUF Gaming FX705GE - i7 8750H - RAM 16 Gb - / - Asus K55VD i7 3610QM RAM 8Gb.

Avatar utente
Janvitus
Amministratore
Amministratore
Messaggi: 18103
Iscrizione: lunedì 25 aprile 2005, 15:52
Desktop: GNOME Shell / Xfce
Sesso: Maschile
Località: Potenza
Contatti:

Re: Al click del mouse su una riga dell'indice il testo scorre di un step verso l'alto

Messaggio da Janvitus » giovedì 21 maggio 2020, 10:14

Lo uso pure io Firefox e non riscontro questo problema... Come detto, è probabile che sia qualcosa che ci aggiungi, estensioni, opzioni, script...
+Fedora 32 • +Xubuntu 20.04

Avatar utente
et4beta
Rampante Reduce
Rampante Reduce
Messaggi: 7519
Iscrizione: mercoledì 9 gennaio 2008, 10:15
Desktop: Gnome
Distribuzione: 18.04-20.04-20.10 (NO UEFI)
Località: Ancona

Re: Al click del mouse su una riga dell'indice il testo scorre di un step verso l'alto

Messaggio da et4beta » giovedì 21 maggio 2020, 13:07

Bene potrebbe essere un passo in avanti per capire.
Ora debbo fare un attento controllo incrociato tra il Firefox in Win e quello in Ubuntu 20.04, che non hanno installati precisamente gli stessi componenti aggiuntivi, e vedere se salta fuori il "colpevole".
Mi da un po' di pensiero il fatto che inizialmente non riuscivo a riprodurre il problema con Ubuntu, nonostante avessi provato e riprovato ripetutamente, poi senza nulla fare è comparso, e questo depone per una certa incostanza .... la peggiore delle cose.
Sto pensando all'ADBlocker, che però tengo disattivato per la navigazione sul sito di Ubuntu, ma è un'estensione talmente diffusa che trovo improbabile possa dare problemi solo a me. Anche se, ripeto, è un difetto "subdolo" a cui si rischia di non fare caso avendoci fatto l'abitudine, dato che in fin dei conti può passare per una cliccata con la mira sbagliata.
Fatte le prove faccio sapere.
Linux User #485103 - Ubuntu User #38220 - Desktop: MoBo Asus X99-A - Intel i7 5820K - RAM G.Skill Ripjaws V DDR4 32 Gb - GPU Asus STRIX Nvidia GTX 970 - Monitor Asus MG278Q - SSD Samsung 970 EVO Plus M.2 PCIe NVMe 500 Gb - SSD Samsung 850 EVO 500 Gb + 3 HDD (2 Seagate 2Tb+ 1 WD 2Tb) - / - Asus TUF Gaming FX705GE - i7 8750H - RAM 16 Gb - / - Asus K55VD i7 3610QM RAM 8Gb.

Avatar utente
et4beta
Rampante Reduce
Rampante Reduce
Messaggi: 7519
Iscrizione: mercoledì 9 gennaio 2008, 10:15
Desktop: Gnome
Distribuzione: 18.04-20.04-20.10 (NO UEFI)
Località: Ancona

Re: [Risolto]-Al click del mouse su una riga dell'indice il testo scorre di uno step verso l'alto

Messaggio da et4beta » giovedì 21 maggio 2020, 17:51

Faccio un nuovo post perché mettere la soluzione in "edit" non avrebbe visibilità.

Ho risolto.
La colpevole del lieve "malfunzionamento" è l'estensione "ImTranslator"(traduttore). Ottima estensione ed anche molto utile ma crea questo problema. Perché lo faccia solo navigando nel forum di Ubuntu(almeno a me lo fa solo qui) proprio non lo so.
Ho fatto, come preannunciato, una ricerca incrociata tra Firefox in Windows 10 e Ubuntu 20.04 e disattivando una alla volta le estensioni sia nell'uno che nell'altro il "problema" scompare quando viene disattivato ImTranslator. È sufficiente disattivarlo per avere la scomparsa dell'inconveniente, mentre riattivandolo la ricomparsa di questo non è sempre immediata.
Ripeto come fare per riprodurre quanto da me "lamentato": bisogna entrare nel forum di Ubuntu e poi in una sezione(non ho pensato a provare se lo fa anche sull'indice generale), cliccare su un titolo per visualizzarne la discussione, uscire da questa cliccando sulla freccia a sx(pagina indietro) della barra del menu di Firefox, fare il refresh della pagina dell'indice a cui si è tornati con la precedente manovra e poi, non appena avvenuto il refresh, puntare e cliccare un titolo a caso per visualizzare la discussione. Al click tutta la pagina fa uno step(una riga) verso l'alto e la cliccata non ha altro effetto, per cui bisogna ripuntare il titolo e cliccare nuovamente su di esso e questa volta va tutto ok.
Alla fine è una sciocchezza ma un po' fastidiosa.
Linux User #485103 - Ubuntu User #38220 - Desktop: MoBo Asus X99-A - Intel i7 5820K - RAM G.Skill Ripjaws V DDR4 32 Gb - GPU Asus STRIX Nvidia GTX 970 - Monitor Asus MG278Q - SSD Samsung 970 EVO Plus M.2 PCIe NVMe 500 Gb - SSD Samsung 850 EVO 500 Gb + 3 HDD (2 Seagate 2Tb+ 1 WD 2Tb) - / - Asus TUF Gaming FX705GE - i7 8750H - RAM 16 Gb - / - Asus K55VD i7 3610QM RAM 8Gb.

Scrivi risposta

Ritorna a “Gruppo Forum”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 1 ospite