Android - Problema API

Linguaggi di programmazione: php, perl, python, C, bash e tutti gli altri.
daveBuc
Prode Principiante
Messaggi: 17
Iscrizione: mercoledì 4 marzo 2020, 9:47
Desktop: Ubuntu
Distribuzione: 18.04
Sesso: Maschile

Android - Problema API

Messaggio da daveBuc » lunedì 9 marzo 2020, 18:13

Ciao a tutti, spero che qualcuno possa darmi una mano. Sto scrivendo una app di navigazione, usando le api di google e di tomtom. Quando mando in running l'app scrivendola secondo le modalità delle API di google developer non ho nessun problema, ma quando "converto" tutto nella versione tomtom, secondo questo link: https://developer.tomtom.com/maps-sdk-a ... aps-tomtom e mando in esecuzione ottengo questo errore:

Build Failed:
Invoke-customs are only supported starting with Android O (--min-api 26)
Static interface methods are only supported starting with Android N (--min-api 24):
java.lang.Objectcom.tomtom.online.sdk.common.functional.CheckedFunction1.$deserializeLambda$(java.lang.invoke.SerializedLambda)
Compatible side by side NDK version was not found. Default is 20.0.5594570.

Io ho creato una AVD con API 30, ma di default me le ha impostate lui, quindi non saprei eventualmente come modificarle.

Qualcuno potrebbe darmi una mano?

Grazie
Ultima modifica di daveBuc il lunedì 9 marzo 2020, 19:41, modificato 1 volta in totale.

Avatar utente
giulux
Amministratore
Amministratore
Messaggi: 23945
Iscrizione: domenica 10 gennaio 2010, 12:17
Desktop: ubuntu 18.04
Distribuzione: Ubuntu 18.04.3 LTS x86_64
Sesso: Maschile
Località: Roma

Re: Android

Messaggio da giulux » lunedì 9 marzo 2020, 18:44

Metti un titolo meno generico, che faccia capire il problema.
Grazie.
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...

Scrivi risposta

Ritorna a “Programmazione”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 3 ospiti