Consentire solo il traffico locale sulla porta di CUPS

Sicurezza del sistema: firewall, antispam, antivirus, ssh, patch, bug, ecc.

Consentire solo il traffico locale sulla porta di CUPS

Messaggioda Ghepus » lunedì 8 ottobre 2018, 14:44

Vorrei impostare una regola di iptables che consenta di accedere al server di CUPS al computer locale.
Non so come fare. Mi date una mano?
Grazie.
:ciao:
Ultima modifica di giulux il lunedì 8 ottobre 2018, 18:03, modificato 1 volta in totale.
Motivazione: corretto titolo
Ghepus
Prode Principiante
 
Messaggi: 137
Iscrizione: dicembre 2017

Re: Consentire solo il traffico locale sulla pora di CUPS

Messaggioda pachisapiu » lunedì 8 ottobre 2018, 15:08

basta che nelle proprietà della stampante non abiliti la condivisione
Avatar utente
pachisapiu
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2337
Iscrizione: maggio 2017
Distribuzione: FreeDOS

Re: Consentire solo il traffico locale sulla pora di CUPS

Messaggioda Pike » lunedì 8 ottobre 2018, 15:39

Ghepus Immagine ha scritto:Vorrei impostare una regola di iptables che consenta di accedere al server di CUPS al computer locale.
Non so come fare. Mi date una mano?
Grazie.
:ciao:

Destkop o server?
Incivile e maleducato. Come certificato dalla moderazione. You have been warned. Pigroidiorazione. Non fallisce MAI. Specialmente nel considerare offensivi solo certi contenuti.
Se pensi che il tuo tempo sia più importante del mio, significa che non hai bisogno del mio tempo.
Pike
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3452
Iscrizione: gennaio 2008
Desktop: xubuntu
Distribuzione: Bionic Beaver i686 (18.04)

Re: Consentire solo il traffico locale sulla pora di CUPS

Messaggioda Ghepus » lunedì 8 ottobre 2018, 16:31

Pike Immagine ha scritto:
Ghepus Immagine ha scritto:Vorrei impostare una regola di iptables che consenta di accedere al server di CUPS al computer locale.
Non so come fare. Mi date una mano?
Grazie.
:ciao:

Destkop o server?


Desktop.
:ciao:
Ultima modifica di Ghepus il lunedì 8 ottobre 2018, 16:33, modificato 1 volta in totale.
Ghepus
Prode Principiante
 
Messaggi: 137
Iscrizione: dicembre 2017

Re: Consentire solo il traffico locale sulla pora di CUPS

Messaggioda DoctorStrange » lunedì 8 ottobre 2018, 16:31

Vuoi abilitare il traffico entrante su localhost, proveniente dalla porta 631?
Avatar utente
DoctorStrange
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1473
Iscrizione: ottobre 2015
Località: Roma, Italia
Desktop: Unity
Distribuzione: Ubuntu 16.04.03 Xenial Xerus
Sesso: Maschile

Re: Consentire solo il traffico locale sulla pora di CUPS

Messaggioda Ghepus » lunedì 8 ottobre 2018, 16:32

pachisapiu Immagine ha scritto:basta che nelle proprietà della stampante non abiliti la condivisione


E' collegata direttamente via USB ed impostazioni di condivisione non ne trovo nel menù.
Altri suggerimenti?
:ciao:
Ghepus
Prode Principiante
 
Messaggi: 137
Iscrizione: dicembre 2017

Re: Consentire solo il traffico locale sulla pora di CUPS

Messaggioda Ghepus » lunedì 8 ottobre 2018, 16:33

DoctorStrange Immagine ha scritto:Vuoi abilitare il traffico entrante su localhost, proveniente dalla porta 631?


E viceversa.
:ciao:
Ghepus
Prode Principiante
 
Messaggi: 137
Iscrizione: dicembre 2017

Re: Consentire solo il traffico locale sulla pora di CUPS

Messaggioda pachisapiu » lunedì 8 ottobre 2018, 16:37

Ghepus Immagine ha scritto:
pachisapiu Immagine ha scritto:basta che nelle proprietà della stampante non abiliti la condivisione


E' collegata direttamente via USB ed impostazioni di condivisione non ne trovo nel menù.
Altri suggerimenti?
:ciao:

Impostazioni di stampa → clicchi col destro sulla stampante configurata → proprietà → regole
Avatar utente
pachisapiu
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2337
Iscrizione: maggio 2017
Distribuzione: FreeDOS

Re: Consentire solo il traffico locale sulla pora di CUPS

Messaggioda DoctorStrange » lunedì 8 ottobre 2018, 16:41

Io comincerei così:
Codice: Seleziona tutto
sudo iptables -A INPUT --dport 631 --jump ACCEPT && sudo iptables -A OUTPUT --sport 631 --jump ACCEPT
.

Se funziona tutto regolarmente, la rendi persistente, altrimenti le elimini.
Avatar utente
DoctorStrange
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1473
Iscrizione: ottobre 2015
Località: Roma, Italia
Desktop: Unity
Distribuzione: Ubuntu 16.04.03 Xenial Xerus
Sesso: Maschile

Re: Consentire solo il traffico locale sulla pora di CUPS

Messaggioda Pike » lunedì 8 ottobre 2018, 16:49

Si può usare gufw per scrivere la regola.
Incivile e maleducato. Come certificato dalla moderazione. You have been warned. Pigroidiorazione. Non fallisce MAI. Specialmente nel considerare offensivi solo certi contenuti.
Se pensi che il tuo tempo sia più importante del mio, significa che non hai bisogno del mio tempo.
Pike
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3452
Iscrizione: gennaio 2008
Desktop: xubuntu
Distribuzione: Bionic Beaver i686 (18.04)

Re: Consentire solo il traffico locale sulla pora di CUPS

Messaggioda DoctorStrange » lunedì 8 ottobre 2018, 16:53

Resta sempre il fatto però che in quel modo apri solo la porta, poi ci deve essere il demone cups attivo ed in ascolto proprio su quella porta, altrimenti ti comparirà sempre chiusa se non c'è alcun servizio server in ascolto su quella porta. Assicurati quindi che i files di configurazione di cups stesso siano impostati di conseguenza.
Avatar utente
DoctorStrange
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1473
Iscrizione: ottobre 2015
Località: Roma, Italia
Desktop: Unity
Distribuzione: Ubuntu 16.04.03 Xenial Xerus
Sesso: Maschile

Re: Consentire solo il traffico locale sulla pora di CUPS

Messaggioda pachisapiu » lunedì 8 ottobre 2018, 16:58

Ma che senso ha aprire una porta quando di default su ubuntu sono già tutte aperte
Avatar utente
pachisapiu
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2337
Iscrizione: maggio 2017
Distribuzione: FreeDOS

Re: Consentire solo il traffico locale sulla pora di CUPS

Messaggioda DoctorStrange » lunedì 8 ottobre 2018, 17:58

Vediamo come è impostato questo particolare firewall. A me sembra di aver capito che il nostro amico voglia trafficare con le porte. Almeno a leggere quanto scritto.
Avatar utente
DoctorStrange
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1473
Iscrizione: ottobre 2015
Località: Roma, Italia
Desktop: Unity
Distribuzione: Ubuntu 16.04.03 Xenial Xerus
Sesso: Maschile

Re: Consentire solo il traffico locale sulla pora di CUPS

Messaggioda Ghepus » martedì 9 ottobre 2018, 10:37

DoctorStrange Immagine ha scritto:Vediamo come è impostato questo particolare firewall. A me sembra di aver capito che il nostro amico voglia trafficare con le porte. Almeno a leggere quanto scritto.


"Nessun traffico". :D Al contratio vorrei chiudere questa porta a tutti tranne che al desktop locale. Forse la regola suggerita non è quella che mi aspettavo, anche perché non l'ho ben capita.
:ciao:
Ghepus
Prode Principiante
 
Messaggi: 137
Iscrizione: dicembre 2017

Re: Consentire solo il traffico locale sulla porta di CUPS

Messaggioda pachisapiu » martedì 9 ottobre 2018, 10:41

@ ghepus : posta
Codice: Seleziona tutto
sudo iptables -S


PS : La soluzione stampante non condivisa non ti piace proprio eh ?
Avatar utente
pachisapiu
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2337
Iscrizione: maggio 2017
Distribuzione: FreeDOS

Re: Consentire solo il traffico locale sulla porta di CUPS

Messaggioda Ghepus » martedì 9 ottobre 2018, 10:50

pachisapiu Immagine ha scritto:@ ghepus : posta
Codice: Seleziona tutto
sudo iptables -S


PS : La soluzione stampante non condivisa non ti piace proprio eh ?


Al contrario, l'impostazione l'ho applicata. Poi avere conoscenza di un altro metodo non mi dispiace.
:ciao:
Ghepus
Prode Principiante
 
Messaggi: 137
Iscrizione: dicembre 2017

Re: Consentire solo il traffico locale sulla porta di CUPS

Messaggioda pachisapiu » martedì 9 ottobre 2018, 10:53

allora aspettiamo che posti l'output richiesto per capire da dove si parte
Avatar utente
pachisapiu
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2337
Iscrizione: maggio 2017
Distribuzione: FreeDOS

Re: Consentire solo il traffico locale sulla pora di CUPS

Messaggioda Ghepus » martedì 9 ottobre 2018, 10:54

DoctorStrange Immagine ha scritto:Io comincerei così:
Codice: Seleziona tutto
sudo iptables -A INPUT --dport 631 --jump ACCEPT && sudo iptables -A OUTPUT --sport 631 --jump ACCEPT
.

Se funziona tutto regolarmente, la rendi persistente, altrimenti le elimini.


In ogni caso la regola sembra avere qualche problema:
Codice: Seleziona tutto
ubuntu@ubuntu:~$ sudo iptables -A INPUT --dport 631 --jump ACCEPT && sudo iptables -A OUTPUT --sport 631 --jump ACCEPT
iptables v1.6.1: unknown option "--dport"
Try `iptables -h' or 'iptables --help' for more information.
ubuntu@ubuntu:~$ sudo iptables -A INPUT --dports 631 --jump ACCEPT && sudo iptables -A OUTPUT --sport 631 --jump ACCEPT
iptables v1.6.1: unknown option "--dports"
Try `iptables -h' or 'iptables --help' for more information.
ubuntu@ubuntu:~$ sudo iptables -A INPUT --dports 631 --jump ACCEPT && sudo iptables -A OUTPUT --sports 631 --jump ACCEPT
iptables v1.6.1: unknown option "--dports"
Try `iptables -h' or 'iptables --help' for more information.
ubuntu@ubuntu:~$

:ciao:
Ghepus
Prode Principiante
 
Messaggi: 137
Iscrizione: dicembre 2017

Re: Consentire solo il traffico locale sulla porta di CUPS

Messaggioda pachisapiu » martedì 9 ottobre 2018, 11:01

Mi riferivo a questo ...

pachisapiu Immagine ha scritto:@ ghepus : posta
Codice: Seleziona tutto
sudo iptables -S

Avatar utente
pachisapiu
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2337
Iscrizione: maggio 2017
Distribuzione: FreeDOS

Re: Consentire solo il traffico locale sulla pora di CUPS

Messaggioda DoctorStrange » martedì 9 ottobre 2018, 11:18

Forse è il caso che prima di tentare di inserire una nuova regola posti realmente l'attuale stato del tuo firewall. Posta il risultato del comando che ti ha sugerito @pachisapiu .

Comunque riconosco che il comando che ti ho dato ha un errore. non è --dport ma -dport (un solo simbolo trattino, nopn due). Stessa cosa per -sport.
Avatar utente
DoctorStrange
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1473
Iscrizione: ottobre 2015
Località: Roma, Italia
Desktop: Unity
Distribuzione: Ubuntu 16.04.03 Xenial Xerus
Sesso: Maschile

Successiva

Torna a Sicurezza

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 4 ospiti