Inserire il plugin Python in kate

Configurazione e uso delle applicazioni del desktop manager predefinito di Kubuntu.

Inserire il plugin Python in kate

Messaggioda venti » martedì 23 ottobre 2018, 6:18

Ciao a tutti,

come da titolo, vorrei inserire il plugin python in kate, ho seguito delle guide in inglese, ma nulla di fatto.
In Impostazioni/configura kate, Applicazioni/Estensioni, non mi appare la voce python plugin.

Idee?

Grazie
Avatar utente
venti
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 870
Iscrizione: gennaio 2008
Località: Modena
Desktop: KDE plasma
Distribuzione: Kubuntu, Kde Neon
Sesso: Maschile

Re: Inserire il plugin Python in kate

Messaggioda wilecoyote » martedì 23 ottobre 2018, 14:58

:) Salve, cercato nel posto sbagliato.

Dal menù Strumenti → Evidenziazione → Script → spunta Python , colonna destra in alto.

:ciao: Ciao
ACER Extensa 5230E 2,2 Ghz cpu Celeron 900 hdd 160 GB Ram 1GB scheda video Intel GM500
ACER Extensa 5635Z 2,2 Ghz cpu Celeron T3100 hdd 320 GB Ram 4 GB scheda video Intel Mobile 4
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
wilecoyote
Rampante Reduce
Rampante Reduce
 
Messaggi: 9187
Iscrizione: agosto 2009
Località: Ceranesi - Ge
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14/16/18.04 LTS 64bit
Sesso: Maschile

Re: Inserire il plugin Python in kate

Messaggioda venti » mercoledì 31 ottobre 2018, 21:29

Scusa forse non hai capito...

Ti ho scritto il percorso dove in kate andare ad abilitare il plugin: te lo riscrivo "Impostazioni/configura kate, Applicazioni/Estensioni".

Non mi interessa evidenziare il colore.

E poi non un problema di programmazione, ma di kate/kde
Ultima modifica di venti il giovedì 1 novembre 2018, 15:16, modificato 1 volta in totale.
Avatar utente
venti
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 870
Iscrizione: gennaio 2008
Località: Modena
Desktop: KDE plasma
Distribuzione: Kubuntu, Kde Neon
Sesso: Maschile

Re: Inserire il plugin Python in kate

Messaggioda wilecoyote » giovedì 1 novembre 2018, 14:39

:) Salve, allora intendi forse questo https://pypi.org/project/Kate-plugins/ ?

:ciao: Ciao
ACER Extensa 5230E 2,2 Ghz cpu Celeron 900 hdd 160 GB Ram 1GB scheda video Intel GM500
ACER Extensa 5635Z 2,2 Ghz cpu Celeron T3100 hdd 320 GB Ram 4 GB scheda video Intel Mobile 4
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
wilecoyote
Rampante Reduce
Rampante Reduce
 
Messaggi: 9187
Iscrizione: agosto 2009
Località: Ceranesi - Ge
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14/16/18.04 LTS 64bit
Sesso: Maschile

Re: Inserire il plugin Python in kate

Messaggioda venti » giovedì 1 novembre 2018, 14:59

Ho già seguito questo sito, ma il risultato è stato un errore
Visto che lo uso solo per python3.6, difatti non va bene per python3, ma solo per la 2

Screenshot_20181101_145733.png
Screenshot
Avatar utente
venti
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 870
Iscrizione: gennaio 2008
Località: Modena
Desktop: KDE plasma
Distribuzione: Kubuntu, Kde Neon
Sesso: Maschile

Re: Inserire il plugin Python in kate

Messaggioda wilecoyote » giovedì 1 novembre 2018, 15:07

:) Salve, dovresti postare l'intero output per poter far capire l'errore.

Provato adesso l'installazione, con successo:

Installing collected packages: setuptools, pep8, pyflakes, pyjslint, pyplete, pysmell, simplejson, Kate-plugins
Running setup.py install for pep8 ... done
Running setup.py install for pyflakes ... done
Running setup.py install for pyjslint ... done
Running setup.py install for pyplete ... done
Running setup.py install for pysmell ... done
Running setup.py install for simplejson ... done
Running setup.py install for Kate-plugins ... done
Successfully installed Kate-plugins-0.2.3 pep8-0.6.1 pyflakes-0.5.0 pyjslint-0.3.3 pyplete-0.0.2 pysmell-0.7.3 setuptools-40.5.0 simplejson-2.6.1


wilecoyote@GhostCreek:~$ pip install Kate-plugins
Collecting Kate-plugins
Using cached https://files.pythonhosted.org/packages ... 2.3.tar.gz
Collecting pep8==0.6.1 (from Kate-plugins)
Using cached https://files.pythonhosted.org/packages ... 6.1.tar.gz
Collecting pyflakes==0.5.0 (from Kate-plugins)
Using cached https://files.pythonhosted.org/packages ... 5.0.tar.gz
Collecting pyjslint==0.3.3 (from Kate-plugins)
Using cached https://files.pythonhosted.org/packages ... 3.3.tar.gz
Collecting pyplete==0.0.2 (from Kate-plugins)
Using cached https://files.pythonhosted.org/packages ... 0.2.tar.gz
Collecting pysmell==0.7.3 (from Kate-plugins)
Using cached https://files.pythonhosted.org/packages ... -0.7.3.zip
Collecting simplejson==2.6.1 (from Kate-plugins)
Using cached https://files.pythonhosted.org/packages ... 6.1.tar.gz
Collecting setuptools (from pep8==0.6.1->Kate-plugins)
Using cached https://files.pythonhosted.org/packages ... ne-any.whl
Building wheels for collected packages: Kate-plugins, pep8, pyflakes, pyjslint, pyplete, pysmell, simplejson
Running setup.py bdist_wheel for Kate-plugins ... error
Complete output from command /usr/bin/python -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-MNvqMW/Kate-plugins/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/tmpzcLZfepip-wheel- --python-tag cp27:
usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
or: -c --help [cmd1 cmd2 ...]
or: -c --help-commands
or: -c cmd --help

error: invalid command 'bdist_wheel'

----------------------------------------
Failed building wheel for Kate-plugins
Running setup.py clean for Kate-plugins
Running setup.py bdist_wheel for pep8 ... error
Complete output from command /usr/bin/python -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-MNvqMW/pep8/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/tmpaYG02fpip-wheel- --python-tag cp27:
usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
or: -c --help [cmd1 cmd2 ...]
or: -c --help-commands
or: -c cmd --help

error: invalid command 'bdist_wheel'

----------------------------------------
Failed building wheel for pep8
Running setup.py clean for pep8
Running setup.py bdist_wheel for pyflakes ... error
Complete output from command /usr/bin/python -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-MNvqMW/pyflakes/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/tmpgqibnvpip-wheel- --python-tag cp27:
usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
or: -c --help [cmd1 cmd2 ...]
or: -c --help-commands
or: -c cmd --help

error: invalid command 'bdist_wheel'

----------------------------------------
Failed building wheel for pyflakes
Running setup.py clean for pyflakes
Running setup.py bdist_wheel for pyjslint ... error
Complete output from command /usr/bin/python -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-MNvqMW/pyjslint/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/tmpmjMjaTpip-wheel- --python-tag cp27:
usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
or: -c --help [cmd1 cmd2 ...]
or: -c --help-commands
or: -c cmd --help

error: invalid command 'bdist_wheel'

----------------------------------------
Failed building wheel for pyjslint
Running setup.py clean for pyjslint
Running setup.py bdist_wheel for pyplete ... error
Complete output from command /usr/bin/python -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-MNvqMW/pyplete/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/tmp0mQQz6pip-wheel- --python-tag cp27:
usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
or: -c --help [cmd1 cmd2 ...]
or: -c --help-commands
or: -c cmd --help

error: invalid command 'bdist_wheel'

----------------------------------------
Failed building wheel for pyplete
Running setup.py clean for pyplete
Running setup.py bdist_wheel for pysmell ... error
Complete output from command /usr/bin/python -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-MNvqMW/pysmell/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/tmpDr75fNpip-wheel- --python-tag cp27:
usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
or: -c --help [cmd1 cmd2 ...]
or: -c --help-commands
or: -c cmd --help

error: invalid command 'bdist_wheel'

----------------------------------------
Failed building wheel for pysmell
Running setup.py clean for pysmell
Running setup.py bdist_wheel for simplejson ... error
Complete output from command /usr/bin/python -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-MNvqMW/simplejson/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/tmpCrAuSVpip-wheel- --python-tag cp27:
usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
or: -c --help [cmd1 cmd2 ...]
or: -c --help-commands
or: -c cmd --help

error: invalid command 'bdist_wheel'

----------------------------------------
Failed building wheel for simplejson
Running setup.py clean for simplejson
Failed to build Kate-plugins pep8 pyflakes pyjslint pyplete pysmell simplejson
Installing collected packages: setuptools, pep8, pyflakes, pyjslint, pyplete, pysmell, simplejson, Kate-plugins
Running setup.py install for pep8 ... done
Running setup.py install for pyflakes ... done
Running setup.py install for pyjslint ... done
Running setup.py install for pyplete ... done
Running setup.py install for pysmell ... done
Running setup.py install for simplejson ... done
Running setup.py install for Kate-plugins ... done
Successfully installed Kate-plugins-0.2.3 pep8-0.6.1 pyflakes-0.5.0 pyjslint-0.3.3 pyplete-0.0.2 pysmell-0.7.3 setuptools-40.5.0 simplejson-2.6.1


Spoilerizzo l'output completo a causa della sua lunghezza.

In pratica c'è sì un errore riguardante pip-wheel, però non inficia l'installazione dei plugin.

:ciao: Ciao
ACER Extensa 5230E 2,2 Ghz cpu Celeron 900 hdd 160 GB Ram 1GB scheda video Intel GM500
ACER Extensa 5635Z 2,2 Ghz cpu Celeron T3100 hdd 320 GB Ram 4 GB scheda video Intel Mobile 4
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
wilecoyote
Rampante Reduce
Rampante Reduce
 
Messaggi: 9187
Iscrizione: agosto 2009
Località: Ceranesi - Ge
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14/16/18.04 LTS 64bit
Sesso: Maschile

Re: Inserire il plugin Python in kate

Messaggioda venti » giovedì 1 novembre 2018, 15:09

Screenshot_20181101_151049.png
output


...con pip certamente che funziona, non con pip3 install

Quindi mi sa che con python3, non si riesce
Avatar utente
venti
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 870
Iscrizione: gennaio 2008
Località: Modena
Desktop: KDE plasma
Distribuzione: Kubuntu, Kde Neon
Sesso: Maschile

Re: Inserire il plugin Python in kate

Messaggioda wilecoyote » giovedì 1 novembre 2018, 15:20

:) Salve, ah già, c'è anche pip3… :shy:

Considerando che i plugin sono aggiornati al 2013, ha anche una sua logica che non girino col Python 3… :sisi:

Bisogna accontentarsi del 2.

:ciao: Ciao
ACER Extensa 5230E 2,2 Ghz cpu Celeron 900 hdd 160 GB Ram 1GB scheda video Intel GM500
ACER Extensa 5635Z 2,2 Ghz cpu Celeron T3100 hdd 320 GB Ram 4 GB scheda video Intel Mobile 4
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
wilecoyote
Rampante Reduce
Rampante Reduce
 
Messaggi: 9187
Iscrizione: agosto 2009
Località: Ceranesi - Ge
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14/16/18.04 LTS 64bit
Sesso: Maschile

Re: Inserire il plugin Python in kate

Messaggioda venti » giovedì 1 novembre 2018, 15:26

Bene...ripiego su Atom, anche se non volevo farlo.
Ciao e grazie
Avatar utente
venti
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 870
Iscrizione: gennaio 2008
Località: Modena
Desktop: KDE plasma
Distribuzione: Kubuntu, Kde Neon
Sesso: Maschile


Torna a KDE

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 3 ospiti