[Risolto] problemi con doppio schermo

Configurazione e uso delle applicazioni del desktop manager predefinito di Kubuntu.
axr
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1634
Iscrizione: sabato 1 aprile 2006, 16:10
Distribuzione: kubuntu 18.04

[Risolto ] problemi con doppio schermo

Messaggio da axr » martedì 31 dicembre 2019, 9:37

Ciao intanto ti anticipo che con kubuntu 19.10 va tutto perfetto, con la 18.04.1 ho lo stesso problema. Ho fatto delle prove con le live
Ultima modifica di axr il mercoledì 8 gennaio 2020, 10:48, modificato 1 volta in totale.

axr
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1634
Iscrizione: sabato 1 aprile 2006, 16:10
Distribuzione: kubuntu 18.04

Re: problemi con doppio schermo

Messaggio da axr » martedì 31 dicembre 2019, 9:54

allora, per kubuntu allego due risultati, uno con solo il 27 alla massima risoluzione e un altro con i due schermi collegati ma con il 27 abbassato a 1920x1080 altrimenti non mi vedeva il secondo monitor.
Arch e Opensuse, entrambi i test fatti con i due monitor collegati e il 27 alla massima risoluzione. di xorg.conf nessuna traccia

Codice: Seleziona tutto

Screen 0: minimum 320 x 200, current 2560 x 1440, maximum 8192 x 8192
VGA-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-1 connected primary 2560x1440+0+0 (normal left inverted right x axis y axis) 597mm x 336mm
   2560x1440     59.95*+
   1920x1080     60.00    60.00    50.00    59.94  
   1680x1050     59.95  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1280x800      59.81  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    60.00  
   832x624       74.55  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    60.00    59.94  
   720x400       70.08  

Codice: Seleziona tutto

Screen 0: minimum 320 x 200, current 3839 x 1080, maximum 8192 x 8192
VGA-1 connected 1920x1080+1919+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080     60.00*+
   1600x1200     60.00  
   1680x1050     59.95  
   1280x1024     75.02    60.02  
   1440x900      74.98    59.89  
   1280x960      60.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   640x480       75.00    72.81    66.67    59.94  
   720x400       70.08  
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 597mm x 336mm
   2560x1440     59.95 +
   1920x1080     60.00*   60.00    50.00    59.94  
   1680x1050     59.95  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1280x800      59.81  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    60.00  
   832x624       74.55  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    60.00    59.94  
   720x400       70.08  
Archlinux

Codice: Seleziona tutto

Screen 0: minimum 8 x 8, current 4479 x 1440, maximum 32767 x 32767
DP1 connected primary 2560x1440+0+0 (normal left inverted right x axis y axis) 600mm x 340mm
   2560x1440     59.95*+
   1920x1080     60.00    60.00    50.00    59.94  
   1680x1050     59.95  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1280x800      59.81  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    60.00  
   832x624       74.55  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    60.00    59.94  
   720x400       70.08  
HDMI1 disconnected (normal left inverted right x axis y axis)
VGA1 connected 1920x1080+2559+0 (normal left inverted right x axis y axis) 480mm x 270mm
   1920x1080     60.00*+
   1600x1200     60.00  
   1680x1050     59.95  
   1280x1024     75.02    60.02  
   1440x900      74.98    59.89  
   1280x960      60.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   640x480       75.00    72.81    66.67    59.94  
   720x400       70.08  
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
Opensuse

Codice: Seleziona tutto

Screen 0: minimum 320 x 200, current 4480 x 1440, maximum 8192 x 8192
VGA-1 connected 1920x1080+2560+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080     60.00*+
   1600x1200     60.00  
   1680x1050     59.95  
   1280x1024     75.02    60.02  
   1440x900      74.98    59.89  
   1280x960      60.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   640x480       75.00    72.81    66.67    59.94  
   720x400       70.08  
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-1 connected primary 2560x1440+0+0 (normal left inverted right x axis y axis) 597mm x 336mm
   2560x1440     59.95*+
   1920x1080     60.00    60.00    50.00    59.94  
   1680x1050     59.95  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1280x800      59.81  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    60.00  
   832x624       74.55  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    60.00    59.94  
   720x400       70.08  
Ancora grazie per il tuo aiuto

andrea111
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1667
Iscrizione: mercoledì 7 novembre 2007, 4:18

Re: problemi con doppio schermo

Messaggio da andrea111 » martedì 31 dicembre 2019, 17:40

axr [url=https://forum.ubuntu-it.org/viewtopic.php?p=5169754#p5169754][img]https://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:Ciao intanto ti anticipo che con kubuntu 19.10 va tutto perfetto, con la 18.04.1 ho lo stesso problema. Ho fatto delle prove con le live
Prova a vedere la versione di plasma in 19.10 e 18.04, se sono diverse aveva ragione woddy68. Sono i miglioramenti di plasma apportati con l'ultima versione.

Ad aprile di quest'anno (anticipiamo i tempi di un giorno visto che, oggi, siamo ancora nel 2019) uscirà la 20.04 che è una LTS - la 19.10 viene supportata per solo 6 mesi. Che vuoi fare? aspetti che esca o vuoi tentare ancora di sistemare la 18.04.

Dal confronto degli xrandr che hai postato (interessano solo le prime tre righe iniziali) le dimensioni dei monitor sono corrette ma emergono le difficoltà per kubuntu ad intercettare correttamente il secondo monitor (però riesce a farlo solo per la risoluzione 1980x1080).

Hai provato a far scrivere al sistema uno xorg.conf?
Bisogna passare alla consolle (Ctrl+Alt+F1) arrestare il display manager (per kde mi pare sddm)

Codice: Seleziona tutto

sudo service sddm stop
poi dare

Codice: Seleziona tutto

sudo X -configure
che scrive un file xorg.conf-new nella tua home. Provare a dare un'occhiata su come è fatto questo file.
Dalla consolle, per tornare al desktop, dovrai dare

Codice: Seleziona tutto

sudo service sddm start
Altra prova: file ~/.config/monitors.xml
lì c'è scritto come il sistema "vede" i monitor connessi - c'è chi ha risolto semplicemente cancellando (rinominando) quel file e riavviando - al riavvio (con entrambe i monitor connessi) il sistema ne riscrive uno nuovo.

Si potrebbe anche confrontare il contenuto di quel file fra le varie distro (es. kubuntu e arch).

axr
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1634
Iscrizione: sabato 1 aprile 2006, 16:10
Distribuzione: kubuntu 18.04

Re: problemi con doppio schermo

Messaggio da axr » mercoledì 1 gennaio 2020, 15:40

Ciao le versione di kde su ubuntu è la 5.17.4 in quant è kde neon. per questo ho scaricato ance kubuntu 18.04.3 perché, dato che la base è la stessa, volevo escludere che fosse un problema di kde neon.... invece è di ubuntu (come base). aspetterò la versione LTS.
domani proverò a fare ciò che mi suggerisci, nel frattempo mi è arrivata una gt730 con la quale ho problemi di risoluzione e per la quale ho aperto un'altro post.
per la prova cmq staccherò la scheda e userò quella integrata, almeno fino a quando non risolvo il problema dei driver nvidia.
Ti ringrazio

andrea111
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1667
Iscrizione: mercoledì 7 novembre 2007, 4:18

Re: problemi con doppio schermo

Messaggio da andrea111 » mercoledì 1 gennaio 2020, 23:29

Una cosa alla volta, se intendi dedicarti alla nvidia pensa solo a quello finché hai risolto.
Qui il problema è minimale e (quasi) autorisolto. Eventulmente lo riprenderai successivamente.

axr
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1634
Iscrizione: sabato 1 aprile 2006, 16:10
Distribuzione: kubuntu 18.04

Re: problemi con doppio schermo

Messaggio da axr » giovedì 2 gennaio 2020, 13:53

ciao, con la nvidia ho risolto nel senso che la restituisco. Non va ne con ubuntu ne con windows 10. ho reinstallato tutto come prima. ora provo a fare come mi hai suggerito e riscrivere un xorg.

axr
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1634
Iscrizione: sabato 1 aprile 2006, 16:10
Distribuzione: kubuntu 18.04

Re: problemi con doppio schermo

Messaggio da axr » giovedì 2 gennaio 2020, 13:58

cioa con non mi fassa alla console testuale F1 ma solo quella da F2. dopo aver stoppato sddm ottengo questo errore:

Codice: Seleziona tutto

axenx@axenx:~$ sudo X -configure
_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
(EE) 
Fatal server error:
(EE) Cannot establish any listening sockets - Make sure an X server isn't already running(EE) 
(EE) 
Please consult the The X.Org Foundation support 
         at http://wiki.x.org
 for help. 
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE) 
(EE) Server terminated with error (1). Closing log file.
axenx@axenx:~$ 
ptovo ad entrare in recovery e fare tutto

axr
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1634
Iscrizione: sabato 1 aprile 2006, 16:10
Distribuzione: kubuntu 18.04

Re: problemi con doppio schermo

Messaggio da axr » giovedì 2 gennaio 2020, 14:06

allora, da recovery sono entrato in console testale da root e ho eseguito i tuoi comandi e mi ha generato questo file di xorg:

Codice: Seleziona tutto

root@axenx:~# cat xorg.conf.new
Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        Screen      1  "Screen1" RightOf "Screen0"
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        ModulePath   "/usr/lib/xorg/modules"
        FontPath     "/usr/share/fonts/X11/misc"
        FontPath     "/usr/share/fonts/X11/cyrillic"
        FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
        FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
        FontPath     "/usr/share/fonts/X11/Type1"
        FontPath     "/usr/share/fonts/X11/100dpi"
        FontPath     "/usr/share/fonts/X11/75dpi"
        FontPath     "built-ins"
EndSection

Section "Module"
        Load  "glx"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
EndSection

Section "Monitor"
        Identifier   "Monitor1"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"                  # [<bool>]
        #Option     "kmsdev"                    # <str>
        #Option     "ShadowFB"                  # [<bool>]
        #Option     "AccelMethod"               # <str>
        #Option     "PageFlip"                  # [<bool>]
        #Option     "ZaphodHeads"               # <str>
        #Option     "DoubleShadow"              # [<bool>]
        Identifier  "Card0"
        Driver      "modesetting"
        BusID       "PCI:0:2:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"                  # [<bool>]
        #Option     "kmsdev"                    # <str>
        #Option     "ShadowFB"                  # [<bool>]
        #Option     "AccelMethod"               # <str>
        #Option     "PageFlip"                  # [<bool>]
        #Option     "ZaphodHeads"               # <str>
        #Option     "DoubleShadow"              # [<bool>]
        Identifier  "Card1"
        Driver      "modesetting"
        BusID       "PCI:0:2:1"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
                Viewport   0 0
                Depth     1
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     4
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     8
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     15
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     16
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

Section "Screen"
        Identifier "Screen1"
        Device     "Card1"
        Monitor    "Monitor1"
        SubSection "Display"
                Viewport   0 0
                Depth     1
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     4
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     8
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     15
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     16
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

root@axenx:~# 

andrea111
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1667
Iscrizione: mercoledì 7 novembre 2007, 4:18

Re: problemi con doppio schermo

Messaggio da andrea111 » giovedì 2 gennaio 2020, 16:33

dopo aver stoppato sddm ottengo questo errore:
l'errore dice che sddm era ancora in esecuzione. Sicuro di averlo scritto giusto? Ti ha dato come risposta "service sddm stopped"?
Posta il risultato di

Codice: Seleziona tutto

cat /etc/X11/default-display-manager
Lo xorg.conf che hai postato dice di due schede grafiche entrambe pilotate dal driver "modesetting", questo vuol dire che la nvidia è ancora installata (con o senza i suoi driver?).
Posta

Codice: Seleziona tutto

sudo lshw -c video | grep configuration

axr
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1634
Iscrizione: sabato 1 aprile 2006, 16:10
Distribuzione: kubuntu 18.04

Re: problemi con doppio schermo

Messaggio da axr » venerdì 3 gennaio 2020, 9:07

Ciao, allora.... ho disinstallato tutti i driver nvidia e staccato fisicamente la scheda (la restituisco).
ho stoppato sddm e mi è apparso lo schermo nero con il cursore e non potevo scrivere niente ne andare nella console con F1, sono andato allora alla F2 e ho generato l'xorg:

Codice: Seleziona tutto

Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	Screen      1  "Screen1" RightOf "Screen0"
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/lib/xorg/modules"
	FontPath     "/usr/share/fonts/X11/misc"
	FontPath     "/usr/share/fonts/X11/cyrillic"
	FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath     "/usr/share/fonts/X11/Type1"
	FontPath     "/usr/share/fonts/X11/100dpi"
	FontPath     "/usr/share/fonts/X11/75dpi"
	FontPath     "built-ins"
EndSection

Section "Module"
	Load  "glx"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Monitor"
	Identifier   "Monitor1"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"           	# [<bool>]
        #Option     "kmsdev"             	# <str>
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "AccelMethod"        	# <str>
        #Option     "PageFlip"           	# [<bool>]
        #Option     "ZaphodHeads"        	# <str>
        #Option     "DoubleShadow"       	# [<bool>]
	Identifier  "Card0"
	Driver      "modesetting"
	BusID       "PCI:0:2:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"           	# [<bool>]
        #Option     "kmsdev"             	# <str>
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "AccelMethod"        	# <str>
        #Option     "PageFlip"           	# [<bool>]
        #Option     "ZaphodHeads"        	# <str>
        #Option     "DoubleShadow"       	# [<bool>]
	Identifier  "Card1"
	Driver      "modesetting"
	BusID       "PCI:0:2:1"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "Screen"
	Identifier "Screen1"
	Device     "Card1"
	Monitor    "Monitor1"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

e fatto riaprtire sddm, sono rientrato in modalità grafica dato i comandi:

Codice: Seleziona tutto

axenx@axenx:~$     cat /etc/X11/default-display-manager
/usr/bin/sddm
axenx@axenx:~$     sudo lshw -c video | grep configuration
[sudo] password di axenx: 
       configuration: driver=i915 latency=0
       configuration: latency=0
axenx@axenx:~$ 



axr
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1634
Iscrizione: sabato 1 aprile 2006, 16:10
Distribuzione: kubuntu 18.04

Re: problemi con doppio schermo

Messaggio da axr » venerdì 3 gennaio 2020, 11:14

questo è l'xorg generato da archlinux

Codice: Seleziona tutto

Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	Screen      1  "Screen1" RightOf "Screen0"
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/lib/xorg/modules"
	FontPath     "/usr/share/fonts/misc"
	FontPath     "/usr/share/fonts/TTF"
	FontPath     "/usr/share/fonts/OTF"
	FontPath     "/usr/share/fonts/Type1"
	FontPath     "/usr/share/fonts/100dpi"
	FontPath     "/usr/share/fonts/75dpi"
EndSection

Section "Module"
	Load  "glx"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Monitor"
	Identifier   "Monitor1"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "Accel"              	# [<bool>]
        #Option     "AccelMethod"        	# <str>
        #Option     "Backlight"          	# <str>
        #Option     "CustomEDID"         	# <str>
        #Option     "DRI"                	# <str>
        #Option     "Present"            	# [<bool>]
        #Option     "ColorKey"           	# <i>
        #Option     "VideoKey"           	# <i>
        #Option     "Tiling"             	# [<bool>]
        #Option     "LinearFramebuffer"  	# [<bool>]
        #Option     "HWRotation"         	# [<bool>]
        #Option     "VSync"              	# [<bool>]
        #Option     "PageFlip"           	# [<bool>]
        #Option     "SwapbuffersWait"    	# [<bool>]
        #Option     "TripleBuffer"       	# [<bool>]
        #Option     "XvPreferOverlay"    	# [<bool>]
        #Option     "HotPlug"            	# [<bool>]
        #Option     "ReprobeOutputs"     	# [<bool>]
        #Option     "XvMC"               	# [<bool>]
        #Option     "ZaphodHeads"        	# <str>
        #Option     "VirtualHeads"       	# <i>
        #Option     "TearFree"           	# [<bool>]
        #Option     "PerCrtcPixmaps"     	# [<bool>]
        #Option     "FallbackDebug"      	# [<bool>]
        #Option     "DebugFlushBatches"  	# [<bool>]
        #Option     "DebugFlushCaches"   	# [<bool>]
        #Option     "DebugWait"          	# [<bool>]
        #Option     "BufferCache"        	# [<bool>]
	Identifier  "Card0"
	Driver      "intel"
	BusID       "PCI:0:2:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "Accel"              	# [<bool>]
        #Option     "AccelMethod"        	# <str>
        #Option     "Backlight"          	# <str>
        #Option     "CustomEDID"         	# <str>
        #Option     "DRI"                	# <str>
        #Option     "Present"            	# [<bool>]
        #Option     "ColorKey"           	# <i>
        #Option     "VideoKey"           	# <i>
        #Option     "Tiling"             	# [<bool>]
        #Option     "LinearFramebuffer"  	# [<bool>]
        #Option     "HWRotation"         	# [<bool>]
        #Option     "VSync"              	# [<bool>]
        #Option     "PageFlip"           	# [<bool>]
        #Option     "SwapbuffersWait"    	# [<bool>]
        #Option     "TripleBuffer"       	# [<bool>]
        #Option     "XvPreferOverlay"    	# [<bool>]
        #Option     "HotPlug"            	# [<bool>]
        #Option     "ReprobeOutputs"     	# [<bool>]
        #Option     "XvMC"               	# [<bool>]
        #Option     "ZaphodHeads"        	# <str>
        #Option     "VirtualHeads"       	# <i>
        #Option     "TearFree"           	# [<bool>]
        #Option     "PerCrtcPixmaps"     	# [<bool>]
        #Option     "FallbackDebug"      	# [<bool>]
        #Option     "DebugFlushBatches"  	# [<bool>]
        #Option     "DebugFlushCaches"   	# [<bool>]
        #Option     "DebugWait"          	# [<bool>]
        #Option     "BufferCache"        	# [<bool>]
	Identifier  "Card1"
	Driver      "intel"
	BusID       "PCI:0:2:1"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "Screen"
	Identifier "Screen1"
	Device     "Card1"
	Monitor    "Monitor1"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

per completezza ti dico che al pc è collegato anche il cavo vga ma solo al pc, dalla parte del secondo monitor è scollegato. il monitor principale da 27 è con DP
ti ringrazio

andrea111
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1667
Iscrizione: mercoledì 7 novembre 2007, 4:18

Re: problemi con doppio schermo

Messaggio da andrea111 » venerdì 3 gennaio 2020, 12:53

Quindi ora sei senza la nvidia, strano perché ti vede due schede grafiche (anche arch).

Da kubuntu posta

Codice: Seleziona tutto

sudo lshw -c video
lspci

axr
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1634
Iscrizione: sabato 1 aprile 2006, 16:10
Distribuzione: kubuntu 18.04

Re: problemi con doppio schermo

Messaggio da axr » venerdì 3 gennaio 2020, 18:21

ciao ecco il risultato

Codice: Seleziona tutto

axenx@axenx:~$ sudo lshw -c video
[sudo] password di axenx: 
  *-display:0               
       description: VGA compatible controller
       product: 4 Series Chipset Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 03
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:16 memory:f0000000-f03fffff memory:e0000000-efffffff ioport:1230(size=8) memory:c0000-dffff
  *-display:1 UNCLAIMED
       description: Display controller
       product: 4 Series Chipset Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2.1
       bus info: pci@0000:00:02.1
       version: 03
       width: 64 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=0
       resources: memory:f0400000-f04fffff
axenx@axenx:~$ lspci
00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
00:03.0 Communication controller: Intel Corporation 4 Series Chipset HECI Controller (rev 03)
00:03.3 Serial controller: Intel Corporation 4 Series Chipset Serial KT Controller (rev 03)
00:19.0 Ethernet controller: Intel Corporation 82567LM-3 Gigabit Network Connection (rev 02)
00:1a.0 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801JD/DO (ICH10 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801JD/DO (ICH10 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801JD/DO (ICH10 Family) PCI Express Port 2 (rev 02)
00:1d.0 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev a2)
00:1f.0 ISA bridge: Intel Corporation 82801JD (ICH10D) LPC Interface Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801JD/DO (ICH10 Family) SATA AHCI Controller (rev 02)
10:00.0 Network controller: Qualcomm Atheros AR9227 Wireless Network Adapter (rev 01)
30:00.0 USB controller: VIA Technologies, Inc. VL805 USB 3.0 Host Controller (rev 01)
axenx@axenx:~$ 

per sicurezza ho anche disinstallato i driver nvidia open

andrea111
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1667
Iscrizione: mercoledì 7 novembre 2007, 4:18

Re: problemi con doppio schermo

Messaggio da andrea111 » sabato 4 gennaio 2020, 17:03

Bisogna chiarire una cosa: l'ultimo xorg.conf di kubuntu che hai postato lo hai fatto da root o da utente normale?

In ogni caso è inutilizzabile perché peggiora la situazione rispetto alla attuale: vede due dispositivi grafici pilotati entrambe dal driver modesetting (che è il driver di emergenza) invece che dall'intel (i915) che è quello giusto.
Invece lo xorg.conf di arch è corretto.
Ipotesi: a quanto pare la doppia grafica fornita da quella particolare intel "confonde" kubuntu e va generare "l'intoppo".

A questo punto farei una prova estemporanea: prendere lo xorg.conf di arch e copiarlo pari-pari in /etc/X11 di kubuntu, riavviare e vedere come si comporta.
Fai così: avvii kubuntu - copi lo xorg.conf di arch e dai questo comando:

Codice: Seleziona tutto

sudo update-initramfs -u
poi riavvii e vedi se si sistema.
Qualora al riavvio si presentasse lo schermo nero, avvi arch cancelli lo xorg.conf di kubuntu e riavvii.

Quanto alla nvidia che vuoi restituire: in windows10 avevi installato i driver per la stessa che trovi nel cd allegato alla nvidia?
La nvidia non funzionava neanche con arch?

axr
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1634
Iscrizione: sabato 1 aprile 2006, 16:10
Distribuzione: kubuntu 18.04

Re: problemi con doppio schermo

Messaggio da axr » martedì 7 gennaio 2020, 9:32

Ciao l'ho fatto da utente normale, ho fatto la prpva di usare quello di arch ma niente da fare, stesso problema.
ho provato a generarlo un'altro da kubuntu e cambiare modeset in intel.... niente da fare!

Avatar utente
noel80
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1389
Iscrizione: giovedì 11 settembre 2014, 2:49
Desktop: plasma@linux-libre
Distribuzione: archlinux, Pop!_OS

Re: problemi con doppio schermo

Messaggio da noel80 » martedì 7 gennaio 2020, 11:08

Buondi', scusate ma VGA non dovrebbe non supportare 1980x1080 (a meno che di aver un adattatore/convertitore)?

axr
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1634
Iscrizione: sabato 1 aprile 2006, 16:10
Distribuzione: kubuntu 18.04

Re: problemi con doppio schermo

Messaggio da axr » martedì 7 gennaio 2020, 11:24

si, infatti il problema è sul 27 pollici collegato sulla display port

axr
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1634
Iscrizione: sabato 1 aprile 2006, 16:10
Distribuzione: kubuntu 18.04

Re: problemi con doppio schermo

Messaggio da axr » mercoledì 8 gennaio 2020, 10:47

RISOLTOOOOOOO.... scuate, allora il problema era che dando questo comando
axenx@axenx:~$ apt-cache policy xserver-xorg-video-intel*
ho scoperto che erano installati questi:
xserver-xorg-video-intel-native-modesetting
e non questi:
xserver-xorg-video-intel-hwe-18.04
il perchè non ne ho idea in quanto anche con delle live ho avuto lo stesso problema.
Metto risolto e vi ringrazio moltissimo per il tempo che mi avete dedicato!
a presto e grazie ancora

andrea111
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1667
Iscrizione: mercoledì 7 novembre 2007, 4:18

Re: [Risolto] problemi con doppio schermo

Messaggio da andrea111 » mercoledì 8 gennaio 2020, 14:17

A forza di dài e dài alla fine è saltato fuori. Buono a sapersi.
Diversi utenti con la intel denunciavano problemi vari (tearing, lagging, flickering) per i quali le soluzioni tipiche non risolvevano.

Penso che sia dovuto ai problemi connessi alla serie HWE (che trasforma la distro in semi-rolling: hai sempre l'ultimo kernel ed il relativo xorg).
A quanto pare con le intel possono esserci problemi.
Indicazione generica: se vuoi stare tranquillo evita la serie HWE.
Un altro fattore da avere presente.
Grazie a te.

axr
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1634
Iscrizione: sabato 1 aprile 2006, 16:10
Distribuzione: kubuntu 18.04

Re: [Risolto] problemi con doppio schermo

Messaggio da axr » mercoledì 8 gennaio 2020, 15:43

Hai ragione infatti in futuro eviterò tanto l'hardware che ho è sempre lo stesso grazie ancora a presto buona giornata

Scrivi risposta

Ritorna a “KDE”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 4 ospiti