Pagina 1 di 1

Ubuntu Windows dual boot

MessaggioInviato: sabato 18 febbraio 2017, 23:22
da UgoMela
Buonasera,

Ho un grosso problema. Ho istallato ubuntu in dual boot con Windows 10 su due hard disk separati. Sul PC inizialmente avevo istallato windows 10, poi ho collegato il nuovo hard disk e istallato ubuntu 16.04. Per la prima settimana dopo l'istallazione non c'è stato nessun problema funzionavano entrambi. Poi per una settimana ho utilizzato solo ubuntu e ieri quando ho riacceso windows non partiva più. Dal bios l'hard disk con windows non viene più riconosciuto (non c'è proprio! ho provato ad attaccare meglio i cavi, a scollegarlo e a riattaccarlo ma niente) quindi riesco ad accedere al pc sono con ubuntu. Inizialmente avevo impostato come disco principale windows quindi se non tocco nulla all'avvio dovrebbe partire windows invece mi esce la preoccupante schermata "EFI Shell version 2.31 [4.651] - Current running mode 1.1.2.....". Quando, invece, accedo al pc con ubuntu l'hard disk di windows viene riconosciuto ma ovviamente non mi fa accedere.

Il bello è che non ho toccato nulla ne istallato qualcosa di nuovo, semplicemente da un giorno all'altro l'hard disk di windows è scomparso dal bios però funziona tant'è che ubuntu lo risconosce.

Qualcuno si è trovato nella mia stessa situazione?

Re: Ubuntu Windows dual boot

MessaggioInviato: domenica 19 febbraio 2017, 13:20
da Telefo
Una cosa alla volta: dove hai installato grub? qual è l'ordine di boot del bios? se alla schermata di grub selezioni windows che cosa ti dice?

Re: Ubuntu Windows dual boot

MessaggioInviato: domenica 19 febbraio 2017, 16:04
da UgoMela
Ho istallato grub sul secondo hard disk, che ho collegato dopo il primo sul quale c'era windows, il mio obbiettivo era quello di non far dialogare windows con ubuntu, evidentemente non ci sono riuscito.

Per il boot del bios non ho molta scelta: l'hard disk con windows la scheda madre non lo legge più (pero quando vado nella sezione dischi di ubuntu è presente), quindi sta come primo l'hard disk con ubuntu.

Nella schermata di grub se seleziono windows 10 mi esce:
errore: no such device:CE023A2C023A19C3
Impostazione tipo di partizione a 0x82
errore: invalid signature.

Se premo qualunque tasto mi rimanda alla schermata grub

Re: Ubuntu Windows dual boot

MessaggioInviato: domenica 19 febbraio 2017, 20:29
da Telefo
Ma, non credo che se Ubuntu vede il disco, la scheda madre non lo legge come dici tu. Più verosimilmente non lo legge come disco di avvio. Forse si è corrotto l'MBR (hai partizioni in MBR o in GPT?) di windows. Prova a rispristinare win con un disco di ripristino o di installazione e poi, se funziona, reinstalli grub

Re: Ubuntu Windows dual boot

MessaggioInviato: lunedì 20 febbraio 2017, 0:40
da UgoMela
Purtroppo non mi ricordo come l'ho partizionato, ho seguito la procedura guidata standard di ubuntu.

Ho provato a ripristinare windows con una pennetta per il ripristino seguendo le istruzioni della microsoft ma niente.

Se, con il sistema di ripristino, cerco di riparare l'istallazione elabora per un oretta poi si riavvia ma si presenta lo stesso problema. Se voglio usare il sistema che permette il ripristino dell'hard disk dice che non lo riesce a trovare.

Re: Ubuntu Windows dual boot

MessaggioInviato: lunedì 20 febbraio 2017, 11:38
da Telefo
Posta l'output di
Codice: Seleziona tutto
sudo blkid -o list

e quello di
Codice: Seleziona tutto
cat /etc/fstab

Re: Ubuntu Windows dual boot

MessaggioInviato: lunedì 20 febbraio 2017, 16:21
da UgoMela
Il primo:
Codice: Seleziona tutto
device             fs_type   label      mount point            UUID
----------------------------------------------------------------------------------------------------
/dev/sda1          ntfs      Riservato per il sistema (not mounted) CE023A2C023A19C3
/dev/sda2          ntfs                 (not mounted)          44E03D2CE03D2618
/dev/sda3          ntfs                 (not mounted)          5A1425071424E7A9
/dev/sdb1          swap                 [SWAP]                 3e076fcd-f32b-4d7e-9b64-34a28e6ec6a7
/dev/sdb2          ext4                 /                      9935b463-45e9-47d8-bff6-492969ac9ac3


Il secondo:
Codice: Seleziona tutto
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb2 during installation
UUID=9935b463-45e9-47d8-bff6-492969ac9ac3 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sdb1 during installation
UUID=3e076fcd-f32b-4d7e-9b64-34a28e6ec6a7 none            swap    sw              0       0
/dev/disk/by-uuid/CE023A2C023A19C3 /mnt/CE023A2C023A19C3 auto nosuid,nodev,nofail,noauto 0 0


Questo è il disco che non viene riconosciuto all'avvio:
Schermata del 2017-02-20 15-18-33.png


Dice che c'è un settore danneggiato: ho provato a ripararlo, senza successo con la guida che dice qui ->https://www.lffl.org/2013/09/ubuntu-linux-come-riparare-i-settori.html

Re: Ubuntu Windows dual boot

MessaggioInviato: lunedì 20 febbraio 2017, 19:19
da Telefo
tra l'errore
errore: no such device:CE023A2C023A19C3
e gli uuid delle tue partizioni c'è qualcosa che non torna...
prova a reinstallare e aggiornare grub
Codice: Seleziona tutto
sudo grub-install /dev/sda

e poi
Codice: Seleziona tutto
sudo update-grub

dopodiché riavvia e vedi cosa ti dice, selezionando win

Re: Ubuntu Windows dual boot

MessaggioInviato: lunedì 20 febbraio 2017, 20:47
da UgoMela
Eseguendo il primo comando esce:
Codice: Seleziona tutto
grub-install: avviso: Il settore 32 è già in uso dal programma "FlexNet", viene saltato. Questo software potrebbe causare problemi di avvio, o altri, nel futuro. Informare gli autori e avvisarli di non archiviare dati nell'intervallo del MBR..


eseguendo il secondo:

Codice: Seleziona tutto
sudo update-grub
Generating grub configuration file ...
Trovata immagine linux: /boot/vmlinuz-4.4.0-62-generic
Trovata immagine initrd: /boot/initrd.img-4.4.0-62-generic
Trovata immagine linux: /boot/vmlinuz-4.4.0-59-generic
Trovata immagine initrd: /boot/initrd.img-4.4.0-59-generic
Trovata immagine linux: /boot/vmlinuz-4.4.0-31-generic
Trovata immagine initrd: /boot/initrd.img-4.4.0-31-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
/usr/sbin/grub-probe: errore: file system sconosciuto.
Trovato Windows 10 (loader) su /dev/sda1
errore: impossibile leggere "/dev/sda": Errore di input/output.
errore: impossibile leggere "/dev/sda": Errore di input/output.
errore: impossibile leggere "/dev/sda": Errore di input/output.
errore: impossibile leggere "/dev/sda": Errore di input/output.
errore: impossibile leggere "/dev/sda": Errore di input/output.
/usr/sbin/grub-probe: errore: impossibile trovare un'unità GRUB per /dev/sda1, controllare device.map.
errore: impossibile leggere "/dev/sda": Errore di input/output.
errore: impossibile leggere "/dev/sda": Errore di input/output.
errore: impossibile leggere "/dev/sda": Errore di input/output.
errore: impossibile leggere "/dev/sda": Errore di input/output.
errore: impossibile leggere "/dev/sda": Errore di input/output.
/usr/sbin/grub-probe: errore: impossibile trovare un'unità GRUB per /dev/sda1, controllare device.map.
fatto


Ho provato ad avviare windows, purtroppo esce ancora un messaggio di errore (però più corto di prima):

errore: invalid signature.

Re: Ubuntu Windows dual boot

MessaggioInviato: lunedì 20 febbraio 2017, 23:01
da Telefo
Guarda la cosa si fa complicata. Qui di seguito c'è una guida sulla risoluzione di questo problema, ti consiglio, se segui la guida, di fare un backup dei dati.
http://www.chimerarevo.com/linux/risolvere-problema-flexnet-grub-linux-83081/