Problema "dipendenze irrisolte"

Domande e richieste di un principiante alle prime armi con Ubuntu e il mondo GNU/Linux in generale. Per domande specifiche, utilizzare le altre sezioni.
Regole della sezione
In questa sezione possono inserire nuove discussioni solo coloro che fanno parte del livello "Prode Principiante", tutti gli altri possono comunque rispondere regolarmente. Se si fa parte di questo livello e si è registrati al forum prima del 24 aprile 2012, data del passaggio al nuovo forum, consultare questa discussione.

Immagine Come usare UbuntuIntroduzione a UbuntuPrimi passi su Ubuntu Immagine Amministrazione del sistemaComandi di baseInstallare programmiLog di sistemaRiga di comandoSudo

Problema "dipendenze irrisolte"

Messaggioda Leonethegrey_01 » venerdì 31 marzo 2017, 11:41

salve a tutti, premetto di essere nuovo nel forum e principiante per quanto riguarda le piattaforme linux ubuntu etc.
ho da poco installato linux ubuntu 16.10 ed in alto a destra (vicino connesioni wi-fi) è comparso un segnale di errore
"errore nell'aprire la cache(E:Opening/etc/apt/sources-list.d/chromium-daily-ubuntu-ppa-yakketty.list-if stream::ifstream(13:permission denied),E:the list of sources could not be read.) Di solito questo significa che i pacchetti installati presentano delle dipendenze irrisolte."
come posso risolvere questo problema?
Leonethegrey_01
Prode Principiante
 
Messaggi: 9
Iscrizione: marzo 2017
Distribuzione: ubuntu 16.10
Sesso: Maschile

Re: Problema "dipendenze irrisolte"

Messaggioda giulux » venerdì 31 marzo 2017, 13:31

Benvenuto!

Dai nel terminale
Codice: Seleziona tutto
sudo -H software-properties-gtk
e nella finestra che si apre vai alla scheda "altro software" e togli la spunta a quella fonte.
Chiudi facendo fare l'aggiornamento e verifica se l'avviso è scomparso.

Fai sapere.
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...
Avatar utente
giulux
Amministratore
Amministratore
 
Messaggi: 19565
Iscrizione: gennaio 2010
Località: Roma
Desktop: xubuntu - ubuntu gnome
Distribuzione: Ubuntu 16.04.1 LTS x86_64
Sesso: Maschile

Re: Problema "dipendenze irrisolte"

Messaggioda Leonethegrey_01 » venerdì 31 marzo 2017, 14:01

ciao giulux grazie della risposta,
dopo aver inserito il comando nel terminale mi da: "WARNING:root:could not open file '/etc/apt/sources.list'"
"Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged."
anche dopo aver aver tolto la spunta "chromium-daily-ubuntu-ppa-yakketty"
Leonethegrey_01
Prode Principiante
 
Messaggi: 9
Iscrizione: marzo 2017
Distribuzione: ubuntu 16.10
Sesso: Maschile

Re: Problema "dipendenze irrisolte"

Messaggioda giulux » venerdì 31 marzo 2017, 14:38

Posta il terminale di questo comando
Codice: Seleziona tutto
sudo apt update && sudo apt upgrade
tra i tag [ code] e [ /code] che si creano cliccando su Codice in alto, sopra a finestra di scrittura (editor completo) così:
    [ code]listato
    da postare
    [ /code]
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...
Avatar utente
giulux
Amministratore
Amministratore
 
Messaggi: 19565
Iscrizione: gennaio 2010
Località: Roma
Desktop: xubuntu - ubuntu gnome
Distribuzione: Ubuntu 16.04.1 LTS x86_64
Sesso: Maschile

Re: Problema "dipendenze irrisolte"

Messaggioda Leonethegrey_01 » venerdì 31 marzo 2017, 15:01

Grazie del tuo tempo e scusami se ti sto disturbando ma sono alla prime armi;
inserendo il primo comando mi da "Err:7 http://ppa.launchpad.net/damien-moore/c ... ble/ubuntu yakkety Release
404 Not Found" ce ne sono vari, ne ho scritto uno da esempio.
Leonethegrey_01
Prode Principiante
 
Messaggi: 9
Iscrizione: marzo 2017
Distribuzione: ubuntu 16.10
Sesso: Maschile

Re: Problema "dipendenze irrisolte"

Messaggioda GreYOwL » venerdì 31 marzo 2017, 15:14

Chiedo scusa, ma come hai installato chromium ???
il comando:
Codice: Seleziona tutto
sudo apt-get install -f
cosa ti restituisce ??
"Disapprovo quello che dici, ma difenderò fino alla morte il tuo diritto a dirlo" - Evelyn Beatrice Hall -
Avatar utente
GreYOwL
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1157
Iscrizione: aprile 2007
Località: Roma
Desktop: Gnome 3.26.1
Distribuzione: Ubuntu 17.10
Sesso: Maschile

Re: Problema "dipendenze irrisolte"

Messaggioda Leonethegrey_01 » venerdì 31 marzo 2017, 15:28

GreYOwL Immagine ha scritto:Chiedo scusa, ma come hai installato chromium ???
il comando:
Codice: Seleziona tutto
sudo apt-get install -f
cosa ti restituisce ??

ciao GreYowl,
mi restituisce
Codice: Seleziona tutto
:ettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  ant ant-optional antlr3 aspectj bnd default-jdk default-jdk-doc
  default-jdk-headless gstreamer1.0-plugins-base:i386 java-wrappers javahelp2
  junit junit-doc junit4 junit4-doc libantlr-java libantlr3-runtime-java
  libapache-pom-java libapr1 libaprutil1 libasm3-java libasm4-java
  libaspectj-java libatinject-jsr330-api-java libavalon-framework-java
  libbeansbinding-java libbindex-java libbsh-java libbytelist-java
  libcairo2:i386 libcap2:i386 libcdi-api-java libcdparanoia0:i386
  libcglib3-java libcommons-beanutils-java libcommons-codec-java
  libcommons-collections3-java libcommons-compress-java
  libcommons-digester-java libcommons-io-java libcommons-lang-java
  libcommons-logging-java libcommons-net-java libcommons-parent-java
  libeclipselink-java libequinox-osgi-java libexcalibur-logkit-java
  libfelix-framework-java libfelix-main-java libfelix-osgi-obr-java
  libfreemarker-java libgeronimo-interceptor-3.0-spec-java
  libgeronimo-j2ee-connector-1.5-spec-java libgeronimo-jms-1.1-spec-java
  libgeronimo-jta-1.1-spec-java libgeronimo-osgi-support-java
  libgeronimo-validation-1.0-spec-java libglib2.0-0:i386
  libgstreamer-plugins-base1.0-0:i386 libgstreamer1.0-0:i386 libhamcrest-java
  libhamcrest-java-doc libhtml5parser-java libhttpclient-java libhttpcore-java
  libice-dev libicu4j-4.4-java libini4j-java libjavaewah-java libjcodings-java
  libjcommander-java libjemmy2-java libjgit-java libjna-java libjna-jni
  libjna-platform-java libjnlp-servlet-java libjoda-time-java
  libjpa-2.1-spec-java libjsch-agent-proxy-java libjsch-java
  libjson-simple-java libjsr311-api-java libjvyamlb-java libjzlib-java
  libkxml2-java liblog4j1.2-java liblucene3-contrib-java liblucene3-java
  libmail-java libmysql-java libnb-absolutelayout-java libnb-apisupport3-java
  libnb-ide14-java libnb-java5-java libnb-javaparser-java
  libnb-org-openide-modules-java libnb-org-openide-util-java
  libnb-org-openide-util-lookup-java libnb-platform-devel-java
  libnb-platform18-java libopus0:i386 liborc-0.4-0:i386
  libosgi-annotation-java libosgi-compendium-java libosgi-core-java
  libpixman-1-0:i386 libpostgresql-jdbc-java libpthread-stubs0-dev
  libregexp-java libsdo-api-java libsequence-library-java libserf-1-1
  libservlet3.0-java libservlet3.1-java libsimple-validation-java
  libslf4j-java libsm-dev libsqljet-java libstringtemplate-java
  libstringtemplate4-java libsvn-java libsvn1 libsvnclientadapter-java
  libsvnkit-java libswing-layout-java libswingx-java libtheora0:i386
  libtrilead-ssh2-java libvisual-0.4-0:i386 libwine-development
  libwine-development:i386 libws-commons-util-java libx11-dev libx11-doc
  libxau-dev libxcb-render0:i386 libxcb-shm0:i386 libxcb1-dev libxdmcp-dev
  libxerces2-java libxml-commons-external-java libxml-commons-resolver1.1-java
  libxt-dev libyaml-snake-java openjdk-8-doc openjdk-8-jdk
  openjdk-8-jdk-headless testng wine32-development:i386 wine64-development
  x11proto-core-dev x11proto-input-dev x11proto-kb-dev xorg-sgml-doctools
  xtrans-dev
Usare "sudo apt autoremove" per rimuoverli.
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
Ultima modifica di Leonethegrey_01 il venerdì 31 marzo 2017, 16:59, modificato 2 volte in totale.
Leonethegrey_01
Prode Principiante
 
Messaggi: 9
Iscrizione: marzo 2017
Distribuzione: ubuntu 16.10
Sesso: Maschile

Re: Problema "dipendenze irrisolte"

Messaggioda giulux » venerdì 31 marzo 2017, 15:30

Leonethegrey_01 Immagine ha scritto:Grazie del tuo tempo e scusami se ti sto disturbando ma sono alla prime armi;
inserendo il primo comando mi da "Err:7 http://ppa.launchpad.net/damien-moore/c ... ble/ubuntu yakkety Release
404 Not Found" ce ne sono vari, ne ho scritto uno da esempio.
La richiesta era di postare tutto il terminale per consentire a chi ti assiste di vedere quel che è successo, NON di farne un riassunto con parole tue, che purtroppo serve a niente :nono: .

Idem per quanto ti ha chiesto greyowl.
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...
Avatar utente
giulux
Amministratore
Amministratore
 
Messaggi: 19565
Iscrizione: gennaio 2010
Località: Roma
Desktop: xubuntu - ubuntu gnome
Distribuzione: Ubuntu 16.04.1 LTS x86_64
Sesso: Maschile

Re: Problema "dipendenze irrisolte"

Messaggioda Leonethegrey_01 » venerdì 31 marzo 2017, 15:50

La richiesta era di postare tutto il terminale per consentire a chi ti assiste di vedere quel che è successo, NON di farne un riassunto con parole tue, che purtroppo serve a niente :nono: .

Idem per quanto ti ha chiesto greyowl.


hai ragione, scusami.
Codice: Seleziona tutto
ecco : Ign:1 http://ppa.launchpad.net/damien-moore/codeblocks-stable/ubuntu yakkety InRelease
Ign:2 http://ppa.launchpad.net/jonathonf/wine/ubuntu yakkety InRelease
Trovato:3 http://ppa.launchpad.net/ricotz/unstable/ubuntu yakkety InRelease
Ign:4 http://ppa.launchpad.net/upubuntu-com/chat/ubuntu yakkety InRelease
Trovato:5 http://ppa.launchpad.net/videolan/stable-daily/ubuntu yakkety InRelease
Trovato:6 http://ppa.launchpad.net/wine/wine-builds/ubuntu yakkety InRelease
Trovato:7 https://repo.skype.com/deb stable InRelease
Err:8 http://ppa.launchpad.net/damien-moore/codeblocks-stable/ubuntu yakkety Release
  404  Not Found
Err:9 http://ppa.launchpad.net/jonathonf/wine/ubuntu yakkety Release
  404  Not Found
Err:10 http://ppa.launchpad.net/upubuntu-com/chat/ubuntu yakkety Release
  404  Not Found
Lettura elenco dei pacchetti... Fatto                 
E: The repository 'http://ppa.launchpad.net/damien-moore/codeblocks-stable/ubuntu yakkety Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://ppa.launchpad.net/jonathonf/wine/ubuntu yakkety Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://ppa.launchpad.net/upubuntu-com/chat/ubuntu yakkety Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
Ultima modifica di Leonethegrey_01 il venerdì 31 marzo 2017, 16:58, modificato 1 volta in totale.
Leonethegrey_01
Prode Principiante
 
Messaggi: 9
Iscrizione: marzo 2017
Distribuzione: ubuntu 16.10
Sesso: Maschile

Re: Problema "dipendenze irrisolte"

Messaggioda giulux » venerdì 31 marzo 2017, 16:52

Inseriti come hai fatto i listati rendono il post troppo lungo e di difficile lettura.
In futuro incollali tra i tag [ code] e [ /code] che si creano cliccando su Codice in alto, sopra la finestra di scrittura(editor completo) così:
    [ code]listato
    da postare
    [ /code]

Correggi i post precedenti cliccando su "modifica", poi seleziona il listato, clicca su Codice e salva.

Nel merito: hai una serie di ppa con problemi: ti consiglio di disabilitarle tutte e vedere se il problema scompare.

Ciao.

P.S. per il futuro: il terminale va postato tutto, comando e prompt finale compresi in modo che si possa verificare eventuali errori
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...
Avatar utente
giulux
Amministratore
Amministratore
 
Messaggi: 19565
Iscrizione: gennaio 2010
Località: Roma
Desktop: xubuntu - ubuntu gnome
Distribuzione: Ubuntu 16.04.1 LTS x86_64
Sesso: Maschile

Re: Problema "dipendenze irrisolte"

Messaggioda Leonethegrey_01 » venerdì 31 marzo 2017, 17:05

giulux Immagine ha scritto:Inseriti come hai fatto i listati rendono il post troppo lungo e di difficile lettura.
In futuro incollali tra i tag [ code] e [ /code] che si creano cliccando su Codice in alto, sopra la finestra di scrittura(editor completo) così:
    [ code]listato
    da postare
    [ /code]

Correggi i post precedenti cliccando su "modifica", poi seleziona il listato, clicca su Codice e salva.

Nel merito: hai una serie di ppa con problemi: ti consiglio di disabilitarle tutte e vedere se il problema scompare.

Ciao.

P.S. per il futuro: il terminale va postato tutto, comando e prompt finale compresi in modo che si possa verificare eventuali errori

grazie giulux in futuro cercherò di non sbagliare :D ;
purtroppo il problema persiste :muro:
Leonethegrey_01
Prode Principiante
 
Messaggi: 9
Iscrizione: marzo 2017
Distribuzione: ubuntu 16.10
Sesso: Maschile

Re: Problema "dipendenze irrisolte"

Messaggioda GreYOwL » venerdì 31 marzo 2017, 19:02

1) ho paura che hai qualche ppa che non vada più.
sai dirmi perchè li hai messi ? (per capire se ti servivano effettivamente.)
2) per capire quanti e quali hai, posta il contenuto del source.d inquesto modo:
Codice: Seleziona tutto
cd /etc/apt/sources.list.d/

Codice: Seleziona tutto
ls

intanto puoi installare tutto quello che ti propone il comando
Codice: Seleziona tutto
apt-get install -f
dando la conferma alla domanda se continuare
"Disapprovo quello che dici, ma difenderò fino alla morte il tuo diritto a dirlo" - Evelyn Beatrice Hall -
Avatar utente
GreYOwL
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1157
Iscrizione: aprile 2007
Località: Roma
Desktop: Gnome 3.26.1
Distribuzione: Ubuntu 17.10
Sesso: Maschile

Re: Problema "dipendenze irrisolte"

Messaggioda trekfan1 » sabato 1 aprile 2017, 10:58

Codice: Seleziona tutto
http://ppa.launchpad.net/damien-moore/codeblocks-stable/ubuntu/dists/
http://ppa.launchpad.net/jonathonf/wine/ubuntu/dists/
si fermano a xenial
Codice: Seleziona tutto
http://ppa.launchpad.net/upubuntu-com/chat/ubuntu/dists/
si ferma addirittura a quantal...

Non mi stancherò mai di ripetere che BASTA APRIRLI CON FIREFOX quei link! Sono normali link http!!!!
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 16328
Iscrizione: maggio 2006
Località: Formigine (MO) | Tenace Tecnocrate
Desktop: Gnome Shell
Distribuzione: Ubuntu 17.10 e 18.04 (dev) 64 bit
Sesso: Maschile

Re: Problema "dipendenze irrisolte"

Messaggioda GreYOwL » sabato 1 aprile 2017, 11:18

si giusto, però prima di farli cancellare, volevo capire come e perchè li ha messi... l' ho detto sopra... non mi andava di fargli cancellare tutto cosi a fuffa...
con meno di minuto risolve tutto:
1) entrare nella directory dei ppa::
Codice: Seleziona tutto
cd /etc/apt/sources.list.d/

cancellare SOLO i ppa scaduti
3)
Codice: Seleziona tutto
sudo apt-get update

Codice: Seleziona tutto
sudo aptg-get install -f

e poi pulire tutto
Codice: Seleziona tutto
sudo apt-get autoremove

Però se non si legge cosa ha dentro, che facciamo, togliamo tutto ??
"Disapprovo quello che dici, ma difenderò fino alla morte il tuo diritto a dirlo" - Evelyn Beatrice Hall -
Avatar utente
GreYOwL
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1157
Iscrizione: aprile 2007
Località: Roma
Desktop: Gnome 3.26.1
Distribuzione: Ubuntu 17.10
Sesso: Maschile

Re: Problema "dipendenze irrisolte"

Messaggioda Leonethegrey_01 » domenica 2 aprile 2017, 13:06

penso di averli aggiungi cercando di installare qualche programma, ripetevo i comandi trovati da internet senza nemmeno sapere di cosa si trattassero,
ho risolto formattando tutto e reinstallando ubuntu, visto che non avevo file importanti o altro.
Leonethegrey_01
Prode Principiante
 
Messaggi: 9
Iscrizione: marzo 2017
Distribuzione: ubuntu 16.10
Sesso: Maschile

Re: Problema "dipendenze irrisolte"

Messaggioda trekfan1 » domenica 2 aprile 2017, 13:22

Wine lo trovi nei repo, codeblocks pure, ti invito a guardare con SYNAPTIC
Codice: Seleziona tutto
sudo apt install synaptic
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 16328
Iscrizione: maggio 2006
Località: Formigine (MO) | Tenace Tecnocrate
Desktop: Gnome Shell
Distribuzione: Ubuntu 17.10 e 18.04 (dev) 64 bit
Sesso: Maschile

Re: Problema "dipendenze irrisolte"

Messaggioda Leonethegrey_01 » domenica 2 aprile 2017, 22:07

ora ho l'errore "BrokenCount >0 " :(
come posso risolverlo?
Leonethegrey_01
Prode Principiante
 
Messaggi: 9
Iscrizione: marzo 2017
Distribuzione: ubuntu 16.10
Sesso: Maschile

Re: Problema "dipendenze irrisolte"

Messaggioda giulux » lunedì 3 aprile 2017, 7:52

La regola del forum è 1 problema = 1 discussione.
Il tuo secondo problema mi pare sia stato già affrontato più volte e se fai una ricerca dovresti trovare; altrimenti api una nuova discussione.
Guarda qui https://www.google.it/search?as_q=risol ... as_rights=
Ciao.
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...
Avatar utente
giulux
Amministratore
Amministratore
 
Messaggi: 19565
Iscrizione: gennaio 2010
Località: Roma
Desktop: xubuntu - ubuntu gnome
Distribuzione: Ubuntu 16.04.1 LTS x86_64
Sesso: Maschile

Re: Problema "dipendenze irrisolte"

Messaggioda Leonethegrey_01 » lunedì 3 aprile 2017, 10:09

giulux Immagine ha scritto:La regola del forum è 1 problema = 1 discussione.
Il tuo secondo problema mi pare sia stato già affrontato più volte e se fai una ricerca dovresti trovare; altrimenti api una nuova discussione.
Guarda qui https://www.google.it/search?as_q=risol ... as_rights=
Ciao.

darò un'occhiata, grazie.
Leonethegrey_01
Prode Principiante
 
Messaggi: 9
Iscrizione: marzo 2017
Distribuzione: ubuntu 16.10
Sesso: Maschile


Torna a Dilemmi del principiante

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 2 ospiti