Windows 10 è nel Grub2 ma non si avvia

Domande e richieste di un principiante alle prime armi con Ubuntu e il mondo GNU/Linux in generale. Per domande specifiche, utilizzare le altre sezioni.
Regole della sezione
In questa sezione possono inserire nuove discussioni solo coloro che fanno parte del livello "Prode Principiante", tutti gli altri possono comunque rispondere regolarmente. Se si fa parte di questo livello e si è registrati al forum prima del 24 aprile 2012, data del passaggio al nuovo forum, consultare questa discussione.

Immagine Come usare UbuntuPrimi passi su Ubuntu Immagine Amministrazione del sistemaComandi di baseInstallare programmiLog di sistemaRiga di comandoSudo
miglioverde
Prode Principiante
Messaggi: 19
Iscrizione: domenica 30 settembre 2018, 22:27
Desktop: Lubuntu 18.04 amd64
Distribuzione: Lubuntu 18.04 amd64
Sesso: Maschile

Windows 10 è nel Grub2 ma non si avvia

Messaggio da miglioverde » lunedì 22 ottobre 2018, 16:30

Ciao a tutti,
ho nuovamente un problema col Grub2.
Ho un pc partizionato con due sistemi operativi (Windows 10 e Ubuntu 18.04).
Ma questa mattina avviandolo normalmente Windows 10, seppur compare nel menù di boot, non si avvia ma mi ritorna la schermata di Grub2.
Windows funziona correttamente: ho provato ad avviarlo con Supergrub ed è tutto ok.
Ho provato a disinstallare e reinstallare Grub2 ma senza esito positivo, il problema rimane.
Qualcuno ha qualche idea migliore? Grazie.
PS: Il pc è in Legacy.

Avatar utente
giulux
Amministratore
Amministratore
Messaggi: 24286
Iscrizione: domenica 10 gennaio 2010, 12:17
Desktop: ubuntu 18.04
Distribuzione: Ubuntu 18.04.3 LTS x86_64
Sesso: Maschile
Località: Roma

Re: Windows 10 è nel Grub2 ma non si avvia

Messaggio da giulux » lunedì 22 ottobre 2018, 16:48

Vediamo che dice

Codice: Seleziona tutto

sudo os-prober

miglioverde
Prode Principiante
Messaggi: 19
Iscrizione: domenica 30 settembre 2018, 22:27
Desktop: Lubuntu 18.04 amd64
Distribuzione: Lubuntu 18.04 amd64
Sesso: Maschile

Re: Windows 10 è nel Grub2 ma non si avvia

Messaggio da miglioverde » lunedì 22 ottobre 2018, 20:48

Codice: Seleziona tutto

/dev/sda3:Windows 10:Windows:chain
Qualche anima buona che possa aiutarmi? Grazie.

miglioverde
Prode Principiante
Messaggi: 19
Iscrizione: domenica 30 settembre 2018, 22:27
Desktop: Lubuntu 18.04 amd64
Distribuzione: Lubuntu 18.04 amd64
Sesso: Maschile

Re: Windows 10 è nel Grub2 ma non si avvia

Messaggio da miglioverde » martedì 23 ottobre 2018, 20:31

Va beh...

Avatar utente
willy54
Rampante Reduce
Rampante Reduce
Messaggi: 6039
Iscrizione: lunedì 18 dicembre 2017, 21:42
Desktop: Xfce, Xorg, Plasma
Distribuzione: Ubuntu studio,Ubuntu, Kubuntu 18.04
Sesso: Maschile
Località: Castell'Alfero (AT)
Contatti:

Re: Windows 10 è nel Grub2 ma non si avvia

Messaggio da willy54 » martedì 23 ottobre 2018, 21:32

Posta per favore la schermata di gparted ed il risultato di

Codice: Seleziona tutto

inxi -Fz
Hp Pavilon 15-CS2093nl Win10, UbuntuStudio 20.04.1 caratteristiche
Toshiba Satellite A660 11M Win7, Win10, Ubuntu 18.04 LTS- Kubuntu 18.04 LTS gparted sda inxi -Fz
disattivare Avvio rapido in Windows10 Installazione su pc Uefi download/file.php?id=31104 -- download/file.php?id=33560

miglioverde
Prode Principiante
Messaggi: 19
Iscrizione: domenica 30 settembre 2018, 22:27
Desktop: Lubuntu 18.04 amd64
Distribuzione: Lubuntu 18.04 amd64
Sesso: Maschile

Re: Windows 10 è nel Grub2 ma non si avvia

Messaggio da miglioverde » mercoledì 24 ottobre 2018, 11:12

Immagine

Codice: Seleziona tutto

System:    Host: samsungserie5 Kernel: 4.15.0-36-generic x86_64 bits: 64
           Desktop: LXDE (Openbox 3.6.1) Distro: Ubuntu 18.04.1 LTS
Machine:   Device: laptop System: SAMSUNG product: 550P5C/550P7C v: P09ABI serial: N/A
           Mobo: SAMSUNG model: NP550P7C-T06IT v: SEC_SW__1234567890ABCD serial: N/A
           BIOS: American Megatrends v: P09ABI.026.141024.dg date: 10/24/2014
Battery    BAT1: charge: 28.3 Wh 98.0% condition: 28.9/57.7 Wh (50%)
CPU:       Quad core Intel Core i7-3630QM (-MT-MCP-) cache: 6144 KB
           clock speeds: max: 3400 MHz 1: 1204 MHz 2: 1258 MHz 3: 1227 MHz
           4: 1245 MHz 5: 1260 MHz 6: 1280 MHz 7: 1270 MHz 8: 1227 MHz
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller
           Card-2: NVIDIA GF108M [GeForce GT 630M]
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting,nouveau (unloaded: fbdev,vesa)
           Resolution: 1600x900@60.06hz
           OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile
           version: 4.2 Mesa 18.0.5
Audio:     Card Intel 7 Series/C216 Family High Def. Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-36-generic
Network:   Card-1: Intel Centrino Advanced-N 6235 driver: iwlwifi
           IF: wlp2s0 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169
           IF: enp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 3008.3GB (36.4% used)
           ID-1: /dev/sda model: ST1000LM024_HN size: 1000.2GB
           ID-2: USB /dev/sdb model: M3_Portable size: 2000.4GB
           ID-3: USB /dev/sdc model: Trans size: 7.7GB
Partition: ID-1: / size: 192G used: 7.3G (5%) fs: ext4 dev: /dev/sda5
           ID-2: swap-1 size: 16.78GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 62.0C mobo: 62.0C gpu: 60.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 225 Uptime: 55 min Memory: 1670.3/7864.0MB
           Client: Shell (bash) inxi: 2.3.56 


Avatar utente
willy54
Rampante Reduce
Rampante Reduce
Messaggi: 6039
Iscrizione: lunedì 18 dicembre 2017, 21:42
Desktop: Xfce, Xorg, Plasma
Distribuzione: Ubuntu studio,Ubuntu, Kubuntu 18.04
Sesso: Maschile
Località: Castell'Alfero (AT)
Contatti:

Re: Windows 10 è nel Grub2 ma non si avvia

Messaggio da willy54 » mercoledì 24 ottobre 2018, 13:31

Con molta probabilità hai un sistema ibrido , ovvero windows è installato in modalità Uefi e Ubuntu in modalità Legacy .
Se confermato questo caso io rifarei la installazione di Ubuntu in modalità Uefi.
Prova a disattivare nel bios/firmware la modalità Legacy e vedi se windows si avvia.
Bisognerebbe poi sapere come è stata fatta la riduzione di Windows, se è stata fatta da Gestione disco di windows o come.
Se fatta con Gparted brobabilmente hai danneggiato la installazione di windows.
Mi lascia poi perplesso che la Swap si presente in sda2, hai forse cancellato una delle partizioni del preinstallato windows?
Hp Pavilon 15-CS2093nl Win10, UbuntuStudio 20.04.1 caratteristiche
Toshiba Satellite A660 11M Win7, Win10, Ubuntu 18.04 LTS- Kubuntu 18.04 LTS gparted sda inxi -Fz
disattivare Avvio rapido in Windows10 Installazione su pc Uefi download/file.php?id=31104 -- download/file.php?id=33560

miglioverde
Prode Principiante
Messaggi: 19
Iscrizione: domenica 30 settembre 2018, 22:27
Desktop: Lubuntu 18.04 amd64
Distribuzione: Lubuntu 18.04 amd64
Sesso: Maschile

Re: Windows 10 è nel Grub2 ma non si avvia

Messaggio da miglioverde » mercoledì 24 ottobre 2018, 13:54

Sia Windows sia Linux sono installati in modalità Legacy. Infatti per molto tempo ho usato i due sistemi senza alcun problema, scegliendo con Grub2 se partire con l'uno o con l'altro. Andare a reinstallare Linux sarebbe inutile. Tutte le partizioni sono state realizzate da disco pulito con GParted e Windows non è mai stato ridimensionato. Inoltre, non mi risulta che la partizione Swap non possa stare in sda2, forse è discutibile che io gli abbia assegnato il doppio della RAM, ma questa è una mia scelta e non riguarda il problema in questione.
Forse sarebbe utile capire come fare ad assegnare al Grub2 per la stringa di Windows un percorso diverso che lo vada a cercare in sda1 anziché sda3. Si potrebbe fare questo tentativo, ma non so dove mettere mano.

Avatar utente
giulux
Amministratore
Amministratore
Messaggi: 24286
Iscrizione: domenica 10 gennaio 2010, 12:17
Desktop: ubuntu 18.04
Distribuzione: Ubuntu 18.04.3 LTS x86_64
Sesso: Maschile
Località: Roma

Re: Windows 10 è nel Grub2 ma non si avvia

Messaggio da giulux » mercoledì 24 ottobre 2018, 15:32

Io proverei, nell'ordine, Boot Repair AmministrazioneSistema/BootRepair e Grub Customizer AmministrazioneSistema/GrubCustomizer

Scrivi risposta

Ritorna a “Dilemmi del principiante”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 2 ospiti