Guida browser Opera

Richieste di nuove guide, traduzioni, offerte di collaborazione e comunicazioni da parte del gruppo agli utenti.

Moderatore: Gruppo Documentazione

Guida browser Opera

Messaggioda Ipnorospo » lunedì 10 novembre 2008, 13:16

Ciao a tutti,

in un post dove un utente chiedeva come installare l'ultima versione di opera io gli ho passato il relativo link del wiki:http://wiki.ubuntu-it.org/InternetRete/Navigazione/Opera?action=show&redirect=BrowserOpera.
La sua risposta è stata che la guida è vecchia e che si riferiva a versioni passate di opera e di ubuntu: in realtà la guida va ancora bene(almeno per quanto riguarda la parte di installazione,la configurazione non l'ho controllata) per cui penso che forse è meglio togliere i riferimenti alle versioni specifiche o comunque aggiornarli.
They see me trollin
Avatar utente
Ipnorospo
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3685
Iscrizione: gennaio 2007

Re: Guida browser Opera

Messaggioda alberto t. » lunedì 10 novembre 2008, 15:43

La guida ha bisogno di essere rivista dal punto di vista stilistico.
Se volete lo posso fare io :)
Avatar utente
alberto t.
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2977
Iscrizione: febbraio 2008

Re: Guida browser Opera

Messaggioda `Alessio` » venerdì 14 novembre 2008, 8:02

Procedi pure, Alberto.
everybody lies
Non usate i PM per contattarmi, non li leggo!
Avatar utente
`Alessio`
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3043
Iscrizione: dicembre 2006
Località: Aprilia

Re: Guida browser Opera

Messaggioda alberto t. » lunedì 8 dicembre 2008, 17:05

Ciao
Ho revisionato la guida qui, aggiustandola stilisticamente e integrandola con quella della documentazione internazionale.
Resterebbe da tradurre i paragrafi "General Plugin Problems" e "Flash problems", non ho potuto farlo io perché vanno oltre le mie conoscenze di inglese. Se c'è qualche volontario traduca e importi i paragrafi dalla pagina internazionale nella mia pagina di prova.

Spero sia di vostro gradimento.
Ciao :)
Avatar utente
alberto t.
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2977
Iscrizione: febbraio 2008

Re: Guida browser Opera

Messaggioda cristian_c » lunedì 8 dicembre 2008, 17:58

alberto t. ha scritto:Ciao
Ho revisionato la guida qui, aggiustandola stilisticamente e integrandola con quella della documentazione internazionale.
Resterebbe da tradurre i paragrafi "General Plugin Problems" e "Flash problems", non ho potuto farlo io perché vanno oltre le mie conoscenze di inglese. Se c'è qualche volontario traduca e importi i paragrafi dalla pagina internazionale nella mia pagina di prova.

Spero sia di vostro gradimento.
Ciao :)


Se ti va bene, posso farlo io  ;D
In caso affermativo, importa i paragrafi in inglese nella tua prove e la si traduce li direttamente  ;)
UP! Unreal Project: il futuro inizia qui. Crusade è tra noi
È scienza!
Avatar utente
cristian_c
Accecante Asceta
Accecante Asceta
 
Messaggi: 23422
Iscrizione: ottobre 2007

Re: Guida browser Opera

Messaggioda alberto t. » lunedì 8 dicembre 2008, 18:03

In caso affermativo, importa i paragrafi in inglese nella tua prove e la si traduce li direttamente

Fatto :)
Cristian_c, fai pure tu le traduzioni nella mia pagina di prova ;)
Già che ci sei, controlla se ho tradotto bene anche gli altri paragrafi ;)
Avatar utente
alberto t.
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2977
Iscrizione: febbraio 2008

Re: Guida browser Opera

Messaggioda cristian_c » martedì 9 dicembre 2008, 16:38

allora, facciamo il punto:

- nella parte sull'installazione manuale del pacchetto deb nel documento originale in fondo c'e' questo:
If you get messages about unmet dependencies type:

sudo apt-get -f install

apt will then install the missing packages.


- poi ho visto che c'e' tutto il paragrafo relativo ai 64 bit, sempre nella documentazione ufficiale. Chiedo se serve questa parte per chi usa Ubuntu 64 bit.

- poi mi chiedo, perchè non lo so  :-[ , se qui
Codice: Seleziona tutto
/usr/bin/gaim-url-handler(gaim)
e qui
Codice: Seleziona tutto
/usr/bin/purple-url-handler(pidgin)
vanno tolti (gaim) e (pidgin). E poi vorrei sapere se Integrazione con Gaim/Pidgin e Integrazione di protocollo con KDE vanno accorpati in un unico paragrafo.  :-\

- per quanto riguarda i due paragrafi segnalati da Alberto, Problemi con i plugin e Problemi con Flash, mi sembra chesiano gia stati tradotti nella stessa pagina. Si possono considerare dei doppioni, e quindi tenersi quelli già in italiano?  ???

- inoltre c'e' questa istruzione che mi risulta poco chiara:
3. Check your ~/.opera/javapath.txt, when using blackdown java, it should be /usr/lib/j2se/1.4/jre/lib/i386


- sempre in Risoluzione dei problemi, potrebbe essere utile aggiungere questa riga?:
Video plugins

Install gecko-mediaplayer and most videos should just work.
UP! Unreal Project: il futuro inizia qui. Crusade è tra noi
È scienza!
Avatar utente
cristian_c
Accecante Asceta
Accecante Asceta
 
Messaggi: 23422
Iscrizione: ottobre 2007

Re: Guida browser Opera

Messaggioda Ipnorospo » martedì 9 dicembre 2008, 18:06

una piccola nota per l'installazione tramite repo: se si aggiunge il repo di opera viene installata l'ultima versione stabile(infatti è presente la versione 9.62) mentre il repo partner di canonical è ancora fermo alla versione 9.27.Penso sia meglio dirlo nella guida...
3. Check your ~/.opera/javapath.txt, when using blackdown java, it should be /usr/lib/j2se/1.4/jre/lib/i386

si riferiscono a questo:http://en.wikipedia.org/wiki/Blackdown_Java  ???
They see me trollin
Avatar utente
Ipnorospo
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3685
Iscrizione: gennaio 2007

Re: Guida browser Opera

Messaggioda Schwitzd » martedì 9 dicembre 2008, 20:29

cristian_c ha scritto:- nella parte sull'installazione manuale del pacchetto deb nel documento originale in fondo c'e' questo:
If you get messages about unmet dependencies type:

sudo apt-get -f install

apt will then install the missing packages.



Se dopo aver installato il pacchetto vi chiede altre dipendenze aggiungete anche questa parte.... fate dei test  ;)
cristian_c ha scritto:- poi ho visto che c'e' tutto il paragrafo relativo ai 64 bit, sempre nella documentazione ufficiale. Chiedo se serve questa parte per chi usa Ubuntu 64 bit.


Io vedo solo che parla dell'installazione su 64bit dove intendi?

cristian_c ha scritto:- poi mi chiedo, perchè non lo so  :-[ , se qui
Codice: Seleziona tutto
/usr/bin/gaim-url-handler(gaim)
e qui
Codice: Seleziona tutto
/usr/bin/purple-url-handler(pidgin)
vanno tolti (gaim) e (pidgin). E poi vorrei sapere se Integrazione con Gaim/Pidgin e Integrazione di protocollo con KDE vanno accorpati in un unico paragrafo.  :-\


Anche qui un bel test può togliere tutti i dubbi

cristian_c ha scritto:- per quanto riguarda i due paragrafi segnalati da Alberto, Problemi con i plugin e Problemi con Flash, mi sembra chesiano gia stati tradotti nella stessa pagina. Si possono considerare dei doppioni, e quindi tenersi quelli già in italiano?  ???


Forse è meglio fare un controllo meglio evitare doppioni

cristian_c ha scritto:- inoltre c'e' questa istruzione che mi risulta poco chiara:
3. Check your ~/.opera/javapath.txt, when using blackdown java, it should be /usr/lib/j2se/1.4/jre/lib/i386

Suppongo che in quel file da qualche parte ci sia quel percorso e penso che si deve controllare se il percorso coincide.

cristian_c ha scritto:
- sempre in Risoluzione dei problemi, potrebbe essere utile aggiungere questa riga?:
Video plugins

Install gecko-mediaplayer and most videos should just work.




Direi di si  ;D
La RAM è come la gnocca non è mai abbastanza!
Pagine Personale sul wiki
Contribuisci alla Documentazione
Avatar utente
Schwitzd
Rampante Reduce
Rampante Reduce
 
Messaggi: 7618
Iscrizione: luglio 2006
Località: Svizzera

Re: Guida browser Opera

Messaggioda cristian_c » martedì 9 dicembre 2008, 22:11

Io vedo solo che parla dell'installazione su 64bit dove intendi?

qui si parla di come far funzionare i plugin a 32 bit in una versione di opera per i 64 bit. Mi sembra che occorra installare le versioni a 32 bit e forzare l'architettura, per quanto riguarda lo spellchecker, si seguono le istruzioni successive:
64-bit

Official package (recommended)

A 64 bit Linux version is officially available at the usual place (Ubuntu 7.10 & 8.04 are detected properly)

Get Opera

32 bit plugins

To get 32bit plugins working in the 64bit Opera (There are other places to get better guides, but here is a quick run through.)

You will want some compatibility-layers:

sudo aptitude install ia32-libs

    * To get Flash 9, get the "flashplugin-nonfree" package from packages.ubuntu.com, for i386.
    *

      To get Adobe acroread, get the packages "acroread", "acroread-escript", and "mozilla-acroread" from packages.ubunu.com. You will have to get the ones for Edgy or earlier because licensing changes prevent inclusion in Feisty and later.

Install each package with the following dpkg command (adapt the package names).

sudo dpkg -i --force-architecture package.deb

The spellchecker will not work with the standard instructions. It appears that the 64-bit dictionary works well with the 32-bit library, thus you only need to manually install the 32-bit library. You must install aspell and a dictionary (such as aspell-en) as the instructions say. A 64-bit version of libaspell will be installed as a dependency.

sudo aptitude install aspell aspell-en

Then you need a 32-bit version of the library libaspell. Get the libaspell package for i386 from packages.ubuntu.com. Then extract it to some directory, such as ~/Desktop, with the following command:

dpkg -x libaspell*.deb ~/Desktop

Now copy the .so file to /usr/lib32 (you need the symlink too):

sudo cp ~/Desktop/usr/lib/libaspell* /usr/lib32/

Restart Opera and you should have a working spell checker.



Suppongo che in quel file da qualche parte ci sia quel percorso e penso che si deve controllare se il percorso coincide.

dopo la spiegazione di deimos, tutto a posto  ;D
UP! Unreal Project: il futuro inizia qui. Crusade è tra noi
È scienza!
Avatar utente
cristian_c
Accecante Asceta
Accecante Asceta
 
Messaggi: 23422
Iscrizione: ottobre 2007

Re: Guida browser Opera

Messaggioda alberto t. » sabato 20 dicembre 2008, 16:28

Ciao
cristian_c, che ne pensi di tradurre l'ultima parte riguardante il paragrafo "32 bit plugins"? (ovviamente già importato nella pagina di prova).
Avatar utente
alberto t.
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2977
Iscrizione: febbraio 2008

Re: Guida browser Opera

Messaggioda cristian_c » sabato 20 dicembre 2008, 16:54

alberto t. ha scritto:Ciao
cristian_c, che ne pensi di tradurre l'ultima parte riguardante il paragrafo "32 bit plugins"? (ovviamente già importato nella pagina di prova).

ok  ;)
UP! Unreal Project: il futuro inizia qui. Crusade è tra noi
È scienza!
Avatar utente
cristian_c
Accecante Asceta
Accecante Asceta
 
Messaggi: 23422
Iscrizione: ottobre 2007

Re: Guida browser Opera

Messaggioda shouldes » sabato 20 dicembre 2008, 17:00

Secondo me basta e avanza mettere il link ad opera, spiegare il force per la 64bit e basta, non serve più altro.

Opera da qualsiasi mirror si scarichi, se il sistema è in italiano si avvia in italiano.
Dalla 9.5, ma forse addirittura da prima (non ricordo), trova sia flashplayer che java, sia installati manualmente che tramite apt, senza fare assolutamente nulla.

ia32-libs è necessario sulla 64bit, quindi va bene che si inserisca questa complicazione nella guida.

L'unica cosa che si dovrebbe spiegare è che non funziona con il plugin totem per firefox, quindi se si usa totem-gstreamer+plugin e/o totem-xine, andrebbe installato xine-pluign, che tra l'altro non funziona con firefox 3, quindi non crea incasinamenti come vlc o mplayer che non fanno più funzionare bene il plugin totem, ne loro stessi funzionano bene in presenza di altri plugin.




Edit: naturalmente mi riferivo a problemi con java, problemi con plugin, problemi con flash, tutte storie vecchissime, ormai inutili.
Tranne lo spellchecker, fin quando non rilasciano una versione 64bit di opera.
Ultima modifica di shouldes il sabato 20 dicembre 2008, 17:11, modificato 1 volta in totale.
Avatar utente
shouldes
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 19407
Iscrizione: febbraio 2008
Desktop: KappaDiE

Re: Guida browser Opera

Messaggioda Schwitzd » sabato 20 dicembre 2008, 17:28

Io direi che il wiki si dovrebbe basare sull'ultima versione del software.... quindi problemi vecchi oramai risolti sono inutile citarli.

shouldes ha scritto:ia32-libs è necessario sulla 64bit, quindi va bene che si inserisca questa complicazione nella guida.

in che senso complicazione?? alla fine è un pacchetto da installare....

shouldes ha scritto:L'unica cosa che si dovrebbe spiegare è che non funziona con il plugin totem per firefox, quindi se si usa totem-gstreamer+plugin e/o totem-xine, andrebbe installato xine-pluign, che tra l'altro non funziona con firefox 3, quindi non crea incasinamenti come vlc o mplayer che non fanno più funzionare bene il plugin totem, ne loro stessi funzionano bene in presenza di altri plugin.

Se conosci bene questo tipo di problema poi metterti daccordo con chi ha scritto la pagina e potete fare un capitoletto ;)
La RAM è come la gnocca non è mai abbastanza!
Pagine Personale sul wiki
Contribuisci alla Documentazione
Avatar utente
Schwitzd
Rampante Reduce
Rampante Reduce
 
Messaggi: 7618
Iscrizione: luglio 2006
Località: Svizzera

Re: Guida browser Opera

Messaggioda alberto t. » sabato 20 dicembre 2008, 17:32

Ciao
Opera da qualsiasi mirror si scarichi, se il sistema è in italiano si avvia in italiano.
Dalla 9.5, ma forse addirittura da prima (non ricordo), trova sia flashplayer che java, sia installati manualmente che tramite apt, senza fare assolutamente nulla.

Quali paragrafi proponi di rimuovere?
Avatar utente
alberto t.
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2977
Iscrizione: febbraio 2008

Re: Guida browser Opera

Messaggioda shouldes » sabato 20 dicembre 2008, 17:48

acroread plugin non l'ho provato, quindi non sono in grado di dire se quella sezione è da rimuovere.

qua:
Inoltre con Strumenti -> Preferenze -> Avanzate -> Download è possibile raggiungere un elenco delle estensioni supportate da Opera (solo deselezionando l'opzione «Nascondi i tipi gestiti da Opera» si avrà l'elenco completo). Una volta selezionata una voce dal menu «Tipo MIME» fare clic su «Modifica» per modificarla.

Potrebbe essere spiegata la situazione di xine-plugin, che praticamente apre tutto, per il resto se ci sono plugin compatibili con opera li trova da solo, già da parecchie versioni.
Edit: inoltre trova anche i programmi esterni predefiniti per aprire i file che non gestisce direttamente, quindi credo sia meglio non far mettere le mani dove non necessario, omettendo questa spiegazione.

Problemi con Flash e Segmentation fault di Opera e problema crash Java con la versione statica, sono storie abbastanza vecchie, e se si da il link direttamente al sito opera si possono eliminare.

Per quanto riguarda l'uso dei repository canonical, secondo me è meglio dare il link al sito, dove si trova sempre l'ulima versione, quindi si snellisce di molto la guida.


Parlo di complicazioni, perché chi si trova le prime volte davanti a queste guide, nel 90% dei casi le segue passo passo senza verificare se i problemi esistono realmente, magari creandoli.

Io al massimo posso dare suggerimenti, non fa per me scrivere guide, sono troppo prolisso, da quello che ho letto siete abbastanza bravi a sintetizzare, per questo voglio complimentarmi.
Ultima modifica di shouldes il sabato 20 dicembre 2008, 17:58, modificato 1 volta in totale.
Avatar utente
shouldes
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 19407
Iscrizione: febbraio 2008
Desktop: KappaDiE

Re: Guida browser Opera

Messaggioda cristian_c » sabato 20 dicembre 2008, 18:00

Allora, ho letto la parte sui plugin a 32 bit  ;)
se vuoi si puo togliere la parte su flash nel paragrafo, java infatti non è menzionata.
Per il resto andrebbe aggiornato il punto su acroread sempre nello stesso paragrafo.
E riportare la parte sul correttore pari pari.(Occorre anche inserire come creare il link simbolico?)

L'unica cosa che si dovrebbe spiegare è che non funziona con il plugin totem per firefox, quindi se si usa totem-gstreamer+plugin e/o totem-xine, andrebbe installato xine-pluign, che tra l'altro non funziona con firefox 3, quindi non crea incasinamenti come vlc o mplayer che non fanno più funzionare bene il plugin totem, ne loro stessi funzionano bene in presenza di altri plugin.

Ti riferisci alla versione di Ubuntu 64 o Ubuntu 32 con opera? In ogni caso faro' delle prove  ;)

E poi vorrei sapere se Integrazione con Gaim/Pidgin e Integrazione di protocollo con KDE vanno accorpati in un unico paragrafo.

Credo di aver chiarito tutti i miei dubbi su questo. Quindi correggerò la traduzione. Praticamente kfmclient exec andrebbe inserito nella finestra in cui si vuole aggiungere un protocollo(yahoo,mail,ecc...) per fare in modo che un file che sfutta quel determinato protocollo , venga aperta con la specifica applicazione predefinita di kde senza menzionare esplicitamente il programma. Questo script andrebbe a cercare il programma con cui eseguire il file dalla lista presente in kcontrol.
"kfm exec" andrebbe inserito in "Apri con un'altra applicazione" e si deve lasciare vuoto il campo dei "Parametri".
Qualcuno che ha kde puo confermare il fatto?
UP! Unreal Project: il futuro inizia qui. Crusade è tra noi
È scienza!
Avatar utente
cristian_c
Accecante Asceta
Accecante Asceta
 
Messaggi: 23422
Iscrizione: ottobre 2007

Re: Guida browser Opera

Messaggioda alberto t. » sabato 20 dicembre 2008, 18:01

Ciao
acroread plugin non l'ho provato, quindi non sono in grado di dire se quella sezione è da rimuovere.

Uhm... Nemmeno io l'ho provata fino in fondo la guida, mi sono semplicemente limitato a revisionare/integrare la guida con quella del wiki internazionale. Oltretutto alcuni paragrafi che sono stati tradotti non mi sono molto chiari (ma se presenti nel wiki internazionale, vuol dire che funzionano, magari sono io che non so usare opera :D :-[ )

Problemi con Flash e Segmentation fault di Opera e problema crash Java con la versione statica, sono storie abbastanza vecchie, e se si da il link direttamente al sito opera si possono eliminare.

Fatto.

Potrebbe essere spiegata la situazione di xine-plugin, che praticamente apre tutto, per il resto se ci sono plugin compatibili con opera li trova da solo, già da parecchie versioni.

Come ho detto sopra, le procedure descritte nel wiki inglese non sono molto chiare (imho), percui non posso nemmeno aggiustare il paragrafo da te citato. Se qualcuno conosce il programma meglio di me, è libero di farlo.

Grazie shouldes per i suggerimenti.
Ciao

edit: cristian_c  mi ha preceduto nel postare
Avatar utente
alberto t.
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2977
Iscrizione: febbraio 2008

Re: Guida browser Opera

Messaggioda cristian_c » sabato 20 dicembre 2008, 18:09

acroread plugin non l'ho provato, quindi non sono in grado di dire se quella sezione è da rimuovere.

Il plugin per acroread l'avevo gia usato in firefox. Posso provarlo con Opera. Il problema è che ho la versione a 32 bit di Ubuntu. Se c'e' qualche sessantaquattrista che vuole fare da cavia provare...

Inoltre con Strumenti -> Preferenze -> Avanzate -> Download è possibile raggiungere un elenco delle estensioni supportate da Opera (solo deselezionando l'opzione «Nascondi i tipi gestiti da Opera» si avrà l'elenco completo). Una volta selezionata una voce dal menu «Tipo MIME» fare clic su «Modifica» per modificarla.

confermo  ;)

Per quanto riguarda l'uso dei repository canonical, secondo me è meglio dare il link al sito, dove si trova sempre l'ulima versione, quindi si snellisce di molto la guida.

quoto  ;D
UP! Unreal Project: il futuro inizia qui. Crusade è tra noi
È scienza!
Avatar utente
cristian_c
Accecante Asceta
Accecante Asceta
 
Messaggi: 23422
Iscrizione: ottobre 2007

Re: Guida browser Opera

Messaggioda shouldes » sabato 20 dicembre 2008, 18:15

Ti riferisci alla versione di Ubuntu 64 o Ubuntu 32 con opera? In ogni caso faro' delle prove  ;)


Con il plugin predefinito di Ubuntu, non funziona ne la i386, ne a 64bit, a quanto pare totem-plugin non è proprio compatibile con opera.
Io ho inserito i percorsi ma non si aprivano gli stessi video che firefox apriva senza problemi.

Per chi ha installato il plugin mplayer o vlc, non ci dovrebbero essere problemi, visto che ha già rimosso quello totem, il problema nasce per chi installa un plugin diverso da xine-plugin senza rimuovere quello totem, visto che firefox non riesce più a riprodurre buona parte dei video che riproduceva.

Un articoletto a parte che eviti molti posti (  edit: ;D post che poi dovrebbe essere posts) "non riesco a riprodurre questo" non sarebbe un male.
Ultima modifica di shouldes il sabato 20 dicembre 2008, 18:21, modificato 1 volta in totale.
Avatar utente
shouldes
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 19407
Iscrizione: febbraio 2008
Desktop: KappaDiE

Successiva

Torna a Gruppo Documentazione

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 4 ospiti