[WIKI] Stampanti Brother - installazione driver

Richieste di nuove guide, traduzioni, offerte di collaborazione e comunicazioni da parte del gruppo agli utenti.

Moderatore: Gruppo Documentazione

Avatar utente
shouldes
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 19407
Iscrizione: domenica 10 febbraio 2008, 21:45
Desktop: KappaDiE

Re: [WIKI] Stampanti Brother - installazione driver

Messaggio da shouldes » venerdì 19 ottobre 2018, 15:02

rai [url=https://forum.ubuntu-it.org/viewtopic.php?p=5086732#p5086732][img]https://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:
shouldes [url=https://forum.ubuntu-it.org/viewtopic.php?p=5085960#p5085960][img]https://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:Siete sicuri che bisogna installare i driver per far funzionare le stampanti brother?
Uso da 4 anni ormai solo Debian con KDE e non installo nulla di specifico per brother, il sistema le rileva e installa in automatico, questo da Jessie in avanti.
Su Ubuntu avete provato a collegarle e basta?
Per gli scanner invece si deve smadonnare un pochino e il driver è sempre quello che non si disinstalla alla buona.
La stampa invece va benissimissimo out of the box, margini pagine e tutto quanto (economy mode, pulizia testine, resa in DPI e tutto il resto), su Stretch avrò provato una decina di modelli, senza installare niente.
Se volete posso farvi la lista pacchetti installata relativa a cups.
Mi sembra assurdo che su Ubuntu si debba fare qualcosa anche con stampanti Brother che hanno un paio d'anni dalla commercializzazione.
Sarò io incapace: su Ubuntu 16.04 e 18.04 la basica stampante HL1110 non funziona senza installare i loro driver, nel senso che viene vista, riceve il comando di stampa e, indipendentemente dal numero di pagine da stampare, parte a emettere indefinitamente pagine bianche.
shouldes ha scritto:
rai ha scritto:EDIT Non avevo letto attentamente dei problemi per a mancato uninstall di driver per scanner prima di avanzamento di versione. Mi pare che le segnalazioni risalgano ad Hardy ( circa 10 anni fa ) e dopo non ce ne sono più. Forse per questo il wiki non ne fa cenno.
Ho dato quel contributo giusto perché il Wiki non ne faceva cenno e il mio avanzamento di versione si è dovuto trasformare d'ufficio in installazione da zero, per colpa del driver dello scanner Brother.
Ancora oggi li devi creare tu i percorsi per far funzionare l'uninstall, quindi niente è cambiato.
OK allora se hai tempo bisognerebbe modificare la pagina del wiki relativa a questi driver per informare chi legge, l'ideale sarebbe che lo facessi tu che hai avuto l'esperienza
Probabilmente su Ubuntu è necessario installare i driver, visto che presenti nei repository, mentre da molti anni sono spariti su Debian e vanno senza fare nulla, quelle che ho potuto testare.

Per quanto riguarda lo scanner, driver necessario, purtroppo lo si deve installare per forza, bisogna solo creare i percorsi che generano errore durante la disinstallazione.

Dovrebbe bastare solo la directory principale /usr/local/Brother/sane/ per far andare l'uninstall.
Non posso testare su Ubuntu perché non ho più Ubuntu a portata di mano, posso testare su Stretch e SID.

Questo li crea tutti ma su Debian non è necessario:
https://forums.linuxmint.com/viewtopic.php?t=185667

Anche su Ubuntu questi li creano tutti:
viewtopic.php?f=75&t=559129

https://forum.ubuntu-fr.org/viewtopic.php?id=1656911

Ci sarebbero da testare i pacchetti più recenti, del 2013, per brscan4, così da vedere se con quelli hanno risolto il problema.
Scompattando il pacchetto.deb il problema sembra presente.
Ma ripeto, è inutile vada a testarlo su una distro diversa da Ubuntu per la guida Ubuntu.
I pacchetti per brscan, brscan2 e brscan3 non sono mai cambiati, per questo il problema non passerà mai di moda, è un bug dei pacchetti.

Scrivi risposta

Ritorna a “Gruppo Documentazione”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 2 ospiti