Sospensione difettosa 16.04

Riconoscimento, installazione e configurazione delle periferiche.

Sospensione difettosa 16.04

Messaggioda battutommy » sabato 23 aprile 2016, 15:37

Ciao a tutti. Sono (circa) alle prime armi con Ubuntu. Finora l'ho sempre usato per motivi universitari, quindi lo avevo installato qualche anno fa, ed anche se non funzionava tutto alla perfezione, non mi creava particolari problemi.
Qualche giorno fa invece mi sono comprato un ssd ed ho deciso di provare a farne il mio unico sistema operativo.
Fondamentalmente l'unico problema che mi crea molto fastidio, è il fatto di non riuscire ad utilizzare la sospensione.

In pratica sospendendo normalmente da pulsante, o dalla tendina in alto a destra, il pc entra correttamente in sospensione, ma al riavvio ogni volta succede una cosa diversa:
-mi rimane una schermata totalmente nera ed il pc diventa inutilizzabile.
-mi appare la schermata di login ma dopo poco mi si blocca
-mi appare una schermata nera (tipo quella che appare premendo Alt+F1) con delle righe che da quello che mi pare di capire riguardano l'usb.
-(molto raramente) funziona tutto ok.

Ho provato un sacco di cose e ho letto molti thread a riguardo, sia su questo forum sia su altri forum, ma non riesco a risolvere :muro:

L'unica cosa che ho notato è che se eseguo da terminale
Codice: Seleziona tutto
sudo sh -c "sync && echo 1 > /sys/power/pm_trace && pm-suspend"
la sospensione si riavvia praticamente senza problemi. (Edit: a quanto pare questo comando funziona meglio degli altri ma a volte fallisce pure lui, solo che quando fallisce è perchè proprio non riesce ad entrare in standby. Una volta riavviato il pc però Ubuntu si accorge che c'è stato un problema e avvia la procedura per inviare l'errore)

Il mio portatile è un asus U36SD e giro con Ubuntu 16.04.
Se c'è bisogno di sapere qualche dettaglio in particolare che può aiutare a capire la fonte del problema ditemelo che cerco di fornirvi tutto l'occorrente. Se invece mi sia sfuggito il thread che parla esattamente di questo problema vi prego di farmelo notare.

Grazie mille!!! :D
Ultima modifica di battutommy il sabato 23 aprile 2016, 15:58, modificato 3 volte in totale.
battutommy
Prode Principiante
 
Messaggi: 4
Iscrizione: maggio 2013
Desktop: ubuntu
Distribuzione: Ubuntu 15.10 x86_64
Sesso: Maschile

Re: Sospensione difettosa 16.04

Messaggioda Mdfalcubo » sabato 23 aprile 2016, 15:45

Sposto in portatili.
"Il genere umano è stimolante, è la gente che non sopporto,, (Linus - Peanuts)
"Se vuoi una mano per essere aiutato la trovi alla fine del tuo braccio,,
Avatar utente
Mdfalcubo
Moderatore Globale
Moderatore Globale
 
Messaggi: 20329
Iscrizione: dicembre 2008
Desktop: Solo XFCE
Distribuzione: Xubuntu 64 bit
Sesso: Maschile

Re: Sospensione difettosa 16.04

Messaggioda steff » sabato 23 aprile 2016, 15:53

Pensavo che ubuntu usasse
Codice: Seleziona tutto
sudo systemctl suspend
di default adesso, cosa succede se usi quel comando?
Hai fatto il backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox
Avatar utente
steff
Moderatore Globale
Moderatore Globale
 
Messaggi: 37919
Iscrizione: febbraio 2007
Località: Toscana
Desktop: LXQt
Distribuzione: Arch Linux 64bit
Sesso: Maschile

Re: Sospensione difettosa 16.04

Messaggioda battutommy » sabato 23 aprile 2016, 17:32

steff Immagine ha scritto:Pensavo che ubuntu usasse
Codice: Seleziona tutto
sudo systemctl suspend
di default adesso, cosa succede se usi quel comando?


Allora. ho fatto qualche prova. Usando il tuo comando la situazione è identica a a quella che ottengo se uso la procedura di sospensione normale.

In particolare mi sono accorto che:
Se imposto "Lock screen after screen turns off" la sospensione non avviene e si impalla prima con una schermata nera.
Se imposto di richiedere la password quando si sveglia dalla sospensione, il pc entra in sospensione, ma quando si sveglia ottengo una schermata tipo questa:
(la foto è troppo grande, uso un link dropbox)
foto
Nel caso in cui non richieda alcuna password e non faccia lo screen lock, il pc si comporta meglio ed entra sempre in sospensione. Solo che non sempre si risveglia, e quando non succede mi rimane la schermata nera.
battutommy
Prode Principiante
 
Messaggi: 4
Iscrizione: maggio 2013
Desktop: ubuntu
Distribuzione: Ubuntu 15.10 x86_64
Sesso: Maschile

Re: Sospensione difettosa 16.04

Messaggioda dallas » martedì 24 maggio 2016, 21:46

battutommy Immagine ha scritto:
steff Immagine ha scritto:Pensavo che ubuntu usasse
Codice: Seleziona tutto
sudo systemctl suspend
di default adesso, cosa succede se usi quel comando?


Allora. ho fatto qualche prova. Usando il tuo comando la situazione è identica a a quella che ottengo se uso la procedura di sospensione normale.

In particolare mi sono accorto che:
Se imposto "Lock screen after screen turns off" la sospensione non avviene e si impalla prima con una schermata nera.
Se imposto di richiedere la password quando si sveglia dalla sospensione, il pc entra in sospensione, ma quando si sveglia ottengo una schermata tipo questa:
(la foto è troppo grande, uso un link dropbox)
foto
Nel caso in cui non richieda alcuna password e non faccia lo screen lock, il pc si comporta meglio ed entra sempre in sospensione. Solo che non sempre si risveglia, e quando non succede mi rimane la schermata nera.


In rete ho letto di diverse persone che hanno risolto installando il kernel 4.6, che però è la versione di sviluppo e quindi potrebbe non essere stabile. Una conferma del fix nel kernel 4.6 potrebbe essere questa: https://bugzilla.kernel.org/show_bug.cgi?id=112781
Avatar utente
dallas
Prode Principiante
 
Messaggi: 217
Iscrizione: aprile 2012
Località: Padova
Desktop: Kde plasma
Distribuzione: Kubuntu 16.04 LTS x86_64
Sesso: Maschile

Re: Sospensione difettosa 16.04

Messaggioda Carrett667 » mercoledì 25 maggio 2016, 9:48

Ho lo stesso identico problema. Ho installato Ubuntu 16.04 sul mio MacBook Pro, allego l'immagine della mia tabella di partizioni (ho 4 gb di ram e 4 gb di swap) Immagine
Carrett667
Prode Principiante
 
Messaggi: 12
Iscrizione: aprile 2016
Distribuzione: Ubuntu 15.10
Sesso: Maschile

Re: Sospensione difettosa 16.04

Messaggioda Carrett667 » mercoledì 25 maggio 2016, 10:26

Ho provato a installare il Kernel 4.6 tramite questa guida, l'installazione è andata a buon fine, ma non è cambiato nulla. Si freeza ancora dopo che sospendo
Guida Kernel 4.6
Carrett667
Prode Principiante
 
Messaggi: 12
Iscrizione: aprile 2016
Distribuzione: Ubuntu 15.10
Sesso: Maschile

Re: Sospensione difettosa 16.04

Messaggioda Carrett667 » mercoledì 29 giugno 2016, 9:09

Ragazzi ho risolto il problema grazie a un video che ho trovato su internet, adesso funziona perfettamente! Nel terminale dovete scrivere i seguenti comandi:
Codice: Seleziona tutto
sudo gedit /etc/default/grub

Sostituire nel file testuale che si aprirà
Codice: Seleziona tutto
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash'"

con
Codice: Seleziona tutto
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor acpi_osi='!Windows 2013' acpi_osi='!Windows 2012'"

Salvare il file, chiuderlo e sempre nel terminale inserire
Codice: Seleziona tutto
sudo update-grub

Dopodiché riavviare DUE VOLTEdi fila il computer, non so perchè due volte ma funziona così quindi ci si accontenta :birra:
Carrett667
Prode Principiante
 
Messaggi: 12
Iscrizione: aprile 2016
Distribuzione: Ubuntu 15.10
Sesso: Maschile

Re: Sospensione difettosa 16.04

Messaggioda dallas » martedì 16 agosto 2016, 17:01

Carrett667 Immagine ha scritto:Ragazzi ho risolto il problema grazie a un video che ho trovato su internet, adesso funziona perfettamente! Nel terminale dovete scrivere i seguenti comandi:
Codice: Seleziona tutto
sudo gedit /etc/default/grub

Sostituire nel file testuale che si aprirà
Codice: Seleziona tutto
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash'"

con
Codice: Seleziona tutto
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor acpi_osi='!Windows 2013' acpi_osi='!Windows 2012'"

Salvare il file, chiuderlo e sempre nel terminale inserire
Codice: Seleziona tutto
sudo update-grub

Dopodiché riavviare DUE VOLTEdi fila il computer, non so perchè due volte ma funziona così quindi ci si accontenta :birra:


Se hai risolto scrivi [RISOLTO] anche nel titolo del primo post ;)
Avatar utente
dallas
Prode Principiante
 
Messaggi: 217
Iscrizione: aprile 2012
Località: Padova
Desktop: Kde plasma
Distribuzione: Kubuntu 16.04 LTS x86_64
Sesso: Maschile


Torna a Driver e periferiche

Chi c’è in linea

Visualizzano questa sezione: trekfan1 e 7 ospiti