problemi di connessione con DHCP e navigazione [ RISOLTO]

Networking, configurazione della connessione, periferiche e condivisione di rete, ecc.

problemi di connessione con DHCP e navigazione [ RISOLTO]

Messaggioda sissi55 » mercoledì 23 gennaio 2019, 12:21

Salve sono nuova sia di Ubuntu che del forum
Sono un'insegnante, per ripristinare alcuni PC dei laboratori della scuola, abbiamo deciso di installare Edubuntu e per provarlo l'ho installato su un PC , la versione ultima Edubuntu 14.04.2 . Installazione ok. Connessione Ok, ha scaricato aggiornamenti. Ieri ho riacceso il PC. ma non si collega più ad Internet con il DHCP automatico gira a vuoto e poi si disconnette. Ho provato a mettere un IP statico e si collega , ma non mi fa navigare.
Qualcuno mi può aiutare risolvere questo problema?
Grazie
Ultima modifica di sissi55 il mercoledì 27 febbraio 2019, 19:47, modificato 1 volta in totale.
sissi55
Prode Principiante
 
Messaggi: 34
Iscrizione: gennaio 2019
Sesso: Femminile

Re: problemi di connessione con DHCP e navigazione

Messaggioda thece » mercoledì 23 gennaio 2019, 12:27

:ciao: e benvenuta sul Forum

sissi55 Immagine ha scritto:Ho provato a mettere un IP statico e ...

Dove? Ci sono molti modi per configurare la rete.

Molto probabilmente ti sei dimenticata di specificare i server DNS.
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 10268
Iscrizione: aprile 2007
Distribuzione: Debian 10 (Buster) - KDE

Re: problemi di connessione con DHCP e navigazione

Messaggioda willy54 » mercoledì 23 gennaio 2019, 13:26

Benvenuta sul Forum
Entra in configurazione della rete wifi nella scheda IPv6 a seconda della versione imposta Disabilita/Ignora, solo i router altamente professionali accettano IPv6.
Configura in generali il nome della rete e la pasword di accesso sono normalmente scritti su una etichetta sul router.
Edubuntu non è aggiornato da anni ed è basato su una versione ancora più vecchia (12.04) di ubuntu, non ritengo sia sicuro per navigare , e molti programmi sono da allora stati aggiornati, credo sia preferibile utilizzare la versione Lubuntu o Xubuntu su pc datati che almeno hanno gli ultimi aggiornamenti in quanto a sicurezza.
Toshiba Satellite A660 11M Intel® Core™ i7 CPU Q 720 @ 1.60GHz × 8, SSD 250 gb + hdd 500 gb ram 2x4 Gb : Win7 - Win10 - Ubuntu 18.04 LTS - Kubuntu 18.04 LTS - - VisualBasic 2008 su win7 gparted sda inxi -Fz disattivare Avvio rapido in Windows10
Una cortesia per favore per chi cerca di aiutarvi, quando la soluzione è trovata, mettete il [Risolto] sul primo post, la discussione può aiutare altri.
Avatar utente
willy54
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2956
Iscrizione: dicembre 2017
Località: Castell'Alfero (AT)
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile

Re: problemi di connessione con DHCP e navigazione

Messaggioda sissi55 » giovedì 24 gennaio 2019, 23:59

Grazie per la risposta
io ho scaricato l'ultima versione di edubuntu la 14.04.2 come ho scritto nel messaggio e proprio edubuntu, perchè fornisce molte applicazioni adatte ai bambini di scuola primaria. Non c'è IPv6, ma solo IPv4. Non è rete wifi ma rete LAN parlo di laboratori informatici della scuola e sono collegati in rete con un server. Il PC appena installato edubuntu si è collegato con IP statico e ha scaricato gli aggiornamenti del sistema. E' dopo l'aggiornamento che si collega ma non mi fa navigare. I DNS li ho specificati.
Comunque accetto il tuo consiglio e provo a scaricare e installare Lubuntu
sissi55
Prode Principiante
 
Messaggi: 34
Iscrizione: gennaio 2019
Sesso: Femminile

Re: problemi di connessione con DHCP e navigazione

Messaggioda thece » venerdì 25 gennaio 2019, 9:08

Allora ci aggiorniamo ad eventuali problemi con Lubuntu.
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 10268
Iscrizione: aprile 2007
Distribuzione: Debian 10 (Buster) - KDE

Re: problemi di connessione con DHCP e navigazione

Messaggioda thece » lunedì 28 gennaio 2019, 20:16

Dall'altra discussione vedo che hai ancora problemi con la configurazione di rete.

Cosa hai usato per impostare la connessione di rete? Il file /etc/network/interfaces oppure Network Manager?

Nel frattempo potresti aprire il terminale, dare i seguenti comandi e postarne qui gli output. Così inizio a farmi un'idea del problema.

Codice: Seleziona tutto
ifconfig
route -n
cat /etc/resolv.conf

Codice: Seleziona tutto
ping -c 4 INDIRIZZO_IP_GATEWAY

dove INDIRIZZO_IP_GATEWAY è quello che viene fuori dal comando route di cui sopra, riga che inizia con 0.0.0.0, colonna Gateway

Codice: Seleziona tutto
ping -c 4 8.8.8.8
ping -c 4 google.it
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 10268
Iscrizione: aprile 2007
Distribuzione: Debian 10 (Buster) - KDE

Re: problemi di connessione con DHCP e navigazione

Messaggioda sissi55 » lunedì 11 febbraio 2019, 11:32

Scusa thece, ma ho avuto problemi di salute e sono stata assente da scuola. Grazie per avermi risposto. E' la prima volta che uso ubuntu, su windows so fare tante cose. ma qui no per cui non so fare quello che mi chiedi. Cosa intendi per terminale? Dimmi come aprirlo su ubuntu, equivale presuppongo al prompt dei comandi di windows? Comunque ti scrivo La configurazione dell'IP statico: iPv4
Indirizzo IP: 192.168.0.121
Indirizzo di broadcast 192.168.0.255
maschera 255.255.255.0
instradamento predefinito 192.168.0.15
DNS primario 8.8.8.8

E non ho usato Network Manager ma da impostazioni.

In un'altra discussione ho letto che dopo il primo aggiornamento non c'era più Network Manager... non è che è questo il problema? Perchè come ti dicevo nella prima discussione, appena io ho collegato il pc alla rete si è subito connesso e ha scaricato gli aggiornamenti ...è stata la seconda volta che si connette, ma non mi fa navigare.
sissi55
Prode Principiante
 
Messaggi: 34
Iscrizione: gennaio 2019
Sesso: Femminile

Re: problemi di connessione con DHCP e navigazione

Messaggioda Sam9999 » lunedì 11 febbraio 2019, 11:58

Riesci a pingare google.it? apri il teminale (ex prompt dei comandi) e scrivi "ping google.it"
Fai un trasceroute a google e vedi dove si ferma...controlla se hai gli strumenti di rete altrimenti è da installare "traceroute google.it" o altro sito tipo facebook.

Essendo in rete di scuola, sicuro che hai abilitata la navigazione ?
Ultima modifica di Sam9999 il lunedì 11 febbraio 2019, 12:01, modificato 2 volte in totale.
-------------
S. @-M.
-------------
Avatar utente
Sam9999
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1587
Iscrizione: giugno 2014
Località: BO
Desktop: Studio Xfce
Distribuzione: Ubuntu 19.04 (Disco Dingo)

Re: problemi di connessione con DHCP e navigazione

Messaggioda sissi55 » lunedì 11 febbraio 2019, 12:01

Trovato il terminale: Faccio quanto mi hai chiesto e ti scrivo tutto
sissi55
Prode Principiante
 
Messaggi: 34
Iscrizione: gennaio 2019
Sesso: Femminile

Re: problemi di connessione con DHCP e navigazione

Messaggioda sissi55 » lunedì 11 febbraio 2019, 12:03

No Sam9999 mi dice unknown host google.it
sissi55
Prode Principiante
 
Messaggi: 34
Iscrizione: gennaio 2019
Sesso: Femminile

Re: problemi di connessione con DHCP e navigazione

Messaggioda Sam9999 » lunedì 11 febbraio 2019, 12:06

Sempre da terminale il comando "ifconfig" che ti restituisce ?

Sicura che il gateway debba essere 192.168.0.15 ?
-------------
S. @-M.
-------------
Avatar utente
Sam9999
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1587
Iscrizione: giugno 2014
Località: BO
Desktop: Studio Xfce
Distribuzione: Ubuntu 19.04 (Disco Dingo)

Re: problemi di connessione con DHCP e navigazione

Messaggioda sissi55 » lunedì 11 febbraio 2019, 12:07

si Sam la navigazione è abilitata...sto parlando con te da un computer del laboratorio e l'altro PC è collegato nella stessa rete LAN
sissi55
Prode Principiante
 
Messaggi: 34
Iscrizione: gennaio 2019
Sesso: Femminile

Re: problemi di connessione con DHCP e navigazione

Messaggioda sissi55 » lunedì 11 febbraio 2019, 12:09

192.168.0.15 è l'Ip del pc ...il Gateway è 192.168.0.255
sissi55
Prode Principiante
 
Messaggi: 34
Iscrizione: gennaio 2019
Sesso: Femminile

Re: problemi di connessione con DHCP e navigazione

Messaggioda Sam9999 » lunedì 11 febbraio 2019, 12:13

Indirizzo IP: 192.168.0.121
Indirizzo di broadcast 192.168.0.255
maschera 255.255.255.0
instradamento predefinito 192.168.0.15


Io qui leggo che l'IP del computer è 121 menre il gateway è 15...

Quindi o non prende bene il dhcp oppure c'è altro.. lo puoi configurare a mano sotto /etc/network editando il file interfaces ?

Sempre non hai scritto il comando ifconfig
-------------
S. @-M.
-------------
Avatar utente
Sam9999
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1587
Iscrizione: giugno 2014
Località: BO
Desktop: Studio Xfce
Distribuzione: Ubuntu 19.04 (Disco Dingo)

Re: problemi di connessione con DHCP e navigazione

Messaggioda sissi55 » lunedì 11 febbraio 2019, 12:18

Thece questo è quanto è uscito Sul terminale non so se ho digitato bene...
pc8@pc8-System-Product-Name:~$
Codice: Seleziona tutto
ifconfig


Codice: Seleziona tutto
eth0      Link encap:Ethernet  IndirizzoHW 00:1b:fc:1d:c4:ab 
          indirizzo inet:192.168.0.121  Bcast:192.168.0.255  Maschera:255.255.255.0
          indirizzo inet6: fe80::21b:fcff:fe1d:c4ab/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:188 overruns:0 carrier:0
          collisioni:0 txqueuelen:1000
          Byte RX:0 (0.0 B)  Byte TX:0 (0.0 B)

lo        Link encap:Loopback locale 
          indirizzo inet:127.0.0.1  Maschera:255.0.0.0
          indirizzo inet6: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1121 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1121 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:1
          Byte RX:89081 (89.0 KB)  Byte TX:89081 (89.0 KB)



pc8@pc8-System-Product-Name:~$
Codice: Seleziona tutto
route -n

Codice: Seleziona tutto
Tabella di routing IP del kernel
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.0.15    0.0.0.0         UG    0      0        0 eth0
192.168.0.0     0.0.0.0         255.255.255.0   U     1      0        0 eth0


pc8@pc8-System-Product-Name:~$
Codice: Seleziona tutto
cat /etc/resolv.conf

Codice: Seleziona tutto
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1


pc8@pc8-System-Product-Name:~$
Codice: Seleziona tutto
ping -c INDIRIZZO_IP_GATEWAY

Codice: Seleziona tutto
ping: bad number of packets to transmit.



pc8@pc8-System-Product-Name:~$
Codice: Seleziona tutto
ping -c 4 8.8.8.8

Codice: Seleziona tutto
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
From 192.168.0.121 icmp_seq=1 Destination Host Unreachable
From 192.168.0.121 icmp_seq=2 Destination Host Unreachable
From 192.168.0.121 icmp_seq=3 Destination Host Unreachable
From 192.168.0.121 icmp_seq=4 Destination Host Unreachable

--- 8.8.8.8 ping statistics ---
4 packets transmitted, 0 received, +4 errors, 100% packet loss, time 3013ms
pipe 3

il ping di google non me lo da dice unknown
Ultima modifica di sissi55 il mercoledì 13 febbraio 2019, 18:38, modificato 1 volta in totale.
sissi55
Prode Principiante
 
Messaggi: 34
Iscrizione: gennaio 2019
Sesso: Femminile

Re: problemi di connessione con DHCP e navigazione

Messaggioda sissi55 » lunedì 11 febbraio 2019, 12:27

Controlla anche tu SAM ...ci sentiamo dopo adesso devo andare in classe...GRAZIE
sissi55
Prode Principiante
 
Messaggi: 34
Iscrizione: gennaio 2019
Sesso: Femminile

Re: problemi di connessione con DHCP e navigazione

Messaggioda Sam9999 » lunedì 11 febbraio 2019, 12:39

La scheda è configurata ma non trova il gateway...

Prova a postare il comando "arp -a" magari restituisce il gateway che appare essere 192.168.0.0 ma non credo possa essere quello.

Nel comando " ping -c INDIRIZZO_IP_GATEWAY" la dicitura INDIRIZZO_IP_GATEWAY va cambiata con l'IP del gateway cioé 192.168.0.14 o altro che ti possono dire i tecnici della rete della scuola quindi sarà il comando "ping -c 192.168.0.14"
-------------
S. @-M.
-------------
Avatar utente
Sam9999
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1587
Iscrizione: giugno 2014
Località: BO
Desktop: Studio Xfce
Distribuzione: Ubuntu 19.04 (Disco Dingo)

Re: problemi di connessione con DHCP e navigazione

Messaggioda thece » lunedì 11 febbraio 2019, 14:02

sissi55 Immagine ha scritto:Scusa thece, ma ho avuto problemi di salute e sono stata assente da scuola. Grazie per avermi risposto.

Figurati.

sissi55 Immagine ha scritto:E' la prima volta che uso ubuntu, su windows so fare tante cose. ma qui no per cui non so fare quello che mi chiedi.
Cosa intendi per terminale?

Il terminale (o shell) è quell'interfaccia tra uomo e computer nella quale è possibile immettere dei comandi per ottenere dei risultati.

sissi55 Immagine ha scritto:Dimmi come aprirlo su ubuntu, equivale presuppongo al prompt dei comandi di windows?

Direi che lo hai già scoperto da te. Si, il terminale è l'equivalente del prompt dei comandi di Windows ... ma anche quello di Windows si chiama terminale (o shell).

sissi55 Immagine ha scritto:Comunque ti scrivo La configurazione dell'IP statico: ...

Diciamo che, fornite così, queste informazioni non sono utili, non sono "attendibili" (ma non per tua malafede).

sissi55 Immagine ha scritto:E non ho usato Network Manager ma da impostazioni.

Il pannello di configurazione grafico della rete, che hai richiamato da Impostazioni, altro non è che un'interfaccia per Network Manager. Quindi stai utilizzando Network Manager.

sissi55 Immagine ha scritto:In un'altra discussione ho letto che dopo il primo aggiornamento non c'era più Network Manager... non è che è questo il problema?

Non credo. Però controlliamo subito con il comando

Codice: Seleziona tutto
dpkg -l | grep -i network

sissi55 Immagine ha scritto:Perchè come ti dicevo nella prima discussione, appena io ho collegato il pc alla rete si è subito connesso e ha scaricato gli aggiornamenti ...è stata la seconda volta che si connette, ma non mi fa navigare.

Per il momento ti lascio nelle mani di @Sam9999 , così quieto le mie smanie di protagonismo. Se vi bloccate, vi do una spintarella.


Aggiungo la consueta frase di rito: come avrai sicuramente già visto in giro per il Forum, per rendere più comprensibile la discussione, dovresti formattare correttamente sia i comandi sia i relativi output racchiudendoli tra i tag [ code ] ... [ /code ] (scritti senza spazi), in modo da ottenere un qualcosa del genere

Codice: Seleziona tutto
COMANDO
...
OUTPUT
...

Puoi applicare i tag automaticamente selezionando il testo che vuoi racchiudere tra di essi e poi premendo il bottone Codice nella pulsantiera posta sopra il riquadro di scrittura.
Sei invitata a modificare il tuo precedente post.
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 10268
Iscrizione: aprile 2007
Distribuzione: Debian 10 (Buster) - KDE

Re: problemi di connessione con DHCP e navigazione

Messaggioda Sam9999 » lunedì 11 febbraio 2019, 15:35

Un esempio, per provare, una volta appurato che il gateway è 192.168.0.15, puoi provare a impostare la rete manualmente dal file interfaces (visto che hai detto che hai la versione Ubuntu 14.04)
Le istruzioni sono al sito web qui linkato

apri il file "sudo nano /etc/network/interfaces:" e dentro commenti

Codice: Seleziona tutto
# auto eth0
# iface eth0 inet dhcp


Poi scrivi sotto
Codice: Seleziona tutto
iface eth0 inet static
address 192.168.0.121
netmask 255.255.255.0
gateway 192.168.0.15
broadcast 192.168.0.255
dns-nameservers 1.1.1.1,1.0.0.1


Altra cosa da provare è editare il file "sudo nano /etc/resolv.conf" ed aggiungere la riga
Codice: Seleziona tutto
options edns0


successivamente riavvia network manager

Codice: Seleziona tutto
sudo service network-manager restart
Ultima modifica di Sam9999 il lunedì 11 febbraio 2019, 15:54, modificato 1 volta in totale.
-------------
S. @-M.
-------------
Avatar utente
Sam9999
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1587
Iscrizione: giugno 2014
Località: BO
Desktop: Studio Xfce
Distribuzione: Ubuntu 19.04 (Disco Dingo)

Re: problemi di connessione con DHCP e navigazione

Messaggioda giulux » lunedì 11 febbraio 2019, 15:46

@sissi55 modifica il tuo post come ti ha spiegato thece: accludo clip d'esempio
0tag_codice.gif
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...
Avatar utente
giulux
Amministratore
Amministratore
 
Messaggi: 22728
Iscrizione: gennaio 2010
Località: Roma
Desktop: xubuntu - ubuntu 18.04
Distribuzione: Ubuntu+Xubuntu 18.04.2 LTS x86_64
Sesso: Maschile

Successiva

Torna a Connessione e configurazione delle reti

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 5 ospiti