risoluzione nomi dopo connessione vpn

Networking, configurazione della connessione, periferiche e condivisioni di rete.
Avatar utente
Emy74
Prode Principiante
Messaggi: 134
Iscrizione: domenica 5 ottobre 2008, 22:41
Località: Turin - Italy

risoluzione nomi dopo connessione vpn

Messaggio da Emy74 »

Ciao a tutti,
ho il mio portatile aziendale con Ubuntu groovy. Utilizzo per connettermi in VPN Openfortigui, funziona tutto correttamente tranne per il fatto che non risolvo i nomi del dominio.
Premetto che la VPN lato azienda l'ho configurata io, impostando il push dei DNS e dei suffissi delle zone di dominio. I parametri vengono correttamente caricati nel resolv.conf, infatti se faccio un dig dal terminale verso un server del mio dominio funziona correttamente:
dig nome_server.suffisso
mentre se cerco di risolvere tramite browser o remmina i nomi non mi vengono risolti.
Avete suggerimenti?
Grazie.
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 11905
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 10 (Buster) - KDE

Re: risoluzione nomi dopo connessione vpn

Messaggio da thece »

:ciao:

nella barra degli indirizzi del browser scrivi http(s)://nome_server.suffisso ?

Sul browser hai impostato un qualche proxy? scusa, visto che il problema lo hai anche su Remmina, le impostazioni del browser non dovrebbero dare problemi

Sempre scrivendo nome_server.suffisso , usando curl o wget i nomi vengono risolti correttamente?

E' possibile vedere il contenuto del file /etc/resolv.conf ?

E' possibile vedere il contenuto della tabella di routing?

Hai provato a tracciare una connessione del browser, di Remmina o qualsiasi altra applicazione "con problemi", con Wireshark o tcpdump per vedere come si sta comportando il tuo sistema "sotto il cofano" ?
Avatar utente
Emy74
Prode Principiante
Messaggi: 134
Iscrizione: domenica 5 ottobre 2008, 22:41
Località: Turin - Italy

Re: risoluzione nomi dopo connessione vpn

Messaggio da Emy74 »

Ciao,
ti rispondi per punti.
- ho provato sul browser nome.suffisso ma non funziona
- questo è il contenuto della tabella di routing:
Tabella di routing IP del kernel
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 192.168.1.1 0.0.0.0 UG 600 0 0 wlo1
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 wlo1
172.16.0.0 0.0.0.0 255.248.0.0 U 0 0 0 ppp0
192.0.2.1 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
192.168.0.0 0.0.0.0 255.255.0.0 U 0 0 0 ppp0
192.168.1.0 0.0.0.0 255.255.255.0 U 600 0 0 wlo1
193.111.20.0 0.0.0.0 255.255.255.128 U 0 0 0 ppp0
193.111.20.130 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
193.111.20.133 192.168.1.1 255.255.255.255 UGH 0 0 0 wlo1
- questo è il contenuto del file resolv.conf
nameserver 192.168.248.3
search winad.p7o p7o priv7o csmtwinad.smauro
nameserver 192.168.248.2
nameserver 192.168.248.3
# This file is managed by man:systemd-resolved(8). Do not edit.
#
# This is a dynamic resolv.conf file for connecting local clients to the
# internal DNS stub resolver of systemd-resolved. This file lists all
# configured search domains.
#
# Run "resolvectl status" to see details about the uplink DNS servers
# currently in use.
#
# Third party programs should typically not access this file directly, but only
# through the symlink at /etc/resolv.conf. To manage man:resolv.conf(5) in a
# different way, replace this symlink by a static file or a different symlink.
#
# See man:systemd-resolved.service(8) for details about the supported modes of
# operation for /etc/resolv.conf.

options edns0 trust-ad
search lan
Come puoi vedere in testa al file mi ha caricato i dns locali e i suffissi.

Da Remmina ho provato a contattare in ssh il server pigato.p7o, la richiesta sarebbe dovuta andare nel tunnel perchè i dns locali nel resolv.conf ci sono e invece no, la query dns è andata verso il dns della connessione wifi e quindi sulla wl01
emy@SATWS124024:~$ sudo tcpdump -i wlo1 -n |grep pigato
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on wlo1, link-type EN10MB (Ethernet), capture size 262144 bytes
11:49:45.641769 IP 192.168.1.198.34978 > 208.67.222.222.53: 1139+ [1au] A? pigato.p7o. (39)
11:49:45.641837 IP 192.168.1.198.46839 > 208.67.222.222.53: 13922+ [1au] AAAA? pigato.p7o. (39)
11:49:45.648285 IP 192.168.1.198.34978 > 208.67.222.222.53: 1139+ A? pigato.p7o. (28)
11:49:45.649207 IP 192.168.1.198.46839 > 208.67.222.222.53: 13922+ AAAA? pigato.p7o. (28)
mentre da come puoi vedere dall'immagine in allegato se faccio il dig verso la stesso server va nel tunnel

Grazie
Allegati
Screenshot_20210223_120355.png
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 11905
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 10 (Buster) - KDE

Re: risoluzione nomi dopo connessione vpn

Messaggio da thece »

Emy74 ha scritto:
martedì 23 febbraio 2021, 12:05
Da Remmina ho provato a contattare in ssh il server pigato.p7o, la richiesta sarebbe dovuta andare nel tunnel perchè i dns locali nel resolv.conf ci sono e invece no, la query dns è andata verso il dns della connessione wifi e quindi sulla wl01
Perdonami ma io il server DNS locale alla connessione WIFI non lo vedo (leggo)

Per curiosità, prova a forzare il file /etc/resolv.conf così

Codice: Seleziona tutto

nameserver 192.168.248.3
search p7o
pulischi la cache DNS e riprova a contattare pigato.p7o


Per una maggiore leggibilità se non è strettamente necessario non postare screenshot e ... frase di rito: come avrai sicuramente già visto in giro per il Forum, per rendere più comprensibile la discussione, dovresti formattare correttamente sia i comandi sia i relativi output racchiudendoli tra i tag [ code ] ... [ /code ] (scritti senza spazi) in modo da ottenere un qualcosa del genere

Codice: Seleziona tutto

COMANDO
...
OUTPUT
...
Puoi applicare i tag automaticamente selezionando il testo che vuoi racchiudere tra di essi e poi premendo il bottone </> (Codice) nella pulsantiera posta sopra il riquadro di scrittura.
Sei invitato a modificare il tuo precedente post.

Immagine
Avatar utente
Emy74
Prode Principiante
Messaggi: 134
Iscrizione: domenica 5 ottobre 2008, 22:41
Località: Turin - Italy

Re: risoluzione nomi dopo connessione vpn

Messaggio da Emy74 »

Ciao,
pulita la cache dns

Codice: Seleziona tutto

sudo systemd-resolve --flush-caches
forzato il file resolv.conf commentando tutte le righe e lasciando solo quelle da te suggerite.

Codice: Seleziona tutto

emy@SATWS124024:~$ cat /etc/resolv.conf 
nameserver 192.168.248.3
search p7o
#search winad.p7o p7o priv7o csmtwinad.smauro
#nameserver 192.168.248.2
#nameserver 192.168.248.3
# This file is managed by man:systemd-resolved(8). Do not edit.
#
# This is a dynamic resolv.conf file for connecting local clients to the
# internal DNS stub resolver of systemd-resolved. This file lists all
# configured search domains.
#
# Run "resolvectl status" to see details about the uplink DNS servers
# currently in use.
#
# Third party programs should typically not access this file directly, but only
# through the symlink at /etc/resolv.conf. To manage man:resolv.conf(5) in a
# different way, replace this symlink by a static file or a different symlink.
#
# See man:systemd-resolved.service(8) for details about the supported modes of
# operation for /etc/resolv.conf.

#options edns0 trust-ad
#search lan
Ho provato a contattare il server tramite remmina ma continua a non funzionare.
Prima mi hai detto che non vedi il dns locale wifi, hai ragione infatti nel resolv.conf non c'è ma se edito l'interfaccia wifi tramite il network-manager li lo vedo.
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 11905
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 10 (Buster) - KDE

Re: risoluzione nomi dopo connessione vpn

Messaggio da thece »

OK, iniziamo a fare un pò più di luce.

Dai il comando

Codice: Seleziona tutto

nmcli connection
ricava il nome della connessione WIFI e usalo per completare il seguente comando

Codice: Seleziona tutto

nmcli -t connection show "NOME_DELLA_CONNESSIONE_WIFI"

Codice: Seleziona tutto

systemd-resolve --no-pager --status
Posta l'output degli ultimi due.


Cose che mi lasciano perplesso:

- anche se attivo, systemd-resove non dovrebbe essere in alcun modo interpellato, poichè non c'e alcuna indicazione che lo riguarda nel file /etc/resolv.conf
- stessa cosa per quanto riguarda il server DNS locale alla tua connessione WIFI

Per quello che ne so io (*) Network Manager ricava dalla connessione configurata/attiva il/i server DNS da interpellare e istruisce il proxy DNS locale - systemd-resolve - per utilizzare quanto ricavato.
A livello di chiamate di sistema, la risoluzione dei nomi si attiene sempre a quanto indicato nel file /etc/resolv.conf . Se in questo file c'è il riferimento al proxy DNS locale

Codice: Seleziona tutto

nameserver 127.0.0.53
viene interrogato systemd-resolve, altrimenti gli altri server DNS configurati.

Il comportamento che hai riportato lo ritengo piuttosto anomalo.



(*) Piccolo test a supporto della mia affermazione

Codice: Seleziona tutto

systemd-resolve --status

Global
       LLMNR setting: no
MulticastDNS setting: no
  DNSOverTLS setting: no
      DNSSEC setting: no
    DNSSEC supported: no

Link 2 (enp0s3)
      Current Scopes: DNS        
DefaultRoute setting: yes        
       LLMNR setting: yes        
MulticastDNS setting: no         
  DNSOverTLS setting: no         
      DNSSEC setting: no         
    DNSSEC supported: no         
  Current DNS Server: 192.168.0.1
         DNS Servers: 192.168.0.1
          DNS Domain: ~.         
                      fritz.box  

Codice: Seleziona tutto

cat /etc/resolv.conf 

nameserver 127.0.0.53     <---<< systemd-resolve
options edns0 trust-ad
search fritz.box

Codice: Seleziona tutto

nslookup google.it

Server:		127.0.0.53
Address:	127.0.0.53#53

Non-authoritative answer:
Name:	google.it
Address: 142.250.180.163
Name:	google.it
Address: 2a00:1450:4002:800::2003

Codice: Seleziona tutto

echo "nameserver 192.168.0.2" | sudo tee /etc/resolv.conf

Codice: Seleziona tutto

cat /etc/resolv.conf 

nameserver 192.168.0.2     <---<< Server DNS inesistente

Codice: Seleziona tutto

nslookup google.it

;; connection timed out; no servers could be reached
Avatar utente
Emy74
Prode Principiante
Messaggi: 134
Iscrizione: domenica 5 ottobre 2008, 22:41
Località: Turin - Italy

Re: risoluzione nomi dopo connessione vpn

Messaggio da Emy74 »

Ciao,
si è tutto un pò anomalo, inizialmente per collegarmi in vpn usavo il Forticlient proprietario e funzionava tutto, unica pecca che avevo sempre l'avviso di certificato non attendibile, allora l'ho disinstallato e ho installato il Forticlient che comprendeva solo la parte di remote access, questo perchè quest'ultima forticlient ha l'opportunità di mettere il flag per ignorare l'errore certificato....ed è qui che son cominciati i problemi, perchè quando facevo disconnetti ci metteva un minuto e mezzo per buttare giù la sessione, così son passato a Openfortigui, tutto bene, la connessione si attacca e si stacca subito, i dns li scrive sul resolv.conf, dal terminale funziona tutto ma dagli applicativi come Remmina e il browser no.
Di seguito l'output dei due comandi.

Codice: Seleziona tutto

emy@SATWS124024:~$ nmcli -t connection show LINUXEMY
connection.id:LINUXEMY
connection.uuid:5586090c-5930-480a-8fed-672f75decef1
connection.stable-id:
connection.type:802-11-wireless
connection.interface-name:
connection.autoconnect:no
connection.autoconnect-priority:0
connection.autoconnect-retries:-1
connection.multi-connect:0
connection.auth-retries:-1
connection.timestamp:1614094998
connection.read-only:no
connection.permissions:
connection.zone:
connection.master:
connection.slave-type:
connection.autoconnect-slaves:-1
connection.secondaries:
connection.gateway-ping-timeout:0
connection.metered:unknown
connection.lldp:default
connection.mdns:-1
connection.llmnr:-1
connection.wait-device-timeout:-1
802-11-wireless.ssid:LINUXEMY
802-11-wireless.mode:infrastructure
802-11-wireless.band:
802-11-wireless.channel:0
802-11-wireless.bssid:
802-11-wireless.rate:0
802-11-wireless.tx-power:0
802-11-wireless.mac-address:
802-11-wireless.cloned-mac-address:
802-11-wireless.generate-mac-address-mask:
802-11-wireless.mac-address-blacklist:
802-11-wireless.mac-address-randomization:default
802-11-wireless.mtu:auto
802-11-wireless.seen-bssids:10:13:31:C7:C0:3D,12:13:31:C7:C0:45
802-11-wireless.hidden:no
802-11-wireless.powersave:default
802-11-wireless.wake-on-wlan:0x1
802-11-wireless-security.key-mgmt:wpa-psk
802-11-wireless-security.wep-tx-keyidx:0
802-11-wireless-security.auth-alg:
802-11-wireless-security.proto:
802-11-wireless-security.pairwise:
802-11-wireless-security.group:
802-11-wireless-security.pmf:0
802-11-wireless-security.leap-username:
802-11-wireless-security.wep-key0:<hidden>
802-11-wireless-security.wep-key1:<hidden>
802-11-wireless-security.wep-key2:<hidden>
802-11-wireless-security.wep-key3:<hidden>
802-11-wireless-security.wep-key-flags:0
802-11-wireless-security.wep-key-type:unknown
802-11-wireless-security.psk:<hidden>
802-11-wireless-security.psk-flags:1
802-11-wireless-security.leap-password:<hidden>
802-11-wireless-security.leap-password-flags:0
802-11-wireless-security.wps-method:0x0
802-11-wireless-security.fils:0
ipv4.method:auto
ipv4.dns:208.67.222.222
ipv4.dns-search:
ipv4.dns-options:
ipv4.dns-priority:0
ipv4.addresses:
ipv4.gateway:
ipv4.routes:
ipv4.route-metric:-1
ipv4.route-table:0
ipv4.routing-rules:
ipv4.ignore-auto-routes:no
ipv4.ignore-auto-dns:no
ipv4.dhcp-client-id:
ipv4.dhcp-iaid:
ipv4.dhcp-timeout:0
ipv4.dhcp-send-hostname:yes
ipv4.dhcp-hostname:
ipv4.dhcp-fqdn:
ipv4.dhcp-hostname-flags:0x0
ipv4.never-default:no
ipv4.may-fail:yes
ipv4.dad-timeout:-1
ipv6.method:auto
ipv6.dns:
ipv6.dns-search:
ipv6.dns-options:
ipv6.dns-priority:0
ipv6.addresses:
ipv6.gateway:
ipv6.routes:
ipv6.route-metric:-1
ipv6.route-table:0
ipv6.routing-rules:
ipv6.ignore-auto-routes:no
ipv6.ignore-auto-dns:no
ipv6.never-default:no
ipv6.may-fail:yes
ipv6.ip6-privacy:-1
ipv6.addr-gen-mode:stable-privacy
ipv6.ra-timeout:0
ipv6.dhcp-duid:
ipv6.dhcp-iaid:
ipv6.dhcp-timeout:0
ipv6.dhcp-send-hostname:yes
ipv6.dhcp-hostname:
ipv6.dhcp-hostname-flags:0x0
ipv6.token:
proxy.method:none
proxy.browser-only:no
proxy.pac-url:
proxy.pac-script:
GENERAL.NAME:LINUXEMY
GENERAL.UUID:5586090c-5930-480a-8fed-672f75decef1
GENERAL.DEVICES:wlo1
GENERAL.IP-IFACE:wlo1
GENERAL.STATE:activated
GENERAL.DEFAULT:yes
GENERAL.DEFAULT6:no
GENERAL.SPEC-OBJECT:/org/freedesktop/NetworkManager/AccessPoint/437
GENERAL.VPN:no
GENERAL.DBUS-PATH:/org/freedesktop/NetworkManager/ActiveConnection/4
GENERAL.CON-PATH:/org/freedesktop/NetworkManager/Settings/4
GENERAL.ZONE:
GENERAL.MASTER-PATH:
IP4.ADDRESS[1]:192.168.1.198/24
IP4.GATEWAY:192.168.1.1
IP4.ROUTE[1]:dst = 0.0.0.0/0, nh = 192.168.1.1, mt = 600
IP4.ROUTE[2]:dst = 169.254.0.0/16, nh = 0.0.0.0, mt = 1000
IP4.ROUTE[3]:dst = 192.168.1.0/24, nh = 0.0.0.0, mt = 600
IP4.ROUTE[4]:dst = 193.111.20.133/32, nh = 192.168.1.1, mt = 0
IP4.DNS[1]:208.67.222.222
IP4.DOMAIN[1]:lan
DHCP4.OPTION[1]:dhcp_lease_time = 43200
DHCP4.OPTION[2]:domain_name = lan
DHCP4.OPTION[3]:domain_name_servers = 208.67.222.222
DHCP4.OPTION[4]:expiry = 1614135314
DHCP4.OPTION[5]:host_name = SATWS124024
DHCP4.OPTION[6]:ip_address = 192.168.1.198
DHCP4.OPTION[7]:next_server = 192.168.1.1
DHCP4.OPTION[8]:requested_broadcast_address = 1
DHCP4.OPTION[9]:requested_domain_name = 1
DHCP4.OPTION[10]:requested_domain_name_servers = 1
DHCP4.OPTION[11]:requested_domain_search = 1
DHCP4.OPTION[12]:requested_host_name = 1
DHCP4.OPTION[13]:requested_interface_mtu = 1
DHCP4.OPTION[14]:requested_ms_classless_static_routes = 1
DHCP4.OPTION[15]:requested_nis_domain = 1
DHCP4.OPTION[16]:requested_nis_servers = 1
DHCP4.OPTION[17]:requested_ntp_servers = 1
DHCP4.OPTION[18]:requested_rfc3442_classless_static_routes = 1
DHCP4.OPTION[19]:requested_root_path = 1
DHCP4.OPTION[20]:requested_routers = 1
DHCP4.OPTION[21]:requested_static_routes = 1
DHCP4.OPTION[22]:requested_subnet_mask = 1
DHCP4.OPTION[23]:requested_time_offset = 1
DHCP4.OPTION[24]:requested_wpad = 1
DHCP4.OPTION[25]:routers = 192.168.1.1
DHCP4.OPTION[26]:subnet_mask = 255.255.255.0
IP6.ADDRESS[1]:fe80::8851:eddc:9a18:d9e1/64
IP6.GATEWAY:
IP6.ROUTE[1]:dst = fe80::/64, nh = ::, mt = 600
IP6.ROUTE[2]:dst = ff00::/8, nh = ::, mt = 256, table=255

Codice: Seleziona tutto

emy@SATWS124024:~$ systemd-resolve --no-pager --status
Global
       LLMNR setting: no
MulticastDNS setting: no
  DNSOverTLS setting: no
      DNSSEC setting: no
    DNSSEC supported: no

Link 2 (eno2)
      Current Scopes: none
DefaultRoute setting: no  
       LLMNR setting: yes 
MulticastDNS setting: no  
  DNSOverTLS setting: no  
      DNSSEC setting: no  
    DNSSEC supported: no  

Link 3 (wlo1)
      Current Scopes: DNS           
DefaultRoute setting: yes           
       LLMNR setting: yes           
MulticastDNS setting: no            
  DNSOverTLS setting: no            
      DNSSEC setting: no            
    DNSSEC supported: no            
  Current DNS Server: 208.67.222.222
         DNS Servers: 208.67.222.222
          DNS Domain: ~.            
                      lan           

Link 4 (virbr0)
      Current Scopes: none
DefaultRoute setting: no  
       LLMNR setting: yes 
MulticastDNS setting: no  
  DNSOverTLS setting: no  
      DNSSEC setting: no  
    DNSSEC supported: no  

Link 5 (virbr0-nic)
      Current Scopes: none
DefaultRoute setting: no  
       LLMNR setting: yes 
MulticastDNS setting: no  
  DNSOverTLS setting: no  
      DNSSEC setting: no  
    DNSSEC supported: no  

Link 11 (ppp0)
      Current Scopes: none
DefaultRoute setting: no  
       LLMNR setting: yes 
MulticastDNS setting: no  
  DNSOverTLS setting: no  
      DNSSEC setting: no  
    DNSSEC supported: no  
Grazie
Avatar utente
Emy74
Prode Principiante
Messaggi: 134
Iscrizione: domenica 5 ottobre 2008, 22:41
Località: Turin - Italy

Re: risoluzione nomi dopo connessione vpn

Messaggio da Emy74 »

Ciao, dall'ultimo comando si vede come la connessione ppp0 non usa i dns nonostante siano scritti nel resolv.conf, in teoria io sia per le richieste verso i server aziendali che le richieste esterne dovrei usare i dns che mi vengono pushati dalla vpn
Avatar utente
Emy74
Prode Principiante
Messaggi: 134
Iscrizione: domenica 5 ottobre 2008, 22:41
Località: Turin - Italy

Re: risoluzione nomi dopo connessione vpn

Messaggio da Emy74 »

Anni fa usavo su un altra macchina dnsmasq, andando a crearmi un file dove impostavo le zone e i server relativi. Se non ricordo male nel resolv.conf dovevo impostare come ricerca il localhost e non il 127.0.0.53, ma adesso il resolv.conf è un link simbolico che viene riscritto a ogni riavvio, quindi non saprei.
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 11905
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 10 (Buster) - KDE

Re: risoluzione nomi dopo connessione vpn

Messaggio da thece »

E' la stessa cosa, hanno solo cambiato il backend

Codice: Seleziona tutto

netstat -tulnp | grep 53

tcp        0      0 127.0.0.53:53           0.0.0.0:*               LISTEN      456/systemd-resolve 
udp        0      0 127.0.0.53:53           0.0.0.0:*                           456/systemd-resolve 

Codice: Seleziona tutto

cat /etc/resolv.conf 

nameserver 127.0.0.53
options edns0 trust-ad
search fritz.box
Hai fatto la prova con curl e/o wget ?
Avatar utente
Emy74
Prode Principiante
Messaggi: 134
Iscrizione: domenica 5 ottobre 2008, 22:41
Località: Turin - Italy

Re: risoluzione nomi dopo connessione vpn

Messaggio da Emy74 »

Gli unici indirizzi che posso provare sono in https, posso farlo ugualmente il test?

Codice: Seleziona tutto

emy@SATWS124024:~$ netstat -tulnp | grep 53
(Non tutti i processi potrebbero essere identificati, le informazioni sui processi non propri
 non saranno mostrate, per visualizzarle tutte bisogna avere privilegi di root.)
tcp        0      0 127.0.0.53:53           0.0.0.0:*               LISTEN      -                   
udp        0      0 127.0.0.53:53           0.0.0.0:*                           -                 
a me non compare 456 systemd resolved
Ultima modifica di Emy74 il martedì 23 febbraio 2021, 17:49, modificato 1 volta in totale.
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 11905
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 10 (Buster) - KDE

Re: risoluzione nomi dopo connessione vpn

Messaggio da thece »

Certo
Avatar utente
Emy74
Prode Principiante
Messaggi: 134
Iscrizione: domenica 5 ottobre 2008, 22:41
Località: Turin - Italy

Re: risoluzione nomi dopo connessione vpn

Messaggio da Emy74 »

Codice: Seleziona tutto

emy@SATWS124024:~$ curl https://ovengine1.priv7o/ovirt-engine/
curl: (6) Could not resolve host: ovengine1.priv7o
Avatar utente
Emy74
Prode Principiante
Messaggi: 134
Iscrizione: domenica 5 ottobre 2008, 22:41
Località: Turin - Italy

Re: risoluzione nomi dopo connessione vpn

Messaggio da Emy74 »

Codice: Seleziona tutto

emy@SATWS124024:~$ dig ovengine1.priv7o

; <<>> DiG 9.16.6-Ubuntu <<>> ovengine1.priv7o
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 28090
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 3

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;ovengine1.priv7o.		IN	A

;; ANSWER SECTION:
ovengine1.priv7o.	360	IN	A	192.168.248.100

;; AUTHORITY SECTION:
priv7o.			43200	IN	NS	localdns.p7o.
priv7o.			43200	IN	NS	dns2.p7o.

;; ADDITIONAL SECTION:
dns2.p7o.		43200	IN	A	192.168.248.3
localdns.p7o.		43200	IN	A	192.168.248.60

;; Query time: 11 msec
;; SERVER: 192.168.248.3#53(192.168.248.3)
;; WHEN: mar feb 23 17:52:11 CET 2021
;; MSG SIZE  rcvd: 138
è pazzesco
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 11905
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 10 (Buster) - KDE

Re: risoluzione nomi dopo connessione vpn

Messaggio da thece »

Non penso che otterrai un risultato diverso, ma se usi nslookup invece di dig ? Avevo letto che funzionano in modo leggermente diverso

Codice: Seleziona tutto

nslookup ovengine1.priv7o
Avatar utente
Emy74
Prode Principiante
Messaggi: 134
Iscrizione: domenica 5 ottobre 2008, 22:41
Località: Turin - Italy

Re: risoluzione nomi dopo connessione vpn

Messaggio da Emy74 »

anche nslookup funziona correttamente

Codice: Seleziona tutto

emy@SATWS124024:~$ nslookup ovengine1.priv7o
Server:		192.168.248.3
Address:	192.168.248.3#53

Name:	ovengine1.priv7o
Address: 192.168.248.100
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 11905
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 10 (Buster) - KDE

Re: risoluzione nomi dopo connessione vpn

Messaggio da thece »

Nelle variabili di ambiente hai mica settato qualche proxy?

Hai mica customizzato il file /etc/hosts?

Codice: Seleziona tutto

cat /etc/hosts
Hai mica customizzato il file /etc/nsswitch.conf?

Codice: Seleziona tutto

cat /etc/nsswitch.conf
Avatar utente
Emy74
Prode Principiante
Messaggi: 134
Iscrizione: domenica 5 ottobre 2008, 22:41
Località: Turin - Italy

Re: risoluzione nomi dopo connessione vpn

Messaggio da Emy74 »

che io ricordi no, questa ubuntu è in piedi solo da un mese
Avatar utente
Emy74
Prode Principiante
Messaggi: 134
Iscrizione: domenica 5 ottobre 2008, 22:41
Località: Turin - Italy

Re: risoluzione nomi dopo connessione vpn

Messaggio da Emy74 »

a quanto pare il problema è solo con Forticlient, perchè verso l'azienda ho anche un openvpn configurata su Network Manager e funziona correttamente

Codice: Seleziona tutto

emy@SATWS124024:~$ systemd-resolve --no-pager --status
Global
       LLMNR setting: no
MulticastDNS setting: no
  DNSOverTLS setting: no
      DNSSEC setting: no
    DNSSEC supported: no

Link 2 (eno2)
      Current Scopes: none
DefaultRoute setting: no  
       LLMNR setting: yes 
MulticastDNS setting: no  
  DNSOverTLS setting: no  
      DNSSEC setting: no  
    DNSSEC supported: no  

Link 3 (wlo1)
      Current Scopes: DNS           
DefaultRoute setting: yes           
       LLMNR setting: yes           
MulticastDNS setting: no            
  DNSOverTLS setting: no            
      DNSSEC setting: no            
    DNSSEC supported: no            
  Current DNS Server: 208.67.222.222
         DNS Servers: 208.67.222.222
          DNS Domain: lan           

Link 11 (tun0)
      Current Scopes: DNS          
DefaultRoute setting: yes          
       LLMNR setting: yes          
MulticastDNS setting: no           
  DNSOverTLS setting: no           
      DNSSEC setting: no           
    DNSSEC supported: no           
  Current DNS Server: 192.168.248.2
         DNS Servers: 192.168.248.2
          DNS Domain: ~.           
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 11905
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 10 (Buster) - KDE

Re: risoluzione nomi dopo connessione vpn

Messaggio da thece »

Magari si trova qualcosa

forticlient resolv.conf issues
Scrivi risposta

Ritorna a “Connessione e configurazione delle reti”

Chi c’è in linea

Visualizzano questa sezione: Google [Bot] e 3 ospiti