Ubuntu 14.04 non funziona wifi con intel PRO/Wireless 3945

Networking, configurazione della connessione, periferiche e condivisioni di rete.
Scrivi risposta
temperino
Prode Principiante
Messaggi: 5
Iscrizione: martedì 21 ottobre 2014, 22:02

Ubuntu 14.04 non funziona wifi con intel PRO/Wireless 3945

Messaggio da temperino » martedì 21 ottobre 2014, 22:35

Ciao,
anche io sono un neofita (ho installato ieri ubuntu), ed ho lo stesso problema con la connessione wifi (il cavo ethernet funziona).
Vedo le reti wireless disponibili, ma quando tento di connetermi alla mia Vodafone Station non si connette.
Ho controllato e ricontrollato la password, ma non è quello.

Non ho una scheda Broadcom ma una intel PRO/Wireless 3945ABG

dopo il comando
lspci -nn | grep -i net
compare:

Codice: Seleziona tutto

 
03:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02)
06:07.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8100/8101L/8139 PCI Fast Ethernet Adapter [10ec:8139] (rev 10)
dopo il comando
rfkill list
compare:

Codice: Seleziona tutto

 
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
dopo il comando
sudo lshw -c network
compare:

Codice: Seleziona tutto

  *-network               
       description: Wireless interface
       product: PRO/Wireless 3945ABG [Golan] Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 02
       serial: 00:13:02:bc:4c:14
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwl3945 driverversion=3.13.0-32-generic firmware=15.32.2.9 latency=0 link=no multicast=yes wireless=IEEE 802.11abg
       resources: irq:45 memory:fe1ff000-fe1fffff
  *-network
       description: Ethernet interface
       product: RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 7
       bus info: pci@0000:06:07.0
       logical name: eth0
       version: 10
       serial: 00:18:f3:32:dc:b9
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=full ip=192.168.1.6 latency=64 link=yes maxlatency=64 mingnt=32 multicast=yes port=MII speed=100Mbit/s
       resources: irq:16 ioport:d800(size=256) memory:feafe400-feafe4ff
Non riesco a capire se è un problema di driver o di impostazioni di connessione.
Cosa mi consigliate?
Ultima modifica di temperino il venerdì 24 ottobre 2014, 20:31, modificato 1 volta in totale.

Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 21448
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64
Località: Pisa

Ubuntu 14.04 non funziona wi-fi - Intel PRO/Wireless 3945ABG

Messaggio da magozurlinux » mercoledì 22 ottobre 2014, 12:27

@temperino

Da terminale postami questo comando:

Codice: Seleziona tutto

dmesg | grep iwl3945
Xubuntu 18.04 LTS amd64 :ciao:

Avatar utente
tokijin
Moderatore Globale
Moderatore Globale
Messaggi: 4305
Iscrizione: mercoledì 3 giugno 2009, 23:10
Desktop: Plasma 5.19.0
Distribuzione: KDE Neon User Edition 5.19 x86_64
Località: Abruzzo

Re: Ubuntu 14.04 non funziona wi-fi - Intel PRO/Wireless 394

Messaggio da tokijin » mercoledì 22 ottobre 2014, 12:59

@temperino ho separato i messaggi dalla discussione in cui ti eri inserito.
È bene unirsi alle discussioni solo quando la situazione è identica.

Ti lascio nelle ottime mani di @magozurlinux :)

Ciao :ciao:
Sei abbruzzese se dopo che ti sei strafogato un chilogrammo di pasta, hai il coraggio di dire alla cuoca "cacc ch'è cott" - Se entra un piccione in casa..chiudi le finestre!
Ubuntu User #28657 - Il mio vecchio hardware - Tag Codice

temperino
Prode Principiante
Messaggi: 5
Iscrizione: martedì 21 ottobre 2014, 22:02

Ubuntu 14.04 non funziona wifi con intel PRO/Wireless 3945

Messaggio da temperino » venerdì 24 ottobre 2014, 19:52

Ciao magozurlinux,
ti ringrazio e chiedo scusa se rispondo solo oggi.

dopo il comando
dmesg | grep iwl3945
compare:

Codice: Seleziona tutto

[   18.088969] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:s
[   18.088974] iwl3945: Copyright(c) 2003-2011 Intel Corporation
[   18.089031] iwl3945 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control
[   18.143264] iwl3945 0000:03:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
[   18.143269] iwl3945 0000:03:00.0: Detected Intel Wireless WiFi Link 3945ABG
[   18.143351] iwl3945 0000:03:00.0: irq 45 for MSI/MSI-X
[   36.052364] iwl3945 0000:03:00.0: loaded firmware version 15.32.2.9
[  279.116071] iwl3945 0000:03:00.0: Queue 0 stuck for 2500 ms.
[  279.116081] iwl3945 0000:03:00.0: On demand firmware reload
[  367.684051] iwl3945 0000:03:00.0: Queue 0 stuck for 2500 ms.
[  367.684060] iwl3945 0000:03:00.0: On demand firmware reload
[  381.248034] iwl3945 0000:03:00.0: Queue 0 stuck for 2500 ms.
[  381.248044] iwl3945 0000:03:00.0: On demand firmware reload
[  409.240051] iwl3945 0000:03:00.0: Queue 0 stuck for 109244 ms.
[  409.240074] iwl3945 0000:03:00.0: On demand firmware reload
[  409.804051] iwl3945 0000:03:00.0: Queue 0 stuck for 109808 ms.
[  532.756051] iwl3945 0000:03:00.0: Queue 0 stuck for 232760 ms.
[  532.756076] iwl3945 0000:03:00.0: On demand firmware reload
[  533.320061] iwl3945 0000:03:00.0: Queue 0 stuck for 233324 ms.
[  552.824036] iwl3945 0000:03:00.0: Queue 2 stuck for 2500 ms.
[  552.824046] iwl3945 0000:03:00.0: On demand firmware reload
[  553.392052] iwl3945 0000:03:00.0: Queue 2 stuck for 253396 ms.
[  553.892052] iwl3945 0000:03:00.0: Queue 2 stuck for 253896 ms.
[  554.392048] iwl3945 0000:03:00.0: Queue 2 stuck for 254396 ms.
[  554.892052] iwl3945 0000:03:00.0: Queue 2 stuck for 254896 ms.
[  555.392056] iwl3945 0000:03:00.0: Queue 2 stuck for 255396 ms.
[  555.892055] iwl3945 0000:03:00.0: Queue 2 stuck for 255896 ms.
[  556.392055] iwl3945 0000:03:00.0: Queue 2 stuck for 256396 ms.
[  556.892047] iwl3945 0000:03:00.0: Queue 2 stuck for 256896 ms.
[  557.392048] iwl3945 0000:03:00.0: Queue 2 stuck for 257396 ms.
[  557.892058] iwl3945 0000:03:00.0: Queue 2 stuck for 257896 ms.
[  557.892080] iwl3945 0000:03:00.0: On demand firmware reload
[  561.960053] iwl3945 0000:03:00.0: Queue 2 stuck for 2500 ms.
[  562.460047] iwl3945 0000:03:00.0: Queue 2 stuck for 3000 ms.
[  562.960048] iwl3945 0000:03:00.0: Queue 2 stuck for 3500 ms.
[  562.960071] iwl3945 0000:03:00.0: On demand firmware reload
[  568.024041] iwl3945 0000:03:00.0: Queue 2 stuck for 2500 ms.
[  568.024051] iwl3945 0000:03:00.0: On demand firmware reload
[  584.088056] iwl3945 0000:03:00.0: Queue 2 stuck for 2500 ms.
[  584.088080] iwl3945 0000:03:00.0: On demand firmware reload
[  616.152058] iwl3945 0000:03:00.0: Queue 2 stuck for 2500 ms.
[  616.152084] iwl3945 0000:03:00.0: On demand firmware reload
[  643.028075] iwl3945 0000:03:00.0: Queue 0 stuck for 343032 ms.
[  643.028086] iwl3945 0000:03:00.0: On demand firmware reload
[  663.592046] iwl3945 0000:03:00.0: Queue 0 stuck for 2500 ms.
[  663.592056] iwl3945 0000:03:00.0: On demand firmware reload
Ho provato a capire cosa vuol dire il messaggio: can't disable ASPM; OS doesn't have ASPM control
Questo [url=http://%20http://askubuntu.com/questions/372363/what-does-r8169-cant-disable-aspm-os-doesnt-have-aspm-control-really-mean]link[/url] dice che ASPM è l'acronimo di Active State Power Management ed è configurabile dal BIOS oppure da OS.
Il link consiglia di dare i seguenti comandi:
sudo apt-get install fwts
sudo fwts aspm


sudo fwts aspm ha creato il seguente file di log:

Codice: Seleziona tutto

Results generated by fwts: Version V14.03.01 (2014-03-27 02:14:17).

Some of this work - Copyright (c) 1999 - 2014, Intel Corp. All rights reserved.
Some of this work - Copyright (c) 2010 - 2014, Canonical.

This test run on 25/10/14 at 20:04:20 on host Linux lincon 3.13.0-37-generic
#64-Ubuntu SMP Mon Sep 22 21:30:01 UTC 2014 i686.

Command: "fwts aspm".
Running tests: aspm.

aspm: PCIe ASPM test.
--------------------------------------------------------------------------------
Test 1 of 2: PCIe ASPM ACPI test.
PCIe ASPM is controlled by Linux kernel.

Test 2 of 2: PCIe ASPM registers test.
WARNING: Test 2, RP 00h:01h.00h L0s not enabled.
WARNING: Test 2, RP 00h:01h.00h L1 not enabled.
WARNING: Test 2, Device 01h:00h.00h L0s not enabled.
WARNING: Test 2, Device 01h:00h.00h L1 not enabled.

ADVICE: The ASPM L0s low power Link state is optimized for short entry and exit
latencies, while providing substantial power savings. Disabling L0s of a PCIe
device may increases power consumption, and will impact the battery life of a
mobile system.


ADVICE: The ASPM L1 low power Link state is optimized for maximum power savings
with longer entry and exit latencies. Disabling L1 of a PCIe device may
increases power consumption, and will impact the battery life of a mobile system
significantly.

PASSED: Test 2, PCIe ASPM setting matched was matched.
WARNING: Test 2, RP 00h:1Ch.01h L0s not enabled.
WARNING: Test 2, RP 00h:1Ch.01h L1 not enabled.
WARNING: Test 2, Device 03h:00h.00h L0s not enabled.
WARNING: Test 2, Device 03h:00h.00h L1 not enabled.

ADVICE: The ASPM L0s low power Link state is optimized for short entry and exit
latencies, while providing substantial power savings. Disabling L0s of a PCIe
device may increases power consumption, and will impact the battery life of a
mobile system.


ADVICE: The ASPM L1 low power Link state is optimized for maximum power savings
with longer entry and exit latencies. Disabling L1 of a PCIe device may
increases power consumption, and will impact the battery life of a mobile system
significantly.

PASSED: Test 2, PCIe ASPM setting matched was matched.
PASSED: Test 2, PCIe ASPM setting matched was matched.

================================================================================
3 passed, 0 failed, 8 warnings, 0 aborted, 0 skipped, 0 info only.
================================================================================


3 passed, 0 failed, 8 warnings, 0 aborted, 0 skipped, 0 info only.

Test Failure Summary
================================================================================

Critical failures: NONE

High failures: NONE

Medium failures: NONE

Low failures: NONE

Other failures: NONE

Test           |Pass |Fail |Abort|Warn |Skip |Info |
---------------+-----+-----+-----+-----+-----+-----+
aspm           |    3|     |     |    8|     |     |
---------------+-----+-----+-----+-----+-----+-----+
Total:         |    3|    0|    0|    8|    0|    0|
---------------+-----+-----+-----+-----+-----+-----+
Vedo che ci sono dei warning ma non ci capisco nulla..... e non credo che il problema sia questo ASPM.

Ancora Grazie
Ciao
Ultima modifica di temperino il venerdì 24 ottobre 2014, 20:38, modificato 4 volte in totale.

Avatar utente
jackynet92
Moderatore Globale
Moderatore Globale
Messaggi: 13413
Iscrizione: sabato 3 settembre 2011, 1:41
Desktop: Mate
Distribuzione: Ubuntu 16.04 64bit
Sesso: Maschile
Località: Torino

Re: Re: [Risolto] Ubuntu 14.04 non funziona internet cavo n

Messaggio da jackynet92 » venerdì 24 ottobre 2014, 19:54

Ciao. Visto che il post è stato scorporato, provvedi a modificarne il titolo

temperino
Prode Principiante
Messaggi: 5
Iscrizione: martedì 21 ottobre 2014, 22:02

Re: Ubuntu 14.04 non funziona wifi con intel PRO/Wireless 39

Messaggio da temperino » venerdì 24 ottobre 2014, 20:34

Fatto
Grazie

Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 21448
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64
Località: Pisa

Re: Ubuntu 14.04 non funziona wifi con intel PRO/Wireless 39

Messaggio da magozurlinux » domenica 26 ottobre 2014, 19:23

Da terminale dai questi comandi:

questo va dato una volta sola

Codice: Seleziona tutto

echo "options iwl_legacy bt_coex_active=N" | sudo tee /etc/modprobe.d/iwl_legacy.conf

Codice: Seleziona tutto

sudo modprobe -rfv iwl3945

Codice: Seleziona tutto

sudo modprobe -v iwl3945 
riavvia il portatile.
Xubuntu 18.04 LTS amd64 :ciao:

temperino
Prode Principiante
Messaggi: 5
Iscrizione: martedì 21 ottobre 2014, 22:02

Re: Ubuntu 14.04 non funziona wifi con intel PRO/Wireless 39

Messaggio da temperino » domenica 26 ottobre 2014, 23:13

Ciao magozurlinux,
purtroppo non va ancora

dopo il comando:
echo "options iwl_legacy bt_coex_active=N" | sudo tee /etc/modprobe.d/iwl_legacy.conf
ha restituito:

Codice: Seleziona tutto

options iwl_legacy bt_coex_active=N
dopo il comando:
sudo modprobe -rfv iwl3945
ha restituito:

Codice: Seleziona tutto

rmmod iwl3945
rmmod iwlegacy
rmmod mac80211
rmmod cfg80211
dopo il comando:
sudo modprobe -v iwl3945
ha restituito:

Codice: Seleziona tutto

insmod /lib/modules/3.13.0-37-generic/kernel/net/wireless/cfg80211.ko 
insmod /lib/modules/3.13.0-37-generic/kernel/net/mac80211/mac80211.ko 
insmod /lib/modules/3.13.0-37-generic/kernel/drivers/net/wireless/iwlegacy/iwlegacy.ko 
insmod /lib/modules/3.13.0-37-generic/kernel/drivers/net/wireless/iwlegacy/iwl3945.ko 

Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 21448
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64
Località: Pisa

Re: Ubuntu 14.04 non funziona wifi con intel PRO/Wireless 39

Messaggio da magozurlinux » lunedì 27 ottobre 2014, 12:16

Da terminale postami questi comandi:

Codice: Seleziona tutto

modinfo iwl3945

Codice: Seleziona tutto

lsmod
Xubuntu 18.04 LTS amd64 :ciao:

Avatar utente
milazzo87
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1958
Iscrizione: sabato 17 dicembre 2011, 16:51
Desktop: GNOME
Distribuzione: Ubuntu 17.10

Re: Ubuntu 14.04 non funziona wifi con intel PRO/Wireless 39

Messaggio da milazzo87 » lunedì 27 ottobre 2014, 12:46

Leggendo su forum di debian, dovrebbe essere sufficiente installare firmware-iwlwifi. Pacchetto che però non è presente nei repo di Ubuntu e, se ho capito bene, è incluso in linux-firmware (aspetto conferma da qualcuno più esperto di me).
La pisciata in compagnia è di sinistra, il cesso è sempre in fondo a destra. [cit. G. Gaber]

Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 21448
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64
Località: Pisa

Re: Ubuntu 14.04 non funziona wifi con intel PRO/Wireless 39

Messaggio da magozurlinux » lunedì 27 ottobre 2014, 19:38

Da terminale dai questo comando:

Codice: Seleziona tutto

sudo iwconfig wlan0 power off 
Xubuntu 18.04 LTS amd64 :ciao:

temperino
Prode Principiante
Messaggi: 5
Iscrizione: martedì 21 ottobre 2014, 22:02

Re: Ubuntu 14.04 non funziona wifi con intel PRO/Wireless 39

Messaggio da temperino » lunedì 27 ottobre 2014, 20:11

il comando
modinfo iwl3945

restituisce:

Codice: Seleziona tutto

filename:       /lib/modules/3.13.0-37-generic/kernel/drivers/net/wireless/iwlegacy/iwl3945.ko
firmware:       iwlwifi-3945-2.ucode
license:        GPL
author:         Copyright(c) 2003-2011 Intel Corporation <ilw@linux.intel.com>
version:        in-tree:s
description:    Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux
srcversion:     C93C31FCEBBAE1F376E495F
alias:          pci:v00008086d00004227sv*sd*bc*sc*i*
alias:          pci:v00008086d00004222sv*sd*bc*sc*i*
alias:          pci:v00008086d00004227sv*sd00001014bc*sc*i*
alias:          pci:v00008086d00004222sv*sd00001044bc*sc*i*
alias:          pci:v00008086d00004222sv*sd00001034bc*sc*i*
alias:          pci:v00008086d00004222sv*sd00001005bc*sc*i*
depends:        iwlegacy,cfg80211,mac80211
intree:         Y
vermagic:       3.13.0-37-generic SMP mod_unload modversions 686 
signer:         Magrathea: Glacier signing key
sig_key:        7A:CF:8E:D9:48:D7:7B:6A:80:F2:4F:59:D5:D8:ED:03:87:AA:B4:26
sig_hashalgo:   sha512
parm:           antenna:select antenna (1=Main, 2=Aux, default 0 [both]) (int)
parm:           swcrypto:using software crypto (default 1 [software]) (int)
parm:           disable_hw_scan:disable hardware scanning (default 1) (int)
parm:           fw_restart:restart firmware in case of error (int)
il comando lsmod
restituisce:

Codice: Seleziona tutto

Module                  Size  Used by
rfcomm                 53664  0 
bnep                   18895  2 
bluetooth             342208  10 bnep,rfcomm
hid_generic            12492  0 
snd_hda_codec_si3054    12864  1 
snd_hda_codec_analog    14537  1 
usbhid                 47070  0 
hid                    87604  2 hid_generic,usbhid
snd_hda_intel          42730  3 
snd_hda_codec         164067  3 snd_hda_codec_si3054,snd_hda_intel,snd_hda_codec_analog
snd_hwdep              13272  1 snd_hda_codec
r852                   17722  0 
coretemp               13195  0 
sm_common              16772  1 r852
nand                   58760  2 r852,sm_common
r592                   17711  0 
nouveau               969577  2 
snd_pcm                85501  3 snd_hda_codec_si3054,snd_hda_codec,snd_hda_intel
nand_ecc               13136  1 nand
nand_bch               13067  1 nand
lpc_ich                16864  0 
bch                    17197  1 nand_bch
nand_ids                8547  1 nand
mtd                    52813  2 nand,sm_common
joydev                 17101  0 
serio_raw              13230  0 
snd_page_alloc         14230  2 snd_pcm,snd_hda_intel
arc4                   12536  2 
snd_seq_midi           13132  0 
mxm_wmi                12893  1 nouveau
memstick               16174  1 r592
snd_seq_midi_event     14475  1 snd_seq_midi
iwl3945                63619  0 
wmi                    18673  2 mxm_wmi,nouveau
iwlegacy               88016  1 iwl3945
ttm                    72725  1 nouveau
video                  18903  1 nouveau
drm_kms_helper         48868  1 nouveau
mac80211              546051  2 iwl3945,iwlegacy
snd_rawmidi            25135  1 snd_seq_midi
asus_laptop            23897  0 
cfg80211              409394  3 iwl3945,iwlegacy,mac80211
mac_hid                13037  0 
snd_seq                55383  2 snd_seq_midi_event,snd_seq_midi
drm                   244037  4 ttm,drm_kms_helper,nouveau
sparse_keymap          13708  1 asus_laptop
input_polldev          13648  1 asus_laptop
snd_seq_device         14137  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              28584  2 snd_pcm,snd_seq
i2c_algo_bit           13197  1 nouveau
snd                    60939  17 snd_hda_codec_si3054,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_hda_codec_analog,snd_seq_midi
parport_pc             31981  0 
soundcore              12600  1 snd
ppdev                  17391  0 
lp                     13299  0 
parport                40836  3 lp,ppdev,parport_pc
8139too                32571  0 
firewire_ohci          35529  0 
8139cp                 27171  0 
firewire_core          61867  1 firewire_ohci
sdhci_pci              18535  0 
psmouse                91329  0 
sdhci                  37779  1 sdhci_pci
mii                    13654  2 8139cp,8139too
crc_itu_t              12627  1 firewire_core
ho provato a eseguire:
sudo iwconfig wlan0 power off

ma la situazione non è cambiata.
ho anche provato a riavviare, ma continua non collegarsi

Itapop
Prode Principiante
Messaggi: 6
Iscrizione: mercoledì 11 marzo 2015, 0:37

RISOLTO: Ubuntu 14.04 non funziona wifi con Intel 3945ABG

Messaggio da Itapop » mercoledì 11 marzo 2015, 0:57

Dopo aver passato qualche ora a provare tutte le possibili soluzioni suggerite in rete ho risolto con l'unica che funziona veramente: eliminare Network Manager e installare WICD. Il primo è infatti incompatibile con i driver (Iwlegaci, Iwl3945,...) della scheda Intel Wifi in questione (3945ABG). Nel mio caso alla connessione stabile si alternavano improvvisamente cicli di sconnessione/riconnessione. Nello sviluppo di Network Manager non è stata curata la compatibilità con i driver di "vecchie" schede Wifi.
Ho provato a cambiare i parametri dei driver, elencabili come segue

Codice: Seleziona tutto

grep -R [[:alnum:]] /sys/module/iwl*/parameters
in tutte le combinazioni possibili, a rilanciare wpa_supplicant.conf (client che negozia l'autenticazione wpa), niente, il log fornito da

Codice: Seleziona tutto

dmesg | grep 3945
conteneva vari "deauthenticating, reason=3" (= “WLAN_REASON_DEAUTH_LEAVING”).

Alla fine, come detto, c'è un'unica soluzione. Con WICD (in repository) tutto a meraviglia. C'è solo da stare attenti a non perdere la connessione nel passaggio tra i due SW.
NB.: è bene disabilitare di default il bluetooth e abilitarlo solo quando necessario, perchè può confliggere con il servizio WIFI. Questo suggerimento è "ufficiale", è contenuto nel sito Intel dedicato al driver.
Ultima modifica di Itapop il mercoledì 11 marzo 2015, 15:11, modificato 2 volte in totale.

Avatar utente
milazzo87
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1958
Iscrizione: sabato 17 dicembre 2011, 16:51
Desktop: GNOME
Distribuzione: Ubuntu 17.10

Re: Ubuntu 14.04 non funziona wifi con intel PRO/Wireless 39

Messaggio da milazzo87 » mercoledì 11 marzo 2015, 10:41

Bene. Se hai risolto, puoi mettere RISOLTO nel titolo.
La pisciata in compagnia è di sinistra, il cesso è sempre in fondo a destra. [cit. G. Gaber]

Avatar utente
giulux
Amministratore
Amministratore
Messaggi: 23991
Iscrizione: domenica 10 gennaio 2010, 12:17
Desktop: ubuntu 18.04
Distribuzione: Ubuntu 18.04.3 LTS x86_64
Sesso: Maschile
Località: Roma

Re: Ubuntu 14.04 non funziona wifi con intel PRO/Wireless 39

Messaggio da giulux » mercoledì 11 marzo 2015, 15:58

itapop [Risolto] va messo davanti al titolo del primo post.

Se vuoi puoi installare questo script che aggiunge un pulsante per mettere [Risolto] con un solo click.
Ciao.
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...

Itapop
Prode Principiante
Messaggi: 6
Iscrizione: mercoledì 11 marzo 2015, 0:37

Re: Ubuntu 14.04 non funziona wifi con intel PRO/Wireless 39

Messaggio da Itapop » mercoledì 11 marzo 2015, 20:54

Uhm, il primo post non è mio, non sono l'autore del 3d, sicuro che posso modificare il titolo? Inoltre mi limito ad affermare come ho risolto nel mio caso (pur con la stessa scheda Wifi e la stessa versione di Ubuntu),

Avatar utente
jackynet92
Moderatore Globale
Moderatore Globale
Messaggi: 13413
Iscrizione: sabato 3 settembre 2011, 1:41
Desktop: Mate
Distribuzione: Ubuntu 16.04 64bit
Sesso: Maschile
Località: Torino

Re: Ubuntu 14.04 non funziona wifi con intel PRO/Wireless 39

Messaggio da jackynet92 » mercoledì 11 marzo 2015, 23:45

No, non puoi modificare il primo. Può farlo l'utente che ha aperto la discussione.

Geak
Prode Principiante
Messaggi: 7
Iscrizione: domenica 14 agosto 2011, 22:35
Desktop: Unity
Distribuzione: Ubuntu 14.04.3 LTS x86_64
Località: Torino

Re: Ubuntu 14.04 non funziona wifi con intel PRO/Wireless 39

Messaggio da Geak » lunedì 9 novembre 2015, 21:55

Salve, ho un problema identico ma non sono in grado di eliminare Network Manager e installare WICD
Ho descritto il mio problema qui (vedere anche i commenti) http://chiedi.ubuntu-it.org/questions/4 ... sione-wifi, credevo si trattasse di un problema della scheda Broadcom, invece il wireless è gestito dalla stessa Intel di questo thread.
Aggiungo però che io non ho problemi di connessione/disconnessione, non è proprio abilitato il pulsante delle wireless.

Prego @magozurlinux e @Itapop di darmi una mano
Eseguendo il comando rfkill list però io ricevo la risposta: Soft blocked: no Hard blocked: yes

Se do il comando sudo lshw -c network risponde "network disabled"

Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 11333
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 10 (Buster) - KDE

Re: Ubuntu 14.04 non funziona wifi con intel PRO/Wireless 39

Messaggio da thece » martedì 10 novembre 2015, 11:09

:ciao:

Innanzitutto ti invito ad aprire una nuova discussione tutta tua piuttosto che andare a riesumare una vecchia ...

Ti suggerisco inoltre di dare una letta a questa discussione su come iniziarne una nuova, inerente a problemi con schede di rete

Ho letto quanto hai scritto, molto probabilmente occorrerà andare a disfare quanto da te già fatto e procedere con altre soluzioni

Geak
Prode Principiante
Messaggi: 7
Iscrizione: domenica 14 agosto 2011, 22:35
Desktop: Unity
Distribuzione: Ubuntu 14.04.3 LTS x86_64
Località: Torino

Re: Ubuntu 14.04 non funziona wifi con intel PRO/Wireless 39

Messaggio da Geak » sabato 14 novembre 2015, 22:06

Ho creato la nuova discussione qui
Grazie per la pagina-guida.

Scrivi risposta

Ritorna a “Connessione e configurazione delle reti”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 2 ospiti