Condivisioni non funzionano

Networking, configurazione della connessione, periferiche e condivisioni di rete.
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 21714
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 20.10 e 21.04 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Condivisioni non funzionano

Messaggio da trekfan1 »

Alla fine mi arrendo a chiedere aiuto, ho cercato e provato non so più quante soluzioni trovate su questo forum, su quello inglese e altri posti usando google, ma da un pò di tempo riesco a malapena ad accedere ad uno dei miei pc con win10 usando il mio pc con ubuntu, gli altri proprio nulla da fare devo usare un win10 virtuale, cmq la sostanza è che ho la rete LAN con un pò di problemi, cmq procediamo con ordine, questo è il mio smb.conf

Codice: Seleziona tutto

[global] 
	workgroup = <miogruppo>
        client lanman auth = No 
	server string = %h server (Samba, Ubuntu) 
	dns proxy = no 
	name resolve order = bcast host lmhosts wins 
	os level = 33 
	log file = /var/log/samba/log.%m 
	max log size = 1000 
	#syslog = 0 
	security = user
        map to guest = Bad User 
	passdb backend = tdbsam 
	obey pam restrictions = yes 
	unix password sync = yes 
	passwd program = /usr/bin/passwd %u 
	passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* . 
	pam password change = yes 
	map to guest = bad user 
	usershare allow guests = yes 
	wins support = yes 
	
[printers] 
   comment = All Printers 
   browseable = no 
   path = /var/spool/samba 
   printable = yes 
   guest ok = no 
   read only = yes 
   create mask = 0700 


[print$] 
   comment = Printer Drivers 
   path = /var/lib/samba/printers 
   browseable = yes 
   read only = yes 
   guest ok = no 
Chiaramente dove ho messo <miogruppo> c'è il nome del mio gruppo.
Pike
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 4904
Iscrizione: domenica 20 gennaio 2008, 1:13
Desktop: Kubuntu
Distribuzione: 20.04 x64
Contatti:

Re: Condivisioni non funzionano

Messaggio da Pike »

Chi fa da client?
Chi fa da server?

Non è chiaro dal tuo post.
Sono colui che fa cose che non servono...
Secondo Principio di Dilbert, di Scott Adams. "Si parte dalla certezza che siamo tutti idioti". Ed alcuni su questo mi ab-battono alla grande.
Come certificato dalla moderazione, incivile e maleducato. You have been warned.
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 21714
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 20.10 e 21.04 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: Condivisioni non funzionano

Messaggio da trekfan1 »

ho 3 pc Win10 (due fissi e un portatile) e un portatile con Ubuntu, tecnicamente non ci dovrebbe essere nessun server, cmq solo al pc1 riesco ad accedere, agli altri mi da l'errore "Impossibile accedere alla posizione recupero dell'elenco delle condivisioni dal server non riuscito: connessione scaduta"
Pike
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 4904
Iscrizione: domenica 20 gennaio 2008, 1:13
Desktop: Kubuntu
Distribuzione: 20.04 x64
Contatti:

Re: Condivisioni non funzionano

Messaggio da Pike »

Anche se non hai un unico computer che è il server centrale di rete, ad ogni connessione hai sempre un client ed un server.
Il server è quello che ha la condivisione attiva. Il client è quello che cerca di accedervi.

Dalla tua descrizione, hai
PC1Win10
PC2Win10
Lap1Win10
Lap2Linux (non hai esplicitato la Distro, nel profilo ce ne sono 2. Puoi fornire maggiori dettagli?)

Ti pregherei, se riesci, di fare tutte le prove incrociate, evidenziandole come
Client -> Server = Messaggio di errore (username usato, con la computazione esatta).

Inoltre, alcune domande sui pc Windows.
-Sono tutti Fall Creator Update (1709)?
-Sono dotati di utenti con password? Gli utenti in oggetto sono account Microsoft o utenti locali? (verifica tramite il comando

Codice: Seleziona tutto

whoami
dal prompt se c'è coincidenza tra il nome che vedi in Windows ed il reale nome utente)
-Le condivisioni su questi computer come sono state realizzate? (linka una guida che lo spieghi, per piacere)
-La rete che usi come viene classificata dal PC? Pubblica o Privata?
-Il firewall di windows consente di visualizzare le condivisioni? (ti sconsiglio di abilitare questa funzione per la rete pubblica, piuttosto inserisci tra le reti private quella a cui sei connesso.
Sono colui che fa cose che non servono...
Secondo Principio di Dilbert, di Scott Adams. "Si parte dalla certezza che siamo tutti idioti". Ed alcuni su questo mi ab-battono alla grande.
Come certificato dalla moderazione, incivile e maleducato. You have been warned.
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 21714
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 20.10 e 21.04 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: Condivisioni non funzionano

Messaggio da trekfan1 »

risposte sui pc windows:

1) Si sono tutti 1709
2) No, dato che li uso solo io nessun utente windows ha la password e sono tutti locali, nessun account microsoft
3) Mi visualizza nomepc\nomeutente
4) Le ho create usando la procedura di condivisione standard di windows e aggiungendo Everyone con controllo completo
5) Privata
6) Sui pc windows uso Norton ma anche disattivandolo temporaneamente non cambia la situazione
7) In quanto al fatto che ci sono due versioni nel profilo è perché sul portatile con ubuntu ho un dual boot stabile/sviluppo
8) Tutti i pc hanno ip statico con OpenDNS come server DNS
Pike
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 4904
Iscrizione: domenica 20 gennaio 2008, 1:13
Desktop: Kubuntu
Distribuzione: 20.04 x64
Contatti:

Re: Condivisioni non funzionano

Messaggio da Pike »

Norton ha la funzione di firewall? Se sì, considera la rete locale affidabile?

Il fatto che siano presenti utenti senza password è un'arma a doppio taglio, per me...
Se crei in ogni computer un utente con password (non necessariamente amministratore di PC, basta "standard" nella nomenclatura Windows 10) puoi usare NomePC\Nomeutenteconpassword come login e la relativa password per autenticarti sulla cartella (previe autorizzazioni di condivision e di filesystem sulla stessa).
In termini di sicurezza autorizzare everyone è male, più che altro perchè se ti gabolano qualcosa (i laptop vanno a spasso) dentro a quelle cartelle entrano...

Inoltre, per quanto riguarda linux, sarebbe saggio chiedere al client di usare il protocollo SMBv2, in quanto di recente Microsoft ha disabilitato via patch il vecchio SMBv1 (con meno layer di sicurezza integrati e con qualche vulnerabilità in più)
Sono colui che fa cose che non servono...
Secondo Principio di Dilbert, di Scott Adams. "Si parte dalla certezza che siamo tutti idioti". Ed alcuni su questo mi ab-battono alla grande.
Come certificato dalla moderazione, incivile e maleducato. You have been warned.
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 11463
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 10 (Buster) - KDE

Re: Condivisioni non funzionano

Messaggio da thece »

:ciao:
trekfan1 [url=https://forum.ubuntu-it.org/viewtopic.php?p=5040986#p5040986][img]https://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto: ... ma da un pò di tempo riesco a malapena ad accedere ad uno dei miei pc con win10 usando il mio pc con ubuntu ...
Se il problema sta nella connessione dal PC Ubuntu verso il PC Windows allora postare il contenuto del file /etc/samba/smb.conf (*) non serve a nulla. Quel file sovrintende alla configurazione del servizio Samba (il lato server) sul PC Ubuntu.

Il concetto di client e server è relativo ... al servizio, non all'etichetta che tu hai o vuoi appiccicare al tuo PC. Se il tuo PC eroga un servizio, ad esempio Samba, allora per quel servizio il tuo PC è un server e i PC che ci si connettono sono i client.

I sistemi Linux, in generale, mal digeriscono l'assenza di password, quindi molto probabilmente ripristinare l'autenticazione con password sui PC WIndows e sugli share risolverà il problema.

Per qualche dettaglio in più, potresti installare sul tuo PC nmap ed utilizzarlo per scansionare il servizio di "Condivisione file e stampanti" (aka Samba) sui PC Windows.

Comando:

Codice: Seleziona tutto

nmap -sS -sU -A -p T:139,445,U:137,138 --script smb-enum-shares <INDIRIZZO IP PC WINDOWS>

(*) comunque migliorabile
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 21714
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 20.10 e 21.04 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: Condivisioni non funzionano

Messaggio da trekfan1 »

@Pike il mio portatile con win10 è usato alla stregua di un fisso e NON si muove da casa, i pc li uso SOLO IO, in quanto ad accedere al pc da ubuntu, quando riesco ad accedere, devo digitare il nomepc come utente e il nome utente come password, in quanto a Norton è ovvio che è impostato per considerare la rete locale AFFIDABILE! Il problema è nato solo recentemente, fino a poco tempo fa funzionava tutto ok.

Output di nmap

Codice: Seleziona tutto

nmap -sS -sU -A -p T:139,445,U:137,138 --script smb-enum-shares 192.168.1.2

Starting Nmap 7.60 ( https://nmap.org ) at 2018-02-08 12:12 CET
Nmap scan report for 192.168.1.2
Host is up (0.0017s latency).

PORT    STATE         SERVICE       VERSION
139/tcp open          netbios-ssn   Microsoft Windows netbios-ssn
445/tcp open          microsoft-ds?
137/udp open          netbios-ns    Microsoft Windows 10 netbios-ns (workgroup: miogruppo)
138/udp open|filtered netbios-dgm
MAC Address: 98:E7:F4:5B:C2:4F (Hewlett Packard)
Warning: OSScan results may be unreliable because we could not find at least 1 open and 1 closed port
Aggressive OS guesses: Microsoft Windows Longhorn (93%), Microsoft Windows 10 10586 - 14393 (89%), Microsoft Windows 10 build 10074 - 14393 (89%), Microsoft Windows Server 2008 SP1 (89%), Microsoft Windows Server 2008 SP2 or Windows 10 or Xbox One (89%), Version 6.1 (Build 7601: Service Pack 1) (89%), Microsoft Windows 7 or Windows Server 2008 (89%), Microsoft Windows 7 SP0 - SP1, Windows Server 2008 SP1, Windows Server 2008 R2, Windows 8, or Windows 8.1 Update 1 (89%), Microsoft Windows 8.1 R1 (89%), Microsoft Windows 10 (88%)
No exact OS matches for host (test conditions non-ideal).
Network Distance: 1 hop
Service Info: Host: PC2; OS: Windows; CPE: cpe:/o:microsoft:windows, cpe:/o:microsoft:windows_10

TRACEROUTE
HOP RTT     ADDRESS
1   1.65 ms 192.168.1.2

OS and Service detection performed. Please report any incorrect results at https://nmap.org/submit/ .
Nmap done: 1 IP address (1 host up) scanned in 118.92 seconds
Il router è un router fibra TIM nome in codice "Baffo rosso" AGTVF 5.3.3

Immagine
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 11463
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 10 (Buster) - KDE

Re: Condivisioni non funzionano

Messaggio da thece »

La scansione con nmap non ha rilevato alcun share sul PC Windows di IP 192.168.1.2. Per ulteriore verifica prova anche con smbclient

Codice: Seleziona tutto

smbclient -L 192.168.1.2 -N
Verifica anche che sul firewall di Windows sia permesso l'utilizzo del servizio "Condivisione Files e Stampanti". Eventualmente prova anche una scansione con il firewall di Windows temporanemente disabilitato.
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 21714
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 20.10 e 21.04 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: Condivisioni non funzionano

Messaggio da trekfan1 »

Codice: Seleziona tutto

protocol negotiation failed: NT_STATUS_CONNECTION_RESET
e cmq è condivisa la partizione Dati, le opzioni di Norton (è quello il firewall predefinito) sono impostate per mettere la rete in "attendibilità totale" e il pannello in condivisioni di rete è settato esattamente come in questa immagine (dato che poi è presa giusto da uno dei miei pc)
Immagine
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 11463
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 10 (Buster) - KDE

Re: Condivisioni non funzionano

Messaggio da thece »

Spegni il firewall (di Norton, di Windows, quel che è ... ) e rifai i test.
Se il problema è sulla connessione, ma non mi sembrava, dovrebbe essere evidenziato anche dall'autput di questi comandi (no, cavolata)

nc -v <INDIRIZZO IP PC WINDOWS> 139
nc -v <INDIRIZZO IP PC WINDOWS> 445
nc -v -u <INDIRIZZO IP PC WINDOWS> 137
nc -v -u <INDIRIZZO IP PC WINDOWS> 138



PS: mi spiace ma al momento non sono in grado di visualizzare le immagini, quindi non so cosa hai postato
Ultima modifica di thece il giovedì 8 febbraio 2018, 14:04, modificato 3 volte in totale.
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 21714
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 20.10 e 21.04 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: Condivisioni non funzionano

Messaggio da trekfan1 »

Stesso risultato anche con il firewall di norton spento
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 11463
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 10 (Buster) - KDE

Re: Condivisioni non funzionano

Messaggio da thece »

Intendi: stesso risultato su questo comando?

Codice: Seleziona tutto

smbclient -L 192.168.1.2 -N

Hai provato a ripristinare l'autenticazione sullo share di Windows? Mi sono fatto l'idea che il problema sia lì (dall'output del comando smbclient)



PS: quando diciamo, per maggiore chiarezza espositiva, fai Cut&Paste sia del comando sia del suo output direttamente dal terminale ... vale anche per moderatori del Forum
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 21714
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 20.10 e 21.04 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: Condivisioni non funzionano

Messaggio da trekfan1 »

Quale parte di stesso risultato non è chiaro? L'output è lo stesso identico, cmq lo posto

Codice: Seleziona tutto

nmap -sS -sU -A -p T:139,445,U:137,138 --script smb-enum-shares 192.168.1.2

Starting Nmap 7.60 ( https://nmap.org ) at 2018-02-08 14:15 CET
Nmap scan report for 192.168.1.2
Host is up (-0.019s latency).

PORT    STATE         SERVICE      VERSION
139/tcp open          netbios-ssn  Microsoft Windows netbios-ssn
445/tcp open          microsoft-ds Microsoft Windows 7 - 10 microsoft-ds (workgroup: miogruppo)
137/udp open          netbios-ns   Microsoft Windows netbios-ns (workgroup: miogruppo)
138/udp open|filtered netbios-dgm
MAC Address: 98:E7:F4:5B:C2:4F (Hewlett Packard)
Warning: OSScan results may be unreliable because we could not find at least 1 open and 1 closed port
Aggressive OS guesses: Microsoft Windows Longhorn (94%), Microsoft Windows 10 10586 - 14393 (92%), Microsoft Windows 10 build 10074 - 14393 (92%), Microsoft Windows Server 2008 SP2 or Windows 10 or Xbox One (92%), Microsoft Windows 7 SP0 - SP1, Windows Server 2008 SP1, Windows Server 2008 R2, Windows 8, or Windows 8.1 Update 1 (92%), Microsoft Windows 8.1 R1 (92%), Microsoft Windows Server 2008 SP1 (91%), Microsoft Windows 7 (91%), Microsoft Windows 7 or 8.1 R1 (91%), Microsoft Windows 7 Professional SP1 (91%)
No exact OS matches for host (test conditions non-ideal).
Network Distance: 1 hop
Service Info: Host: ENRICO2; OS: Windows; CPE: cpe:/o:microsoft:windows

TRACEROUTE
HOP RTT ADDRESS
1   --  192.168.1.2

OS and Service detection performed. Please report any incorrect results at https://nmap.org/submit/ .
Nmap done: 1 IP address (1 host up) scanned in 119.63 seconds
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 11463
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 10 (Buster) - KDE

Re: Condivisioni non funzionano

Messaggio da thece »

Scusa, errore mio, intedevo che questo era il test da ripetere a firewall spento

Codice: Seleziona tutto

smbclient -L <INDIRIZZO IP PC WINDOWS> -N
se è come credo
Hai provato a ripristinare l'autenticazione sullo share di Windows? Mi sono fatto l'idea che il problema sia lì (dall'output del comando smbclient)
il problema è sulla connessione a livello di protocollo CIFS e il test con nmap non l'evidenzia.
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 21714
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 20.10 e 21.04 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: Condivisioni non funzionano

Messaggio da trekfan1 »

Ok, ecco l'output

Codice: Seleziona tutto

smbclient -L 192.168.1.2 -N
OS=[Windows 10 Pro 16299] Server=[Windows 10 Pro 6.3]

        Sharename       Type      Comment
        ---------       ----      -------
        ADMIN$          Disk      Amministrazione remota
        Disco1          Disk      
        Disco2          Disk      
        C$              Disk      Condivisione predefinita
        D$              Disk      Condivisione predefinita
        IPC$            IPC       IPC remoto
        Z$              Disk      Condivisione predefinita
Connection to 192.168.1.2 failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)
NetBIOS over TCP disabled -- no workgroup available
EDIT

Questo invece è nmap sul PC1:

Codice: Seleziona tutto

Starting Nmap 7.60 ( https://nmap.org ) at 2018-02-08 15:07 CET
Nmap scan report for 192.168.1.1
Host is up (0.0050s latency).

PORT    STATE         SERVICE      VERSION
139/tcp open          netbios-ssn  Microsoft Windows netbios-ssn
445/tcp open          microsoft-ds Microsoft Windows 7 - 10 microsoft-ds (workgroup: miogruppo)
137/udp open          netbios-ns   Microsoft Windows 10 netbios-ns (workgroup: miogruppo)
138/udp open|filtered netbios-dgm
MAC Address: 34:64:A9:31:2B:B7 (Hewlett Packard)
Warning: OSScan results may be unreliable because we could not find at least 1 open and 1 closed port
Aggressive OS guesses: Microsoft Windows Longhorn (93%), Microsoft Windows 10 10586 - 14393 (92%), Microsoft Windows 10 build 10074 - 14393 (92%), Microsoft Windows Server 2008 SP2 or Windows 10 or Xbox One (92%), Microsoft Windows 7 SP0 - SP1, Windows Server 2008 SP1, Windows Server 2008 R2, Windows 8, or Windows 8.1 Update 1 (92%), Microsoft Windows Server 2008 R2 SP1 (91%), Microsoft Windows 7 or 8.1 R1 (91%), Microsoft Windows Vista or Windows 7 SP1 (91%), Microsoft Windows Vista SP0 - SP2, Windows Server 2008, or Windows 7 Ultimate (91%), Microsoft Windows Vista SP2, Windows 7, or Windows 7 SP1 (91%)
No exact OS matches for host (test conditions non-ideal).
Network Distance: 1 hop
Service Info: Host: PC1; OS: Windows; CPE: cpe:/o:microsoft:windows, cpe:/o:microsoft:windows_10

Host script results:
| smb-enum-shares: 
|   account_used: guest
|   \\192.168.1.1\ADMIN$: 
|     Type: STYPE_DISKTREE_HIDDEN
|     Comment: Amministrazione remota
|     Anonymous access: <none>
|     Current user access: <none>
|   \\192.168.1.1\Disco2: 
|     Type: STYPE_DISKTREE
|     Comment: 
|     Anonymous access: <none>
|     Current user access: READ/WRITE
|   \\192.168.1.1\Disco3: 
|     Type: STYPE_DISKTREE
|     Comment: 
|     Anonymous access: <none>
|     Current user access: READ/WRITE
|   \\192.168.1.1\C$: 
|     Type: STYPE_DISKTREE_HIDDEN
|     Comment: Condivisione predefinita
|     Anonymous access: <none>
|     Current user access: <none>
|   \\192.168.1.1\D$: 
|     Type: STYPE_DISKTREE_HIDDEN
|     Comment: Condivisione predefinita
|     Anonymous access: <none>
|     Current user access: <none>
|   \\192.168.1.1\E$: 
|     Type: STYPE_DISKTREE_HIDDEN
|     Comment: Condivisione predefinita
|     Anonymous access: <none>
|     Current user access: <none>
|   \\192.168.1.1\F$: 
|     Type: STYPE_DISKTREE_HIDDEN
|     Comment: Condivisione predefinita
|     Anonymous access: <none>
|     Current user access: <none>
|   \\192.168.1.1\IPC$: 
|     Type: STYPE_IPC_HIDDEN
|     Comment: IPC remoto
|     Anonymous access: READ
|     Current user access: READ/WRITE
|   \\192.168.1.1\Disco4: 
|     Type: STYPE_DISKTREE
|     Comment: 
|     Anonymous access: <none>
|     Current user access: READ/WRITE
|   \\192.168.1.1\Z$: 
|     Type: STYPE_DISKTREE_HIDDEN
|     Comment: Condivisione predefinita
|     Anonymous access: <none>
|_    Current user access: <none>

TRACEROUTE
HOP RTT     ADDRESS
1   5.04 ms 192.168.1.1

OS and Service detection performed. Please report any incorrect results at https://nmap.org/submit/ .
Nmap done: 1 IP address (1 host up) scanned in 119.52 seconds
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 11463
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 10 (Buster) - KDE

Re: Condivisioni non funzionano

Messaggio da thece »

Direi che l'output è cambiato. Cosa hai modificato quando hai dato il comando

Codice: Seleziona tutto

smbclient -L <INDIRIZZO IP PC WINDOWS> -N
dal test che ha restituito questo output

Codice: Seleziona tutto

NT_STATUS_CONNECTION_RESET
al test che ha restituito questo output?

Codice: Seleziona tutto

NT_STATUS_RESOURCE_NAME_NOT_FOUND
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 21714
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 20.10 e 21.04 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: Condivisioni non funzionano

Messaggio da trekfan1 »

L'output su PC1 lo ho fatto con il firewall di norton attivo, quindi non capisco che cosa abbia il PC2 per dare un output del genere anche con il firewall disattivato, vabbè, ci rinuncio, tanto in qualche modo prima o poi...
Pike
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 4904
Iscrizione: domenica 20 gennaio 2008, 1:13
Desktop: Kubuntu
Distribuzione: 20.04 x64
Contatti:

Re: Condivisioni non funzionano

Messaggio da Pike »

Codice: Seleziona tutto

NetBIOS over TCP disabled -- no workgroup available
Hai verificato se sul PC problematico è attiva questa opzione?
http://www.tomshardware.co.uk/answers/i ... atter.html
Sono colui che fa cose che non servono...
Secondo Principio di Dilbert, di Scott Adams. "Si parte dalla certezza che siamo tutti idioti". Ed alcuni su questo mi ab-battono alla grande.
Come certificato dalla moderazione, incivile e maleducato. You have been warned.
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 11463
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 10 (Buster) - KDE

Re: Condivisioni non funzionano

Messaggio da thece »

Il problema l'ho anche io e non ci ho mai fatto caso perchè solitamente trasferisco il file dal mio PC Linux al mio PC Windows 10 (una VM) collegandomi da Windows 10 (tu stai provando a fare il contrario).

Ho scoperto che il problema è Windows 10, o meglio la versione di protocolli SMB che supporta, di default SMBv2 e SMBv3.

Piccolo test

Codice: Seleziona tutto

nmap -sS -sU -p U:137,138,T:139,445 --script smbv2-enabled <INDIRIZZO IP PC WINDOWS 10> 
Prova questo

Codice: Seleziona tutto

smbclient -L <INDIRIZZO IP PC WINDOWS 10> -N -m smb2          (oppure -m smb3)
e vedrai che la lista degli share dovrebbe venire fuori sempre "quasi" senza alcun problema. "Quasi" perchè rimane ancora il messaggio di errore (evidenziato anche da @Pike)

Codice: Seleziona tutto

NetBIOS over TCP disabled -- no workgroup available
Con questo

Codice: Seleziona tutto

smbclient //<INDIRIZZO IP PC WINDOWS 10>/<SHARE> -N -m smb2
dovresti riuscire a collegarti allo share da terminale con smbclient



Come rilevare, abilitare e disabilitare SMBv1, SMBv2 e SMBv3 in Windows e Windows Server



Soluzione: (fonte) forzare smbclient ad usare il protocollo SMBv2 (o SMBv3) invece del protocollo SMBv1.
smbclient è usato dal file manager per collegarsi agli share Samba. La soluzione l'ho provata sia con Nautilus che con Konqueror.

Creare nella propria home directory il file $HOME/.smb/smb.conf

Codice: Seleziona tutto

mkdir -p $HOME/.smb
touch $HOME/.smb/smb.conf

Codice: Seleziona tutto

nano $HOME/.smb/smb.conf
e copiarci dentro il seguente contenuto

Codice: Seleziona tutto

[global]

	client max protocol = SMB2
salvare il file e riprovare il collegamento verso gli share
Ultima modifica di thece il venerdì 9 febbraio 2018, 12:08, modificato 1 volta in totale.
Scrivi risposta

Ritorna a “Connessione e configurazione delle reti”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 2 ospiti