[risolto] un pc non si collega al wifi

Networking, configurazione della connessione, periferiche e condivisione di rete, ecc.

[risolto] un pc non si collega al wifi

Messaggioda duns » venerdì 19 aprile 2019, 9:36

riformulazione del problema [20-4-2019, 11.30]
Credo che il problema che sollevavo ieri sia riconducibile a a una corretta configurazione della connessione a una rete wifi a cui si connettono anche altri PC (tutti con Kubuntu 18.04) .
Da quando il PC che prima era in una certa posizione (e che da quella posizione non riusciva a connettersi al wifi) è stato spostato in prossimità del router e collegato via cavo al router, da quest'altro PC, collegato via wifi alla stessa rete, non riesco più a connettermi a internet.
Se setto la connessione wifi su IPv4 su link-local dice di connettersi, ma in realtà non navigo. Così dice di connettersi se setto IPv4 su «shared to others computers»: dice di essere connesso, ma in realtà non fa navigare.
Come devo configurare correttamente la connessione?
Grazie

EDIT
Tramite il pannello di controllo del router ho settato un indirizzo IP statico per il PC di cui sto parlando. Solo che non riesco a farglielo prendere. Ho seguito le istruzioni qui riportate. Ma se do il comando
Codice: Seleziona tutto
 route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.0.1     0.0.0.0         UG    100    0        0 enp0s18f2u2
0.0.0.0         87.26.52.126    0.0.0.0         UG    600    0        0 wlxc46e1f288735
87.26.52.126    0.0.0.0         255.255.255.255 UH    600    0        0 wlxc46e1f288735
169.254.0.0     0.0.0.0         255.255.0.0     U     304    0        0 wlxc46e1f288735
192.168.0.0     0.0.0.0         255.255.255.0   U     100    0        0 enp0s18f2u2
192.168.1.0     0.0.0.0         255.255.255.0   U     600    0        0 wlxc46e1f288735


Non mi viene fuori "192.168.1.10" che è l'IP statico che ho settato da pannello di controllo del router.
Come mai?

EDIT
Ho appurato che non posso settare indirizzi IP statici. E comunque la cosa probabilmente non avrebbe risolto il problema.
Adesso ho fatto un'altra cosa: siccome l'extender (tp-link) ha una porta ethernet ho collegato via ethernet l'extender al PC. Pare funzioni, anche se al momento la connessione è decisamente lenta.


precedenti domande [19-4-2019]
Fino a ieri non ho avuto nessun problema su questo PC (Kubuntu 18.04) connesso a internet tramite un extender wifi. Ieri ho usato windows (10) come non facevo da tantissimo tempo e windows 10 si è connesso alla rete wifi, ma adesso in Kubuntu non riesco più a connettermi con quel wifi (
Codice: Seleziona tutto
IP configuration was unavailable
);
Cito dal log di networkmanager
Codice: Seleziona tutto
apr 19 11:38:52 duns-oldsir NetworkManager[834]: <info>  [1555666732.3145] device (wlxc46e1f288735): state change: ip-config -> failed (reason 'ip-config-unavailable', sys-iface-state: 'managed')

In notifications si ha che «No secrets were provided» dal wifi incriminato.

E' mia convinzione che sia successo qualcosa con windows, che è sullo stesso PC. Ho provato a distruggere la connessione wifi precedentemente usata, ne ha creata una nuova (stesso nome, strano), mi ha chiesto la password e l'ha apparentemente accettata, ma poi non si connette.
Grazie di un aiuto

p.s.
Tra l'altro è lo stesso problema, penso, che aveva un altro PC (sempre con Kubuntu 18.04), posto al piano di sotto della stessa casa e che invano ho tentato di connettere alla stessa rete wifi.

EDIT

Ho provato a usare lo smartphone come hotspot e il PC in questione, dopo aver rilevato quella "fonte" e avermi chiesto la password, si è regolarmente connesso (via wifi).
Così ho modificato il titolo: non è che non si connette al wifi, ma a una certa rete wifi, e solo a quella.
Aggiungo che lo smartphone invece si collega regolarmente, come sempre, a quella rete wifi.

EDIT

[sembrava risolto]
Guardando su vari forums ho trovato questa indicazione: «It works if you set IPv6 to "link local"»
Così ho fatto e adesso dice di essersi connessa, ma di fatto non mi fa navigare.
Posto il logo di networkmanager da quando ho fatto quest'ultimo tentativo (link local)
Codice: Seleziona tutto
apr 19 11:57:15 duns-oldsir NetworkManager[834]: <info>  [1555667835.6565] device (wlxc46e1f288735): supplicant interface state: 4-way handshake -> completed
apr 19 11:57:15 duns-oldsir NetworkManager[834]: <info>  [1555667835.6566] device (wlxc46e1f288735): Activation: (wifi) Stage 2 of 5 (Device Configure) successful.  Connected to wireless network '[nome-wifi]'.
apr 19 11:57:15 duns-oldsir NetworkManager[834]: <info>  [1555667835.6568] device (wlxc46e1f288735): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
apr 19 11:57:15 duns-oldsir NetworkManager[834]: <info>  [1555667835.6670] device (wlxc46e1f288735): IPv4LL: started
apr 19 11:57:21 duns-oldsir NetworkManager[834]: <info>  [1555667841.9119] device (wlxc46e1f288735): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')
apr 19 11:57:21 duns-oldsir NetworkManager[834]: <info>  [1555667841.9144] device (wlxc46e1f288735): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'managed')
apr 19 11:57:21 duns-oldsir NetworkManager[834]: <info>  [1555667841.9147] device (wlxc46e1f288735): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed')
apr 19 11:57:21 duns-oldsir NetworkManager[834]: <info>  [1555667841.9537] device (wlxc46e1f288735): Activation: successful, device activated.
apr 19 11:57:31 duns-oldsir NetworkManager[834]: <info>  [1555667851.1865] device (enp0s18f2u4): state change: activated -> deactivating (reason 'user-requested', sys-iface-state: 'managed')
apr 19 11:57:31 duns-oldsir NetworkManager[834]: <info>  [1555667851.2287] manager: NetworkManager state is now CONNECTED_LOCAL
apr 19 11:57:31 duns-oldsir NetworkManager[834]: <info>  [1555667851.2295] audit: op="device-disconnect" interface="enp0s18f2u4" ifindex=5 pid=1512 uid=1000 result="success"
apr 19 11:57:31 duns-oldsir NetworkManager[834]: <info>  [1555667851.2317] device (enp0s18f2u4): state change: deactivating -> disconnected (reason 'user-requested', sys-iface-state: 'managed')
apr 19 11:57:31 duns-oldsir NetworkManager[834]: <info>  [1555667851.2812] dhcp4 (enp0s18f2u4): canceled DHCP transaction, DHCP client pid 10523
apr 19 11:57:31 duns-oldsir NetworkManager[834]: <info>  [1555667851.2813] dhcp4 (enp0s18f2u4): state changed bound -> done


EDIT
Stavolta sembra davvero risolto. Non so come, ma dopo aver annullato il local-linked di cui appena sopra, chiuso e riaperto la connessione col wifi "incriminato", tutto sta tornando a funzionare regolarmente.
Slo che a questo punto ho paura a tornare ancora su windows ... perché non vorrei perdere ancora così tanto tempo (ammesso che sia stato windows, su un'altra partizione multiboot di questo PC a causare questo pasticcio).

EDIT
No: fatto reset, entrato e uscito da windows e poi ritornato in Kubuntu ilo problema si ripresenta, forse anche aggravato.

EDIT :devilmad:
Certo che un sistema operativo che rende quasi impossibile accedere a internet non ha molto futuro. Sarebbe auspicabile che gli sviluppatori dedicassero più energie alle connessioni internet, che sono più importanti di molte altre cose, per agevolare una facile connessione.


EDIT [20-4-2019, 10.55]
Stamattina sono riandato su windows e stavolta anche windows aveva problema a connettersi con quella rete wifi.
A questo punto io faccio una ipotesi: se il problema fosse il contemporaneo (tentativo di) accesso alla stessa rete wifi di due PC? L'uno esclude l'altro?
Ultima modifica di duns il domenica 19 maggio 2019, 19:26, modificato 2 volte in totale.
duns
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 305
Iscrizione: febbraio 2006
Desktop: KDE plasma5
Distribuzione: Kubuntu 18.04
Sesso: Maschile

Re: come configurare la connessione di più pc allo stesso wi

Messaggioda BumBunL » martedì 23 aprile 2019, 10:48

Metti tutto in DHCP e si configurano da soli i vari pc connessi wifi.
BumBunL
Prode Principiante
 
Messaggi: 5
Iscrizione: aprile 2019
Desktop: Gnome
Distribuzione: Lubuntu
Sesso: Femminile

Re: come configurare la connessione di più pc allo stesso wi

Messaggioda duns » mercoledì 24 aprile 2019, 12:31

BumBunL Immagine ha scritto:Metti tutto in DHCP e si configurano da soli i vari pc connessi wifi.

Grazie, ma anche così finché sono wifi quello secondario non si connetteva. Ho risolto (finora funziona) collegando il PC secondario via ethernet a un extender.
duns
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 305
Iscrizione: febbraio 2006
Desktop: KDE plasma5
Distribuzione: Kubuntu 18.04
Sesso: Maschile

Re: un pc non si collega al wifi [risolto]

Messaggioda trekfan1 » mercoledì 24 aprile 2019, 17:45

Il [Risolto] va ad inizio titolo, non alla fine, correggi, grazie :)
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 20061
Iscrizione: maggio 2006
Località: Formigine (MO) | Accecante Asceta
Desktop: Gnome
Distribuzione: Ubuntu 19.10 e 20.04 (dev) 64 bit
Sesso: Maschile

Re: un pc non si collega al wifi [risolto]

Messaggioda duns » domenica 19 maggio 2019, 19:26

trekfan1 Immagine ha scritto:Il [Risolto] va ad inizio titolo, non alla fine, correggi, grazie :)

fatto! scusa, non mi ero accorto!
duns
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 305
Iscrizione: febbraio 2006
Desktop: KDE plasma5
Distribuzione: Kubuntu 18.04
Sesso: Maschile


Torna a Connessione e configurazione delle reti

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 6 ospiti