Problema WIFI: si disconnette dopo alcuni minuti dall'avvio

Networking, configurazione della connessione, periferiche e condivisioni di rete.
Scrivi risposta
19vincenzo85
Prode Principiante
Messaggi: 3
Iscrizione: mercoledì 20 novembre 2019, 16:38
Desktop: Ubuntu 18.04
Distribuzione: Ubuntu 18.04.3 LTS x86_64
Sesso: Maschile

Problema WIFI: si disconnette dopo alcuni minuti dall'avvio

Messaggio da 19vincenzo85 » mercoledì 20 novembre 2019, 16:44

Salve,
grazie per tutto il supporto che date costantemente a chi, come me, ne ha davvero bisogno.

Premetto che sono un principiante.
Ho da poco installato sul mio Asus Zenbook UX305 Ubuntu 18.04 lts e fino a qualche giorno fa andava tutto bene.

Da un paio di giorni ho un problema con il wifi: dopo alcuni minuti dall'avvio (delle volte 10 minuti, alcune volte 2-3 minuti) non ho più internet ed è come se la scheda wifi fosse "impallata". Ovvero non riesco a cambiare connessione o a modificare qualche impostazione della stessa.

Ho provato un paio di operazioni trovate sul forum, ma nulla. Pertanto sono a chiedervi una grossa mano di aiuto.

Aggiungo che lanciando il comando iwconfig ho come risultato questo:

Codice: Seleziona tutto

enx9cebe8375abe  no wireless extensions.

wlp2s0    IEEE 802.11  ESSID:"nome rete"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 1C:49:7B:B1:09:97   
          Bit Rate=270 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=64/70  Signal level=-46 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:79   Missed beacon:0

lo        no wireless extensions.
Grazie a chi interverrà.
Ultima modifica di trekfan1 il venerdì 29 novembre 2019, 6:47, modificato 1 volta in totale.
Motivazione: Inseriti i tag CODE, ricordalo per il futuro

Avatar utente
woddy68
Rampante Reduce
Rampante Reduce
Messaggi: 5779
Iscrizione: sabato 12 febbraio 2011, 14:23
Desktop: Kde Plasma5
Distribuzione: openSUSE Leap-Tumbleweed-Kubuntu 20
Sesso: Maschile

Re: Problema WIFI: si disconnette dopo alcuni minuti dall'av

Messaggio da woddy68 » mercoledì 20 novembre 2019, 17:29

Prova in network manager, impostare password non criptata o qualcosa di simile.
Desktop - Acer Aspire M5500 (AMD) - Notebook Acer Aspire E1 -522 (Amd)
Voglio trovare la mia strada per il paradiso - Perché ho scontato la mia pena all'inferno
Non avevo un bell'aspetto ma mi sentivo proprio bene 😬

19vincenzo85
Prode Principiante
Messaggi: 3
Iscrizione: mercoledì 20 novembre 2019, 16:38
Desktop: Ubuntu 18.04
Distribuzione: Ubuntu 18.04.3 LTS x86_64
Sesso: Maschile

Re: Problema WIFI: si disconnette dopo alcuni minuti dall'av

Messaggio da 19vincenzo85 » mercoledì 20 novembre 2019, 20:10

Non trovo questa impostazione.

Aggiungo che quando si blocca la connessione e riavvio o spengo il pc il sistema si arresta e mi da una sfilza di errori tipo "mac failed" e poi si spegne.

19vincenzo85
Prode Principiante
Messaggi: 3
Iscrizione: mercoledì 20 novembre 2019, 16:38
Desktop: Ubuntu 18.04
Distribuzione: Ubuntu 18.04.3 LTS x86_64
Sesso: Maschile

Re: Problema WIFI: si disconnette dopo alcuni minuti dall'av

Messaggio da 19vincenzo85 » giovedì 28 novembre 2019, 15:53

Un'anima pia che mi può dare una mano?

kar64
Prode Principiante
Messaggi: 107
Iscrizione: domenica 2 settembre 2018, 17:13
Desktop: kubuntu
Distribuzione: 19.10 64bit
Sesso: Maschile

Re: Problema WIFI: si disconnette dopo alcuni minuti dall'av

Messaggio da kar64 » giovedì 28 novembre 2019, 22:08

Mi accodo alla tua domanda. Anche a me capita la stessa cosa con notebook simile al tuo (Asus ZenBook UX430U) con 18.04 installata da 2 giorni.
Talvolta internet manca ma il simbolo del wifi è presente e quindi devo cliccarci sopra e spegnere la scheda, poi accenderla e connettere. A volte, invece, la rete non c'è più e devo spegnere e riaccendere per ritrovarla ....

Aspettiamo interventi .
Asus Zenbook pro
Dual boot con Windows10pro
Kubuntu 19.10 con crossover x Excel e Word 2016.

Avatar utente
Ayrtux
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1499
Iscrizione: sabato 5 aprile 2008, 17:15
Desktop: Gnome
Distribuzione: Ubuntu 18.04

Re: Problema WIFI: si disconnette dopo alcuni minuti dall'av

Messaggio da Ayrtux » mercoledì 4 dicembre 2019, 18:27

Ero indeciso se aprire una discussione, ma dal momento che ho più o meno lo stesso problema (e che a quanto pare è abbastanza diffuso), mi accodo. Fornisco però ulteriori dettagli, almeno nel mio caso, magari qualcuno potrà identificare qualche analogia.

In particolare riscontro "freeze" del wifi, non sempre il simbolo del wifi scompare per il punto interrogativo (disconnessione), spesso rimane acceso come se stesse funzionando ma, di fatto, è bloccato. Per risolvere mi basta semplicemente spegnere/riaccendere direttamente dalla barra delle applicazioni sul simbolo del wifi. Il problema però si verifica troppo spesso e la cosa è diventata molto fastidiosa.

Escluderei un problema di driver, perché nell'ufficio il wifi non mi da mai problemi; il sospetto ricade piuttosto sul router di casa (vodafone station revolution) e/o ad eventuale inquinamento da reti wifi/saturazione canale. Tuttavia un computer desktop con Windows, che si collega tramite un adattatore wifi usb allo stesso router, non riscontra quasi mai questo problema. La cosa è pertanto strana, perché se ci fosse un problema di canale dovrebbe coinvolgere anche il pc con windows, presumo.

Qualcuno ha qualche idea in merito?
Software is like sex, it's better when it's free. (Linus Torvalds)
Linux User #490751 | Ubuntu User #27591

kar64
Prode Principiante
Messaggi: 107
Iscrizione: domenica 2 settembre 2018, 17:13
Desktop: kubuntu
Distribuzione: 19.10 64bit
Sesso: Maschile

Re: Problema WIFI: si disconnette dopo alcuni minuti dall'av

Messaggio da kar64 » mercoledì 4 dicembre 2019, 21:25

Mi riassocio, dicendo che pure io ho una vodafone station revolution che su windows non ha mai presenato di questi problemi.
Asus Zenbook pro
Dual boot con Windows10pro
Kubuntu 19.10 con crossover x Excel e Word 2016.

Avatar utente
willy54
Rampante Reduce
Rampante Reduce
Messaggi: 6048
Iscrizione: lunedì 18 dicembre 2017, 21:42
Desktop: Xfce, Xorg, Plasma
Distribuzione: Ubuntu studio,Ubuntu, Kubuntu 18.04
Sesso: Maschile
Località: Castell'Alfero (AT)
Contatti:

Re: Problema WIFI: si disconnette dopo alcuni minuti dall'av

Messaggio da willy54 » giovedì 5 dicembre 2019, 0:15

Provate a disabilitare IPV6 nella scheda gestione del wifi, molti router specialmente quelli avuti in bundle con la connessione non sono in grado di gestire in modo efficiente IPV6 specialmente se datati.
Hp Pavilon 15-CS2093nl Win10, UbuntuStudio 20.04.1 caratteristiche
Toshiba Satellite A660 11M Win7, Win10, Ubuntu 18.04 LTS- Kubuntu 18.04 LTS gparted sda inxi -Fz
disattivare Avvio rapido in Windows10 Installazione su pc Uefi download/file.php?id=31104 -- download/file.php?id=33560

Avatar utente
Ayrtux
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1499
Iscrizione: sabato 5 aprile 2008, 17:15
Desktop: Gnome
Distribuzione: Ubuntu 18.04

Re: Problema WIFI: si disconnette dopo alcuni minuti dall'av

Messaggio da Ayrtux » giovedì 5 dicembre 2019, 12:29

Io non vedo alcuna voce inerente a IPV6 nella sezione del wifi.. (ho la visualizzazione in modalità utente esperto).
Software is like sex, it's better when it's free. (Linus Torvalds)
Linux User #490751 | Ubuntu User #27591

Avatar utente
willy54
Rampante Reduce
Rampante Reduce
Messaggi: 6048
Iscrizione: lunedì 18 dicembre 2017, 21:42
Desktop: Xfce, Xorg, Plasma
Distribuzione: Ubuntu studio,Ubuntu, Kubuntu 18.04
Sesso: Maschile
Località: Castell'Alfero (AT)
Contatti:

Re: Problema WIFI: si disconnette dopo alcuni minuti dall'av

Messaggio da willy54 » giovedì 5 dicembre 2019, 23:51

Bene possiamo sapere le caratteristiche del chip e dei driver utilizzati ?
vedete se la 2a casella nella App Software e aggiornamenti è spuntata
Nel terminale

Codice: Seleziona tutto

sudo apt install inxi
inxi -n
rfkill list all
Hp Pavilon 15-CS2093nl Win10, UbuntuStudio 20.04.1 caratteristiche
Toshiba Satellite A660 11M Win7, Win10, Ubuntu 18.04 LTS- Kubuntu 18.04 LTS gparted sda inxi -Fz
disattivare Avvio rapido in Windows10 Installazione su pc Uefi download/file.php?id=31104 -- download/file.php?id=33560

Avatar utente
Ayrtux
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1499
Iscrizione: sabato 5 aprile 2008, 17:15
Desktop: Gnome
Distribuzione: Ubuntu 18.04

Re: Problema WIFI: si disconnette dopo alcuni minuti dall'av

Messaggio da Ayrtux » venerdì 6 dicembre 2019, 12:13

Intendi "Driver proprietari per i dispositivi (restricted)"? Sì è spuntata.

Codice: Seleziona tutto

Network:   Card-1: Realtek RTL810xE PCIE Fast Ethernet controller
           driver: r8169
           IF: enp1s0 state: down mac: (ecc...)
           Card-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
           driver: ath9k
           IF: wlp2s0 state: up mac: (ecc...)

Codice: Seleziona tutto

0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
Software is like sex, it's better when it's free. (Linus Torvalds)
Linux User #490751 | Ubuntu User #27591

Avatar utente
willy54
Rampante Reduce
Rampante Reduce
Messaggi: 6048
Iscrizione: lunedì 18 dicembre 2017, 21:42
Desktop: Xfce, Xorg, Plasma
Distribuzione: Ubuntu studio,Ubuntu, Kubuntu 18.04
Sesso: Maschile
Località: Castell'Alfero (AT)
Contatti:

Re: Problema WIFI: si disconnette dopo alcuni minuti dall'av

Messaggio da willy54 » venerdì 6 dicembre 2019, 13:03

@Ayrtux
Segui questo 3D
Hp Pavilon 15-CS2093nl Win10, UbuntuStudio 20.04.1 caratteristiche
Toshiba Satellite A660 11M Win7, Win10, Ubuntu 18.04 LTS- Kubuntu 18.04 LTS gparted sda inxi -Fz
disattivare Avvio rapido in Windows10 Installazione su pc Uefi download/file.php?id=31104 -- download/file.php?id=33560

Avatar utente
Ayrtux
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1499
Iscrizione: sabato 5 aprile 2008, 17:15
Desktop: Gnome
Distribuzione: Ubuntu 18.04

Re: Problema WIFI: si disconnette dopo alcuni minuti dall'av

Messaggio da Ayrtux » venerdì 6 dicembre 2019, 16:11

Scusa willy, ho visto quel 3D, ma dove sarebbe la soluzione? Tra l'altro mi pare di capire che l'utente che l'ha aperto avesse un problema un po' diverso cioè che il wifi di colpo avesse smesso di funzionare, e che in ogni caso ha risolto fortuitamente dopo aggiornamenti di sistema..
Software is like sex, it's better when it's free. (Linus Torvalds)
Linux User #490751 | Ubuntu User #27591

Avatar utente
willy54
Rampante Reduce
Rampante Reduce
Messaggi: 6048
Iscrizione: lunedì 18 dicembre 2017, 21:42
Desktop: Xfce, Xorg, Plasma
Distribuzione: Ubuntu studio,Ubuntu, Kubuntu 18.04
Sesso: Maschile
Località: Castell'Alfero (AT)
Contatti:

Re: Problema WIFI: si disconnette dopo alcuni minuti dall'av

Messaggio da willy54 » venerdì 6 dicembre 2019, 20:57

Vero ma se dai i comandi suggeriti dal Mago dovresti arrivare alla soluzione.
Hp Pavilon 15-CS2093nl Win10, UbuntuStudio 20.04.1 caratteristiche
Toshiba Satellite A660 11M Win7, Win10, Ubuntu 18.04 LTS- Kubuntu 18.04 LTS gparted sda inxi -Fz
disattivare Avvio rapido in Windows10 Installazione su pc Uefi download/file.php?id=31104 -- download/file.php?id=33560

Avatar utente
Ayrtux
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1499
Iscrizione: sabato 5 aprile 2008, 17:15
Desktop: Gnome
Distribuzione: Ubuntu 18.04

Re: Problema WIFI: si disconnette dopo alcuni minuti dall'avvio

Messaggio da Ayrtux » giovedì 2 aprile 2020, 1:03

Torno ad aggiornare questa discussione perché, almeno da 2-3 giorni, pare che sia riuscito a risolvere. Spiego le operazioni sperando che possano essere utili anche ad altri col medesimo problema.

Sebbene come detto il pc con windows non presentasse il problema con la stessa cadenza del portatile in oggetto, non ho seguito i comandi suggeriti da willy, un po' per mancanza di tempo e un po' per l'incertezza, a seguito di quei comandi, con cui terminava quel thread (wifi non più funzionante per - probabilmente - scheda wifi guasta).

Come mi ero riproposto mi sono concentrato sulla saturazione dei canali wireless: come immaginavo le reti erano molte e i canali affollati (in realtà lo sono sempre stati nella mia zona), e ho deciso di provare un canale lontano (nel mio caso l'ultimo, il 13). Non pensavo di sortire granché come effetti, perché in passato avevo già provato a cambiare canali, fatto sta che almeno negli ultimi tre giorni, sono cessate le disconnessioni del wifi. Rispetto a prima che erano decine al giorno, direi che probabilmente era questa la causa.

Giacché si tratta della vodafone station mi permetto di fornire ulteriori due consigli che, sempre nel mio caso, hanno anche migliorato di molto la velocità:
- impostare solo a 40Mhz la banda, nelle impostazioni del wifi a 2.4 GHz
- abilitare il band steering
Software is like sex, it's better when it's free. (Linus Torvalds)
Linux User #490751 | Ubuntu User #27591

Avatar utente
giulux
Amministratore
Amministratore
Messaggi: 24294
Iscrizione: domenica 10 gennaio 2010, 12:17
Desktop: ubuntu 18.04
Distribuzione: Ubuntu 18.04.3 LTS x86_64
Sesso: Maschile
Località: Roma

Re: Problema WIFI: si disconnette dopo alcuni minuti dall'avvio

Messaggio da giulux » giovedì 2 aprile 2020, 6:49

Modifica il titolo del primo post mettendoci davanti [Risolto].

Se il problema dovesse ripresentarsi lo togli e prosegui.
Ciao.

Avatar utente
Ayrtux
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1499
Iscrizione: sabato 5 aprile 2008, 17:15
Desktop: Gnome
Distribuzione: Ubuntu 18.04

Re: Problema WIFI: si disconnette dopo alcuni minuti dall'avvio

Messaggio da Ayrtux » giovedì 2 aprile 2020, 13:49

Ciao giulux, non sono io l'autore del thread ;)
Software is like sex, it's better when it's free. (Linus Torvalds)
Linux User #490751 | Ubuntu User #27591

Avatar utente
giulux
Amministratore
Amministratore
Messaggi: 24294
Iscrizione: domenica 10 gennaio 2010, 12:17
Desktop: ubuntu 18.04
Distribuzione: Ubuntu 18.04.3 LTS x86_64
Sesso: Maschile
Località: Roma

Re: Problema WIFI: si disconnette dopo alcuni minuti dall'avvio

Messaggio da giulux » giovedì 2 aprile 2020, 13:50

Ayrtux ha scritto:
giovedì 2 aprile 2020, 13:49
Ciao giulux, non sono io l'autore del thread ;)
Già, non ci avevo fatto caso :shy:

Avatar utente
Jachinux
Prode Principiante
Messaggi: 23
Iscrizione: sabato 24 marzo 2012, 14:49

Re: Problema WIFI: si disconnette dopo alcuni minuti dall'avvio

Messaggio da Jachinux » mercoledì 2 settembre 2020, 10:57

Non so quanto sia valida da un punto di vista strettamente teorico ma credo di aver trovato una soluzione.
Sono andato nella cartella /etc/NetworkManager/conf.d e ho aperto in modalità amministratore su gedit il file default-wifi-powersave-on.conf, ho modificato la riga

Codice: Seleziona tutto

wifi.powersave = 3
in

Codice: Seleziona tutto

wifi.powersave = 0
Salvo, chiudo, riavvio.
Da allora più nessun problema.

Scrivi risposta

Ritorna a “Connessione e configurazione delle reti”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 4 ospiti