Impostare ambiente desktop e display manager predefinito

Configurazione e uso di desktop e window manager alternativi, quali FVWM, Fluxbox, OpenBox, e17 e altri.

Impostare ambiente desktop e display manager predefinito

Messaggioda marck120 » mercoledì 2 novembre 2016, 19:55

Salve, volevo chiedervi la procedura corretta per impostare il display manager e l'ambiente desktop in modo predefinito all'avvio.

Per evitare di fare pasticci sto provando la procedura su virtualbox, ho installato ubuntu con unity di default e mate.

Dalle ricerche che ho fatto credo che le procedure siano queste.

Impostare ambiente desktop :

Se ho capito bene devo aprire con un editor di testo e configurare il file xsession in /usr/share/xsessions/ubuntu.desktop

[Desktop Entry]
Name=Ubuntu
Comment=This session logs you into Ubuntu
Exec=gnome-session --session=ubuntu
TryExec=unity
Icon=
Type=Application
DesktopNames=Unity
X-Ubuntu-Gettext-Domain=gnome-session-3.0

Impostare display manager :

Mi basta dare questo comando :

sudo dpkg-reconfigure sddm o sudo dpkg-reconfigure lightdm a seconda del display manager installato, gdm, kdm ecc..
marck120
Prode Principiante
 
Messaggi: 231
Iscrizione: dicembre 2011

Re: Impostare ambiente desktop e display manager predefinit

Messaggioda steff » mercoledì 2 novembre 2016, 21:20

Basta il comando, i file .desktop non vanno toccati, sono la base per la scelta del DE da avviare al login.
Poi kdm è obsoleto, gdm non lo so ma forse, cmq ogniuno ha una sua impostazione per il DE da avviare per default, normalmente è l'ultima scelta.
La Documentazione da consultare e la FAQ sul uso del forum
$ rsync -auv --delete /home/NOME/ /media/disco_USB/BACKUP
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu virtuale in Vbox
Avatar utente
steff
Moderatore Globale
Moderatore Globale
 
Messaggi: 36111
Iscrizione: febbraio 2007
Località: Toscana
Desktop: LXQt
Distribuzione: Arch Linux 64bit
Sesso: Maschile

Re: Impostare ambiente desktop e display manager predefinit

Messaggioda marck120 » mercoledì 2 novembre 2016, 22:57

steff Immagine ha scritto:Basta il comando, i file .desktop non vanno toccati, sono la base per la scelta del DE da avviare al login.
Poi kdm è obsoleto, gdm non lo so ma forse, cmq ogniuno ha una sua impostazione per il DE da avviare per default, normalmente è l'ultima scelta.



Ciao, ti ringrazio tanto per avermi risposto.

Cerco di spiegare con esattezza quale è il mio intento, dunque io imposto sempre il login automatico, all'avvio del sistema voglio che parta un DE di mia scelta in automatico, poi se voglio accedere su un' altro DE termino la sessione corrente e accedo nel DE scelto.

Il display manager di unity dovrebbe essere LightDM, per impostare il display manager come mi spiegavi credo che mi basti scrivere sudo dpkg-reconfigure LightDM.

Adesso su unity ho questa situazione, come si vede dall'immagine ubuntu è predefinito, invece se volessi mate predefinito quale è il comando che devo usare per impostare il DE come predefinito ?

Immagine
marck120
Prode Principiante
 
Messaggi: 231
Iscrizione: dicembre 2011

Re: Impostare ambiente desktop e display manager predefinit

Messaggioda steff » mercoledì 2 novembre 2016, 23:45

Conosco poco lightdm ma ha i suoi file di configurazione e sicuramente anche un suo tool per impostare la sessione di default, autologin, utente di default ecc, ma non saprei come si chiama in unity, lightdm-settings?
Cmq i file sono tutti in /etc/lightdm.conf e /etc/lightdm.d/...
La Documentazione da consultare e la FAQ sul uso del forum
$ rsync -auv --delete /home/NOME/ /media/disco_USB/BACKUP
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu virtuale in Vbox
Avatar utente
steff
Moderatore Globale
Moderatore Globale
 
Messaggi: 36111
Iscrizione: febbraio 2007
Località: Toscana
Desktop: LXQt
Distribuzione: Arch Linux 64bit
Sesso: Maschile

Re: Impostare ambiente desktop e display manager predefinit

Messaggioda marck120 » giovedì 3 novembre 2016, 0:18

steff Immagine ha scritto:Conosco poco lightdm ma ha i suoi file di configurazione e sicuramente anche un suo tool per impostare la sessione di default, autologin, utente di default ecc, ma non saprei come si chiama in unity, lightdm-settings?
Cmq i file sono tutti in /etc/lightdm.conf e /etc/lightdm.d/...


In /etc ho questi file :

Immagine

La cartella lightdm.d è vuota, ho provato anche questo comando ma non funziona :

Codice: Seleziona tutto
sudo /usr/lib/lightdm/lightdm-set-defaults -s mate


Codice: Seleziona tutto
itx@itx:~$ sudo/usr/lib/lightdm/lightdm-set-deafaults -s mate
bash: sudo/usr/lib/lightdm/lightdm-set-deafaults: File o directory non esistente
itx@itx:~$




Il tool per impostare la sessione di default non l'ho trovato, mi sembra non ci sia, c'è solo l'impostazione per l'autologin e l'utente.
marck120
Prode Principiante
 
Messaggi: 231
Iscrizione: dicembre 2011

Re: Impostare ambiente desktop e display manager predefinit

Messaggioda caturen » giovedì 3 novembre 2016, 7:13

per impostare un qualsiasi DE che parta di default basta semplicemente sceglierlo una volta e fare il login. La prossima volta quel DE verra messo in avvio predefinito e servirà solo loggarsi. Per cambiarlo basterà di nuovo scegliere un altro DE.
caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 13086
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: Impostare ambiente desktop e display manager predefinit

Messaggioda marck120 » giovedì 3 novembre 2016, 10:05

caturen Immagine ha scritto:per impostare un qualsiasi DE che parta di default basta semplicemente sceglierlo una volta e fare il login. La prossima volta quel DE verra messo in avvio predefinito e servirà solo loggarsi. Per cambiarlo basterà di nuovo scegliere un altro DE.



Ciao, grazie per la disponibilità e il supporto.

Dunque su virtualbox ho installato nuovamente ubuntu 16.04 con unity di default e gnome come secondo DE, adesso funziona come mi hai spiegato, prima però partiva sempre unity.

Sul PC invece ho installo kubuntu 16.10 con il kde 5 di default, come DE aggiuntivi ho gnome e unity, in questo caso nonostante scelga il DE al riavvio parte sempre KDE.

Ho provato ad'impostare gnome come DE di defaults ma non ha funzionato :

Codice: Seleziona tutto
itx@itx:~$ sudo /usr/lib/sddm/sddm-set-defaults -s gnome
[sudo] password di itx:
sudo: /usr/lib/sddm/sddm-set-defaults: comando non trovato
itx@itx:~$


In questi casi in cui parte in automatico solo un ambiente desktop esiste un sistema per impostare il DE predefinito manualmente ? o da terminale oppure configurando il file sul sistema ?
marck120
Prode Principiante
 
Messaggi: 231
Iscrizione: dicembre 2011

Re: Impostare ambiente desktop e display manager predefinit

Messaggioda daigo » giovedì 3 novembre 2016, 10:35

non saprei, se esiste un modo per configurare sddm, comunque, l'unico sistema dove ho piu DE è ubuntu (unity, gnome shell e cinnamon) e come ti diceva caturen, resta selezionato da avviare l'ultimo usato, però ubuntu usa lightdm, mentre kubuntu usa sddm.

prova a usare lightdm come display manager, installalo e impostalo con
Codice: Seleziona tutto
sudo dpkg-reconfigure lightdm


mi pare che sddm ha delle limitazioni, per esempio se abiliti l'utente root, a differenza di lightdm non te lo mostra nella lista utenti, mentre se hai più utenti normali te li mostra tutti.
Avatar utente
daigo
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 18580
Iscrizione: maggio 2011

Re: Impostare ambiente desktop e display manager predefinit

Messaggioda UbuNuovo » giovedì 3 novembre 2016, 10:42

Hai provato a seguire la guida?
Nel caso in cui sia il primo a rispondere ad una richiesta di aiuto...chiunque abbia una soluzione migliore o anche solo diversa dalla mia è incoraggiato ad intervenire liberamente senza inviarmi alcun messaggio privato. In programmazione è basilare sapere che si può ottenere il medesimo risultato utilizzando metodi diversi.
Avatar utente
UbuNuovo
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2834
Iscrizione: dicembre 2009
Desktop: Mate
Distribuzione: Ubuntu 14.04
Sesso: Maschile

Re: Impostare ambiente desktop e display manager predefinit

Messaggioda steff » giovedì 3 novembre 2016, 10:47

Kubuntu non usa lightdm (sconsigliato) ma sddm e si può configurare bene.
http://wiki.ubuntu-it.org/AmbienteGrafi ... OA_grafica
La Documentazione da consultare e la FAQ sul uso del forum
$ rsync -auv --delete /home/NOME/ /media/disco_USB/BACKUP
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu virtuale in Vbox
Avatar utente
steff
Moderatore Globale
Moderatore Globale
 
Messaggi: 36111
Iscrizione: febbraio 2007
Località: Toscana
Desktop: LXQt
Distribuzione: Arch Linux 64bit
Sesso: Maschile

Re: Impostare ambiente desktop e display manager predefinit

Messaggioda daigo » giovedì 3 novembre 2016, 10:57

ciao steff, la guida a sddm non l'avevo vista, comunque come dicevo su kubuntu non ho altri DE.

come mai sarebbe sconsigliato ligthdm? non credo che faccia molta differenza il DM tenendo conto che insieme a plasma, lui ci ha anche caricato unity e gnome shell....piu di cosi ormai...

tra l'altro ho usato anche pclinuxos plasma e li di default viene usato se non sbaglio gdm e non c'è nessun problema.

anche sabayon plasma non usa sddm e anche li è tutto in ordine.
Avatar utente
daigo
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 18580
Iscrizione: maggio 2011

Re: Impostare ambiente desktop e display manager predefinit

Messaggioda steff » giovedì 3 novembre 2016, 11:26

Dovevo dire meglio: è raccomandato sddm per vari ragioni (wayland tra altro e lightdm viene sviluppato in casa canonical, sddm su github), non è che non funziona lightdm (il resto dei DM forse proprio non funziona più se non supporta systemd/logind).
http://aseigo.blogspot.it/2013/03/loggi ... ces-2.html
http://blog.davidedmundson.co.uk/blog/d ... ers_finale
La Documentazione da consultare e la FAQ sul uso del forum
$ rsync -auv --delete /home/NOME/ /media/disco_USB/BACKUP
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu virtuale in Vbox
Avatar utente
steff
Moderatore Globale
Moderatore Globale
 
Messaggi: 36111
Iscrizione: febbraio 2007
Località: Toscana
Desktop: LXQt
Distribuzione: Arch Linux 64bit
Sesso: Maschile

Re: Impostare ambiente desktop e display manager predefinit

Messaggioda marck120 » giovedì 3 novembre 2016, 21:44

Caspita quante risposte, grazie a tutti gentilissimi. Rispondo a tutti con un unico post.

Dunque vi spiego tutte le procedure che ho eseguito.

Impostare la sessione predefinita tramite il display manager light .

Come mi avete indicato ho eseguito questa guida :

http://wiki.ubuntu-it.org/AmbienteGrafi ... redefinita

Qui il problema è che non riesco a capire quale è il file in questione, vi posto il contenuto dei file lightdm.conf

1 file
:

http://depositfiles.com/files/jwgfeioig

Codice: Seleziona tutto
[Seat:*]
autologin-guest=false
autologin-user=itx
autologin-user-timeout=0


2 file

http://depositfiles.com/files/9nc8j335a

Codice: Seleziona tutto
# LightDM - light Display Manager
#
# The display manager service manages the X servers running on the
# system, providing login and auto-login services
#
# based on gdm upstart script

description   "LightDM Display Manager"
author      "Robert Ancell <robert.ancell@canonical.com>"

start on ((filesystem
           and runlevel [!06]
           and started dbus
           and plymouth-ready)
          or runlevel PREVLEVEL=S)

stop on runlevel [016]

respawn
respawn limit 2 15

emits login-session-start
emits desktop-session-start
emits desktop-shutdown

script
    if [ -n "$UPSTART_EVENTS" ]
    then
        # Check kernel command-line for inhibitors, unless we are being called
        # manually
        for ARG in $(cat /proc/cmdline); do
            if [ "$ARG" = "text" ]; then
      plymouth quit || :
                stop
      exit 0
            fi
        done

   [ ! -f /etc/X11/default-display-manager -o "$(cat /etc/X11/default-display-manager 2>/dev/null)" = "/usr/bin/lightdm" -o "$(cat /etc/X11/default-display-manager 2>/dev/null)" = "/usr/sbin/lightdm" ] || { stop; exit 0; }

   if [ "$RUNLEVEL" = S -o "$RUNLEVEL" = 1 ]
   then
       # Single-user mode
       plymouth quit || :
       exit 0
   fi
    fi

    exec lightdm
end script

post-start script
    sleep 5
    clear > /dev/tty7
end script

post-stop script
   clear > /dev/tty7
   sleep 1
   if [ "$UPSTART_STOP_EVENTS" = runlevel ]; then
      initctl emit desktop-shutdown
   fi
end script


3 file

http://depositfiles.com/files/c9sfgofr0

Codice: Seleziona tutto
#!/bin/sh
# Debian lightdm package configuration script
# based on xdm script
# Copyright 2000-2001 Branden Robinson.
# Licensed under the GNU General Public License, version 2.  See the file
# /usr/share/common-licenses/GPL or <http://www.gnu.org/copyleft/gpl.txt>.

set -e

# source debconf library
. /usr/share/debconf/confmodule

# set default display manager
DEFAULT_DISPLAY_MANAGER_FILE=/etc/X11/default-display-manager

OWNERS=
if db_metaget shared/default-x-display-manager owners; then
  OWNERS="$RET"
fi

CHOICES=
if db_metaget shared/default-x-display-manager choices; then
  CHOICES="$RET"
fi

if [ "$OWNERS" != "$CHOICES" ]; then
  db_subst shared/default-x-display-manager choices "$OWNERS" || :
  db_fset shared/default-x-display-manager seen false || :
fi

# debconf is not a registry; use the current contents of the default display
# manager file to pre-answer the question if possible
if [ -e "$DEFAULT_DISPLAY_MANAGER_FILE" ]; then
  CURRENT_DEFAULT=$(basename "$(grep -v '^[[:space:]]*#' \
                                "$DEFAULT_DISPLAY_MANAGER_FILE" |
                                head -n 1)")
  if [ -n "$CURRENT_DEFAULT" ]; then
    db_set shared/default-x-display-manager "$CURRENT_DEFAULT"
  fi
else
  CURRENT_DEFAULT=
  if db_get shared/default-x-display-manager; then
    CURRENT_DEFAULT="$RET"
  fi
fi

# when installing from scratch as part of a release upgrade, default to
# lightdm, otherwise ask
if [ -z "$2" -a -n "$RELEASE_UPGRADE_IN_PROGRESS" ]; then
    db_set shared/default-x-display-manager lightdm
    db_fset shared/default-x-display-manager seen true
else
    db_input high shared/default-x-display-manager || :
    db_go || :
fi

# using this display manager?
NEW_DEFAULT=
if db_get shared/default-x-display-manager; then
  NEW_DEFAULT="$RET"
fi

# move the default display manager file if we are going to change it
if [ -n "$NEW_DEFAULT" ]; then
  if [ "$NEW_DEFAULT" != "$CURRENT_DEFAULT" ]; then
    if [ -e "$DEFAULT_DISPLAY_MANAGER_FILE" ]; then
      mv "$DEFAULT_DISPLAY_MANAGER_FILE" \
         "${DEFAULT_DISPLAY_MANAGER_FILE}.dpkg-tmp"
    fi
  fi
fi


4 file

http://depositfiles.com/files/ukbvxbvvi

Codice: Seleziona tutto
/etc/apparmor.d/abstractions/lightdm
/etc/apparmor.d/abstractions/lightdm_chromium-browser
/etc/apparmor.d/lightdm-guest-session
/etc/dbus-1/system.d/org.freedesktop.DisplayManager.conf
/etc/init.d/lightdm
/etc/init/lightdm.conf
/etc/lightdm/users.conf
/etc/logrotate.d/lightdm
/etc/pam.d/lightdm
/etc/pam.d/lightdm-autologin
/etc/pam.d/lightdm-greeter


5 file

http://depositfiles.com/files/5gojkwer9

Questo file il forum non mi permette di inserirlo nel forum , mo dice che ci sono troppe faccine scaricatelo dal link per vedere il contenuto.

Impostare la sessione predefinita tramite il display manager sddm.........
marck120
Prode Principiante
 
Messaggi: 231
Iscrizione: dicembre 2011

Re: Impostare ambiente desktop e display manager predefinit

Messaggioda UbuNuovo » giovedì 3 novembre 2016, 22:16

Ma che razza di servizio per la condivisione di file è quello! :devilmad:
io la voce che riguarda cosa avviare l'ho trovata con:
Codice: Seleziona tutto
grep -r 'user-session=' /usr/share/lightdm/lightdm.conf.d/*.conf

ottengo:
Codice: Seleziona tutto
/usr/share/lightdm/lightdm.conf.d/50-ubuntu-mate.conf:user-session=mate

Come vedi a me risulta 'mate', guarda se trovi un file simile usando grep, e prova a cambiare l'impostazione.
Nel caso in cui sia il primo a rispondere ad una richiesta di aiuto...chiunque abbia una soluzione migliore o anche solo diversa dalla mia è incoraggiato ad intervenire liberamente senza inviarmi alcun messaggio privato. In programmazione è basilare sapere che si può ottenere il medesimo risultato utilizzando metodi diversi.
Avatar utente
UbuNuovo
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2834
Iscrizione: dicembre 2009
Desktop: Mate
Distribuzione: Ubuntu 14.04
Sesso: Maschile

Re: Impostare ambiente desktop e display manager predefinit

Messaggioda marck120 » giovedì 3 novembre 2016, 22:33

Questa è la procedura che ho usato per impostare il DE predefinito con il display manager sddm, seguendo questa guida : http://wiki.ubuntu-it.org/AmbienteGrafi ... OA_grafica

Prima cosa ho installato sddm su ubuntu (unity)

sudo apt-get install sddm

In seguito ho installato kde config :

i
Codice: Seleziona tutto
tx@itx-VirtualBox:~$ sudo apt-get install kde-config-sddm
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti NUOVI saranno installati:
  kde-config-sddm
0 aggiornati, 1 installati, 0 da rimuovere e 204 non aggiornati.
È necessario scaricare 78,9 kB di archivi.
Dopo quest'operazione, verranno occupati 472 kB di spazio su disco.
Scaricamento di:1 http://it.archive.ubuntu.com/ubuntu xenial/universe amd64 kde-config-sddm amd64 4:5.5.5-0ubuntu1 [78,9 kB]
Recuperati 78,9 kB in 0s (104 kB/s)       
Selezionato il pacchetto kde-config-sddm non precedentemente selezionato.
(Lettura del database... 215560 file e directory attualmente installati.)
Preparativi per estrarre .../kde-config-sddm_4%3a5.5.5-0ubuntu1_amd64.deb...
Estrazione di kde-config-sddm (4:5.5.5-0ubuntu1)...
Elaborazione dei trigger per dbus (1.10.6-1ubuntu3)...
Configurazione di kde-config-sddm (4:5.5.5-0ubuntu1)...
Elaborazione dei trigger



Il risultato è che il DE di unity non parte più e visualizzo solo uno schermo nero, poi con sudo apt-get install sddm mi ha installato anche una parte di desktop, infatti nel display manager ho in lista plasma, se vado d'accedere mi dice che manca la shell, non capisco perché installando sddm contemporaneamente installi anche il DE plasma.

Tramite il DE gnome ho dato il comando descritto nella guida :

Codice: Seleziona tutto
itx@itx-VirtualBox:~$ sudo kcmshell5 kcm_sddm
Recreating ksycoca file ("/home/itx/.cache/ksycoca5_it_C723fYx8dHRuYnXZw5EHppffgHQ=", version 303)
Menu "applications-kmenuedit.menu" not found.
The desktop entry file "/usr/share/applications/evolution-data-server-uoa.desktop" has Type= "Application" but no Exec line
kf5.kservice.sycoca: Invalid Service :  "/usr/share/applications/evolution-data-server-uoa.desktop"
The desktop entry file "/usr/share/applications/unity-lens-photos.desktop" has Type= "Application" but no Exec line
kf5.kservice.sycoca: Invalid Service :  "/usr/share/applications/unity-lens-photos.desktop"
The desktop entry file "/usr/share/applications/unity-scope-gdrive.desktop" has Type= "Application" but no Exec line
kf5.kservice.sycoca: Invalid Service :  "/usr/share/applications/unity-scope-gdrive.desktop"
Saving
false


IL comando sembra funzionare, mi fa impostare il DE predefinito, poi provo su kubuntu e vi do la conferma.

Immagine

@UbuNuovo

Un attimo e provo la procedura che mi hai indicato, per la condivisione dei file ho avuto un problema con il file N. 5 il resto dei file l 'ho inserito tra i codici.
Ultima modifica di marck120 il giovedì 3 novembre 2016, 22:40, modificato 2 volte in totale.
marck120
Prode Principiante
 
Messaggi: 231
Iscrizione: dicembre 2011

Re: Impostare ambiente desktop e display manager predefinit

Messaggioda daigo » giovedì 3 novembre 2016, 22:36

io ho provato a seguire la guida linkata da steff per sddm, ho installato la sessione gnome shell per fare le prove.

verificate le sessioni disponibili con
Codice: Seleziona tutto
ls -1 /usr/share/xsessions/
e ho
Codice: Seleziona tutto
gnome.desktop
plasma.desktop


allora ho modificato il file
Codice: Seleziona tutto
/etc/sddm.conf

Codice: Seleziona tutto
kdesudo kate /etc/sddm.conf

e modificato qui a Session ho messo gnome.desktop e a User il mio nome utente (kubuntu) salvato il file e riavviato si avvia direttamente gnome shell senza passare da sddm, se termini la sessione poi, hai sddm e scegli quella che vuoi
[Autologin]
Relogin=false
Session=gnome.desktop
User=kubuntu


[General]
HaltCommand=
RebootCommand=

[Theme]
CursorTheme=breeze_cursors

[Users]
MaximumUid=65000
MinimumUid=1000


EDIT: comunque anche se non tocco quel file, l'ho riportato a default, mi mostra sddm e se avvio gnome shell , mantiene comunque quella sessione di default in sddm al successivo riavvio o termine sessione
Avatar utente
daigo
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 18580
Iscrizione: maggio 2011

Re: Impostare ambiente desktop e display manager predefinit

Messaggioda marck120 » giovedì 3 novembre 2016, 23:48

UbuNuovo Immagine ha scritto:Ma che razza di servizio per la condivisione di file è quello! :devilmad:
io la voce che riguarda cosa avviare l'ho trovata con:
Codice: Seleziona tutto
grep -r 'user-session=' /usr/share/lightdm/lightdm.conf.d/*.conf

ottengo:
Codice: Seleziona tutto
/usr/share/lightdm/lightdm.conf.d/50-ubuntu-mate.conf:user-session=mate

Come vedi a me risulta 'mate', guarda se trovi un file simile usando grep, e prova a cambiare l'impostazione.


La procedura funziona, è andata a buon fine, cioè ho trovato il file e l'ho configurato, il problema è che parte sempre il DE in cui accedo, cioè se entro su gnome parte predefinito gnome, se entro su ubuntu poi parte predefinito ubuntu (unity) ma a te ha funzionato la procedura ? a me sembra che non prenda l'impostazione :

Immagine

Immagine
marck120
Prode Principiante
 
Messaggi: 231
Iscrizione: dicembre 2011

Re: Impostare ambiente desktop e display manager predefinit

Messaggioda marck120 » giovedì 3 novembre 2016, 23:53

daigo Immagine ha scritto:io ho provato a seguire la guida linkata da steff per sddm, ho installato la sessione gnome shell per fare le prove.

verificate le sessioni disponibili con
Codice: Seleziona tutto
ls -1 /usr/share/xsessions/
e ho
Codice: Seleziona tutto
gnome.desktop
plasma.desktop


allora ho modificato il file
Codice: Seleziona tutto
/etc/sddm.conf

Codice: Seleziona tutto
kdesudo kate /etc/sddm.conf

e modificato qui a Session ho messo gnome.desktop e a User il mio nome utente (kubuntu) salvato il file e riavviato si avvia direttamente gnome shell senza passare da sddm, se termini la sessione poi, hai sddm e scegli quella che vuoi
[Autologin]
Relogin=false
Session=gnome.desktop
User=kubuntu


[General]
HaltCommand=
RebootCommand=

[Theme]
CursorTheme=breeze_cursors

[Users]
MaximumUid=65000
MinimumUid=1000


EDIT: comunque anche se non tocco quel file, l'ho riportato a default, mi mostra sddm e se avvio gnome shell , mantiene comunque quella sessione di default in sddm al successivo riavvio o termine sessione


Adesso provo la procedura.
marck120
Prode Principiante
 
Messaggi: 231
Iscrizione: dicembre 2011

Re: Impostare ambiente desktop e display manager predefinit

Messaggioda UbuNuovo » venerdì 4 novembre 2016, 0:08

Ho provato a cambiare l'impostazione di user-session ma sembra che non abbia effetto! :(
Nel caso in cui sia il primo a rispondere ad una richiesta di aiuto...chiunque abbia una soluzione migliore o anche solo diversa dalla mia è incoraggiato ad intervenire liberamente senza inviarmi alcun messaggio privato. In programmazione è basilare sapere che si può ottenere il medesimo risultato utilizzando metodi diversi.
Avatar utente
UbuNuovo
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2834
Iscrizione: dicembre 2009
Desktop: Mate
Distribuzione: Ubuntu 14.04
Sesso: Maschile

Re: Impostare ambiente desktop e display manager predefinit

Messaggioda marck120 » venerdì 4 novembre 2016, 0:14

marck120 Immagine ha scritto:
daigo Immagine ha scritto:io ho provato a seguire la guida linkata da steff per sddm, ho installato la sessione gnome shell per fare le prove.

verificate le sessioni disponibili con
Codice: Seleziona tutto
ls -1 /usr/share/xsessions/
e ho
Codice: Seleziona tutto
gnome.desktop
plasma.desktop


allora ho modificato il file
Codice: Seleziona tutto
/etc/sddm.conf

Codice: Seleziona tutto
kdesudo kate /etc/sddm.conf

e modificato qui a Session ho messo gnome.desktop e a User il mio nome utente (kubuntu) salvato il file e riavviato si avvia direttamente gnome shell senza passare da sddm, se termini la sessione poi, hai sddm e scegli quella che vuoi
[Autologin]
Relogin=false
Session=gnome.desktop
User=kubuntu


[General]
HaltCommand=
RebootCommand=

[Theme]
CursorTheme=breeze_cursors

[Users]
MaximumUid=65000
MinimumUid=1000


EDIT: comunque anche se non tocco quel file, l'ho riportato a default, mi mostra sddm e se avvio gnome shell , mantiene comunque quella sessione di default in sddm al successivo riavvio o termine sessione


Adesso provo la procedura.


Ecco qui.

Allora come desktop ho questi :

Codice: Seleziona tutto
itx@itx:~$ ls -1 /usr/share/xsessions/
gnome-classic.desktop
gnome.desktop
plasma.desktop
ubuntu.desktop
itx@itx:~$


Ubuntu purtroppo non parte più.

Andando avanti nella procedura con etc/sddm.conf ho accesso negato, anche a te è successo lo stesso ?

Codice: Seleziona tutto
itx@itx:~$ /etc/sddm.conf
bash: /etc/sddm.conf: Permesso negato
itx@itx:~$ sudo su
[sudo] password di itx:
root@itx:/home/itx# /etc/sddm.conf
bash: /etc/sddm.conf: Permesso negato


L'ultimo comando che mi hai indicato :

Codice: Seleziona tutto
root@itx:/home/itx# kdesudo kate /etc/sddm.conf
Config timer connecting...
Setting the name of  0x560828a2fb80  to  "org.kde.ActivityManager.ActivityTemplates"
Setting the name of  0x560828a2ebc0  to  "org.kde.ActivityManager.RunApplication"
Setting the name of  0x560828a41950  to  "org.kde.ActivityManager.Resources.Scoring"
Creating directory:  "/root/.local/share/kactivitymanagerd/resources/"
KActivities: Database connection:  "kactivities_db_resources_140121511249408_readwrite"
    query_only:          QVariant(qlonglong, 0)
    journal_mode:        QVariant(QString, "wal")
    wal_autocheckpoint:  QVariant(qlonglong, 100)
    synchronous:         QVariant(qlonglong, 1)
Service started, version: 7.0.0
Cleaning up...


Con kdesudo kate /etc/sddm.conf si apre un file di testo con dentro questo contenuto :

Codice: Seleziona tutto
[Autologin]
User=itx
Session=plasma.desktop


Adesso imposto gnome come desktop e ti faccio sapere se funziona.

EDIT :

Funziona alla perfezione, peccato per LightDM, certo se si potesse installare sddm su Unity, io ho provato ma è successo un pasticcio.
Ultima modifica di marck120 il venerdì 4 novembre 2016, 0:35, modificato 2 volte in totale.
marck120
Prode Principiante
 
Messaggi: 231
Iscrizione: dicembre 2011

Successiva

Torna a Altri ambienti desktop e window manager

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 1 ospite