Problema: scheda ATI sembra avere 3D lento

Problemi riscontrati nella Edgy (Ubuntu 6.10) in fase di sviluppo.
Avatar utente
stitch
Prode Principiante
Messaggi: 189
Iscrizione: domenica 9 luglio 2006, 21:56
Località: MILANO

Problema: scheda ATI sembra avere 3D lento

Messaggio da stitch »

Ciao, ho un problema con la mia scheda ATI Radeon 9550SE:premetto che con Dapper funzionava bene, ma con Edgy ho notato questo:

1) L'output di fglrxinfo è questo:
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)

ma dovrebbe essere ATI, perchè io avevo installato il driver proprietario ATI ver. 8.28.08

2) il classico glxgears funziona, ma è MOLTO lento
3) GoogleEarth non va oltre la finestra Initializing...

ho seguito la guida disponibile su http://wiki.cchtml.com/index.php/Ubuntu ... 88.28.8.29
ma senza successo, il risultato è sempre lo stesso.

ci sono problemi con le ATI ? O è un problema Edgy ?

Grazie

ciao/Dimitri
Avatar utente
Pixel
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 2714
Iscrizione: lunedì 29 maggio 2006, 14:24
Sesso: Maschile
Località: Forlimpopoli

Re: Problema: scheda ATI sembra avere 3D lento

Messaggio da Pixel »

Per le ATI (per ora) è necessario utilizzare il driver open presente nei repo, fglrx fa' a cazzotti con il 3d.
A riguardo c'è un thread molto particolareggiato.
Ciao
Ubuntu User 4683 Comunità Italiana Gambas  
Non chiedetevi cosa Ubuntu-it può fare per voi ma chiedetevi cosa potete fare voi per Ubuntu-it
Avatar utente
l3on
Gruppo Web
Gruppo Web
Messaggi: 6443
Iscrizione: sabato 20 maggio 2006, 19:03
Località: Bologna
Contatti:

Re: Problema: scheda ATI sembra avere 3D lento

Messaggio da l3on »

Scusa pixel, non per contraddirti, ma io ho i driver proprietari e il 3d abilitato...
Ho seguito questo howto: Driver Proprietari ATI (è la stessa guida di stitch)

Se lo segui con attenzione, c'è la possibilita' che ti funge... provalo stitch!
Magari dagli un'occhiata anche tu Pixel forse risolvi...

EDIT: prima pero' dovresti togliere tutto dell'installazione fglrx dei repo...
Ultima modifica di l3on il martedì 24 ottobre 2006, 10:08, modificato 1 volta in totale.
Pagina Personale sul Wiki - Sito Personale - Blog | `l3on @ ubuntu.com` .

Ex "Membro del Consiglio, Sysadmin e Web-Designer dei portali della comunità, Amministratore del Sito e tante altre cose..." Con Ubuntu-it dal maggio del 2006.
Avatar utente
redgun
Prode Principiante
Messaggi: 166
Iscrizione: martedì 30 maggio 2006, 9:59
Contatti:

Re: Problema: scheda ATI sembra avere 3D lento

Messaggio da redgun »

http://linubuntu.blogspot.com/  il mio blog
http://planimo.sf.net  instant messenger per rete locale in python
http://cgmail.tuxfamily.org mail notifier con supporto a gnome keyring e dbus
Avatar utente
Pixel
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 2714
Iscrizione: lunedì 29 maggio 2006, 14:24
Sesso: Maschile
Località: Forlimpopoli

Re: Problema: scheda ATI sembra avere 3D lento

Messaggio da Pixel »

@L3oN e redgun
Personalmente le ho provate un po' tutte ma non ho ancora risolto, comunque, alla luce degli ultimi aggiornamenti di Edgy può darsi (e sottolineo può darsi) che funzionino. Stasera riprovo poi vi dico.
Grazie a tutti per le info.
Pix
Ubuntu User 4683 Comunità Italiana Gambas  
Non chiedetevi cosa Ubuntu-it può fare per voi ma chiedetevi cosa potete fare voi per Ubuntu-it
Avatar utente
stitch
Prode Principiante
Messaggi: 189
Iscrizione: domenica 9 luglio 2006, 21:56
Località: MILANO

Re: Problema: scheda ATI sembra avere 3D lento

Messaggio da stitch »

Grazie a tutti. Questa sera ri-proverò magari eliminando le fglrx prima

ciao/Dimitri
Avatar utente
stitch
Prode Principiante
Messaggi: 189
Iscrizione: domenica 9 luglio 2006, 21:56
Località: MILANO

Re: Problema: scheda ATI sembra avere 3D lento

Messaggio da stitch »

Ho provato il sistema suggerito da L3on, ma non c'è verso. Ecco l'output di glxinfo:

name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample,
GLX_ATI_pixel_format_float, GLX_ATI_render_texture
GLX version: 1.2
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_multisample
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 24 tc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None
0x24 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None
0x25 24 tc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x26 24 tc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x27 24 dc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None
0x28 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None
0x29 24 dc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x2a 24 dc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None

e il comando glxgears funziona, ma le ruote vanno lente e a scatti. Il bello è che partono bene, ma dopo un secondo rallentano.... molto strano, e secondo me i driver ATI ancora non sono installati, oppure sono installati parzialmente.

Altre idee ?
Avatar utente
stitch
Prode Principiante
Messaggi: 189
Iscrizione: domenica 9 luglio 2006, 21:56
Località: MILANO

Re: Problema: scheda ATI sembra avere 3D lento

Messaggio da stitch »

...intendo, aspettando la versione definitiva ? ;-)
Avatar utente
l3on
Gruppo Web
Gruppo Web
Messaggi: 6443
Iscrizione: sabato 20 maggio 2006, 19:03
Località: Bologna
Contatti:

Re: Problema: scheda ATI sembra avere 3D lento

Messaggio da l3on »

Qual è l'out di fglrxinfo ?
Pagina Personale sul Wiki - Sito Personale - Blog | `l3on @ ubuntu.com` .

Ex "Membro del Consiglio, Sysadmin e Web-Designer dei portali della comunità, Amministratore del Sito e tante altre cose..." Con Ubuntu-it dal maggio del 2006.
Avatar utente
Pixel
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 2714
Iscrizione: lunedì 29 maggio 2006, 14:24
Sesso: Maschile
Località: Forlimpopoli

Re: Problema: scheda ATI sembra avere 3D lento

Messaggio da Pixel »

Come volevasi dimostrare, se voglio 3d, aiglx e compiz mi devo dimenticare che esiste fglrx...
Inoltre una volta installato il driver se voglio ripristinare il sistema non è sufficiente rimettere il vecchio xorg.conf, ma è necessario rimuovere completamente il pacchetto fglrx e i restricted modules del kernel.... mah.. (mad)
Ciao
Pix
Ubuntu User 4683 Comunità Italiana Gambas  
Non chiedetevi cosa Ubuntu-it può fare per voi ma chiedetevi cosa potete fare voi per Ubuntu-it
Avatar utente
stitch
Prode Principiante
Messaggi: 189
Iscrizione: domenica 9 luglio 2006, 21:56
Località: MILANO

Re: Problema: scheda ATI sembra avere 3D lento

Messaggio da stitch »

Per L3on:

display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)

esattamente come prima.

Tra l'altro, se tento di eseguire l'installazione "normale" dei driver ATI (come avevo fatto con Dapper) ecco l'output del comando:

Creating directory fglrx-install
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.20.8............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
-e ==================================================
-e ATI Technologies Linux Driver Installer/Packager
-e ==================================================
./ati-installer.sh: 90: Syntax error: Bad substitution
Removing temporary directory: fglrx-install

questo errore non lo dava in Dapper....

Lascio agli esperti la sentenza ;)
Avatar utente
stitch
Prode Principiante
Messaggi: 189
Iscrizione: domenica 9 luglio 2006, 21:56
Località: MILANO

Re: Problema: scheda ATI sembra avere 3D lento

Messaggio da stitch »

Aggiungo che non mi è perfettamente chiara la differenza tra i vari glx, fglrx, ecc...
Questo probabilmente non mi aiuta nella comprensione del problema...

che odio l'ignoranza !
:D
Avatar utente
l3on
Gruppo Web
Gruppo Web
Messaggi: 6443
Iscrizione: sabato 20 maggio 2006, 19:03
Località: Bologna
Contatti:

Re: Problema: scheda ATI sembra avere 3D lento

Messaggio da l3on »

Bene, proviamo a procedere insieme, passo dopo passo...



Innanzi tutto togliamo tutto della vecchia installazione
(fglrx dei repo):


- Eliminiamo le righe aggiunte all'xorg (non sono sicuro che questo passaggio serva, io l'ho fatto lo stesso per sicurezza):

Codice: Seleziona tutto

sudo gedit /etc/X11/xorg.conf
e cancelliamo le seguenti linee in fondo al file:

Codice: Seleziona tutto

Section "Extensions"
        Option  "Composite" "0"
EndSection
se non ci sono, non preoccupiamoci piu' di tanto e andiamo avanti.

- Disinstalliamo i pacchetti aggiunti:

Codice: Seleziona tutto

xorg-driver-fglrx
(stando alla guida che hai seguito, dovresti eliminare solo questo pacchetto... Dai una sbirciata in synaptic per essere sicuri che tu non abbia altri pacchetti aggiunti!)

- Riconfiguriamo xorg: questo passo è fondamentale, il fine dell'intera installazione puo' dipendere da questo passo!

Codice: Seleziona tutto

 sudo dpkg-reconfigure xserver-xorg
e scegliamo al momento opportuno i soliti driver Vesa.

Riavviamo...





Bene ora installiamo gli altri driver!


- Prima cosa prima di procedere: iniziamo a scaricare i driver: ati-driver-installer-8.29.6.run (nota: driver per i 32bit!)
Vi consiglio di utilizzare una estensione di firefox per aumentare la velocita' di down: DownThemAll


- Rimettiamo la nuova Sezione in xorg:

Codice: Seleziona tutto

sudo gedit /etc/X11/xorg.conf
e incolliamo alla fine del file queste righe:

Codice: Seleziona tutto

Section "Extensions"
        Option  "Composite" "0"
EndSection
salviamo e chiudiamo.

- Eliminiamo il problema a monte:

Codice: Seleziona tutto

sudo gedit /etc/default/linux-restricted-modules-common
e cambiamo il righo:

Codice: Seleziona tutto

DISABLED_MODULES=" "
con questa:

Codice: Seleziona tutto

DISABLED_MODULES="fglrx"
salviamo e chiudiamo.

- Aggiorniamo e installiamo i pacchetti:

Codice: Seleziona tutto

sudo apt-get update
sudo apt-get install module-assistant build-essential 
sudo apt-get install fakeroot dh-make debconf libstdc++5 linux-headers-$(uname -r)
- CI posizionamo nella cartella dove sono stati scarivati i driver ATI, e diamo questi comandi (cosi' verrano creati i deb):

Codice: Seleziona tutto

sudo ln -sf bash /bin/sh
bash ati-driver-installer-8.29.6.run --buildpkg Ubuntu/edgy
sudo ln -sf dash /bin/sh
- Installiamo:

Codice: Seleziona tutto

sudo dpkg -i xorg-driver-fglrx_8.29.6-1_i386.deb
sudo dpkg -i fglrx-kernel-source_8.29.6-1_i386.deb
sudo dpkg -i fglrx-control_8.29.6-1_i386.deb
sudo rm /usr/src/fglrx-kernel*.deb
Se l'ultimo comando da problemi, non vi preoccupate.

- E compiliamo il modulo:

Codice: Seleziona tutto

sudo module-assistant prepare
sudo module-assistant update
sudo module-assistant build fglrx
sudo module-assistant install fglrx
sudo depmod -a
- Facciamo la solita modifica all'xorg per utilizzare i driver:

Codice: Seleziona tutto

sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv
Riavviamo...






e preghiamo che il risultato sia questo:

Codice: Seleziona tutto

$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9700 Generic
OpenGL version string: 2.0.6065 (8.29.6)
E questo:

Codice: Seleziona tutto

$ glxinfo | grep render
direct rendering: Yes






In caso negativo, potremmo provare a creare un link simbolico cosi
:

Codice: Seleziona tutto

sudo mkdir /usr/X11R6/lib/modules
sudo ln -s /usr/lib/dri /usr/X11R6/lib/modules/




Buona fortuna  ;)
Ultima modifica di l3on il martedì 24 ottobre 2006, 23:03, modificato 1 volta in totale.
Pagina Personale sul Wiki - Sito Personale - Blog | `l3on @ ubuntu.com` .

Ex "Membro del Consiglio, Sysadmin e Web-Designer dei portali della comunità, Amministratore del Sito e tante altre cose..." Con Ubuntu-it dal maggio del 2006.
Avatar utente
stitch
Prode Principiante
Messaggi: 189
Iscrizione: domenica 9 luglio 2006, 21:56
Località: MILANO

Re: Problema: scheda ATI sembra avere 3D lento

Messaggio da stitch »

Dunque, al momento della compilazione, sul comando sudo module-assistant build fglrx, ecco l'output (vedi allegati). C'è di sicuro qualcosa che non va (o che manca)...
Allegati
due.jpg
uno.jpg
Ultima modifica di stitch il martedì 24 ottobre 2006, 23:13, modificato 1 volta in totale.
Avatar utente
l3on
Gruppo Web
Gruppo Web
Messaggi: 6443
Iscrizione: sabato 20 maggio 2006, 19:03
Località: Bologna
Contatti:

Re: Problema: scheda ATI sembra avere 3D lento

Messaggio da l3on »

Per curiosita' ma che kernel hai? Posta l'out di questo:

Codice: Seleziona tutto

uname -r
PS:sicuro di avere tutto aggiornato?

Codice: Seleziona tutto

sudo apt-get update && sudo apt-get dist-upgrade
Ultima modifica di l3on il martedì 24 ottobre 2006, 23:17, modificato 1 volta in totale.
Pagina Personale sul Wiki - Sito Personale - Blog | `l3on @ ubuntu.com` .

Ex "Membro del Consiglio, Sysadmin e Web-Designer dei portali della comunità, Amministratore del Sito e tante altre cose..." Con Ubuntu-it dal maggio del 2006.
Avatar utente
stitch
Prode Principiante
Messaggi: 189
Iscrizione: domenica 9 luglio 2006, 21:56
Località: MILANO

Re: Problema: scheda ATI sembra avere 3D lento

Messaggio da stitch »

Questa sera controllo, poi ti faccio sapere.
Grazie per la pazienza ;-)
Avatar utente
Kcris22
Prode Principiante
Messaggi: 49
Iscrizione: mercoledì 25 ottobre 2006, 10:26

Re: Problema: scheda ATI sembra avere 3D lento

Messaggio da Kcris22 »

In definitiva, per chi ha questa benedetta scheda ati, cosa è meglio fare?
Installare i driver da repository o quelli dal sito e costruirsi il .deb?

Non mi aggredite.... (sono abb. niubbo :D)!!!
Avatar utente
newbee5012
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 329
Iscrizione: venerdì 10 marzo 2006, 8:53

Re: Problema: scheda ATI sembra avere 3D lento

Messaggio da newbee5012 »

mah..

ti chiedi se è meglio morire impiccati o fucilati..
questione di gusti!

Ho una X700 e ai mitici due metodi gli fa un baffo..
(con edgy, mentre dapper con ati proprietari funzionava)

I have a dream:
$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: mesa ATI Technologies Inc.
OpenGL renderer string: mesa RADEON x700
OpenGL version string: 2.0.6065 (8.29.6)
Avatar utente
stitch
Prode Principiante
Messaggi: 189
Iscrizione: domenica 9 luglio 2006, 21:56
Località: MILANO

Re: Problema: scheda ATI sembra avere 3D lento

Messaggio da stitch »

Per L3on:

ver. 2.6.15-27-386

e, sì l'aggiornamento è completo
Avatar utente
stitch
Prode Principiante
Messaggi: 189
Iscrizione: domenica 9 luglio 2006, 21:56
Località: MILANO

Re: Problema: scheda ATI sembra avere 3D lento

Messaggio da stitch »

Ad ogni modo dobbiamo anche riconoscere che utilizzando una RC non siamo ancora sicuri che la ATI (oppure altro) non funzionerà nemmeno dopo.
E poi voglio dare fiducia a Mark ;)
C'è poi da dire che secondo me con la nuova versione sono cambiate molte più cose di quelle annunciate pubblicamente...

I have the same dream:
$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: mesa ATI Technologies Inc.
OpenGL renderer string: mesa RADEON x700
OpenGL version string: 2.0.6065 (8.29.6)

:D
Ultima modifica di stitch il mercoledì 25 ottobre 2006, 21:39, modificato 1 volta in totale.
Scrivi risposta

Ritorna a “Edgy 6.10”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 1 ospite