ubuntu 11.04 toshiba ac100

Problematiche specifiche di hardware e software su sistemi SPARC, IA-64, HP PA-RIsc e altri.
Wonder Boy
Prode Principiante
Messaggi: 16
Iscrizione: giovedì 1 maggio 2008, 11:37

Re: ubuntu 11.04 toshiba ac100

Messaggio da Wonder Boy »

Grazie per le risposte, ti ricordi dove avevi letto di quel tipo che ha installato sia linux che android?
Comunque per il decoding, avevo letto questo thread dove si parla delle api OpenMAX per il decoding video che dovrebbero essere supportate dai driver tegra. Speriamo che qualcuno sviluppi qualcosa in questo senso.
gyppe
Prode Principiante
Messaggi: 42
Iscrizione: giovedì 24 novembre 2011, 11:58

Re: ubuntu 11.04 toshiba ac100

Messaggio da gyppe »

pedlo ha scritto:
gyppe ha scritto: Mi da errori anche provando a far installare il driver ad aircrack:

Codice: Seleziona tutto

sudo airdriver-ng install 36
Driver "Realtek rtl8187" specified for installation.
Kernel headers missing!
Failed to install the driver.
Look through "/var/log/airdriver" for errors.
Secondo me mi manca qualche pacchetto apposito per compilare i soli moduli, oppure qualche configurazione da fare chissà dove.
ti chiede di installare gli headers del kernel 2.6.38, che andrebbeo messi in /lib/modules/2.6.38-1001-ac100
Ci sono! Forse è buggato aircrack? Boh, ormai non ci capisco più nulla!

Per i driver, non avevo già spiegato? Io ormai ho fatto mille test e non sono più sicuro di come ho attivato l'audio ne il flash, nessuno sperimenta, così non ne usciamo più. :D
Comunque per il flash, dovrebbe bastare installare solo questo:
https://launchpad.net/~ac100/+archive/p ... _armel.deb

E con chromium dovrebbe andare, con firefox ho letto che va ugualmente ma non ci sono riuscito perchè non so come fargli usare i driver che lui ritiene obsoleti.

Come potenza, mi sembra piuttosto più veloce del mio 901 nonostante questo sistema completamente incasinato e strapieno di servizi attivi e consumo di ram vergognoso. Ho provato qualche video youtube a mi pare 720 e li visualizzava bene anche a pieno schermo, con l'eee a 1.6GHz non riuscivo, 1080 non ricordo ma credo dovrebbe farli andare, il tegra è potentissimo il problema sono solo i driver, ma infondo credo abbiamo gli stessi driver di android e con quello l'hd era "garantito".

Comunque, ormai funziona tutto, da tenere conto che è tutto praticamente in alfa (anche android), che ubuntu è pesantissimo e non si riesce a levare il superfluo. Più che altro andrebbe un po allegerito il sistema per evitare qualche rallentamento quando la ram inspiegabilmente si riempie, sul eee stavo bene con 90Mb di ram e pochissimi servizi caricati qui sto a 150 e non ero mai andato oltre 3-400 in uso con firefox e film, qui si riempiono tutti i 500Mb e anche lo swap con si e no due schede aperte, boh?

Comunque ci va tutto, mancano giusto qualche rifinitura come attivare i tasti rapidi, accendere-spegnere il wifi fisicamente, l'uscita audio del hdmi non sono riuscito a farla andare (e non so se ci sia o no), non ho capito come attivare le cuffie ma in compenso mi funzionano bene le casse, e direi basta.

Insomma è ancora un po da sviluppare, e se non ci si mette un po tutti a smanettarci e raccogliere dati va a finire che si blocca lo sviluppo e questo mega portatile non lo sfrutteremo mai come si deve.
gyppe
Prode Principiante
Messaggi: 42
Iscrizione: giovedì 24 novembre 2011, 11:58

Re: ubuntu 11.04 toshiba ac100

Messaggio da gyppe »

Ho sistemato cromium che ultimamente mi funzionava male, ho anche attivato l'accelerazione come spiegato in quella guida, ma mi pare proprio che non vada bene oltre i 480 con i video. Probabilmente la volta scorsa mi ero confuso, visto che con la mia linea lenta non posso mai andare oltre i 240.
gyppe
Prode Principiante
Messaggi: 42
Iscrizione: giovedì 24 novembre 2011, 11:58

Re: ubuntu 11.04 toshiba ac100

Messaggio da gyppe »

Dunque, in questo repo: deb http://people.debian.org/~jak/ac100/ unreleased main non-free

Si trova oltre al kernel migliorato, i driver nvidia e qualche altra roba apposita per ac100, il pacchetto xserver-xorg-video-tegra, che dovrebbe appunto gestire il server grafico usando l'accelerazione tegra, credo almeno.
Però come dovrei usarlo? Con questa versione di ubuntu è cambiato tutto quanto, non riesco neppure a xorg.conf, la gestione driver proprietari non rileva niente, e la gestione schermo neppure, come fare a capire se sto usando questo pacchetto o no?
marcobh5
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 551
Iscrizione: domenica 3 agosto 2008, 14:36

Re: ubuntu 11.04 toshiba ac100

Messaggio da marcobh5 »

gyppe ha scritto: Dunque, in questo repo: deb http://people.debian.org/~jak/ac100/ unreleased main non-free

Si trova oltre al kernel migliorato, i driver nvidia e qualche altra roba apposita per ac100, il pacchetto xserver-xorg-video-tegra, che dovrebbe appunto gestire il server grafico usando l'accelerazione tegra, credo almeno.
Però come dovrei usarlo? Con questa versione di ubuntu è cambiato tutto quanto, non riesco neppure a xorg.conf, la gestione driver proprietari non rileva niente, e la gestione schermo neppure, come fare a capire se sto usando questo pacchetto o no?
hai letto il readme del link? hai aggiunto il repo e installatoi file? io sono senza net da circa 3 mesi (assistenza)
[Guida] accelerare video hd h264 wmv9 con ati 4xxx 5xxx series (smplayer xbmc vlc)
http://forum.ubuntu-it.org/viewtopic.php?t=401372
gyppe
Prode Principiante
Messaggi: 42
Iscrizione: giovedì 24 novembre 2011, 11:58

Re: ubuntu 11.04 toshiba ac100

Messaggio da gyppe »

3 mesi in assistenza, caspita! :O

Si ho letto, dice appunto che xorg-tegra è per armel, proprio quello che serve a noi, ma non capisco come farlo andare, boh.
Provando con powertop che visualizza anche le operazioni della scheda video, ho visto che non viene mai utilizzata ne navigando con chromium (con accelerazione attivata) ne vedendo video, dovrei provare magari con un gioco 3d ma dubito funzioni uguale.
Quindi o i driver non sono attivi e la scheda video non viene proprio usata, oppure funziona male powertop e non rileva quando la gpu lavora.
gyppe
Prode Principiante
Messaggi: 42
Iscrizione: giovedì 24 novembre 2011, 11:58

Re: ubuntu 11.04 toshiba ac100

Messaggio da gyppe »

Ciao a tutti, per favore qualcuno potrebbe postarmi il contenuto di lsusb?

L'altro giorno stavo provando un nuovo kernel e ho bloccato tutto, così ho reinstallato ma ora non mi va il mouse, non credo sia andato solo perchè mi è caduto sul tavolo da si e no 5 cm di altezza!
Vorrei vedere se almeno viene riconosciuto ma non so come si chiama, grazie mille in anticipo.
marcobh5
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 551
Iscrizione: domenica 3 agosto 2008, 14:36

Re: ubuntu 11.04 toshiba ac100

Messaggio da marcobh5 »

staccalo dai lsusb attaccalo e ridai il comando e vedi se ci sono differenze
[Guida] accelerare video hd h264 wmv9 con ati 4xxx 5xxx series (smplayer xbmc vlc)
http://forum.ubuntu-it.org/viewtopic.php?t=401372
Avatar utente
Xan
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 261
Iscrizione: domenica 31 dicembre 2006, 15:06
Località: Colleferro RM

Re: ubuntu 11.04 toshiba ac100

Messaggio da Xan »

un po di info generiche

confronto tegra2 vs ATOM (uno qualunque, tanto so tutti uguali)

CPU: sono pressochè uguali (forse leggermente migliore l'ATOM) come potenza. anche a livello software sono ben supportate tutte e 2 compresi gli step per la frequenza e il resto

GPU: (arrivano i dolori) la GPU tegra 2 è incalcolabilmente migliore di quella dell'ATOM, il problema è che a livello di driver la sk video ATOM è perfettamente supportata avendo i driver open source scritti direttamente da intel. mentre per tegra2 i driver in pratica non esistono. nvidia non supporta minimamente il mondo open source e i driver che fa sono 2:
1 per geforce desktop e portatili per linux
2 per tegra per android

ora visto che tegra 2 come gpu non è molto diversa dalle geforce e che il kernel modificato di android non è molto diverso del kernel usato da ubuntu, la comunità sta cercando di unire le 2 cose per arrivare ad un driver specifico

di fatto nvidia non supporta ubuntu su piattaforma tegra e ad oggi non risponde proprio alle domande, un buco nero

ad oggi su ac100 usiamo un driver universale che sfrutta al 0.1% la scheda video


l'unico fattore positivo è che nvidia vuole far entrare i suoi driver per tegra direttamente dentro android per averli più integrati, e per far questo deve rilasciarli open, se lo fanno il porting sarà molto piu facile. tenete tutti le dita incrociate!!!!
Alessandro Scarozza - La risposta alla domanda numero 1: perché odi la microsoft?
Se un device non funziona su osx la colpa è del device, se non funziona su gnu/linux la colpa è di gnu/linux.
gyppe
Prode Principiante
Messaggi: 42
Iscrizione: giovedì 24 novembre 2011, 11:58

Re: ubuntu 11.04 toshiba ac100

Messaggio da gyppe »

Grazie marco, avevo anche provato smontando tutto ma non cambiava nulla, poi improvvisamente ha ripreso a funzionare, mah!

Copio la lista così rimane, potrebbe sempre servire:

Codice: Seleziona tutto

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 0424:2512 Standard Microsystems Corp. USB 2.0 Hub
Bus 002 Device 002: ID 0424:2513 Standard Microsystems Corp. 
Bus 001 Device 003: ID 0db0:3871 Micro Star International 
Bus 001 Device 004: ID 0db0:a871 Micro Star International 
Bus 002 Device 003: ID 0bda:58f2 Realtek Semiconductor Corp. 
Vero xan, come processore è davvero potente, e ora credo anzi è ancora poco supportato anche quello, basta pensare che c'è un'intera sezione per la virgola mobile inutilizzata (si fa con il processore) e anche un interprete java hardware, roba che volerebbe! E sopratutto consuma niente, ora con le gestioni energetiche ancora mica ben attive, l'intero sistema ATTIVO a schermo spento consuma circa 2.3W CON WIFI ATTIVO! E già si parla di 11 ore di autonomia, ma esiste la possibilità dello standby dal consumo di pochi mW ma con diverse funzioni attive come ricezione di email (quindi connessione attiva) o lettura mp3, che però anche lei non è attiva a livello software, per cui l'autonomia salirebbe realmente a mesi con la piccolissima batteria disponibile. La potenza nel caso si attivassero le periferiche hardware sarebbe enormente più alta e probabilmente consumerebbe pure meno di adesso!

Insomma questo affare è almeno 5 se non 10 anni avanti rispetto agli intel, roba quasi fantascientifica direi, il problema davvero grave è il software, speriamo che la comunità non abbandoni lo sviluppo!
Sembra di no, proprio ieri è uscito anche un bootloader multiboot, che potrebbe permettere di caricare o finalmente Debian, o magari fare un multiboot con android-linux a scelta, è tutto freschissimo e da provare:

http://ac100.grandou.net/multiboot?Doku ... c65252b133

Dopo aver appena reinstallato, confermo che senza il kernel apposito l'audio esterno non funziona, non esiste proprio la periferica in alsamixer, mentre per il flash è sufficiente installare i driver nvidia e scaricare il plugin flash di android, come ho spiegato più sopra. Non ho provato le cuffie ma suppongo funzionino.

Fa ben sperare il fatto che pare che il tegra stia cominciando a essere impiegato da diverse case, la asus sta per lanciare a giorni il tegra 3 su eepad trasformer prime, che è identico al nostro ma quad core e pare consumi addirittura un po meno, almeno stando alle autonomie reali dichiarate con la stessa batteria del nostro. Ma probabilmente è solo questione di periferiche con gestione energetica migliore, e probabilmente di driver migliori visto che ci gira android 3 di fabbrica ed è già disponibile il 4.
Ultima modifica di gyppe il giovedì 15 dicembre 2011, 11:26, modificato 1 volta in totale.
gyppe
Prode Principiante
Messaggi: 42
Iscrizione: giovedì 24 novembre 2011, 11:58

Re: ubuntu 11.04 toshiba ac100

Messaggio da gyppe »

Per l'audio, non serve neppure aggiornare il kernel, è già tutto fatto nei repo ufficiali di ubuntu. Basta fare i normali aggiornamenti, poi andare in alsamixer e impostare su speaker, se il volume vi sembra basso basta impostare su vmid e si avrà piena potenza ma rumori in sottofondo quando non si riproduce niente.
marcobh5
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 551
Iscrizione: domenica 3 agosto 2008, 14:36

Re: ubuntu 11.04 toshiba ac100

Messaggio da marcobh5 »

il problema di questo net è NVIDIA! la comunità pur troppo i miracoli non li può fere. lato software/driver è penoso. anche su android! prova a far girare un video 1080p su android. e anche su un galaxy fai girare i 720 ma non tutti nemmeno quelli. dopo più di un anno nvidia rilascia 4 caz...te per di più in beta e non sfruttano l'hardware. è davvero penosa questa cosa e loro sul sito te la garantiscono la riproduzione in 1080p mi devono far vedere come però! pensa che leggevo di tegra 3 che video 1080p con profilo alto, la cosa mi ha fatto un po ridere, spero che stavolta almeno x il tre lo supportino un pò meglio se no per conto mio possono tenerlo sugli scaffali!
[Guida] accelerare video hd h264 wmv9 con ati 4xxx 5xxx series (smplayer xbmc vlc)
http://forum.ubuntu-it.org/viewtopic.php?t=401372
gyppe
Prode Principiante
Messaggi: 42
Iscrizione: giovedì 24 novembre 2011, 11:58

Re: ubuntu 11.04 toshiba ac100

Messaggio da gyppe »

Certo che se non si muovono e diventa obsoleto prima di poterlo usare, ci vorrebbe una bella class action e farli pagare tutti i danni, a questo punto si parlerebbe di truffa, visto che ti garantiscono cose che poi in realtà non sono vere manco alla lontana. Ho letto anche io il sito, ma credevo che almeno su android fosse vero, poi in effetti sento ovunque che anche li lo standby non va, che i video vanno a scatti, etc, etc.
Dovremmo smettere di comprare cose non supportate, come era successo per l'archos5, mega sistema, costo molto basso, e poi lo fermano ad android 1.6 senza flash dopo neppure un anno.

Che cacchio se non la finiamo di comprare ogni 6 mesi nuove cose non avremo mai niente di buono e loro faranno sempre peggio, sopratutto ora che stanno uscendo nuovi sistemi che richiedono molto tempo per lo sviluppo software.
marcobh5
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 551
Iscrizione: domenica 3 agosto 2008, 14:36

Re: ubuntu 11.04 toshiba ac100

Messaggio da marcobh5 »

cmq di openmax c'è qualcosa, c'è una versione di mplayer che lo supporta ma hai lo stesso problema arrivi a 720p e non sempre >:(
[Guida] accelerare video hd h264 wmv9 con ati 4xxx 5xxx series (smplayer xbmc vlc)
http://forum.ubuntu-it.org/viewtopic.php?t=401372
gyppe
Prode Principiante
Messaggi: 42
Iscrizione: giovedì 24 novembre 2011, 11:58

Re: ubuntu 11.04 toshiba ac100

Messaggio da gyppe »

Marco potresti spiegare meglio? Esiste una versione di mplayer ricompilata per tegra?
marcobh5
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 551
Iscrizione: domenica 3 agosto 2008, 14:36

Re: ubuntu 11.04 toshiba ac100

Messaggio da marcobh5 »

come sai è 3 mesi che sono senza net e la pagina con mplayer non me la ricordo più però guarda questo link
http://87.238.52.168/ac100/mplayer-omx
se vuoi sperimentare a clonare il git e provare la compilazione (yes)
[Guida] accelerare video hd h264 wmv9 con ati 4xxx 5xxx series (smplayer xbmc vlc)
http://forum.ubuntu-it.org/viewtopic.php?t=401372
gyppe
Prode Principiante
Messaggi: 42
Iscrizione: giovedì 24 novembre 2011, 11:58

Re: ubuntu 11.04 toshiba ac100

Messaggio da gyppe »

In effetti vorrei provare sul serio, ultimamente sto smanettando un bel po in ricompilazione kernel e moduli.

Ma sinceramente questo git non so neppure cosa sia, se riuscissi a trovare almeno i sorgenti potrei tentare e vedere i miglioramenti. Chissà che intanto non hanno migliorato parecchio il porting e ora vada benissimo.
marcobh5
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 551
Iscrizione: domenica 3 agosto 2008, 14:36

Re: ubuntu 11.04 toshiba ac100

Messaggio da marcobh5 »

git clona quella cartella dal server. il comando è quaalcosa simile a git clone git ... e ti crea una cartella con tutti i file x la compilazione, se vuoi provare ;)
[Guida] accelerare video hd h264 wmv9 con ati 4xxx 5xxx series (smplayer xbmc vlc)
http://forum.ubuntu-it.org/viewtopic.php?t=401372
Wonder Boy
Prode Principiante
Messaggi: 16
Iscrizione: giovedì 1 maggio 2008, 11:37

Re: ubuntu 11.04 toshiba ac100

Messaggio da Wonder Boy »

Ok ho preso il cavetto mini usb, così durante le vacanza di natale installarò anch'io ubuntu sul mio ac100 perchè navigare con android è per me insopportabile (mi dispiace solo che non potrò più riprodurre l'HD, ma pazienza)
Prima di procedere però volevo fare il backup della configurazione attuale. In questa pagina ci sono delle indicazioni su come salvare le partizioni attuali:

Codice: Seleziona tutto

nvflash -r --read <N> <filename>[/url]
Ho letto nella guida aggiornata che l'ac100 ha 7 partizioni (o 8, non so se si parte a contare da 0 o da 1). Io con il comando nvflash potrei copiarmi le partizioni sul pc, ma poi se volessi ripristinare come dovrei fare? Basterebbe caricare tutte le partizioni una per una o c'è altra procedura più complessa?
Avete un link che spiega come fare?
Grazie
Avatar utente
Xan
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 261
Iscrizione: domenica 31 dicembre 2006, 15:06
Località: Colleferro RM

Re: ubuntu 11.04 toshiba ac100

Messaggio da Xan »

...mentre per il flash è sufficiente installare i driver nvidia...
di che driver stai parlando?
Alessandro Scarozza - La risposta alla domanda numero 1: perché odi la microsoft?
Se un device non funziona su osx la colpa è del device, se non funziona su gnu/linux la colpa è di gnu/linux.
Scrivi risposta

Ritorna a “Architetture meno diffuse”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 1 ospite