[Beryl] Beryl su AiGLX/XGL per GNOME/KDE/XfCE

Configurazione e uso dell'interfaccia utente predefinita di Ubuntu.

Re: [Beryl] Beryl su NVIDIA/XGL/AiGLX per GNOME/KDE/XfCE

Messaggioda mauro21 » sabato 3 febbraio 2007, 23:19

beh bello...  (rotfl) (rotfl)

[img width=750 height=600]http://img65.imageshack.us/img65/9671/91747730ts3.jpg[/img]

[img width=750 height=600]http://img169.imageshack.us/img169/7012/71203374gt8.jpg[/img]
mauro21
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1459
Iscrizione: febbraio 2006
Distribuzione: ubuntu 12.10

Re: [Beryl] Beryl su NVIDIA/XGL/AiGLX per GNOME/KDE/XfCE

Messaggioda mauro21 » domenica 4 febbraio 2007, 13:55

problemino con gli aggiornamenti di oggi...

dopo il make debs esce

Codice: Seleziona tutto
checking for intltool >= 0.35.0... awk: cmd. line:1: fatal: cannot open file `./intltool-update.in' for reading (No such file or directory)
awk: cmd. line:1: fatal: cannot open file `./intltool-update.in' for reading (No such file or directory)
 found
/home/mauro/beryl/trunk/.beryl-plugins-unsupported.build/./configure: line 21115: test: : integer expression expected
configure: error: Your intltool is too old.  You need intltool 0.35.0 or later.
make[1]: *** [config.status] Error 1
make[1]: Leaving directory `/home/mauro/beryl/trunk/.beryl-plugins-unsupported.build'
==> Installing beryl-plugins-unsupported debian packages.
dpkg: errore processando *.deb (--install):
 impossibile accedere all'archivio: No such file or directory
Sono occorsi degli errori processando:
 *.deb
mv: cannot stat `*.deb': No such file or directory
mv: cannot stat `*.changes': No such file or directory
make: *** [cookies/beryl-plugins-unsupported.deb-installed] Error 1


ho intltool 0.35 (l'ultima versione che trovo in synaptic) e automake 1.9... che problema ho?
mauro21
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1459
Iscrizione: febbraio 2006
Distribuzione: ubuntu 12.10

Re: [Beryl] Beryl su NVIDIA/XGL/AiGLX per GNOME/KDE/XfCE

Messaggioda telperion » domenica 4 febbraio 2007, 14:20

mauro21 ha scritto:problemino con gli aggiornamenti di oggi...

dopo il make debs esce

ho intltool 0.35 (l'ultima versione che trovo in synaptic) e automake 1.9... che problema ho?


Succede che si sono scordati un file (~/beryl/trunk/beryl-plugins-unsupported/src/debug/Makefile.am).
fai così

EDIT
Hanno aggiornato ora il file c'è
Ultima modifica di telperion il domenica 4 febbraio 2007, 17:57, modificato 1 volta in totale.
Avatar utente
telperion
Rampante Reduce
Rampante Reduce
 
Messaggi: 5406
Iscrizione: luglio 2006

Re: [Beryl] Beryl su NVIDIA/XGL/AiGLX per GNOME/KDE/XfCE

Messaggioda Janvitus » domenica 4 febbraio 2007, 15:35

Ragazzi per gli screenshot c'è la sezione apposita, non andate OT.
Avatar utente
Janvitus
Amministratore
Amministratore
 
Messaggi: 17408
Iscrizione: aprile 2005
Località: Potenza
Desktop: GNOME Shell 3.28
Distribuzione: Fedora/Ubuntu
Sesso: Maschile

Re: [Beryl] Beryl su NVIDIA/XGL/AiGLX per GNOME/KDE/XfCE

Messaggioda z3n0 » lunedì 5 febbraio 2007, 13:51

salve gente,
diciamo che...sto impazzendo!

allora, io faccio parte degli utenti nvidia con gnome ed ubuntu 6.10.

ho installato gli ultimi driver nvidia presi dal sito ed ho l'accelerazione grafica (xkè il logo che carica l'os all'avvio invece di essere coloratoè bianco e nero?).

alora come da guida ho creato la sessione xgl che dapprima si avviava con il beryl, ma ora non solo il beryl non funge, e non ho l'accelerazione 3d!
eppure il file xorg.conf è configurato perfettamente..quindi se torno alla sessione gnome senza xgl funge il 3d, come torno qui x avviare il beryl, non ho l'accelerazione 3d ne gli effetti funzionanti..

come posso fare? ma poii a prescindere sta ubuntu si blocca sempre, cosa che il dapper non si è mai sognato di fare!

AGGIORNAMENTO:

ho notato che quando voglio fare il logout da questa sessione xgl, non posso spegnere direttamente il pc ma devo tornare x forza in gdm..
allora cos'ho fatto, ho avviato beryl-manager sempre sotto la sessione xgl tramite il sudo:

Codice: Seleziona tutto
 sudo beryl-manager
z3n0@phh:~$ **************************************************************
* Beryl system compatiblity check                            *
**************************************************************

Detected xserver                                : XGL

Checking Display :1.0 ...

Checking for XComposite extension               : passed (v0.3)
Checking for XDamage extension                  : passed
Checking for RandR extension                    : passed
Checking for XSync extension                    : passed

Checking Screen 0 ...

Checking for GLX_SGIX_fbconfig                  : passed
Checking for GLX_EXT_texture_from_pixmap        : passed
Checking for non power of two texture support   : passed
Checking maximum texture size                   : passed (4096x4096)

Reloading options
beryl-xgl: dbus_bus_get error: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
beryl-xgl: Plugin 'dbus':initDisplay failed
beryl-xgl: Couldn't activate plugin 'dbus'
Couldn't initialise dbus. This should not happen!


e cosi mi si è avviato l'effetto che avevo settato..questa è una cosa valida anche x il settaggio dei temi..da user non si settano ,se apro con sudo il theme-manager di emerald se li prende..dove posso risolvere tso problema di permessi?

Codice: Seleziona tutto
 sudo emerald-theme-manager

(emerald-theme-manager:7278): libgnomevfs-WARNING **: Failed to open session DBUS connection: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Volume monitoring will not work.
Ultima modifica di z3n0 il lunedì 5 febbraio 2007, 14:03, modificato 1 volta in totale.
z3n0.org
Avatar utente
z3n0
Prode Principiante
 
Messaggi: 16
Iscrizione: agosto 2006
Località: Caserta

Re: [Beryl] Beryl su NVIDIA/XGL/AiGLX per GNOME/KDE/XfCE

Messaggioda topmix » martedì 6 febbraio 2007, 13:56

Ciao ragazzi....

le sto provando tutte, ma nulla,

ho anche cambiato la mia sources.list con questa http://3v1n0.tuxfamily.org/blog/lista-r ... ntu-linux/

e l'unica cosa che è cambiata dopo l'aggiornamento è il fatto che mi fa selezionare Beryl come Gestore di Finestre (prima solo il Metacity), attiva sulla barra le sei aree di lavoro, ma rimane tutto in blocco, per continuare a lavorare devo disattivare Beryl e rimettere Metacity.

un'altra cosa, non riesco ad attivare le chiavi riportate nel Link suddetto....come devo fare?

se do questo comando da terminale
gpg –recv-keys A278DF5EE8BDA4E3

mi da questa risposta:

uso: gpg [opzioni] [nomefile]...
che significa?

Fatemi sapere GRAZIE!!!

Ciao TopMix  (good) (b2b)
Nonostante tutto....Con Zeman contro il sistema....U.L.
Avatar utente
topmix
Prode Principiante
 
Messaggi: 172
Iscrizione: maggio 2006

Re: [Beryl] Beryl su NVIDIA/XGL/AiGLX per GNOME/KDE/XfCE

Messaggioda thewall83 » martedì 6 febbraio 2007, 16:06

topmix ha scritto:Ciao ragazzi....
le sto provando tutte, ma nulla,
ho anche cambiato la mia sources.list con questa http://3v1n0.tuxfamily.org/blog/lista-r ... ntu-linux/
e l'unica cosa che è cambiata dopo l'aggiornamento è il fatto che mi fa selezionare Beryl come Gestore di Finestre (prima solo il Metacity), attiva sulla barra le sei aree di lavoro, ma rimane tutto in blocco, per continuare a lavorare devo disattivare Beryl e rimettere Metacity.

Devi darci un pò di notizie in più tipo se sei su Xgl o AiGLX, che driver e che scheda nvidia usi, se hai modificato correttamente il tuo xorg.conf....
Magari posta anche il risultato di beryl-manager.
topmix ha scritto:un'altra cosa, non riesco ad attivare le chiavi riportate nel Link suddetto....come devo fare?
se do questo comando da terminale
gpg –recv-keys A278DF5EE8BDA4E3
mi da questa risposta:
uso: gpg [opzioni] [nomefile]...
che significa?

il comando esatto è con due trattini:
Codice: Seleziona tutto
gpg --recv-keys

C'è un errore sul blog di 3Vino per cui il doppio trattino viene trasformato in tratto singolo.
;D
Linux user #442614 - Ubuntu user #11952
Bill Gates disse "Bug". E Windows fu...
Avatar utente
thewall83
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 307
Iscrizione: agosto 2006
Località: Cerco con Google Earth...Streaming 0%

Re: [Beryl] Beryl su NVIDIA/XGL/AiGLX per GNOME/KDE/XfCE

Messaggioda pinguin » martedì 6 febbraio 2007, 16:16

topmix ha scritto:Ciao ragazzi....

le sto provando tutte, ma nulla,

ho anche cambiato la mia sources.list con questa http://3v1n0.tuxfamily.org/blog/lista-r ... ntu-linux/
....


per installare Beryl è sufficiente aggiungere queste righe in un sources.lst standard:
Codice: Seleziona tutto
deb http://ubuntu.beryl-project.org edgy main
deb-src http://ubuntu.beryl-project.org edgy main

sostituendo eventualmente edgy con la tua versione di ubuntu
per importare la chiave di questi repo devi digitare in un teminale:
Codice: Seleziona tutto
wget http://ubuntu.beryl-project.org/root@lupine.me.uk.gpg -O- | sudo apt-key add -

poi inserisci la tua password di sudo e dai invio quando l'operazione sembra si sia fermata senza risultato
dopo di che apri synaptic aggiorni la lista dei pacchetti e cerchi i pacchetti collegati a beryl per l'installazione.
Nella scatola era scritto: "Richiede Windows Xp o superiore"
Così ho installato Linux :-)
Avatar utente
pinguin
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1066
Iscrizione: febbraio 2006

Re: [Beryl] Beryl su NVIDIA/XGL/AiGLX per GNOME/KDE/XfCE

Messaggioda Australiano » martedì 6 febbraio 2007, 19:56

Dopo gli ultimi aggiornamenti, non mi funziona più beryl.
Che caspita ho?
>:( >:( >:( >:(
Grazie
Ivan
By Ivan
Avatar utente
Australiano
Prode Principiante
 
Messaggi: 230
Iscrizione: ottobre 2006

Re: [Beryl] Beryl su NVIDIA/XGL/AiGLX per GNOME/KDE/XfCE

Messaggioda z3n0 » martedì 6 febbraio 2007, 21:58

non per fare il geloso eh, ma ho postato 2 giorni fa e nessuno mi ha risposto, poi al post di topmix subito sono state date risposte..

c'è un motivo? mi sembra giusto di essere stato ignorato/scavalcato..

topmix niente contro di te eh :)
z3n0.org
Avatar utente
z3n0
Prode Principiante
 
Messaggi: 16
Iscrizione: agosto 2006
Località: Caserta

Re: [Beryl] Beryl su NVIDIA/XGL/AiGLX per GNOME/KDE/XfCE

Messaggioda telperion » martedì 6 febbraio 2007, 22:05

z3n0 ha scritto:non per fare il geloso eh, ma ho postato 2 giorni fa e nessuno mi ha risposto, poi al post di topmix subito sono state date risposte..

c'è un motivo? mi sembra giusto di essere stato ignorato/scavalcato..

topmix niente contro di te eh :)


Forse perchè un buon modo per cercare di risolvere il tuo problema è descritto
nel primo post di questo thread

Schede video Nvidia
Quindi: schede Nvidia con NvidiaGLXserver


Poi perchè non siamo dal dottore, ognuno risponde a quello che sà
o che reputa di essere in grado di aiutare, o solo che ha voglia.
Avatar utente
telperion
Rampante Reduce
Rampante Reduce
 
Messaggi: 5406
Iscrizione: luglio 2006

Re: [Beryl] Beryl su NVIDIA/XGL/AiGLX per GNOME/KDE/XfCE

Messaggioda F2002 » martedì 6 febbraio 2007, 23:57

Ragazzi, scusate ma io non riesco ancora a vedere le decorazioni delle finestre. Il mio sistema e' un Amd64 con Kubuntu 6.10, driver NVidia 9746, beryl 0.20 rc1 da http://download.tuxfamily.org/3v1deb e questo e' il mio xorg.conf:

Codice: Seleziona tutto
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder26)  Mon Oct 16 22:13:48 PDT 2006

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    RgbPath         "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
    Load           "dri"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 110.0
    VertRefresh     50.0 - 150.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option         "XAANoOffscreenPixmaps"
    Option         "TripleBuffer" "true"
    Option         "AllowGLXWithComposite" "True"
    Option         "RenderAccel" "True"
    Option         "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth   24
    Option         "TripleBuffer" "true"
    Option         "AllowGLXWithComposite" "True"
    Option         "RenderAccel" "True"
    Option         "AddARGBGLXVisuals" "True"
    SubSection     "Display"
        Depth      24
        Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "Extensions"
        Option      "Composite"
EndSection
Section "DRI"
        Group        0
        Mode         0666
EndSection


Questa e' invece la risposta all'avvio di beryl-manager:

Codice: Seleziona tutto
 kwin: Fatal IO error: client killed
kwin: Fatal IO error: client killed
**************************************************************
* Beryl system compatiblity check                            *
**************************************************************

Detected xserver                                : NVIDIA

Checking Display :0.0 ...

Checking for XComposite extension               : passed (v0.3)
Checking for XDamage extension                  : passed
Checking for RandR extension                    : passed
Checking for XSync extension                    : passed

Checking Screen 0 ...

Checking for GLX_SGIX_fbconfig                  : passed
Checking for GLX_EXT_texture_from_pixmap        : passed
Checking for non power of two texture support   : passed
Checking maximum texture size                   : passed (4096x4096)

Relaunching beryl with __GL_YIELD="NOTHING"
**************************************************************
* Beryl system compatiblity check                            *
**************************************************************

Detected xserver                                : NVIDIA

Checking Display :0.0 ...

Checking for XComposite extension               : passed (v0.3)
Checking for XDamage extension                  : passed
Checking for RandR extension                    : passed
Checking for XSync extension                    : passed

Checking Screen 0 ...

Checking for GLX_SGIX_fbconfig                  : passed
Checking for GLX_EXT_texture_from_pixmap        : passed
Checking for non power of two texture support   : passed
Checking maximum texture size                   : passed (4096x4096)

Reloading options
Initiating splash


La cosa curiosa e' che beryl funziona con i driver 8776. Ho cercato in lungo e in largo con google, provando diverse modifiche in xorg.conf, ma nulla da fare, tutto senza bordi di decorazione.
Grazie per ogni eventuale aiuto  ;)
F2002
Prode Principiante
 
Messaggi: 10
Iscrizione: dicembre 2006

Re: [Beryl] Beryl su NVIDIA/XGL/AiGLX per GNOME/KDE/XfCE

Messaggioda telperion » mercoledì 7 febbraio 2007, 0:08

F2002 ha scritto:Ragazzi, scusate ma io non riesco ancora a vedere le decorazioni delle finestre. Il mio sistema e' un Amd64 con Kubuntu 6.10, driver NVidia 9746, beryl 0.20 rc1 da http://download.tuxfamily.org/3v1deb e questo e' il mio xorg.conf:


Grazie per ogni eventuale aiuto  ;)


Prova ad eliminare completamente le sezioni:
Section "Extensions"
        Option      "Composite"
EndSection
Section "DRI"
        Group        0
        Mode        0666
EndSection

fai un backup prima.
Fai anche una prova con ricarica decoratore finestre dal manager.

Se poi ancora non va posta anche l'out di
emerald --replace &
Avatar utente
telperion
Rampante Reduce
Rampante Reduce
 
Messaggi: 5406
Iscrizione: luglio 2006

Re: [Beryl] Beryl su NVIDIA/XGL/AiGLX per GNOME/KDE/XfCE

Messaggioda F2002 » mercoledì 7 febbraio 2007, 0:16

telperion ha scritto:
Prova ad eliminare completamente le sezioni:
Section "Extensions"
        Option      "Composite"
EndSection
Section "DRI"
        Group        0
        Mode        0666
EndSection

fai un backup prima.
Fai anche una prova con ricarica decoratore finestre dal manager.

Se poi ancora non va posta anche l'out di
emerald --replace &




Ancora nulla.
Il risultato di "emerald -replace&" e':

emerald: Could not acquire decoration manager selection on screen 0 display ":0.0"
F2002
Prode Principiante
 
Messaggi: 10
Iscrizione: dicembre 2006

Re: [Beryl] Beryl su NVIDIA/XGL/AiGLX per GNOME/KDE/XfCE

Messaggioda pinguin » mercoledì 7 febbraio 2007, 14:20

F2002 ha scritto:Ragazzi, scusate ma io non riesco ancora a vedere le decorazioni delle finestre. Il mio sistema e' un Amd64 con Kubuntu 6.10, driver NVidia 9746, beryl 0.20 rc1 da http://download.tuxfamily.org/3v1deb e questo e' il mio xorg.conf:

Codice: Seleziona tutto
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder26)  Mon Oct 16 22:13:48 PDT 2006

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    RgbPath         "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
    Load           "dri"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 110.0
    VertRefresh     50.0 - 150.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option         "XAANoOffscreenPixmaps"
    Option         "TripleBuffer" "true"
    Option         "AllowGLXWithComposite" "True"
    Option         "RenderAccel" "True"
    Option         "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth   24
    Option         "TripleBuffer" "true"
    Option         "AllowGLXWithComposite" "True"
    Option         "RenderAccel" "True"
    Option         "AddARGBGLXVisuals" "True"
    SubSection     "Display"
        Depth      24
        Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "Extensions"
        Option      "Composite"
EndSection
Section "DRI"
        Group        0
        Mode         0666
EndSection


...
La cosa curiosa e' che beryl funziona con i driver 8776. Ho cercato in lungo e in largo con google, provando diverse modifiche in xorg.conf, ma nulla da fare, tutto senza bordi di decorazione.
Grazie per ogni eventuale aiuto


Guardando il tuo xorg.conf direi che dovresti applicare queste modifiche:
cancella (o mettici # davanti):
Codice: Seleziona tutto
 Load           "dri"

in Section "Module"
cancella l'intera sezione:
Codice: Seleziona tutto
Section "DRI"
        Group        0
        Mode         0666
EndSection

la sezione extensions deve essere così (nella tua manca un pezzo importante - "Enable" ):
Codice: Seleziona tutto
Section "Extensions"
     Option "Composite" "Enable"
 EndSection

credo che questa riga in device non ci debba essere:
Codice: Seleziona tutto
   Option         "XAANoOffscreenPixmaps"


facci sapere
Nella scatola era scritto: "Richiede Windows Xp o superiore"
Così ho installato Linux :-)
Avatar utente
pinguin
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1066
Iscrizione: febbraio 2006

Re: [Beryl] Beryl su NVIDIA/XGL/AiGLX per GNOME/KDE/XfCE

Messaggioda topmix » mercoledì 7 febbraio 2007, 14:37

ciao ragazzi....

ancora nulla..... ho rifatto tutto daccapo, ma nisba.....

io sono su xgl, la mia scheda video è una GeForceGo 7300, xorg.gonf è configurato bene.  >:( >:( >:(

premetto, come ho già detto altre volte, a me funzionava tutto alla perfezione, ma dopo un aggiornamento effettuato ormai più di 10 giorni fa, beryl non ne vuole più sapere.

Ciao TopMix (good) (b2b)
Nonostante tutto....Con Zeman contro il sistema....U.L.
Avatar utente
topmix
Prode Principiante
 
Messaggi: 172
Iscrizione: maggio 2006

Re: [Beryl] Beryl su NVIDIA/XGL/AiGLX per GNOME/KDE/XfCE

Messaggioda emdel » mercoledì 7 febbraio 2007, 15:01

Ragazzi salve!
Ho installato beryl ed xgl sulla mia kubuntu edgy ed è filato tutto liscio. Ho avviato beryl mi sono visto il cubo agognato e poi si è bloccato tutto.
Ho riavviato e da allora cioà da circa un'ora nn va più la tastiera mentre il touchpad si.
Che posso fare?
Non voglio più scrivere da winzoz please :D  >:(
emdel
Prode Principiante
 
Messaggi: 29
Iscrizione: settembre 2006

Re: [Beryl] Beryl su NVIDIA/XGL/AiGLX per GNOME/KDE/XfCE

Messaggioda emdel » mercoledì 7 febbraio 2007, 15:37

ragazzi che collegamento c'è tra beryl e la tastiera???
cavolo :'(
emdel
Prode Principiante
 
Messaggi: 29
Iscrizione: settembre 2006

Re: [Beryl] Beryl su NVIDIA/XGL/AiGLX per GNOME/KDE/XfCE

Messaggioda thewall83 » mercoledì 7 febbraio 2007, 15:56

emdel ha scritto:ragazzi che collegamento c'è tra beryl e la tastiera???
cavolo :'(

Nel primo post c'è un link per chi ha problemi con xgl, kde e la mappatura della tastiera:
http://forum.ubuntu-it.org/viewtopic.ph ... 61991.html#msg261991
Linux user #442614 - Ubuntu user #11952
Bill Gates disse "Bug". E Windows fu...
Avatar utente
thewall83
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 307
Iscrizione: agosto 2006
Località: Cerco con Google Earth...Streaming 0%

Re: [Beryl] Beryl su NVIDIA/XGL/AiGLX per GNOME/KDE/XfCE

Messaggioda thewall83 » mercoledì 7 febbraio 2007, 16:12

topmix ha scritto:ciao ragazzi....
ancora nulla..... ho rifatto tutto daccapo, ma nisba.....
io sono su xgl, la mia scheda video è una GeForceGo 7300, xorg.gonf è configurato bene.  >:( >:( >:(
premetto, come ho già detto altre volte, a me funzionava tutto alla perfezione, ma dopo un aggiornamento effettuato ormai più di 10 giorni fa, beryl non ne vuole più sapere.
Ciao TopMix (good) (b2b)

Assicurati di avere abilitato l'accelerazione 3d col comando:
Codice: Seleziona tutto
glxinfo | grep render

se ti esce direct rendering Yes, allora è ok.
Hai installato i driver nvidia versione>=96xx?
Codice: Seleziona tutto
cat /proc/driver/nvidia/version


Se entrambi i comandi danno risposta soddisfacente puoi provare a dare un bel
Codice: Seleziona tutto
sudo apt-get remove --purge beryl* emerald* heliodor* aquamarine*

Così rimuovi tutto quello che c'è.
Poi nella tua home dai un bel
Codice: Seleziona tutto
sudo rm -rf .beryl .emerald

così rimuovi i file di configurazione(salvali da qualche parte se vuoi mantenere le tue impostazioni).

E poi, assicurandoti di avere nel tuo /etc/apt/sources.list un repository giusto(quelli di trevino oppure gli ufficiali di beryl, decidi tu), installa beryl nuovamente con:
Codice: Seleziona tutto
sudo apt-get install beryl* emerald*
Linux user #442614 - Ubuntu user #11952
Bill Gates disse "Bug". E Windows fu...
Avatar utente
thewall83
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 307
Iscrizione: agosto 2006
Località: Cerco con Google Earth...Streaming 0%

PrecedenteSuccessiva

Torna a Unity

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 1 ospite