Compiz su AiGLX per GNOME/KDE/XfCE (aggiorntato al 22/08/2007)

Configurazione e uso dell'interfaccia utente predefinita fino alla versione 16.04 di Ubuntu.

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggioda flash85 » domenica 5 novembre 2006, 22:51

Ma c'è qualcuno che è riuscito a far funzionare il tutto con kde?? io ho istallato tutto il necessario e modificato lo xorg come da guida di ubuntu-storm ma al riavvio nessuna novità!!!
flash85
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 336
Iscrizione: aprile 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggioda ziopippo » lunedì 6 novembre 2006, 0:17

io su una kubuntu edgy installata su un portatile toshiba con scheda grafica ati 9700...
ho usato la guida modificando xorg.conf e installando i pacchetti ufficiali e funziona tutto bene,dato che di default la kubuntu mi installai driver ati open....
ho solo un problema: non mi funzionano i temi metacity, ho solo quello classico
(anche l'effetto acqua non funziona, ma non importa...)
qualcuno sa dirmi cosa può essere???
grazie anticipatamente
io
ziopippo
Prode Principiante
 
Messaggi: 3
Iscrizione: settembre 2005

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggioda flash85 » lunedì 6 novembre 2006, 14:41

ziopippo ha scritto:io su una kubuntu edgy installata su un portatile toshiba con scheda grafica ati 9700...
ho usato la guida modificando xorg.conf e installando i pacchetti ufficiali e funziona tutto bene,dato che di default la kubuntu mi installai driver ati open....
ho solo un problema: non mi funzionano i temi metacity, ho solo quello classico
(anche l''effetto acqua non funziona, ma non importa...)
qualcuno sa dirmi cosa può essere???
grazie anticipatamente
io

Ma è necessario qualche comando per avviare aiglx ho basta solo modificare lo xorg.conf?? inoltre hai installato anche gnome-compiz-manager oltre a  compiz-freedesktop-kde??? Inoltre come si fa a vedere con i driver open se funziona l''accellerazione 3d?? Anch''io ho una ati, una 9600!!
Ultima modifica di flash85 il lunedì 6 novembre 2006, 14:43, modificato 1 volta in totale.
flash85
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 336
Iscrizione: aprile 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggioda Janvitus » lunedì 6 novembre 2006, 17:58

ziopippo ha scritto:io su una kubuntu edgy installata su un portatile toshiba con scheda grafica ati 9700...
ho usato la guida modificando xorg.conf e installando i pacchetti ufficiali e funziona tutto bene,dato che di default la kubuntu mi installai driver ati open....
ho solo un problema: non mi funzionano i temi metacity, ho solo quello classico
(anche l''effetto acqua non funziona, ma non importa...)
qualcuno sa dirmi cosa può essere???
grazie anticipatamente
io


Normale, metacity è il window manager di default di GNOME.

flash85 ha scritto:Ma è necessario qualche comando per avviare aiglx ho basta solo modificare lo xorg.conf?? inoltre hai installato anche gnome-compiz-manager oltre a compiz-freedesktop-kde??? Inoltre come si fa a vedere con i driver open se funziona l''accellerazione 3d?? Anch''io ho una ati, una 9600!!


Basta solo modificare l''xorg.conf come indicato nel primo messaggio di questa discussione.
Avatar utente
Janvitus
Amministratore
Amministratore
 
Messaggi: 17564
Iscrizione: aprile 2005
Località: Potenza
Desktop: GNOME 3.34
Distribuzione: Fedora/Ubuntu
Sesso: Maschile

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggioda flash85 » lunedì 6 novembre 2006, 19:10

Uhmmm m sa che non c'è nulla da fare perchè sulla mia kubuntu e con la mia 9600 i driver open non sembrano abilitare l'accellerazione 3d!!!
flash85
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 336
Iscrizione: aprile 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggioda mattia77 » lunedì 6 novembre 2006, 20:16

Vi segnalo questa guida scritta dagli sviluppatori nvidia per compiz aixgl:
http://www.nvnews.net/vbulletin/showthread.php?t=77030

Io penso di avere il problema descritto nelle ultime righe ma non so come si fa a vedere se compiz stà usando --indirect-rendering.
Avatar utente
mattia77
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 938
Iscrizione: marzo 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggioda mattia77 » lunedì 6 novembre 2006, 22:56

mattia77 ha scritto:Vi segnalo questa guida scritta dagli sviluppatori nvidia per compiz aixgl:
http://www.nvnews.net/vbulletin/showthread.php?t=77030

Io penso di avere il problema descritto nelle ultime righe ma non so come si fa a vedere se compiz stà usando --indirect-rendering.


Finalmete ho risolto i miei problemi con compiz, anche se show desktop mi pianta anche il ciborio.

Se con compiz state usando --indirect-rendering:
ps aux | grep compiz
e avete un'' elevato consumo di cpu

Provate ad avviare compiz con questo script:

$!/bin/bash

$ gnome-window-decorator &
$ export __GL_YIELD="NOTHING"; compiz --replace --use-cow gconf

A me ha risolto, 0% di utilzzo della cpu con tutti gli effetti di compiz; con una scheda video integrata :-)
Avatar utente
mattia77
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 938
Iscrizione: marzo 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggioda inverse » martedì 7 novembre 2006, 0:39

mattia77 ha scritto:
mattia77 ha scritto:Vi segnalo questa guida scritta dagli sviluppatori nvidia per compiz aixgl:
http://www.nvnews.net/vbulletin/showthread.php?t=77030

Io penso di avere il problema descritto nelle ultime righe ma non so come si fa a vedere se compiz stà usando --indirect-rendering.


Finalmete ho risolto i miei problemi con compiz, anche se show desktop mi pianta anche il ciborio.

Se con compiz state usando --indirect-rendering:
ps aux | grep compiz
e avete un'' elevato consumo di cpu

Provate ad avviare compiz con questo script:

$!/bin/bash

$ gnome-window-decorator &
$ export __GL_YIELD="NOTHING"; compiz --replace --use-cow gconf

A me ha risolto, 0% di utilzzo della cpu con tutti gli effetti di compiz; con una scheda video integrata :-)


Ho provato, ma mi si è piantato tutto :o ;D
Da usare con la dovuta moderazione questo export (yes)
Avatar utente
inverse
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1006
Iscrizione: ottobre 2005

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggioda mattia77 » martedì 7 novembre 2006, 14:46

inverse ha scritto:
mattia77 ha scritto:
mattia77 ha scritto:Vi segnalo questa guida scritta dagli sviluppatori nvidia per compiz aixgl:
http://www.nvnews.net/vbulletin/showthread.php?t=77030

Io penso di avere il problema descritto nelle ultime righe ma non so come si fa a vedere se compiz stà usando --indirect-rendering.


Finalmete ho risolto i miei problemi con compiz, anche se show desktop mi pianta anche il ciborio.

Se con compiz state usando --indirect-rendering:
ps aux | grep compiz
e avete un'' elevato consumo di cpu

Provate ad avviare compiz con questo script:

$!/bin/bash

$ gnome-window-decorator &
$ export __GL_YIELD="NOTHING"; compiz --replace --use-cow gconf

A me ha risolto, 0% di utilzzo della cpu con tutti gli effetti di compiz; con una scheda video integrata :-)


Ho provato, ma mi si è piantato tutto :o ;D
Da usare con la dovuta moderazione questo export (yes)


Certo che deve essere usato con moderazione, funziona solo se compiz si avvia in --indirect-rendering.
Avatar utente
mattia77
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 938
Iscrizione: marzo 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggioda inverse » mercoledì 8 novembre 2006, 0:19

beh ho notato che anche il mio si avvia in --indirect-rendering, perciò ho provato... ;D
Avatar utente
inverse
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1006
Iscrizione: ottobre 2005

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggioda Strappis » mercoledì 8 novembre 2006, 19:04

Funziona!!!! (good) (good)
Ultima modifica di Strappis il mercoledì 8 novembre 2006, 20:28, modificato 1 volta in totale.
Strappis
Prode Principiante
 
Messaggi: 16
Iscrizione: ottobre 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggioda ziopippo » venerdì 10 novembre 2006, 12:43

scusate ma è possibile che se installo compiz su kde non posso avere alcun delle finestra da selezionare????
grazie per le delucidazioni
io
ziopippo
Prode Principiante
 
Messaggi: 3
Iscrizione: settembre 2005

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggioda mattia77 » venerdì 10 novembre 2006, 13:12

mattia77 ha scritto:
inverse ha scritto:
mattia77 ha scritto:
mattia77 ha scritto:Vi segnalo questa guida scritta dagli sviluppatori nvidia per compiz aixgl:
http://www.nvnews.net/vbulletin/showthread.php?t=77030

Io penso di avere il problema descritto nelle ultime righe ma non so come si fa a vedere se compiz stà usando --indirect-rendering.


Finalmete ho risolto i miei problemi con compiz, anche se show desktop mi pianta anche il ciborio.

Se con compiz state usando --indirect-rendering:
ps aux | grep compiz
e avete un'' elevato consumo di cpu

Provate ad avviare compiz con questo script:

$!/bin/bash

$ gnome-window-decorator &
$ export __GL_YIELD="NOTHING"; compiz --replace --use-cow gconf

A me ha risolto, 0% di utilzzo della cpu con tutti gli effetti di compiz; con una scheda video integrata :-)


Ho provato, ma mi si è piantato tutto :o ;D
Da usare con la dovuta moderazione questo export (yes)


Certo che deve essere usato con moderazione, funziona solo se compiz si avvia in --indirect-rendering.



Il bug è stato fissato con la release stabile dei driver nvidia
Avatar utente
mattia77
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 938
Iscrizione: marzo 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggioda sko » sabato 11 novembre 2006, 15:44

spero sia il posto giusto per postare:

ho installato Compiz su ubuntu 6.10 seguendo la guida.
modificato il file xorg.conf
riavviato ( senza fare i successivi passaggi)
partenza del pc ma si bloccava al cariacmenti di metacity
riavviato in recovery mode
rimesso il file xorg.conf che avevo di backup
con apt-get remove rimossi i due pacchetti.

ora quando riavvio mi esce
qualcosa del tipo impossibile killare un pid (non ricordo quale)
qualcosa tipo /sbin/proc/exe
e si blocca li'..
mi scuso per le info un po' confuse ma ricordo questo!
se non basta magari riprovo e mi segno tutto!!
sko
Prode Principiante
 
Messaggi: 104
Iscrizione: novembre 2005

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggioda Janvitus » sabato 11 novembre 2006, 17:54

Servono più informazioni.
Avatar utente
Janvitus
Amministratore
Amministratore
 
Messaggi: 17564
Iscrizione: aprile 2005
Località: Potenza
Desktop: GNOME 3.34
Distribuzione: Fedora/Ubuntu
Sesso: Maschile

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggioda sko » domenica 12 novembre 2006, 2:12

Janvitus ha scritto:Servono più informazioni.


ho provato ora a riavviare!
parte regolarmente fino a quando carica windows menager metacity li si blocca..
se clicco su sparisce il pannello dove escono le icone della roba che carica all''inizio e rimane tutto cosi''!
pero'' se provo tipo ad abbassare la luminosita'' dello schermo o bloccaro con una combinazione di tasti, funziona regolarmente!

provo a postare il file xorg.config

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
FontPath "/usr/share/fonts/X11/misc"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "Intel Corporation 82852/855GM Integrated Graphics Device"
Driver "i810"
BusID "PCI:0:2:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-51
VertRefresh 43-60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation 82852/855GM Integrated Graphics Device"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
InputDevice "Synaptics Touchpad"
EndSection

Section "DRI"
Mode 0666
EndSection
sko
Prode Principiante
 
Messaggi: 104
Iscrizione: novembre 2005

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggioda origin of » domenica 12 novembre 2006, 8:15

@sko Fai partire in modalità restricted e elimina la cartella .gnome-compiz-manager e il file .gnomerc ;)
Codice: Seleziona tutto
rm -r .gnome-compiz-manager
rm .gnomerc


Dimmi se ti va 8)
Utente archlinux, ex utente ubuntu.
Contatto jabber: originof@jaim.at
MIO SITO: http://www.happycode.it
Avatar utente
origin of
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1028
Iscrizione: giugno 2006
Località: Lucca

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggioda sko » domenica 12 novembre 2006, 10:57

origin of ha scritto:@sko Fai partire in modalità restricted e elimina la cartella .gnome-compiz-manager e il file .gnomerc ;)
Codice: Seleziona tutto
rm -r .gnome-compiz-manager
rm .gnomerc


Dimmi se ti va 8)


non ho quelle due cartelle...
sotto la home/sko/ ho solo
.gnome .gome2 .gnome_private
o qualcosa di simile e basta : (

come avevo scritto nell altro post prima ho dato
apt-get remove nome dei due pacchetti di compiz
sko
Prode Principiante
 
Messaggi: 104
Iscrizione: novembre 2005

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggioda origin of » domenica 12 novembre 2006, 11:03

.gnomerc nn è una cartella, cmq allora prova a eliminare la cartela .gnome-compiz-manager (nota il punto davanti il nome, è nascosta)
Utente archlinux, ex utente ubuntu.
Contatto jabber: originof@jaim.at
MIO SITO: http://www.happycode.it
Avatar utente
origin of
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1028
Iscrizione: giugno 2006
Località: Lucca

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggioda sko » domenica 12 novembre 2006, 11:14

origin of ha scritto:.gnomerc nn è una cartella, cmq allora prova a eliminare la cartela .gnome-compiz-manager (nota il punto davanti il nome, è nascosta)


allora

cd /home/sko
ls -al

cut..
drwx------ 5 sko sko 4096 Nov 11 15:06 .gaim
drwx------ 5 sko sko 4096 Nov 12 02:08 .gconf
drwx------ 2 sko sko 4096 Nov 12 02:08 .gconfd
drwxr-xr-x 7 sko sko 4096 Nov 10 23:39 .gdesklets
drwxr-xr-x 21 sko sko 4096 Nov 10 20:04 .gimp-2.2
drwxr-xr-x 5 sko sko 4096 Nov 4 14:28 .gkrellm2
-rw-r----- 1 sko sko 0 Nov 11 14:57 .gksu.lock
drwxr-xr-x 4 sko sko 4096 Nov 5 02:31 .gnome
drwx------ 16 sko sko 4096 Nov 11 14:45 .gnome2
drwx------ 2 sko sko 4096 Nov 4 13:10 .gnome2_private
drwxr-xr-x 2 sko sko 4096 Nov 10 18:04 .gstreamer-0.10
-rw-r--r-- 1 sko sko 140 Nov 4 15:23 .gtkrc-1.2-gnome2
cut...

ho lasciato tutte le cartelle-file che iniziano per .g

cmq grazie per la pazienza : )
sko
Prode Principiante
 
Messaggi: 104
Iscrizione: novembre 2005

PrecedenteSuccessiva

Torna a Unity

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 1 ospite