Compiz su AiGLX per GNOME/KDE/XfCE (aggiorntato al 22/08/2007)

Configurazione e uso dell'interfaccia utente predefinita fino alla versione 16.04 di Ubuntu.
Sbronzolo
Prode Principiante
Messaggi: 1
Iscrizione: domenica 19 novembre 2006, 12:53

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggio da Sbronzolo » domenica 19 novembre 2006, 13:01

Zalve a tutti

Io ho una ati XPRESS 200M, particolare per la sua stressante installazione.
Se installo i suoi driver non proprietari, non ho l' accelerazioe grafica cioé
glxinfo | grep rendering:
NO
Come posso abilitare la mi accelerazione senza installare i driver proprietari? :)
Grazie

Pristark
Prode Principiante
Messaggi: 179
Iscrizione: martedì 14 novembre 2006, 11:30

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggio da Pristark » domenica 19 novembre 2006, 13:55

Ragazzi,

non riesco a far partire decentemente Compiz... uffa!

vabbe'' che non e'' di vitale importanza... ma mi piacevano gli effetti che crea...

ho provato con uno script ma niente.
poi ho modificato lo script... e ancora niente
:(

non e'' che devo reinstallarlo...?
ok... ho capito perche'' non andava. invece di insierire in System->Preferenze->sessioni il comando compiz-tray-icon dovevo inserire tutto il path completo... ovvero /usr/bin/compiz-tray-icon.
Ultima modifica di Pristark il domenica 19 novembre 2006, 15:18, modificato 1 volta in totale.

ShinjiLeery
Prode Principiante
Messaggi: 161
Iscrizione: domenica 5 giugno 2005, 12:13

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggio da ShinjiLeery » domenica 19 novembre 2006, 15:58

ShinjiLeery ha scritto:
aldolat ha scritto: @ ShinjiLeery
Anche a me succede. Se leggi il primo post di Janvitus in questo topic vedrai che questi rallentamenti sono dovuti forse a una pacchettizzazione fatta male. Per cui per avere un Compiz migliore ognuno dovrebbe compilarselo da sé.
Io sono riuscito a compilarlo e ad installarlo, ma... le decorazioni delle finestre non partono e le finestra restano amovibili.
Grazie per la risposta... Proverò pure io a campilarlo da me per vedere se funziona. Tra l''altro lo stesso problema ce l''avevo pure con Beryl.. Chissa se allora è problema di aiglx con la mia ati 9250 ...
Ho seguito la guida per compilare compiz, versione 0.3.2 presa dal sito. Poi ho installato il gnome-compiz-manager sempre secondo la guida: versione 0.9.10. Se prima con i pacchetti compilati funzionava ma avevo i problemi di rallentamenti, ora non parte niente. Appena faccio partire il comando compiz-tray-icon ottengo questo errore:

Codice: Seleziona tutto

(compiz-tray-icon:9999): GLib-GObject-WARNING **: gsignal.c:2133: signal id `23'' is invalid for instance `0x80568c0''

(compiz-tray-icon:9999): GLib-GObject-WARNING **: IA__g_object_notify: object class `GCMTrayIcon'' has no property named `visible''
Poi appena faccio partire il GL Desktop non mi fa vedere i bordi delle finestre, e nella shell ottengo questi errori:

Codice: Seleziona tutto

(compiz-tray-icon:9999): GLib-CRITICAL **: g_io_channel_unref: assertion `channel != NULL'' failed

(compiz-tray-icon:9999): GLib-CRITICAL **: g_io_channel_unref: assertion `channel != NULL'' failed

(compiz-tray-icon:9999): GLib-CRITICAL **: g_io_channel_unref: assertion `channel != NULL'' failed

(compiz-tray-icon:9999): GLib-CRITICAL **: g_io_channel_unref: assertion `channel != NULL'' failed

(compiz-tray-icon:9999): GLib-CRITICAL **: g_io_channel_unref: assertion `channel != NULL'' failed

(compiz-tray-icon:9999): GLib-CRITICAL **: g_io_channel_unref: assertion `channel != NULL'' failed
Aprendo poi Synaptic mi sono accorto di una cosa. C''è installato correntemente il pacchetto che ho compilato, ovvero il compiz 0.3.2, il gnome-compiz-manager ha una versione più recente nei repository ovvero la 0.9.11-prealpha
Tutti gli altri pacchetti non sono installati tipo compiz-core, compiz-gnome, compiz-plugins. Devo installarli?

pasqoo
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 654
Iscrizione: giovedì 14 luglio 2005, 9:50

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggio da pasqoo » domenica 19 novembre 2006, 20:48

leggo il primo post, tutto attento, e alla fine mettete che aiglx non supporta i driver proprietari ati? ::) >:(

sono fermo al punto dove dice di andare in sessioni di gnome per far partire quei 2 processi...

cosa devo fare per annullare tutte le operazioni che ho svolto leggendo questo topic?

grazie ciao :)

oncelot
Prode Principiante
Messaggi: 170
Iscrizione: sabato 6 maggio 2006, 13:08

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggio da oncelot » domenica 19 novembre 2006, 21:13

mattia77 ha scritto: come si installano i plugins linkati su http://www.freedesktop.org/wiki/Software/Compiz

poi qualcuno ha capito come si installano? pleaseee attendo risposta, ciauz

Avatar utente
aldolat
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 506
Iscrizione: mercoledì 9 agosto 2006, 23:04
Desktop: Gnome
Distribuzione: Ubuntu 15.10 (x86_64)
Località: Augusta (Siracusa)
Contatti:

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggio da aldolat » domenica 19 novembre 2006, 23:31

@ kr0n1x

Non è per nulla difficile farlo.

1. devi ripristinarti l'xorg.conf originale. Avevi fatto un backup del file prima di procedere?

Se non l'avevi fatto non è difficile aprirlo e rieditarlo a mano:

Codice: Seleziona tutto

sudo gedit /etc/X11/xorg.conf
e togli le voci in Section "Device"

Codice: Seleziona tutto

Option               "RenderAccel" "true"
Option               "NoRenderExtension" "false"
Option               "DisableGLXRootClipping" "true"
Option               "AddARGBGLXVisuals" "true"
Option               "AllowGLXWithComposite" "true" 
Option               “XAANoOffscreenPixmaps” "true"
Poi togli nella sezione "ServerLayout"

Codice: Seleziona tutto

Option               "AIGLX" "true"
ed infine togli completamente la sezione:

Codice: Seleziona tutto

Section "Extensions"
        Option  "Composite"  "Enable"
EndSection
Infine vai in sistema > preferenze > sessioni del menù di GNOME e togli: compiz-tray-icon e gtk-window-decorator.

2. devi disinstallare compiz e allegati:

Codice: Seleziona tutto

sudo apt-get remove --purge compiz-freedesktop-gnome gnome-compiz-manager
sostituendo gnome con quello che avevi installato (kde, xfce)

3. Devi ripristinare il tuo sources.list originale, oppure rieditare quello attuale:

Codice: Seleziona tutto

sudo gedit /etc/apt/sources.list
cancella riga aggiunta:

Codice: Seleziona tutto

deb http://gandalfn.club.fr/ubuntu edgy .
E' tutto. Ciao,
Aldo
Per avere il pieno valore della conoscenza ci vuole qualcuno col quale condividerla.

pasqoo
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 654
Iscrizione: giovedì 14 luglio 2005, 9:50

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggio da pasqoo » lunedì 20 novembre 2006, 0:26

grazie per la risposta aldolat, al riavvio ubuntu non mi mostrava la parte grafica ihihih

loggato da terminale, sono andato in /etc/X11/ e ho scritto "sudo cp xorg.conf~ xorg.conf", ho l'auto-backup attivo :)

ora grazie alla risposta ho tolto anche compiz (mentre invece il sources.list già è modificato di suo ihihi trevino)

cmq uno che ha ATI coi driver proprietari, non può avere questi effetti? magari con altri pacchetti?
a quanto pare con compiz no, ma con beryl?
io ancora non so cos'è beryl...qualcuno può schiarirmi le idee? che differenze ci sono tra compiz e beryl?

thx bye

Avatar utente
aldolat
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 506
Iscrizione: mercoledì 9 agosto 2006, 23:04
Desktop: Gnome
Distribuzione: Ubuntu 15.10 (x86_64)
Località: Augusta (Siracusa)
Contatti:

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggio da aldolat » lunedì 20 novembre 2006, 8:15

Prova nel mio blog.
Lì ci sono tre post su Beryl e Compiz. Vedi se uno di questi ti può servire.
Ciao.
Per avere il pieno valore della conoscenza ci vuole qualcuno col quale condividerla.

pasqoo
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 654
Iscrizione: giovedì 14 luglio 2005, 9:50

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggio da pasqoo » lunedì 20 novembre 2006, 13:46

aldolat ha scritto: Prova nel mio blog.
Lì ci sono tre post su Beryl e Compiz. Vedi se uno di questi ti può servire.
Ciao.
grazie appena sto tranquillo con la testa (e con i g-unit in sottofondo è impossibile ;D ) leggo tutto!

ciao

pasqoo
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 654
Iscrizione: giovedì 14 luglio 2005, 9:50

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggio da pasqoo » lunedì 20 novembre 2006, 19:21

ok ho letto e seguito tutto, però ho un problema, lo stesso di un certo Mizu che ha commentato la tua guida nel blog, ecco:

http://aldolat.wordpress.com/2006/11/15 ... omment-163

comunque il problema di mizu è un po' "generale".

invito a leggere anche il mio commento: http://aldolat.wordpress.com/2006/11/15 ... omment-193

perché fa così?
Ultima modifica di pasqoo il lunedì 20 novembre 2006, 19:26, modificato 1 volta in totale.

Avatar utente
telperion
Rampante Reduce
Rampante Reduce
Messaggi: 5407
Iscrizione: lunedì 10 luglio 2006, 18:20

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggio da telperion » martedì 21 novembre 2006, 0:29

Altre info qua:
http://forum.go-compiz.org/viewtopic.php?t=90
Per schede Nvidia, ma le info su Compiz sono comunque interessanti, da
7.) Setting up compiz in avanti

edit 21/11

Altra cosa importante non citata:
nel mio caso non erano installati gli "schemas" di compiz e gwd, installateli con

Codice: Seleziona tutto

gconftool-2 --install-schema-file=/usr/etc/gconf/schemas/compiz.schemas
gconftool-2 --install-schema-file=/usr/etc/gconf/schemas/gwd.schemas
Infine è uscito compiz-0.3.4
Ultima modifica di telperion il martedì 21 novembre 2006, 23:31, modificato 1 volta in totale.

Avatar utente
Janvitus
Amministratore
Amministratore
Messaggi: 18121
Iscrizione: lunedì 25 aprile 2005, 15:52
Desktop: GNOME Shell / Xfce
Sesso: Maschile
Località: Potenza
Contatti:

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggio da Janvitus » mercoledì 22 novembre 2006, 13:12

Ho fatto qualche aggiunta al primo messaggio, inserendo soprattutto l'avvio di compiz senza il compiz-tray-icon e senza lo gnome-compiz-manager, sembra vada più veloce, soprattutto nell'avviarsi, almeno su schede nvidia con driver propretari.
+Fedora 32 • +Xubuntu 20.04

Avatar utente
luzzo
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 508
Iscrizione: giovedì 3 marzo 2005, 9:41

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggio da luzzo » giovedì 23 novembre 2006, 9:08

La stringa di apt per i386 sembra essere cambiata:

Codice: Seleziona tutto

deb http://gandalfn.club.fr/ubuntu edgy stable

Avatar utente
mattia77
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 939
Iscrizione: martedì 21 marzo 2006, 14:58

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggio da mattia77 » giovedì 23 novembre 2006, 11:12

luzzo ha scritto: La stringa di apt per i386 sembra essere cambiata:

Codice: Seleziona tutto

deb http://gandalfn.club.fr/ubuntu edgy stable
Si ma è cambiata anche la chiave pubblica:

edgy compiz repos :

edgy repos change you must update your source.list like this :

deb http://gandalfn.club.fr/ubuntu edgy stable

or if you use edgy-dev :

deb http://gandalfn.club.fr/ubuntu edgy stable dev

in addition you should get gpg key like this :

gpg --keyserver hkp://wwwkeys.eu.pgp.net --recv-keys 0x483170E9 ; \

gpg --export -a 0x483170E9 | sudo apt-key add -

Avatar utente
Janvitus
Amministratore
Amministratore
Messaggi: 18121
Iscrizione: lunedì 25 aprile 2005, 15:52
Desktop: GNOME Shell / Xfce
Sesso: Maschile
Località: Potenza
Contatti:

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE

Messaggio da Janvitus » giovedì 23 novembre 2006, 16:04

Aggiorno il primo post.
+Fedora 32 • +Xubuntu 20.04

Avatar utente
Nitro82282
Prode Principiante
Messaggi: 103
Iscrizione: giovedì 27 aprile 2006, 14:57
Contatti:

Re: Compiz su AiGLX per GNOME/KDE/XfCE

Messaggio da Nitro82282 » venerdì 24 novembre 2006, 18:44

ho provato a installare secondo la guida del primo post. Tutto ok.
Per usare il rendering della scheda grafica, ho disinstallato compiz e ho provato a seguire l'how-to linkato da janvitusm,
ma c'e' un problema:

Codice: Seleziona tutto

nitro@darkstar:~/ sudo apt-get build-dep compiz
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso       
Reading state information... Fatto               
E: Non è stato possibile soddisfare le dipendenze di costruzione per compiz.
questo e' il mio sources.list

Codice: Seleziona tutto

## Add comments (##) in front of any line to remove it from being checked.
## Use the following sources.list at your own risk.
deb http://fr.archive.ubuntu.com/ubuntu/ edgy main restricted universe multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ edgy main restricted universe multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ edgy-proposed main restricted universe multiverse

## MAJOR BUG FIX UPDATES produced after the final release
deb http://fr.archive.ubuntu.com/ubuntu/ edgy-updates main restricted universe multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ edgy-updates main restricted universe multiverse

## UBUNTU SECURITY UPDATES
deb http://security.ubuntu.com/ubuntu edgy-security main restricted universe multiverse
deb-src http://security.ubuntu.com/ubuntu edgy-security main restricted universe multiverse

## BACKPORTS REPOSITORY (Unsupported.  May contain illegal packages.  Use at own risk.)
deb http://fr.archive.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse

## CANONICAL COMMERCIAL REPOSITORY (Hosted on Canonical servers, not Ubuntu
## servers. RealPlayer10, Opera, DesktopSecure and more to come.)
deb http://archive.canonical.com/ubuntu edgy-commercial main

## SKYPE
# deb http://download.skype.com/linux/repos/debian/ stable non-free

## PLF REPOSITORY (Unsupported.  May contain illegal packages.  Use at own risk.)
## gpg --keyserver hkp://wwwkeys.eu.pgp.net --recv-keys 0x12B83718 ;  gpg --export -a 0x12B83718 | sudo apt-key add -
deb http://packages.freecontrib.org/plf edgy-plf free non-free
deb-src http://packages.freecontrib.org/plf edgy-plf free non-free

deb http://gandalfn.club.fr/ubuntu edgy stable
deb-src http://gandalfn.club.fr/ubuntu edgy stable

deb http://gandalfn.club.fr/ubuntu edgy dev
deb-src http://gandalfn.club.fr/ubuntu edgy dev
da dove prendo i pacchetti per compilare compiz????
(vorrei utilizzare la 0.2.2 stable)
Vi ringrazio in anticipo per l'aiuto
La via più corta è sempre la più breve - Gianluca S.
Passa a trovarmi sul mio blog!

Avatar utente
telperion
Rampante Reduce
Rampante Reduce
Messaggi: 5407
Iscrizione: lunedì 10 luglio 2006, 18:20

Re: Compiz su AiGLX per GNOME/KDE/XfCE

Messaggio da telperion » venerdì 24 novembre 2006, 22:37

Nitro82282 ha scritto: ho provato a installare secondo la guida del primo post. Tutto ok.
Per usare il rendering della scheda grafica, ho disinstallato compiz e ho provato a seguire l''how-to linkato da janvitusm,
ma c''e'' un problema:

da dove prendo i pacchetti per compilare compiz????
(vorrei utilizzare la 0.2.2 stable)
Vi ringrazio in anticipo per l''aiuto
build-dep, se non sbaglio,funziona solo se c''è la cartella debian con il file control, e nei sorgenti di compiz non c''è, quindi non trova la lista delle dipendenze.

Scarica i sources da qua:
http://www.go-compiz.org/index.php?title=Download
Ti consiglio la 0.3.4 che va benissimo, sopratutto se usi Nvidia o AiGLX, molto più fluida della 0.2.2.
La lista pacchetti necessari alla compilazione la trovi qua:
http://www.go-compiz.org/index.php?title=Compiling
Build-Depends: debhelper (>= 5), quilt (>= 0.40), automake1.9, libtool, libglib2.0-dev, libgconf2-dev, libpng12-dev | libpng-dev, libxcomposite-dev (>= 1:0.3-2), libxfixes-dev (>= 1:4.0.1), libxdamage-dev (>=1:1.0.3), libxrandr-dev (>= 2:1.1.0.2), libxrender-dev (>= 1:0.9.1), libice-dev (>= 1:1.0.1), libsm-dev (>= 1:1.0.1), libgl1-mesa-dev (>= 6.5.1) | libgl-dev, libcairo-dev, librsvg2-dev, libgnome-desktop-dev, libgnome-window-settings-dev, libdbus-1-dev, libwnck-dev, libgtk2.0-dev, libpango1.0-dev, x11proto-gl-dev (>= 1.4.8-1), libxinerama-dev, libmetacity-dev
Se vuoi i plugin aggiuntivi compilati anche
compiz-extra-0.3.4.0.tar.bz2
Ultima modifica di telperion il venerdì 24 novembre 2006, 22:41, modificato 1 volta in totale.

Avatar utente
Nitro82282
Prode Principiante
Messaggi: 103
Iscrizione: giovedì 27 aprile 2006, 14:57
Contatti:

Re: Compiz su AiGLX per GNOME/KDE/XfCE

Messaggio da Nitro82282 » sabato 25 novembre 2006, 1:48

grazie comunque telperion, ma mi sono già arrangiato piu' o meno nel modo che mi hai suggerito.
Solo ho trovato problemi con libwnck-dev.
Aveva delle dipendenze interrotte e non si voleva installare, poi l'ho forzata con dpkg --force-dependances
e ora funziona.
Peccato che nonostante non ci sia piu' l'indirect-rendering non ho notato grossi miglioramenti
cioe' la CPU mi si carica lo stesso anche adesso. Ora provo ad inserire compiz all'avvio di gnome e vedo se cambia qualcosa
La via più corta è sempre la più breve - Gianluca S.
Passa a trovarmi sul mio blog!

ShinjiLeery
Prode Principiante
Messaggi: 161
Iscrizione: domenica 5 giugno 2005, 12:13

Re: Compiz su AiGLX per GNOME/KDE/XfCE

Messaggio da ShinjiLeery » sabato 25 novembre 2006, 19:39

Ho seguito la guida per la compilazione dei pacchetti, ovvero compiz 0.3.4-1 e l'ultimo compiz-manager...

Non funziona niente, ovveri il compiz-tray-icon viene visualizzata, quando provo a far partire il GL Desktop non mi fa vedere niente, ed inoltre se provo a fare configura, si impianta il tray.
Su synaptic come pacchetti compiz, mi fa vedere che ho installato solo compiz compilato da me e compiz-manager compilato sempre da me secondo la guida postata in questo topic.

Ho forse scordato qualcosa?
Datemi un aiuto perchè con i pacchetti pre-compilati firefox mi va da schifo e i video non si vedono :'(

Avatar utente
niusiland
Prode Principiante
Messaggi: 181
Iscrizione: giovedì 12 ottobre 2006, 12:47
Località: Segrate

Re: Compiz su AiGLX per GNOME/KDE/XfCE

Messaggio da niusiland » domenica 26 novembre 2006, 13:41

Ciao,
è quattro giorni che giro sul forum e in rete in generale ma non riesco a risolvere il mio problema, so che è stato trattato più volte ma non ho ancora capito qual'è la soluzione:
ho correttamente installato compiz su edgy (con driver NVIDIA reinstallati non più di due settimane fa) senza alcun problema tramite la guida di pollycoke, ma ancora non riesco a visualizzare i bordi delle finestre nonostante metacity sia attivo (o così sostiene la finestra preferenze raggiungibile da icona nel systray). Ho tentato di rimpiazzare compiz-tray-icon con i comandi sostitutivi trovati su questo forum, compreso gnome-window-decorator ma il risultato non cambia. Ho provato con gtk-window-decorator ma il comando non esiste, da quello che ho capito si tratta di gnome-window-decorator a cui hanno cambiato il nome. Ho provato ad abilitare GLDeskotp e lanciare poi gnome-window-decorator --replace ma ancora niente da fare. Da quel che ho visto sul forum tutti risolvono il problema aggiornando il sistema ma a me non cambia nulla, potreste aiutarmi?
Grazie

...


News: non so come diavolo sia potuto succedere, ora funziona tutto, non ho fatto (credo ma mi sbaglio sicuramente) niente di diverso da quel che ho fatto nei giorni passati, eppure ora è tutto a posto... Vabbè, meglio così, peccato non avere idea di cosa sia successo... (mad)

Ora però ho un'altra domanda: ho abilitato le trasparenze sulle barre dei menu (funzione disponibile anche senza avere compiz), ma quando seleziono una voce del menu la tendina si abbassa senza trasparenza, che voi sappiate esiste un modo per evitare che ciò accada? Intendo, è possibile vedere una simil-trasparenza (tipo terminale) sulle voci del menu?

Grazie di nuovo,
Andrea
Ultima modifica di niusiland il domenica 26 novembre 2006, 14:48, modificato 1 volta in totale.
Se fate una domanda, ed ottenete una risposta, abbiate almeno l'educazione di far sapere se è servita.
Grazie.

Scrivi risposta

Ritorna a “Unity”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 2 ospiti