Compiz su AiGLX per GNOME/KDE/XfCE (aggiorntato al 22/08/2007)

Configurazione e uso dell'interfaccia utente predefinita fino alla versione 16.04 di Ubuntu.

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda x-coder » sabato 21 ottobre 2006, 14:07

Ciao ragazzi, a me questo compiz non mi è mai funzionato!! ho aggiornato a edgy solo per sperare che aixgl funzionasse senza problemi... ma invece niente... Ho un ati radeon 9200SE

il mio xorg:
Codice: Seleziona tutto
Section "Files"
   FontPath   "/usr/share/X11/fonts/misc"
   FontPath   "/usr/share/X11/fonts/cyrillic"
   FontPath   "/usr/share/X11/fonts/100dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/75dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/Type1"
   FontPath   "/usr/share/X11/fonts/100dpi"
   FontPath   "/usr/share/X11/fonts/75dpi"
   FontPath   "/usr/share/fonts/X11/misc"
   # path to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load   "bitmap"
   Load   "ddc"
   Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "type1"
   Load   "v4l"
   Load   "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "it"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ExplorerPS/2"
   Option      "ZAxisMapping"      "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "stylus"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "stylus"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "eraser"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "eraser"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "cursor"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "cursor"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "Scheda video generica"
   Driver      "radeon"
   BusID      "PCI:1:0:0"
   Option "DRI" "true"
   Option "ColorTiling" "on"
   Option "EnablePageFlip" "true"
   Option "AccelMethod" "EXA"
   Option "XAANoOffscreenPixmaps"
   Option "RenderAccel" "true"
 
EndSection

Section "Monitor"
   Identifier   "710S"
   Option      "DPMS"
   HorizSync   30-71
   VertRefresh   50-160
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "Scheda video generica"
   Monitor      "710S"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
   InputDevice     "stylus" "SendCoreEvents"
   InputDevice     "cursor" "SendCoreEvents"
   InputDevice     "eraser" "SendCoreEvents"
   Option               "AIGLX" "true"
EndSection

Section "DRI"
   Mode   0666
EndSection

Section "Extensions"
        Option  "Composite"  "Enable"
EndSection


Il direct rendering non si abilita..
Codice: Seleziona tutto
# glxinfo | grep rendering
direct rendering: No



Se do compiz --replace si blocca tutto kde!

E' destino che non mi deve funzionare?
Ultima modifica di x-coder il sabato 21 ottobre 2006, 14:25, modificato 1 volta in totale.
x-coder
Prode Principiante
 
Messaggi: 198
Iscrizione: gennaio 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda Janvitus » sabato 21 ottobre 2006, 14:28

Avete provato ad usare le opzioni, e solo quelle, che ho indicato nel primo post?
Avatar utente
Janvitus
Amministratore
Amministratore
 
Messaggi: 17566
Iscrizione: aprile 2005
Località: Potenza
Desktop: GNOME 3.34
Distribuzione: Fedora/Ubuntu
Sesso: Maschile

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda x-coder » sabato 21 ottobre 2006, 14:37

Si certo. solo che il direct rendering risulta sempre disattivato... e cmq

Codice: Seleziona tutto
compiz
compiz: Screen 0 on display ":0.0" already has a window manager; try using the --replace option to replace the current window manager.
compiz: No manageable screens found on display :0.0
x-coder
Prode Principiante
 
Messaggi: 198
Iscrizione: gennaio 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda Zed » sabato 21 ottobre 2006, 14:44

a me non installa i driver nvidia quindi non posso procedere...mi dice che manca il kernel...si riferisce a un certo gcc 4.0

Io avevo il 4.1 installato, ho installato anche il 4.0, il 3.4. Niente da fare. Nessuno può dirmi che prove posso fare?
Zed
Prode Principiante
 
Messaggi: 4
Iscrizione: ottobre 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda x-coder » sabato 21 ottobre 2006, 15:10

sono riuscito ad abilitare il direct rendering

do compiz-tray-icon... mi crasha kwin.. avvio dinuovo kwin.. vado nelle preferenze di compiz e clicco su enabe gl Desktop, crasha dinuovo kwin, lo riavvio .. ma non c'è nessun effetto è tutto normale... e inoltre se vado dinuovo sulle preferenze... Enable gl Desktop rimane disattivato...

se lo riabilito stessa cosa... crasha kwin... riavvio kwin.. ma nessun effetto!
x-coder
Prode Principiante
 
Messaggi: 198
Iscrizione: gennaio 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda mattia77 » sabato 21 ottobre 2006, 15:12

Zed ha scritto:a me non installa i driver nvidia quindi non posso procedere...mi dice che manca il kernel...si riferisce a un certo gcc 4.0

Io avevo il 4.1 installato, ho installato anche il 4.0, il 3.4. Niente da fare. Nessuno può dirmi che prove posso fare?







Prima devi installare:

sudo apt-get install build-essential
sudo apt-get install linux-headers-$(uname -r) libc6-dev

Poi devi patchare i driver nvidia così:
http://www.nvnews.net/vbulletin/showpos ... stcount=20

Ed ora puoi installare i driver nvidia 9625
Avatar utente
mattia77
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 938
Iscrizione: marzo 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda Freedreamer » sabato 21 ottobre 2006, 16:01

Ciao raga ho sempre avuto xgl su laptop ora ho meso il pinguino sul fisso e volevo provare edgy
ho una scheda ati 9550 ma se seguo la guida mi crasha all'avvio schermata blu...
allora mi tocca rimodificare lo xorg.conf x farlo partire...

se faccio:

glxinfo | grep rendering
libGL warning: 3D driver claims to not support visual 0x4b
direct rendering: Yes


qlc ha la mia scheda e l'ha fatto andare? credo che sia compatibile ...

tnx 4 help
Avatar utente
Freedreamer
Prode Principiante
 
Messaggi: 139
Iscrizione: agosto 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda Zed » sabato 21 ottobre 2006, 18:31

mattia77 ha scritto:Prima devi installare:

sudo apt-get install build-essential
sudo apt-get install linux-headers-$(uname -r) libc6-dev

Poi devi patchare i driver nvidia così:
http://www.nvnews.net/vbulletin/showpos ... stcount=20

Ed ora puoi installare i driver nvidia 9625


Codice: Seleziona tutto

ERROR: The CC compiler ''cc'' does not appear to be able to
create executables. Please make sure you have
 your Linux distribution''s gcc and libc development
packages installed.


ERROR: Installation has failed. Please see the file
''var/log/nvidia-installer.log'' for details. You may find suggestions on fixing...
www.nvidia.com



Ho provato a installare tutti i gcc e i libc (ex binutils) ma niente. Ho paura che sia per il fatto che sto avviando
l''immagine di Linux sbagliata. Può essere? Come dicevo nell''altro thread, dopo l''aggiornamento da Dapper a Edgy, non sono riuscito ad utilizzare la nuova immagine. Nel menù di grub seleziono la terza, insomma. L''ultima uscita per Dapper.

Ho rifatto il tutto più volte ma non riesco a venirne a capo. Ho dato anche un occhiata al thread sui driver che mi hai segnalato, sul sito nvidia, e non ho trovato ancora niente.

:-\
Ultima modifica di Zed il sabato 21 ottobre 2006, 19:01, modificato 1 volta in totale.
Zed
Prode Principiante
 
Messaggi: 4
Iscrizione: ottobre 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda mattia77 » domenica 22 ottobre 2006, 11:15

Zed ha scritto:
mattia77 ha scritto:Prima devi installare:

sudo apt-get install build-essential
sudo apt-get install linux-headers-$(uname -r) libc6-dev

Poi devi patchare i driver nvidia così:
http://www.nvnews.net/vbulletin/showpos ... stcount=20

Ed ora puoi installare i driver nvidia 9625


Codice: Seleziona tutto

ERROR: The CC compiler ''cc'' does not appear to be able to
create executables. Please make sure you have
 your Linux distribution''s gcc and libc development
packages installed.


ERROR: Installation has failed. Please see the file
''var/log/nvidia-installer.log'' for details. You may find suggestions on fixing...
www.nvidia.com



Ho provato a installare tutti i gcc e i libc (ex binutils) ma niente. Ho paura che sia per il fatto che sto avviando
l''immagine di Linux sbagliata. Può essere? Come dicevo nell''altro thread, dopo l''aggiornamento da Dapper a Edgy, non sono riuscito ad utilizzare la nuova immagine. Nel menù di grub seleziono la terza, insomma. L''ultima uscita per Dapper.

Ho rifatto il tutto più volte ma non riesco a venirne a capo. Ho dato anche un occhiata al thread sui driver che mi hai segnalato, sul sito nvidia, e non ho trovato ancora niente.

:-\


Non ho capito :-) in pratica usi edgy col kernel di dapper?

Cmq non complicarti la vita; comprimi in tar.gz la tua /home spostala in un''altra partizione e formatta, dopo la rimetti in edgy (sidtemi i permessi) e non ti accorgi di nulla.

Fare un'' upgrade da una stabile ad una beta è troppo.
Avatar utente
mattia77
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 938
Iscrizione: marzo 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda Janvitus » domenica 22 ottobre 2006, 17:49

Freedreamer ha scritto:Ciao raga ho sempre avuto xgl su laptop ora ho meso il pinguino sul fisso e volevo provare edgy
ho una scheda ati 9550 ma se seguo la guida mi crasha all''avvio schermata blu...
allora mi tocca rimodificare lo xorg.conf x farlo partire...

se faccio:

glxinfo | grep rendering
libGL warning: 3D driver claims to not support visual 0x4b
direct rendering: Yes


qlc ha la mia scheda e l''ha fatto andare? credo che sia compatibile ...

tnx 4 help


Che driver usi? ricordo che quelli propretari ATI non funzionano con aiglx.

Zed ha scritto:


Ho provato a installare tutti i gcc e i libc (ex binutils) ma niente. Ho paura che sia per il fatto che sto avviando
l''immagine di Linux sbagliata. Può essere? Come dicevo nell''altro thread, dopo l''aggiornamento da Dapper a Edgy, non sono riuscito ad utilizzare la nuova immagine. Nel menù di grub seleziono la terza, insomma. L''ultima uscita per Dapper.

Ho rifatto il tutto più volte ma non riesco a venirne a capo. Ho dato anche un occhiata al thread sui driver che mi hai segnalato, sul sito nvidia, e non ho trovato ancora niente.

:-\


Per installare i driver devi usare la stessa versione del compilatore con cui è stato compilato il kernel, il tuo errore sembra proprio quello, per cui devi "importare" il gcc esatto per compialre il driver nvidia:

Codice: Seleziona tutto
export CC=gcc-4.0 && sh ./NVIDIA-xxx-xxxx.run
Avatar utente
Janvitus
Amministratore
Amministratore
 
Messaggi: 17566
Iscrizione: aprile 2005
Località: Potenza
Desktop: GNOME 3.34
Distribuzione: Fedora/Ubuntu
Sesso: Maschile

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda tiscio » domenica 22 ottobre 2006, 18:37

Ciao a tutti.
Io con questa splendida guida ci sono riuscito al primo colpo.
Per installare correttamente i driver Nvidia ho usato lo script envy per edgy, una vera manna dal cielo, scaricatelo dalla pagina dell'ideatore: http://www.albertomilone.com/nvidia_scripts1.html
Installatelo e avviatelo solo una volta chiuso gdm e il server x, finita l'installazione potete aggiornare i driver normalmente in quanto envy avrà provveduto a scaricare tutte le dipendenze per compilare il modulo.
Finita l'installazione aggiungete le stringhe in xorg.conf come nella guida e dovrebbe funzionare tutto.
Avatar utente
tiscio
Prode Principiante
 
Messaggi: 45
Iscrizione: maggio 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda systrade » domenica 22 ottobre 2006, 21:10

x-coder ha scritto:sono riuscito ad abilitare il direct rendering

do compiz-tray-icon... mi crasha kwin.. avvio dinuovo kwin.. vado nelle preferenze di compiz e clicco su enabe gl Desktop, crasha dinuovo kwin, lo riavvio .. ma non c''è nessun effetto è tutto normale... e inoltre se vado dinuovo sulle preferenze... Enable gl Desktop rimane disattivato...

se lo riabilito stessa cosa... crasha kwin... riavvio kwin.. ma nessun effetto!

visto che avevo quasi tutti i tuoi stessi problemi su un computer .. mi dici come hai fatto?
grazie
Ubuntu user #8446 - Linux Counter #431948 - Ubuntu 6.10 -
systrade
Prode Principiante
 
Messaggi: 146
Iscrizione: agosto 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda x-coder » domenica 22 ottobre 2006, 22:17

systrade ha scritto:
x-coder ha scritto:sono riuscito ad abilitare il direct rendering

do compiz-tray-icon... mi crasha kwin.. avvio dinuovo kwin.. vado nelle preferenze di compiz e clicco su enabe gl Desktop, crasha dinuovo kwin, lo riavvio .. ma non c''è nessun effetto è tutto normale... e inoltre se vado dinuovo sulle preferenze... Enable gl Desktop rimane disattivato...

se lo riabilito stessa cosa... crasha kwin... riavvio kwin.. ma nessun effetto!

visto che avevo quasi tutti i tuoi stessi problemi su un computer .. mi dici come hai fatto?
grazie


Niente ci ho rinunciato.. non so piu cosa fare.. peccato..
x-coder
Prode Principiante
 
Messaggi: 198
Iscrizione: gennaio 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda Janvitus » domenica 22 ottobre 2006, 22:52

x-coder ha scritto:

Niente ci ho rinunciato.. non so piu cosa fare.. peccato..


Quando ci sono questi problemi, cercate di far funzionae i programmi lanciandoli da shell, almeno dovreste vedere gli errori, e magari risolvere.
Avatar utente
Janvitus
Amministratore
Amministratore
 
Messaggi: 17566
Iscrizione: aprile 2005
Località: Potenza
Desktop: GNOME 3.34
Distribuzione: Fedora/Ubuntu
Sesso: Maschile

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda mattia77 » lunedì 23 ottobre 2006, 20:08

Ciao ho messo compiz ad un mio amico, ma dopo un'aggiornamento gli è sparito il bordo delle finestre, nessuno dei consigli trovati su questo thread è servito, qualche idea?

nvidia geforce4


Grazie
Avatar utente
mattia77
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 938
Iscrizione: marzo 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda Janvitus » lunedì 23 ottobre 2006, 22:54

Se nell'aggiornamento è coinvolto xorg, prova a reinstallare i driver nvidia, cmq era una cosa che se ne è già discussa nelle pagine precedenti, diamo una lettura prima ;)
Avatar utente
Janvitus
Amministratore
Amministratore
 
Messaggi: 17566
Iscrizione: aprile 2005
Località: Potenza
Desktop: GNOME 3.34
Distribuzione: Fedora/Ubuntu
Sesso: Maschile

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda Freedreamer » martedì 24 ottobre 2006, 10:19

scusa per il ritardo janvitus
uso i mesa di driver ma mi crasha cmq... :-[
Avatar utente
Freedreamer
Prode Principiante
 
Messaggi: 139
Iscrizione: agosto 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda Attila_fdd » martedì 24 ottobre 2006, 10:47

scusate ma per far funzionare Aiglx con una scheda 7600gt sono necessari i driver beta 9625 nvidia oppure vanno bene i driver glx scaricati dal repositories di beryl?
Attila_fdd
Prode Principiante
 
Messaggi: 201
Iscrizione: marzo 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda mattia77 » martedì 24 ottobre 2006, 11:40

Janvitus ha scritto:Se nell''aggiornamento è coinvolto xorg, prova a reinstallare i driver nvidia, cmq era una cosa che se ne è già discussa nelle pagine precedenti, diamo una lettura prima ;)


i post li avevo letti, ma non c''entravano con l''errore.
Per fortuna dal log user.0 mi sono accorto che aveva perso i permessi di scrittura su .gconfd
Avatar utente
mattia77
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 938
Iscrizione: marzo 2006

Re: [Guida] AiGLX con Compiz per GNOME/KDE/XfCE su Edgy Eft

Messaggioda Janvitus » martedì 24 ottobre 2006, 13:10

Freedreamer ha scritto:scusa per il ritardo janvitus
uso i mesa di driver ma mi crasha cmq... :-[


Usa qualche altro driver.

Attila_fdd ha scritto:scusate ma per far funzionare Aiglx con una scheda 7600gt sono necessari i driver beta 9625 nvidia oppure vanno bene i driver glx scaricati dal repositories di beryl?


No, con i driver propretari servono per forza quelli beta, come scritto nel primo topic.
Avatar utente
Janvitus
Amministratore
Amministratore
 
Messaggi: 17566
Iscrizione: aprile 2005
Località: Potenza
Desktop: GNOME 3.34
Distribuzione: Fedora/Ubuntu
Sesso: Maschile

PrecedenteSuccessiva

Torna a Unity

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 2 ospiti