ubuntu è peggiorato?

Il ritrovo della comunità dove confrontarsi e discutere sulle notizie dal mondo dell'informatica, di Ubuntu e di tutto quello che la riguarda, novità, pettegolezzi e quant'altro.
Avatar utente
wilecoyote
Gruppo Documentazione
Gruppo Documentazione
Messaggi: 12475
Iscrizione: giovedì 20 agosto 2009, 16:21
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14/16/18/20.04 LTS 64bit
Sesso: Maschile
Località: Ceranesi - Ge

Re: ubuntu è peggiorato?

Messaggio da wilecoyote »

:) Salve, elimina i pacchetti snap e migliorerà.

:ciao: Ciao
ACER Extensa 5230E 2,2 Ghz cpu Celeron 900 hdd 160 GB Ram 1GB scheda video Intel GM500
ACER Extensa 5635Z 2,2 Ghz cpu Celeron T3100 hdd 320 GB Ram 4 GB scheda video Intel Mobile 4
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
ne0h
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 2429
Iscrizione: mercoledì 26 luglio 2006, 1:36
Desktop: Cinnamon
Distribuzione: LMDE4+Ubuntu20.04
Sesso: Maschile
Località: provincia di vicenza

Re: ubuntu è peggiorato?

Messaggio da ne0h »

mito60 ha scritto:
lunedì 29 novembre 2021, 17:54
Dopo l'accensione è diventato molto più lento, non che aspettare pesi, ma è davvero molto più lungo anche di windows (ho un dual boot, che però su Windows 8 limito per alcune funzioni)
esatto come ti dice anche wilecoyote, bisogna eliminare snapd in questo caso. Bisogna piallarlo ed eliminare tutti gli snap installati.
la situazione migliora di molto. Sempre meno rispetto ad altre distro, ma diciamo che la situazione diventa decisamente buona. Ho visto nella tua descrizione che hai scritto che stai usando la 21.10, ma questa non è LTS, ma lo è la 20.04.
In ogni caso, la 21.10 dovrebbe essere più veloce rispetto alla 20.04!
LMDE4 su PC Desktop: Intel Core i7 4790S, 1ssd 1TB+1hdd 1TB, 16 GB RAM, Nvidia GeForce GTX 1050 Ti.
Ubuntu 20.04 LTS Laptop: ThinkPad X1
-Free Julian-
Avatar utente
mito60
Prode Principiante
Messaggi: 206
Iscrizione: sabato 10 maggio 2008, 18:25
Desktop: Ubuntu64 bit-Gnome40.4.0
Distribuzione: Ubuntu 21.10 LTS x86_64

Re: ubuntu è peggiorato?

Messaggio da mito60 »

Grazie. Un dubbio da niubbo che ho? Però a me gli snaps (forse) servono nell'uso, quindi anche se ci mette diversi minuti ad accendersi per ora li tengo, magari mi studio a che servono.... 8-)
teoria: si sa’ tutto ma niente funziona; pratica: quando tutto funziona e nessuno sa’ il perché.  Abbiamo messo insieme la teoria e la pratica: non c’ è niente che funziona … e nessuno sa’ il perché. (A. Einstein)
gyanny
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1951
Iscrizione: lunedì 2 febbraio 2009, 10:13
Desktop: Gnome / Kde Plasma
Distribuzione: Fedora / Arch Linux
Località: Brianza

Re: ubuntu è peggiorato?

Messaggio da gyanny »

Gli snap c'entrano niente con i tempi di avvio del sistema, quindi se ti servono tienili tranquillamente e indaga invece le cause rallentano l'avvio
Avatar utente
corradoventu
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 2871
Iscrizione: domenica 27 aprile 2008, 22:23
Desktop: GNOME
Distribuzione: Ubuntu 18.04, 20.04, 21.04, 21.10
Sesso: Maschile
Località: Rezzoaglio (GE)
Contatti:

Re: ubuntu è peggiorato?

Messaggio da corradoventu »

A me sembra che gli snap rallentino, la apertura di ogni dev-loop**-device costa qualcosa dunque se hai tanti snap ne risenti

Codice: Seleziona tutto

corrado@corrado-n4-jj-1107:~$ systemd-analyze blame
11.500s NetworkManager-wait-online.service
 4.786s plymouth-quit-wait.service
 1.098s fwupd.service
  900ms dev-nvme0n1p4.device
  758ms dev-loop11.device
  674ms dev-loop12.device
  647ms dev-loop14.device
  634ms snap-gtk\x2dcommon\x2dthemes-1519.mount
  622ms dev-loop13.device
  551ms udisks2.service
  523ms dev-loop15.device
  509ms snap-snap\x2dstore-549.mount
  496ms snapd.service
  469ms apparmor.service
  397ms dev-loop10.device
Con o senza religione, i buoni si comportano bene e i cattivi male, ma ci vuole la religione per far comportare male i buoni.
(Steven Weinberg)
gyanny
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1951
Iscrizione: lunedì 2 febbraio 2009, 10:13
Desktop: Gnome / Kde Plasma
Distribuzione: Fedora / Arch Linux
Località: Brianza

Re: ubuntu è peggiorato?

Messaggio da gyanny »

si certo ogni dev-loop dai 500 ai 700 ms...
quanti dovrebbe averne visto che stiamo parlando di diversi minuti per avviarsi?
Avatar utente
ne0h
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 2429
Iscrizione: mercoledì 26 luglio 2006, 1:36
Desktop: Cinnamon
Distribuzione: LMDE4+Ubuntu20.04
Sesso: Maschile
Località: provincia di vicenza

Re: ubuntu è peggiorato?

Messaggio da ne0h »

gyanny ha scritto:
lunedì 29 novembre 2021, 19:37
Gli snap c'entrano niente con i tempi di avvio del sistema, quindi se ti servono tienili tranquillamente e indaga invece le cause rallentano l'avvio
grosso errore!! incidono eccome invece!
LMDE4 su PC Desktop: Intel Core i7 4790S, 1ssd 1TB+1hdd 1TB, 16 GB RAM, Nvidia GeForce GTX 1050 Ti.
Ubuntu 20.04 LTS Laptop: ThinkPad X1
-Free Julian-
Avatar utente
wilecoyote
Gruppo Documentazione
Gruppo Documentazione
Messaggi: 12475
Iscrizione: giovedì 20 agosto 2009, 16:21
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14/16/18/20.04 LTS 64bit
Sesso: Maschile
Località: Ceranesi - Ge

Re: ubuntu è peggiorato?

Messaggio da wilecoyote »

:) Salve,
gyanny ha scritto:
lunedì 29 novembre 2021, 20:33
si certo ogni dev-loop dai 500 ai 700 ms...
quanti dovrebbe averne visto che stiamo parlando di diversi minuti per avviarsi?

Purtroppo per 1 volta sbagli te, capita, non hai idea di quante volte rimuovendo il pacchetto snapd ho migliorato la velocità d'avvio.

:ciao: Ciao
ACER Extensa 5230E 2,2 Ghz cpu Celeron 900 hdd 160 GB Ram 1GB scheda video Intel GM500
ACER Extensa 5635Z 2,2 Ghz cpu Celeron T3100 hdd 320 GB Ram 4 GB scheda video Intel Mobile 4
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
gyanny
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1951
Iscrizione: lunedì 2 febbraio 2009, 10:13
Desktop: Gnome / Kde Plasma
Distribuzione: Fedora / Arch Linux
Località: Brianza

Re: ubuntu è peggiorato?

Messaggio da gyanny »

Sarà come dite voi, a me personalmente, se il mio sistema impiega diversi minuti ad avviarsi, di guadagnare 5 o 6 secondi, importerebbe una mazza. Non potrei certo dirmi soddisfatto.
Preferirei tenere quello che mi serve e mi rallenta di 5 secondi, e invece risolvere il problema che mi fa' perdere 2 o 3 minuti.
Avatar utente
corradoventu
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 2871
Iscrizione: domenica 27 aprile 2008, 22:23
Desktop: GNOME
Distribuzione: Ubuntu 18.04, 20.04, 21.04, 21.10
Sesso: Maschile
Località: Rezzoaglio (GE)
Contatti:

Re: ubuntu è peggiorato?

Messaggio da corradoventu »

gyanny ha scritto:
lunedì 29 novembre 2021, 20:33
si certo ogni dev-loop dai 500 ai 700 ms...
quanti dovrebbe averne visto che stiamo parlando di diversi minuti per avviarsi?
dove li hai visti 'diversi minuti'? jeremie2 dice: Niente di estenuante dura 1 minuto e 23 in cui avvio Ubuntu 21.10, avvio qualche applicazione "classica" e poi avvio 2 snap.
dunque compresa la partenza di varie applicazioni compreso Firefox che in effetti è penosamente lento alla prima partenza.
Con o senza religione, i buoni si comportano bene e i cattivi male, ma ci vuole la religione per far comportare male i buoni.
(Steven Weinberg)
gyanny
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1951
Iscrizione: lunedì 2 febbraio 2009, 10:13
Desktop: Gnome / Kde Plasma
Distribuzione: Fedora / Arch Linux
Località: Brianza

Re: ubuntu è peggiorato?

Messaggio da gyanny »

corradoventu ha scritto:
lunedì 29 novembre 2021, 21:27
gyanny ha scritto:
lunedì 29 novembre 2021, 20:33
si certo ogni dev-loop dai 500 ai 700 ms...
quanti dovrebbe averne visto che stiamo parlando di diversi minuti per avviarsi?
dove li hai visti 'diversi minuti'? jeremie2 dice: Niente di estenuante dura 1 minuto e 23 in cui avvio Ubuntu 21.10, avvio qualche applicazione "classica" e poi avvio 2 snap.
dunque compresa la partenza di varie applicazioni compreso Firefox che in effetti è penosamente lento alla prima partenza.
Qui viewtopic.php?p=5280803#p5280803
ma forse te lo eri perso
Avatar utente
frapox
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1956
Iscrizione: sabato 31 dicembre 2005, 19:22
Desktop: Gnome, Kde Plasma
Distribuzione: Arch, Debian
Località: Sud Europa

Re: ubuntu è peggiorato?

Messaggio da frapox »

I tempi di avvio non sono tutto infatti, sono una parte del problema, e sicuramente sono più percepibili da uno che ha un hardware vecchio.
Avatar utente
corradoventu
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 2871
Iscrizione: domenica 27 aprile 2008, 22:23
Desktop: GNOME
Distribuzione: Ubuntu 18.04, 20.04, 21.04, 21.10
Sesso: Maschile
Località: Rezzoaglio (GE)
Contatti:

Re: ubuntu è peggiorato?

Messaggio da corradoventu »

A me va bene, qui i risultati per Impish e Jammy su due partizioni della stessa macchina (buona ma non al top, ma disco nvme)

Codice: Seleziona tutto

corrado@corrado-n5-impish:~$ inxi -SCGM
System:
  Host: corrado-n5-impish Kernel: 5.13.0-22-generic x86_64 bits: 64 
  Desktop: GNOME 40.5 Distro: Ubuntu 21.10 (Impish Indri) 
Machine:
  Type: Laptop System: Dell product: Inspiron 3793 v: N/A 
  serial: <superuser required> 
  Mobo: Dell model: 0C1PF2 v: A00 serial: <superuser required> UEFI: Dell 
  v: 1.5.0 date: 12/17/2019 
CPU:
  Info: Quad Core model: Intel Core i5-1035G1 bits: 64 type: MT MCP cache: 
  L2: 6 MiB 
  Speed: 686 MHz min/max: 400/1000 MHz Core speeds (MHz): 1: 686 2: 999 
  3: 780 4: 755 5: 845 6: 1000 7: 954 8: 622 
Graphics:
  Device-1: Intel Iris Plus Graphics G1 driver: i915 v: kernel 
  Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo 
  Display: wayland server: X.Org 1.21.1.2 driver: loaded: i915 
  note: n/a (using device driver) resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa Intel UHD Graphics (ICL GT1) v: 4.6 Mesa 21.2.2 
corrado@corrado-n5-impish:~$ 
Impish:

Codice: Seleziona tutto

corrado@corrado-n5-impish:~$ systemd-analyze
Startup finished in 7.811s (firmware) + 11.675s (loader) + 4.710s (kernel) + 9.070s (userspace) = 33.266s 
graphical.target reached after 9.038s in userspace
corrado@corrado-n5-impish:~$ systemd-analyze critical-chain
The time when unit became active or started is printed after the "@" character.
The time the unit took to start is printed after the "+" character.

graphical.target @9.038s
└─multi-user.target @9.038s
  └─kerneloops.service @9.013s +24ms
    └─network-online.target @9.006s
      └─NetworkManager-wait-online.service @2.413s +6.592s
        └─NetworkManager.service @2.201s +207ms
          └─dbus.service @2.194s
            └─basic.target @2.168s
              └─sockets.target @2.168s
                └─cups.socket @2.573s
                  └─sysinit.target @2.154s
                    └─snapd.apparmor.service @2.038s +115ms
                      └─apparmor.service @1.612s +424ms
                        └─local-fs.target @1.610s
                          └─snap-snap\x2dstore-547.mount @479ms +1.064s
                            └─dev-loop14.device @1.540s +193ms
corrado@corrado-n5-impish:~$                               
Jammy - leggermente migliore

Codice: Seleziona tutto

corrado@corrado-p3-jj-1130:~$ systemd-analyze 
Startup finished in 7.717s (firmware) + 5.613s (loader) + 4.627s (kernel) + 8.780s (userspace) = 26.738s 
graphical.target reached after 8.766s in userspace
corrado@corrado-p3-jj-1130:~$ systemd-analyze critical-chain
The time when unit became active or started is printed after the "@" character.
The time the unit took to start is printed after the "+" character.

graphical.target @8.766s
└─multi-user.target @8.766s
  └─kerneloops.service @8.740s +24ms
    └─network-online.target @8.734s
      └─NetworkManager-wait-online.service @2.188s +6.545s
        └─NetworkManager.service @1.994s +188ms
          └─dbus.service @1.986s
            └─basic.target @1.933s
              └─sockets.target @1.933s
                └─snapd.socket @1.931s +1ms
                  └─sysinit.target @1.923s
                    └─snapd.apparmor.service @1.750s +173ms
                      └─apparmor.service @1.257s +450ms
                        └─local-fs.target @1.240s
                          └─boot-efi.mount @1.218s +19ms
                            └─systemd-fsck@dev-disk-by\x2duuid-FA81\x2d0C15.ser>
                              └─dev-disk-by\x2duuid-FA81\x2d0C15.device @1.117s
Con o senza religione, i buoni si comportano bene e i cattivi male, ma ci vuole la religione per far comportare male i buoni.
(Steven Weinberg)
Avatar utente
woddy68
Rampante Reduce
Rampante Reduce
Messaggi: 7285
Iscrizione: sabato 12 febbraio 2011, 14:23
Desktop: Kde Plasma5
Distribuzione: openSUSE Leap-Tumbleweed-Kubuntu 20
Sesso: Maschile

Re: ubuntu è peggiorato?

Messaggio da woddy68 »

Beh! sinceramente i tempi di boot se non solo allungati a dismisura, per me non sono un problema.
Un distribuzione orientata a un utenza inesperta, tende ad attivare tutti i servizi che di norma possono essere utili a un utente, proprio per rendere più semplice il sistema. Noi utenti più smaliziati, giustamente disattiviamo tutto quello che non ci interessa.
E' una delle prime cose che faccio anch'io, se il mio desktop non ha il bluetooth inutile tenere attivo il servizio, così come altri servizi, che in molti casi sono inutili.
Tuttavia se vuoi un boot veloce, dovresti almeno avere un SSD, altrimenti sarà comunque lento a prescindere da snap o servizi.
Certo puoi risparmiare qualcosa, ma alla fine sono pochi secondi nella migliore delle ipotesi.
Desktop - Acer Aspire M5500 (AMD) - Notebook Acer Aspire E1 -522 (Amd)
-Ho sempre accettato caramelle dagli sconosciuti-
Ecco cosa succede quando...https://www.youtube.com/watch?v=iigtsYY ... ni7HzinVf8
Avatar utente
corradoventu
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 2871
Iscrizione: domenica 27 aprile 2008, 22:23
Desktop: GNOME
Distribuzione: Ubuntu 18.04, 20.04, 21.04, 21.10
Sesso: Maschile
Località: Rezzoaglio (GE)
Contatti:

Re: ubuntu è peggiorato?

Messaggio da corradoventu »

A me due giorni fa il tempo di boot era passato da circa 9 secondi a oltre 1 minuto perchè un tentativo di installare ubuntu-canary mi aveva scassato lo swap e avevo il messaggio:
Timed out waiting for device /dev/disk/by-uuid/2fe03a21-7269-4915-a943-740fac832325.
sistemato lo swap i tempi sono tornati quelli di prima
Con o senza religione, i buoni si comportano bene e i cattivi male, ma ci vuole la religione per far comportare male i buoni.
(Steven Weinberg)
caturen
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 16960
Iscrizione: giovedì 8 aprile 2010, 18:41
Desktop: diversi
Distribuzione: debian

Re: ubuntu è peggiorato?

Messaggio da caturen »

corradoventu ha scritto:
sabato 4 dicembre 2021, 8:59
A me due giorni fa il tempo di boot era passato da circa 9 secondi a oltre 1 minuto perchè un tentativo di installare ubuntu-canary mi aveva scassato lo swap e avevo il messaggio:
Timed out waiting for device /dev/disk/by-uuid/2fe03a21-7269-4915-a943-740fac832325.
sistemato lo swap i tempi sono tornati quelli di prima
Non ti aveva scassato niente dato che ogni installazione di un sistema va a cambiare la uiid della partizione swap (se la trova) e questa poi deve essere "sistemata" su fstab altrimenti lì rimane il uiid vecchio ed il boot (grazie systemd) va in stallo dato che non trova più la partizione di swap
Avatar utente
woddy68
Rampante Reduce
Rampante Reduce
Messaggi: 7285
Iscrizione: sabato 12 febbraio 2011, 14:23
Desktop: Kde Plasma5
Distribuzione: openSUSE Leap-Tumbleweed-Kubuntu 20
Sesso: Maschile

Re: ubuntu è peggiorato?

Messaggio da woddy68 »

corradoventu ha scritto:
sabato 4 dicembre 2021, 8:59
A me due giorni fa il tempo di boot era passato da circa 9 secondi a oltre 1 minuto perchè un tentativo di installare ubuntu-canary mi aveva scassato lo swap e avevo il messaggio:
Timed out waiting for device /dev/disk/by-uuid/2fe03a21-7269-4915-a943-740fac832325.
sistemato lo swap i tempi sono tornati quelli di prima
Se vuoi la partizione swap condivisa tra sistemi, quando installi il secondo sistema devi mettere solo il flag e non formattarla, altrimenti cambierà uiid e avrai problemi sull'altro sistema, tra l'altro è inutile formattarla se è già una partizione swap.
Desktop - Acer Aspire M5500 (AMD) - Notebook Acer Aspire E1 -522 (Amd)
-Ho sempre accettato caramelle dagli sconosciuti-
Ecco cosa succede quando...https://www.youtube.com/watch?v=iigtsYY ... ni7HzinVf8
caturen
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 16960
Iscrizione: giovedì 8 aprile 2010, 18:41
Desktop: diversi
Distribuzione: debian

Re: ubuntu è peggiorato?

Messaggio da caturen »

Se vuoi la partizione swap condivisa tra sistemi, quando installi il secondo sistema devi mettere solo il flag e non formattarla, .
questo dipende dal installer della distribuzioine: alcuni non danno questa possibilità e te la formattano di default.
Avatar utente
corradoventu
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 2871
Iscrizione: domenica 27 aprile 2008, 22:23
Desktop: GNOME
Distribuzione: Ubuntu 18.04, 20.04, 21.04, 21.10
Sesso: Maschile
Località: Rezzoaglio (GE)
Contatti:

Re: ubuntu è peggiorato?

Messaggio da corradoventu »

caturen ha scritto:
sabato 4 dicembre 2021, 14:18
Se vuoi la partizione swap condivisa tra sistemi, quando installi il secondo sistema devi mettere solo il flag e non formattarla, .
questo dipende dal installer della distribuzioine: alcuni non danno questa possibilità e te la formattano di default.
Lo so, da sempre sui miei PC ci sono almeno 4 diversi Ubuntu in altrettante partizioni con swap condiviso, ma il nuovo installer di canary ancora funziona male.
... mi dirai 'e cosa ti aspetti? è uno snap!

Comunque avevo notato il problema per chi ha osservato un improvviso GRANDE aumento dei tempi di boot e proponevo un controllo da fare, io ho osservato l'aumento e ci ho messo un pò a capirne la causa.
Con o senza religione, i buoni si comportano bene e i cattivi male, ma ci vuole la religione per far comportare male i buoni.
(Steven Weinberg)
caturen
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 16960
Iscrizione: giovedì 8 aprile 2010, 18:41
Desktop: diversi
Distribuzione: debian

Re: ubuntu è peggiorato?

Messaggio da caturen »

io ho osservato l'aumento e ci ho messo un pò a capirne la causa
perchè ubuntu ha plymouth che impedisce di vedere i messaggi del boot, altrimenti avresti visto subito il messaggio
.. mi dirai 'e cosa ti aspetti? è uno snap!
se continui ad usare ciofeghe devi prendertela con te stesso e non con l'installer
Scrivi risposta

Ritorna a “Bar Ubuntu”

Chi c’è in linea

Visualizzano questa sezione: Darren, pomata e 11 ospiti