[Progetto] Varechina - Il BleachBit de no'antri!

Iniziative e progetti della comunità legati a Ubuntu.
Regole della sezione
Questa sezione ha lo scopo di raccogliere le iniziative/progetti della nostra Comunità legati ad Ubuntu. I progetti ospitati nascono da iniziative degli utenti o gruppi di utenti. In futuro i progetti potrebbero rimanere iniziative "personali" o essere integrate nella distribuzione, sponsorizzate da Ubuntu o da Canonical a discrezione dei responsabili. All'interno di essa sarà possibile inserire delle discussioni che hanno la funzione di pubblicizzare avvenimenti, iniziative e progetti software su Ubuntu e GNU/Linux in generale. Sarà inoltre possibile per gli utenti proporre lo sviluppo di nuovi software e in questo caso la discussione di richiesta avrà la funzione di generare un requisito funzionale del prodotto da sviluppare.

Sezione I - Iniziative
  • Fanno parte di iniziative, ad esempio, le seguenti categorie: corsi, progetti editoriali, libri.
  • La segnalazione di un'iniziativa avviene creando una discussione con l'annuncio.
  • Una volta effettuata la segnalazione, la discussione viene chiusa dal Gruppo Forum.
  • Se l'iniziativa esposta comporta un costo di adesione o fruizione, questo deve essere esplicitamente riportato all'interno della discussione.
  • È obbligatorio segnalare all'interno della discussione i riferimenti per poter contattare/partecipare all'iniziativa.
Sezione II - Progetti
  • La segnalazione di un progetto software, come per le iniziative, avviene e si sviluppa all'interno di una singola discussione.
  • Sarà consentito l'inserimento di software solo se rilasciati sotto licenza GPL (in tutte le sue versioni) o equivalente FOSS, tale da garantire agli utenti l'utilizzo del prodotto senza restrizioni e agli sviluppatori la proprietà intellettuale del codice prodotto.
  • Nell'oggetto della discussione dovrà essere riportata la categoria (es. [Iniziativa], [Progetto] o [Proposta]) e una semplice descrizione del progetto.
  • Se il progetto ha già un sito che lo ospita sarà a discrezione del Gruppo Forum chiuderla come segnalazione o lasciarla aperta.
  • Se il progetto non ha un sito che lo ospita si potranno aprire due discussioni, una per proporre modifiche/implementazioni (dove nel titolo occorre specificare [sviluppo]) ed una per segnalare problemi (e nel titolo dovrà comparire [supporto]).
  • Non è consentita l'apertura di nuove discussioni in riferimento a versioni superiori o modificate di un prodotto già riportato in precedenza.
  • Se il software oggetto del progetto ha una dimensione non superiore ai 128 kB, per prodotti che non hanno un sito che li ospita, sarà possibile allegarlo alla discussione.
Sezione III - Proposte
  • Una proposta deve essere eseguita e si svilupperà all'interno di una singola discussione.
  • Le proposte dovranno essere inserite direttamente nella sezione "Progetti della Comunità".
  • Dovranno essere specificate le funzionalità che devono essere sviluppate.
  • Non dovranno essere riportate diciture tipo "...deve fare come questo software...", ma indicare nel miglior modo possibile i requisiti.
  • Una volta segnalata la discussione resterà aperta per consentire uno scambio di idee su come sviluppare il codice o finché gli sviluppatori non forniranno una soluzione (da pubblicizzare poi, come visto prima, nella sezione Progetti) che ne soddisfi il requisito.
Per quanto non esposto sopra, si fa comunque riferimento al Regolamento del forum ed al Codice di Condotta della Comunità.
Avatar utente
UbuNuovo
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 4428
Iscrizione: sabato 12 dicembre 2009, 20:58
Desktop: Mate
Distribuzione: Ubuntu Mate 22.04.1 LTS
Sesso: Maschile
Contatti:

Re: [Progetto] Nuovo script per la manutenzione di Ubuntu

Messaggio da UbuNuovo »

Ora funge tutto
@GjMan78 dovresti aggiornare il messaggio:
Eseguilo così: sudo ./manutenzione.sh
Aggiungendo la -E
Ultima modifica di UbuNuovo il lunedì 4 dicembre 2023, 20:55, modificato 1 volta in totale.
Salva l'Ucraina! 🇺🇦
Avatar utente
GjMan78
Rampante Reduce
Rampante Reduce
Messaggi: 5031
Iscrizione: mercoledì 22 novembre 2006, 19:15
Desktop: KdePlasma
Distribuzione: EndeavourOS
Sesso: Maschile
Località: ~/Italia/Lazio/Viterbo/

Re: [Progetto] Nuovo script per la manutenzione di Ubuntu

Messaggio da GjMan78 »

UbuNuovo ha scritto:
lunedì 4 dicembre 2023, 20:50
Ora funge tutto
Ottimo. Grazie mille per il debug!
UbuNuovo ha scritto:
lunedì 4 dicembre 2023, 20:50
@GjMan78 dovresti aggiornare il messaggio:
Eseguilo così: sudo ./manutenzione.sh
Aggiungendo la -E
Fatto, grazie ancora :D
MacBook Pro - Intel i5-3210 - 16 Gbyte Ram DDR3 - SSD 500 Gbyte x 2
»»» 𝗙𝗮𝗶 𝗶𝗹 𝗕𝗮𝗰𝗸𝘂𝗽! ¯\_(ツ)_/¯
Avatar utente
GjMan78
Rampante Reduce
Rampante Reduce
Messaggi: 5031
Iscrizione: mercoledì 22 novembre 2006, 19:15
Desktop: KdePlasma
Distribuzione: EndeavourOS
Sesso: Maschile
Località: ~/Italia/Lazio/Viterbo/

Re: [Progetto] Varechina - Il BleachBit de no'antri!

Messaggio da GjMan78 »

Creato l'installer .deb.

Ora lo script dovrebbe poter essere eseguito con un semplice click nel menu.

Fatemi sapere se incontrate problemi...
MacBook Pro - Intel i5-3210 - 16 Gbyte Ram DDR3 - SSD 500 Gbyte x 2
»»» 𝗙𝗮𝗶 𝗶𝗹 𝗕𝗮𝗰𝗸𝘂𝗽! ¯\_(ツ)_/¯
Avatar utente
UbuNuovo
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 4428
Iscrizione: sabato 12 dicembre 2009, 20:58
Desktop: Mate
Distribuzione: Ubuntu Mate 22.04.1 LTS
Sesso: Maschile
Contatti:

Re: [Progetto] Varechina - Il BleachBit de no'antri!

Messaggio da UbuNuovo »

Per me tutto regolare, sia per quanto riguarda installazione che funzionamento :birra:
Salva l'Ucraina! 🇺🇦
Avatar utente
GjMan78
Rampante Reduce
Rampante Reduce
Messaggi: 5031
Iscrizione: mercoledì 22 novembre 2006, 19:15
Desktop: KdePlasma
Distribuzione: EndeavourOS
Sesso: Maschile
Località: ~/Italia/Lazio/Viterbo/

Re: [Progetto] Varechina - Il BleachBit de no'antri!

Messaggio da GjMan78 »

UbuNuovo ha scritto:
martedì 5 dicembre 2023, 11:02
Per me tutto regolare, sia per quanto riguarda installazione che funzionamento :birra:
Benissimo, grazie del feedback!
MacBook Pro - Intel i5-3210 - 16 Gbyte Ram DDR3 - SSD 500 Gbyte x 2
»»» 𝗙𝗮𝗶 𝗶𝗹 𝗕𝗮𝗰𝗸𝘂𝗽! ¯\_(ツ)_/¯
Avatar utente
UbuNuovo
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 4428
Iscrizione: sabato 12 dicembre 2009, 20:58
Desktop: Mate
Distribuzione: Ubuntu Mate 22.04.1 LTS
Sesso: Maschile
Contatti:

Re: [Progetto] Varechina - Il BleachBit de no'antri!

Messaggio da UbuNuovo »

di nulla :ciao:
Salva l'Ucraina! 🇺🇦
rai
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 2823
Iscrizione: domenica 11 maggio 2008, 18:03
Desktop: plasma
Distribuzione: 22.04
Località: Palermo

Re: [Progetto] Varechina - Il BleachBit de no'antri!

Messaggio da rai »

Ehilà, ma qui si avanza a grandi passi! :)

Ho avuto qualche difficoltà con il deb precedente (veniva considerato malformato) ma ora si installa bene. Carina l'icona!


Segnalo qualche aggiustamento da fare
Se firefox è già aperto, "Apri il forum" ottiene che si apre una finestra di errore dal titolo Close firefox che recita:
"Firefox is already running, but is not responding. To use Firefox, you must first close the existing Firefox process, restart your device, or use a different profile."
Se firefox è chiuso la funzione apre regolarmente una scheda sull'indice del forum. Mi dispiace, non ho avuto il tempo di risolvere la questione.
Le altre due funzioni per forum funzionano bene in particolare con il copia e incolla


Bisogna reindirizzare lo stderr di tutti i comandi di aggiornamento/pulizia per potere vedere gli eventuali errori sul log. Cioè bisogna mettere il 2>&1 prima della pipe. In questo momento invece il 2>&1 reindirizza gli errori del tee che a noi interessano solo fino a un certo punto :-D
Le funzioni di aggiornamento e di manuntenzione peraltro funzionano bene e hanno il loro log regolare e regolarmente leggibile

Suggerimento:
per semplificare durante il debug la ricerca della sezione interessante, potrebbe essere utile all'inizio del file un elenco alfabetico dei nomi delle funzioni del tipo:

Codice: Seleziona tutto

:<<FUNZIONI
funzione_A
funzione_B
...
FUNZIONI
:birra:
Avatar utente
GjMan78
Rampante Reduce
Rampante Reduce
Messaggi: 5031
Iscrizione: mercoledì 22 novembre 2006, 19:15
Desktop: KdePlasma
Distribuzione: EndeavourOS
Sesso: Maschile
Località: ~/Italia/Lazio/Viterbo/

Re: [Progetto] Varechina - Il BleachBit de no'antri!

Messaggio da GjMan78 »

rai ha scritto:
mercoledì 6 dicembre 2023, 9:48
Ehilà, ma qui si avanza a grandi passi! :)
Mica siamo qua a pettinare i dinosauri!!
rai ha scritto:
mercoledì 6 dicembre 2023, 9:48
Ho avuto qualche difficoltà con il deb precedente (veniva considerato malformato) ma ora si installa bene. Carina l'icona!
Lo avevo notato anche io, ma non era il deb in se ad essere malformato.
Installandolo da locale funzionava benissimo, una volta caricato ed eseguito il download con wget dava errore.
Alla fine ho risolto caricando il deb nella sezione release di github.
rai ha scritto:
mercoledì 6 dicembre 2023, 9:48
Segnalo qualche aggiustamento da fare
Se firefox è già aperto, "Apri il forum" ottiene che si apre una finestra di errore dal titolo Close firefox che recita:
"Firefox is already running, but is not responding. To use Firefox, you must first close the existing Firefox process, restart your device, or use a different profile."
Se firefox è chiuso la funzione apre regolarmente una scheda sull'indice del forum. Mi dispiace, non ho avuto il tempo di risolvere la questione.
Le altre due funzioni per forum funzionano bene in particolare con il copia e incolla
Strano comportamento.
Utilizzando gio open dovrebbe automaticamente aprire una nuova scheda se il browser predefinito è già aperto.
Indagherò, grazie per la segnalazione.
rai ha scritto:
mercoledì 6 dicembre 2023, 9:48
Bisogna reindirizzare lo stderr di tutti i comandi di aggiornamento/pulizia per potere vedere gli eventuali errori sul log. Cioè bisogna mettere il 2>&1 prima della pipe. In questo momento invece il 2>&1 reindirizza gli errori del tee che a noi interessano solo fino a un certo punto :-D
Le funzioni di aggiornamento e di manuntenzione peraltro funzionano bene e hanno il loro log regolare e regolarmente leggibile
Ops, errore di distrazione :p
Arigrazie!
rai ha scritto:
mercoledì 6 dicembre 2023, 9:48
Suggerimento:
per semplificare durante il debug la ricerca della sezione interessante, potrebbe essere utile all'inizio del file un elenco alfabetico dei nomi delle funzioni del tipo:

Codice: Seleziona tutto

:<<FUNZIONI
funzione_A
funzione_B
...
FUNZIONI
:birra:
Utilissimo. Provvedo insieme al resto.

Intanto io stavo pensando, visto che siamo arrivati ad una versione abbastanza stabile, a come sostituire dialog.

Per evitare di complicare troppo il codice stavo ragionando se non sia il caso di utilizzare esclusivamente zenity invece dell'accoppiata zenity + kdialog.

Ho visto che installare zenity su un sistema QT based è semplice e non si porta dietro troppe dipendenze, solo zenity-common.

Ho provato a fare il contrario installando kdialog su un sistema gnome ma il risultato è pessimo

Codice: Seleziona tutto

sudo apt install kdialog
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze... Fatto
Lettura informazioni sullo stato... Fatto   
I seguenti pacchetti aggiuntivi saranno inoltre installati:
  gamin kded5 kio kwayland-data kwayland-integration libdbusmenu-qt5-2
  libgamin0 libgpgmepp6 libhfstospell11 libkf5archive-data libkf5archive5
  libkf5auth-data libkf5authcore5 libkf5codecs-data libkf5codecs5
  libkf5completion-data libkf5completion5 libkf5config-bin libkf5config-data
  libkf5configcore5 libkf5configgui5 libkf5configwidgets-data
  libkf5configwidgets5 libkf5coreaddons-data libkf5coreaddons5 libkf5crash5
  libkf5dbusaddons-bin libkf5dbusaddons-data libkf5dbusaddons5 libkf5doctools5
  libkf5guiaddons-bin libkf5guiaddons-data libkf5guiaddons5 libkf5i18n-data
  libkf5i18n5 libkf5iconthemes-bin libkf5iconthemes-data libkf5iconthemes5
  libkf5itemviews-data libkf5itemviews5 libkf5jobwidgets-data
  libkf5jobwidgets5 libkf5kiocore5 libkf5kiogui5 libkf5kiontlm5
  libkf5kiowidgets5 libkf5notifications-data libkf5notifications5
  libkf5service-bin libkf5service-data libkf5service5 libkf5solid5
  libkf5solid5-data libkf5sonnet5-data libkf5sonnetcore5 libkf5sonnetui5
  libkf5textwidgets-data libkf5textwidgets5 libkf5wallet-bin libkf5wallet-data
  libkf5wallet5 libkf5waylandclient5 libkf5widgetsaddons-data
  libkf5widgetsaddons5 libkf5windowsystem-data libkf5windowsystem5
  libkwalletbackend5-5 libpolkit-qt5-1-1 libqca-qt5-2 libqca-qt5-2-plugins
  libqt5texttospeech5 libqt5x11extras5 libvoikko1 media-player-info
  qtspeech5-speechd-plugin sonnet-plugins
Che ne pensi? Utilizzare soltanto zenity potrebbe essere un buon compromesso secondo te oppure ha degli svantaggi che mi stanno sfuggendo?

:ciao:
MacBook Pro - Intel i5-3210 - 16 Gbyte Ram DDR3 - SSD 500 Gbyte x 2
»»» 𝗙𝗮𝗶 𝗶𝗹 𝗕𝗮𝗰𝗸𝘂𝗽! ¯\_(ツ)_/¯
rai
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 2823
Iscrizione: domenica 11 maggio 2008, 18:03
Desktop: plasma
Distribuzione: 22.04
Località: Palermo

Re: [Progetto] Varechina - Il BleachBit de no'antri!

Messaggio da rai »

Che ne pensi? Utilizzare soltanto zenity potrebbe essere un buon compromesso secondo te oppure ha degli svantaggi che mi stanno sfuggendo?
installo zenity in una KDE virtualizzata e ti so dire.
Avatar utente
GjMan78
Rampante Reduce
Rampante Reduce
Messaggi: 5031
Iscrizione: mercoledì 22 novembre 2006, 19:15
Desktop: KdePlasma
Distribuzione: EndeavourOS
Sesso: Maschile
Località: ~/Italia/Lazio/Viterbo/

Re: [Progetto] Varechina - Il BleachBit de no'antri!

Messaggio da GjMan78 »

Intanto rispondendo a questa discussione viewtopic.php?f=30&t=654352&p=5352061#p5352061 ho capito che devo implementare un ulteriore controllo per la diagnostica degli aggiornamenti.

il forum permette post di lunghezza massima di 20000 caratteri.

Se il log eccede questa dimensione stavo pensando di caricarlo su pastebin.com e copiare negli appunti il link accompagnato da una frase tipo "Il risultato eccede la dimensione massima consentita ed è stato caricato qui: https:/pastebin.com/blablabla"
MacBook Pro - Intel i5-3210 - 16 Gbyte Ram DDR3 - SSD 500 Gbyte x 2
»»» 𝗙𝗮𝗶 𝗶𝗹 𝗕𝗮𝗰𝗸𝘂𝗽! ¯\_(ツ)_/¯
Avatar utente
tokijin
Moderatore Globale
Moderatore Globale
Messaggi: 4603
Iscrizione: mercoledì 3 giugno 2009, 23:10
Desktop: plasma 5.27.4
Distribuzione: Kubuntu 23.04
Località: Abruzzo

Re: [Progetto] Varechina - Il BleachBit de no'antri!

Messaggio da tokijin »

GjMan78 ha scritto:
mercoledì 6 dicembre 2023, 11:55
[...]

Ho visto che installare zenity su un sistema QT based è semplice e non si porta dietro troppe dipendenze, solo zenity-common.

Ho provato a fare il contrario installando kdialog su un sistema gnome ma il risultato è pessimo

Codice: Seleziona tutto

sudo apt install kdialog
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze... Fatto
Lettura informazioni sullo stato... Fatto   
I seguenti pacchetti aggiuntivi saranno inoltre installati:
  gamin kded5 kio kwayland-data kwayland-integration libdbusmenu-qt5-2
  libgamin0 libgpgmepp6 libhfstospell11 libkf5archive-data libkf5archive5
  libkf5auth-data libkf5authcore5 libkf5codecs-data libkf5codecs5
  libkf5completion-data libkf5completion5 libkf5config-bin libkf5config-data
  libkf5configcore5 libkf5configgui5 libkf5configwidgets-data
  libkf5configwidgets5 libkf5coreaddons-data libkf5coreaddons5 libkf5crash5
  libkf5dbusaddons-bin libkf5dbusaddons-data libkf5dbusaddons5 libkf5doctools5
  libkf5guiaddons-bin libkf5guiaddons-data libkf5guiaddons5 libkf5i18n-data
  libkf5i18n5 libkf5iconthemes-bin libkf5iconthemes-data libkf5iconthemes5
  libkf5itemviews-data libkf5itemviews5 libkf5jobwidgets-data
  libkf5jobwidgets5 libkf5kiocore5 libkf5kiogui5 libkf5kiontlm5
  libkf5kiowidgets5 libkf5notifications-data libkf5notifications5
  libkf5service-bin libkf5service-data libkf5service5 libkf5solid5
  libkf5solid5-data libkf5sonnet5-data libkf5sonnetcore5 libkf5sonnetui5
  libkf5textwidgets-data libkf5textwidgets5 libkf5wallet-bin libkf5wallet-data
  libkf5wallet5 libkf5waylandclient5 libkf5widgetsaddons-data
  libkf5widgetsaddons5 libkf5windowsystem-data libkf5windowsystem5
  libkwalletbackend5-5 libpolkit-qt5-1-1 libqca-qt5-2 libqca-qt5-2-plugins
  libqt5texttospeech5 libqt5x11extras5 libvoikko1 media-player-info
  qtspeech5-speechd-plugin sonnet-plugins
Che ne pensi? Utilizzare soltanto zenity potrebbe essere un buon compromesso secondo te oppure ha degli svantaggi che mi stanno sfuggendo?

:ciao:
Non ho una ubuntu sotto mano, ma potresti provare con l'opzione --no-install-recommends e vedere se si snellisce

Codice: Seleziona tutto

sudo apt install --no-install-recommends zenity
Sei abbruzzese se dopo che ti sei strafogato un chilogrammo di pasta, hai il coraggio di dire alla cuoca "cacc ch'è cott" - Se entra un piccione in casa..chiudi le finestre!
Ubuntu User #28657 - Il mio vecchio hardware - Tag Codice
Avatar utente
GjMan78
Rampante Reduce
Rampante Reduce
Messaggi: 5031
Iscrizione: mercoledì 22 novembre 2006, 19:15
Desktop: KdePlasma
Distribuzione: EndeavourOS
Sesso: Maschile
Località: ~/Italia/Lazio/Viterbo/

Re: [Progetto] Varechina - Il BleachBit de no'antri!

Messaggio da GjMan78 »

tokijin ha scritto:
mercoledì 6 dicembre 2023, 15:05
Non ho una ubuntu sotto mano, ma potresti provare con l'opzione --no-install-recommends e vedere se si snellisce
Ottimo suggerimento ma purtroppo il risultato non cambia molto, 65 pacchetti da installare invece di 77.

Codice: Seleziona tutto

sudo apt install --no-install-recommends kdialog
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze... Fatto
Lettura informazioni sullo stato... Fatto   
I seguenti pacchetti aggiuntivi saranno inoltre installati:
  gamin kded5 kio libdbusmenu-qt5-2 libgamin0 libgpgmepp6 libkf5archive-data libkf5archive5 libkf5auth-data libkf5authcore5
  libkf5codecs-data libkf5codecs5 libkf5completion-data libkf5completion5 libkf5config-data libkf5configcore5
  libkf5configgui5 libkf5configwidgets-data libkf5configwidgets5 libkf5coreaddons-data libkf5coreaddons5 libkf5crash5
  libkf5dbusaddons-data libkf5dbusaddons5 libkf5doctools5 libkf5guiaddons-bin libkf5guiaddons-data libkf5guiaddons5
  libkf5i18n-data libkf5i18n5 libkf5iconthemes-data libkf5iconthemes5 libkf5itemviews-data libkf5itemviews5
  libkf5jobwidgets-data libkf5jobwidgets5 libkf5kiocore5 libkf5kiogui5 libkf5kiontlm5 libkf5kiowidgets5
  libkf5notifications-data libkf5notifications5 libkf5service-bin libkf5service-data libkf5service5 libkf5solid5
  libkf5solid5-data libkf5sonnet5-data libkf5sonnetcore5 libkf5sonnetui5 libkf5textwidgets-data libkf5textwidgets5
  libkf5wallet-bin libkf5wallet-data libkf5wallet5 libkf5widgetsaddons-data libkf5widgetsaddons5 libkf5windowsystem-data
  libkf5windowsystem5 libkwalletbackend5-5 libpolkit-qt5-1-1 libqca-qt5-2 libqt5texttospeech5 libqt5x11extras5
Pacchetti raccomandati:
  libkf5config-bin libkf5dbusaddons-bin libkf5iconthemes-bin media-player-info sonnet-plugins kwayland-integration
  libqca-qt5-2-plugins qtspeech5-speechd-plugin | qtspeech5-flite-plugin
I seguenti pacchetti NUOVI saranno installati:
  gamin kded5 kdialog kio libdbusmenu-qt5-2 libgamin0 libgpgmepp6 libkf5archive-data libkf5archive5 libkf5auth-data
  libkf5authcore5 libkf5codecs-data libkf5codecs5 libkf5completion-data libkf5completion5 libkf5config-data
  libkf5configcore5 libkf5configgui5 libkf5configwidgets-data libkf5configwidgets5 libkf5coreaddons-data libkf5coreaddons5
  libkf5crash5 libkf5dbusaddons-data libkf5dbusaddons5 libkf5doctools5 libkf5guiaddons-bin libkf5guiaddons-data
  libkf5guiaddons5 libkf5i18n-data libkf5i18n5 libkf5iconthemes-data libkf5iconthemes5 libkf5itemviews-data libkf5itemviews5
  libkf5jobwidgets-data libkf5jobwidgets5 libkf5kiocore5 libkf5kiogui5 libkf5kiontlm5 libkf5kiowidgets5
  libkf5notifications-data libkf5notifications5 libkf5service-bin libkf5service-data libkf5service5 libkf5solid5
  libkf5solid5-data libkf5sonnet5-data libkf5sonnetcore5 libkf5sonnetui5 libkf5textwidgets-data libkf5textwidgets5
  libkf5wallet-bin libkf5wallet-data libkf5wallet5 libkf5widgetsaddons-data libkf5widgetsaddons5 libkf5windowsystem-data
  libkf5windowsystem5 libkwalletbackend5-5 libpolkit-qt5-1-1 libqca-qt5-2 libqt5texttospeech5 libqt5x11extras5
0 aggiornati, 65 installati, 0 da rimuovere e 9 non aggiornati.
È necessario scaricare 12,5 MB di archivi.
Dopo quest'operazione, verranno occupati 74,1 MB di spazio su disco.
Continuare? [S/n] 
Se non ci sono controindicazioni resto dell'idea di usare zenity per tutti i DE.
MacBook Pro - Intel i5-3210 - 16 Gbyte Ram DDR3 - SSD 500 Gbyte x 2
»»» 𝗙𝗮𝗶 𝗶𝗹 𝗕𝗮𝗰𝗸𝘂𝗽! ¯\_(ツ)_/¯
Avatar utente
UbuNuovo
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 4428
Iscrizione: sabato 12 dicembre 2009, 20:58
Desktop: Mate
Distribuzione: Ubuntu Mate 22.04.1 LTS
Sesso: Maschile
Contatti:

Re: [Progetto] Varechina - Il BleachBit de no'antri!

Messaggio da UbuNuovo »

Io non ho avuto problemi con il primo deb, forse perché fino ad ora ho sempre scaricato il file master, con uno scriptino.

Codice: Seleziona tutto

[ -d 'PuliziaUbuntu-master' ] && rm -r PuliziaUbuntu-master
[ -f 'master.zip' ] && rm master.zip
wget https://github.com/GjMan78/PuliziaUbuntu/archive/refs/heads/master.zip && unzip master.zip || echo 'Qualcosa è andato storto nello scaricamento'
ma ora il deb non c'è più!
Da ora userò:

Codice: Seleziona tutto

wget https://github.com/GjMan78/Varechina/releases/download/v0.9/Varechina_0.9_amd64.deb
Non credo che ti serva, ma visto che guardi zenity, guarda anche yad che ne è un'evoluzione.
Ciaux
Salva l'Ucraina! 🇺🇦
rai
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 2823
Iscrizione: domenica 11 maggio 2008, 18:03
Desktop: plasma
Distribuzione: 22.04
Località: Palermo

Re: [Progetto] Varechina - Il BleachBit de no'antri!

Messaggio da rai »

Codice: Seleziona tutto

raivb@VirtualBox:~$ sudo apt install zenity
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze... Fatto
Lettura informazioni sullo stato... Fatto    
I seguenti pacchetti aggiuntivi saranno inoltre installati:
 enchant-2 libatomic1 libenchant-2-2 libharfbuzz-icu0 libjavascriptcoregtk-4.0-18 libmanette-0.2-0
 libwebkit2gtk-4.0-37 libwpe-1.0-1 libwpebackend-fdo-1.0-1 xdg-dbus-proxy zenity-common
Pacchetti suggeriti:
 libenchant-2-voikko gstreamer1.0-libav gstreamer1.0-plugins-bad gstreamer1.0-alsa
I seguenti pacchetti NUOVI saranno installati:
 enchant-2 libatomic1 libenchant-2-2 libharfbuzz-icu0 libjavascriptcoregtk-4.0-18 libmanette-0.2-0
 libwebkit2gtk-4.0-37 libwpe-1.0-1 libwpebackend-fdo-1.0-1 xdg-dbus-proxy zenity zenity-common
0 aggiornati, 12 installati, 0 da rimuovere e 0 non aggiornati.
È necessario scaricare 30,3 MB di archivi.
Dopo quest'operazione, verranno occupati 108 MB di spazio su disco.
Continuare? [S/n] 
Non lo so. Con i dischi di oggi 100 MB non sono gran cosa ma in assoluto è qualcosa per un dialogo che l'utente non userà per altre cose.
Dato che comunque per posare dialog il codice per zenity servirebbe, ti direi di farla una versione solo-zenity così la proviamo nei fatti su kde.
Poi si decide in base al risultato estetico/funzionale
Avatar utente
GjMan78
Rampante Reduce
Rampante Reduce
Messaggi: 5031
Iscrizione: mercoledì 22 novembre 2006, 19:15
Desktop: KdePlasma
Distribuzione: EndeavourOS
Sesso: Maschile
Località: ~/Italia/Lazio/Viterbo/

Re: [Progetto] Varechina - Il BleachBit de no'antri!

Messaggio da GjMan78 »

@UbuNuovo
a Yad ci avevo già pensato perché viene largamente usato negli script proprietari di EndeavourOS tipo questo

Immagine

Però la sintassi mi è sembrata un po' complessa e questo mi ha fatto desistere. Lo guarderò meglio...

@rai
Io avevo provato avviando una iso di kubuntu 23.10 in live, ho installato zenity e mi ha installato soltanto zenity-common come dipendenza...

Ad ogni modo farò coma hai proposto, ho già creato il ramo unstable su github in cui pensavo di metterci il codice con la nuova grafica.

Devo solo decidere se usare zenity o yad, a questo punto.
MacBook Pro - Intel i5-3210 - 16 Gbyte Ram DDR3 - SSD 500 Gbyte x 2
»»» 𝗙𝗮𝗶 𝗶𝗹 𝗕𝗮𝗰𝗸𝘂𝗽! ¯\_(ツ)_/¯
Avatar utente
neolinux
Rampante Reduce
Rampante Reduce
Messaggi: 5700
Iscrizione: giovedì 11 dicembre 2008, 21:52
Contatti:

Re: [Progetto] Varechina - Il BleachBit de no'antri!

Messaggio da neolinux »

Con la pulizia automatica tradizionale adesso che c'è app image, ci sono programmi app image che vorrebbero dei pacchetti, tu magari li installi, poi il sistema non li giudica utilizzati e li rimuove, tu poi li rimetti, una tela di Penelope infinita.... tipo il caso di libfuse2 fuori uso per Ubuntu perché c'è il libfuse3, ma per più app image invece vogliono il libfuse2, scommetto che ci saranno molti altri casi simili.
Non so se questo progetto possa occuparsi di questa cosa che è alquanto seccante, penso che capite bene perché.
Scrivi risposta

Ritorna a “Progetti della Comunità”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 1 ospite