Pagina 2 di 9

Re: Script per applicare semplicemente il tag [Risolto]

Inviato: domenica 10 febbraio 2013, 20:30
da Zoff
matti 007 » [url=http://forum.ubuntu-it.org/viewtopic.php?p=4318428#p4318428]oggi, 18:38[/url] ha scritto: In che senso i passaggi? Vado nella discussione clicco su applica risolto e poi vedo che ha messo risolto nell'ultimo intrevento della quarta pagina.
Vorrei che prendessi uno screenshot dell'intera pagina della discussione (eventualmente fai piu' screenshot) appena aperta, uno screen della pagina "nera" che mostra l'avvisto e un altro screenshot della pagina intera DOPO che è stato inserito il [Risolto].
Grazie.

Re: Script per applicare semplicemente il tag [Risolto]

Inviato: domenica 10 febbraio 2013, 20:50
da Zoff
Zoff » [url=http://forum.ubuntu-it.org/viewtopic.php?p=4318549#p4318549]20 minuti fa[/url] ha scritto:
pietro98-albini » [url=http://forum.ubuntu-it.org/viewtopic.php?p=4318261#p4318261]oggi, 15:27[/url] ha scritto:Quando clicchi sul link presente nelle notifiche e non hai effettuato l'accesso appare il pulsante anche nel box di accesso.
Grazie della segnalazione, lo aggiungo alla TODOlist
Non sono riuscito a replicare il problema, potresti spiegarti meglio?
Quello che ho fatto io è stato:
1) Logout dal forum
2) Click del link in una delle email di notifica
3) Visualizzazione della schermata di accesso senza pulsante.

Anche perché lo script lavora solo sulla pagina viewtopic.php quindi non è possibile che appaia nella schermata di accesso.

Re: Script per applicare semplicemente il tag [Risolto]

Inviato: lunedì 11 febbraio 2013, 10:33
da Zoff
Nuovo fix:
Ora lo script è in grado di riconoscere la discussione anche se non è presente l'attributo t=XXXXXX nell'url della pagina.

Re: Script per applicare semplicemente il tag [Risolto]

Inviato: giovedì 21 febbraio 2013, 13:51
da magic89
Ciao Zoff,
ho provato lo script su questa discussione: http://forum.ubuntu-it.org/viewtopic.php?f=28&t=545483

Parte la schermata nera che dice di aspettare 2 secondi, ma stà in hang li e non succede niente. Attesa massima 5 minuti, poi scazzo e refresh, titolo invariato.

Re: Script per applicare semplicemente il tag [Risolto]

Inviato: giovedì 21 febbraio 2013, 13:58
da Zoff
Hai perfettamente ragione, c'era un errore.
Ora dovrei aver risolto. Aggiorna lo script.

Re: Script per applicare semplicemente il tag [Risolto]

Inviato: giovedì 21 febbraio 2013, 14:03
da magic89
Ottimo! Ho inoltre piacevolmente notato che una volta inserito il tag, il pulsante non compare. Molto molto complimenti!!

La lista di problemi noti all'inizio della discussione è aggiornata?
Che cerco di replicare anche quelli.

Re: Script per applicare semplicemente il tag [Risolto]

Inviato: giovedì 21 febbraio 2013, 14:07
da Zoff
Sì è aggiornata ma l'ultimo (quello di noscript) non è risolvibile, e gli altri non sono stato in grado di replicarli.

Re: Script per applicare semplicemente il tag [Risolto]

Inviato: giovedì 21 febbraio 2013, 14:24
da magic89
- Il pulsante appare quando l'utente non è loggato
A me non compare. Testato su una discussione aperta da me, datata (non ha formati di date strani).
Logout: non vedo il pulsante
Login: vedo il pulsante


Ti segnalo inoltre un piccolo hang (non so se causato dal mio pc o da un effettiva "pesantezza" dello script) quando ha caricato tutta la pagina, e deve ancora visualizzare il tasto dello script, solo per le pagine per cui lo deve visualizzare, c'è un blocco di 2-3 secondi in cui non succede niente.

Re: Script per applicare semplicemente il tag [Risolto]

Inviato: giovedì 21 febbraio 2013, 14:28
da Zoff
Lo script deve fare diverse richieste per ottenere tutte le informazioni e al momento le fa in maniera sincrona generando quel ritardo.
Nella TODOlist è prevista una riscrittura per il funzionamento asincrono appena ho un po' di tempo.

Re: Script per applicare semplicemente il tag [Risolto]

Inviato: giovedì 21 febbraio 2013, 14:53
da matti 007
Zoff » [url=http://forum.ubuntu-it.org/viewtopic.php?p=4318555#p4318555]domenica 10 febbraio 2013, 20:30[/url] ha scritto:
matti 007 » [url=http://forum.ubuntu-it.org/viewtopic.php?p=4318428#p4318428]oggi, 18:38[/url] ha scritto: In che senso i passaggi? Vado nella discussione clicco su applica risolto e poi vedo che ha messo risolto nell'ultimo intrevento della quarta pagina.
Vorrei che prendessi uno screenshot dell'intera pagina della discussione (eventualmente fai piu' screenshot) appena aperta, uno screen della pagina "nera" che mostra l'avvisto e un altro screenshot della pagina intera DOPO che è stato inserito il [Risolto].
Grazie.
Ciao scusa il ritardo ma la discussione ha quattro pagine di default il link porta nella quarta. Vuoi lo screen di quella o di tutte e quattro?

PS ho aggiornato lo script ma fa sempre così.

Re: Script per applicare semplicemente il tag [Risolto]

Inviato: giovedì 21 febbraio 2013, 15:01
da Zoff
matti 007 » [url=http://forum.ubuntu-it.org/viewtopic.php?p=4328539#p4328539]7 minuti fa[/url] ha scritto: Ciao scusa il ritardo ma la discussione ha quattro pagine di default il link porta nella quarta. Vuoi lo screen di quella o di tutte e quattro?
Va bene anche solo la pagina che visualizzi.

Re: Script per applicare semplicemente il tag [Risolto]

Inviato: giovedì 21 febbraio 2013, 15:47
da magic89
Visualizzazione tasto su discussione "Non Mia":
la discussione in oggetto è: http://forum.ubuntu-it.org/viewtopic.ph ... 9#p4328589

Entro nella discussione, tutto ok. Sono loggato.
Scrivo una risposta veloce, la pubblico, appare il tasto.
Logout: Non vedo più il tasto
Login: Vedo il tasto
Clicco il tasto: Modifica il titolo del mio intervento
Il tasto permane, e se lo riclicco fa append sul titolo del mio intervento ( [Risolto][Risolto]etc...) Non trovando il tag Risolto nel titolo della discussione...

Sembra che sia legato al fatto che è il mio primo intervento su quella discussione.

-edit-

- Append indipendente dal formato della data del mio intervento
- Se posto un nuovo intervento, il bottone resta, e l'append va sul nuovo intervento.
- Se faccio un nuovo intervento su un post già [Risolto], il tasto non viene visualizzato (corretto, presumo!)

-edit2-
La conversazione qui sopra ha data: ieri, ......

Eseguita la stessa procedura qui ( http://forum.ubuntu-it.org/viewtopic.ph ... 7#p4328607 ) con data 12/02,etc... Non vedo il tasto
Forse è si un problema di data. :muro:

La variabile della data ti tira su il "ieri"?!
Sicuro che ne sai più di me, ma non si sa mai! Io faccio un print delle variabili quando faccio i test degli script...

-edit3-
Procedura eseguita su una conversazione con data: oggi,etc.... Non vedo il tasto.

-edit4-

Se premo il tasto nella discussione che mi hai appena spostato in quarantena (che dopo il troncamento, risulta essere stata creata da me) lo script va in hang.

Re: Script per applicare semplicemente il tag [Risolto]

Inviato: giovedì 21 febbraio 2013, 16:19
da matti 007

Re: Script per applicare semplicemente il tag [Risolto]

Inviato: giovedì 21 febbraio 2013, 16:22
da Zoff

Re: Script per applicare semplicemente il tag [Risolto]

Inviato: giovedì 21 febbraio 2013, 16:43
da matti 007
Permessi applicati

Re: Script per applicare semplicemente il tag [Risolto]

Inviato: giovedì 21 febbraio 2013, 16:54
da Zoff
Ah ecco, mi hai mentito! :P
Il tuo formato della data è diverso da quelli che avevo elencato. Il mese è espresso col nome non col numero!

Ora vedo di aggiungere questo caso anche se non ho capito da cosa dipende la differenza.

Re: Script per applicare semplicemente il tag [Risolto]

Inviato: giovedì 21 febbraio 2013, 16:58
da rpadovani
Zoff in [url=http://forum.ubuntu-it.org/viewtopic.php?p=4328672#p4328672]questo messaggio[/url] ha scritto: Ora vedo di aggiungere questo caso anche se non ho capito da cosa dipende la differenza.
Sai vero che nel pannello utente puoi scegliere il formato di data, si? :)
Puoi anche personalizzarlo :D

Re: Script per applicare semplicemente il tag [Risolto]

Inviato: giovedì 21 febbraio 2013, 17:00
da magic89
Sono opzioni personali di ogni utente.

http://postimage.org/image/nkigzkk77/

Re: Script per applicare semplicemente il tag [Risolto]

Inviato: giovedì 21 febbraio 2013, 17:01
da Zoff
WebbyIT in [url=http://forum.ubuntu-it.org/viewtopic.php?p=4328674#p4328674]questo messaggio[/url] ha scritto:
Zoff in [url=http://forum.ubuntu-it.org/viewtopic.php?p=4328672#p4328672]questo messaggio[/url] ha scritto: Ora vedo di aggiungere questo caso anche se non ho capito da cosa dipende la differenza.
Sai vero che nel pannello utente puoi scegliere il formato di data, si? :)
Puoi anche personalizzarlo :D
Sì lo so, ma ero convinto di averlo già considerato.

Re: Script per applicare semplicemente il tag [Risolto]

Inviato: giovedì 21 febbraio 2013, 17:26
da rpadovani
In questa discussione compare il pulsante, ma una volta che viene la schermata nera non fa niente.
La data è: da WebbyIT » giovedì 21 febbraio 2013, 15:01