telefonate bluetooth

Installazione, configurazione e utilizzo di applicativi multimediali, masterizzazione, acquisizione e codec audio/video, streaming, ecc.

telefonate bluetooth

Messaggioda duns » domenica 19 maggio 2019, 19:34

Ciao a tutti. Oggi ho provato a installare un adapter bluetooth: l'idea era quella di fare telefonate con lo smartphone usando casse e microfono del PC.
Ora con bluetooth regolarmente abilitato posso sentire ad esempio dei files musicali sullo smartphone con le casse del Pc, ma non le telefonate.
EDIT
Ho provato con quanto suggerito qui e adesso ha funzionato (dopo aver installato ofono e modificato default.pa in /etc/pulse come suggerito nel link che ho citato).
EDIT
Ho parlato troppo presto: finora riesco a sentire (quello che l'altra persona dice, nelle casse del PC), ma non a farmi sentire (attraverso il microfono del PC). Bisognerà lavorarci ancora
duns
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 281
Iscrizione: febbraio 2006
Desktop: KDE plasma5
Distribuzione: Kubuntu 18.04
Sesso: Maschile

Re: telefonate bluetooth

Messaggioda duns » domenica 9 giugno 2019, 20:00

Ho sperimentato che se disinstallo le apps che gestiscono il collegamento bluetooth con l'auto (leggendo i messaggi quando sto guidando), il tutto funziona: non solo sento l'altra persona nelle casse del Pc ma anche l'altro sente me tramite il microfono.
Peraltro l'audio che riesco a inviare è di qualità piuttosto scadente (gracchiante).
duns
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 281
Iscrizione: febbraio 2006
Desktop: KDE plasma5
Distribuzione: Kubuntu 18.04
Sesso: Maschile

Re: telefonate bluetooth

Messaggioda MoonDragon » domenica 9 giugno 2019, 22:41

interessante mi indicheresti i passaggi giusti che hai eseguito? Vedendo la guida vedo modifiche "permanenti" ma si posson lasciare per il normale funzionamento del pc oppure ogni volta van tolti?
"Coltiva 🐧 LINUX tanto WINDOWS si pianta da solo e la MELA è già stata morsa" :p
Avatar utente
MoonDragon
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1566
Iscrizione: aprile 2010
Desktop: Gnome
Distribuzione: Ubuntu 18.04 64-bit gdm3 xorg
Sesso: Maschile

Re: telefonate bluetooth

Messaggioda duns » lunedì 10 giugno 2019, 19:22

Scusa, ma in questi giorni sono molto preso. Ho seguito, come dicevo, le indicazioni di questo forum.
Ricordati di aggiungere ofono (io l'ho fatto da Synaptic).
Ovviamente occorre avere un adapter bluetooth connesso (nel mio caso tramite porta USB).
:ciao:
duns
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 281
Iscrizione: febbraio 2006
Desktop: KDE plasma5
Distribuzione: Kubuntu 18.04
Sesso: Maschile

Re: telefonate bluetooth

Messaggioda MoonDragon » lunedì 10 giugno 2019, 20:25

Ti ringrazio, anche io ho un periodo intenso, proverò appena riesco ;)
"Coltiva 🐧 LINUX tanto WINDOWS si pianta da solo e la MELA è già stata morsa" :p
Avatar utente
MoonDragon
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1566
Iscrizione: aprile 2010
Desktop: Gnome
Distribuzione: Ubuntu 18.04 64-bit gdm3 xorg
Sesso: Maschile

Re: telefonate bluetooth

Messaggioda magozurlinux » venerdì 14 giugno 2019, 18:28

duns Immagine ha scritto:Ho sperimentato che se disinstallo le apps che gestiscono il collegamento bluetooth con l'auto (leggendo i messaggi quando sto guidando), il tutto funziona: non solo sento l'altra persona nelle casse del Pc ma anche l'altro sente me tramite il microfono.
Peraltro l'audio che riesco a inviare è di qualità piuttosto scadente (gracchiante).


Ciao.

Dovresti usare la funzione A2DP, audio di alta qualità.
Xubuntu 18.04 LTS amd64 :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 21095
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64

Re: telefonate bluetooth

Messaggioda duns » sabato 15 giugno 2019, 7:41

Grazie @magozurlinux (un nome che mi riporta alla mia infanzia: Mago Zurlì :) ).
Ma questa impostazione la dovrei settare a livello di PC o di smartphone?
E come (se non chiedo troppo)?

EDIT

Ho visto che da PC, in Pulseaudio volume control, si può settare per lo smartphone l'A2DP. Proverò, ma mi sembrava che settasse automaticamente il profilo. Vi farò sapere...
Grazie
duns
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 281
Iscrizione: febbraio 2006
Desktop: KDE plasma5
Distribuzione: Kubuntu 18.04
Sesso: Maschile

Re: telefonate bluetooth

Messaggioda magozurlinux » sabato 15 giugno 2019, 10:56

duns Immagine ha scritto:Grazie @magozurlinux (un nome che mi riporta alla mia infanzia: Mago Zurlì :) ).
Ma questa impostazione la dovrei settare a livello di PC o di smartphone?
E come (se non chiedo troppo)?

EDIT

Ho visto che da PC, in Pulseaudio volume control, si può settare per lo smartphone l'A2DP. Proverò, ma mi sembrava che settasse automaticamente il profilo. Vi farò sapere...
Grazie


Prego, di nulla!

Va impostato a livello pc, lo smartphone dovrebbe avere già di suo il servizio A2DP.
Xubuntu 18.04 LTS amd64 :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 21095
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64

Re: telefonate bluetooth

Messaggioda duns » sabato 15 giugno 2019, 16:02

però PA su PC (Kubuntu 18.04) mi da l'A2DP come "unavailable"...
duns
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 281
Iscrizione: febbraio 2006
Desktop: KDE plasma5
Distribuzione: Kubuntu 18.04
Sesso: Maschile

Re: telefonate bluetooth

Messaggioda magozurlinux » sabato 15 giugno 2019, 16:41

duns Immagine ha scritto:però PA su PC (Kubuntu 18.04) mi da l'A2DP come "unavailable"...


Da terminale postami questo comando:

Codice: Seleziona tutto
cat /etc/bluetooth/audio.conf
Xubuntu 18.04 LTS amd64 :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 21095
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64

Re: telefonate bluetooth

Messaggioda duns » sabato 15 giugno 2019, 16:45

grazie!
Codice: Seleziona tutto
cat /etc/bluetooth/audio.conf
cat: /etc/bluetooth/audio.conf: No such file or directory

Non c'è quel file. C'è main.conf, eccolo:
Codice: Seleziona tutto
cat /etc/bluetooth/main.conf
[General]

# Default adaper name
# Defaults to 'BlueZ X.YZ'
#Name = BlueZ

# Default device class. Only the major and minor device class bits are
# considered. Defaults to '0x000000'.
#Class = 0x000100

# How long to stay in discoverable mode before going back to non-discoverable
# The value is in seconds. Default is 180, i.e. 3 minutes.
# 0 = disable timer, i.e. stay discoverable forever
#DiscoverableTimeout = 0

# How long to stay in pairable mode before going back to non-discoverable
# The value is in seconds. Default is 0.
# 0 = disable timer, i.e. stay pairable forever
#PairableTimeout = 0

# Automatic connection for bonded devices driven by platform/user events.
# If a platform plugin uses this mechanism, automatic connections will be
# enabled during the interval defined below. Initially, this feature
# intends to be used to establish connections to ATT channels. Default is 60.
#AutoConnectTimeout = 60

# Use vendor id source (assigner), vendor, product and version information for
# DID profile support. The values are separated by ":" and assigner, VID, PID
# and version.
# Possible vendor id source values: bluetooth, usb (defaults to usb)
#DeviceID = bluetooth:1234:5678:abcd

# Do reverse service discovery for previously unknown devices that connect to
# us. This option is really only needed for qualification since the BITE tester
# doesn't like us doing reverse SDP for some test cases (though there could in
# theory be other useful purposes for this too). Defaults to 'true'.
#ReverseServiceDiscovery = true

# Enable name resolving after inquiry. Set it to 'false' if you don't need
# remote devices name and want shorter discovery cycle. Defaults to 'true'.
#NameResolving = true

# Enable runtime persistency of debug link keys. Default is false which
# makes debug link keys valid only for the duration of the connection
# that they were created for.
#DebugKeys = false

# Restricts all controllers to the specified transport. Default value
# is "dual", i.e. both BR/EDR and LE enabled (when supported by the HW).
# Possible values: "dual", "bredr", "le"
#ControllerMode = dual

# Enables Multi Profile Specification support. This allows to specify if
# system supports only Multiple Profiles Single Device (MPSD) configuration
# or both Multiple Profiles Single Device (MPSD) and Multiple Profiles Multiple
# Devices (MPMD) configurations.
# Possible values: "off", "single", "multiple"
#MultiProfile = off

# Permanently enables the Fast Connectable setting for adapters that
# support it. When enabled other devices can connect faster to us,
# however the tradeoff is increased power consumptions. This feature
# will fully work only on kernel version 4.1 and newer. Defaults to
# 'false'.
#FastConnectable = false

[Policy]

# The ReconnectUUIDs defines the set of remote services that should try
# to be reconnected to in case of a link loss (link supervision
# timeout). The policy plugin should contain a sane set of values by
# default, but this list can be overridden here. By setting the list to
# empty the reconnection feature gets disabled.
#ReconnectUUIDs=00001112-0000-1000-8000-00805f9b34fb, 0000111f-0000-1000-8000-00805f9b34fb, 0000110a-0000-1000-8000-00805f9b34fb

# ReconnectAttempts define the number of attempts to reconnect after a link
# lost. Setting the value to 0 disables reconnecting feature.
#ReconnectAttempts=7

# ReconnectIntervals define the set of intervals in seconds to use in between
# attempts.
# If the number of attempts defined in ReconnectAttempts is bigger than the
# set of intervals the last interval is repeated until the last attempt.
#ReconnectIntervals=1, 2, 4, 8, 16, 32, 64

# AutoEnable defines option to enable all controllers when they are found.
# This includes adapters present on start as well as adapters that are plugged
# in later on. Defaults to 'false'.
AutoEnable=true


O input.conf:
Codice: Seleziona tutto
# Configuration file for the input service

# This section contains options which are not specific to any
# particular interface
[General]

# Set idle timeout (in minutes) before the connection will
# be disconnect (defaults to 0 for no timeout)
#IdleTimeout=30

# Enable HID protocol handling in userspace input profile
# Defaults to false (HIDP handled in HIDP kernel module)
#UserspaceHID=true
duns
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 281
Iscrizione: febbraio 2006
Desktop: KDE plasma5
Distribuzione: Kubuntu 18.04
Sesso: Maschile

Re: telefonate bluetooth

Messaggioda magozurlinux » sabato 15 giugno 2019, 17:16

Prego, di nulla!

Con la 18.04 quel file manca ma si può recuperare da Internet.

Da terminale dai questi comandi:

Codice: Seleziona tutto
sudo nano /etc/bluetooth/audio.conf


copia e incolla queste righe:

Codice: Seleziona tutto
# Configuration file for the audio service
# This section contains options which are not specific to any
# particular interface
[General]
Disable=Headset
Enable=Gateway,Source

# Switch to master role for incoming connections (defaults to true)
Master=true

# If we want to disable support for specific services
# Defaults to supporting all implemented services
#Disable=Gateway,Source,Socket
Disable=Socket

# SCO routing. Either PCM or HCI (in which case audio is routed to/from ALSA)
# Defaults to HCI
#SCORouting=HCI

# Automatically connect both A2DP and HFP/HSP profiles for incoming
# connections. Some headsets that support both profiles will only connect the
# other one automatically so the default setting of true is usually a good
# idea.
AutoConnect=true

# Headset interface specific options (i.e. options which affect how the audio
# service interacts with remote headset devices)
[Headset]

# Set to true to support HFP, false means only HSP is supported
# Defaults to true
HFP=true

# Maximum number of connected HSP/HFP devices per adapter. Defaults to 1
MaxConnected=2

# Set to true to enable use of fast connectable mode (faster page scanning)
# for HFP when incoming call starts. Default settings are restored after
# call is answered or rejected. Page scan interval is much shorter and page
# scan type changed to interlaced. Such allows faster connection initiated
# by a headset.
FastConnectable=true

# Just an example of potential config options for the other interfaces
#[A2DP]
#SBCSources=1
#MPEG12Sources=0


per salvare il file premi i tasti Ctrl o e poi Invio; per uscire premi i tasti Ctrl x

Codice: Seleziona tutto
sudo service bluetooth restart
Xubuntu 18.04 LTS amd64 :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 21095
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64

Re: telefonate bluetooth

Messaggioda duns » sabato 15 giugno 2019, 17:27

Grazie. Perbacco, però il gateway continua ad essere preferito, anche se adesso posso scegliere (ma manualmente, ogni volta di nuovo) l'A2DP.

EDIT
Ho provato a invertire i due, anteponendo, in audio.conf, Source a Gateway: niente da fare.
Ho anche notato che se setto su Source da PA, il suono passa dalla casse del PC allo smartphone, cioè Source, anche se teoricamente available, risulta praticamente inutilizzabile.
Allegati
bluetooth balallo.png
duns
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 281
Iscrizione: febbraio 2006
Desktop: KDE plasma5
Distribuzione: Kubuntu 18.04
Sesso: Maschile

Re: telefonate bluetooth

Messaggioda magozurlinux » sabato 15 giugno 2019, 17:39

duns Immagine ha scritto:Grazie. Perbacco, però il gateway continua ad essere preferito, anche se adesso posso scegliere (ma manualmente, ogni volta di nuovo) l'A2DP.


Da terminale dai questi comandi:

Codice: Seleziona tutto
sudo nano /etc/bluetooth/audio.conf


scorri il file fino a questa riga:

Codice: Seleziona tutto
Enable=Gateway,Source


cancella Gateway, ed aggiungi questi dopo Source:


Sink,Media,Socket

per salvare il file premi i tasti Ctrl o e poi Invio; per uscire premi i tasti Ctrl x

Codice: Seleziona tutto
sudo service bluetooth restart
Xubuntu 18.04 LTS amd64 :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 21095
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64

Re: telefonate bluetooth

Messaggioda duns » sabato 15 giugno 2019, 17:55

Grazie. Ma così è peggio che andar di notte: Source non è più available,e il suono non è trasferito al PC ma resta nello smartphone.
Tra poco devo uscire. Ne riparliamo, se non ti spiace, lunedì.
Grazie. Buona domenica!
duns
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 281
Iscrizione: febbraio 2006
Desktop: KDE plasma5
Distribuzione: Kubuntu 18.04
Sesso: Maschile

Re: telefonate bluetooth

Messaggioda magozurlinux » sabato 15 giugno 2019, 17:57

Forse ti sei dimenticato di mettere la virgola dopo Source.

Da terminale postami questo comando:

Codice: Seleziona tutto
cat /etc/bluetooth/audio.conf
Xubuntu 18.04 LTS amd64 :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 21095
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64

Re: telefonate bluetooth

Messaggioda duns » sabato 15 giugno 2019, 17:59

No, c'è
Enable=Source,Sink,Media,Socket
duns
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 281
Iscrizione: febbraio 2006
Desktop: KDE plasma5
Distribuzione: Kubuntu 18.04
Sesso: Maschile

Re: telefonate bluetooth

Messaggioda magozurlinux » sabato 15 giugno 2019, 18:00

duns Immagine ha scritto:No, c'è
Enable=Source,Sink,Media,Socket


Sì, c'è, prova a riaggiungere Gateway
Xubuntu 18.04 LTS amd64 :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 21095
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64


Torna a Multimediale

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 1 ospite