Errore strano flashplugin

Installazione, configurazione e utilizzo di applicativi multimediali, masterizzazione, acquisizione e codec audio/video, streaming e altro.
Avatar utente
ant1988
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1126
Iscrizione: venerdì 14 novembre 2008, 18:57
Località: Vicino Firenze

Errore strano flashplugin

Messaggio da ant1988 » martedì 14 luglio 2015, 21:47

Allora premesso che:
1) Su firefox la versione di adobe flashplugin è ferma alla versione Versione 11.2.202.481 e siamo al giorno 14/7/2015
2) Ho provato a spostare e cambiare il file libpepflashplugin.so ( libreria di chromium) con libflashplugin.so
Vorrei capire il perché tutte le volte firefox mi segnala che adobe flash plugin non è aggiornato quando invece la mia ultima versione è proprio Versione 11.2.202.481.
poi ho visto questo sito e infatti ho capito che un altro utente denunciava lo stesso... mah i casi umani sono tanti eh
Jack 2015-07-11 02:30:46 PDT

Are you insane?
Why did you block the latest flash Version when no newer version is available. Its in a loop right now and FF keep asking every one to update flash player and once it get updated, it asked again since no newer version is available at this moment

This ridicules decision by people who has no idea how internet works has resulted Firefox losing its user base to chrome. The point is not to insult users by repeating update request.

The whole point of these security warning is absurd since users are not working in CIA or NSA and they dont required over care on securities, these bugs hardly affect 0.0001% of FF users, but every one is forced to update and take the pain.
Ubuntu 14.04.2 x64:
===================

> You're right. It looks like there's no update for Linux (so far?). I'm
> reverting the block for Linux to indicate there's no update available.

File: libflashplayer.so
Path: /usr/lib/mozilla/plugins/libflashplayer.so
Version: 11.2.202.481
State: Enabled (STATE_VULNERABLE_NO_UPDATE)
Shockwave Flash 11.2 r202

For each of the above plugins, I went through the following:

- ensured that clicking on "Check for Update" took the user to the "Mozilla Plugin" page
- ensured when users select "Update Now", the https://get.adobe.com/flashplayer/ page opens
- ensured that clicking on "Update Now.." under the "Flash doorhanger" opens https://get.adobe.com/flashplayer/
- ensured that "Shockwave Flash is known to be vulnerable and should be updated. <button>Update Now</button>" appears under about:addons
- ensured that "Shockwave Flash is known to be vulnerable. Use with caution. <button>More Information</button>" appears under about:addons
- ensured that the entry under about:plugins appears as (STATE_VULNERABLE_UPDATE_AVAILABLE) for Win/OSX
- ensured that the entry under about:plugins appears as (STATE_VULNERABLE_NO_UPDATE) for Linux
Non sono massone ma sono dell'idea che:Giustizia,fratellanza e uguaglianza siano  concetti abbastanza belli :)

Avatar utente
Massimog
Rampante Reduce
Rampante Reduce
Messaggi: 7340
Iscrizione: martedì 2 dicembre 2008, 18:17
Desktop: GNOME 3.16
Distribuzione: Gentoo x86_64
Sesso: Maschile
Località: Osimo(AN)

Re: Errore strano flashplugin

Messaggio da Massimog » martedì 14 luglio 2015, 22:10

ci dovrebero essere delle nuove vulnerabilità che non sono state sistemate con la nuova versione.Ti conviene tenere disabilitato flash per adesso
Acer 5920G con Gentoo 64bit + Ubuntu 12.04 LTS Precise Pangolin 64bit + Windows 7 64 bit | Stampante Epson PX710W | Router Netgear DGN2000

Avatar utente
jackynet92
Moderatore Globale
Moderatore Globale
Messaggi: 13413
Iscrizione: sabato 3 settembre 2011, 1:41
Desktop: Mate
Distribuzione: Ubuntu 16.04 64bit
Sesso: Maschile
Località: Torino

Re: Errore strano flashplugin

Messaggio da jackynet92 » martedì 14 luglio 2015, 22:13

sposto in multimediale.

Avatar utente
ant1988
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1126
Iscrizione: venerdì 14 novembre 2008, 18:57
Località: Vicino Firenze

Re: Errore strano flashplugin

Messaggio da ant1988 » martedì 14 luglio 2015, 22:14

ma se controllo il sito ufficiale della Adobe l'ultima versione per firefox è Versione 11.2.202.481. Solo chromium possiede Adobe Flash Player - Versione: 18.0.0.194
quindi perché é stato segnalato come bug prima che ancora la Adobe pubblica ufficialmente una versione apposta per Firefox??
Non é un'assurdità?
Non sono massone ma sono dell'idea che:Giustizia,fratellanza e uguaglianza siano  concetti abbastanza belli :)

Avatar utente
Massimog
Rampante Reduce
Rampante Reduce
Messaggi: 7340
Iscrizione: martedì 2 dicembre 2008, 18:17
Desktop: GNOME 3.16
Distribuzione: Gentoo x86_64
Sesso: Maschile
Località: Osimo(AN)

Re: Errore strano flashplugin

Messaggio da Massimog » martedì 14 luglio 2015, 22:17

no, firefox per una questione di prevenzione blocca flash finche eche la versione assente da vulnerabilità
Acer 5920G con Gentoo 64bit + Ubuntu 12.04 LTS Precise Pangolin 64bit + Windows 7 64 bit | Stampante Epson PX710W | Router Netgear DGN2000

Avatar utente
ant1988
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1126
Iscrizione: venerdì 14 novembre 2008, 18:57
Località: Vicino Firenze

Re: Errore strano flashplugin

Messaggio da ant1988 » martedì 14 luglio 2015, 22:19

si ma così dai noia a tutti gli utenti. non a caso non sono l'unico che ne parla....
poi che vuol dire lo blocca preventivamente?
Cioé prima tu mi dai l'aggiornamento e POI mi dici che c'è da aggiornarlo e NON prima... Cioé utenti allarmati per niente.
Non sono massone ma sono dell'idea che:Giustizia,fratellanza e uguaglianza siano  concetti abbastanza belli :)

Avatar utente
superlex
Rampante Reduce
Rampante Reduce
Messaggi: 5371
Iscrizione: martedì 19 agosto 2008, 23:22
Desktop: Budgie
Distribuzione: Ubuntu 18.04 LTS

Re: Errore strano flashplugin

Messaggio da superlex » martedì 14 luglio 2015, 22:48

ant1988 [url=http://forum.ubuntu-it.org/viewtopic.php?p=4780629#p4780629][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:si ma così dai noia a tutti gli utenti. non a caso non sono l'unico che ne parla....
poi che vuol dire lo blocca preventivamente?
Cioé prima tu mi dai l'aggiornamento e POI mi dici che c'è da aggiornarlo e NON prima... Cioé utenti allarmati per niente.
Non sono allarmati per nulla, ci sono due gravi vulnerabilità e giustamente l'utente viene avvisato che eseguire quel plugin è rischioso. Poi sta a lui decidere se rischiare o meno.
A titolo di chiarimento, queste due vulnerabilità riguardano sia la versione 18.0.0.203 (Windows e Mac + Chrome) sia la 11.2.202.481 (GNU/Linux):
https://helpx.adobe.com/security/produc ... 15-18.html
Adobe ha rilasciato il fix con la versione 18.0.0.209 per Windows e Mac e Chrome, aspettiamo la nuova versione per GNU/Linux e nel frattempo utilizziamo flash solo se strettamente necessario.
!!! NOTA !!!: non si accettano richieste d'aiuto in privato, sebbene si possa segnalare la discussione aperta per un eventuale intervento. Grazie.
[GUIDA] Webcam Motion Eye 05ca:18** Sony Vaio
[GUIDA] TunerTV eb1a:2881 per Ubuntu 16.04

Avatar utente
ant1988
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1126
Iscrizione: venerdì 14 novembre 2008, 18:57
Località: Vicino Firenze

Re: Errore strano flashplugin

Messaggio da ant1988 » martedì 14 luglio 2015, 22:50

infatti non a caso questo utente aveva scritto:
Jack 2015-07-11 02:30:46 PDT

Are you insane?
Why did you block the latest flash Version when no newer version is available. Its in a loop right now and FF keep asking every one to update flash player and once it get updated, it asked again since no newer version is available at this moment

This ridicules decision by people who has no idea how internet works has resulted Firefox losing its user base to chrome. The point is not to insult users by repeating update request.

The whole point of these security warning is absurd since users are not working in CIA or NSA and they dont required over care on securities, these bugs hardly affect 0.0001% of FF users, but every one is forced to update and take the pain.
ps di solito prima si sviluppa un programma ,poi una volta sviluppato lo si rilascia pubblicamente sul sito scaricabile e DOPO si avvisano TUTTI gli utenti della nuova versione.
Non posso mica essere dentro la testa degli sviluppatori e sviluppargliela io!!!
pps no no non sono per niente allarmati
Non sono massone ma sono dell'idea che:Giustizia,fratellanza e uguaglianza siano  concetti abbastanza belli :)

Avatar utente
superlex
Rampante Reduce
Rampante Reduce
Messaggi: 5371
Iscrizione: martedì 19 agosto 2008, 23:22
Desktop: Budgie
Distribuzione: Ubuntu 18.04 LTS

Re: Errore strano flashplugin

Messaggio da superlex » martedì 14 luglio 2015, 23:11

Scusa, ma non capisco il problema. Nella versione attuale ci sono due falle di sicurezza, firefox lo disattiva (in attesa della nuova versione) per la sicurezza dell'utente che comunque può riabilitarlo (conscio del pericolo). Questo a me fa preferire firefox, non mollarlo in favore di un altro browser che invece magari non avvisa.
!!! NOTA !!!: non si accettano richieste d'aiuto in privato, sebbene si possa segnalare la discussione aperta per un eventuale intervento. Grazie.
[GUIDA] Webcam Motion Eye 05ca:18** Sony Vaio
[GUIDA] TunerTV eb1a:2881 per Ubuntu 16.04

Avatar utente
ant1988
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1126
Iscrizione: venerdì 14 novembre 2008, 18:57
Località: Vicino Firenze

Re: Errore strano flashplugin

Messaggio da ant1988 » martedì 14 luglio 2015, 23:14

Io non lo mollo ma rompe un pò i c*****I tutte le volte abilitarlo manualmente...
ps due bug risolti su windows e MAC ma non su Linux quindi potevano benissimo evitare di segnalarlo a bugzilla.

Codice: Seleziona tutto

The whole point of these security warning is absurd since users are not working in CIA or NSA and they dont required over care on securities, these bugs hardly affect 0.0001% of FF users, but every one is forced to update and take the pain.
Il punto è che questi avvertimenti di sicurezza è assurdo da quando gli utenti non lavorano alla CIA o alla NSA e essi non richiedono cura , questi bug difficilmente hanno effetto su 0.0001% degli utenti Firefox ma ognuno è forzato a eseguire l'aggiornamento ... questo in sintesi ciò che vuol dire la scritta in inglese quindi questa segnalazione di bug è oltre che inopportuno anche inappropiato.
Non sono massone ma sono dell'idea che:Giustizia,fratellanza e uguaglianza siano  concetti abbastanza belli :)

daigo

Re: Errore strano flashplugin

Messaggio da daigo » martedì 14 luglio 2015, 23:27

se lo vuoi abilitato, lascialo abilitato senza doverlo fare manualmente ogni volta
Allegati
schermata7.png

Avatar utente
superlex
Rampante Reduce
Rampante Reduce
Messaggi: 5371
Iscrizione: martedì 19 agosto 2008, 23:22
Desktop: Budgie
Distribuzione: Ubuntu 18.04 LTS

Re: Errore strano flashplugin

Messaggio da superlex » martedì 14 luglio 2015, 23:54

Altrimenti
1) rimuovi la versione di flash che hai
2) installi google-chrome
3) aggiungi questo ppa ppa:nilarimogard/webupd8
4) installi freshplayerplugin
5) ti godi firefox con l'ultima versione di flashplayer (18.0.0.209)

;)
!!! NOTA !!!: non si accettano richieste d'aiuto in privato, sebbene si possa segnalare la discussione aperta per un eventuale intervento. Grazie.
[GUIDA] Webcam Motion Eye 05ca:18** Sony Vaio
[GUIDA] TunerTV eb1a:2881 per Ubuntu 16.04

daigo

Re: Errore strano flashplugin

Messaggio da daigo » mercoledì 15 luglio 2015, 0:02

si ho fatto gli aggiornamenti ora e cè la nuova versione di google-chrome con flash aggiornato
Adobe Flash Player - Versione: 18.0.0.209
Shockwave Flash 18.0 r0
Nome: Shockwave Flash
Descrizione: Shockwave Flash 18.0 r0
Versione: 18.0.0.209
Percorso: /opt/google/chrome/PepperFlash/libpepflashplayer.so
Tipo: PPAPI (out-of-process)
Disabilita
Tipi MIME:
Tipo MIME Descrizione Estensioni file
application/x-shockwave-flash Shockwave Flash
.swf
application/futuresplash FutureSplash Player
.spl

Avatar utente
superlex
Rampante Reduce
Rampante Reduce
Messaggi: 5371
Iscrizione: martedì 19 agosto 2008, 23:22
Desktop: Budgie
Distribuzione: Ubuntu 18.04 LTS

Re: Errore strano flashplugin

Messaggio da superlex » mercoledì 15 luglio 2015, 0:19

Però se uno preferisce firefox..

Immagine
!!! NOTA !!!: non si accettano richieste d'aiuto in privato, sebbene si possa segnalare la discussione aperta per un eventuale intervento. Grazie.
[GUIDA] Webcam Motion Eye 05ca:18** Sony Vaio
[GUIDA] TunerTV eb1a:2881 per Ubuntu 16.04

Avatar utente
noel80
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1088
Iscrizione: giovedì 11 settembre 2014, 2:49
Desktop: plasma@linux-libre-lts
Distribuzione: archlinux, Ubuntu Studio

Re: Errore strano flashplugin

Messaggio da noel80 » mercoledì 15 luglio 2015, 0:25

Oggi mi dava anche a me lo stesso problema : mi chiedeva ogni volta se abilitare il plugin ( uso solo Firefox ) , ma non rimaneva memorizzata la scelta di abilitare la scelta sempre .
Stasera il gestore degli aggiornamenti ha chiesto se installare il flash plugin .
) Su firefox la versione di adobe flashplugin è ferma alla versione Versione 11.2.202.481 e siamo al giorno 14/7/2015
Allegati
flash plugin.png
flash plugin.png (7.12 KiB) Visualizzato 504 volte
Ultima modifica di noel80 il mercoledì 15 luglio 2015, 0:33, modificato 1 volta in totale.

Avatar utente
Massimog
Rampante Reduce
Rampante Reduce
Messaggi: 7340
Iscrizione: martedì 2 dicembre 2008, 18:17
Desktop: GNOME 3.16
Distribuzione: Gentoo x86_64
Sesso: Maschile
Località: Osimo(AN)

Re: Errore strano flashplugin

Messaggio da Massimog » mercoledì 15 luglio 2015, 0:28

ant1988 [url=http://forum.ubuntu-it.org/viewtopic.php?p=4780647#p4780647][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto: Il punto è che questi avvertimenti di sicurezza è assurdo da quando gli utenti non lavorano alla CIA o alla NSA e essi non richiedono cura , questi bug difficilmente hanno effetto su 0.0001% degli utenti Firefox ma ognuno è forzato a eseguire l'aggiornamento ... questo in sintesi ciò che vuol dire la scritta in inglese quindi questa segnalazione di bug è oltre che inopportuno anche inappropiato.
non capisco questo tuo raggionamento... mica devi essere della cia per tenera alla tua sicurezza. con quei tipi di vulnerabilitè basta che visiti un sito sbagliato per fare il modo che un malintenzionato prenda il controllo del tuo pc.
Acer 5920G con Gentoo 64bit + Ubuntu 12.04 LTS Precise Pangolin 64bit + Windows 7 64 bit | Stampante Epson PX710W | Router Netgear DGN2000

Avatar utente
shouldes
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 19407
Iscrizione: domenica 10 febbraio 2008, 21:45
Desktop: KappaDiE

Re: Errore strano flashplugin

Messaggio da shouldes » mercoledì 15 luglio 2015, 0:53

Una cosa del genere in 9 anni di Firefox+Flashplayer+Ubuntu non mi era mai capitata.
Come potete vedere il pacchetto adobe-flashplugin è aggiornato ad oggi 20150714.xxxx e risulta bloccato.
Fino a ieri mi funzionava, oggi non andava più, eseguo l'aggiornamento alla nuova versione e continua a non andare.
Immagine


Aggiornamento inutile?
Tutte le numerazioni inferiori o uguali a 18.0.0.203 sono bloccate, quindi anche se correggono i bug ma non mettono numerazione 18.0.0.204 e superiore viene bloccata.
Qua si rischia di trovarsi con il bug corretto, visto l'aggiornamento di oggi, e il plugin bloccato per questione di numeri.

Fino a ieri ha sempre funzionato, infatti ho aiutato alcuni utenti a mettere adobe-flashplugin dei Canonical al posto di flashplugin-installer che non funziona da un bel pezzo.

superlex [url=http://forum.ubuntu-it.org/viewtopic.php?p=4780653#p4780653][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:Altrimenti
1) rimuovi la versione di flash che hai
2) installi google-chrome
3) aggiungi questo ppa ppa:nilarimogard/webupd8
4) installi freshplayerplugin
5) ti godi firefox con l'ultima versione di flashplayer (18.0.0.209)

;)
Quando si tratta di queste cose preferisco stare senza flashplayer per qualche giorno (mai successo fino ad oggi) piuttosto che affidarmi alla tempestività negli aggiornamenti di sicurezza di un ppa.
Ho sempre usato quello dei Canonical perché è il più veloce ad aggiornare il pacchetto, ma questa volta il pacchetto aggiornato rimane bloccato da Firefox.

Avatar utente
superlex
Rampante Reduce
Rampante Reduce
Messaggi: 5371
Iscrizione: martedì 19 agosto 2008, 23:22
Desktop: Budgie
Distribuzione: Ubuntu 18.04 LTS

Re: Errore strano flashplugin

Messaggio da superlex » mercoledì 15 luglio 2015, 1:04

Ne riparleremo quando Adobe rilascerà una versione di flashplayer 11.2 superiore a 11.2.202.481 (tipo non so, 11.2.202.490).
Fino ad allora qualunque repository si scelga e qualunque versione del pacchetto sia, finché la versione di flash rimarrà 11.2.202.481 le falle rimarranno e firefox continuerà a bloccare il plugin.
Quando la versione di flash sarà superiore a 11.2.202.481 e firefox continuerà a chiedere di aggiornarlo perché inferiore a 18.0.0.209 allora lo considereremo un problema. Ma non credo sarà così ;)
shouldes [url=http://forum.ubuntu-it.org/viewtopic.php?p=4780667#p4780667][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:
superlex [url=http://forum.ubuntu-it.org/viewtopic.php?p=4780653#p4780653][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:Altrimenti
1) rimuovi la versione di flash che hai
2) installi google-chrome
3) aggiungi questo ppa ppa:nilarimogard/webupd8
4) installi freshplayerplugin
5) ti godi firefox con l'ultima versione di flashplayer (18.0.0.209)

;)
Quando si tratta di queste cose preferisco stare senza flashplayer per qualche giorno (mai successo fino ad oggi) piuttosto che affidarmi alla tempestività negli aggiornamenti di sicurezza di un ppa.
Ho sempre usato quello dei Canonical perché è il più veloce ad aggiornare il pacchetto, ma questa volta il pacchetto aggiornato rimane bloccato da Firefox.
La versione di flash sarà sempre quella di google-chrome o pepperflash per chromium, freshplayer non fa altro che "tradurre" pepperflash per firefox.
!!! NOTA !!!: non si accettano richieste d'aiuto in privato, sebbene si possa segnalare la discussione aperta per un eventuale intervento. Grazie.
[GUIDA] Webcam Motion Eye 05ca:18** Sony Vaio
[GUIDA] TunerTV eb1a:2881 per Ubuntu 16.04

Avatar utente
shouldes
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 19407
Iscrizione: domenica 10 febbraio 2008, 21:45
Desktop: KappaDiE

Re: Errore strano flashplugin

Messaggio da shouldes » mercoledì 15 luglio 2015, 1:21

Avevo già visitato il ppa e visto che conteneva 2 pacchetti freshplayer, pacchetti vari e nessun pacchetto pepperflash.
Avevo anche visitato questa pagina https://github.com/i-rinat/freshplayerplugin.
Le mie preoccupazioni sono appunto su eventuali vulnerabilità del freshplayer, volute o casuali, che qualcuno potrebbe sfruttare, perché le scopre o perché ce le mette di proposito.
Sono passato a GNU/Linux perché i repository mi danno un leggero senso di sicurezza rispetto al prendere software da fonti non ufficiali.

Avatar utente
superlex
Rampante Reduce
Rampante Reduce
Messaggi: 5371
Iscrizione: martedì 19 agosto 2008, 23:22
Desktop: Budgie
Distribuzione: Ubuntu 18.04 LTS

Re: Errore strano flashplugin

Messaggio da superlex » mercoledì 15 luglio 2015, 1:30

Freshplayer è opensource, se ci fossero vulnerabilità o backdoor lo si saprebbe velocemente ;)
Le preoccupazioni dovrebbero riguardare piuttosto flashplayer, soprattutto visto che si scopre quasi una vulnerabilità al giorno.
!!! NOTA !!!: non si accettano richieste d'aiuto in privato, sebbene si possa segnalare la discussione aperta per un eventuale intervento. Grazie.
[GUIDA] Webcam Motion Eye 05ca:18** Sony Vaio
[GUIDA] TunerTV eb1a:2881 per Ubuntu 16.04

Scrivi risposta

Ritorna a “Multimediale”

Chi c’è in linea

Visualizzano questa sezione: mokut e 12 ospiti