[Risolto] Problema con cuffie bluetooth

Informazioni, consigli e novità sulla galassia delle distribuzioni GNU/Linux, *nix, *BSD e su altri sistemi operativi non liberi.
Avatar utente
Shingezu
Prode Principiante
Messaggi: 112
Iscrizione: martedì 27 novembre 2012, 17:59
Desktop: Unity
Distribuzione: Ubuntu
Sesso: Maschile

[Risolto] Problema con cuffie bluetooth

Messaggio da Shingezu » venerdì 25 novembre 2016, 12:25

    Salve, sto provando linux peppermint mi sto trovando bene, molto leggero e veloce, unica pecca fin ora è il non riuscire a collegare le cuffie bluetooth, prima utilizzavo ubuntu e funzionavano benissimo, le cuffie vengono rilevate ma mi spunta un messaggio con la scritta dispositivo aggiunto ma connessione fallita, ho provato a seguire una guida che proponeva i seguenti comandi
    sudo apt-get install pulseaudio-module-bluetooth
    pactl load-module module-bluetooth-discover
    poi cancellare e riconnettere il dispositivo
    adesso a volte si connettono altre no ma in ogni caso l'audio non arriva mai, avevo trovato un topic in cui sembrava si affrontasse lo stesso problema ma si è rivelato un vicolo cieco il topic è il seguente
    http://forum.ubuntu.it/viewtopic.php?f=9&t=573845
    Ultima modifica di Shingezu il domenica 5 novembre 2017, 12:07, modificato 1 volta in totale.
    Il mio pc:
    Asus ZenBook UX510U - Intel I7 7500U/BGA

    Avatar utente
    magozurlinux
    Accecante Asceta
    Accecante Asceta
    Messaggi: 21441
    Iscrizione: mercoledì 17 marzo 2010, 17:44
    Desktop: Desktop XfCE
    Distribuzione: Xubuntu 18.04 LTS x86_64
    Località: Pisa

    Re: Problema con cuffie bluetooth

    Messaggio da magozurlinux » venerdì 25 novembre 2016, 19:36

    Da terminale postami qusti comandi:

    Codice: Seleziona tutto

    lsusb
    

    Codice: Seleziona tutto

    dmesg  | grep Blue
    

    Codice: Seleziona tutto

    dpkg -l | grep blue
    

    Codice: Seleziona tutto

    hciconfig -a
    
    Xubuntu 18.04 LTS amd64 :ciao:

    Avatar utente
    Shingezu
    Prode Principiante
    Messaggi: 112
    Iscrizione: martedì 27 novembre 2012, 17:59
    Desktop: Unity
    Distribuzione: Ubuntu
    Sesso: Maschile

    Re: Problema con cuffie bluetooth

    Messaggio da Shingezu » domenica 11 dicembre 2016, 0:01

    Codice: Seleziona tutto

    lsusb
    Bus 001 Device 002: ID 0db0:6877 Micro Star International RT2573
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 005 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

    Codice: Seleziona tutto

    dmesg  | grep Blue
    [   15.890973] Bluetooth: Core ver 2.21
    [   15.891001] Bluetooth: HCI device and connection manager initialized
    [   15.891499] Bluetooth: HCI socket layer initialized
    [   15.891504] Bluetooth: L2CAP socket layer initialized
    [   15.891513] Bluetooth: SCO socket layer initialized
    [   32.071615] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
    [   32.071620] Bluetooth: BNEP filters: protocol multicast
    [   32.071628] Bluetooth: BNEP socket layer initialized
    [  204.362675] Bluetooth: RFCOMM TTY layer initialized
    [  204.362689] Bluetooth: RFCOMM socket layer initialized
    [  204.362698] Bluetooth: RFCOMM ver 1.11
    [19957.356315] Bluetooth: hci0 SCO packet for unknown connection handle 45
    [21117.308231] Bluetooth: hci0 SCO packet for unknown connection handle 46
    [45411.208241] Bluetooth: hci0 SCO packet for unknown connection handle 45

    Codice: Seleziona tutto

    dpkg -l | grep blue
    ii  blueman                                    2.0.4-1ubuntu2                             i386         Graphical bluetooth manager
    ii  bluez                                      5.37-0ubuntu5                              i386         Bluetooth tools and daemons
    ii  bluez-obexd                                5.37-0ubuntu5                              i386         bluez obex daemon
    ii  libbluetooth3:i386                         5.37-0ubuntu5                              i386         Library to use the BlueZ Linux Bluetooth stack
    ii  pulseaudio-module-bluetooth                1:8.0-0ubuntu3.1                           i386         Bluetooth module for PulseAudio sound server
    

    Codice: Seleziona tutto

    hciconfig -a
    hci0:	Type: BR/EDR  Bus: USB
    	BD Address: 00:0D:F0:23:99:BC  ACL MTU: 192:8  SCO MTU: 64:8
    	UP RUNNING PSCAN 
    	RX bytes:24546452 acl:131 sco:481193 events:271 errors:0
    	TX bytes:24498277 acl:119 sco:480288 commands:67 errors:0
    	Features: 0xff 0xff 0x8f 0xf8 0x18 0x18 0x00 0x80
    	Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 
    	Link policy: RSWITCH HOLD SNIFF PARK 
    	Link mode: SLAVE ACCEPT 
    	Name: 'marco-MS-1057'
    	Class: 0x0c010c
    	Service Classes: Rendering, Capturing
    	Device Class: Computer, Laptop
    	HCI Version: 1.2 (0x2)  Revision: 0x639
    	LMP Version: 1.2 (0x2)  Subversion: 0x639
    	Manufacturer: Cambridge Silicon Radio (10)
    
    Ho smanettato con alcuni comandi e non so identificare cosa ho fatto ma ci sono stati effetti benefici adesso l'audio funziona per alcune cose, mi spiego, se devo vedere un film usando vlc sento l'audio, stessa cosa se voglio vedere un video in streaming, ma se invece voglio ascoltare un audio di telegram, giocare a qualche gioco, oppure i semplici suoni di sistema all'avvio e allo spegnimento non si sentono, già è qualcosa ma se riuscissimo a farle funzionare anche negli altri casi sarebbe perfetto
    Il mio pc:
    Asus ZenBook UX510U - Intel I7 7500U/BGA

    Avatar utente
    magozurlinux
    Accecante Asceta
    Accecante Asceta
    Messaggi: 21441
    Iscrizione: mercoledì 17 marzo 2010, 17:44
    Desktop: Desktop XfCE
    Distribuzione: Xubuntu 18.04 LTS x86_64
    Località: Pisa

    Re: Problema con cuffie bluetooth

    Messaggio da magozurlinux » domenica 11 dicembre 2016, 10:20

    Se clicchi sull'icona dell'altoparlante e vai su Impostazioni audio... e vai su Uscita vedi la cuffia bluetooth?

    Se la vedi, seleziona questo dispositivo, l'audio verrà dirottato sulle cuffie.
    Xubuntu 18.04 LTS amd64 :ciao:

    Avatar utente
    Shingezu
    Prode Principiante
    Messaggi: 112
    Iscrizione: martedì 27 novembre 2012, 17:59
    Desktop: Unity
    Distribuzione: Ubuntu
    Sesso: Maschile

    Re: Problema con cuffie bluetooth

    Messaggio da Shingezu » mercoledì 28 dicembre 2016, 11:35

    No tra le voci il dispositivo non è presente, vorrei mandare l'immagine ma non ricordo quale sia il formato supportato
    Il mio pc:
    Asus ZenBook UX510U - Intel I7 7500U/BGA

    Avatar utente
    magozurlinux
    Accecante Asceta
    Accecante Asceta
    Messaggi: 21441
    Iscrizione: mercoledì 17 marzo 2010, 17:44
    Desktop: Desktop XfCE
    Distribuzione: Xubuntu 18.04 LTS x86_64
    Località: Pisa

    Re: Problema con cuffie bluetooth

    Messaggio da magozurlinux » giovedì 29 dicembre 2016, 22:23

    Da terminale dai questi comandi:

    Codice: Seleziona tutto

    sudo gedit /etc/bluetooth/audio.conf
    
    scorri il file, sotto questo parametro

    Codice: Seleziona tutto

    #Disable=Gateway,Source,Socket
    
    aggiungi questo

    Codice: Seleziona tutto

    Disable=Socket
    
    salva ed esci dall'editor di testo.

    Codice: Seleziona tutto

    sudo pulseaudio -k
    

    Codice: Seleziona tutto

    sudo service bluetooth restart 
    

    Codice: Seleziona tutto

    pactl load-module module-bluetooth-discover 
    
    vedi se così funziona.
    Xubuntu 18.04 LTS amd64 :ciao:

    Avatar utente
    Shingezu
    Prode Principiante
    Messaggi: 112
    Iscrizione: martedì 27 novembre 2012, 17:59
    Desktop: Unity
    Distribuzione: Ubuntu
    Sesso: Maschile

    Re: Problema con cuffie bluetooth

    Messaggio da Shingezu » giovedì 19 gennaio 2017, 19:27

    Il file audio.conf è bianco
    Il mio pc:
    Asus ZenBook UX510U - Intel I7 7500U/BGA

    Avatar utente
    magozurlinux
    Accecante Asceta
    Accecante Asceta
    Messaggi: 21441
    Iscrizione: mercoledì 17 marzo 2010, 17:44
    Desktop: Desktop XfCE
    Distribuzione: Xubuntu 18.04 LTS x86_64
    Località: Pisa

    Re: Problema con cuffie bluetooth

    Messaggio da magozurlinux » giovedì 19 gennaio 2017, 19:42

    Da terminale dai questi comandi:

    Codice: Seleziona tutto

    sudo gedit /etc/bluetooth/audio.conf
    
    copia e incolla queste righe:

    Codice: Seleziona tutto

    # Configuration file for the audio service
    
    # This section contains options which are not specific to any
    # particular interface
    [General]
    Disable=Socket
    
    # Switch to master role for incoming connections (defaults to true)
    #Master=true
    
    # If we want to disable support for specific services
    # Defaults to supporting all implemented services
    #Disable=Control,Source
    
    # SCO routing. Either PCM or HCI (in which case audio is routed to/from ALSA)
    # Defaults to HCI
    #SCORouting=PCM
    
    # Automatically connect both A2DP and HFP/HSP profiles for incoming
    # connections. Some headsets that support both profiles will only connect the
    # other one automatically so the default setting of true is usually a good
    # idea.
    #AutoConnect=true
    
    # Headset interface specific options (i.e. options which affect how the audio
    # service interacts with remote headset devices)
    [Headset]
    
    # Set to true to support HFP, false means only HSP is supported
    # Defaults to true
    HFP=true
    
    # Maximum number of connected HSP/HFP devices per adapter. Defaults to 1
    MaxConnected=1
    
    # Set to true to enable use of fast connectable mode (faster page scanning)
    # for HFP when incomming call starts. Default settings are restored after
    # call is answered or rejected. Page scan interval is much shorter and page
    # scan type changed to interlaced. Such allows faster connection initiated
    # by a headset.
    FastConnectable=false
    
    # Just an example of potential config options for the other interfaces
    #[A2DP]
    #SBCSources=1
    #MPEG12Sources=0
    
    salva ed esci dall'editor di testo.

    Riavvia il pc.
    Xubuntu 18.04 LTS amd64 :ciao:

    giodm
    Prode Principiante
    Messaggi: 64
    Iscrizione: sabato 28 luglio 2018, 11:10
    Distribuzione: Ubuntu 16.04 LTS
    Sesso: Maschile

    Re: [Risolto] Problema con cuffie bluetooth

    Messaggio da giodm » martedì 28 maggio 2019, 20:47

    Mi accodo alla discussione perchè ho lo stesso problema: ho seguito tutti i passaggi, il bluetooth è attivo, le cuffie sono visibili ma quando provo a connettermi con esse fallisce.

    Scrivi risposta

    Ritorna a “Altre distribuzioni e sistemi operativi”

    Chi c’è in linea

    Visualizzano questa sezione: 0 utenti iscritti e 0 ospiti