[Risolto] Digikam fragile si sfascia ubuntu 14.04

Installazione, configurazione e utilizzo di applicativi multimediali, masterizzazione, acquisizione e codec audio/video, streaming, ecc.

[Risolto] Digikam fragile si sfascia ubuntu 14.04

Messaggioda neolinux » sabato 8 settembre 2018, 1:32

EDIT: Soluzione qui

---
Digikam fragile si sfascia come niente ubuntu 14.04

Digikam in usc è al 3,5 e quando tento di modificare gli exif tende a crashare, ma anche no, un vero suplizio, sarebbe un buon candidato se fosse più solido...
pyExiftoolguy con gli exif è troppo limitato, manca il campo Note:
Phatch mi fa venire il mal di testa e non trovo il campo corrispettivo a Note:
ExifTool non trovo esempi dei comandi, la GUI mi piace di più della riga di comando, se c'è qualche esempio mi converto...
Usavo exifer con wine ma anche lui non va, troppo obsoleto
Mapivi anche lui fragilino

Ho provato ad aggiornare Digikam ma neppure questa via va:
Codice: Seleziona tutto
sudo add-apt-repository ppa:philip5/extra

Codice: Seleziona tutto
sudo apt-get update

Codice: Seleziona tutto
sudo apt-get install digikam


Codice: Seleziona tutto
sudo apt-get --no-install-recommends install digikam
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
 digikam : Dipende: kdepim-runtime ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.


Qui ci sarebbe una soluzione minuziosamente spiegata, passare a versioni successive ma non va
https://myotragusbalearicus.wordpress.c ... ntu-14-04/
Codice: Seleziona tutto
sudo aptitude install digikam
I seguenti pacchetti NUOVI (NEW) saranno installati:
  akonadi-backend-mysql{a} akonadi-server{a} digikam digikam-data{a}
  enblend{a} enfuse{a} ffmpegthumbs{a} freeglut3{a} hugin{a} hugin-data{a}
  hugin-tools{a} kdepim-runtime{a} kdepimlibs-kio-plugins{a}
  kipi-plugins{a} kipi-plugins-common{a} libaccounts-qt1{a}
  libakonadi-calendar4{a} libakonadi-contact4{a} libakonadi-kabc4{a}
  libakonadi-kcal4{a} libakonadi-kde4{a} libakonadi-kmime4{a}
  libakonadi-notes4{a} libakonadi-socialutils4{a}
  libakonadiprotocolinternals1{a} libastro1{a} libbaloocore4{a}
  libbaloofiles4{a} libbalooxapian4{a} libboost-regex1.54.0{a}
  libboost-signals1.54.0{a} libdmtx0a{a} libexiv2-14{a} libgps20{a}
  libkabc4{a} libkalarmcal2{a} libkcal4{a} libkcalcore4{a} libkcalutils4{a}
  libkdcraw-data{a} libkdcraw23{a} libkexiv2-11{a} libkexiv2-data{a}
  libkface-data{a} libkface3{a} libkfbapi1{a} libkgapi2-2{a}
  libkgeomap-data{a} libkgeomap2{a} libkholidays4{a} libkimap4{a}
  libkipi-data{a} libkipi11{a} libkldap4{a} libkmbox4{a} libkmime4{a}
  libkolab0{a} libkolabxml1{a} libkpimidentities4{a} libkpimtextedit4{a}
  libkpimutils4{a} libkqoauth0{a} libkresources4{a} libksane-data{a}
  libksane0{a} libkvkontakte1{a} libmailtransport4{a} libmarblewidget18{a}
  libmediawiki1{a} libmicroblog4{a} libopencv-photo2.4{a} libpano13-2{a}
  libpano13-bin{a} libpgf6{a} libprison0{a} libqextserialport1{a}
  libqjson0{a} libqrencode3{a} libqt4-sql-mysql{ab} libqtglib-2.0-0{a}
  libqtgstreamer-0.10-0{a} libqtgstreamerutils-0.10-0{a} libqtlocation1{a}
  libqtsolutions-soap-head1{a} libquazip0{a} libraw10{a} libshp1{a}
  libsignon-qt1{a} libsqlite0{a} libvigraimpex5{a} libwlocate0{a}
  libxerces-c3.1{a} libzthread-2.3-2{a} marble-data{a} marble-plugins{a}
  mysql-client-core-5.5{a} mysql-server-core-5.5{a}
0 pacchetti aggiornati, 97 installati, 0 da rimuovere e 5 non aggiornati.
È necessario prelevare 76,9 MB di archivi. Dopo l'estrazione, verranno occupati 280 MB.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 libqt4-sql-mysql : Dipende: libqt4-sql (= 4:4.8.5+git192-g085f851+dfsg-2ubuntu4) ma 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 è installato.
                    Dipende: libqtcore4 (= 4:4.8.5+git192-g085f851+dfsg-2ubuntu4) ma 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 è installato.
Le seguenti azioni permetteranno di soddisfare queste dipendenze:

     Mantenere i seguenti pacchetti alla versione attuale:
1)     akonadi-backend-mysql [Non installato]             
2)     akonadi-server [Non installato]                   
3)     digikam [Non installato]                           
4)     kdepim-runtime [Non installato]                   
5)     libqt4-sql-mysql [Non installato]                 



Accettare questa soluzione? [Y/n/q/?] y
Nessun pacchetto verrà installato, aggiornato o rimosso.
0 pacchetti aggiornati, 0 installati, 0 da rimuovere e 5 non aggiornati.
È necessario prelevare 0 B di archivi. Dopo l'estrazione, verranno occupati 0 B.


Ma questo pacchetto indispensabile pare l'araba fenice
Codice: Seleziona tutto
sudo apt-get install kdepim-runtime
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
 kdepim-runtime : Dipende: akonadi-server (>= 1.8) ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.

sudo aptitude install kdepim-runtime
I seguenti pacchetti NUOVI (NEW) saranno installati:
  akonadi-backend-mysql{a} akonadi-server{a} kdepim-runtime
  kdepimlibs-kio-plugins{a} libaccounts-qt1{a} libakonadi-calendar4{a}
  libakonadi-contact4{a} libakonadi-kabc4{a} libakonadi-kcal4{a}
  libakonadi-kde4{a} libakonadi-kmime4{a} libakonadi-notes4{a}
  libakonadi-socialutils4{a} libakonadiprotocolinternals1{a} libdmtx0a{a}
  libkabc4{a} libkalarmcal2{a} libkcal4{a} libkcalcore4{a} libkcalutils4{a}
  libkfbapi1{a} libkgapi2-2{a} libkholidays4{a} libkimap4{a} libkldap4{a}
  libkmbox4{a} libkmime4{a} libkolab0{a} libkolabxml1{a}
  libkpimidentities4{a} libkpimtextedit4{a} libkpimutils4{a}
  libkresources4{a} libmailtransport4{a} libmicroblog4{a} libprison0{a}
  libqjson0{a} libqrencode3{a} libqt4-sql-mysql{ab} libsignon-qt1{a}
  libxerces-c3.1{a} mysql-client-core-5.5{a} mysql-server-core-5.5{a}
0 pacchetti aggiornati, 43 installati, 0 da rimuovere e 5 non aggiornati.
È necessario prelevare 13,4 MB di archivi. Dopo l'estrazione, verranno occupati 68,4 MB.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 libqt4-sql-mysql : Dipende: libqt4-sql (= 4:4.8.5+git192-g085f851+dfsg-2ubuntu4) ma 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 è installato.
                    Dipende: libqtcore4 (= 4:4.8.5+git192-g085f851+dfsg-2ubuntu4) ma 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 è installato.
Le seguenti azioni permetteranno di soddisfare queste dipendenze:

     Mantenere i seguenti pacchetti alla versione attuale:
1)     akonadi-backend-mysql [Non installato]             
2)     akonadi-server [Non installato]                   
3)     kdepim-runtime [Non installato]                   
4)     libqt4-sql-mysql [Non installato]                 



Accettare questa soluzione? [Y/n/q/?] y
Nessun pacchetto verrà installato, aggiornato o rimosso.
0 pacchetti aggiornati, 0 installati, 0 da rimuovere e 5 non aggiornati.
È necessario prelevare 0 B di archivi. Dopo l'estrazione, verranno occupati 0 B.
:muro:
Ultima modifica di neolinux il lunedì 3 dicembre 2018, 17:17, modificato 2 volte in totale.
Avatar utente
neolinux
Rampante Reduce
Rampante Reduce
 
Messaggi: 5397
Iscrizione: dicembre 2008

Re: Digikam fragile si sfascia come niente ubuntu 14.04

Messaggioda steff » sabato 8 settembre 2018, 11:06

Digikam dipende da librerie di kde, e francamente in 4 anni ci sono stati tanti i cambiamenti e sviluppi - quindi il consiglio è di passare almeno alla 16.04 se non la 18.04 o usare una live se la memoria lo consente.
Hai fatto il backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox
Avatar utente
steff
Moderatore Globale
Moderatore Globale
 
Messaggi: 37899
Iscrizione: febbraio 2007
Località: Toscana
Desktop: LXQt
Distribuzione: Arch Linux 64bit
Sesso: Maschile


Re: Digikam fragile si sfascia come niente ubuntu 14.04

Messaggioda maxbigsi » sabato 8 settembre 2018, 12:26

hai provato a dare il comando
Codice: Seleziona tutto
sudo apt-get install -f
??
W il software libero..... W Ubuntu -- Ubuntu User # 31322
Avatar utente
maxbigsi
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 16557
Iscrizione: maggio 2008
Desktop: Mate
Distribuzione: Ubuntu Mate 18.04 64bit
Sesso: Maschile

Re: Digikam fragile si sfascia come niente ubuntu 14.04

Messaggioda neolinux » sabato 8 settembre 2018, 12:30

Mi pare di si, eccolo...
Codice: Seleziona tutto
sudo apt-get install -f
[sudo] password for pc:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
0 aggiornati, 0 installati, 0 da rimuovere e 5 non aggiornati.

E da quei 5 se ricordo bene non si schioda
Avatar utente
neolinux
Rampante Reduce
Rampante Reduce
 
Messaggi: 5397
Iscrizione: dicembre 2008

Re: Digikam fragile si sfascia come niente ubuntu 14.04

Messaggioda maxbigsi » sabato 8 settembre 2018, 12:31

la versione è quella aggiornata adesso?
W il software libero..... W Ubuntu -- Ubuntu User # 31322
Avatar utente
maxbigsi
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 16557
Iscrizione: maggio 2008
Desktop: Mate
Distribuzione: Ubuntu Mate 18.04 64bit
Sesso: Maschile

Re: Digikam fragile si sfascia come niente ubuntu 14.04

Messaggioda neolinux » sabato 8 settembre 2018, 12:34

È ubuntu 14.04

Edit: sempre peggio usc digikam
Codice: Seleziona tutto
I seguenti pacchetti presentano dipendenze non soddisfatte:

digikam: Depends: digikam-data (= 4:4.14.0-trusty~ppa1) ma 4:4.14.0-trusty~ppa1 sta per essere installato


Prima potevo installare, sarà la sorgente di prima che blocca...
Codice: Seleziona tutto
sudo add-apt-repository ppa:philip5/extra
Ultima modifica di neolinux il sabato 8 settembre 2018, 12:51, modificato 2 volte in totale.
Avatar utente
neolinux
Rampante Reduce
Rampante Reduce
 
Messaggi: 5397
Iscrizione: dicembre 2008

Re: Digikam fragile si sfascia come niente ubuntu 14.04

Messaggioda maxbigsi » sabato 8 settembre 2018, 12:47

rimuovi il ppa perchè i pacchetti vanno in conflitto
Codice: Seleziona tutto
sudo ppa-purge ppa:philip5/extra
e a questo punto segui il consiglio di steff di aggiornare la distro, non ho mai fatto avanzamenti quindi non so se puoi fare il salto da 14.04 a 18.04 :nono:
W il software libero..... W Ubuntu -- Ubuntu User # 31322
Avatar utente
maxbigsi
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 16557
Iscrizione: maggio 2008
Desktop: Mate
Distribuzione: Ubuntu Mate 18.04 64bit
Sesso: Maschile

Re: Digikam fragile si sfascia come niente ubuntu 14.04

Messaggioda neolinux » sabato 8 settembre 2018, 12:53

tolta la sorgente adesso digikam è
Codice: Seleziona tutto
digiKam
Versione 3.5.0
Con piattaforma di sviluppo KDE 4.13.3

Codice: Seleziona tutto
sudo apt-get install -f
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.

Farò l'avanzamento forse è meglio 16.04?
viewtopic.php?f=30&t=630271#p5079717
Avatar utente
neolinux
Rampante Reduce
Rampante Reduce
 
Messaggi: 5397
Iscrizione: dicembre 2008

Re: Digikam fragile si sfascia come niente ubuntu 14.04

Messaggioda neolinux » lunedì 3 dicembre 2018, 17:14

Invece il problema era la lunghezza eccessiva dei nomi dei file per Digikam, Ubuntu li consente decisamente più lunghi rispetto a tanti altri programmi che NON ti avvisano.
viewtopic.php?f=73&t=630308&p=5086130#p5086130
Avatar utente
neolinux
Rampante Reduce
Rampante Reduce
 
Messaggi: 5397
Iscrizione: dicembre 2008


Torna a Multimediale

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 2 ospiti