cuffie bluetooth riconosciute ma senza audio

Installazione, configurazione e utilizzo di applicativi multimediali, masterizzazione, acquisizione e codec audio/video, streaming, ecc.

cuffie bluetooth riconosciute ma senza audio

Messaggioda elaeolo » venerdì 28 dicembre 2018, 22:34

salve, sono arrivate le pamu scroll.

Codice: Seleziona tutto
cucciolo@cucciolo:~$ cat /etc/issue
Ubuntu 16.04.5 LTS \n \l

questa è la mia versione; con xfce (ubuntu studio).

Codice: Seleziona tutto
cucciolo@cucciolo:~$ lsusb
Bus 002 Device 003: ID 1131:1001 Integrated System Solution Corp. KY-BT100 Bluetooth Adapter
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 064e:a219 Suyin Corp. 1.3M WebCam (notebook emachines E730, Acer sub-brand)
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

questo è quello che vede

con la gestione del bluetooth si connette con le cuffie (dice con porta seriale, le cuffie dicono che s'è collegato).

dalle impostazioni audio non compare il bluetooth.

ogni cosa che riproduco si sente sempre dall'altoparlantino del portatile (anche con jack).

ho seguito questo post https://forum.ubuntu-it.org/viewtopic.php?p=4951704 senza successo.
Avatar utente
elaeolo
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 272
Iscrizione: gennaio 2009
Località: asti
Distribuzione: Ubuntu Studio 16.04 lts

Re: cuffie bluetooth riconosciute ma senza audio

Messaggioda maxbigsi » sabato 29 dicembre 2018, 0:03

nella attesa del mago prova con questo comando, è un unico comando ;)
Codice: Seleziona tutto
sudo apt install pulseaudio-module-bluetooth pactl load-module module-bluetooth-discover
W il software libero..... W Ubuntu -- Ubuntu User # 31322
Avatar utente
maxbigsi
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 16382
Iscrizione: maggio 2008
Desktop: Mate
Distribuzione: Ubuntu Mate 16.04 64bit
Sesso: Maschile

Re: cuffie bluetooth riconosciute ma senza audio

Messaggioda elaeolo » sabato 29 dicembre 2018, 0:46

maxbigsi Immagine ha scritto:nella attesa del mago prova con questo comando, è un unico comando ;)
Codice: Seleziona tutto
sudo apt install pulseaudio-module-bluetooth pactl load-module module-bluetooth-discover

Codice: Seleziona tutto
cucciolo@cucciolo:~$ sudo apt install pulseaudio-module-bluetooth pactl load-module module-bluetooth-discover
[sudo] password di cucciolo:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
E: Impossibile trovare il pacchetto pactl
E: Impossibile trovare il pacchetto load-module
E: Impossibile trovare il pacchetto module-bluetooth-discover
cucciolo@cucciolo:~$
Avatar utente
elaeolo
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 272
Iscrizione: gennaio 2009
Località: asti
Distribuzione: Ubuntu Studio 16.04 lts

Re: cuffie bluetooth riconosciute ma senza audio

Messaggioda magozurlinux » mercoledì 16 gennaio 2019, 20:09

Ciao.

Da terminale postami questi comandi:

Codice: Seleziona tutto
dmesg | grep Blue


Codice: Seleziona tutto
dpkg -l | grep blue


Codice: Seleziona tutto
hciconfig -a


Codice: Seleziona tutto
rfkill list
Xubuntu 16.04 LTS 64bit :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 20512
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop
Distribuzione: Xubuntu 16.04 LTS x86_64

Re: cuffie bluetooth riconosciute ma senza audio

Messaggioda elaeolo » mercoledì 16 gennaio 2019, 20:24

Codice: Seleziona tutto
cucciolo@cucciolo:~$ dmesg | grep Blue
[  434.041990] Bluetooth: Core ver 2.22
[  434.042021] Bluetooth: HCI device and connection manager initialized
[  434.042026] Bluetooth: HCI socket layer initialized
[  434.042030] Bluetooth: L2CAP socket layer initialized
[  434.042036] Bluetooth: SCO socket layer initialized
[  437.290279] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[  437.290282] Bluetooth: BNEP filters: protocol multicast
[  437.290287] Bluetooth: BNEP socket layer initialized
[  437.713336] Bluetooth: RFCOMM TTY layer initialized
[  437.713345] Bluetooth: RFCOMM socket layer initialized
[  437.713354] Bluetooth: RFCOMM ver 1.11
cucciolo@cucciolo:~$ dpkg -l | grep blue
ii  blueman                                       2.0.4-1ubuntu2                               amd64        Graphical bluetooth manager
ii  bluez                                         5.37-0ubuntu5.1                              amd64        Bluetooth tools and daemons
ii  bluez-cups                                    5.37-0ubuntu5.1                              amd64        Bluetooth printer driver for CUPS
ii  bluez-obexd                                   5.37-0ubuntu5.1                              amd64        bluez obex daemon
ii  libbluetooth3:amd64                           5.37-0ubuntu5.1                              amd64        Library to use the BlueZ Linux Bluetooth stack
cucciolo@cucciolo:~$ hciconfig -a
hci0:   Type: BR/EDR  Bus: USB
   BD Address: 00:11:67:72:02:62  ACL MTU: 1021:8  SCO MTU: 48:10
   UP RUNNING PSCAN ISCAN
   RX bytes:518 acl:0 sco:0 events:26 errors:0
   TX bytes:613 acl:0 sco:0 commands:26 errors:0
   Features: 0xff 0xfe 0x8d 0x3e 0x88 0x19 0x00 0x00
   Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
   Link policy: RSWITCH HOLD SNIFF
   Link mode: SLAVE ACCEPT
   Name: 'cucciolo'
   Class: 0x10010c
   Service Classes: Object Transfer
   Device Class: Computer, Laptop
   HCI Version: 2.0 (0x3)  Revision: 0x2c6
   LMP Version: 2.0 (0x3)  Subversion: 0x2c6
   Manufacturer: Integrated System Solution Corp. (57)

cucciolo@cucciolo:~$ rfkill list
0: acer-wireless: Wireless LAN
   Soft blocked: no
   Hard blocked: no
1: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no
2: hci0: Bluetooth
   Soft blocked: no
   Hard blocked: no
cucciolo@cucciolo:~$


grazie, ti dice qualcosa?
Avatar utente
elaeolo
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 272
Iscrizione: gennaio 2009
Località: asti
Distribuzione: Ubuntu Studio 16.04 lts

Re: cuffie bluetooth riconosciute ma senza audio

Messaggioda magozurlinux » mercoledì 16 gennaio 2019, 20:28

Prego, di nulla!

manca questo pacchetto:

Codice: Seleziona tutto
pulseaudio-module-bluetooth


da terminale connesso ad Internet dai questi comandi:

Codice: Seleziona tutto
sudo apt-get update


Codice: Seleziona tutto
sudo apt-get install pulseaudio-module-bluetooth
Xubuntu 16.04 LTS 64bit :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 20512
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop
Distribuzione: Xubuntu 16.04 LTS x86_64

Re: cuffie bluetooth riconosciute ma senza audio

Messaggioda elaeolo » mercoledì 16 gennaio 2019, 23:28

grazie, l'ho fatto, si connette come prima (sempre solo come porta seriale, gli altri modi di connessione falliscono), le cuffie producono un suono di connessione, l'audio non viene instradato verso le cuffie, ma sempre verso l'altoparlante del portatile.
cosa sbaglio?
Avatar utente
elaeolo
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 272
Iscrizione: gennaio 2009
Località: asti
Distribuzione: Ubuntu Studio 16.04 lts

Re: cuffie bluetooth riconosciute ma senza audio

Messaggioda maxbigsi » giovedì 17 gennaio 2019, 12:59

controlla i livelli dell'audio da terminale col comando alsamixer
W il software libero..... W Ubuntu -- Ubuntu User # 31322
Avatar utente
maxbigsi
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 16382
Iscrizione: maggio 2008
Desktop: Mate
Distribuzione: Ubuntu Mate 16.04 64bit
Sesso: Maschile

Re: cuffie bluetooth riconosciute ma senza audio

Messaggioda magozurlinux » giovedì 17 gennaio 2019, 13:06

elaeolo Immagine ha scritto:grazie, l'ho fatto, si connette come prima (sempre solo come porta seriale, gli altri modi di connessione falliscono), le cuffie producono un suono di connessione, l'audio non viene instradato verso le cuffie, ma sempre verso l'altoparlante del portatile.
cosa sbaglio?


Clicca sull'icona dell'altoparlante, vai su Impostazioni audio.... > Uscite, sotto l'icona della scheda audio dovresti vedere l'icona della cuffia bluetooth, a destra c'è un menu a tendina, per default è impostato sulla scheda audio integrata, cliccaci sopra e seleziona la cuffia bluetooth.
Xubuntu 16.04 LTS 64bit :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 20512
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop
Distribuzione: Xubuntu 16.04 LTS x86_64

Re: cuffie bluetooth riconosciute ma senza audio

Messaggioda elaeolo » giovedì 17 gennaio 2019, 21:29

magozurlinux Immagine ha scritto:Clicca sull'icona dell'altoparlante, vai su Impostazioni audio.... > Uscite, sotto l'icona della scheda audio dovresti vedere l'icona della cuffia bluetooth


no, ci sono solo: altoparlanti e cuffie analogiche (unplugged)

il pop up del bluetooth dice: connesso a sincronizzazione audio su pamu scroll

però l'audio, come giustamente dici tu, va solo verso l'altoparlante, dato che pulseaudio non le vede
Avatar utente
elaeolo
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 272
Iscrizione: gennaio 2009
Località: asti
Distribuzione: Ubuntu Studio 16.04 lts

Re: cuffie bluetooth riconosciute ma senza audio

Messaggioda elaeolo » giovedì 17 gennaio 2019, 21:34

maxbigsi Immagine ha scritto:controlla i livelli dell'audio da terminale col comando alsamixer

grazie, ho provato, ho alzato headphon (che sono le uniche cuffie che vede), ma nulla
Avatar utente
elaeolo
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 272
Iscrizione: gennaio 2009
Località: asti
Distribuzione: Ubuntu Studio 16.04 lts

Re: cuffie bluetooth riconosciute ma senza audio

Messaggioda magozurlinux » venerdì 18 gennaio 2019, 12:26

Connesso ad Internet da terminale dai questo comando:

Codice: Seleziona tutto
sudo apt-get install bluez-tools


Con la cuffia bluetooth accesa, da terminale postami questo comando:

Codice: Seleziona tutto
hcitool scan
Xubuntu 16.04 LTS 64bit :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 20512
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop
Distribuzione: Xubuntu 16.04 LTS x86_64

Re: cuffie bluetooth riconosciute ma senza audio

Messaggioda elaeolo » venerdì 18 gennaio 2019, 21:25

Codice: Seleziona tutto
cucciolo@cucciolo:~$ sudo apt-get install bluez-tools
[sudo] password di cucciolo:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti NUOVI saranno installati:
  bluez-tools
0 aggiornati, 1 installati, 0 da rimuovere e 0 non aggiornati.
È necessario scaricare 138 kB di archivi.
Dopo quest'operazione, verranno occupati 938 kB di spazio su disco.
Scaricamento di:1 http://it.archive.ubuntu.com/ubuntu xenial/universe amd64 bluez-tools amd64 0.2.0~20140808-5 [138 kB]
Recuperati 138 kB in 0s (203 kB/s) 
Selezionato il pacchetto bluez-tools non precedentemente selezionato.
(Lettura del database... 335826 file e directory attualmente installati.)
Preparativi per estrarre .../bluez-tools_0.2.0~20140808-5_amd64.deb...
Estrazione di bluez-tools (0.2.0~20140808-5)...
Elaborazione dei trigger per man-db (2.7.5-1)...
Configurazione di bluez-tools (0.2.0~20140808-5)...
cucciolo@cucciolo:~$ hcitool scan
Scanning ...
cucciolo@cucciolo:~$
Avatar utente
elaeolo
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 272
Iscrizione: gennaio 2009
Località: asti
Distribuzione: Ubuntu Studio 16.04 lts

Re: cuffie bluetooth riconosciute ma senza audio

Messaggioda magozurlinux » sabato 19 gennaio 2019, 11:53

Nelle cuffie c'è un tasto per fare il pairing?

Durante il pairing, da terminale postami questo comando:

Codice: Seleziona tutto
hcitool scan
Xubuntu 16.04 LTS 64bit :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 20512
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop
Distribuzione: Xubuntu 16.04 LTS x86_64

Re: cuffie bluetooth riconosciute ma senza audio

Messaggioda elaeolo » sabato 19 gennaio 2019, 12:20

magozurlinux Immagine ha scritto:Nelle cuffie c'è un tasto per fare il pairing?

Durante il pairing, da terminale postami questo comando:

Codice: Seleziona tutto
hcitool scan


il tasto non c'è, perché togliendole dalla custodia di carica si accendono e vanno in pairing in automatico.

Codice: Seleziona tutto
cucciolo@cucciolo:~$ hcitool scan
Scanning ...
   00:00:00:01:66:E0   PaMu Scroll
cucciolo@cucciolo:~$
Avatar utente
elaeolo
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 272
Iscrizione: gennaio 2009
Località: asti
Distribuzione: Ubuntu Studio 16.04 lts

Re: cuffie bluetooth riconosciute ma senza audio

Messaggioda magozurlinux » sabato 19 gennaio 2019, 13:02

OK!

Da terminale postami questo comando:

Codice: Seleziona tutto
cat /etc/bluetooth/audio.conf
Xubuntu 16.04 LTS 64bit :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 20512
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop
Distribuzione: Xubuntu 16.04 LTS x86_64

Re: cuffie bluetooth riconosciute ma senza audio

Messaggioda elaeolo » sabato 19 gennaio 2019, 13:32

Codice: Seleziona tutto
cucciolo@cucciolo:~$ cat /etc/bluetooth/audio.conf
# Configuration file for the audio service

# This section contains options which are not specific to any
# particular interface
[General]
Disable=Socket

# Switch to master role for incoming connections (defaults to true)
#Master=true

# If we want to disable support for specific services
# Defaults to supporting all implemented services
#Disable=Control,Source

# SCO routing. Either PCM or HCI (in which case audio is routed to/from ALSA)
# Defaults to HCI
#SCORouting=PCM

# Automatically connect both A2DP and HFP/HSP profiles for incoming
# connections. Some headsets that support both profiles will only connect the
# other one automatically so the default setting of true is usually a good
# idea.
#AutoConnect=true

# Headset interface specific options (i.e. options which affect how the audio
# service interacts with remote headset devices)
[Headset]

# Set to true to support HFP, false means only HSP is supported
# Defaults to true
HFP=true

# Maximum number of connected HSP/HFP devices per adapter. Defaults to 1
MaxConnected=1

# Set to true to enable use of fast connectable mode (faster page scanning)
# for HFP when incomming call starts. Default settings are restored after
# call is answered or rejected. Page scan interval is much shorter and page
# scan type changed to interlaced. Such allows faster connection initiated
# by a headset.
FastConnectable=false

# Just an example of potential config options for the other interfaces
#[A2DP]
#SBCSources=1
#MPEG12Sources=0
cucciolo@cucciolo:~$
Avatar utente
elaeolo
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 272
Iscrizione: gennaio 2009
Località: asti
Distribuzione: Ubuntu Studio 16.04 lts

Re: cuffie bluetooth riconosciute ma senza audio

Messaggioda magozurlinux » sabato 19 gennaio 2019, 13:40

Da terminale dai questi comandi:

Codice: Seleziona tutto
sudo -H gedit /etc/bluetooth/audio.conf


scorri il file, sotto questo:

Codice: Seleziona tutto
Disable=Socket


aggiungi questa riga:

Codice: Seleziona tutto
Enable=Media,Source,Sink,Gateway


salva ed esci dall'editor di testo.

Codice: Seleziona tutto
sudo service bluetooth restart


Codice: Seleziona tutto
sudo pactl load-module module-bluetooth-discover
Xubuntu 16.04 LTS 64bit :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 20512
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop
Distribuzione: Xubuntu 16.04 LTS x86_64

Re: cuffie bluetooth riconosciute ma senza audio

Messaggioda elaeolo » sabato 19 gennaio 2019, 13:57

ho fatto, ho riavviato anche il computer, ma nulla.
è cambiato il fatto che adesso posso collegarle anche come handsfree e headsphone e sincronizzazione audio (prima solo come serial port)
nelle impostazioni trovo solo "altoparlanti" e "cuffie analogiche (unplugged)"; entrambi non mandano l'audio alle cuffie bt
Avatar utente
elaeolo
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 272
Iscrizione: gennaio 2009
Località: asti
Distribuzione: Ubuntu Studio 16.04 lts

Re: cuffie bluetooth riconosciute ma senza audio

Messaggioda magozurlinux » sabato 19 gennaio 2019, 18:57

Clicca sull'icona del bluetooth, scorri l'elenco, seleziona Dispositivi..., si aprirà Blueman, vedrai l'icona della cuffia, cliccaci su col tasto destro, vai su Rimuovi, chiudi l'icona.

Clicca sull'icona del bluetooth, vai su Imposta nuovo dispositivo, clicca su Successivo, dovresti vedere il nome della tua cuffia, clicca su Successivo, seleziona Headset, clicca su Successivo, dovresti sentire 2 beep nella cuffia, chiudi l'icona.

Clicca sull'icona del Bluetooth, vai su Dispositivi...., clicca col tasto destro sull'icona della cuffia bt, vai su Profilo audio seleziona Riproduzione ad alta fedeltà (sink A2DP).

Vedi se così funziona la cuffia bt.

Se ancora non dovesse funzionare, vai sull'Icona dell'altoparlante > Impostazioni Audio... > Uscite, in basso dovresti vedere la tua cuffia bt, se c'è controlla che sia impostato sulla cuffia bt e non sulla scheda audio integrata. (vedi foto) La mia cuffia bluetooth è 5800
Allegati
cuffia bluetooth.png
Xubuntu 16.04 LTS 64bit :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 20512
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop
Distribuzione: Xubuntu 16.04 LTS x86_64

Successiva

Torna a Multimediale

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 5 ospiti