[Risolto] Risoluzione bloccata

Installazione, configurazione e utilizzo di applicativi multimediali, masterizzazione, acquisizione e codec audio/video, streaming e altro.
Avatar utente
maxbigsi
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 16833
Iscrizione: mercoledì 21 maggio 2008, 14:05
Desktop: Mate
Distribuzione: Ubuntu Mate 18.04 64bit
Sesso: Maschile

[Risolto] Risoluzione bloccata

Messaggio da maxbigsi » sabato 18 gennaio 2020, 12:39

Salve a tutti, stamattina accendo il pc e vedo che la risoluzione del monitor è bloccata a 1024x768 premesso che ho un vecchio monitor Samsung a 4:3 sempre correttamente riconosciuto ma in questa occasione mi dice che non lo riconosce, ho tentato di installare gli open ma non è stato possibile da Drivers aggiuntivi, quindi ho purgato da terminale gli nvidia e al riavvio la risoluzione era di nuovo corretta ma mi sono accorto che le macchine virtuali con virtualbox non mi si avviano, ho tentato di reinstallare gli nvidia ma adesso ho dei pacchetti danneggiati, sono certo che l'aggiornamento di ieri ha creato un casotto di cui non riesco a venirne fuori, è comparso anche il senso vietato sulla barra sotto :D vi posto alcuni comandi per farvi rendere conto... ho provato ad avviare anche con gli altri due kernel precedenti ma la situazione non cambia. Adesso che mi ricordo ho installato HWE Stack la settimana scorsa e credo che questi siano gli inconvenienti. :muro:

Codice: Seleziona tutto

max@max:~$ lspci | grep -E 'VGA|Display|3D'
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 430] (rev a1)

Codice: Seleziona tutto

sudo lshw -c display | grep driver
non da nessun output

Codice: Seleziona tutto

max@max:~$ glxinfo | grep render
direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
    GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer, GLX_MESA_query_renderer, 
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: llvmpipe (LLVM 9.0, 256 bits)
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth, 
    GL_MESA_ycbcr_texture, GL_NV_conditional_render, GL_NV_depth_clamp, 
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth, 
    GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_fog_distance, 
    GL_MESA_shader_integer_functions, GL_NV_conditional_render, 
    GL_OES_element_index_uint, GL_OES_fbo_render_mipmap, 

Codice: Seleziona tutto

max@max:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 0mm x 0mm
   1024x768       0.00* 
   800x600        0.00  
   640x480        0.00  

Codice: Seleziona tutto

max@max:~$ sudo apt update
Ignorato:1 http://liveusb.info/multisystem/depot all InRelease
Trovato:2 http://it.archive.ubuntu.com/ubuntu bionic InRelease                 
Trovato:3 http://it.archive.ubuntu.com/ubuntu bionic-updates InRelease         
Trovato:4 http://liveusb.info/multisystem/depot all Release                    
Trovato:5 http://it.archive.ubuntu.com/ubuntu bionic-backports InRelease       
Trovato:6 http://linux.teamviewer.com/deb stable InRelease                     
Scaricamento di:7 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]
Trovato:8 http://ppa.launchpad.net/audio-recorder/ppa/ubuntu bionic InRelease  
Trovato:9 http://ppa.launchpad.net/mc3man/mpv-tests/ubuntu bionic InRelease    
Scaricamento di:10 https://mega.nz/linux/MEGAsync/xUbuntu_18.04 ./ InRelease [1.310 B]
Recuperati 90,0 kB in 1s (72,2 kB/s)                             
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Tutti i pacchetti sono aggiornati.

Codice: Seleziona tutto

max@max:~$ sudo apt upgrade
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt --fix-broken install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 libnvidia-ifr1-390 : Dipende: libnvidia-gl-390 ma non è installato
 libnvidia-ifr1-390:i386 : Dipende: libnvidia-gl-390:i386 ma non è installato
 nvidia-driver-390 : Dipende: libnvidia-gl-390 (= 390.116-0ubuntu0.18.04.1) ma non è installato
                     Raccomanda: libnvidia-gl-390:i386 (= 390.116-0ubuntu0.18.04.1)
E: Dipendenze non soddisfatte. Provare "apt --fix-broken install" senza pacchetti (o specificare una soluzione).

Codice: Seleziona tutto

max@max:~$ sudo apt --fix-broken install
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti aggiuntivi saranno inoltre installati:
  libnvidia-gl-390 libnvidia-gl-390:i386
I seguenti pacchetti NUOVI saranno installati:
  libnvidia-gl-390 libnvidia-gl-390:i386
0 aggiornati, 2 installati, 0 da rimuovere e 0 non aggiornati.
3 non completamente installati o rimossi.
È necessario scaricare 0 B/29,2 MB di archivi.
Dopo quest'operazione, verranno occupati 147 MB di spazio su disco.
Continuare? [S/n] s
(Lettura del database... 295697 file e directory attualmente installati.)
Preparativi per estrarre .../libnvidia-gl-390_390.116-0ubuntu0.18.04.1_i386.deb...
deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 in /usr/lib/i386-linux-gnu/libGL.so.1.distrib da nvidia-340
dpkg-divert: errore: corrispondenza errata sul pacchetto
  nel rimuovere "deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 da libnvidia-gl-390"
  trovato "deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 in /usr/lib/i386-linux-gnu/libGL.so.1.distrib da nvidia-340"
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libnvidia-gl-390_390.116-0ubuntu0.18.04.1_i386.deb (--unpack):
 il sottoprocesso nuovo pacchetto libnvidia-gl-390:i386 script pre-installation ha restituito lo stato di errore 2
Preparativi per estrarre .../libnvidia-gl-390_390.116-0ubuntu0.18.04.1_amd64.deb...
deviazione di /usr/lib/x86_64-linux-gnu/libGL.so.1 in /usr/lib/x86_64-linux-gnu/libGL.so.1.distrib da nvidia-340
dpkg-divert: errore: corrispondenza errata sul pacchetto
  nel rimuovere "deviazione di /usr/lib/x86_64-linux-gnu/libGL.so.1 da libnvidia-gl-390"
  trovato "deviazione di /usr/lib/x86_64-linux-gnu/libGL.so.1 in /usr/lib/x86_64-linux-gnu/libGL.so.1.distrib da nvidia-340"
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libnvidia-gl-390_390.116-0ubuntu0.18.04.1_amd64.deb (--unpack):
 il sottoprocesso nuovo pacchetto libnvidia-gl-390:amd64 script pre-installation ha restituito lo stato di errore 2
Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/libnvidia-gl-390_390.116-0ubuntu0.18.04.1_i386.deb
 /var/cache/apt/archives/libnvidia-gl-390_390.116-0ubuntu0.18.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Codice: Seleziona tutto

max@max:~$ sudo dpkg --configure -a
dpkg: problemi con le dipendenze impediscono la configurazione di nvidia-driver-390:
 nvidia-driver-390 dipende da libnvidia-gl-390 (= 390.116-0ubuntu0.18.04.1); tuttavia:
  Il pacchetto libnvidia-gl-390:amd64 non è installato.

dpkg: errore nell'elaborare il pacchetto nvidia-driver-390 (--configure):
 problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di libnvidia-ifr1-390:i386:
 libnvidia-ifr1-390:i386 dipende da libnvidia-gl-390; tuttavia:
  Il pacchetto libnvidia-gl-390:i386 non è installato.

dpkg: errore nell'elaborare il pacchetto libnvidia-ifr1-390:i386 (--configure):
 problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di libnvidia-ifr1-390:amd64:
 libnvidia-ifr1-390:amd64 dipende da libnvidia-gl-390; tuttavia:
  Il pacchetto libnvidia-gl-390:amd64 non è installato.

dpkg: errore nell'elaborare il pacchetto libnvidia-ifr1-390:amd64 (--configure):
 problemi con le dipendenze - lasciato non configurato
Elaborazione dei trigger per libc-bin (2.27-3ubuntu1)...
Si sono verificati degli errori nell'elaborazione:
 nvidia-driver-390
 libnvidia-ifr1-390:i386
 libnvidia-ifr1-390:amd64
Ultima modifica di maxbigsi il sabato 18 gennaio 2020, 14:18, modificato 1 volta in totale.
W il software libero..... W Ubuntu -- Ubuntu User # 31322

Avatar utente
frapox
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1110
Iscrizione: sabato 31 dicembre 2005, 19:22
Desktop: Gnome 3
Distribuzione: Arch, Debian Sid
Località: Lombardia

Re: Risoluzione bloccata

Messaggio da frapox » sabato 18 gennaio 2020, 13:26

Purga tutto ciò che è purgabile di collegato a nvidia:

Codice: Seleziona tutto

sudo apt purge --autoremove *nvidia*
Poi

Codice: Seleziona tutto

sudo dpkg --configure -a
sudo apt install -f
sudo apt update
auto apt autoremove --purge
sudo apt dist-upgrade
A questo punto riavvia, e poi puoi pensare di reinstallare gli nvidia proprietari, anche tramite la Gui, oppure con:

Codice: Seleziona tutto

sudo apt install nvidia-396
oppure la versione che preferisci.

Avatar utente
maxbigsi
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 16833
Iscrizione: mercoledì 21 maggio 2008, 14:05
Desktop: Mate
Distribuzione: Ubuntu Mate 18.04 64bit
Sesso: Maschile

Re: Risoluzione bloccata

Messaggio da maxbigsi » sabato 18 gennaio 2020, 14:17

grazie frapox ma non è bastato solo quello :nono: ho rimosso da terminale lo stack HWE col comando

Codice: Seleziona tutto

max@max:~$ sudo apt remove xserver-xorg-core-hwe-18.04 xserver-xorg-input-all-hwe-18.04 linux-generic-hwe-18.04 xserver-xorg-video-all-hwe-18.04
a questo punto si bloccava su gdm e ho dovuto riavviare da console di recovery e ho installato ubuntu-mate-desktop con relative dipendenze, avviatosi normalmente ho rimosso il kernel hwe stack manualmente da synaptic e adesso ho ripreso il controllo e sono con i drivers open che per il momento lascio :D ero entrato in una spirale del "cane che si morde la coda" :D magari più in là riprovo con gli nvidia visto che cerco di risolvere il problema dalle 10:30 di stamattina, colpa mia che mi è sfuggita la parte di rimuovere prima i drivers proprietari nel wiki, ti ringrazio delle dritte :birra:
W il software libero..... W Ubuntu -- Ubuntu User # 31322

Avatar utente
frapox
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1110
Iscrizione: sabato 31 dicembre 2005, 19:22
Desktop: Gnome 3
Distribuzione: Arch, Debian Sid
Località: Lombardia

Re: [Risolto] Risoluzione bloccata

Messaggio da frapox » sabato 18 gennaio 2020, 17:49

Mi sarebbe piaciuto capire come mai non ti partiva gdm -- non credo che la colpa fosse del kernel o di xorg più recenti -- ma... va bene che hai risolto :)

Avatar utente
maxbigsi
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 16833
Iscrizione: mercoledì 21 maggio 2008, 14:05
Desktop: Mate
Distribuzione: Ubuntu Mate 18.04 64bit
Sesso: Maschile

Re: [Risolto] Risoluzione bloccata

Messaggio da maxbigsi » sabato 18 gennaio 2020, 17:53

frapox [url=https://forum.ubuntu-it.org/viewtopic.php?p=5172219#p5172219][img]https://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:Mi sarebbe piaciuto capire come mai non ti partiva gdm -- non credo che la colpa fosse del kernel o di xorg più recenti -- ma... va bene che hai risolto :)
di fatto gdm partiva ma il puntatore del mouse rimaneva bloccato e non mi faceva mettere la password, adesso funziona tutto :birra:
W il software libero..... W Ubuntu -- Ubuntu User # 31322

Scrivi risposta

Ritorna a “Multimediale”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 5 ospiti