[Risolto] Crontab non avvia script

Compilazione del kernel, gestione moduli, servizi attivi, e tutti gli interventi per l'ottimizzazione del sistema operativo.

[Risolto] Crontab non avvia script

Messaggioda VitoDoc » mercoledì 24 gennaio 2018, 16:55

Salve, sto cercando di far partire uno script inserito nel crontab ma non succede nulla.
Codice: Seleziona tutto
crontab -l
*/2 * * * *  /home/vitodoc/nomescript.sh

Lo script funziona se lanciato da terminale o con semplice clic sul file.

Ho letto molte discussioni dove dicevano di inserire una riga vuota dopo il comando, di aggiungere il nome utente prima della patch ma nulla di tutto questo ha funzionato.

EDIT: Come non detto, ho risolto. Ho inserito export DISPLAY=:0.0; prima della patch. Nonostante lo avessi già fatto, sicuramente avevo sbagliato a scrivere qualcosa.

Codice: Seleziona tutto
crontab -l
*/2 * * * *  export DISPLAY=:0.0; /home/vitodoc/nomescript.sh
Ultima modifica di VitoDoc il mercoledì 24 gennaio 2018, 17:06, modificato 1 volta in totale.
La probabilita' che qualcuno ti osservi e' direttamente proporzionale alla stupidita' della tua azione.
Avatar utente
VitoDoc
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2038
Iscrizione: maggio 2012
Desktop: plasma
Distribuzione: KUbuntu 18.04 LTS
Sesso: Maschile

Re: Crontab non avvia script

Messaggioda thece » mercoledì 24 gennaio 2018, 17:05

:ciao:

credo di sapere dove stia il problema ma se fai un pò di log e lo scopri da te è meglio

Codice: Seleziona tutto
*/2 * * * *  /home/vitodoc/nomescript.sh > /tmp/nomescript.log 2>&1
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 10232
Iscrizione: aprile 2007
Distribuzione: Debian 9 (Stretch) - KDE

Re: [Risolto] Crontab non avvia script

Messaggioda VitoDoc » mercoledì 24 gennaio 2018, 17:11

Grazie @thace per la risposta....avevo risolto mentre tu postavi :)
La probabilita' che qualcuno ti osservi e' direttamente proporzionale alla stupidita' della tua azione.
Avatar utente
VitoDoc
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2038
Iscrizione: maggio 2012
Desktop: plasma
Distribuzione: KUbuntu 18.04 LTS
Sesso: Maschile

Re: [Risolto] Crontab non avvia script

Messaggioda thece » mercoledì 24 gennaio 2018, 17:18

VitoDoc Immagine ha scritto:Grazie @thace per la risposta....avevo risolto mentre tu postavi :)

Mancava qualche path?
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 10232
Iscrizione: aprile 2007
Distribuzione: Debian 9 (Stretch) - KDE

Re: [Risolto] Crontab non avvia script

Messaggioda VitoDoc » mercoledì 24 gennaio 2018, 17:29

Sicuramente avevo sbagliato a scrivere DISPLAY....Mi capita spesso fare ORRORI di battitura :D tanto è vero che l'ho rifatto in questo momento....avevo scritto DYPLAY :D
La probabilita' che qualcuno ti osservi e' direttamente proporzionale alla stupidita' della tua azione.
Avatar utente
VitoDoc
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2038
Iscrizione: maggio 2012
Desktop: plasma
Distribuzione: KUbuntu 18.04 LTS
Sesso: Maschile


Torna a Kernel e servizi di sistema

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 5 ospiti