[Risolto] Problema Eclipse su ubuntu 17.04

Utilizzo di applicazioni in ambito professionale.

[Risolto] Problema Eclipse su ubuntu 17.04

Messaggioda damy kosko » sabato 14 ottobre 2017, 16:45

Salve a tutti, oggi ho installato il jdk sul mio ubuntu ed eclipse, ma non riesco ad aprirlo, perchè mi viene dato un errore che trovo nel file log che riporto di seguito:
Codice: Seleziona tutto
!SESSION 2017-10-14 16:42:39.636 -----------------------------------------------
eclipse.buildId=debbuild
java.version=9-Ubuntu
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=it_IT
Command-line arguments:  -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.osgi 4 0 2017-10-14 16:42:47.847
!MESSAGE error loading hook: org.eclipse.osgi.internal.baseadaptor.BaseHookConfigurator
!STACK 0
java.lang.reflect.InaccessibleObjectException: Unable to make protected void java.net.URLClassLoader.addURL(java.net.URL) accessible: module java.base does not "opens java.net" to unnamed module @60c6f5b
   at java.base/java.lang.reflect.AccessibleObject.checkCanSetAccessible(AccessibleObject.java:335)
   at java.base/java.lang.reflect.AccessibleObject.checkCanSetAccessible(AccessibleObject.java:278)
   at java.base/java.lang.reflect.Method.checkCanSetAccessible(Method.java:196)
   at java.base/java.lang.reflect.Method.setAccessible(Method.java:190)
   at org.eclipse.osgi.internal.baseadaptor.BaseStorage.findMethod(BaseStorage.java:174)
   at org.eclipse.osgi.internal.baseadaptor.BaseStorage.findMethod(BaseStorage.java:181)
   at org.eclipse.osgi.internal.baseadaptor.BaseStorage.findAddURLMethod(BaseStorage.java:165)
   at org.eclipse.osgi.internal.baseadaptor.BaseStorage.<init>(BaseStorage.java:135)
   at org.eclipse.osgi.internal.baseadaptor.BaseHookConfigurator.addHooks(BaseHookConfigurator.java:24)
   at org.eclipse.osgi.baseadaptor.HookRegistry.loadConfigurators(HookRegistry.java:178)
   at org.eclipse.osgi.baseadaptor.HookRegistry.initialize(HookRegistry.java:100)
   at org.eclipse.osgi.baseadaptor.BaseAdaptor.<init>(BaseAdaptor.java:98)
   at java.base/jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
   at java.base/jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
   at java.base/jdk.internal.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
   at java.base/java.lang.reflect.Constructor.newInstance(Constructor.java:473)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.createAdaptor(EclipseStarter.java:737)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:258)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:176)
   at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
   at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.base/java.lang.reflect.Method.invoke(Method.java:547)
   at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
   at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
   at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
   at org.eclipse.equinox.launcher.Main.main(Main.java:1414)

!ENTRY org.eclipse.osgi 4 0 2017-10-14 16:42:47.878
!MESSAGE Startup error
!STACK 1
java.lang.NullPointerException
   at org.eclipse.osgi.baseadaptor.BaseAdaptor.initializeStorage(BaseAdaptor.java:123)
   at org.eclipse.osgi.framework.internal.core.Framework.<init>(Framework.java:192)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:262)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:176)
   at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
   at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.base/java.lang.reflect.Method.invoke(Method.java:547)
   at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
   at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
   at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
   at org.eclipse.equinox.launcher.Main.main(Main.java:1414)

Come posso risolvere? grazie mille :D :D
Ultima modifica di damy kosko il martedì 17 ottobre 2017, 19:30, modificato 1 volta in totale.
Damiano Cosco
Avatar utente
damy kosko
Prode Principiante
 
Messaggi: 167
Iscrizione: marzo 2010
Desktop: ubuntu
Distribuzione: 17.04 x86_64
Sesso: Maschile

Re: Problema esecuzione Eclipse su ubuntu 17.04

Messaggioda damy kosko » domenica 15 ottobre 2017, 11:23

niente?? devo trovare un altro software? :( :( :(
Damiano Cosco
Avatar utente
damy kosko
Prode Principiante
 
Messaggi: 167
Iscrizione: marzo 2010
Desktop: ubuntu
Distribuzione: 17.04 x86_64
Sesso: Maschile

Re: Problema esecuzione Eclipse su ubuntu 17.04

Messaggioda Roberto Pontecorvi » lunedì 16 ottobre 2017, 12:10

Roberto Pontecorvi
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4498
Iscrizione: maggio 2009
Località: Versilia
Distribuzione: 16.4 mate - 18.4 mate
Sesso: Maschile

Re: Problema esecuzione Eclipse su ubuntu 17.04

Messaggioda damy kosko » lunedì 16 ottobre 2017, 13:30

si ho provato sia tramite installazione manuale che da gestore pacchetti, ma nulla
Damiano Cosco
Avatar utente
damy kosko
Prode Principiante
 
Messaggi: 167
Iscrizione: marzo 2010
Desktop: ubuntu
Distribuzione: 17.04 x86_64
Sesso: Maschile

Re: Problema esecuzione Eclipse su ubuntu 17.04

Messaggioda Gerry Ghetto » lunedì 16 ottobre 2017, 14:30

damy kosko Immagine ha scritto:niente?? devo trovare un altro software? :( :( :(

Sì, infatti devi trovare un altro software.
Scusate il mio italiano. Non è la mia madrelingua.
forum.ubuntu-it.org - il peggior forum che conosco
Gerry Ghetto
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1571
Iscrizione: marzo 2015

Re: Problema esecuzione Eclipse su ubuntu 17.04

Messaggioda damy kosko » lunedì 16 ottobre 2017, 14:36

Gerry Ghetto Immagine ha scritto:
damy kosko Immagine ha scritto:niente?? devo trovare un altro software? :( :( :(

Sì, infatti devi trovare un altro software.


ma seriamente? non posso credere che Eclipse non riesce a girare su ubuntu... é tra i piú usati
Damiano Cosco
Avatar utente
damy kosko
Prode Principiante
 
Messaggi: 167
Iscrizione: marzo 2010
Desktop: ubuntu
Distribuzione: 17.04 x86_64
Sesso: Maschile

Re: Problema esecuzione Eclipse su ubuntu 17.04

Messaggioda Gerry Ghetto » lunedì 16 ottobre 2017, 15:04

Quale Eclipse hai installato? Perché hai installato Java 9? Funziona con Java 8?
Scusate il mio italiano. Non è la mia madrelingua.
forum.ubuntu-it.org - il peggior forum che conosco
Gerry Ghetto
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1571
Iscrizione: marzo 2015

Re: Problema esecuzione Eclipse su ubuntu 17.04

Messaggioda damy kosko » lunedì 16 ottobre 2017, 15:32

Gerry Ghetto Immagine ha scritto:Quale Eclipse hai installato? Perché hai installato Java 9? Funziona con Java 8?

inizialmente avevo installato l'8, ma mi davo lo stesso problema e ho provato ad aggiornare per vedere se riuscivo a risolvere, ma a quanto pare nulla... :nono: :nono: :nono:
Damiano Cosco
Avatar utente
damy kosko
Prode Principiante
 
Messaggi: 167
Iscrizione: marzo 2010
Desktop: ubuntu
Distribuzione: 17.04 x86_64
Sesso: Maschile

Re: Problema esecuzione Eclipse su ubuntu 17.04

Messaggioda DoctorStrange » lunedì 16 ottobre 2017, 16:01

Ma vaaa, Eclipse funziona benissimo sotto linux, io stesso lo uso. Il problema è, semmai l'installazione di java che, sotto linux è un pò più impegnativa.

Consiglio la lettura di questa wiki, soprattutto i punti 10 ed 11 della suddetta guida.

Posta poi il risultato di questo comando combinato:

Codice: Seleziona tutto
sudo uname -a && java -version && update-alternatives --display java && update-alternatives --display javac && update-alternatives --display jar && update-alternatives --display javaws
Avatar utente
DoctorStrange
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1122
Iscrizione: ottobre 2015
Località: Roma, Italia
Desktop: Unity
Distribuzione: Ubuntu 16.04.03 Xenial Xerus
Sesso: Maschile

Re: Problema esecuzione Eclipse su ubuntu 17.04

Messaggioda damy kosko » lunedì 16 ottobre 2017, 16:51

harpefalcata Immagine ha scritto:Ma vaaa, Eclipse funziona benissimo sotto linux, io stesso lo uso. Il problema è, semmai l'installazione di java che, sotto linux è un pò più impegnativa.

Consiglio la lettura di questa wiki, soprattutto i punti 10 ed 11 della suddetta guida.

Posta poi il risultato di questo comando combinato:

Codice: Seleziona tutto
sudo uname -a && java -version && update-alternatives --display java && update-alternatives --display javac && update-alternatives --display jar && update-alternatives --display javaws

ok il risultato è il seguente
Codice: Seleziona tutto
sudo uname -a && java -version && update-alternatives --display java && update-alternatives --display javac && update-alternatives --display jar && update-alternatives --display javaws
[sudo] password di damiano:
Linux damiano-Studio 4.10.0-37-generic #41-Ubuntu SMP Fri Oct 6 20:20:37 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
openjdk version "9-Ubuntu"
OpenJDK Runtime Environment (build 9-Ubuntu+0-9b161-1)
OpenJDK 64-Bit Server VM (build 9-Ubuntu+0-9b161-1, mixed mode)
java - modalità automatica
  link best version is /usr/lib/jvm/java-9-openjdk-amd64/bin/java
  il collegamento attualmente punta a /usr/lib/jvm/java-9-openjdk-amd64/bin/java
  link java is /usr/bin/java
  slave java.1.gz is /usr/share/man/man1/java.1.gz
/usr/bin/gij-6 - priorità 1060
  slave java.1.gz: /usr/share/man/man1/gij-6.1.gz
/usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java - priorità 1081
  slave java.1.gz: /usr/lib/jvm/java-8-openjdk-amd64/jre/man/man1/java.1.gz
/usr/lib/jvm/java-9-openjdk-amd64/bin/java - priorità 1091
  slave java.1.gz: /usr/lib/jvm/java-9-openjdk-amd64/man/man1/java.1.gz
javac - modalità automatica
  link best version is /usr/lib/jvm/java-9-openjdk-amd64/bin/javac
  il collegamento attualmente punta a /usr/lib/jvm/java-9-openjdk-amd64/bin/javac
  link javac is /usr/bin/javac
  slave javac.1.gz is /usr/share/man/man1/javac.1.gz
/usr/lib/jvm/java-8-openjdk-amd64/bin/javac - priorità 1081
  slave javac.1.gz: /usr/lib/jvm/java-8-openjdk-amd64/man/man1/javac.1.gz
/usr/lib/jvm/java-9-openjdk-amd64/bin/javac - priorità 1091
  slave javac.1.gz: /usr/lib/jvm/java-9-openjdk-amd64/man/man1/javac.1.gz
jar - modalità automatica
  link best version is /usr/lib/jvm/java-9-openjdk-amd64/bin/jar
  il collegamento attualmente punta a /usr/lib/jvm/java-9-openjdk-amd64/bin/jar
  link jar is /usr/bin/jar
  slave jar.1.gz is /usr/share/man/man1/jar.1.gz
/usr/bin/fastjar - priorità 100
  slave jar.1.gz: /usr/share/man/man1/fastjar.1.gz
/usr/lib/jvm/java-8-openjdk-amd64/bin/jar - priorità 1081
  slave jar.1.gz: /usr/lib/jvm/java-8-openjdk-amd64/man/man1/jar.1.gz
/usr/lib/jvm/java-9-openjdk-amd64/bin/jar - priorità 1091
  slave jar.1.gz: /usr/lib/jvm/java-9-openjdk-amd64/man/man1/jar.1.gz
update-alternatives: errore: nessuna alternativa per javaws

grazie mille :D
Damiano Cosco
Avatar utente
damy kosko
Prode Principiante
 
Messaggi: 167
Iscrizione: marzo 2010
Desktop: ubuntu
Distribuzione: 17.04 x86_64
Sesso: Maschile

Re: Problema esecuzione Eclipse su ubuntu 17.04

Messaggioda Gerry Ghetto » lunedì 16 ottobre 2017, 19:31

Ho appena scaricato Eclipse oxygen. Poi ho installato openjdk-9-* e provato l'installazione, ma c'era un errore. Quindi ho disinstallato tutto di openjdk-9
Codice: Seleziona tutto
sudo apt-get purge openjdk-9-jdk openjdk-9-demo openjdk-9-doc openjdk-9-jre-headless openjdk-9-source
Dopo ho installato openjdk-8-*
Codice: Seleziona tutto
sudo apt install openjdk-8-jre openjdk-8-jdk openjdk-8-jre-headless openjdk-8-source
e riprovato l'installazione con successo.
Scusate il mio italiano. Non è la mia madrelingua.
forum.ubuntu-it.org - il peggior forum che conosco
Gerry Ghetto
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1571
Iscrizione: marzo 2015

Re: Problema esecuzione Eclipse su ubuntu 17.04

Messaggioda damy kosko » lunedì 16 ottobre 2017, 19:34

Gerry Ghetto Immagine ha scritto:Ho appena scaricato Eclipse oxygen. Poi ho installato openjdk-9-* e provato l'installazione, ma c'era un errore. Quindi ho disinstallato tutto di openjdk-9
Codice: Seleziona tutto
sudo apt-get purge openjdk-9-jdk openjdk-9-demo openjdk-9-doc openjdk-9-jre-headless openjdk-9-source
Dopo ho installato openjdk-8-*
Codice: Seleziona tutto
sudo apt install openjdk-8-jre openjdk-8-jdk openjdk-8-jre-headless openjdk-8-source
e riprovato l'installazione con successo.

mi scusi, ma senza offesa.. se le ho detto che ho provato prima con la versione 8, perchè dovrei dire una fesseria? non ho tempo da perdere ne io e presumibilmente ne voi.
Damiano Cosco
Avatar utente
damy kosko
Prode Principiante
 
Messaggi: 167
Iscrizione: marzo 2010
Desktop: ubuntu
Distribuzione: 17.04 x86_64
Sesso: Maschile

Re: Problema esecuzione Eclipse su ubuntu 17.04

Messaggioda Gerry Ghetto » lunedì 16 ottobre 2017, 19:40

damy kosko Immagine ha scritto:se le ho detto che ho provato prima con la versione 8, perchè dovrei dire una fesseria?
Non ho mai detto che tu l'abbia fatto. Anzi ho solo scritto cosa ho fatto io, perché io ho tempo da perdere.
Scusate il mio italiano. Non è la mia madrelingua.
forum.ubuntu-it.org - il peggior forum che conosco
Gerry Ghetto
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1571
Iscrizione: marzo 2015

Re: Problema esecuzione Eclipse su ubuntu 17.04

Messaggioda damy kosko » lunedì 16 ottobre 2017, 19:41

ok. Allora grazie mille
Damiano Cosco
Avatar utente
damy kosko
Prode Principiante
 
Messaggi: 167
Iscrizione: marzo 2010
Desktop: ubuntu
Distribuzione: 17.04 x86_64
Sesso: Maschile

Re: Problema esecuzione Eclipse su ubuntu 17.04

Messaggioda Mdfalcubo » lunedì 16 ottobre 2017, 20:02

@damy: prima di partire per la tangente ed essere sgarbati con chi usa il proprio tempo per aiutarti, sarebbe meglio leggerli BENE, i commenti altrui.. ;)
"Il genere umano è stimolante, è la gente che non sopporto,, (Linus - Peanuts)
"Se vuoi una mano per essere aiutato la trovi alla fine del tuo braccio,,
Avatar utente
Mdfalcubo
Moderatore Globale
Moderatore Globale
 
Messaggi: 20301
Iscrizione: dicembre 2008
Desktop: Solo XFCE
Distribuzione: Xubuntu -+ Manjaro - 64 bit
Sesso: Maschile

Re: Problema esecuzione Eclipse su ubuntu 17.04

Messaggioda damy kosko » lunedì 16 ottobre 2017, 20:04

Mdfalcubo Immagine ha scritto:@damy: prima di partire per la tangente ed essere sgarbati con chi usa il proprio tempo per aiutarti, sarebbe meglio leggerli BENE, i commenti altrui.. ;)

infatti credo di aver chiesto scusa all'inizio, anche perchè questa richiesta era stata già fatta qualche commento prima ed avevo già dato una risposta a questa domanda, riproponendomela mi è sembrato quasi come se mi dicesse "guarda che deve essere così!", se sono apparso sgarbato chiedo di nuovo scusa.
Damiano Cosco
Avatar utente
damy kosko
Prode Principiante
 
Messaggi: 167
Iscrizione: marzo 2010
Desktop: ubuntu
Distribuzione: 17.04 x86_64
Sesso: Maschile

Re: Problema esecuzione Eclipse su ubuntu 17.04

Messaggioda DoctorStrange » martedì 17 ottobre 2017, 8:27

Premesso il fatto che la openjdk in alcune applicazioni crea problemi, io ti consiglierei di usare la jdk versione 8 originale, ovvero quella resa gratuitamente disponibile dalla oracle.

Anche se hai già tentato con la 8, si vede dal risultato di quel comando che mi hai postato, che la situazione del tuo java è molto caotica.

Prima di tutto, se vuoi sostituire la jdk attualmente in usa con una diversa, non è necessario rimuovere quella precedente, ma è sufficiente che dici al sistema di puntare a quella nuova, lasciando la vecchia dove si trova.

Si vede che tutti i tuoi puntamenti sono sballati, e sono impostati come priorità a 1024. Io ti consiglio di seguire quella guida che ti ho postato. Io la reputo affidabile, poi ritenta di avviare Eclipse e vedi se funziona meglio.
Avatar utente
DoctorStrange
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1122
Iscrizione: ottobre 2015
Località: Roma, Italia
Desktop: Unity
Distribuzione: Ubuntu 16.04.03 Xenial Xerus
Sesso: Maschile

Re: Problema esecuzione Eclipse su ubuntu 17.04

Messaggioda damy kosko » martedì 17 ottobre 2017, 18:01

ok apposto ragazzi, mancava il pacchetto source, grazie mille😃😃
Damiano Cosco
Avatar utente
damy kosko
Prode Principiante
 
Messaggi: 167
Iscrizione: marzo 2010
Desktop: ubuntu
Distribuzione: 17.04 x86_64
Sesso: Maschile

Re: Problema esecuzione Eclipse su ubuntu 17.04

Messaggioda Mdfalcubo » martedì 17 ottobre 2017, 18:42

Aggiungi [Risolto] al titolo del post per favore. Grazie.
"Il genere umano è stimolante, è la gente che non sopporto,, (Linus - Peanuts)
"Se vuoi una mano per essere aiutato la trovi alla fine del tuo braccio,,
Avatar utente
Mdfalcubo
Moderatore Globale
Moderatore Globale
 
Messaggi: 20301
Iscrizione: dicembre 2008
Desktop: Solo XFCE
Distribuzione: Xubuntu -+ Manjaro - 64 bit
Sesso: Maschile

Re: Problema esecuzione Eclipse su ubuntu 17.04

Messaggioda damy kosko » martedì 17 ottobre 2017, 19:31

Mdfalcubo Immagine ha scritto:Aggiungi [Risolto] al titolo del post per favore. Grazie.

apposto, di nulla :D
Damiano Cosco
Avatar utente
damy kosko
Prode Principiante
 
Messaggi: 167
Iscrizione: marzo 2010
Desktop: ubuntu
Distribuzione: 17.04 x86_64
Sesso: Maschile


Torna a Applicazioni professionali

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 2 ospiti