[Risolto] [PPA] Non riesco a caricare i pacchetti con dput

Coordinamento delle attività e informazioni sui progetti del gruppo: creazione, modifica e gestione dei pacchetti di Ubuntu e relative problematiche.

Moderatore: Gruppo Sviluppo

Scrivi risposta
Avatar utente
urturino
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 365
Iscrizione: mercoledì 25 aprile 2007, 10:39
Località: Villa San Giovanni (RC)

[Risolto] [PPA] Non riesco a caricare i pacchetti con dput

Messaggio da urturino » giovedì 25 febbraio 2010, 10:33

Salve, ho recentemente aperto un PPA su Launchpad per il mio progetto, ho aggiunto la chiave PGP, ho firmato il codice di condotta, sono riuscito a creare un file .changes corretto, dopodiché, visto che sono su Karmic ho eseguito

Codice: Seleziona tutto

dput ppa:urturino/qvs-ppa qvs-gtk_2.0.0_source.changes
come suggerito nella pagina di Launchpad e nel suo wiki.
Tutto file liscio, mi viene creato un file contenente:

Codice: Seleziona tutto

Successfully uploaded qvs-gtk_2.0.0.dsc to ppa.launchpad.net for ppa.
Successfully uploaded qvs-gtk_2.0.0.tar.gz to ppa.launchpad.net for ppa.
Successfully uploaded qvs-gtk_2.0.0_source.changes to ppa.launchpad.net for ppa.
Eppure il mio PPA resta vuoto e pure la pagina dei Builds è deserta. Per email non mi viene notificato alcun errore.

Dove sbaglio? Qualcuno che ha già un PPA potrebbe illuminarmi?

Grazie a tutti.
Ultima modifica di urturino il sabato 20 marzo 2010, 20:52, modificato 1 volta in totale.
L'importante non è quanto sia grande la montagna, ma quanto l'uomo che la sta scalando.
QVS - Quanto Vinco Se... (http://code.google.com/p/qvs/)
Contatto Jabber: urturino@jabber.org - Identi.ca: http://identi.ca/urturino

Avatar utente
Janvitus
Amministratore
Amministratore
Messaggi: 18156
Iscrizione: lunedì 25 aprile 2005, 15:52
Desktop: GNOME Shell / Xfce
Sesso: Maschile
Località: Potenza
Contatti:

Re: [PPA] Non riesco a caricare i pacchetti con dput

Messaggio da Janvitus » sabato 27 febbraio 2010, 14:14

Risolto o ancora nulla?
+Fedora 32 • +Xubuntu 20.04

Avatar utente
urturino
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 365
Iscrizione: mercoledì 25 aprile 2007, 10:39
Località: Villa San Giovanni (RC)

Re: [PPA] Non riesco a caricare i pacchetti con dput

Messaggio da urturino » sabato 27 febbraio 2010, 20:49

Ancora nulla, sto chiedendo anche in altri forum, ma non si vede la soluzione all'orizzonte.
L'importante non è quanto sia grande la montagna, ma quanto l'uomo che la sta scalando.
QVS - Quanto Vinco Se... (http://code.google.com/p/qvs/)
Contatto Jabber: urturino@jabber.org - Identi.ca: http://identi.ca/urturino

Avatar utente
Janvitus
Amministratore
Amministratore
Messaggi: 18156
Iscrizione: lunedì 25 aprile 2005, 15:52
Desktop: GNOME Shell / Xfce
Sesso: Maschile
Località: Potenza
Contatti:

Re: [PPA] Non riesco a caricare i pacchetti con dput

Messaggio da Janvitus » domenica 28 febbraio 2010, 13:53

MA per mail ti viene avvisato che il pacchetto è stato accettato?
+Fedora 32 • +Xubuntu 20.04

Avatar utente
urturino
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 365
Iscrizione: mercoledì 25 aprile 2007, 10:39
Località: Villa San Giovanni (RC)

Re: [PPA] Non riesco a caricare i pacchetti con dput

Messaggio da urturino » domenica 28 febbraio 2010, 19:00

Janvitus ha scritto: MA per mail ti viene avvisato che il pacchetto è stato accettato?
No, non ricevo nessuna email, ne di accettazione, ne di errore.
L'importante non è quanto sia grande la montagna, ma quanto l'uomo che la sta scalando.
QVS - Quanto Vinco Se... (http://code.google.com/p/qvs/)
Contatto Jabber: urturino@jabber.org - Identi.ca: http://identi.ca/urturino

Avatar utente
Janvitus
Amministratore
Amministratore
Messaggi: 18156
Iscrizione: lunedì 25 aprile 2005, 15:52
Desktop: GNOME Shell / Xfce
Sesso: Maschile
Località: Potenza
Contatti:

Re: [PPA] Non riesco a caricare i pacchetti con dput

Messaggio da Janvitus » lunedì 1 marzo 2010, 17:38

Se non ricevi nulla mi sa che i file non arrivano proprio, perchè a me a ogni pacchetto che carico mi arriva una mail di avvenuta accettazione. Rimanda il pacchetto e controlla per bene tutti i messaggi che ti da il terminale.
+Fedora 32 • +Xubuntu 20.04

Avatar utente
urturino
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 365
Iscrizione: mercoledì 25 aprile 2007, 10:39
Località: Villa San Giovanni (RC)

Re: [PPA] Non riesco a caricare i pacchetti con dput

Messaggio da urturino » martedì 2 marzo 2010, 12:12

Janvitus ha scritto: Se non ricevi nulla mi sa che i file non arrivano proprio, perchè a me a ogni pacchetto che carico mi arriva una mail di avvenuta accettazione. Rimanda il pacchetto e controlla per bene tutti i messaggi che ti da il terminale.
L'invio risulta corretto, forse è un problema di creazione dei pacchetti dovuto al file rules.

Ora ho creato un file rules che non genera errori, l'ho caricato con successo, ma continua a non arrivare nulla per email e a non caricare i pacchetti.

C'è qualcosa di male a prendere i sorgenti di un pacchetto già presente si launchpad e provare a caricarli sul mio ppa per vedere se il problema è di creazione dei pacchetti i nell'upload?
L'importante non è quanto sia grande la montagna, ma quanto l'uomo che la sta scalando.
QVS - Quanto Vinco Se... (http://code.google.com/p/qvs/)
Contatto Jabber: urturino@jabber.org - Identi.ca: http://identi.ca/urturino

Avatar utente
Janvitus
Amministratore
Amministratore
Messaggi: 18156
Iscrizione: lunedì 25 aprile 2005, 15:52
Desktop: GNOME Shell / Xfce
Sesso: Maschile
Località: Potenza
Contatti:

Re: [PPA] Non riesco a caricare i pacchetti con dput

Messaggio da Janvitus » mercoledì 3 marzo 2010, 12:50

Prova, comunque controlla pure il file dput.cf nella tua home, è nascosto.
+Fedora 32 • +Xubuntu 20.04

Avatar utente
urturino
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 365
Iscrizione: mercoledì 25 aprile 2007, 10:39
Località: Villa San Giovanni (RC)

Re: [PPA] Non riesco a caricare i pacchetti con dput

Messaggio da urturino » mercoledì 3 marzo 2010, 13:29

Come sospettavo il problema è nel file rules, provando a caricare un altro sorgente funziona tutto.

Dovrò cercare di capire qual'è il problema nel file.
L'importante non è quanto sia grande la montagna, ma quanto l'uomo che la sta scalando.
QVS - Quanto Vinco Se... (http://code.google.com/p/qvs/)
Contatto Jabber: urturino@jabber.org - Identi.ca: http://identi.ca/urturino

Avatar utente
urturino
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 365
Iscrizione: mercoledì 25 aprile 2007, 10:39
Località: Villa San Giovanni (RC)

Re: [PPA] Non riesco a caricare i pacchetti con dput

Messaggio da urturino » sabato 20 marzo 2010, 20:52

tutto a posto, grazie per l'aiuto (b2b)
L'importante non è quanto sia grande la montagna, ma quanto l'uomo che la sta scalando.
QVS - Quanto Vinco Se... (http://code.google.com/p/qvs/)
Contatto Jabber: urturino@jabber.org - Identi.ca: http://identi.ca/urturino

Avatar utente
l3on
Gruppo Web
Gruppo Web
Messaggi: 6443
Iscrizione: sabato 20 maggio 2006, 19:03
Località: Bologna
Contatti:

Re: [Risolto] [PPA] Non riesco a caricare i pacchetti con dput

Messaggio da l3on » domenica 21 marzo 2010, 10:31

Saremmo felici di leggere, oltre al problema, la soluzione :).
Pagina Personale sul Wiki - Sito Personale - Blog | `l3on @ ubuntu.com` .

Ex "Membro del Consiglio, Sysadmin e Web-Designer dei portali della comunità, Amministratore del Sito e tante altre cose..." Con Ubuntu-it dal maggio del 2006.

Avatar utente
urturino
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 365
Iscrizione: mercoledì 25 aprile 2007, 10:39
Località: Villa San Giovanni (RC)

Re: [Risolto] [PPA] Non riesco a caricare i pacchetti con dput

Messaggio da urturino » domenica 21 marzo 2010, 12:34

Si, il problema come avrete capito non era nella configurazione di dput, ma nel mio pacchetto.

Avevo sempre creato il deb con "dpgk -b" e non avevo mai creato un makefile o un debian/rules, una volta creati questi 2 file tutto e andato liscio.
L'importante non è quanto sia grande la montagna, ma quanto l'uomo che la sta scalando.
QVS - Quanto Vinco Se... (http://code.google.com/p/qvs/)
Contatto Jabber: urturino@jabber.org - Identi.ca: http://identi.ca/urturino

Scrivi risposta

Ritorna a “Gruppo Sviluppo”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 1 ospite