Dipendenze mancanti pacchetti [RISOLTO]

Installazione, configurazione e uso di programmi e strumenti.

Dipendenze mancanti pacchetti [RISOLTO]

Messaggioda wizzowizard » domenica 11 febbraio 2018, 22:58

Ciao a tutti, nonostante le ricerche, non ho trovato discussione alcuna su come risolvere il problema che vado a mostrarvi dallo screen seguente:

Immagine

In poche parole, non mi fa installare nessun programma. Il problema è iniziato qualche giorno fa cercando inutilmente di installare Tor...adesso questo programma per kindle.
Se qualcuno ha la soluzione, mi dica come fare gentilmente, ma in maniera basilare sennò mi perdo per strada ;)
Grazie mille

p.s. chiaramente se è stato già trattao l'argomento, indicatemelo pure. E' probabile che mi sia sfuggito.
Ultima modifica di wizzowizard il domenica 25 febbraio 2018, 20:26, modificato 1 volta in totale.
Avatar utente
wizzowizard
Prode Principiante
 
Messaggi: 60
Iscrizione: marzo 2014

Re: Dipendenze mancanti pachetti

Messaggioda wilecoyote » lunedì 12 febbraio 2018, 15:13

:) Salve, quale release di Ubuntu usi ? Potrebbe essere fuori supporto, posta l'output dei comandi:

Codice: Seleziona tutto
lsb_release -dcr
uname -a


:ciao: Ciao
ACER Extensa 5230E 2,2 Ghz cpu Celeron 900 hdd 160 GB Ram 1GB scheda video Intel GM500
ACER Extensa 5635Z 2,2 Ghz cpu Celeron T3100 hdd 320 GB Ram 4 GB scheda video Intel Mobile 4
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
wilecoyote
Rampante Reduce
Rampante Reduce
 
Messaggi: 8089
Iscrizione: agosto 2009
Località: Ceranesi - Ge
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14/16/18.04 LTS 64bit
Sesso: Maschile

Re: Dipendenze mancanti pachetti

Messaggioda wizzowizard » domenica 18 febbraio 2018, 0:34

Ciao, Lubuntu 17.10

Codice: Seleziona tutto
corteo@corteo-Aspire-E1-571:~$ lsb_release -dcr
Description: Ubuntu 17.10
Release: 17.10
Codename: artful
corteo@corteo-Aspire-E1-571:~$ uname -a
Linux corteo-Aspire-E1-571 4.13.0-32-generic #35-Ubuntu SMP Thu Jan 25 09:13:46 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
corteo@corteo-Aspire-E1-571:~$ ^C
corteo@corteo-Aspire-E1-571:~$


grazie per il responso, attendo tue :ciao:
Ultima modifica di wizzowizard il lunedì 19 febbraio 2018, 0:41, modificato 1 volta in totale.
Avatar utente
wizzowizard
Prode Principiante
 
Messaggi: 60
Iscrizione: marzo 2014

Re: Dipendenze mancanti pachetti

Messaggioda wilecoyote » domenica 18 febbraio 2018, 16:04

:) Salve, intanto correggi il post usando i tag [Codice], clicca sul [Modifica] in alto a destra, nell'editor messaggi seleziona gli output, clicca sul pulsante [Codice] presente sopra la finestra verso sinistra, ed invia.

Immagine

Così da renderli più leggibili.

Il Calibre hai provato ad installarlo da repository o da fonti esterne ?

Prova a dare una sistemata al sistema pacchetti coi seguenti comandi:

Codice: Seleziona tutto
sudo apt install -f
sudo apt update
sudo apt upgrade
sudo apt install calibre


Il 1° corregge gli eventuali errori, il 2° aggiorna la lista dei pacchetti, il 3° installa eventuali aggiornamenti, il 4° installa il voluto.

Se hai ancora problemi posta l'output completo del prompt.

:ciao: Ciao
ACER Extensa 5230E 2,2 Ghz cpu Celeron 900 hdd 160 GB Ram 1GB scheda video Intel GM500
ACER Extensa 5635Z 2,2 Ghz cpu Celeron T3100 hdd 320 GB Ram 4 GB scheda video Intel Mobile 4
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
wilecoyote
Rampante Reduce
Rampante Reduce
 
Messaggi: 8089
Iscrizione: agosto 2009
Località: Ceranesi - Ge
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14/16/18.04 LTS 64bit
Sesso: Maschile

Re: Dipendenze mancanti pachetti

Messaggioda giulux » domenica 18 febbraio 2018, 16:10

Se non risolvi come indicato posta
Codice: Seleziona tutto
ls /etc/apt/sources.list.d
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...
Avatar utente
giulux
Amministratore
Amministratore
 
Messaggi: 21415
Iscrizione: gennaio 2010
Località: Roma
Desktop: xubuntu - ubuntu 17.10
Distribuzione: Ubuntu 16.04.1 LTS x86_64
Sesso: Maschile

Re: Dipendenze mancanti pacchetti

Messaggioda wizzowizard » lunedì 19 febbraio 2018, 0:44

ecco i risultati dei comandi dati:

Codice: Seleziona tutto
corteo@corteo-Aspire-E1-571:~$ sudo apt install -f
[sudo] password for corteo:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-4.13.0-16 linux-headers-4.13.0-16-generic
  linux-headers-4.13.0-19 linux-headers-4.13.0-19-generic
  linux-headers-4.13.0-21 linux-headers-4.13.0-21-generic
  linux-headers-4.13.0-25 linux-headers-4.13.0-25-generic
  linux-image-4.13.0-16-generic linux-image-4.13.0-19-generic
  linux-image-4.13.0-21-generic linux-image-4.13.0-25-generic
  linux-image-extra-4.13.0-16-generic linux-image-extra-4.13.0-19-generic
  linux-image-extra-4.13.0-21-generic linux-image-extra-4.13.0-25-generic
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
corteo@corteo-Aspire-E1-571:~$ sudo apt update
Hit:1 http://it.archive.ubuntu.com/ubuntu artful InRelease
Hit:2 http://it.archive.ubuntu.com/ubuntu artful-updates InRelease             
Ign:3 http://ppa.launchpad.net/webupd8team/tor-browser/ubuntu artful InRelease
Hit:4 http://it.archive.ubuntu.com/ubuntu artful-backports InRelease           
Hit:5 https://repo.skype.com/deb stable InRelease                             
Get:6 http://security.ubuntu.com/ubuntu artful-security InRelease [78,6 kB]   
Err:7 http://ppa.launchpad.net/webupd8team/tor-browser/ubuntu artful Release   
  404  Not Found
Hit:8 http://deb.torproject.org/torproject.org artful InRelease               
Get:9 http://security.ubuntu.com/ubuntu artful-security/main amd64 DEP-11 Metadata [2.920 B]
Reading package lists... Done               
E: The repository 'http://ppa.launchpad.net/webupd8team/tor-browser/ubuntu artful Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: Skipping acquire of configured file 'aardvark/binary-i386/Packages' as repository 'http://deb.torproject.org/torproject.org artful InRelease' doesn't have the component 'aardvark' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'aardvark/binary-amd64/Packages' as repository 'http://deb.torproject.org/torproject.org artful InRelease' doesn't have the component 'aardvark' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'aardvark/i18n/Translation-en' as repository 'http://deb.torproject.org/torproject.org artful InRelease' doesn't have the component 'aardvark' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'aardvark/i18n/Translation-en_US' as repository 'http://deb.torproject.org/torproject.org artful InRelease' doesn't have the component 'aardvark' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'aardvark/dep11/Components-amd64.yml' as repository 'http://deb.torproject.org/torproject.org artful InRelease' doesn't have the component 'aardvark' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'aardvark/dep11/icons-64x64.tar' as repository 'http://deb.torproject.org/torproject.org artful InRelease' doesn't have the component 'aardvark' (component misspelt in sources.list?)
corteo@corteo-Aspire-E1-571:~$ sudo apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  linux-headers-4.13.0-16 linux-headers-4.13.0-16-generic
  linux-headers-4.13.0-19 linux-headers-4.13.0-19-generic
  linux-headers-4.13.0-21 linux-headers-4.13.0-21-generic
  linux-headers-4.13.0-25 linux-headers-4.13.0-25-generic
  linux-image-4.13.0-16-generic linux-image-4.13.0-19-generic
  linux-image-4.13.0-21-generic linux-image-4.13.0-25-generic
  linux-image-extra-4.13.0-16-generic linux-image-extra-4.13.0-19-generic
  linux-image-extra-4.13.0-21-generic linux-image-extra-4.13.0-25-generic
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
corteo@corteo-Aspire-E1-571:~$ sudo apt install calibre
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package calibre
corteo@corteo-Aspire-E1-571:~$ sudo apt install calibre
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package calibre
corteo@corteo-Aspire-E1-571:~$     ls /etc/apt/sources.list.d
skype-stable.list       webupd8team-ubuntu-tor-browser-artful.list
skype-stable.list.save  webupd8team-ubuntu-tor-browser-artful.list.save
corteo@corteo-Aspire-E1-571:~$     ls /etc/apt/sources.list.d


:S

Calibre (come anche Tor) li ho scaricati come pacchetti autoinstallanti .deb (poichè a compilare i tar.gz da terminale sono sempre uscito pazzo :nono: )
Avatar utente
wizzowizard
Prode Principiante
 
Messaggi: 60
Iscrizione: marzo 2014

Re: Dipendenze mancanti pacchetti

Messaggioda giulux » lunedì 19 febbraio 2018, 8:24

Calibre dovrebbe essere nei repo di ubuntu e non c'è bisogno di usare il deb
Comincerei con un po' di pulizia eliminando i vecchi kernel
Codice: Seleziona tutto
sudo apt autoremove

poi
Codice: Seleziona tutto
sudo -H software-properties-gtk
nella prima scheda assicurati che siano spuntate tutte le fonti come da immagine
fonti.png
e nella scheda altro software togli la spunta ai repo di tor.
Chiudi facendo aggiornare e riprova con
Codice: Seleziona tutto
sudo apt install calibre
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...
Avatar utente
giulux
Amministratore
Amministratore
 
Messaggi: 21415
Iscrizione: gennaio 2010
Località: Roma
Desktop: xubuntu - ubuntu 17.10
Distribuzione: Ubuntu 16.04.1 LTS x86_64
Sesso: Maschile

Re: Dipendenze mancanti pacchetti

Messaggioda wizzowizard » lunedì 19 febbraio 2018, 18:33

Benissimo, tutto corretto. Grazie mille.

Per Tor invece come potrei fare? per evitare di incappare di nuovo in tutto questo macello? (sempre se esiste qualcosa di autoinstallante) ;)
Avatar utente
wizzowizard
Prode Principiante
 
Messaggi: 60
Iscrizione: marzo 2014

Re: Dipendenze mancanti pacchetti

Messaggioda caturen » lunedì 19 febbraio 2018, 18:51

caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14353
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid


Torna a Applicazioni

Chi c’è in linea

Visualizzano questa sezione: Baidu [Spider], Rex Artorius e 10 ospiti