Ho installato la libreria ma poi...

Installazione, configurazione e uso di programmi e strumenti.
Nopollution
Prode Principiante
Messaggi: 8
Iscrizione: mercoledì 16 marzo 2005, 12:31

Ho installato la libreria ma poi...

Messaggio da Nopollution »

ok gente, grazie ai vostri consigli ed alla lettura di parecchia "roba" sono riuscito ad installare le librerie che mi mancavano (almeno spero). Ora, quando digito ./configure non mi fornisce piu' in output una serie di "no" ma una serie di "yes" :laugh:
Qui di sotto vi riporto la risposta al comando ./configure:

nopollution@Barolo:~/provaLib/libctl-2.2 $ ./configure
checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking whether make sets ${MAKE}... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking for ranlib... ranlib
checking for indent... indent
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for guile... yes
checking for guile-config... yes
checking if linking to guile works... no
configure: error: Guile could not be found


Come potete notare, quando giunge al gran finale, mi dice che qualcosa non gli sfagiola. Ho pensato che potesse essere un problema di PATH, ma come fissarlo se non mi e' nemmeno chiaro quale file stia cercando? Avete qualche idea a proposito?

Grazie

Remo
Avatar utente
pierba
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 14531
Iscrizione: sabato 26 febbraio 2005, 19:10

Re:Ho installato la libreria ma poi...

Messaggio da pierba »

Ti dice che guile non è linkato.
Vedo due possibilità:
1) cercare in quale cartella è il file guile.conf e copiarlo in /usr/local/bin:

Codice: Seleziona tutto

sudo cp /percorso/guile.conf /usr/local/bin/guile.conf
, e viene linkato automaticamente;
oppure,
2)provare a fargli costruire le dipendenze del pacchetto che devi installare, se hai già fatto

Codice: Seleziona tutto

sudo apt-get build-essential
puoi digitare:

Codice: Seleziona tutto

sudo apt-get build-dep nomepacchetto
Se tutto va bene ti troverai con tutte le dipendenze necessarie installate, altrimenti a mano torni al punto 1.
Personalmente, ti consiglio il punto 2), è più sicuro che non si alteri il sistema.
Pietro pagina personale - Avete domande sul forum? Leggendo le FAQ: potreste trovare la risposta.
La conoscenza deve essere collettiva, quindi, come da regolamento (Sez. II punto 15) i messaggi personali contententi richieste di assistenza tecnica verranno ignorati.
Nopollution
Prode Principiante
Messaggi: 8
Iscrizione: mercoledì 16 marzo 2005, 12:31

Re:Ho installato la libreria ma poi...

Messaggio da Nopollution »

Ho appena provato il comando

Codice: Seleziona tutto

 sudo apt-get build-essential
ma la risposta che ho ottenuto e' stata:

Codice: Seleziona tutto

E: Invalid operation build-essential
Non capisco cosa ci sia di sbagliato. Idee?

Grazie
Avatar utente
Alessio
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 423
Iscrizione: sabato 5 febbraio 2005, 11:25

Re:Ho installato la libreria ma poi...

Messaggio da Alessio »

manca un install :)

Codice: Seleziona tutto

sudo apt-get install build-essential
"Gli farò una proposta che non potrà rifiutare…”
Nopollution
Prode Principiante
Messaggi: 8
Iscrizione: mercoledì 16 marzo 2005, 12:31

Re:Ho installato la libreria ma poi...

Messaggio da Nopollution »

Hai ragionissimo! :)

Dopo aver messo
l'install
la cosa ha funzionato e mi e' stato chiesto di inserire il CD di installazione. Cosi' ho fatto ed ha installato cio' che "mancava". A tal punto, prima di procedere con quanto suggeritomi da Pierba, ho provato ancora il comando

Codice: Seleziona tutto

./configure
ma la risposta e' stata quella che vio ho menzionato nel primo messaggio. Ho cosi' proceduto a digitare

Codice: Seleziona tutto

sudo apt-get build-essential
e questa volta il messaggio e' stato:

Codice: Seleziona tutto

Reading Package Lists... Done
Building Dependency Tree... Done
E: Unable to find a source package for guile
Ho provato a reinstallare il pacchetto Guile ma mi dice che e' gia' presente la versione piu' recente (ho anche appena rifatto un update/upgrade). Non ho idea di come andare avanti (ehi, Linux e' intrigante ma bisogna davvero sapere dove mettere le mani!)

Grazie ancora
Nopollution
Prode Principiante
Messaggi: 8
Iscrizione: mercoledì 16 marzo 2005, 12:31

Re:Ho installato la libreria ma poi...

Messaggio da Nopollution »

correggo il mio precedente messaggio:

Hai ragionissimo!

Dopo aver messo l'install la cosa ha funzionato e mi e' stato chiesto di inserire il CD di installazione. Cosi' ho fatto ed ha installato cio' che "mancava". A tal punto, prima di procedere con quanto suggeritomi da Pierba, ho provato ancora il comando

Codice: Seleziona tutto


./configure
ma la risposta e' stata quella che vio ho menzionato nel primo messaggio. Ho cosi' proceduto a digitare

Codice: Seleziona tutto


sudo apt-get build-dep guile
e questa volta il messaggio e' stato:

Codice: Seleziona tutto


Reading Package Lists... Done

Building Dependency Tree... Done

E: Unable to find a source package for guile
Ho provato a reinstallare il pacchetto Guile ma mi dice che e' gia' presente la versione piu' recente (ho anche appena rifatto un update/upgrade). Non ho idea di come andare avanti (ehi, Linux
e' intrigante ma bisogna davvero sapere dove mettere le mani!)

Grazie ancora
Avatar utente
pierba
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 14531
Iscrizione: sabato 26 febbraio 2005, 19:10

Re:Ho installato la libreria ma poi...

Messaggio da pierba »

Prova a lanciarla, se non riesci da ->applicazioni ->esegui programma, ti conviene cercare in quali directory ha messo il programma (probabilmente /etc o /usr), quando trovi il file eseguibile lo lanci da terminale.

ciao, pietroPost modificato da: pierba, alle: 2005/03/23 08:01
Pietro pagina personale - Avete domande sul forum? Leggendo le FAQ: potreste trovare la risposta.
La conoscenza deve essere collettiva, quindi, come da regolamento (Sez. II punto 15) i messaggi personali contententi richieste di assistenza tecnica verranno ignorati.
Scrivi risposta

Ritorna a “Applicazioni”

Chi c’è in linea

Visualizzano questa sezione: Google [Bot] e 9 ospiti