Gestore aggiornamenti/pacchetti danneggiati (errore)[risolto

Problemi riscontrati durante l'installazione di Ubuntu, degli aggiornamenti e degli avanzamenti del sistema.

Gestore aggiornamenti/pacchetti danneggiati (errore)[risolto

Messaggioda mig992 » lunedì 20 gennaio 2014, 11:32

Ho il solito problema come ho letto in molti forum del "pacchetti danneggiati", ma non riesco a trovare una soluzione.. c'è qualcuno che può darmi una mano? Grazie! :))

Codice: Seleziona tutto
riccardo@mig:~$ sudo apt-get upgrade
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 wireshark : Dipende: wireshark-common (= 1.11.3+svn54293-0ubuntu1~precise1~ppa0) ma la versione 1.6.7-1 è installata
E: Dipendenze non trovate. Riprovare usando -f.

Codice: Seleziona tutto
riccardo@mig:~$ sudo apt-get -f install
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  gir1.2-ubuntuoneui-3.0 linux-headers-3.2.0-44 libwsutil1 libwireshark-data
  libubuntuoneui-3.0-1 tzdata-java libwireshark1 libwiretap1
  linux-headers-3.2.0-44-generic
Usare "apt-get autoremove" per rimuoverli.
I seguenti pacchetti saranno inoltre installati:
  wireshark-common
Pacchetti suggeriti:
  snmp-mibs-downloader
I seguenti pacchetti saranno aggiornati:
  wireshark-common
1 aggiornati, 0 installati, 0 da rimuovere e 182 non aggiornati.
1 non completamente installati o rimossi.
È necessario scaricare 0 B/14,2 MB di archivi.
Dopo quest'operazione, verranno occupati 53,8 MB di spazio su disco.
Continuare [S/n]? s
(Lettura del database... 286037 file e directory attualmente installati.)
Preparativi per sostituire wireshark-common v.1.6.7-1 (utilizzando .../wireshark-common_1.11.3+svn54293-0ubuntu1~precise1~ppa0_i386.deb)...
Estrazione del sostituto di wireshark-common...
dpkg: errore nell'elaborare /var/cache/apt/archives/wireshark-common_1.11.3+svn54293-0ubuntu1~precise1~ppa0_i386.deb (--unpack):
 tentata sovrascrittura di "/etc/wireshark/init.lua" presente anche nel pacchetto libwireshark-data 1.6.7-1
Segnalazione apport non scritta poiché è stato raggiunto il valore massimo di MaxReports
        dpkg-deb: errore: il sottoprocesso paste è stato terminato dal segnale (Pipe interrotta)
Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/wireshark-common_1.11.3+svn54293-0ubuntu1~precise1~ppa0_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Ultima modifica di mig992 il lunedì 20 gennaio 2014, 14:39, modificato 2 volte in totale.
mig992
Prode Principiante
 
Messaggi: 2
Iscrizione: gennaio 2014

Re: Gestore aggiornamenti/pacchetti danneggiati (errore)

Messaggioda daigo » lunedì 20 gennaio 2014, 11:38

prova così
Codice: Seleziona tutto
sudo dpkg --force-all -i /var/cache/apt/archives/wireshark-common_1.11.3+svn54293-0ubuntu1~precise1~ppa0_i386.deb

Codice: Seleziona tutto
sudo apt-get install -f
daigo
 

Re: Gestore aggiornamenti/pacchetti danneggiati (errore)

Messaggioda mig992 » lunedì 20 gennaio 2014, 11:42

daigo Immagine ha scritto:prova così
Codice: Seleziona tutto
sudo dpkg --force-all -i /var/cache/apt/archives/wireshark-common_1.11.3+svn54293-0ubuntu1~precise1~ppa0_i386.deb

Codice: Seleziona tutto
sudo apt-get install -f

GRAZIE MILLE!! :) era un ora che provavo..
mig992
Prode Principiante
 
Messaggi: 2
Iscrizione: gennaio 2014

Re: Gestore aggiornamenti/pacchetti danneggiati (errore)

Messaggioda daigo » lunedì 20 gennaio 2014, 11:50

ma hai risolto? se si metti risolto al primo post,ciao
daigo
 

Re: Gestore aggiornamenti/pacchetti danneggiati (errore)

Messaggioda vaillant » lunedì 20 gennaio 2014, 12:11

Quando inserisci un output del terminale racchiudilo nel tag "code" per una maggiore leggibilità. Per questa volta l'ho fatto io.

Ciao
I miei computer - Ubuntu Builder - Crea la tua Ubuntu personalizzata
Se sei incerto, tieni aperto
Did I ever tell you what the definition of insanity is?
Avatar utente
vaillant
Rampante Reduce
Rampante Reduce
 
Messaggi: 8319
Iscrizione: marzo 2009
Località: Modica
Distribuzione: Ubuntu 16.04
Sesso: Maschile


Torna a Installazione e aggiornamento del sistema operativo

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 4 ospiti