[Risolto] Permessi di scrittura Transmission

Installazione, configurazione e uso di programmi e strumenti.
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 11338
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 10 (Buster) - KDE

Re: Permessi di scrittura Transmission

Messaggio da thece » domenica 20 novembre 2016, 14:17

Fidati: sono easy. Se non capisci, chiedimi esattamente cosa non capisci e vedrò di spiegartelo

Ho modificato il mio precedente post

Avatar utente
FlameMEX
Prode Principiante
Messaggi: 229
Iscrizione: martedì 4 ottobre 2016, 11:56

Re: Permessi di scrittura Transmission

Messaggio da FlameMEX » domenica 20 novembre 2016, 14:21

Codice: Seleziona tutto

naslinux@naslinux:/etc/init.d$ cat /etc/passwd | grep transmission
debian-transmission:x:112:118::/var/lib/transmission-daemon:/bin/false
naslinux@naslinux:/etc/init.d$ ls -l /var/lib | grep transmission-daemon
drwxrwxrwx  4 root root    4096 nov  3 14:55 transmission-daemon
naslinux@naslinux:/etc/init.d$     ls -l /var/lib/transmission-daemon | grep downloads
drwsrwxrwx 2 nobody nogroup 4096 nov 20 10:00 downloads
naslinux@naslinux:/etc/init.d$ ls -l /var/lib/transmission-daemon/downloads
totale 0
naslinux@naslinux:/etc/init.d$
Fin qui ci siamo ok, ti ho postato gli output.. :sisi:
Possiamo dire a SAMBA di autenticare , vabene incollami il smb.conf

Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 11338
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 10 (Buster) - KDE

Re: Permessi di scrittura Transmission

Messaggio da thece » domenica 20 novembre 2016, 14:28

Questo me lo sono dimenticato io

Codice: Seleziona tutto

ps -ef | grep transmission

Questo te lo sei dimenticato tu
thece [url=http://forum.ubuntu-it.org/viewtopic.php?p=4935865#p4935865][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto: Se rispondessi alle mie domande ...

Hai modificato la proprietà di qualcuna di queste directory? Non mi tornano gli output

Codice: Seleziona tutto

/var/lib/transmission-daemon

Codice: Seleziona tutto

/var/lib/transmission-daemon/downloads

Avatar utente
FlameMEX
Prode Principiante
Messaggi: 229
Iscrizione: martedì 4 ottobre 2016, 11:56

Re: Permessi di scrittura Transmission

Messaggio da FlameMEX » domenica 20 novembre 2016, 14:34

Codice: Seleziona tutto

debian-+  1495     1  0 nov19 ?        00:00:30 /usr/bin/transmission-daemon -f --log-error
naslinux  2889  2389  0 14:35 pts/0    00:00:00 grep --color=auto transmission
devo darle il?

Codice: Seleziona tutto

sudo chmod -R 777

Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 11338
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 10 (Buster) - KDE

Re: Permessi di scrittura Transmission

Messaggio da thece » domenica 20 novembre 2016, 14:36

Quale parte della domanda "Hai modificato la proprietà di qualcuna di queste directory?" non hai capito?

Avatar utente
FlameMEX
Prode Principiante
Messaggi: 229
Iscrizione: martedì 4 ottobre 2016, 11:56

Re: Permessi di scrittura Transmission

Messaggio da FlameMEX » domenica 20 novembre 2016, 14:42

Allora, andiamo per ordine, per prima cosa do il sudo chmod -R 777 sulle cartelle che mi hai detto tu di modo da modificare i permessi....
adesso ti posto l'output delle cartelle dopo aver dato il chmod:

Codice: Seleziona tutto

naslinux@naslinux:/etc/init.d$ sudo chmod -R 777 /var/lib/transmission-daemon
naslinux@naslinux:/etc/init.d$ sudo chmod -R 777 /var/lib/transmission-daemon/downloads
Codice dopo avere dato i permessi chamod:

Codice: Seleziona tutto

naslinux@naslinux:/etc/init.d$ cat /etc/passwd | grep transmission
debian-transmission:x:112:118::/var/lib/transmission-daemon:/bin/false
naslinux@naslinux:/etc/init.d$ ls -l /var/lib | grep transmission-daemon
drwxrwxrwx  4 root root    4096 nov  3 14:55 transmission-daemon
naslinux@naslinux:/etc/init.d$ ls -l /var/lib/transmission-daemon | grep downloads
drwsrwxrwx 2 nobody nogroup 4096 nov 20 10:00 downloads
naslinux@naslinux:/etc/init.d$ ls -l /var/lib/transmission-daemon/downloads
totale 0
dimmi se ti è piu in ordine cos'ì

Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 11338
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 10 (Buster) - KDE

Re: Permessi di scrittura Transmission

Messaggio da thece » domenica 20 novembre 2016, 14:45

Io non ti ho chiesto di fare nulla. Io ti ho semplicemente chiesto di rispondere ad una semplice domanda

Avatar utente
FlameMEX
Prode Principiante
Messaggi: 229
Iscrizione: martedì 4 ottobre 2016, 11:56

Re: Permessi di scrittura Transmission

Messaggio da FlameMEX » domenica 20 novembre 2016, 14:49

Alla partenza le da il comando in automatico:

Codice: Seleziona tutto

sudo chmod -R 777 /var/lib/transmission-daemon
Per il resto non ho modificato nessul altra cosa....

Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 11338
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 10 (Buster) - KDE

Re: Permessi di scrittura Transmission

Messaggio da thece » domenica 20 novembre 2016, 15:00

OK ... non mi torna ma magari Transmission funziona così (io non lo uso). Secondo me la directory /var/lib/transmission-daemon/downloads deve appartenere all'utente debian-transmission

Codice: Seleziona tutto

sudo chown debian-transmission:debian-transmission /var/lib/transmission-daemon/downloads
Togli il comando alla partenza: sistemisticamente è un orrore, fa danni e lo hai inserito in un punto difficilmente rintracciabile in futuro

Codice: Seleziona tutto

sudo chmod -R 777 /var/lib/transmission-daemon
Aggiungi l'utente debian-transmission tra gli utenti di Samba

Codice: Seleziona tutto

sudo smbpasswd -a debian-transmission
assegnagli una password non vuota, anche "debian-transmission" va bene


Modifica lo share sul tuo file /etc/samba/smb.conf così

Codice: Seleziona tutto

[transmission]
        comment = Transmission
        path = /var/lib/transmission-daemon/downloads
        available = yes
        browseable = yes
        writeable = yes
        guest ok = no
        guest only = no
        directory mask = 0755
        create mask = 0644
Riavvia Samba
Ultima modifica di thece il domenica 20 novembre 2016, 15:09, modificato 1 volta in totale.

Avatar utente
FlameMEX
Prode Principiante
Messaggi: 229
Iscrizione: martedì 4 ottobre 2016, 11:56

Re: Permessi di scrittura Transmission

Messaggio da FlameMEX » domenica 20 novembre 2016, 15:09

:muro: fatto tutto riavviato il server, ma non da i permessi per eliminare il file creato con transmission.....
acnhe dopo aver creato il debian-trasnsmission ed impostato la password...

Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 11338
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 10 (Buster) - KDE

Re: Permessi di scrittura Transmission

Messaggio da thece » domenica 20 novembre 2016, 15:10

Hai fatto anche questo?
thece [url=http://forum.ubuntu-it.org/viewtopic.php?p=4935895#p4935895][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto: OK ... non mi torna ma magari Transmission funziona così (io non lo uso). Secondo me la directory /var/lib/transmission-daemon/downloads deve appartenere all'utente debian-transmission

Codice: Seleziona tutto

sudo chown debian-transmission:debian-transmission /var/lib/transmission-daemon/downloads

Avatar utente
FlameMEX
Prode Principiante
Messaggi: 229
Iscrizione: martedì 4 ottobre 2016, 11:56

Re: Permessi di scrittura Transmission

Messaggio da FlameMEX » domenica 20 novembre 2016, 15:12

yess

Codice: Seleziona tutto

sudo service smbd restart
non'è che bisogna impostare un valore nelle proprietà del transmission...
in passato feci quello ed andò tutto ok.... :o

Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 11338
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 10 (Buster) - KDE

Re: Permessi di scrittura Transmission

Messaggio da thece » domenica 20 novembre 2016, 15:18

Mi sembra strano ...
Questo comando non riavvia tutto Samba, ma solamente uno dei due servizi sui quali si basa
FlameMEX [url=http://forum.ubuntu-it.org/viewtopic.php?p=4935904#p4935904][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto: non'è che bisogna impostare un valore nelle proprietà del transmission...
in passato feci quello ed andò tutto ok.... :o
Come ti ho già detto io non conosco Transmission. Ho solamente provato a farti impostare uno share di Samba coerente a livello di utente e permessi con Transmission

Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 11338
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 10 (Buster) - KDE

Re: Permessi di scrittura Transmission

Messaggio da thece » domenica 20 novembre 2016, 16:27

Siccome a me non piace che gli utenti pensino che io fornisca informazioni scorrette ... ho provato ad installare Transmission su una Raspberry Pi con sistema operativo Raspbian (base Debian, stessa di Ubuntu) seguendo questa guida.

Dopo aver installato il pacchetto con il classico

Codice: Seleziona tutto

sudo apt-get install transmission-daemon
il quadro a livello di utenti, processi, proprietà e permessi sulle directory interessate è risultato il seguente:

Codice: Seleziona tutto

cat /etc/passwd | grep transmission

debian-transmission:x:114:124::/var/lib/transmission-daemon:/bin/false

Codice: Seleziona tutto

ps -ef | grep transmission

debian-+ 18542     1  0 15:38 ?        00:00:00 /usr/bin/transmission-daemon -f --log-error

Codice: Seleziona tutto

ls -l /var/lib | grep transmission

drwxr-xr-x 4 root       root       4096 Nov 20 15:37 transmission-daemon

Codice: Seleziona tutto

ls -l /var/lib/transmission-daemon

drwsrwxr-x 2 debian-transmission debian-transmission 4096 Dec 25  2014 downloads
lrwxrwxrwx 1 root                root                  27 Dec 25  2014 info -> .config/transmission-daemon
Ho modificato lievemente il file di configurazione di Transmission, meno rispetto a quanto indicato nella guida

Codice: Seleziona tutto

sudo cat /etc/transmission-daemon/settings.json

{
    "alt-speed-down": 50, 
    "alt-speed-enabled": false, 
    "alt-speed-time-begin": 540, 
    "alt-speed-time-day": 127, 
    "alt-speed-time-enabled": false, 
    "alt-speed-time-end": 1020, 
    "alt-speed-up": 50, 
    "bind-address-ipv4": "0.0.0.0", 
    "bind-address-ipv6": "::", 
    "blocklist-enabled": false, 
    "blocklist-url": "http://www.example.com/blocklist", 
    "cache-size-mb": 4, 
    "dht-enabled": true, 
    "download-dir": "/var/lib/transmission-daemon/downloads", 
    "download-limit": 100, 
    "download-limit-enabled": 0, 
    "download-queue-enabled": true, 
    "download-queue-size": 5, 
    "encryption": 1, 
    "idle-seeding-limit": 30, 
    "idle-seeding-limit-enabled": false, 
    "incomplete-dir": "/var/lib/transmission-daemon/Downloads", 
    "incomplete-dir-enabled": false, 
    "lpd-enabled": false, 
    "max-peers-global": 200, 
    "message-level": 1, 
    "peer-congestion-algorithm": "", 
    "peer-id-ttl-hours": 6, 
    "peer-limit-global": 200, 
    "peer-limit-per-torrent": 50, 
    "peer-port": 51413, 
    "peer-port-random-high": 65535, 
    "peer-port-random-low": 49152, 
    "peer-port-random-on-start": false, 
    "peer-socket-tos": "default", 
    "pex-enabled": true, 
    "port-forwarding-enabled": false, 
    "preallocation": 1, 
    "prefetch-enabled": 1, 
    "queue-stalled-enabled": true, 
    "queue-stalled-minutes": 30, 
    "ratio-limit": 2, 
    "ratio-limit-enabled": false, 
    "rename-partial-files": true, 
    "rpc-authentication-required": true, 
    "rpc-bind-address": "0.0.0.0", 
    "rpc-enabled": true, 
    "rpc-password": "{efd6985785072a8030816e7b43559694392d4893guvhSLhx", 
    "rpc-port": 9091, 
    "rpc-url": "/transmission/", 
    "rpc-username": "transmission", 
    "rpc-whitelist": "127.0.0.1", 
    "rpc-whitelist-enabled": false, 
    "scrape-paused-torrents-enabled": true, 
    "script-torrent-done-enabled": false, 
    "script-torrent-done-filename": "", 
    "seed-queue-enabled": false, 
    "seed-queue-size": 10, 
    "speed-limit-down": 100, 
    "speed-limit-down-enabled": false, 
    "speed-limit-up": 100, 
    "speed-limit-up-enabled": false, 
    "start-added-torrents": true, 
    "trash-original-torrent-files": false, 
    "umask": 18, 
    "upload-limit": 100, 
    "upload-limit-enabled": 0, 
    "upload-slots-per-torrent": 14, 
    "utp-enabled": true
}
Ho riavviato il servizio di Transmission e ho usato la sua GUI Web per scaricare Tails

Codice: Seleziona tutto

ls -l /var/lib/transmission-daemon/downloads/

drwxr-xr-x 2 debian-transmission debian-transmission 4096 Nov 20 15:50 tails-i386-2.7
A questo punto mi sono occupato della creazione del relativo share (autenticato) per Samba. Il file /etc/samba/smb.conf l'ho configurato così:

Codice: Seleziona tutto

cat /etc/samba/smb.conf      

[global]
        netbios name = ALEXA
        workgroup = WORKGROUP

        server string = %h Samba Server - Version %v

        domain logons = no
        domain master = no
        local master = yes
        preferred master = no
        os level = 3

        server role = auto
        security = user
        encrypt passwords = yes
        map to guest = Bad User
        guest account = nobody
        directory mask = 0755
        create mask = 0644

        dns proxy = yes
        wins support = no

        syslog = 0
        log file = /var/log/samba/log.%m
        max log size = 1000

[transmission]
        comment = Transmission
        path = /var/lib/transmission-daemon/downloads
        available = yes
        browseable = yes
        writeable = yes
        guest ok = no
        guest only = no
Ho aggiunto l'utente debian-transmission tra gli utenti di Samba

Codice: Seleziona tutto

sudo smbpasswd -a debian-transmission

Codice: Seleziona tutto

sudo pdbedit -L

debian-transmission:114:
Ho riavviato Samba e ho provato a collegarmi da remoto allo share transmission di Samba, utilizzando le credenziali dell'utente debian-transmission di Samba , senza riscontrare alcun problema ne di lettura ne scrittura sullo share.

Come puoi vedere, dal punto di vista sistemistico, non ho utilizzato nessun arzigoglo strano. Ho creato lo share di Samba sfruttando le caratteristiche dell'installazione di default di Transmission.
Spero che questo post possa esserti di aiuto nella risoluzione del problema.


PS: avevo ragione. I conti non tornavano ...
thece [url=http://forum.ubuntu-it.org/viewtopic.php?p=4935865#p4935865][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto: Hai modificato la proprietà di qualcuna di queste directory? Non mi tornano gli output

Codice: Seleziona tutto

/var/lib/transmission-daemon

Codice: Seleziona tutto

/var/lib/transmission-daemon/downloads
thece [url=http://forum.ubuntu-it.org/viewtopic.php?p=4935895#p4935895][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto: OK ... non mi torna ma magari Transmission funziona così (io non lo uso). Secondo me la directory /var/lib/transmission-daemon/downloads deve appartenere all'utente debian-transmission

Codice: Seleziona tutto

sudo chown debian-transmission:debian-transmission /var/lib/transmission-daemon/downloads

Avatar utente
FlameMEX
Prode Principiante
Messaggi: 229
Iscrizione: martedì 4 ottobre 2016, 11:56

Re: Permessi di scrittura Transmission

Messaggio da FlameMEX » sabato 4 maggio 2019, 15:46

il problema si presenta quando transmission crea il file, e li che torna il giochino dei permessi negati....

Avatar utente
derma
Rampante Reduce
Rampante Reduce
Messaggi: 7041
Iscrizione: martedì 5 settembre 2006, 20:07
Distribuzione: Ubuntu 15.10 (Wily Werewolf)
Località: Sicilia
Contatti:

Re: Permessi di scrittura Transmission

Messaggio da derma » sabato 4 maggio 2019, 15:52

FlameMEX [url=https://forum.ubuntu-it.org/viewtopic.php?p=5131976#p5131976][img]https://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:il problema si presenta quando transmission crea il file, e li che torna il giochino dei permessi negati....


Beh, che si presenti una volta ogni 3 anni, è già un passo avanti.
_/-ENZA  [ ENSURA   ▅         |        |        |        |        |    Drive    |    _/- Γı |V| F · Γ| |7 F · |\| Γı -|- · |-| |_| |V| Γ| |\| ()                        Γı /\ ı\   |7 Γı Γı Γı -|-

Avatar utente
FlameMEX
Prode Principiante
Messaggi: 229
Iscrizione: martedì 4 ottobre 2016, 11:56

Re: Permessi di scrittura Transmission

Messaggio da FlameMEX » sabato 4 maggio 2019, 15:56

loool!!!!!!!!!!!!!!!

Avatar utente
FlameMEX
Prode Principiante
Messaggi: 229
Iscrizione: martedì 4 ottobre 2016, 11:56

Re: Permessi di scrittura Transmission

Messaggio da FlameMEX » domenica 5 maggio 2019, 14:22

per la cronaca bisognava soltanto mettere il seguente valore in umask:

Codice: Seleziona tutto
"umask": 000,



poi funge tutto

BYZ

Avatar utente
derma
Rampante Reduce
Rampante Reduce
Messaggi: 7041
Iscrizione: martedì 5 settembre 2006, 20:07
Distribuzione: Ubuntu 15.10 (Wily Werewolf)
Località: Sicilia
Contatti:

Re: Permessi di scrittura Transmission

Messaggio da derma » domenica 5 maggio 2019, 14:42

Dovresti specificare in quale file tale modifica/aggiunta va fatta... presumo tu ti riferisca al file di configurazione di Transmission che si trova in...

Codice: Seleziona tutto


/home/<nome-user>/.config/transmission/settings.json


...se si vuole che sia valido per il solo utente che effettuò l'accesso, quello che avviò la sessione... in ogni caso, qui si possono trovare delle informazioni in merito, ma non solo per la questione "umask"...

Editing Configuration Files · transmission/transmission Wiki

(https://trac.transmissionbt.com/wiki/Mo ... onfigFiles)


...ma, leggendo questo 3D di due anni fa, non avevi già "risolto" mettendo mano proprio al file "umask" ?
_/-ENZA  [ ENSURA   ▅         |        |        |        |        |    Drive    |    _/- Γı |V| F · Γ| |7 F · |\| Γı -|- · |-| |_| |V| Γ| |\| ()                        Γı /\ ı\   |7 Γı Γı Γı -|-

Avatar utente
FlameMEX
Prode Principiante
Messaggi: 229
Iscrizione: martedì 4 ottobre 2016, 11:56

Re: Permessi di scrittura Transmission

Messaggio da FlameMEX » domenica 5 maggio 2019, 14:51

si esatto, anzi gia che ci sono incollo tutto il mio settings.json, cosi se puo tornare utile a terzi.....

Codice: Seleziona tutto

{
    "alt-speed-down": 50,
    "alt-speed-enabled": false,
    "alt-speed-time-begin": 540,
    "alt-speed-time-day": 127,
    "alt-speed-time-enabled": false,
    "alt-speed-time-end": 1020,
    "alt-speed-up": 50,
    "bind-address-ipv4": "0.0.0.0",
    "bind-address-ipv6": "::",
    "blocklist-enabled": false,
    "blocklist-url": "http://www.example.com/blocklist",
    "cache-size-mb": 4,
    "dht-enabled": true,
    "download-dir": "/var/lib/transmission-daemon/downloads",
    "download-limit": 100,
    "download-limit-enabled": 0,
    "download-queue-enabled": true,
    "download-queue-size": 5,
    "encryption": 1,
    "idle-seeding-limit": 30,
    "idle-seeding-limit-enabled": false,
    "incomplete-dir": "/var/lib/transmission-daemon/downloads",
    "incomplete-dir-enabled": false,
    "lpd-enabled": false,
    "max-peers-global": 200,
    "message-level": 1,
    "peer-congestion-algorithm": "",
    "peer-id-ttl-hours": 6,
    "peer-limit-global": 200,
    "peer-limit-per-torrent": 50,
    "peer-port": 51413,
    "peer-port-random-high": 65535,
    "peer-port-random-low": 49152,
    "peer-port-random-on-start": false,
    "peer-socket-tos": "default",
    "pex-enabled": true,
    "port-forwarding-enabled": false,
    "preallocation": 1,
    "prefetch-enabled": true,
    "queue-stalled-enabled": true,
    "queue-stalled-minutes": 30,
    "ratio-limit": 2,
    "ratio-limit-enabled": false,
    "rename-partial-files": true,
    "rpc-authentication-required": true,
    "rpc-bind-address": "0.0.0.0",
    "rpc-enabled": true,
    "rpc-host-whitelist": "",
    "rpc-host-whitelist-enabled": true,
    "rpc-password": "VOSTRAPASSWORD",
    "rpc-port": 9091,
    "rpc-url": "/transmission/",
    "rpc-username": "admin",
    "rpc-whitelist": "*.*.*.*",
    "rpc-whitelist-enabled": true,
    "scrape-paused-torrents-enabled": true,
    "script-torrent-done-enabled": false,
    "script-torrent-done-filename": "",
    "seed-queue-enabled": false,
    "seed-queue-size": 10,
    "speed-limit-down": 100,
    "speed-limit-down-enabled": false,
    "speed-limit-up": 100,
    "speed-limit-up-enabled": false,
    "start-added-torrents": true,
    "trash-original-torrent-files": false,
    "umask": 0,
    "upload-limit": 100,
    "upload-limit-enabled": 0,
    "upload-slots-per-torrent": 14,
    "utp-enabled": true
}
Facenso cosi, accedete all'interfaccia con admin + VOSTRAPASSWORD, con permessi di scrittura e tutta le comodità che seguono....
ricordo che prima va disattivato il demone come segue:

Codice: Seleziona tutto

sudo service transmission-daemon stop
dopodichè fate le dovute modifiche oppure copiate ed incollate i miei setting..... ciao!

Scrivi risposta

Ritorna a “Applicazioni”

Chi c’è in linea

Visualizzano questa sezione: Majestic-12 [Bot] e 11 ospiti