Ripristinare la precedente versione di un programma

Installazione, configurazione e uso di programmi e strumenti.

Re: Ripristinare la precedente versione di un programma

Messaggioda Rosssiiii » venerdì 19 maggio 2017, 14:58

enziosavio Immagine ha scritto:
Rosssiiii Immagine ha scritto:
enziosavio Immagine ha scritto:Esatto , vedi che c'è versioni , controlla che versioni hai disponibili .
Vedo che dice Stato> danneggiato .

Ecco: http://i.imgur.com/s7Wsv2k.png

Attualmente risulta installata quella con scritto (now), però forse è dovuto al fatto che l'ho installato da terminale e che devo installare le dipendenze richieste che fabrixx mi ha linkato ?

Esatto hai la versione della lingua alla 58 e il browser vero e proprio alla 57 , devi sistemare

ora ho dato da terminale i seguenti comandi:
Codice: Seleziona tutto
roberto@roberto-Toshiba:~$ cd /home/roberto/Scrivania/
roberto@roberto-Toshiba:~/Scrivania$ ls
afc.mount
apk scaricati
chromium-browser_57.0.2987.98-0ubuntu1.1348_amd64.deb
chromium-codecs-ffmpeg_57.0.2987.98-0ubuntu1.1348_amd64.deb
chromium-codecs-ffmpeg-extra_57.0.2987.98-0ubuntu1.1348_amd64.deb
coil whine
File .deb
fusepod-0.5.2-194.3.x86_64.rpm
fusepod_0.5.2-195.3_amd64.deb
lxrandr.desktop
pavucontrol.desktop
roberto@roberto-Toshiba:~/Scrivania$ sudo dpkg -i chromium-codecs-ffmpeg_57.0.2987.98-0ubuntu1.1348_amd64.deb
[sudo] password di roberto:
dpkg: errore: un altro processo detiene il blocco su database di stato di dpkg
roberto@roberto-Toshiba:~/Scrivania$ sudo dpkg -i chromium-codecs-ffmpeg_57.0.2987.98-0ubuntu1.1348_amd64.deb
Selezionato il pacchetto chromium-codecs-ffmpeg non precedentemente selezionato.
dpkg: possibile rimozione di chromium-codecs-ffmpeg-extra al posto di chromium-codecs-ffmpeg...
dpkg: il pacchetto chromium-codecs-ffmpeg-extra verrà rimosso al posto di chromium-codecs-ffmpeg
(Lettura del database... 339199 file e directory attualmente installati.)
Preparativi per estrarre chromium-codecs-ffmpeg_57.0.2987.98-0ubuntu1.1348_amd64.deb...
Estrazione di chromium-codecs-ffmpeg (57.0.2987.98-0ubuntu1.1348)...
Configurazione di chromium-codecs-ffmpeg (57.0.2987.98-0ubuntu1.1348)...
roberto@roberto-Toshiba:~/Scrivania$ sudo dpkg -i chromium-codecs-ffmpeg-extra_57.0.2987.98-0ubuntu1.1348_amd64.deb
Selezionato il pacchetto chromium-codecs-ffmpeg-extra non precedentemente selezionato.
dpkg: possibile rimozione di chromium-codecs-ffmpeg al posto di chromium-codecs-ffmpeg-extra...
dpkg: il pacchetto chromium-codecs-ffmpeg verrà rimosso al posto di chromium-codecs-ffmpeg-extra
(Lettura del database... 339199 file e directory attualmente installati.)
Preparativi per estrarre chromium-codecs-ffmpeg-extra_57.0.2987.98-0ubuntu1.1348_amd64.deb...
Estrazione di chromium-codecs-ffmpeg-extra (57.0.2987.98-0ubuntu1.1348)...
Configurazione di chromium-codecs-ffmpeg-extra (57.0.2987.98-0ubuntu1.1348)...

Ma quando dice "dpkg: possibile rimozione di chromium-codecs-ffmpeg al posto di chromium-codecs-ffmpeg-extra...
dpkg: il pacchetto chromium-codecs-ffmpeg verrà rimosso al posto di chromium-codecs-ffmpeg-extra" significa che va ad eliminare un pacchetto che era presente per la versione più nuova di chromium al posto di quello che sono andato ad installare ora ?

Ma volendo ora, tramite synaptic posso scegliere di usare una o l'altra versione del programma senza problemi ?
----
Ora comunque dopo aver installato i 2 file .deb indicati anche dal terminale, quando vado in synaptic mi esce sempre il messaggio che ci sono dei pacchetti danneggiati, ma in questo caso è solo 1 ad essere indicato ed è questo questo qui:
http://i.imgur.com/qafIRKU.png

Come devo procedere ora ?

Saluti :)
Rosssiiii
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 366
Iscrizione: dicembre 2016
Distribuzione: Lubuntu 64bit
Sesso: Maschile

Re: Ripristinare la precedente versione di un programma

Messaggioda Rosssiiii » martedì 23 maggio 2017, 21:58

Aiuto...non lasciatemi a metà , non so come procedere ora :)

Saluti :)
Rosssiiii
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 366
Iscrizione: dicembre 2016
Distribuzione: Lubuntu 64bit
Sesso: Maschile

Re: Ripristinare la precedente versione di un programma

Messaggioda fabrixx » martedì 23 maggio 2017, 22:51

Quell'errore è dovuto al mancato downgrade del pacchetto delle lingue che devi installare da qui:
https://launchpad.net/ubuntu/+source/ch ... 48_all.deb


Una volta che hai installato come hai già fatto:

chromium-codecs-ffmpeg_57.0.2987.98-0ubuntu1.1348_amd64.deb
chromium-codecs-ffmpeg-extra_57.0.2987.98-0ubuntu1.1348_amd64.deb


Puoi installare il browser vero e proprio alla versione del downgrade rimuovendo la versione 58.0...
https://launchpad.net/ubuntu/+source/ch ... _amd64.deb
Per un futuro migliore, apt-get dist-upgrade per tutti...
os)(side blog      
Avatar utente
fabrixx
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4157
Iscrizione: maggio 2006
Desktop: gnome 3.23_x86_64 dev_rep
Distribuzione: "Arch Linux" x86_64

Re: Ripristinare la precedente versione di un programma

Messaggioda Rosssiiii » mercoledì 24 maggio 2017, 19:25

fabrixx Immagine ha scritto:Quell'errore è dovuto al mancato downgrade del pacchetto delle lingue che devi installare da qui:
https://launchpad.net/ubuntu/+source/ch ... 48_all.deb


Una volta che hai installato come hai già fatto:

chromium-codecs-ffmpeg_57.0.2987.98-0ubuntu1.1348_amd64.deb
chromium-codecs-ffmpeg-extra_57.0.2987.98-0ubuntu1.1348_amd64.deb


Puoi installare il browser vero e proprio alla versione del downgrade rimuovendo la versione 58.0...
https://launchpad.net/ubuntu/+source/ch ... _amd64.deb


Ciao , grazie :)

Ho installato il primo pacchetto e il risultato del terminale è questo :
Codice: Seleziona tutto
roberto@roberto-Toshiba:~$ cd /home/roberto/Scrivania/
roberto@roberto-Toshiba:~/Scrivania$ sudo dpkg -i chromium-browser-l10n_57.0.2987.98-0ubuntu1.1348_all.deb
[sudo] password di roberto:
dpkg: attenzione: retrocessione di chromium-browser-l10n dalla versione 58.0.3029.96-0ubuntu0.16.04.1279 alla 57.0.2987.98-0ubuntu1.1348
(Lettura del database... 339199 file e directory attualmente installati.)
Preparativi per estrarre chromium-browser-l10n_57.0.2987.98-0ubuntu1.1348_all.deb...
Estrazione di chromium-browser-l10n (57.0.2987.98-0ubuntu1.1348) su (58.0.3029.96-0ubuntu0.16.04.1279)...
dpkg: problemi con le dipendenze impediscono la configurazione di chromium-browser-l10n:
 chromium-browser-l10n dipende da chromium-browser (>= 57.0.2987.98-0ubuntu1.1348); comunque:
  Il pacchetto chromium-browser non è ancora configurato.
 chromium-browser-l10n dipende da chromium-browser (<< 57.0.2987.98-0ubuntu1.1348.1~); comunque:
  Il pacchetto chromium-browser non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto chromium-browser-l10n (--install):
 problemi con le dipendenze - lasciato non configurato
Si sono verificati degli errori nell'elaborazione:
 chromium-browser-l10n
roberto@roberto-Toshiba:~/Scrivania$


vedi per favore se è andato tutto bene,nel finale ho letto quel messaggio di errore, allora prima di installare il successivo pacchetto che sarebbe il browser vorrei una conferma che è andato tutto bene :)

Saluti :)

EDIT: che poi a pensarci bene il pacchetto del browser, l'ultimo che mi hai likato l'avevo già installato, quindi ora non dovrebbe servire più.
Ora è scomparso il messaggio di errore nella barra vicino l'orologio.
Rosssiiii
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 366
Iscrizione: dicembre 2016
Distribuzione: Lubuntu 64bit
Sesso: Maschile

Re: Ripristinare la precedente versione di un programma

Messaggioda fabrixx » mercoledì 24 maggio 2017, 21:53

Per installare chromium-browser-l10n devi avere il pacchetto del browser alla stessa versione.

Verifica cercando chromium su Synaptic cosa e in quali versioni hai installato.
Per un futuro migliore, apt-get dist-upgrade per tutti...
os)(side blog      
Avatar utente
fabrixx
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4157
Iscrizione: maggio 2006
Desktop: gnome 3.23_x86_64 dev_rep
Distribuzione: "Arch Linux" x86_64

Re: Ripristinare la precedente versione di un programma

Messaggioda Rosssiiii » giovedì 25 maggio 2017, 9:10

fabrixx Immagine ha scritto:Per installare chromium-browser-l10n devi avere il pacchetto del browser alla stessa versione.

Verifica cercando chromium su Synaptic cosa e in quali versioni hai installato.

Ciao :)
Su synaptic, la voce che ho selezionata dovrebbe essere il pacchetto del browser :http://i.imgur.com/uMgxsM2.png
lo avevo già installato in passato quello per riportarlo alla versione precedente, tu stesso me lo avevi linkato se non ricordo male :)
-----
Ma come si fa a capire quali sono le dipendenze di un programma ?
--->Provo a rispondermi perchè stamane mi sono svegliato un pò presto e mi sono dedicato a capire come funziona prima di studiare :D

Allora per capire le dipendenze pare non essere complicato, basta aprire synaptic e cercare il pacchetto desiderato,cliccare su proprietà/dipendenze e ci si trova davanti a questa schermata: http://i.imgur.com/Um4QYrI.png
Quindi chromium dipende da tutti quei file che non ho installato io manualmente (vengono installati in automatico o sono di sistema ?) +
chromium-codecs-ffmpeg-extra_57.0.2987.98-0ubuntu1.1348_amd64.deb
chromium-codecs-ffmpeg_57.0.2987.98-0ubuntu1.1348_amd64.deb
chromium-browser-l10n_57.0.2987.98-0ubuntu1.1348_all.deb

Quindi andandoli ad installare manualmente, il primo che devo installare è questo : chromium-browser_57.0.2987.98-0ubuntu1.1348_amd64.deb ? altrimenti forse gli altri .deb neanche me li fa installare o no ?

Come mai andando in questa pagina: https://launchpad.net/ubuntu/+source/ch ... d/12405870
trovo anche quest'altri file ?:
Codice: Seleziona tutto
chromium-browser 57.0.2987.98-0ubuntu1.1348
chromium-browser-dbgsym 57.0.2987.98-0ubuntu1.1348
chromium-browser-l10n 57.0.2987.98-0ubuntu1.1348
chromium-chromedriver 57.0.2987.98-0ubuntu1.1348
chromium-chromedriver-dbgsym 57.0.2987.98-0ubuntu1.1348
chromium-codecs-ffmpeg 57.0.2987.98-0ubuntu1.1348
chromium-codecs-ffmpeg-dbgsym 57.0.2987.98-0ubuntu1.1348
chromium-codecs-ffmpeg-extra 57.0.2987.98-0ubuntu1.1348
chromium-codecs-ffmpeg-extra-dbgsym 57.0.2987.98-0ubuntu1.1348


----
Ora faccio una prova con un'altro pacchetto, ad esempio ho preso opera: http://i.imgur.com/G0A29lO.png
nel caso di opera non c'è nessun pacchetto, ne consiglia solo due ma non sono richiesti per forza.
----
Nel caso di firefox: http://i.imgur.com/x8lKUUr.png in caso volessi fare un downgrade gli unici pacchetti che dovrei andare a toccare oltre a quello principale di firefox sarebbe quello della lingua (firefox-locale-en ; firefox-locale-ita) ma non capisco perchè non è indicato tra le dipendenze nella schermata proprietà del pacchetto firefox ?


Forse quello delle dipendenze è un discorso più complicato di quello che io penso o forse il contrario...però mi piacerebbe capirne di più :)

Buona giornata :)
Rosssiiii
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 366
Iscrizione: dicembre 2016
Distribuzione: Lubuntu 64bit
Sesso: Maschile

Re: Ripristinare la precedente versione di un programma

Messaggioda fabrixx » giovedì 25 maggio 2017, 21:19

Quindi andandoli ad installare manualmente, il primo che devo installare è questo : chromium-browser_57.0.2987.98-0ubuntu1.1348_amd64.deb ? altrimenti forse gli altri .deb neanche me li fa installare o no ?


Se installi tramite Synaptic le dipendenze vengono gestite in automatico, se le installi manualmente no. Le puoi tuttavia piazzare tutte in una cartella e una volta entrato in essa dare il comando:
Codice: Seleziona tutto
sudo dpkg -i *.deb


Come mai andando in questa pagina: https://launchpad.net/ubuntu/+source/ch ... d/12405870
trovo anche quest'altri file ?:
Codice: Seleziona tutto
chromium-browser 57.0.2987.98-0ubuntu1.1348
chromium-browser-dbgsym 57.0.2987.98-0ubuntu1.1348
chromium-browser-l10n 57.0.2987.98-0ubuntu1.1348
chromium-chromedriver 57.0.2987.98-0ubuntu1.1348
chromium-chromedriver-dbgsym 57.0.2987.98-0ubuntu1.1348
chromium-codecs-ffmpeg 57.0.2987.98-0ubuntu1.1348
chromium-codecs-ffmpeg-dbgsym 57.0.2987.98-0ubuntu1.1348
chromium-codecs-ffmpeg-extra 57.0.2987.98-0ubuntu1.1348
chromium-codecs-ffmpeg-extra-dbgsym 57.0.2987.98-0ubuntu1.1348


Ci sono pacchetti relativi a Chromium che non è necessario installare per un uso normale come i dbgsym (AutomaticDebugPackages) o altri come quelli relativi a ffmeg che potrebbero non essere obbligatoriamente richiesti.

Quello è solo l'elenco dei binari amd64 e sotto trovi i relativi .deb


----
Ora faccio una prova con un'altro pacchetto, ad esempio ho preso opera: http://i.imgur.com/G0A29lO.png
nel caso di opera non c'è nessun pacchetto, ne consiglia solo due ma non sono richiesti per forza.
----
Nel caso di firefox: http://i.imgur.com/x8lKUUr.png in caso volessi fare un downgrade gli unici pacchetti che dovrei andare a toccare oltre a quello principale di firefox sarebbe quello della lingua (firefox-locale-en ; firefox-locale-ita) ma non capisco perchè non è indicato tra le dipendenze nella schermata proprietà del pacchetto firefox ?

firefox-locale-en e firefox-locale-ita sono localizzazioni specifiche inglese e italiano, il .deb relativo alla lingua di Chrome è multilingual e immagino vada installato per forza.
firefox-locale-ita dipende da firefox e non viceversa, ognuno installa la lingua preferita.
Se non ricordo male di default viene installato il pacchetto in inglese e quello relativo alla lingua del sistema in uso anche se in taluni casi non è automatico.

Per il downgrade di Firefox è possibile anche scaricare la versione preferita anche dall'ftp di mozilla


Forse quello delle dipendenze è un discorso più complicato di quello che io penso o forse il contrario...però mi piacerebbe capirne di più :)



Le dipendenze nascono per facilitare l'installazione , in genere se si fa tutto da Synaptic non ci sono problemi. Quando si effettua un downgrade ce ne sono invece quasi sempre a causa delle dipendenze e molto spesso è impossibile venirne a capo quando coinvolgono in profondità il sistema.

Un'altra soluzione è bloccare un pacchetto da Pacchetto>Blocca versione di Synaptic per evitare venga aggiornato (se lo è già è troppo tardi).

Ora mi spiace di averti portato a questi casini, non so se poi avevi provato il metodo descritto all'inizio nella guida al downgrade che già ti avevo segnalato come il più corretto.
Per un futuro migliore, apt-get dist-upgrade per tutti...
os)(side blog      
Avatar utente
fabrixx
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4157
Iscrizione: maggio 2006
Desktop: gnome 3.23_x86_64 dev_rep
Distribuzione: "Arch Linux" x86_64

Re: Ripristinare la precedente versione di un programma

Messaggioda enziosavio » venerdì 26 maggio 2017, 22:17

È complicato rompere le dipendenze in Ubuntu , perchè io le rompo senza conseguenze da una vita in Opensuse , anche il Downgrade è praticabile senza conseguenze , e Opensuse non è l' unica ce ne son altre
Rivestì la corazza come gigante , cinse l'armatura di guerra e impegnò battaglia difendendo il campo con la spada
Avatar utente
enziosavio
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2301
Iscrizione: novembre 2010
Desktop: Gnome-Shell
Distribuzione: 64bit
Sesso: Maschile

Precedente

Torna a Applicazioni

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 10 ospiti

cron