[Risolto] Problemi con Python3.6

Installazione, configurazione e uso di programmi e strumenti.

[Risolto] Problemi con Python3.6

Messaggioda 500maniaco » domenica 23 settembre 2018, 23:37

Da qualche giorno ho un problema con Python3.6 che mi ha incasinato tutti i programmi . Ho tentato la reistallazione ma senza risultato. vi allego gli errori che ricevo.

Codice: Seleziona tutto
michael@Xubu:~$ sudo apt-get upgrade
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Calcolo dell'aggiornamento... Fatto
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
3 non completamente installati o rimossi.
Dopo quest'operazione, verranno occupati 0 B di spazio su disco.
Continuare? [S/n] S
Configurazione di python3.6 (3.6.6-1~18.04)...
Traceback (most recent call last):
  File "/usr/lib/python3.6/py_compile.py", line 186, in <module>
    sys.exit(main())
  File "/usr/lib/python3.6/py_compile.py", line 178, in main
    compile(filename, doraise=True)
  File "/usr/lib/python3.6/py_compile.py", line 122, in compile
    source_bytes = loader.get_data(file)
  File "<frozen importlib._bootstrap_external>", line 833, in get_data
OSError: [Errno 5] Input/output error
dpkg: errore nell'elaborare il pacchetto python3.6 (--configure):
 installed python3.6 package post-installation script subprocess returned error exit status 1
dpkg: problemi con le dipendenze impediscono la configurazione di python3.6-examples:
 python3.6-examples dipende da python3.6:any (>= 3.6.6-1~18.04); tuttavia:
  Il pacchetto python3.6 non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto python3.6-examples (--configure):
 problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di python3-uno:
 python3-uno dipende da python3.6; tuttavia:
  Il pacchetto python3.6 non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto python3-uno (--configure):
 problemi con le dipendenze - lasciato non configurato
Segnalazione apport non scritta poiché il messaggio di errore indica la presenza di un fallimento precedente.
                             Segnalazione apport non scritta poiché il messaggio di errore indica la presenza di un fallimento precedente.
                                                          Si sono verificati degli errori nell'elaborazione:
 python3.6
 python3.6-examples
 python3-uno
E: Sub-process /usr/bin/dpkg returned an error code (1)
michael@Xubu:~$
Ultima modifica di 500maniaco il lunedì 8 ottobre 2018, 18:09, modificato 1 volta in totale.
500maniaco
Prode Principiante
 
Messaggi: 207
Iscrizione: gennaio 2009

Re: Problemi con Python3.6

Messaggioda wilecoyote » lunedì 24 settembre 2018, 14:04

:) Salve, sembra venuta male l'installazione di 'python3.6', prova a rimuoverlo e reinstallarlo.

Codice: Seleziona tutto
sudo rm /var/lib/dpkg/info/python3.6.*
 sudo dpkg --configure -a
 sudo apt update
 sudo apt install --reinstall python3.6
 sudo apt upgrade


Il 1° rimuove le informazioni del pacchetto oggetto, il 2° riconfigura il sistema pacchetti, il 3° aggiorna la lista pacchetti, il 4° forza il reinstallo, il 5° installa eventuali aggiornamenti.

:ciao: Ciao
ACER Extensa 5230E 2,2 Ghz cpu Celeron 900 hdd 160 GB Ram 1GB scheda video Intel GM500
ACER Extensa 5635Z 2,2 Ghz cpu Celeron T3100 hdd 320 GB Ram 4 GB scheda video Intel Mobile 4
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
wilecoyote
Rampante Reduce
Rampante Reduce
 
Messaggi: 9187
Iscrizione: agosto 2009
Località: Ceranesi - Ge
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14/16/18.04 LTS 64bit
Sesso: Maschile

Re: Problemi con Python3.6

Messaggioda 500maniaco » martedì 25 settembre 2018, 20:13

Ho provato i comandi ma con pochi risultati:

Codice: Seleziona tutto
michael@Xubu:~$ sudo rm /var/lib/dpkg/info/python3.6.*
[sudo] password di michael:
michael@Xubu:~$ sudo dpkg --configure -a
Configurazione di python3.6 (3.6.6-1~18.04)...
Configurazione di python3.6-examples (3.6.6-1~18.04)...
Configurazione di python3-uno (1:6.0.6-0ubuntu0.18.04.1)...
michael@Xubu:~$ sudo apt update
Trovato:1 http://archive.canonical.com/ubuntu bionic InRelease                 
Trovato:2 http://ppa.launchpad.net/deadsnakes/ppa/ubuntu bionic InRelease     
Trovato:3 http://es-mirrors.evowise.com/ubuntu bionic InRelease               
Trovato:4 http://es-mirrors.evowise.com/ubuntu bionic-updates InRelease       
Trovato:5 http://ppa.launchpad.net/gezakovacs/ppa/ubuntu bionic InRelease     
Trovato:6 http://es-mirrors.evowise.com/ubuntu bionic-backports InRelease     
Trovato:7 http://es-mirrors.evowise.com/ubuntu bionic-security InRelease       
Trovato:8 http://ppa.launchpad.net/linuxuprising/java/ubuntu bionic InRelease
Trovato:9 http://es-mirrors.evowise.com/ubuntu bionic-proposed InRelease     
Lettura elenco dei pacchetti... Fatto                 
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Tutti i pacchetti sono aggiornati.
michael@Xubu:~$ sudo apt install --reinstall python3.6
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
0 aggiornati, 0 installati, 1 reinstallati, 0 da rimuovere e 0 non aggiornati.
È necessario scaricare 190 kB di archivi.
Dopo quest'operazione, verranno occupati 0 B di spazio su disco.
Scaricamento di:1 http://es-mirrors.evowise.com/ubuntu bionic-updates/main amd64 python3.6 amd64 3.6.6-1~18.04 [190 kB]
Recuperati 190 kB in 1s (158 kB/s)
dpkg: attenzione: file con l'elenco dei file del pacchetto "python3.6" mancante, il pacchetto viene considerato senza alcun file attualmente installato
(Lettura del database... 257963 file e directory attualmente installati.)
Preparativi per estrarre .../python3.6_3.6.6-1~18.04_amd64.deb...
Estrazione di python3.6 (3.6.6-1~18.04) su (3.6.6-1~18.04)...
Configurazione di python3.6 (3.6.6-1~18.04)...
Traceback (most recent call last):
  File "/usr/lib/python3.6/py_compile.py", line 186, in <module>
    sys.exit(main())
  File "/usr/lib/python3.6/py_compile.py", line 178, in main
    compile(filename, doraise=True)
  File "/usr/lib/python3.6/py_compile.py", line 122, in compile
    source_bytes = loader.get_data(file)
  File "<frozen importlib._bootstrap_external>", line 833, in get_data
OSError: [Errno 5] Input/output error
dpkg: errore nell'elaborare il pacchetto python3.6 (--configure):
 installed python3.6 package post-installation script subprocess returned error exit status 1
Elaborazione dei trigger per mime-support (3.60ubuntu1)...
Elaborazione dei trigger per desktop-file-utils (0.23-1ubuntu3.18.04.1)...
Elaborazione dei trigger per man-db (2.8.3-2ubuntu0.1)...
Elaborazione dei trigger per gnome-menus (3.13.3-11ubuntu1.1)...
Si sono verificati degli errori nell'elaborazione:
 python3.6
E: Sub-process /usr/bin/dpkg returned an error code (1)
michael@Xubu:~$ sudo apt-get upgrade
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Calcolo dell'aggiornamento... Fatto
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
1 non completamente installati o rimossi.
Dopo quest'operazione, verranno occupati 0 B di spazio su disco.
Continuare? [S/n] S
Configurazione di python3.6 (3.6.6-1~18.04)...
Traceback (most recent call last):
  File "/usr/lib/python3.6/py_compile.py", line 186, in <module>
    sys.exit(main())
  File "/usr/lib/python3.6/py_compile.py", line 178, in main
    compile(filename, doraise=True)
  File "/usr/lib/python3.6/py_compile.py", line 122, in compile
    source_bytes = loader.get_data(file)
  File "<frozen importlib._bootstrap_external>", line 833, in get_data
OSError: [Errno 5] Input/output error
dpkg: errore nell'elaborare il pacchetto python3.6 (--configure):
 installed python3.6 package post-installation script subprocess returned error exit status 1
Si sono verificati degli errori nell'elaborazione:
 python3.6
E: Sub-process /usr/bin/dpkg returned an error code (1)
michael@Xubu:~$
500maniaco
Prode Principiante
 
Messaggi: 207
Iscrizione: gennaio 2009

Re: Problemi con Python3.6

Messaggioda rai » martedì 25 settembre 2018, 20:52

Secondo me quei ppa sono fortemente sospetti di essere responsabili di questo problema. Prova a disabilitarli e ripeti i comandi che ti erano stati consigliati.
E poi, hai un motivo importante per avere abilitato i repo proposed?
rai
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2276
Iscrizione: maggio 2008
Località: Palermo
Distribuzione: 16.04

Re: Problemi con Python3.6

Messaggioda wilecoyote » mercoledì 26 settembre 2018, 13:32

:) Salve, oltre al ppa che rende disponibili versioni alternative di Python, probabilmente creando un casotto, c'è un motivo per cui usi come repository il http://es-mirrors.evowise.com/ubuntu e non quello ufficiale http://it.archive.ubuntu.com/ubuntu/ ?

Per provare senza il ppa dai il comando:

Codice: Seleziona tutto
sudo mv /etc/apt/sources.list.d /etc/apt/sources.list.d~


Sposterà in backup la directory in oggetto.

Se non c'è un motivo per usare un repository non ufficiale, per correggere dai il comando:

Codice: Seleziona tutto
software-properties-gtk


Nella scheda 'Software per Ubuntu' nel menù a scomparsa seleziona 'Server in Italia' od in subordine 'Server principale'.

Poi ridai i comandi che già postai.

:ciao: Ciao
ACER Extensa 5230E 2,2 Ghz cpu Celeron 900 hdd 160 GB Ram 1GB scheda video Intel GM500
ACER Extensa 5635Z 2,2 Ghz cpu Celeron T3100 hdd 320 GB Ram 4 GB scheda video Intel Mobile 4
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
wilecoyote
Rampante Reduce
Rampante Reduce
 
Messaggi: 9187
Iscrizione: agosto 2009
Località: Ceranesi - Ge
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14/16/18.04 LTS 64bit
Sesso: Maschile

Re: Problemi con Python3.6

Messaggioda 500maniaco » giovedì 27 settembre 2018, 7:18

Ancora nulla! Ho provato ma alla fine ho sempre il messaggio di errore di Python3.6.
Il gestore aggiornamenti non si apre e non riesco a cambiare il server.
Quando arriva l'aggiornamento e si apre la finestra con la notifica per l'installazione, non la esegue, mi da il messaggio che si è chiusa inaspettatamente.
comunque questi sono i risultati.


Codice: Seleziona tutto
michael@Xubu:~$ sudo mv /etc/apt/sources.list.d /etc/apt/sources.list.d~
[sudo] password di michael:
michael@Xubu:~$ software-properties-gtk
Traceback (most recent call last):
  File "/usr/bin/software-properties-gtk", line 37, in <module>
    from softwareproperties.gtk.SoftwarePropertiesGtk import SoftwarePropertiesGtk
  File "/usr/lib/python3/dist-packages/softwareproperties/gtk/SoftwarePropertiesGtk.py", line 53, in <module>
    from .DialogCacheOutdated import DialogCacheOutdated
  File "/usr/lib/python3/dist-packages/softwareproperties/gtk/DialogCacheOutdated.py", line 30, in <module>
    from aptdaemon.gtk3widgets import AptErrorDialog, AptProgressDialog
  File "/usr/lib/python3/dist-packages/aptdaemon/gtk3widgets.py", line 35, in <module>
    import difflib
  File "<frozen importlib._bootstrap>", line 971, in _find_and_load
  File "<frozen importlib._bootstrap>", line 955, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 665, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 674, in exec_module
  File "<frozen importlib._bootstrap_external>", line 780, in get_code
  File "<frozen importlib._bootstrap_external>", line 833, in get_data
OSError: [Errno 5] Errore di input/output
michael@Xubu:~$ sudo rm /var/lib/dpkg/info/python3.6.*
michael@Xubu:~$ sudo dpkg --configure -a
Configurazione di python3.6 (3.6.6-1~18.04)...
michael@Xubu:~$ sudo apt update
Trovato:1 http://es-mirrors.evowise.com/ubuntu bionic InRelease
Scaricamento di:2 http://es-mirrors.evowise.com/ubuntu bionic-updates InRelease [88,7 kB]
Trovato:3 http://archive.canonical.com/ubuntu bionic InRelease
Scaricamento di:4 http://es-mirrors.evowise.com/ubuntu bionic-backports InRelease [74,6 kB]
Scaricamento di:5 http://es-mirrors.evowise.com/ubuntu bionic-security InRelease [83,2 kB]
Scaricamento di:6 http://es-mirrors.evowise.com/ubuntu bionic-proposed InRelease [242 kB]
Scaricamento di:7 http://es-mirrors.evowise.com/ubuntu bionic-updates/main i386 Packages [318 kB]
Scaricamento di:8 http://es-mirrors.evowise.com/ubuntu bionic-updates/main amd64 Packages [354 kB]
Scaricamento di:9 http://es-mirrors.evowise.com/ubuntu bionic-updates/main Translation-en [136 kB]
Scaricamento di:10 http://es-mirrors.evowise.com/ubuntu bionic-updates/main amd64 DEP-11 Metadata [146 kB]
Scaricamento di:11 http://es-mirrors.evowise.com/ubuntu bionic-updates/main DEP-11 48x48 Icons [39,1 kB]
Scaricamento di:12 http://es-mirrors.evowise.com/ubuntu bionic-updates/main DEP-11 64x64 Icons [73,9 kB]
Scaricamento di:13 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 Packages [214 kB]
Scaricamento di:14 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe i386 Packages [214 kB]
Scaricamento di:15 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe Translation-en [101 kB]
Scaricamento di:16 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 DEP-11 Metadata [182 kB]
Scaricamento di:17 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe DEP-11 48x48 Icons [177 kB]
Scaricamento di:18 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe DEP-11 64x64 Icons [290 kB]
Scaricamento di:19 http://es-mirrors.evowise.com/ubuntu bionic-updates/multiverse amd64 DEP-11 Metadata [2.468 B]
Scaricamento di:20 http://es-mirrors.evowise.com/ubuntu bionic-backports/universe amd64 DEP-11 Metadata [5.100 B]
Scaricamento di:21 http://es-mirrors.evowise.com/ubuntu bionic-security/main amd64 Packages [171 kB]
Scaricamento di:22 http://es-mirrors.evowise.com/ubuntu bionic-security/main i386 Packages [137 kB]
Scaricamento di:23 http://es-mirrors.evowise.com/ubuntu bionic-security/main Translation-en [67,3 kB]
Scaricamento di:24 http://es-mirrors.evowise.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [204 B]
Scaricamento di:25 http://es-mirrors.evowise.com/ubuntu bionic-security/universe amd64 Packages [74,7 kB]
Scaricamento di:26 http://es-mirrors.evowise.com/ubuntu bionic-security/universe i386 Packages [74,5 kB]
Scaricamento di:27 http://es-mirrors.evowise.com/ubuntu bionic-security/universe Translation-en [42,3 kB]
Scaricamento di:28 http://es-mirrors.evowise.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [6.828 B]
Scaricamento di:29 http://es-mirrors.evowise.com/ubuntu bionic-security/universe DEP-11 64x64 Icons [11,3 kB]
Scaricamento di:30 http://es-mirrors.evowise.com/ubuntu bionic-proposed/main amd64 Packages [125 kB]
Scaricamento di:31 http://es-mirrors.evowise.com/ubuntu bionic-proposed/main i386 Packages [109 kB]
Scaricamento di:32 http://es-mirrors.evowise.com/ubuntu bionic-proposed/main Translation-en [44,7 kB]
Scaricamento di:33 http://es-mirrors.evowise.com/ubuntu bionic-proposed/main amd64 DEP-11 Metadata [76,9 kB]
Scaricamento di:34 http://es-mirrors.evowise.com/ubuntu bionic-proposed/main DEP-11 48x48 Icons [19,4 kB]
Scaricamento di:35 http://es-mirrors.evowise.com/ubuntu bionic-proposed/main DEP-11 64x64 Icons [40,2 kB]
Scaricamento di:36 http://es-mirrors.evowise.com/ubuntu bionic-proposed/universe amd64 Packages [374 kB]
Scaricamento di:37 http://es-mirrors.evowise.com/ubuntu bionic-proposed/universe Translation-en [61,2 kB]
Scaricamento di:38 http://es-mirrors.evowise.com/ubuntu bionic-proposed/universe amd64 DEP-11 Metadata [30,3 kB]
Recuperati 4.207 kB in 7s (635 kB/s)                                           
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
52 pacchetti possono essere aggiornati: eseguire "apt list --upgradable" per vederli.
michael@Xubu:~$ apt list --upgradable
Elencazione... Fatto
grub-common/bionic-proposed 2.02-2ubuntu8.5 amd64 [aggiornabile da: 2.02-2ubuntu8.4]
grub-pc/bionic-proposed 2.02-2ubuntu8.5 amd64 [aggiornabile da: 2.02-2ubuntu8.4]
grub-pc-bin/bionic-proposed 2.02-2ubuntu8.5 amd64 [aggiornabile da: 2.02-2ubuntu8.4]
grub2-common/bionic-proposed 2.02-2ubuntu8.5 amd64 [aggiornabile da: 2.02-2ubuntu8.4]
initramfs-tools/bionic-proposed,bionic-proposed 0.130ubuntu3.4 all [aggiornabile da: 0.130ubuntu3.3]
initramfs-tools-bin/bionic-proposed 0.130ubuntu3.4 amd64 [aggiornabile da: 0.130ubuntu3.3]
initramfs-tools-core/bionic-proposed,bionic-proposed 0.130ubuntu3.4 all [aggiornabile da: 0.130ubuntu3.3]
libopencv-calib3d-dev/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-calib3d3.2/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-contrib-dev/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-contrib3.2/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-core-dev/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-core3.2/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-dev/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-features2d-dev/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-features2d3.2/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-flann-dev/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-flann3.2/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-highgui-dev/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-highgui3.2/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-imgcodecs-dev/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-imgcodecs3.2/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-imgproc-dev/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-imgproc3.2/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-ml-dev/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-ml3.2/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-objdetect-dev/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-objdetect3.2/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-photo-dev/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-photo3.2/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-shape-dev/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-shape3.2/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-stitching-dev/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-stitching3.2/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-superres-dev/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-superres3.2/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-ts-dev/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-video-dev/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-video3.2/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-videoio-dev/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-videoio3.2/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-videostab-dev/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-videostab3.2/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-viz-dev/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv-viz3.2/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv3.2-java/bionic-updates,bionic-updates,bionic-security,bionic-security 3.2.0+dfsg-4ubuntu0.1 all [aggiornabile da: 3.2.0+dfsg-4build2]
libopencv3.2-jni/bionic-updates,bionic-security 3.2.0+dfsg-4ubuntu0.1 amd64 [aggiornabile da: 3.2.0+dfsg-4build2]
libudisks2-0/bionic-updates,bionic-security 2.7.6-3ubuntu0.2 amd64 [aggiornabile da: 2.7.6-3ubuntu0.1]
linux-image-generic/bionic-proposed 4.15.0.36.38 amd64 [aggiornabile da: 4.15.0.35.37]
linux-libc-dev/bionic-proposed 4.15.0-36.39 amd64 [aggiornabile da: 4.15.0-35.38]
opencv-data/bionic-updates,bionic-updates,bionic-security,bionic-security 3.2.0+dfsg-4ubuntu0.1 all [aggiornabile da: 3.2.0+dfsg-4build2]
udisks2/bionic-updates,bionic-security 2.7.6-3ubuntu0.2 amd64 [aggiornabile da: 2.7.6-3ubuntu0.1]
michael@Xubu:~$ sudo apt install --reinstall python3.6
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
0 aggiornati, 0 installati, 1 reinstallati, 0 da rimuovere e 52 non aggiornati.
È necessario scaricare 0 B/190 kB di archivi.
Dopo quest'operazione, verranno occupati 0 B di spazio su disco.
dpkg: attenzione: file con l'elenco dei file del pacchetto "python3.6" mancante, il pacchetto viene considerato senza alcun file attualmente installato
(Lettura del database... 257963 file e directory attualmente installati.)
Preparativi per estrarre .../python3.6_3.6.6-1~18.04_amd64.deb...
Estrazione di python3.6 (3.6.6-1~18.04) su (3.6.6-1~18.04)...
Configurazione di python3.6 (3.6.6-1~18.04)...
Traceback (most recent call last):
  File "/usr/lib/python3.6/py_compile.py", line 186, in <module>
    sys.exit(main())
  File "/usr/lib/python3.6/py_compile.py", line 178, in main
    compile(filename, doraise=True)
  File "/usr/lib/python3.6/py_compile.py", line 122, in compile
    source_bytes = loader.get_data(file)
  File "<frozen importlib._bootstrap_external>", line 833, in get_data
OSError: [Errno 5] Input/output error
dpkg: errore nell'elaborare il pacchetto python3.6 (--configure):
 installed python3.6 package post-installation script subprocess returned error exit status 1
Elaborazione dei trigger per mime-support (3.60ubuntu1)...
Elaborazione dei trigger per desktop-file-utils (0.23-1ubuntu3.18.04.1)...
Elaborazione dei trigger per man-db (2.8.3-2ubuntu0.1)...
Elaborazione dei trigger per gnome-menus (3.13.3-11ubuntu1.1)...
Si sono verificati degli errori nell'elaborazione:
 python3.6
E: Sub-process /usr/bin/dpkg returned an error code (1)
michael@Xubu:~$ sudo apt-get upgrade
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Calcolo dell'aggiornamento... Fatto
I seguenti pacchetti sono stati mantenuti alla versione attuale:
  linux-image-generic
I seguenti pacchetti saranno aggiornati:
  grub-common grub-pc grub-pc-bin grub2-common initramfs-tools
  initramfs-tools-bin initramfs-tools-core libopencv-calib3d-dev
  libopencv-calib3d3.2 libopencv-contrib-dev libopencv-contrib3.2
  libopencv-core-dev libopencv-core3.2 libopencv-dev libopencv-features2d-dev
  libopencv-features2d3.2 libopencv-flann-dev libopencv-flann3.2
  libopencv-highgui-dev libopencv-highgui3.2 libopencv-imgcodecs-dev
  libopencv-imgcodecs3.2 libopencv-imgproc-dev libopencv-imgproc3.2
  libopencv-ml-dev libopencv-ml3.2 libopencv-objdetect-dev
  libopencv-objdetect3.2 libopencv-photo-dev libopencv-photo3.2
  libopencv-shape-dev libopencv-shape3.2 libopencv-stitching-dev
  libopencv-stitching3.2 libopencv-superres-dev libopencv-superres3.2
  libopencv-ts-dev libopencv-video-dev libopencv-video3.2
  libopencv-videoio-dev libopencv-videoio3.2 libopencv-videostab-dev
  libopencv-videostab3.2 libopencv-viz-dev libopencv-viz3.2 libopencv3.2-java
  libopencv3.2-jni libudisks2-0 linux-libc-dev opencv-data udisks2
51 aggiornati, 0 installati, 0 da rimuovere e 1 non aggiornati.
1 non completamente installati o rimossi.
È necessario scaricare 18,6 MB di archivi.
Dopo quest'operazione, verranno occupati 46,1 kB di spazio su disco.
Continuare? [S/n] S
Scaricamento di:1 http://es-mirrors.evowise.com/ubuntu bionic-proposed/main amd64 initramfs-tools all 0.130ubuntu3.4 [9.576 B]
Scaricamento di:2 http://es-mirrors.evowise.com/ubuntu bionic-proposed/main amd64 initramfs-tools-core all 0.130ubuntu3.4 [47,9 kB]
Scaricamento di:3 http://es-mirrors.evowise.com/ubuntu bionic-proposed/main amd64 initramfs-tools-bin amd64 0.130ubuntu3.4 [12,9 kB]
Scaricamento di:4 http://es-mirrors.evowise.com/ubuntu bionic-proposed/main amd64 grub-pc amd64 2.02-2ubuntu8.5 [137 kB]
Scaricamento di:5 http://es-mirrors.evowise.com/ubuntu bionic-proposed/main amd64 grub-pc-bin amd64 2.02-2ubuntu8.5 [900 kB]
Scaricamento di:6 http://es-mirrors.evowise.com/ubuntu bionic-proposed/main amd64 grub2-common amd64 2.02-2ubuntu8.5 [532 kB]
Scaricamento di:7 http://es-mirrors.evowise.com/ubuntu bionic-proposed/main amd64 grub-common amd64 2.02-2ubuntu8.5 [1.771 kB]
Scaricamento di:8 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 opencv-data all 3.2.0+dfsg-4ubuntu0.1 [1.196 kB]
Scaricamento di:9 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-dev amd64 3.2.0+dfsg-4ubuntu0.1 [223 kB]
Scaricamento di:10 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-contrib-dev amd64 3.2.0+dfsg-4ubuntu0.1 [1.862 kB]
Scaricamento di:11 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-videostab-dev amd64 3.2.0+dfsg-4ubuntu0.1 [121 kB]
Scaricamento di:12 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-stitching-dev amd64 3.2.0+dfsg-4ubuntu0.1 [208 kB]
Scaricamento di:13 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-calib3d-dev amd64 3.2.0+dfsg-4ubuntu0.1 [502 kB]
Scaricamento di:14 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-features2d-dev amd64 3.2.0+dfsg-4ubuntu0.1 [280 kB]
Scaricamento di:15 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-flann-dev amd64 3.2.0+dfsg-4ubuntu0.1 [162 kB]
Scaricamento di:16 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-objdetect-dev amd64 3.2.0+dfsg-4ubuntu0.1 [161 kB]
Scaricamento di:17 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-ml-dev amd64 3.2.0+dfsg-4ubuntu0.1 [283 kB]
Scaricamento di:18 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-contrib3.2 amd64 3.2.0+dfsg-4ubuntu0.1 [1.450 kB]
Scaricamento di:19 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv3.2-jni amd64 3.2.0+dfsg-4ubuntu0.1 [188 kB]
Scaricamento di:20 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-stitching3.2 amd64 3.2.0+dfsg-4ubuntu0.1 [166 kB]
Scaricamento di:21 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-objdetect3.2 amd64 3.2.0+dfsg-4ubuntu0.1 [137 kB]
Scaricamento di:22 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-videostab3.2 amd64 3.2.0+dfsg-4ubuntu0.1 [97,7 kB]
Scaricamento di:23 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-calib3d3.2 amd64 3.2.0+dfsg-4ubuntu0.1 [427 kB]
Scaricamento di:24 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-features2d3.2 amd64 3.2.0+dfsg-4ubuntu0.1 [231 kB]
Scaricamento di:25 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-ml3.2 amd64 3.2.0+dfsg-4ubuntu0.1 [223 kB]
Scaricamento di:26 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-superres-dev amd64 3.2.0+dfsg-4ubuntu0.1 [51,7 kB]
Scaricamento di:27 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-highgui-dev amd64 3.2.0+dfsg-4ubuntu0.1 [30,8 kB]
Scaricamento di:28 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-videoio-dev amd64 3.2.0+dfsg-4ubuntu0.1 [110 kB]
Scaricamento di:29 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-superres3.2 amd64 3.2.0+dfsg-4ubuntu0.1 [42,4 kB]
Scaricamento di:30 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-highgui3.2 amd64 3.2.0+dfsg-4ubuntu0.1 [18,9 kB]
Scaricamento di:31 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-videoio3.2 amd64 3.2.0+dfsg-4ubuntu0.1 [77,2 kB]
Scaricamento di:32 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-imgcodecs-dev amd64 3.2.0+dfsg-4ubuntu0.1 [119 kB]
Scaricamento di:33 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-imgcodecs3.2 amd64 3.2.0+dfsg-4ubuntu0.1 [82,3 kB]
Scaricamento di:34 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-shape-dev amd64 3.2.0+dfsg-4ubuntu0.1 [70,4 kB]
Scaricamento di:35 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-shape3.2 amd64 3.2.0+dfsg-4ubuntu0.1 [56,3 kB]
Scaricamento di:36 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-video-dev amd64 3.2.0+dfsg-4ubuntu0.1 [148 kB]
Scaricamento di:37 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-photo-dev amd64 3.2.0+dfsg-4ubuntu0.1 [222 kB]
Scaricamento di:38 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-imgproc-dev amd64 3.2.0+dfsg-4ubuntu0.1 [1.010 kB]
Scaricamento di:39 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-photo3.2 amd64 3.2.0+dfsg-4ubuntu0.1 [188 kB]
Scaricamento di:40 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-video3.2 amd64 3.2.0+dfsg-4ubuntu0.1 [122 kB]
Scaricamento di:41 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-imgproc3.2 amd64 3.2.0+dfsg-4ubuntu0.1 [818 kB]
Scaricamento di:42 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-viz-dev amd64 3.2.0+dfsg-4ubuntu0.1 [150 kB]
Scaricamento di:43 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-viz3.2 amd64 3.2.0+dfsg-4ubuntu0.1 [111 kB]
Scaricamento di:44 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-flann3.2 amd64 3.2.0+dfsg-4ubuntu0.1 [91,5 kB]
Scaricamento di:45 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-ts-dev amd64 3.2.0+dfsg-4ubuntu0.1 [266 kB]
Scaricamento di:46 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-core-dev amd64 3.2.0+dfsg-4ubuntu0.1 [1.094 kB]
Scaricamento di:47 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv-core3.2 amd64 3.2.0+dfsg-4ubuntu0.1 [709 kB]
Scaricamento di:48 http://es-mirrors.evowise.com/ubuntu bionic-updates/universe amd64 libopencv3.2-java all 3.2.0+dfsg-4ubuntu0.1 [387 kB]
Scaricamento di:49 http://es-mirrors.evowise.com/ubuntu bionic-updates/main amd64 libudisks2-0 amd64 2.7.6-3ubuntu0.2 [98,1 kB]
Scaricamento di:50 http://es-mirrors.evowise.com/ubuntu bionic-proposed/main amd64 linux-libc-dev amd64 4.15.0-36.39 [999 kB]
Scaricamento di:51 http://es-mirrors.evowise.com/ubuntu bionic-updates/main amd64 udisks2 amd64 2.7.6-3ubuntu0.2 [231 kB]
Recuperati 18,6 MB in 22s (851 kB/s)                                           
Estrazione dei template dai pacchetti: 100%
Preconfigurazione dei pacchetti in corso
(Lettura del database... 257981 file e directory attualmente installati.)
Preparativi per estrarre .../00-initramfs-tools_0.130ubuntu3.4_all.deb...
Estrazione di initramfs-tools (0.130ubuntu3.4) su (0.130ubuntu3.3)...
Preparativi per estrarre .../01-initramfs-tools-core_0.130ubuntu3.4_all.deb...
Estrazione di initramfs-tools-core (0.130ubuntu3.4) su (0.130ubuntu3.3)...
Preparativi per estrarre .../02-initramfs-tools-bin_0.130ubuntu3.4_amd64.deb...
Estrazione di initramfs-tools-bin (0.130ubuntu3.4) su (0.130ubuntu3.3)...
Preparativi per estrarre .../03-grub-pc_2.02-2ubuntu8.5_amd64.deb...
Estrazione di grub-pc (2.02-2ubuntu8.5) su (2.02-2ubuntu8.4)...
Preparativi per estrarre .../04-grub-pc-bin_2.02-2ubuntu8.5_amd64.deb...
Estrazione di grub-pc-bin (2.02-2ubuntu8.5) su (2.02-2ubuntu8.4)...
Preparativi per estrarre .../05-grub2-common_2.02-2ubuntu8.5_amd64.deb...
Estrazione di grub2-common (2.02-2ubuntu8.5) su (2.02-2ubuntu8.4)...
Preparativi per estrarre .../06-grub-common_2.02-2ubuntu8.5_amd64.deb...
Estrazione di grub-common (2.02-2ubuntu8.5) su (2.02-2ubuntu8.4)...
Preparativi per estrarre .../07-opencv-data_3.2.0+dfsg-4ubuntu0.1_all.deb...
Estrazione di opencv-data (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../08-libopencv-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-dev (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../09-libopencv-contrib-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-contrib-dev:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../10-libopencv-videostab-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-videostab-dev:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../11-libopencv-stitching-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-stitching-dev:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../12-libopencv-calib3d-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-calib3d-dev:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../13-libopencv-features2d-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-features2d-dev:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../14-libopencv-flann-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-flann-dev:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../15-libopencv-objdetect-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-objdetect-dev:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../16-libopencv-ml-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-ml-dev:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../17-libopencv-contrib3.2_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-contrib3.2:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../18-libopencv3.2-jni_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv3.2-jni (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../19-libopencv-stitching3.2_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-stitching3.2:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../20-libopencv-objdetect3.2_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-objdetect3.2:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../21-libopencv-videostab3.2_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-videostab3.2:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../22-libopencv-calib3d3.2_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-calib3d3.2:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../23-libopencv-features2d3.2_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-features2d3.2:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../24-libopencv-ml3.2_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-ml3.2:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../25-libopencv-superres-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-superres-dev:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../26-libopencv-highgui-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-highgui-dev:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../27-libopencv-videoio-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-videoio-dev:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../28-libopencv-superres3.2_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-superres3.2:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../29-libopencv-highgui3.2_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-highgui3.2:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../30-libopencv-videoio3.2_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-videoio3.2:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../31-libopencv-imgcodecs-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-imgcodecs-dev:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../32-libopencv-imgcodecs3.2_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-imgcodecs3.2:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../33-libopencv-shape-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-shape-dev:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../34-libopencv-shape3.2_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-shape3.2:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../35-libopencv-video-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-video-dev:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../36-libopencv-photo-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-photo-dev:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../37-libopencv-imgproc-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-imgproc-dev:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../38-libopencv-photo3.2_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-photo3.2:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../39-libopencv-video3.2_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-video3.2:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../40-libopencv-imgproc3.2_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-imgproc3.2:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../41-libopencv-viz-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-viz-dev:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../42-libopencv-viz3.2_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-viz3.2:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../43-libopencv-flann3.2_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-flann3.2:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../44-libopencv-ts-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-ts-dev:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../45-libopencv-core-dev_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-core-dev:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../46-libopencv-core3.2_3.2.0+dfsg-4ubuntu0.1_amd64.deb...
Estrazione di libopencv-core3.2:amd64 (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../47-libopencv3.2-java_3.2.0+dfsg-4ubuntu0.1_all.deb...
Estrazione di libopencv3.2-java (3.2.0+dfsg-4ubuntu0.1) su (3.2.0+dfsg-4build2)...
Preparativi per estrarre .../48-libudisks2-0_2.7.6-3ubuntu0.2_amd64.deb...
Estrazione di libudisks2-0:amd64 (2.7.6-3ubuntu0.2) su (2.7.6-3ubuntu0.1)...
Preparativi per estrarre .../49-linux-libc-dev_4.15.0-36.39_amd64.deb...
Estrazione di linux-libc-dev:amd64 (4.15.0-36.39) su (4.15.0-35.38)...
Preparativi per estrarre .../50-udisks2_2.7.6-3ubuntu0.2_amd64.deb...
Estrazione di udisks2 (2.7.6-3ubuntu0.2) su (2.7.6-3ubuntu0.1)...
Configurazione di python3.6 (3.6.6-1~18.04)...
Traceback (most recent call last):
  File "/usr/lib/python3.6/py_compile.py", line 186, in <module>
    sys.exit(main())
  File "/usr/lib/python3.6/py_compile.py", line 178, in main
    compile(filename, doraise=True)
  File "/usr/lib/python3.6/py_compile.py", line 122, in compile
    source_bytes = loader.get_data(file)
  File "<frozen importlib._bootstrap_external>", line 833, in get_data
OSError: [Errno 5] Input/output error
dpkg: errore nell'elaborare il pacchetto python3.6 (--configure):
 installed python3.6 package post-installation script subprocess returned error exit status 1
Elaborazione dei trigger per ureadahead (0.100.0-20)...
ureadahead will be reprofiled on next reboot
Elaborazione dei trigger per install-info (6.5.0.dfsg.1-2)...
Configurazione di libopencv-core3.2:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libudisks2-0:amd64 (2.7.6-3ubuntu0.2)...
Configurazione di linux-libc-dev:amd64 (4.15.0-36.39)...
Configurazione di udisks2 (2.7.6-3ubuntu0.2)...
Configurazione di libopencv-viz3.2:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di opencv-data (3.2.0+dfsg-4ubuntu0.1)...
Elaborazione dei trigger per libc-bin (2.27-3ubuntu1)...
Configurazione di grub-common (2.02-2ubuntu8.5)...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
Elaborazione dei trigger per doc-base (0.10.8)...
Elaborazione 1 file doc-base modificato...
Registrazione dei documenti con  scrollkeeper...
Configurazione di libopencv-core-dev:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Elaborazione dei trigger per systemd (237-3ubuntu10.3)...
Configurazione di libopencv-ml3.2:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-ml-dev:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Elaborazione dei trigger per man-db (2.8.3-2ubuntu0.1)...
Configurazione di libopencv-imgproc3.2:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-flann3.2:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di initramfs-tools-bin (0.130ubuntu3.4)...
Elaborazione dei trigger per dbus (1.12.2-1ubuntu1)...
Configurazione di libopencv-video3.2:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-imgproc-dev:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-photo3.2:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-viz-dev:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-ts-dev:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-photo-dev:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di grub-pc-bin (2.02-2ubuntu8.5)...
Configurazione di initramfs-tools-core (0.130ubuntu3.4)...
Configurazione di libopencv-flann-dev:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di grub2-common (2.02-2ubuntu8.5)...
Configurazione di initramfs-tools (0.130ubuntu3.4)...
update-initramfs: deferring update (trigger activated)
Configurazione di libopencv-imgcodecs3.2:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-shape3.2:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-video-dev:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-videoio3.2:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-shape-dev:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-imgcodecs-dev:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di grub-pc (2.02-2ubuntu8.5)...
Installazione per la piattaforma i386-pc.
Installazione completata, nessun errore segnalato.
Generazione file di configurazione GRUB...
Trovata immagine linux: /boot/vmlinuz-4.15.0-35-generic
Trovata immagine initrd: /boot/initrd.img-4.15.0-35-generic
Trovata immagine linux: /boot/vmlinuz-4.15.0-34-generic
Trovata immagine initrd: /boot/initrd.img-4.15.0-34-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Trovato Windows 7 su /dev/sda1
fatto
Configurazione di libopencv-superres3.2:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-highgui3.2:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-videoio-dev:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-objdetect3.2:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-highgui-dev:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-features2d3.2:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-superres-dev:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-features2d-dev:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-calib3d3.2:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-stitching3.2:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-calib3d-dev:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-objdetect-dev:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-videostab3.2:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-stitching-dev:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-contrib3.2:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-videostab-dev:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-contrib-dev:amd64 (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv3.2-jni (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv3.2-java (3.2.0+dfsg-4ubuntu0.1)...
Configurazione di libopencv-dev (3.2.0+dfsg-4ubuntu0.1)...
Elaborazione dei trigger per libc-bin (2.27-3ubuntu1)...
Elaborazione dei trigger per initramfs-tools (0.130ubuntu3.4)...
update-initramfs: Generating /boot/initrd.img-4.15.0-35-generic
Si sono verificati degli errori nell'elaborazione:
 python3.6
E: Sub-process /usr/bin/dpkg returned an error code (1)
michael@Xubu:~$
500maniaco
Prode Principiante
 
Messaggi: 207
Iscrizione: gennaio 2009

Re: Problemi con Python3.6

Messaggioda rai » giovedì 27 settembre 2018, 11:27

posta
Codice: Seleziona tutto
apt policy python3.6
rai
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2276
Iscrizione: maggio 2008
Località: Palermo
Distribuzione: 16.04

Re: Problemi con Python3.6

Messaggioda 500maniaco » domenica 30 settembre 2018, 10:30

Codice: Seleziona tutto
michael@Xubu:~$ apt policy python3.6
python3.6:
  Installato: 3.6.6-1~18.04
  Candidato:  3.6.6-1~18.04
  Tabella versione:
 *** 3.6.6-1~18.04 500
        500 http://es-mirrors.evowise.com/ubuntu bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     3.6.5-3 500
        500 http://es-mirrors.evowise.com/ubuntu bionic/main amd64 Packages
michael@Xubu:~$


Se non riesco a ripristinare Python3.6 non funziona nemmeno la pagina di impostazione di aggiornamento
500maniaco
Prode Principiante
 
Messaggi: 207
Iscrizione: gennaio 2009

Re: Problemi con Python3.6

Messaggioda wilecoyote » domenica 30 settembre 2018, 13:39

:) Salve, ti passo le istruzioni per un intervento più forte per provare a sbloccare.

Comincia col sbarazzarti dei ppa:

Codice: Seleziona tutto
sudo rm /etc/apt/sources.list.d/*


Sostituisci il contenuto della lista repository:

Codice: Seleziona tutto
sudo -H gedit /etc/apt/sources.list


Cancella tutto e copiaci il seguente:

# deb cdrom:[Kubuntu 18.04 LTS _Bionic Beaver_ - Release amd64 (20180426)]/ bionic universe restricted multiverse main

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://it.archive.ubuntu.com/ubuntu/ bionic restricted main
# deb-src http://it.archive.ubuntu.com/ubuntu/ bionic restricted main

## Major bug fix updates produced after the final release of the
## distribution.
deb http://it.archive.ubuntu.com/ubuntu/ bionic-updates restricted main
# deb-src http://it.archive.ubuntu.com/ubuntu/ bionic-updates restricted main

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://it.archive.ubuntu.com/ubuntu/ bionic universe
# deb-src http://it.archive.ubuntu.com/ubuntu/ bionic universe
deb http://it.archive.ubuntu.com/ubuntu/ bionic-updates universe
# deb-src http://it.archive.ubuntu.com/ubuntu/ bionic-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://it.archive.ubuntu.com/ubuntu/ bionic multiverse
# deb-src http://it.archive.ubuntu.com/ubuntu/ bionic multiverse
deb http://it.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
# deb-src http://it.archive.ubuntu.com/ubuntu/ bionic-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb-src http://it.archive.ubuntu.com/ubuntu/ bionic-backports multiverse universe restricted main

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu/ bionic partner
# deb-src http://archive.canonical.com/ubuntu/ bionic partner

deb http://security.ubuntu.com/ubuntu/ bionic-security restricted main
# deb-src http://security.ubuntu.com/ubuntu/ bionic-security restricted main
deb http://security.ubuntu.com/ubuntu/ bionic-security universe
# deb-src http://security.ubuntu.com/ubuntu/ bionic-security universe
deb http://security.ubuntu.com/ubuntu/ bionic-security multiverse
# deb-src http://security.ubuntu.com/ubuntu/ bionic-security multiverse


Salva Ctrl+S e chiudi Ctrl+Q.

Adesso aggiorna:

Codice: Seleziona tutto
sudo apt --fix-broken install
sudo apt update
sudo apt upgrade


Il 1° corregge gli eventuali errori, il 2° aggiorna la lista dei pacchetti, il 3° installa eventuali aggiornamenti.

:ciao: Ciao
ACER Extensa 5230E 2,2 Ghz cpu Celeron 900 hdd 160 GB Ram 1GB scheda video Intel GM500
ACER Extensa 5635Z 2,2 Ghz cpu Celeron T3100 hdd 320 GB Ram 4 GB scheda video Intel Mobile 4
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
wilecoyote
Rampante Reduce
Rampante Reduce
 
Messaggi: 9187
Iscrizione: agosto 2009
Località: Ceranesi - Ge
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14/16/18.04 LTS 64bit
Sesso: Maschile

Re: Problemi con Python3.6

Messaggioda rai » domenica 30 settembre 2018, 15:38

rai ha scritto:E poi, hai un motivo importante per avere abilitato i repo proposed?
@500maniaco non hai risposto a questo, quindi lo prenderò per un "no"
Se invece esiste un motivo per usare le versioni instabili non tenere in considerazione quanto segue.

Non credo che i pacchetti che causano il problema si downgraderanno da soli alla versione stabile. Quindi suggerisco di modificare le impostazioni di apt in modo da forzare il downgrade:
Codice: Seleziona tutto
sudo nano /etc/apt/preferences
e incollaci dentro ( Ctrl + Maiusc + V ) il seguente contenuto:
Codice: Seleziona tutto
Package: *
Pin: release a=bionic
Pin-Priority: 1001

Package: *
Pin: release a=bionic-updates
Pin-Priority: 1001

Package: *
Pin: release a=bionic-proposed
Pin-Priority: -10

Esci e salva con Ctrl+X e Ctrl+S

questo dovrebbe indurre apt a dare la priorità ai pacchetti stabili quando fai
Codice: Seleziona tutto
sudo apt upgrade

e eventualmente sistemare i conflitti con
Codice: Seleziona tutto
sudo apt -f install


EDIT nel rispetto del regolamento, quella suggerita è una modifica potenzialmente destabilizzante per il sistema
vedi https://wiki.debian.org/AptPreferences#Pinning

D'altronde mi pare che il tuo sistema sia tutt'altro che stabile già ora :nono:
Hai un backup di tutto quello che ritieni importante, vero?
rai
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2276
Iscrizione: maggio 2008
Località: Palermo
Distribuzione: 16.04

Re: Problemi con Python3.6

Messaggioda wilecoyote » domenica 30 settembre 2018, 17:08

:) Salve, @rai l'opzione '-f' o '--fix-broken' può retrocedere, downgrade, la versione del pacchetto purché essa sia quella prevista per la release nel repository.

:ciao: Ciao
ACER Extensa 5230E 2,2 Ghz cpu Celeron 900 hdd 160 GB Ram 1GB scheda video Intel GM500
ACER Extensa 5635Z 2,2 Ghz cpu Celeron T3100 hdd 320 GB Ram 4 GB scheda video Intel Mobile 4
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
wilecoyote
Rampante Reduce
Rampante Reduce
 
Messaggi: 9187
Iscrizione: agosto 2009
Località: Ceranesi - Ge
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14/16/18.04 LTS 64bit
Sesso: Maschile

Re: Problemi con Python3.6

Messaggioda rai » domenica 30 settembre 2018, 17:22

wilecoyote ha scritto::) Salve, @rai l'opzione '-f' o '--fix-broken' può retrocedere, downgrade, la versione del pacchetto purché essa sia quella prevista per la release nel repository.

:ciao: Ciao

se è così basterà il tuo suggerimento :), staremo a vedere la risposta dell'OP
ma dubito che apt arrischi un downgrade se non espressamente richiesto. Il manuale dice esplicitamente che nonostante -f a volte è richiesto un intervento manuale
rai
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2276
Iscrizione: maggio 2008
Località: Palermo
Distribuzione: 16.04

Re: Problemi con Python3.6

Messaggioda 500maniaco » lunedì 1 ottobre 2018, 15:27

rai ha scritto:
rai ha scritto:E poi, hai un motivo importante per avere abilitato i repo proposed?
@500maniaco non hai risposto a questo, quindi lo prenderò per un "no"

No, non c'è un motivo preciso, sinceramente non sapevo che potesse essere dannoso !
Grazie a tutti, ho eseguito tutto quello che mi avete suggerito , ho visto aggiornarsi dei pacchetti e retrocedere altri, ho riavviato il pc e provato ad eseguire gli aggiornamenti, ma l'applicazione non funziona ancora..... :muro: :muro: :muro:
500maniaco
Prode Principiante
 
Messaggi: 207
Iscrizione: gennaio 2009

Re: Problemi con Python3.6

Messaggioda wilecoyote » lunedì 1 ottobre 2018, 15:37

:) Salve, l'hai sostituita nel file /etc/apt/sources.list la lista dei repository come indicai ?

I proposed sono disattivati e punta ai server ufficiali.

:ciao: Ciao
ACER Extensa 5230E 2,2 Ghz cpu Celeron 900 hdd 160 GB Ram 1GB scheda video Intel GM500
ACER Extensa 5635Z 2,2 Ghz cpu Celeron T3100 hdd 320 GB Ram 4 GB scheda video Intel Mobile 4
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
wilecoyote
Rampante Reduce
Rampante Reduce
 
Messaggi: 9187
Iscrizione: agosto 2009
Località: Ceranesi - Ge
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14/16/18.04 LTS 64bit
Sesso: Maschile

Re: Problemi con Python3.6

Messaggioda 500maniaco » lunedì 1 ottobre 2018, 17:13

Si ho sostituito tutto, ma se non si ripristina Python non funziona il gestore aggiornamenti e diverse applicazioni!
500maniaco
Prode Principiante
 
Messaggi: 207
Iscrizione: gennaio 2009

Re: Problemi con Python3.6

Messaggioda rai » martedì 2 ottobre 2018, 10:49

500maniaco ha scritto:Si ho sostituito tutto, ma se non si ripristina Python non funziona il gestore aggiornamenti e diverse applicazioni!
Se hai anche creato il file /etc/apt/preferences con il contenuto che ti avevo suggerito non so cosa altro farti provare.
Se nessuno interviene in modo risolutivo, re-installa
rai
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2276
Iscrizione: maggio 2008
Località: Palermo
Distribuzione: 16.04

Re: Problemi con Python3.6

Messaggioda 500maniaco » martedì 2 ottobre 2018, 11:49

Re-installare Python dici? Oppure reinstallare tutto il s.o. ?
500maniaco
Prode Principiante
 
Messaggi: 207
Iscrizione: gennaio 2009

Re: Problemi con Python3.6

Messaggioda rai » martedì 2 ottobre 2018, 12:04

Intendo re-installare tutto il sistema operativo.
I repo proposed sono per chi vuole collaborare a testare i nuovi pacchetti prima che vengano ritenuti sicuri e immessi nei repo principali. C'è scritto nella GUI degli aggiornamenti, forse senza sufficiente enfasi, ma c'è scritto chiaramente che attivare gli aggiornamenti proposed può sgangherarti il sistema
rai
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2276
Iscrizione: maggio 2008
Località: Palermo
Distribuzione: 16.04

Re: Problemi con Python3.6

Messaggioda wilecoyote » martedì 2 ottobre 2018, 14:03

:) Salve, se vuoi, prima di reinstallare, puoi provare con le maniere forti a reinstallare i pacchetti Python mancanti, occhio che sono maniere veramente forti.

Comincia col creare nella tua /home/<nomeutente> una directory di nome Python ove scaricare i vari pacchetti.

Adesso scarica i seguenti pacchetti da ciascun link:

http://it.archive.ubuntu.com/ubuntu/poo ... ython-apt/ scarica python-apt e python3-apt versione 1.6.2 scegliendo l'architettura corretta

http://it.archive.ubuntu.com/ubuntu/poo ... stro-info/ scarica i python-distro-info e python3-distro-info versione 0.18

http://it.archive.ubuntu.com/ubuntu/poo ... pygobject/ scarica i python-gi , python-gi-cairo , python3-gi e python3-gi-cairo versione 3.26.1-2 scegliendo l'architettura corretta

http://it.archive.ubuntu.com/ubuntu/poo ... thon-cups/ scarica python-cups e python3-cups versione 1.9.73-2 scegliendo l'architettura corretta

http://it.archive.ubuntu.com/ubuntu/poo ... -defaults/ scarica python , python-minimal e libpython-stdlib versione 2.7.15~rc1-1 scegliendo l'architettura corretta

http://it.archive.ubuntu.com/ubuntu/poo ... etuptools/ scarica python-setuptools , python-pkg-resources , python3-setuptools e python3-pkg-resources versione 39.0.1-2

http://it.archive.ubuntu.com/ubuntu/poo ... python2.7/ scarica python2.7 , python2.7-minimal , libpython2.7 , libpython2.7-stdlib versione 2.7.15~rc1-1

http://it.archive.ubuntu.com/ubuntu/poo ... xtensions/ scarica python-distutils versione 3.6.5-3 scegliendo l'architettura corretta

http://it.archive.ubuntu.com/ubuntu/poo ... python-tz/ scarica python-tz e python3-tz versione 2018.3-2

http://it.archive.ubuntu.com/ubuntu/poo ... -defaults/ python3 3.6.5-3ubuntu1 , python3-minimal e libpython3-stdlib versione 3.6.5-3ubuntu1 scegliendo l'architettura corretta

http://it.archive.ubuntu.com/ubuntu/poo ... python3.6/ scarica python3.6 3.6.6-1~18.04 , python3.6-minimal , libpython3.6 , libpython3.6-minimal e libpython3.6-stdlib versione 3.6.6-1~18.04 scegliendo l'architettura corretta

http://it.archive.ubuntu.com/ubuntu/poo ... -upgrader/ scarica python3-distupgrade versione 18.04.26

Apri il terminale e dai seguenti comandi:

Codice: Seleziona tutto
cd ~/Python
sudo dpkg --auto-deconfigure --force-all -i *.deb
sudo apt install -f


Il 1° ti sposta ove salvati i pacchetti, il 2° l'installa brutalmente senza fare complimenti ed il 3° sistema eventuali problemi purché il 2° abbia funzionato e siano sufficienti i Python.

:ciao: Ciao
Ultima modifica di wilecoyote il giovedì 4 ottobre 2018, 15:13, modificato 1 volta in totale.
ACER Extensa 5230E 2,2 Ghz cpu Celeron 900 hdd 160 GB Ram 1GB scheda video Intel GM500
ACER Extensa 5635Z 2,2 Ghz cpu Celeron T3100 hdd 320 GB Ram 4 GB scheda video Intel Mobile 4
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
wilecoyote
Rampante Reduce
Rampante Reduce
 
Messaggi: 9187
Iscrizione: agosto 2009
Località: Ceranesi - Ge
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14/16/18.04 LTS 64bit
Sesso: Maschile

Re: Problemi con Python3.6

Messaggioda 500maniaco » giovedì 4 ottobre 2018, 11:04

Codice: Seleziona tutto
/home/michael/Scaricati/Python/libpython2.7_2.7.15~rc1-1_amd64.deb
/home/michael/Scaricati/Python/libpython2.7-stdlib_2.7.15~rc1-1_amd64.deb
/home/michael/Scaricati/Python/libpython3.6_3.6.6-1~18.04_amd64.deb
/home/michael/Scaricati/Python/libpython3.6-minimal_3.6.6-1~18.04_amd64.deb
/home/michael/Scaricati/Python/libpython3.6-stdlib_3.6.6-1~18.04_amd64.deb
/home/michael/Scaricati/Python/libpython3-stdlib_3.6.5-3ubuntu1_amd64.deb
/home/michael/Scaricati/Python/libpython-stdlib_2.7.15~rc1-1_amd64.deb
/home/michael/Scaricati/Python/python2.7_2.7.15~rc1-1_amd64.deb
/home/michael/Scaricati/Python/python2.7-minimal_2.7.15~rc1-1_amd64.deb
/home/michael/Scaricati/Python/python3.6_3.6.6-1~18.04_amd64.deb
/home/michael/Scaricati/Python/python3.6-minimal_3.6.6-1~18.04_amd64.deb
/home/michael/Scaricati/Python/python3_3.6.5-3ubuntu1_amd64.deb
/home/michael/Scaricati/Python/python3-apt_1.6.2_amd64.deb
/home/michael/Scaricati/Python/python3-cups_1.9.73-2_amd64.deb
/home/michael/Scaricati/Python/python3-distro-info_0.18_all.deb
/home/michael/Scaricati/Python/python3-distupgrade_18.04.26_all.deb
/home/michael/Scaricati/Python/python3-distutils_3.6.5-3_all.deb
/home/michael/Scaricati/Python/python3-gi_3.26.1-2_amd64.deb
/home/michael/Scaricati/Python/python3-gi-cairo_3.26.1-2_amd64.deb
/home/michael/Scaricati/Python/python3-minimal_3.6.5-3_amd64.deb
/home/michael/Scaricati/Python/python3-pkg-resources_39.0.1-2_all.deb
/home/michael/Scaricati/Python/python3-setuptools_39.0.1-2_all.deb
/home/michael/Scaricati/Python/python3-tz_2018.3-2_all.deb
/home/michael/Scaricati/Python/python-apt_1.6.2_amd64.deb
/home/michael/Scaricati/Python/python-cups_1.9.73-2.debian.tar.xz
/home/michael/Scaricati/Python/python-gi_3.26.1-2_amd64.deb
/home/michael/Scaricati/Python/python-gi-dbg_3.26.1-2_amd64.deb
/home/michael/Scaricati/Python/python-minimal_2.7.15-3_amd64.deb
/home/michael/Scaricati/Python/python-minimal_2.7.15~rc1-1_amd64.deb
/home/michael/Scaricati/Python/python-pkg-resources_39.0.1-2_all.deb
/home/michael/Scaricati/Python/python-setuptools_39.0.1-2_all.deb
/home/michael/Scaricati/Python/python-tz_2018.3-2_all.deb


Ciao e grazie dell'aiuto. Ho scaricato i file richiesti, uso un pc a 64bit. Tra tutti i file richiesti alcuni non sono riuscito a trovarli. Questi sono quelli che ho scaricato e messo in una cartella apposita, puoi controllare se vanno bene? Grazie.
500maniaco
Prode Principiante
 
Messaggi: 207
Iscrizione: gennaio 2009

Successiva

Torna a Applicazioni

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 6 ospiti