non mi funziona il comando cd

Installazione, configurazione e uso di programmi e strumenti.

non mi funziona il comando cd

Messaggioda Zed91 » sabato 12 gennaio 2019, 14:03

steff Immagine ha scritto:http://wiki.ubuntu-it.org/AmministrazioneSistema/Terminale#Tasti_di_selezione_rapida

Inoltre molti gestore file hanno nel menu contestuale il "apri terminale qui"


Ciao, io sto avendo lo stesso problema, tutte le volte che do il comando cd mi risponde no such file or directory, anche se metto una cartella nella home chiamata rambo e do cd /home/rambo... inoltre in questa versione di ubuntu (14.04 lts)non trovo il comando "apri terminale qui" è possibile aggiungere questa opzione?
Zed91
Prode Principiante
 
Messaggi: 21
Iscrizione: novembre 2017
Distribuzione: UBUNTU
Sesso: Maschile

Re: non mi funziona il comando cd

Messaggioda pachisapiu » sabato 12 gennaio 2019, 14:18

zam19_89 Immagine ha scritto:non saprei dove mettere questa discussione,
il mio problema è stupido ma fastidioso ,ho bisogno d'accedere ad una cartella da terminale con questo comando cerco di recarmi nella cartella desiderata e eseguo questo comando

cd /home/mio nome/scaricati mi da impossibile trovare la directory in qualsiasi cartella che voglio andare mi da questo errore come mai??
ho toccato qualcosa che può dare questo errore grazie

Già in quanto scrivi vi è un errore infatti non è scaricati ma Scaricati ...forse per quello non la trovi
Avatar utente
pachisapiu
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2337
Iscrizione: maggio 2017
Distribuzione: FreeDOS

Re: non mi funziona il comando cd

Messaggioda dxgiusti » sabato 12 gennaio 2019, 14:22

in synaptic, il gestore pacchetti cerca nautilus-admin nautilus-open-terminal o simile. ( immagino tu usi ubuntu )
Avatar utente
dxgiusti
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3129
Iscrizione: novembre 2007
Località: Lodi
Desktop: gnome
Distribuzione: ubuntu 18.10
Sesso: Maschile

Re: non mi funziona il comando cd

Messaggioda Zed91 » sabato 12 gennaio 2019, 15:02

Perfetto così almeno riesco a fare quello che devo..Ma comunque il comando cd continua a darmi "no such file or directory"...
Zed91
Prode Principiante
 
Messaggi: 21
Iscrizione: novembre 2017
Distribuzione: UBUNTU
Sesso: Maschile

Re: non mi funziona il comando cd

Messaggioda pachisapiu » sabato 12 gennaio 2019, 15:18

Zed91 Immagine ha scritto:Perfetto così almeno riesco a fare quello che devo..Ma comunque il comando cd continua a darmi "no such file or directory"...

prima di usare cd verifica col comando ls il nome esatto delle cartelle presenti
Avatar utente
pachisapiu
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2337
Iscrizione: maggio 2017
Distribuzione: FreeDOS

Re: non mi funziona il comando cd

Messaggioda Zed91 » sabato 12 gennaio 2019, 15:34

pachisapiu Immagine ha scritto:
Zed91 Immagine ha scritto:Perfetto così almeno riesco a fare quello che devo..Ma comunque il comando cd continua a darmi "no such file or directory"...

prima di usare cd verifica col comando ls il nome esatto delle cartelle presenti


Se da terminale scrivo cd / Scrivania ottengo "no such file or directory" così come con Immagini o altre..L'unica che funziona pare home (cd /home) con h minuscola...con ls /Immagini ottengo:
cannot access /Immagini: No such file or directory...
Zed91
Prode Principiante
 
Messaggi: 21
Iscrizione: novembre 2017
Distribuzione: UBUNTU
Sesso: Maschile

Re: non mi funziona il comando cd

Messaggioda Filoteo » sabato 12 gennaio 2019, 16:17

Non funziona perché quelle cartelle non ci sono. Se scrivi ls /Immagini cerchi di leggere il contenuto della cartella Immagini contenuta nella cartella radice /. Quella cartella però non c’è, quella di cui tu vuoi visualizzare il contenuto è /home/tuonomeutente/Immagini. Alternativamente puoi spostarti prima nella tua home col comando cd /home/tuonomeutente (o anche solo cd che senza argomenti ti fa spostare nella tua home) e poi esegui ls Immagini.
Filoteo
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 402
Iscrizione: agosto 2015
Desktop: Gnome
Distribuzione: Manjaro Linux

Re: non mi funziona il comando cd

Messaggioda wilecoyote » sabato 12 gennaio 2019, 16:33

Immagine Salve, @Filoteo più semplicemente basta apporre una tilde:

ls ~/Immagini


La tilde ~ equivale e sostituisce /home/nomeutente.

@Zed91 tieni sempre bene a mente che Linux è sensibile a MAIUSCOLE e minuscole, Immagini è una cosa immagini ne è un'altra.

Immagine Ciao
ACER Extensa 5230E 2,2 Ghz cpu Celeron 900 hdd 160 GB Ram 1GB scheda video Intel GM500
ACER Extensa 5635Z 2,2 Ghz cpu Celeron T3100 hdd 320 GB Ram 4 GB scheda video Intel Mobile 4
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
wilecoyote
Rampante Reduce
Rampante Reduce
 
Messaggi: 9064
Iscrizione: agosto 2009
Località: Ceranesi - Ge
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14/16/18.04 LTS 64bit
Sesso: Maschile

Re: non mi funziona il comando cd

Messaggioda Zed91 » sabato 12 gennaio 2019, 17:29

wilecoyote Immagine ha scritto:Immagine Salve, @Filoteo più semplicemente basta apporre una tilde:

ls ~/Immagini


La tilde ~ equivale e sostituisce /home/nomeutente.

@Zed91 tieni sempre bene a mente che Linux è sensibile a MAIUSCOLE e minuscole, Immagini è una cosa immagini ne è un'altra.

Immagine Ciao


Si, non ho capito bene come funziona il comando ls comunque.. che prova dovrei fare? ls Immagini? Ho capito invece il discorso delle maiuscole, infatti negli esempi che ho postato le ho specificate...
Zed91
Prode Principiante
 
Messaggi: 21
Iscrizione: novembre 2017
Distribuzione: UBUNTU
Sesso: Maschile

Re: non mi funziona il comando cd

Messaggioda pachisapiu » sabato 12 gennaio 2019, 17:31

Zed91 Immagine ha scritto:Si, non ho capito bene come funziona il comando ls comunque.. che prova dovrei fare? Ho capito invece il discorso delle maiuscole, infatti negli esempi che ho postato le ho specificate...

/AmministrazioneSistema/ComandiBase
Avatar utente
pachisapiu
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2337
Iscrizione: maggio 2017
Distribuzione: FreeDOS

Re: non mi funziona il comando cd

Messaggioda Zed91 » sabato 12 gennaio 2019, 19:17

pachisapiu Immagine ha scritto:
Zed91 Immagine ha scritto:Si, non ho capito bene come funziona il comando ls comunque.. che prova dovrei fare? Ho capito invece il discorso delle maiuscole, infatti negli esempi che ho postato le ho specificate...

/AmministrazioneSistema/ComandiBase

preferirei esempio pratico.. Comunque mi sono riletto quello che diceva wilecoyote, dopo farò alcune prove...
Zed91
Prode Principiante
 
Messaggi: 21
Iscrizione: novembre 2017
Distribuzione: UBUNTU
Sesso: Maschile

Re: non mi funziona il comando cd

Messaggioda pachisapiu » sabato 12 gennaio 2019, 21:09

Zed91 Immagine ha scritto:
pachisapiu Immagine ha scritto:
Zed91 Immagine ha scritto:Si, non ho capito bene come funziona il comando ls comunque.. che prova dovrei fare? Ho capito invece il discorso delle maiuscole, infatti negli esempi che ho postato le ho specificate...

/AmministrazioneSistema/ComandiBase

preferirei esempio pratico.. Comunque mi sono riletto quello che diceva wilecoyote, dopo farò alcune prove...

Leggere qualche guida non ti farà male ...
Avatar utente
pachisapiu
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2337
Iscrizione: maggio 2017
Distribuzione: FreeDOS

Re: non mi funziona il comando cd

Messaggioda dxgiusti » domenica 13 gennaio 2019, 12:44

hai letto il mio post?
viewtopic.php?f=8&t=632444&view=unread#p5107515
mi sembra sia la soluzione a quanto chiedevi, la funzione in nautilus.
Avatar utente
dxgiusti
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3129
Iscrizione: novembre 2007
Località: Lodi
Desktop: gnome
Distribuzione: ubuntu 18.10
Sesso: Maschile

Re: non mi funziona il comando cd

Messaggioda Zed91 » domenica 13 gennaio 2019, 19:07

dxgiusti Immagine ha scritto:hai letto il mio post?
viewtopic.php?f=8&t=632444&view=unread#p5107515
mi sembra sia la soluzione a quanto chiedevi, la funzione in nautilus.

Si quello ho risolto, adesso mi rimane da capire perchè non riesco ad utilizzare il comando cd..
Zed91
Prode Principiante
 
Messaggi: 21
Iscrizione: novembre 2017
Distribuzione: UBUNTU
Sesso: Maschile

Re: non mi funziona il comando cd

Messaggioda dxgiusti » domenica 13 gennaio 2019, 21:35

bene. esempio pratico per aprire il terminale nella cartella Immagini >>>
cd /home/tuo_nome/Immagini
se invece la cartella è in altra partizione ( mio esempio ) >>>>
cd /media/win_d/Virtualbox
dove media è la cartella di sistema, win_d è il nome che ho dato alla mia partizione archivio, Virtualbox è la cartella dove tengo i sistemi virtuali. spero di averti schiarito le idee.
mi raccomando due cose, lo spazio tra cd ed il primo / e scrivere correttamente maiuscole/minuscole.
Avatar utente
dxgiusti
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3129
Iscrizione: novembre 2007
Località: Lodi
Desktop: gnome
Distribuzione: ubuntu 18.10
Sesso: Maschile


Torna a Applicazioni

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 5 ospiti