[Risolto]Pacchetti danneggiate dopo disinstallazione Nemesys

Installazione, configurazione e uso di programmi e strumenti.

[Risolto]Pacchetti danneggiate dopo disinstallazione Nemesys

Messaggioda CDR_Militello » domenica 31 marzo 2019, 22:09

Ragazzi mentre installavo Nemesys, un software per il controllo della velocità di internet della AGCOM, durante la disinstallazione e la reinstallazione, mi si sono danneggiati i pacchetti. adesso, mi compare il messaggio :
Codice: Seleziona tutto
Questo è un problema grave del sistema di gestione del software. Controllare i pacchetti danneggiati con synaptic, i permessi dei file e la correttezza dei file presenti in «/etc/apt/sources.list» e ricaricare le informazioni del software con: «sudo apt-get update» e «sudo apt-get install -f».
Nonostante io faccia la procedura, non cambia niente, il tutto mi rimane danneggiato.

se invece avvio il gestore pacchetti Synaptic, mi da:
E: Il pacchetto nemesys deve essere reinstallato, ma non è possibile trovarne un archivio.
E: Errore interno nell'aprire la cache (1). Segnalare l'errore.


Sapete darmi qualche ragguaglio? Grazie
Ultima modifica di CDR_Militello il martedì 30 aprile 2019, 7:45, modificato 5 volte in totale.
Potete ingannare tutti per qualche tempo e alcuni per tutto il tempo, ma non potete ingannare tutti per tutto il tempo
Avatar utente
CDR_Militello
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 354
Iscrizione: dicembre 2009
Località: Militello Rosmarino
Desktop: Unity
Distribuzione: Ubuntu 16.04 64 bit
Sesso: Maschile

Re: Pacchetti con dipendenze non soddisfatte

Messaggioda derma » domenica 31 marzo 2019, 22:31

Disinstallare da Synaptic il pacchetto "Nemesys" anziché reinstallarlo?... ma 'sto pacchetto lo installasti tramite ".deb" scaricato da qualche parte?
__Ŧ__
'\°°/'
Γı /\ ı\   |7 Γı Γı Γı -|-
Avatar utente
derma
Rampante Reduce
Rampante Reduce
 
Messaggi: 7035
Iscrizione: settembre 2006
Località: Sicilia
Distribuzione: Ubuntu 15.10 (Wily Werewolf)

Re: Pacchetti con dipendenze non soddisfatte

Messaggioda CDR_Militello » lunedì 1 aprile 2019, 7:30

derma Immagine ha scritto:Disinstallare da Synaptic il pacchetto "Nemesys" anziché reinstallarlo?... ma 'sto pacchetto lo installasti tramite ".deb" scaricato da qualche parte?


Synaptic non me lo fa aprire poichè mio compare l'errore
Codice: Seleziona tutto
(E: Il pacchetto nemesys deve essere reinstallato, ma non è possibile trovarne un archivio.
E: Errore interno nell'aprire la cache (1). Segnalare l'errore.). Nemesys, invece è un pacchetto DEB che si scarica dal sito ufficiale dell' AGCOM da quì:  https://www.misurainternet.it/download/nemesys/


quindi, se provo a disinstallare da synaptic, questo non si avvia per via dell'errore, se invece provo a disinstallare dal pacchetto DEB, mi da altrettanto errore come scritto sopra
Ultima modifica di trekfan1 il lunedì 1 aprile 2019, 16:45, modificato 2 volte in totale.
Motivazione: Inseriti i tag CODE, ricordalo per il futuro
Potete ingannare tutti per qualche tempo e alcuni per tutto il tempo, ma non potete ingannare tutti per tutto il tempo
Avatar utente
CDR_Militello
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 354
Iscrizione: dicembre 2009
Località: Militello Rosmarino
Desktop: Unity
Distribuzione: Ubuntu 16.04 64 bit
Sesso: Maschile

Re: Pacchetti con dipendenze non soddisfatte

Messaggioda giulux » lunedì 1 aprile 2019, 8:16

Ho creato questa nuova discussione perchè il tuo problema è diverso da quello trattato in quella dove ti eri inserito.
Metti un titolo che rappresenti il tuo problema modificando quello del primo post.
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...
Avatar utente
giulux
Amministratore
Amministratore
 
Messaggi: 22744
Iscrizione: gennaio 2010
Località: Roma
Desktop: xubuntu - ubuntu 18.04
Distribuzione: Ubuntu+Xubuntu 18.04.2 LTS x86_64
Sesso: Maschile

Re: Pacchetti con dipendenze non soddisfatte

Messaggioda derma » lunedì 1 aprile 2019, 8:29

Prova, uno alla volta, e se il precedente non ha risolto, i seguenti comandi usando il Terminale...


Codice: Seleziona tutto
sudo dpkg -r nome-del-pacchetto


Codice: Seleziona tutto
sudo dpkg --purge nome-del-pacchetto


Codice: Seleziona tutto
sudo apt-get remove nome-del-pacchetto


Codice: Seleziona tutto
sudo apt-get purge nome-del-pacchetto



...la differenza tra "purge" e remove" sta nel fatto che il primo elimina anche gli eventuali file di configurazione.
__Ŧ__
'\°°/'
Γı /\ ı\   |7 Γı Γı Γı -|-
Avatar utente
derma
Rampante Reduce
Rampante Reduce
 
Messaggi: 7035
Iscrizione: settembre 2006
Località: Sicilia
Distribuzione: Ubuntu 15.10 (Wily Werewolf)

Re: Pacchetti con dipendenze non soddisfatte

Messaggioda caturen » lunedì 1 aprile 2019, 10:59

ma fare quello che è richiesto
Il pacchetto nemesys deve essere reinstallato, ma non è possibile trovarne un archivio.
cioè reinstallare il pacchetto deb giusto per la tua versione di ubuntu ?


ps io su ubuntu 18.04 (non ho sottomano la 16.04) ho installato il deb di nemesys senza nessun problema.
caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 15043
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: Pacchetti con dipendenze non soddisfatte

Messaggioda CDR_Militello » lunedì 1 aprile 2019, 13:36

giulux Immagine ha scritto:Ho creato questa nuova discussione perchè il tuo problema è diverso da quello trattato in quella dove ti eri inserito.
Metti un titolo che rappresenti il tuo problema modificando quello del primo post.


ciao, ho modificato il titolo primo, spero di aver fatto bene. Grazie comunque!
Potete ingannare tutti per qualche tempo e alcuni per tutto il tempo, ma non potete ingannare tutti per tutto il tempo
Avatar utente
CDR_Militello
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 354
Iscrizione: dicembre 2009
Località: Militello Rosmarino
Desktop: Unity
Distribuzione: Ubuntu 16.04 64 bit
Sesso: Maschile

Re: Pacchetti con dipendenze non soddisfatte

Messaggioda CDR_Militello » lunedì 1 aprile 2019, 13:43

derma Immagine ha scritto:Prova, uno alla volta, e se il precedente non ha risolto, i seguenti comandi usando il Terminale...


Codice: Seleziona tutto
sudo dpkg -r nome-del-pacchetto


Codice: Seleziona tutto
sudo dpkg --purge nome-del-pacchetto


Codice: Seleziona tutto
sudo apt-get remove nome-del-pacchetto


Codice: Seleziona tutto
sudo apt-get purge nome-del-pacchetto



...la differenza tra "purge" e remove" sta nel fatto che il primo elimina anche gli eventuali file di configurazione.


gentilissimo, grazie per la collaborazione, ecco cosa mi viene fuori:
Codice: Seleziona tutto
antonino@antonino:~$ sudo apt-get remove nemesys
[sudo] password di antonino:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
E: Il pacchetto nemesys deve essere reinstallato, ma non è possibile trovarne un archivio.

poi:
Codice: Seleziona tutto
antonino@antonino:~$ sudo dpkg -r nemesys
dpkg: errore nell'elaborare il pacchetto nemesys (--remove):
 il pacchetto si trova in uno stato di inconsistenza grave:
 è necessario installarlo nuovamente prima di rimuoverlo
Si sono verificati degli errori nell'elaborazione:
 nemesys

poi:
Codice: Seleziona tutto
antonino@antonino:~$ sudo dpkg --purge nemesys
dpkg: errore nell'elaborare il pacchetto nemesys (--purge):
 il pacchetto si trova in uno stato di inconsistenza grave:
 è necessario installarlo nuovamente prima di rimuoverlo
Si sono verificati degli errori nell'elaborazione:
 nemesys

praticamente mi chiede di reinstallare prima di rimuovere. Anche se ci provo dal pacchetto DEB, mi da errore e non va avanti
Potete ingannare tutti per qualche tempo e alcuni per tutto il tempo, ma non potete ingannare tutti per tutto il tempo
Avatar utente
CDR_Militello
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 354
Iscrizione: dicembre 2009
Località: Militello Rosmarino
Desktop: Unity
Distribuzione: Ubuntu 16.04 64 bit
Sesso: Maschile

Re: Pacchetti con dipendenze non soddisfatte

Messaggioda CDR_Militello » lunedì 1 aprile 2019, 13:46

CDR_Militello Immagine ha scritto:
giulux Immagine ha scritto:Ho creato questa nuova discussione perchè il tuo problema è diverso da quello trattato in quella dove ti eri inserito.
Metti un titolo che rappresenti il tuo problema modificando quello del primo post.


ciao, ho modificato il titolo primo, spero di aver fatto bene. Grazie comunque!


ciao, io rimuovo e installo i pacchetti aggiornati da anni, ma è la prima volta che succede. Praticamente avevo rimosso nemesys per installare l'ultima versione. Una volta installata, ti chiede il nome utente e la password durante l'installazione. Inserivo le due cose, ma mi diceva che erano errate, mentre in realtà erano giuste! allora sono andato sul sito e ho chiesto il rinnovo pasword, mi continuava a dare errore nonostante utilizzassi una nuova pasword. A questo punto, ho attivato la licenza come se dovessi monitorare la connessione internet e la pasword è stata riconosciuta. A questo punto è nato il problema coi pacchetti
Potete ingannare tutti per qualche tempo e alcuni per tutto il tempo, ma non potete ingannare tutti per tutto il tempo
Avatar utente
CDR_Militello
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 354
Iscrizione: dicembre 2009
Località: Militello Rosmarino
Desktop: Unity
Distribuzione: Ubuntu 16.04 64 bit
Sesso: Maschile

Re: Pacchetti danneggiate dopo disinstallazione Nemesys

Messaggioda derma » lunedì 1 aprile 2019, 13:58

Forse interpreto non correttamente quanto scrivesti prima a proposito di Synaptic...


CDR_Militello Immagine ha scritto:
derma Immagine ha scritto:Disinstallare da Synaptic il pacchetto "Nemesys" anziché reinstallarlo?... ma 'sto pacchetto lo installasti tramite ".deb" scaricato da qualche parte?


Synaptic non me lo fa aprire poichè mio compare l'errore (E: Il pacchetto nemesys deve essere reinstallato, ma non è possibile trovarne un archivio.
E: Errore interno nell'aprire la cache (1). Segnalare l'errore.). Nemesys, invece è un pacchetto DEB che si scarica dal sito ufficiale dell' AGCOM da quì: https://www.misurainternet.it/download/nemesys/

quindi, se provo a disinstallare da synaptic, questo non si avvia per via dell'errore, se invece provo a disinstallare dal pacchetto DEB, mi da altrettanto errore come scritto sopra



...riesci ad avviare Synaptic, e quindi a selezionare "Pacchetti danneggiati" presente nella barra laterale?
__Ŧ__
'\°°/'
Γı /\ ı\   |7 Γı Γı Γı -|-
Avatar utente
derma
Rampante Reduce
Rampante Reduce
 
Messaggi: 7035
Iscrizione: settembre 2006
Località: Sicilia
Distribuzione: Ubuntu 15.10 (Wily Werewolf)

Re: Pacchetti danneggiate dopo disinstallazione Nemesys

Messaggioda trekfan1 » lunedì 1 aprile 2019, 14:42

@CDR_Militello ti invito a non fare post consecutivi, ma se non ci sono risposte clicca su Modifica e aggiungi il nuovo testo eventualmente preceduto da EDIT, grazie
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 19593
Iscrizione: maggio 2006
Località: Formigine (MO) | Tenace Tecnocrate
Desktop: Gnome
Distribuzione: Ubuntu 19.04 e 19.10 (dev) 64 bit
Sesso: Maschile

Re: Pacchetti danneggiate dopo disinstallazione Nemesys

Messaggioda caturen » lunedì 1 aprile 2019, 16:05

Il pacchetto nemesys deve essere reinstallato
ti decidi o no a reinstallare quel deb?
caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 15043
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: Pacchetti danneggiate dopo disinstallazione Nemesys

Messaggioda trekfan1 » lunedì 1 aprile 2019, 16:48

Supponendo che il pacchetto nemesys sia nella cartella scaricati:
Codice: Seleziona tutto
sudo dpkg -i ~/Scaricati/Nemesys_v.3.3.1_ubuntu-18.04_64bit.deb
puoi usare il tasto TAB per autocompletare i nomi di file e cartelle
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 19593
Iscrizione: maggio 2006
Località: Formigine (MO) | Tenace Tecnocrate
Desktop: Gnome
Distribuzione: Ubuntu 19.04 e 19.10 (dev) 64 bit
Sesso: Maschile

Re: Pacchetti danneggiate dopo disinstallazione Nemesys

Messaggioda CDR_Militello » lunedì 1 aprile 2019, 19:15

trekfan1 Immagine ha scritto:@CDR_Militello ti invito a non fare post consecutivi, ma se non ci sono risposte clicca su Modifica e aggiungi il nuovo testo eventualmente preceduto da EDIT, grazie

ciao, scusami ma non so cosa sono i post consecutivi. ho risposto ai vari utenti citandoli, non si può?
Ultima modifica di CDR_Militello il lunedì 1 aprile 2019, 19:23, modificato 1 volta in totale.
Potete ingannare tutti per qualche tempo e alcuni per tutto il tempo, ma non potete ingannare tutti per tutto il tempo
Avatar utente
CDR_Militello
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 354
Iscrizione: dicembre 2009
Località: Militello Rosmarino
Desktop: Unity
Distribuzione: Ubuntu 16.04 64 bit
Sesso: Maschile

Re: Pacchetti danneggiate dopo disinstallazione Nemesys

Messaggioda CDR_Militello » lunedì 1 aprile 2019, 19:17

derma Immagine ha scritto:Forse interpreto non correttamente quanto scrivesti prima a proposito di Synaptic...


CDR_Militello Immagine ha scritto:
derma Immagine ha scritto:Disinstallare da Synaptic il pacchetto "Nemesys" anziché reinstallarlo?... ma 'sto pacchetto lo installasti tramite ".deb" scaricato da qualche parte?


Synaptic non me lo fa aprire poichè mio compare l'errore (E: Il pacchetto nemesys deve essere reinstallato, ma non è possibile trovarne un archivio.
E: Errore interno nell'aprire la cache (1). Segnalare l'errore.). Nemesys, invece è un pacchetto DEB che si scarica dal sito ufficiale dell' AGCOM da quì: https://www.misurainternet.it/download/nemesys/

quindi, se provo a disinstallare da synaptic, questo non si avvia per via dell'errore, se invece provo a disinstallare dal pacchetto DEB, mi da altrettanto errore come scritto sopra



...riesci ad avviare Synaptic, e quindi a selezionare "Pacchetti danneggiati" presente nella barra laterale?

ciao, l'errore lo da Synaptic all'apertura, non mi fa operare!"
Allegati
Schermata del 2019-04-01 20-16-42.png
Potete ingannare tutti per qualche tempo e alcuni per tutto il tempo, ma non potete ingannare tutti per tutto il tempo
Avatar utente
CDR_Militello
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 354
Iscrizione: dicembre 2009
Località: Militello Rosmarino
Desktop: Unity
Distribuzione: Ubuntu 16.04 64 bit
Sesso: Maschile

Re: Pacchetti danneggiate dopo disinstallazione Nemesys

Messaggioda CDR_Militello » lunedì 1 aprile 2019, 19:23

trekfan1 Immagine ha scritto:Supponendo che il pacchetto nemesys sia nella cartella scaricati:
Codice: Seleziona tutto
sudo dpkg -i ~/Scaricati/Nemesys_v.3.3.1_ubuntu-18.04_64bit.deb
puoi usare il tasto TAB per autocompletare i nomi di file e cartelle


Effettivamente con il tuo consiglio qualcosa è cambiata, ma non ho risolto il problema che rimane. Ecco cosa mi restituisce il terminale
Codice: Seleziona tutto
antonino@antonino:~$ sudo dpkg -i ~/Scaricati/Nemesys_v.3.3.1_ubuntu-16.04_64bit.deb
[sudo] password di antonino:
Selezionato il pacchetto nemesys non precedentemente selezionato.
(Lettura del database... 435770 file e directory attualmente installati.)
Preparativi per estrarre .../Nemesys_v.3.3.1_ubuntu-16.04_64bit.deb...
prerm called with unknown argument `upgrade'
dpkg: attenzione: il sottoprocesso vecchio script di pre-removal ha restituito lo stato di errore 1
dpkg: viene provato lo script dal nuovo pacchetto...
prerm called with unknown argument `failed-upgrade'
dpkg: errore nell'elaborare l'archivio /home/antonino/Scaricati/Nemesys_v.3.3.1_ubuntu-16.04_64bit.deb (--install):
 il sottoprocesso nuovo script pre-removal ha restituito lo stato di errore 1
postinst called with unknown argument `abort-upgrade'
dpkg: errore durante la pulizia:
 il sottoprocesso installato script di post-installation ha restituito lo stato di errore 1
Si sono verificati degli errori nell'elaborazione:
 /home/antonino/Scaricati/Nemesys_v.3.3.1_ubuntu-16.04_64bit.deb
antonino@antonino:~$
Allegati
3.png
2.png
Potete ingannare tutti per qualche tempo e alcuni per tutto il tempo, ma non potete ingannare tutti per tutto il tempo
Avatar utente
CDR_Militello
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 354
Iscrizione: dicembre 2009
Località: Militello Rosmarino
Desktop: Unity
Distribuzione: Ubuntu 16.04 64 bit
Sesso: Maschile

Re: Pacchetti danneggiate dopo disinstallazione Nemesys

Messaggioda derma » lunedì 1 aprile 2019, 19:25

Cliccando su "Chiudi" nella finestra che si apre in Synaptic, si chiude lo stesso Synaptic?... apri un Terminale e copia/incolla il seguente comando...


Codice: Seleziona tutto

cat /var/lib/dpkg/status > status




...creerà un file chiamato status nella tua "/home"... aprilo e copia/incolla il suo contenuto inserendolo sempre nei tag [code]... puoi anche fare tu una ricerca del pacchetto "nemesys" in questo file, e magari postare solo la parte/righe che lo riguardano.
__Ŧ__
'\°°/'
Γı /\ ı\   |7 Γı Γı Γı -|-
Avatar utente
derma
Rampante Reduce
Rampante Reduce
 
Messaggi: 7035
Iscrizione: settembre 2006
Località: Sicilia
Distribuzione: Ubuntu 15.10 (Wily Werewolf)

Re: Pacchetti danneggiate dopo disinstallazione Nemesys

Messaggioda CDR_Militello » lunedì 1 aprile 2019, 19:26

caturen Immagine ha scritto:
Il pacchetto nemesys deve essere reinstallato
ti decidi o no a reinstallare quel deb?

ciao, il pacchetto DEB, non me lo fa reinstallare perchè mi da errore
Allegati
4.png
Potete ingannare tutti per qualche tempo e alcuni per tutto il tempo, ma non potete ingannare tutti per tutto il tempo
Avatar utente
CDR_Militello
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 354
Iscrizione: dicembre 2009
Località: Militello Rosmarino
Desktop: Unity
Distribuzione: Ubuntu 16.04 64 bit
Sesso: Maschile

Re: Pacchetti danneggiate dopo disinstallazione Nemesys

Messaggioda trekfan1 » lunedì 1 aprile 2019, 19:30

Post consecutivi = messaggi consecutivi
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 19593
Iscrizione: maggio 2006
Località: Formigine (MO) | Tenace Tecnocrate
Desktop: Gnome
Distribuzione: Ubuntu 19.04 e 19.10 (dev) 64 bit
Sesso: Maschile

Re: Pacchetti danneggiate dopo disinstallazione Nemesys

Messaggioda CDR_Militello » lunedì 1 aprile 2019, 19:32

derma Immagine ha scritto:Cliccando su "Chiudi" nella finestra che si apre in Synaptic, si chiude lo stesso Synaptic?... apri un Terminale e copia/incolla il seguente comando...


Codice: Seleziona tutto

cat /var/lib/dpkg/status > status




...creerà un file chiamato status nella tua "/home"... aprilo e copia/incolla il suo contenuto inserendolo sempre nei tag code... puoi anche fare tu una ricerca del pacchetto "nemesys" in questo file, e magari postare solo la parte/righe che lo riguardano.

ciao, se chiudo si chiude anche Synaptic. Tutto il file è enorme, facendo la ricerca ho trovato questa sezione:
Codice: Seleziona tutto
Package: nemesys
Status: install reinstreq half-configured
Priority: optional
Section: Network
Maintainer: Helpdesk Misurainternet <gestione.misurainternet@fub.it>
Architecture: amd64
Source: nemesys
Version: 3.3.1
Config-Version: 3.3.1
Conffiles:
 /etc/init.d/nemesys 889da6e61fe0a326e62d34154ff3c2bb
Description: Sistema per la valutazione della connessione broadband
  "Il software Ne.Me.Sys, sviluppato e realizzato dalla Fondazione Ugo Bordoni, è il programma ufficiale del progetto "Misura Internet" dell’Autorità per le Garanzie nelle Comunicazioni "AGCOM" per la misura della qualità della connessione ad Internet da postazione fissa. Ne.Me.Sys. rappresenta il primo ed unico caso in Europa di software ufficiale e certificato messo a disposizione degli utenti che desiderano verificare le prestazioni del proprio accesso ad Internet da postazione fissa."
Homepage: http://www.misurainternet.it/
Ultima modifica di trekfan1 il lunedì 1 aprile 2019, 19:34, modificato 1 volta in totale.
Motivazione: Sistemati i tag
Potete ingannare tutti per qualche tempo e alcuni per tutto il tempo, ma non potete ingannare tutti per tutto il tempo
Avatar utente
CDR_Militello
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 354
Iscrizione: dicembre 2009
Località: Militello Rosmarino
Desktop: Unity
Distribuzione: Ubuntu 16.04 64 bit
Sesso: Maschile

Successiva

Torna a Applicazioni

Chi c’è in linea

Visualizzano questa sezione: Maxwell87 e 12 ospiti