problemi con l'ambiente grafico

Installazione, configurazione e uso di programmi e strumenti.

problemi con l'ambiente grafico

Messaggioda duns » domenica 12 maggio 2019, 13:36

Dei miei familiari, sul cui PC ho installato Kubuntu 18.04, mi hanno detto che oggi dopo il login appare un ambiente grafico senza icone e senza barra dei menu e task manager (si vede solo lo sfondo del desktop, correttamente). Hanno provato diverse volte con dei reset, senza risolvere. Io, non essendo lì fisicamente, li ho guidati a usare un'altra istallazione di Kubuntu presente sullo stesso PC. Ma vorrei risolvergli il problema: se li faccio andare in modalità provvisoria è possibile che la cosa poi si risolva?
Grazie

EDIT
Dimenticavo: mi hanno detto che prima che succedesse questo patatrac avevano chiuso la sessione in modo diciamo brutale, cioè spegnendo il PC, perché andava troppo per le lunghe.

EDIT
Stasera ho visto direttamente la cosa: lo schermo diventa nero con solo il mouse visibile, dopo il login, in tutti gli utenti.
Ho provato coi comandi
Codice: Seleziona tutto
killall (/kquitapp5) plasmashell && kstart(/5) plasmashell

ma niente da fare.
Qualche idea?

EDIT
Stamattina ho provato, in modalità testuale, con sudo apt update (corretto) e sudo apt upgrade (con errori di bad gateway e poi un numero di IP, se ben ricordo).

EDIT
1) Riprovando sono riuscito, in modalità tesuale, a fare l'aggiornamento del sistema. Ma questo non ha risolto.
2) Avendo istallato wireshark-gtk (avevo letto su un forum che risolveva un problema che ho visto in .xsessionerrors, riguardando X11) mi sono accorto che i programmi grafici partono. Se dalla riga di comando (alt+F2) digito firefox, parte firefox nella consueta modalità grafica e così gli altri programmi.
Quindi il problema è il desktop, e a livello di sistema.
Che fare?

EDIT
Accortomi che posso far partire i programmi con la solita grafica ho lanciato synaptic e ho reinstallato tutto ciò che si riferisce a *plasma*.
Riavvio: niente da fare.
Questo il contenuto più recente di .xsessionerrors:
Codice: Seleziona tutto
kdeinit5: PID 1178 terminated.
startkde: Shutting down...
kdeinit5: terminate KDE.
klauncher: Exiting on signal 1
QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
QThread: Destroyed while thread is still running
QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
startkde: Done.
QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
... [idem]...
QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
      after 33 requests (33 known processed) with 0 events remaining.
QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
bluedevil: Destroyed
QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
The X11 connection broke: I/O error (code 1)
XIO:  fatal IO error 4 (Chiamata di sistema interrotta) on X server ":0"
      after 25 requests (25 known processed) with 0 events remaining.
Invalid MIT-MAGIC-COOKIE-1 key
duns
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 304
Iscrizione: febbraio 2006
Desktop: KDE plasma5
Distribuzione: Kubuntu 18.04
Sesso: Maschile

Re: problemi con l'ambiente grafico

Messaggioda duns » martedì 14 maggio 2019, 19:38

Alla fine ho risolto reinstallando Kubuntu: è la seconda volta, su quell'SSD.
duns
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 304
Iscrizione: febbraio 2006
Desktop: KDE plasma5
Distribuzione: Kubuntu 18.04
Sesso: Maschile

Re: problemi con l'ambiente grafico

Messaggioda frapox » martedì 14 maggio 2019, 20:54

Codice: Seleziona tutto
Invalid MIT-MAGIC-COOKIE-1 key

questo errore mi fa pensare a una situazione simile che m'è capitata tempo fa, che risolsi rimuovendo il file .Xauthority
Codice: Seleziona tutto
rm -v  ~/.Xauthority


Ed è bene googlare gli errori che ti escono, non fosse altro che magari trovi una soluzione meno radicale al formatta e reinstalla. Tienilo presente la prossima volta :)

Ciao!
Avatar utente
frapox
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 421
Iscrizione: dicembre 2005
Località: Lombardia
Desktop: Gnome 3, Plasma 5
Distribuzione: Arch, Debian, Ubuntu

Re: problemi con l'ambiente grafico

Messaggioda woddy68 » martedì 14 maggio 2019, 23:06

Sarebbe utile conoscere le specifiche del pc in questione....sopratutto sapere se ha una scheda grafica Nvidia e se sta utilizzando driver proprietari, oppure se utilizza driver open nel caso di intel e amd. Dico questo perché spesso i driver proprietari Nvidia creano problemi....
Desktop - Acer Aspire M5500 (AMD) OpenSuse Leap 15.1 Kde -- openSUSE Tumbleweed
Notebook Acer Aspire E1 -522 (Amd) Kde Neon
No Windows :o :nono: ;)
Avatar utente
woddy68
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4614
Iscrizione: febbraio 2011
Desktop: Kde Plasma5
Distribuzione: Leap 15.1 - Tumbleweed- Kde Neon
Sesso: Maschile

Re: problemi con l'ambiente grafico

Messaggioda duns » giovedì 16 maggio 2019, 9:41

Grazie!
1) Ho in effetti googlato . E così ho trovato una soluzione (wireshark) ... che si è rivelata inutile :D
2) Non penso che il problema fosse .xauthority, perché era comune a tutti gli utenti.
3) né penso sia un problema di driver perché graficamente aveva sempre funzionato alla perfezione senza installarne di particolari.
duns
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 304
Iscrizione: febbraio 2006
Desktop: KDE plasma5
Distribuzione: Kubuntu 18.04
Sesso: Maschile


Torna a Applicazioni

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 11 ospiti