[Risolto] GRRRRRRRR!!!! Open Office 3.0

Problemi riscontrati nella Intrepid (Ubuntu 8.10) in fase di sviluppo.

[Risolto] GRRRRRRRR!!!! Open Office 3.0

Messaggioda ziocane » giovedì 16 ottobre 2008, 23:06

Ciao a tutti, posto qui perchè la 3.0 non è ancora ufficiale. Spero di non aver sbagliato sezione.

Allora oggi ho scaricato questo pacchetto:

OOo_3.0.0_LinuxX86-64_install_it_deb.tar.gz

per il mio 64 bit, installo da terminale e lancio il programma e vedo che arriva tranquillamente alla fase di configurazione (nome, registrazione prodotto etc).
Soddisfatto decido di rimuovere la versione vecchia (da synaptic) ho rimosso:

openoffice.org-common

Adesso, a parte che se clikko su un documento non succede nulla e cerca la versione vecchia.
Ma anche se gli dico di avviarlo tramite comando da shell parte open office 3.0, ma crasha...(non mi apre il documento).
Quando creo un documento nuovo mi chiede dove salvarlo (es scrivani), ma non lo salva...sulla scrivania non esiste.

Qualche idea senza dover reinstallare il pacchetto rimosso?

Ho anche provato a reinstallare il pacchetto (OOo_3.0.0_LinuxX86-64_install_it_deb.tar.gz), per vedere se avevo rimosso qualche dipendenza ma nisba...
Ultima modifica di ziocane il venerdì 24 ottobre 2008, 8:44, modificato 1 volta in totale.
Sono uno Zero member!
Avatar utente
ziocane
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3243
Iscrizione: aprile 2007

Re: Open Office 3.0

Messaggioda ryouza » giovedì 16 ottobre 2008, 23:15

A parte che é uscito ufficiale,magari manca ancora sui repo,cmq prova a rimuovere tutto e poi fai un giro su getdeb,credo che ci sia già qualcosa...
Avatar utente
ryouza
Prode Principiante
 
Messaggi: 146
Iscrizione: febbraio 2007

Re: Open Office 3.0

Messaggioda ziocane » venerdì 17 ottobre 2008, 17:05

Ieri sera ho rimosso tutto...ma proprio TUTTO! Fortunatamente oggi sono riuscito a risistemare...
Su getdeb avevo già guardato e non l'avevo trovato.
Ma il programma funziona adesso, solo che ha dei problemi:

1-I file li salva dove vuole lui: nella home solitamente, nella scrivania non gli garba.
2-Se vado nei miei documenti e apro un file, parte il programma ma crasha.
Se invece apro il programma e faccio file>apri lo stesso file si apre tranquillamente.

per la cronaca ho reinstallato office vecchio...
Sono uno Zero member!
Avatar utente
ziocane
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3243
Iscrizione: aprile 2007

Re: Open Office 3.0

Messaggioda toretto85 » venerdì 17 ottobre 2008, 22:50

anche io ho questo problema con la versione 64 bit, ho rimosso il vecchio office 2.4 ed ora quando devo aprire un documento word non mi trova il percorso.
mentre se apro direttamente word (openoffice) e seleziono il file da aprire lo fà tranquillamente.
come faccio ad associare il programma appena installato ad ogni file che deve riconoscere in automatico?
toretto85
Prode Principiante
 
Messaggi: 179
Iscrizione: aprile 2007

Re: Open Office 3.0

Messaggioda » venerdì 17 ottobre 2008, 22:56

toretto85 ha scritto:anche io ho questo problema con la versione 64 bit, ho rimosso il vecchio office 2.4 ed ora quando devo aprire un documento word non mi trova il percorso.
mentre se apro direttamente word (openoffice) e seleziono il file da aprire lo fà tranquillamente.
come faccio ad associare il programma appena installato ad ogni file che deve riconoscere in automatico?

Tasto destro del mouse sul file...proprietà...vai in apri con (od apri con altra applicazione... non ricordo bene a memoria)...aggiungi e scegli con cosa vuoi aprirlo.

gp
Ultima modifica di Anonymous il venerdì 17 ottobre 2008, 22:59, modificato 1 volta in totale.
Avatar utente
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1549
Iscrizione: ottobre 2005
Località: Giardini Naxos

Re: Open Office 3.0

Messaggioda toretto85 » venerdì 17 ottobre 2008, 23:00

ok ci sono riuscito, ma il problema era che non quando facevo apri con non usciva openoffice.
sono riuscito a risolvere inserendo la riga di comando che si inseriva in terminale dopo l'installazione per farlo partire.
ora in tutti i file che ho nel pc partono subito.
toretto85
Prode Principiante
 
Messaggi: 179
Iscrizione: aprile 2007

Re: GRRRRRRRR!!!! Open Office 3.0

Messaggioda ziocane » giovedì 23 ottobre 2008, 9:35

Uffaaaaa adesso mi arrabbio e defenestro il pc...
Il mio ha ancora il solito problema. Apre i file solo da apri>file, se invece clikko su un documento parte la schermata di OPENOFFICE 3.0 (quindi il comando di richiamo è giusto), ma poi crasha.
Che faccio? Disinstallo openofice 3.0 e ci riprovo?
Se si come? Che non vorrei ripetere l'esperienza della settimana scorsa...
Ed altra cosa: a questo punto credo che il mio pacchetto fosse corrotto, da dove scarico una versione funzionante?
Ricordo che ho un 64 bit...

Grazie grazie
Sono uno Zero member!
Avatar utente
ziocane
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3243
Iscrizione: aprile 2007

Re: GRRRRRRRR!!!! Open Office 3.0

Messaggioda Remanufactory » giovedì 23 ottobre 2008, 9:52

A me crasha su Kubuntu (32bit).
Ho disinstallato tutto OO2, ho installato tutto OO3 dai pacchetti.
Al momento del primo lancio, lui mi chiede la procedura di registrazione, terminata la quale si chiude e non fa più nulla.
Per capire ogni problema con i computer, i software e le nuove tecnologie, esistono 4 parole magiche: "Mmmh: chissà come funziona?"
Remanufactory
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 435
Iscrizione: ottobre 2007

Re: GRRRRRRRR!!!! Open Office 3.0

Messaggioda » giovedì 23 ottobre 2008, 9:55

Avete provato con tramite questo repository?
Codice: Seleziona tutto
deb http://ppa.launchpad.net/openoffice-pkgs/ubuntu intrepid main


Rimuovete OO 3 che già avete installato, aggiungete il repository alla lista ed installatelo nuovamente.

gp
Avatar utente
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1549
Iscrizione: ottobre 2005
Località: Giardini Naxos

Re: GRRRRRRRR!!!! Open Office 3.0

Messaggioda Remanufactory » giovedì 23 ottobre 2008, 13:07

ha scritto:Avete provato con tramite questo repository?
Codice: Seleziona tutto
deb http://ppa.launchpad.net/openoffice-pkgs/ubuntu intrepid main

Rimuovete OO 3 che già avete installato, aggiungete il repository alla lista ed installatelo nuovamente.


Sob... provato anche con questa source, ma nisba.  :'(
Io non riesco proprio a installarlo e farlo funzionare. Per ora mi tengo la 2, aspetterò in futuro.... ;-) tanto non ho fretta. Però se qualcuno ci riesce lo faccia sapere :-)
Per capire ogni problema con i computer, i software e le nuove tecnologie, esistono 4 parole magiche: "Mmmh: chissà come funziona?"
Remanufactory
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 435
Iscrizione: ottobre 2007

Re: GRRRRRRRR!!!! Open Office 3.0

Messaggioda » giovedì 23 ottobre 2008, 13:31

Remanufactory ha scritto:
ha scritto:Avete provato con tramite questo repository?
Codice: Seleziona tutto
deb http://ppa.launchpad.net/openoffice-pkgs/ubuntu intrepid main

Rimuovete OO 3 che già avete installato, aggiungete il repository alla lista ed installatelo nuovamente.


Sob... provato anche con questa source, ma nisba.  :'(
Io non riesco proprio a installarlo e farlo funzionare. Per ora mi tengo la 2, aspetterò in futuro.... ;-) tanto non ho fretta. Però se qualcuno ci riesce lo faccia sapere :-)



Volendo potresti provare a lanciarlo da terminale e vedere se restituisce un qualche output di errore. Giusto per provare a capire dove sta il problema.

gp
Avatar utente
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1549
Iscrizione: ottobre 2005
Località: Giardini Naxos

Re: GRRRRRRRR!!!! Open Office 3.0

Messaggioda Remanufactory » giovedì 23 ottobre 2008, 14:28

ha scritto:Volendo potresti provare a lanciarlo da terminale e vedere se restituisce un qualche output di errore. Giusto per provare a capire dove sta il problema.


Argh, che idiota! L'avevo anche fatto una volta, ma mi ero completamente scordato dell'esito!!! Mi aveva effettivamente detto che mancava qualcosa - tipo un modulo o una funzione (non si trattava di un pacchetto perché altrimenti l'avrei riconosciuto, e installato).
Ora non posso riprovare, ma ci tornerò su appena potrò.
Per capire ogni problema con i computer, i software e le nuove tecnologie, esistono 4 parole magiche: "Mmmh: chissà come funziona?"
Remanufactory
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 435
Iscrizione: ottobre 2007

Re: GRRRRRRRR!!!! Open Office 3.0

Messaggioda telperion » giovedì 23 ottobre 2008, 15:18

grrr grr grrr
ma il pacchetto nella cartella destop-integration dentro DEBS lo hai installato?
Avatar utente
telperion
Rampante Reduce
Rampante Reduce
 
Messaggi: 5407
Iscrizione: luglio 2006

Re: GRRRRRRRR!!!! Open Office 3.0

Messaggioda Remanufactory » giovedì 23 ottobre 2008, 15:46

telperion ha scritto:ma il pacchetto nella cartella destop-integration dentro DEBS lo hai installato?


Dici a me? Sì, lho installato, e funziona bene, nel senso che integra tutte le icone nel menu correttamente, e tutto il resto. E' la procedura di avvio che si blocca come ho detto. Ma devo leggere bene il messaggio di errrore da shell, la chiave forse è lì.
Per capire ogni problema con i computer, i software e le nuove tecnologie, esistono 4 parole magiche: "Mmmh: chissà come funziona?"
Remanufactory
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 435
Iscrizione: ottobre 2007

Re: GRRRRRRRR!!!! Open Office 3.0

Messaggioda ziocane » giovedì 23 ottobre 2008, 15:48

L'avevo installato, poi rimosso perchè secondo me andava ad influire solo sul menù...comunque per scrupolo l'ho reinstallato e la situazione è la medesima...

Altra cosa: com'è il comando inverso di

sudo dpkg -i OOo_3.0.0_LinuxX86-64_install_it_deb/*.deb

per rimuovere tutti sti pacchetti senza doverli levare ad uno ad uno, e senza rischiare di eliminare dipendenze?
Grazie!

@remanufactory: non è che ti dicesse che aveva il pacchetto JRT (java real qualcosa) corrotto? A me l'ha detto una volta prima di iniziare una presentazione (che si vedeva perfettamente), e poi non me l'ha più detto.
Sono uno Zero member!
Avatar utente
ziocane
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3243
Iscrizione: aprile 2007

Re: GRRRRRRRR!!!! Open Office 3.0

Messaggioda m4tt » giovedì 23 ottobre 2008, 19:17

Ciao a tutti...
Io avevo sul mio ubuntu hardy amd64 lo stesso problema di crash all'avvio di openoffice3.

Ho risolto adesso... scrivo i passi:

Rimosso la versione 2:
Codice: Seleziona tutto
sudo apt-get remove --purge openoffice.org-base-core openoffice.org-calc openoffice.org-common openoffice.org-core openoffice.org-draw openoffice.org-emailmerge openoffice.org-gnome openoffice.org-gtk openoffice.org-impress openoffice.org-style-human openoffice.org-writer ttf-opensymbol python-uno


Ho poi eliminato dalla home le directory nascoste .openoffice*

In seguito ho installato la versione 3.

dalla directory DEBS del tar.gz estratto:
Codice: Seleziona tutto
sudo dpkg -i *.*
sudo dpkg -i desktop-integration/openoffice.org3.0-debian-menus_3.0-9358_all.deb


e tutto adesso funziona alla perfezione!

P.S.
Se dopo il primo avvio dovesse andare in crash il panello di gnome basta riavviare X.

Spero di essere stato utile!
Ultima modifica di m4tt il giovedì 23 ottobre 2008, 19:20, modificato 1 volta in totale.
Avatar utente
m4tt
Prode Principiante
 
Messaggi: 1
Iscrizione: ottobre 2008

Re: GRRRRRRRR!!!! Open Office 3.0

Messaggioda ziocane » venerdì 24 ottobre 2008, 8:43

Siccome ho la testa dura, dopo un miliardo di tentativi ce l'ho fatta. (Grazie anche a Giova che mi ha fatto notare i JDK e a m4tt per la questione delle cartelle da eliminare!).

Procedimento:

Ho rimosso open office vecchio, e anche il pacchetto openoffice.org-ure (che sospetto fosse il problema. Infatti contiene jre per la versione vecchia e secondo me faceva casino. Appena rimosso da /otp è sparito openoffice.org). Poi per sicurezza ho rimosso openoffice 3.0 e anche il pacchetto openoffice.org-debian-menus.

HO installato JDK che secondo me da meno problemi di jre.

Poi ho reinstallato tutto dall'inizio.
Risultato che ora openoffice funzica, non sbarella più e i file si aprono anche clikkando semplicemente su di essi.
Funzionano anche i pdf...
Questa non l'ho capita visto che avevo letto che bisognava aggiungere un pacchetto per loro...mah!

Ultima cosa...mi infastidisce un pò la presenza di 4-5 pacchetti residui di open office vecchio (tipo quelli di help). Ma cercando di rimuoverli mi dice che hanno dipendenze vitali per il pc. quindi per il momento mi fermo qui.
Grazie a tutti.
Sono uno Zero member!
Avatar utente
ziocane
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3243
Iscrizione: aprile 2007

Re: GRRRRRRRR!!!! Open Office 3.0

Messaggioda telperion » venerdì 24 ottobre 2008, 10:32

ziocane ha scritto:

Ultima cosa...mi infastidisce un pò la presenza di 4-5 pacchetti residui di open office vecchio (tipo quelli di help). Ma cercando di rimuoverli mi dice che hanno dipendenze vitali per il pc. quindi per il momento mi fermo qui.
Grazie a tutti.


Si con gnome quei pacchetti delle lingue devono restare perchè sono dipendenze di altri ma non danno alcun fastidio invece il resto va rimosso senza pietà altrimenti sono casini.
Avatar utente
telperion
Rampante Reduce
Rampante Reduce
 
Messaggi: 5407
Iscrizione: luglio 2006


Torna a Intrepid 8.10

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 1 ospite