[Risolto] Tempo di avvio esageratamente lungo

Supporto relativo alle versioni di Ubuntu in fase di sviluppo e test. All'interno troverete delle sottosezioni riguardanti le precedenti versioni.

[Risolto] Tempo di avvio esageratamente lungo

Messaggioda vaillant » mercoledì 15 settembre 2010, 22:01

Salve a tutti. Ho Maverick Beta e, da quando l'ho installata, ho riscontrato dei tempi di boot molto lenti. Speravo in qualche miglioramento con gli aggiornamenti, ma la situazione è andata ad aggravarsi.

Neanche la versione beta di Lucid aveva tempi di boot così alti.

Allego la "foto" fatta da bootchart
Immagine
dove ho notato che il tempo totale di quasi due minuti sembra essere causato dal processo "modprobe" che impiega 80 secondi!!

Qualcuno ha idea di cosa poter fare per risolvere? O quantomeno capire di cosa si tratta? Grazie :)
Ultima modifica di vaillant il mercoledì 29 settembre 2010, 14:49, modificato 1 volta in totale.
I miei computer - Ubuntu Builder - Crea la tua Ubuntu personalizzata
Se sei incerto, tieni aperto
Did I ever tell you what the definition of insanity is?
Avatar utente
vaillant
Rampante Reduce
Rampante Reduce
 
Messaggi: 8319
Iscrizione: marzo 2009
Località: Modica
Distribuzione: Ubuntu 16.04
Sesso: Maschile

Re: Tempo di avvio esageratamente lungo

Messaggioda vaillant » domenica 19 settembre 2010, 10:06

UP
I miei computer - Ubuntu Builder - Crea la tua Ubuntu personalizzata
Se sei incerto, tieni aperto
Did I ever tell you what the definition of insanity is?
Avatar utente
vaillant
Rampante Reduce
Rampante Reduce
 
Messaggi: 8319
Iscrizione: marzo 2009
Località: Modica
Distribuzione: Ubuntu 16.04
Sesso: Maschile

Re: Tempo di avvio esageratamente lungo

Messaggioda fil0 » domenica 19 settembre 2010, 11:24

Sai se almeno la foto fosse a risoluzione maggiore si potrebbero leggere le scritte... (yes)
fil0
Prode Principiante
 
Messaggi: 32
Iscrizione: marzo 2010

Re: Tempo di avvio esageratamente lungo

Messaggioda vaillant » domenica 19 settembre 2010, 11:54

fil0 ha scritto:Sai se almeno la foto fosse a risoluzione maggiore si potrebbero leggere le scritte... (yes)


La rimetto a dimensioni originali
Immagine
I miei computer - Ubuntu Builder - Crea la tua Ubuntu personalizzata
Se sei incerto, tieni aperto
Did I ever tell you what the definition of insanity is?
Avatar utente
vaillant
Rampante Reduce
Rampante Reduce
 
Messaggi: 8319
Iscrizione: marzo 2009
Località: Modica
Distribuzione: Ubuntu 16.04
Sesso: Maschile

Re: Tempo di avvio esageratamente lungo

Messaggioda vaillant » lunedì 27 settembre 2010, 11:50

UP
I miei computer - Ubuntu Builder - Crea la tua Ubuntu personalizzata
Se sei incerto, tieni aperto
Did I ever tell you what the definition of insanity is?
Avatar utente
vaillant
Rampante Reduce
Rampante Reduce
 
Messaggi: 8319
Iscrizione: marzo 2009
Località: Modica
Distribuzione: Ubuntu 16.04
Sesso: Maschile

Re: Tempo di avvio esageratamente lungo

Messaggioda einstein1969 » lunedì 27 settembre 2010, 12:06

perche' non alleghi anche un dmegs? (rifai pero' il bootchart aggiornato)
einstein1969
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 931
Iscrizione: dicembre 2005

Re: Tempo di avvio esageratamente lungo

Messaggioda vaillant » lunedì 27 settembre 2010, 13:51

Il dmesg è in allegato. Il grafico di bootchart è questo

Immagine
Allegati
dmesg.txt
(54.81 KiB) Scaricato 34 volte
I miei computer - Ubuntu Builder - Crea la tua Ubuntu personalizzata
Se sei incerto, tieni aperto
Did I ever tell you what the definition of insanity is?
Avatar utente
vaillant
Rampante Reduce
Rampante Reduce
 
Messaggi: 8319
Iscrizione: marzo 2009
Località: Modica
Distribuzione: Ubuntu 16.04
Sesso: Maschile

Re: Tempo di avvio esageratamente lungo

Messaggioda einstein1969 » lunedì 27 settembre 2010, 14:37

cosa c'e' su ATA6?

sembra un problema con i controller PATA...
einstein1969
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 931
Iscrizione: dicembre 2005

Re: Tempo di avvio esageratamente lungo

Messaggioda vaillant » lunedì 27 settembre 2010, 14:44

Ho due hard disk S-Ata, quello contenente Ubuntu è questo
Codice: Seleziona tutto
francesco@francesco-desktop:~$ sudo fdisk -l
[sudo] password for francesco:

Disco /dev/sda: 160.0 GB, 160041885696 byte
255 testine, 63 settori/tracce, 19457 cilindri
Unità = cilindri di 16065 * 512 = 8225280 byte
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identificativo disco: 0x333890ff

Dispositivo Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        2432    19535008+  83  Linux
/dev/sda2            2433       16801   115418992+  83  Linux
/dev/sda3           16802       19457    21334320    7  HPFS/NTFS


l'altro non è visualizzato da grub
I miei computer - Ubuntu Builder - Crea la tua Ubuntu personalizzata
Se sei incerto, tieni aperto
Did I ever tell you what the definition of insanity is?
Avatar utente
vaillant
Rampante Reduce
Rampante Reduce
 
Messaggi: 8319
Iscrizione: marzo 2009
Località: Modica
Distribuzione: Ubuntu 16.04
Sesso: Maschile

Re: Tempo di avvio esageratamente lungo

Messaggioda einstein1969 » lunedì 27 settembre 2010, 14:52

vaillant86 ha scritto:Ho due hard disk S-Ata, quello contenente Ubuntu è questo
Codice: Seleziona tutto
francesco@francesco-desktop:~$ sudo fdisk -l
[sudo] password for francesco:

Disco /dev/sda: 160.0 GB, 160041885696 byte
255 testine, 63 settori/tracce, 19457 cilindri
Unità = cilindri di 16065 * 512 = 8225280 byte
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identificativo disco: 0x333890ff

Dispositivo Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        2432    19535008+  83  Linux
/dev/sda2            2433       16801   115418992+  83  Linux
/dev/sda3           16802       19457    21334320    7  HPFS/NTFS


l'altro non è visualizzato da grub


Sul cavo PATA hai il cdrom/masterizzatore? (e' ATA5)
Poi c'e' ATA6 che credo sia l'altro canale PATA...
Controlla da bios se e' disattivato , oppure prova a cambiare impostazione...
einstein1969
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 931
Iscrizione: dicembre 2005

Re: Tempo di avvio esageratamente lungo

Messaggioda pablo_honey » lunedì 27 settembre 2010, 15:58

magari sto solo tirando qualche falso allarme, ma l'ultima volta, e mi ci faceva con lucid ufficiale, che avevo il boot lento causato da modprobe era perchè l'hard disk era pressochè andato
You can't always get what you want [Mick Jagger]
Avatar utente
pablo_honey
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1019
Iscrizione: novembre 2009
Località: Italian East Coast
Desktop: Kde
Distribuzione: Debian Testing i686

Re: Tempo di avvio esageratamente lungo

Messaggioda vaillant » lunedì 27 settembre 2010, 16:29

einstein1969 ha scritto:Sul cavo PATA hai il cdrom/masterizzatore? (e' ATA5)
Poi c'e' ATA6 che credo sia l'altro canale PATA...
Controlla da bios se e' disattivato , oppure prova a cambiare impostazione...


Si, il masterizzatore è sul cavo PATA. Quindi pensi che potrebbe essere il secondo canale (inutilizzato e quindi disattivabile) il problema?

pablo_honey ha scritto:magari sto solo tirando qualche falso allarme, ma l'ultima volta, e mi ci faceva con lucid ufficiale, che avevo il boot lento causato da modprobe era perchè l'hard disk era pressochè andato

Spero vivamente che sia solo un falso allarme ;D
I miei computer - Ubuntu Builder - Crea la tua Ubuntu personalizzata
Se sei incerto, tieni aperto
Did I ever tell you what the definition of insanity is?
Avatar utente
vaillant
Rampante Reduce
Rampante Reduce
 
Messaggi: 8319
Iscrizione: marzo 2009
Località: Modica
Distribuzione: Ubuntu 16.04
Sesso: Maschile

Re: Tempo di avvio esageratamente lungo

Messaggioda einstein1969 » lunedì 27 settembre 2010, 17:28

vaillant86 ha scritto:
einstein1969 ha scritto:Sul cavo PATA hai il cdrom/masterizzatore? (e' ATA5)
Poi c'e' ATA6 che credo sia l'altro canale PATA...
Controlla da bios se e' disattivato , oppure prova a cambiare impostazione...


Si, il masterizzatore è sul cavo PATA. Quindi pensi che potrebbe essere il secondo canale (inutilizzato e quindi disattivabile) il problema?



prova... ma hai anche esata?

comunque sembra proprio che si ferma sull'ata6...
Codice: Seleziona tutto
[    1.840482] ata5: PATA max UDMA/100 cmd 0xec00 ctl 0xe880 bmdma 0xe400 irq 16
[    1.840484] ata6: PATA max UDMA/133 cmd 0xe800 ctl 0xe480 bmdma 0xe408 irq 16
...
[    7.240062] ata6.00: qc timeout (cmd 0xec)
[    7.240068] ata6.00: failed to IDENTIFY (I/O error, err_mask=0x4)
[   12.280097] ata6: link is slow to respond, please be patient (ready=0)
[   17.260108] ata6: device not ready (errno=-16), forcing hardreset
[   27.440057] ata6.00: qc timeout (cmd 0xec)
[   27.440061] ata6.00: failed to IDENTIFY (I/O error, err_mask=0x4)
[   32.480092] ata6: link is slow to respond, please be patient (ready=0)
[   37.460098] ata6: device not ready (errno=-16), forcing hardreset
[   67.643797] ata6.00: qc timeout (cmd 0xec)
[   67.643800] ata6.00: failed to IDENTIFY (I/O error, err_mask=0x4)
[   72.683790] ata6: link is slow to respond, please be patient (ready=0)
[   77.663780] ata6: device not ready (errno=-16), forcing hardreset

einstein1969
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 931
Iscrizione: dicembre 2005

Re: Tempo di avvio esageratamente lungo

Messaggioda vaillant » lunedì 27 settembre 2010, 17:30

einstein1969 ha scritto:ma hai anche esata?


No

Ok, proverò intanto a disabilitare il PATA da bios, poi procederò eventualmente a staccare il disco principale. Vediamo che succede
I miei computer - Ubuntu Builder - Crea la tua Ubuntu personalizzata
Se sei incerto, tieni aperto
Did I ever tell you what the definition of insanity is?
Avatar utente
vaillant
Rampante Reduce
Rampante Reduce
 
Messaggi: 8319
Iscrizione: marzo 2009
Località: Modica
Distribuzione: Ubuntu 16.04
Sesso: Maschile

Re: Tempo di avvio esageratamente lungo

Messaggioda vaillant » mercoledì 29 settembre 2010, 12:46

Non funziona nulla. Il tempo di avvio si riduce (di pochi secondi, resta comunque sopra il minuto e mezzo) solamente con il disco principale staccato... >:( >:(
I miei computer - Ubuntu Builder - Crea la tua Ubuntu personalizzata
Se sei incerto, tieni aperto
Did I ever tell you what the definition of insanity is?
Avatar utente
vaillant
Rampante Reduce
Rampante Reduce
 
Messaggi: 8319
Iscrizione: marzo 2009
Località: Modica
Distribuzione: Ubuntu 16.04
Sesso: Maschile

Re: Tempo di avvio esageratamente lungo

Messaggioda vaillant » mercoledì 29 settembre 2010, 14:49

Ho risolto, era un problema del disco rigido che presentava errori ;)

Grazie a tutti
I miei computer - Ubuntu Builder - Crea la tua Ubuntu personalizzata
Se sei incerto, tieni aperto
Did I ever tell you what the definition of insanity is?
Avatar utente
vaillant
Rampante Reduce
Rampante Reduce
 
Messaggi: 8319
Iscrizione: marzo 2009
Località: Modica
Distribuzione: Ubuntu 16.04
Sesso: Maschile

Re: [Risolto] Tempo di avvio esageratamente lungo

Messaggioda pablo_honey » giovedì 30 settembre 2010, 10:26

e quindi?
You can't always get what you want [Mick Jagger]
Avatar utente
pablo_honey
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1019
Iscrizione: novembre 2009
Località: Italian East Coast
Desktop: Kde
Distribuzione: Debian Testing i686

Re: [Risolto] Tempo di avvio esageratamente lungo

Messaggioda vaillant » giovedì 30 settembre 2010, 10:26

E quindi cosa?
I miei computer - Ubuntu Builder - Crea la tua Ubuntu personalizzata
Se sei incerto, tieni aperto
Did I ever tell you what the definition of insanity is?
Avatar utente
vaillant
Rampante Reduce
Rampante Reduce
 
Messaggi: 8319
Iscrizione: marzo 2009
Località: Modica
Distribuzione: Ubuntu 16.04
Sesso: Maschile

Re: [Risolto] Tempo di avvio esageratamente lungo

Messaggioda pablo_honey » giovedì 30 settembre 2010, 10:27

hai corretto gli errori del disco, che gli hai fatto?
You can't always get what you want [Mick Jagger]
Avatar utente
pablo_honey
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1019
Iscrizione: novembre 2009
Località: Italian East Coast
Desktop: Kde
Distribuzione: Debian Testing i686

Re: [Risolto] Tempo di avvio esageratamente lungo

Messaggioda vaillant » giovedì 30 settembre 2010, 10:30

Certo, pensavo fosse ovvio visto che ho scritto "era un problema del disco..." ;)
I miei computer - Ubuntu Builder - Crea la tua Ubuntu personalizzata
Se sei incerto, tieni aperto
Did I ever tell you what the definition of insanity is?
Avatar utente
vaillant
Rampante Reduce
Rampante Reduce
 
Messaggi: 8319
Iscrizione: marzo 2009
Località: Modica
Distribuzione: Ubuntu 16.04
Sesso: Maschile

Successiva

Torna a Maverick 10.10

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 1 ospite

cron