Stampa PDF non centrata in A5

Riconoscimento, installazione e configurazione delle periferiche.
Scrivi risposta
Innerina
Prode Principiante
Messaggi: 133
Iscrizione: domenica 6 gennaio 2008, 17:52
Desktop: Mate (Cinnamon)
Distribuzione: Ubuntu Mate 19.10 - amd64
Sesso: Femminile

Stampa PDF non centrata in A5

Messaggio da Innerina » domenica 21 giugno 2020, 1:29

La mia stampante è HP Deskjet 2540 di cui ho già visto i limiti operativi, quando per esempio ho cercato di stampare una cornice decorata me la tagliava a sinistra. Ho visto che da LibreOffice Writer stampa correttamente tutto centrato nel formato A5 per singola pagina, ma coi PDF me li sfasa tutti, come se le misure del foglio fossero più piccole, e non sono ancora riuscita a capire perché, dato che le impostazioni dal pannello di controllo indicano chiaramente A4 come formato di base, anche se da Writer noto che ha la tendenza a stampare nel formato preimpostato inglese Letter e mi tocca sempre sistemarlo. Ho letto che i pdf pescano le impostazioni dal CUPS, anziché dalla stampante stessa, ma non so come verificarlo. Sto sclerando perché la maggior parte dei documenti è in formato PDF e non voglio fare stampe tutte sfasate!!! :muro:

Spiego cmq come stampo:
- di solito setto formato A4, con 2 pagine per foglio, ma con ordine invertito perché uso fogli tagliati al formato A5 quindi mi esce tranquillamente come prima stampa, per poi stampare anche dietro allo stesso modo. Il problema però è che nei PDF, legge la stampa come se fossero 2 pagine unite per foglio e quindi sono sfasate rispetto ai margini destro e sinistro dell'A4. Anche se ho sempre lasciata flaggata la scelta di ruotare e centrare automaticamente, rimane sempre sfasato e dà un effetto orrendo se viene stampato anche sul retro. :muro:
- se provo a stampare nel formato A5, riesce a stampare correttamente nel centro ma risulta spostato verso l'alto come se appunto leggesse un formato cartaceo più piccolo rispetto a quello effettivo A5, ed anche questo è abbastanza fastidioso esteticamente NONOSTANTE lasci sempre flaggata la scelta di ruotare e centrare automaticamente! Che sia riduci o adatta la stampa all'area, il risultato non cambia, è come se non riconoscesse la carta effettivamente immessa! In questa modalità è pure fastidioso perché stampa solo col foglio in piedi e quindi devo modificare la livellina apposita che a differenza dell'altro metodo rimane comodamente ferma al formato A4 anche se lo tagli a metà. Inoltre non riconosce il formato orizzontale se settato. :muro: :muro: :muro:

Non riesco a capire se dipende dal programma in uso per stampare i PDF che è Atril, in tal caso ditemi se c'é un'alternativa che dia stampe fedeli all'anteprima, come fa Writer infatti. Esportare i file pdf in Writer è fuori discussione perché riformatta tutto in modo diverso e ci dovrei perdere le ore a sistemare tutto. Quindi se ci sono alternative che leggono e stampano meglio i PDF, ben venga!
Oppure se dipende dal pannello di controllo della stampante, se magari aggiornando risolvo questo problema, al momento è alla versione hplip-3.20.3. Con cui non mi trovo molto perché è tutto in inglese e non ha nemmeno l'anteprima per verificare le impostazioni prima di stampare... Tra l'altro dovrei aggiornare il sistema operativo alla 20.04 dall'attuale 19.10, dite che risolvo così?
Oppure esiste un programma apposito ed universale per stampare a prescindere dai formati, che insomma stampi esattamente ciò che vedi a schermo?

Roberto Pontecorvi
Rampante Reduce
Rampante Reduce
Messaggi: 5231
Iscrizione: mercoledì 20 maggio 2009, 22:48
Distribuzione: 18.4 mate - 20.4 mate
Sesso: Maschile
Località: Versilia

Re: Stampa PDF non centrata in A5

Messaggio da Roberto Pontecorvi » domenica 21 giugno 2020, 21:15

Da terminale dai il comando:

Codice: Seleziona tutto

hp-doctor
e posta il risultato.

Innerina
Prode Principiante
Messaggi: 133
Iscrizione: domenica 6 gennaio 2008, 17:52
Desktop: Mate (Cinnamon)
Distribuzione: Ubuntu Mate 19.10 - amd64
Sesso: Femminile

Re: Stampa PDF non centrata in A5

Messaggio da Innerina » lunedì 22 giugno 2020, 2:05

Eccolo:

Codice: Seleziona tutto

error: Either Internet is not working or Wget is not installed.
error: Failed to upgrade latest HPLIP. Is hp-upgrade already running (i.e. foreground or background)?


Checking for Dependencies....

---------------
| SYSTEM INFO |
---------------

 Kernel: 5.3.0-59-generic #53-Ubuntu SMP Wed Jun 3 15:52:15 UTC 2020 GNU/Linux
 Host: innerina-pc
 Proc: 5.3.0-59-generic #53-Ubuntu SMP Wed Jun 3 15:52:15 UTC 2020 GNU/Linux
 Distribution: 12 19.10
 Bitness: 64 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.20.3
HPLIP-Home: /usr/share/hplip
HPLIP-Installation: Auto installation is supported for ubuntu distro  19.10 version 

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.20.3

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-3.20.3
html=/usr/share/doc/hplip-3.20.3
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.20.3
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
qt5=no
policy-kit=no
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=yes
class-driver=no


Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: File o directory non esistente

Current contents of '~/.hplip/hplip.conf' file:
[upgrade]
notify_upgrade = true
last_upgraded_time = 1585694668
pending_upgrade_time = 0
latest_available_version = 3.17.10

[settings]
systray_visible = 0
systray_messages = 0

[last_used]
device_uri = "hp:/usb/Deskjet_2540_series?serial=CN48B4FBHV0604"
printer_name = 
working_dir = .

[commands]
scan = /usr/bin/xsane -V %SANE_URI%

[refresh]
rate = 30
enable = true
type = 1

[polling]
enable = false
interval = 5
device_list = 

[fax]
voice_phone = 
email_address = 

[installation]
date_time = 22/06/2020 01:55:52
version = 3.20.3


 <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>

--------------
| COMPILEDEP |
--------------

 gcc                  gcc - GNU Project C and C++ Compiler                         REQUIRED        -               9.2.1           OK         -
 make                 make - GNU make utility to maintain groups of programs       REQUIRED        3.0             4.2.1           OK         -
 libtool              libtool - Library building support services                  REQUIRED        -               2.4.6           OK         -

------------------------
| General Dependencies |
------------------------

 libcrypto            libcrypto - OpenSSL cryptographic library                    REQUIRED        -               1.1.1           OK         -
 python-xml           Python XML libraries                                         REQUIRED        -               2.2.7           OK         -
 libnetsnmp-devel     libnetsnmp-devel - SNMP networking library development files REQUIRED        5.0.9           5.7.3           OK         -
 sane-devel           SANE - Scanning library development files                    REQUIRED        -               -               OK         -
 pil                  PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL        -               6.1.0           OK         -
 pyqt4-dbus           PyQt 4 DBus - DBus Support for PyQt4                         REQUIRED        4.0             4.12.1          OK         -
 libpthread           libpthread - POSIX threads library                           REQUIRED        -               2.30            OK         -
 python-devel         Python devel - Python development files                      REQUIRED        2.2             2.7.17          OK         -
 cups-devel           CUPS devel- Common Unix Printing System development files    REQUIRED        -               2.2.12          OK         -
 python-dbus          Python DBus - Python bindings for DBus                       REQUIRED        0.80.0          1.2.12          OK         -
 cups-ddk             CUPS DDK - CUPS driver development kit                       OPTIONAL        -               -               OK         -
 reportlab            Reportlab - PDF library for Python                           OPTIONAL        2.0             3.5.23          OK         -
 pyqt4                PyQt 4- Qt interface for Python (for Qt version 4.x)         REQUIRED        4.0             4.12.1          OK         -
 libusb               libusb - USB library                                         REQUIRED        -               1.0             OK         -
 cups-image           CUPS image - CUPS image development files                    REQUIRED        -               2.2.12          OK         -
 python2X             Python 2.2 or greater - Python programming language          REQUIRED        2.2             2.7.17          OK         -
 python-notify        Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               OK         -
 libjpeg              libjpeg - JPEG library                                       REQUIRED        -               -               OK         -
 sane                 SANE - Scanning library                                      REQUIRED        -               -               OK         -

----------------------
| Scan Configuration |
----------------------

 scanext              Scan-SANE-Extension                                          REQUIRED        -               3.20.3          OK         -
 hpaio                HPLIP-SANE-Backend                                           REQUIRED        -               3.20.3          OK         'hpaio found in /etc/sane.d/dll.conf'

-------------------------
| External Dependencies |
-------------------------

 gs                   GhostScript - PostScript and PDF language interpreter and previewer REQUIRED        7.05            9.27            OK         -
 scanimage            scanimage - Shell scanning program                           OPTIONAL        1.0             1.0.27          OK         -
 cups                 CUPS - Common Unix Printing System                           REQUIRED        1.1             2.2.12          OK         'CUPS Scheduler is running'
 network              network -wget                                                OPTIONAL        -               1.20.3          OK         -
 policykit            PolicyKit - Administrative policy framework                  OPTIONAL        -               0.105           OK         -
 xsane                xsane - Graphical scanner frontend for SANE                  OPTIONAL        0.9             0.999           OK         -
 dbus                 DBus - Message bus system                                    REQUIRED        -               1.12.14         OK         -
 avahi-utils          avahi-utils                                                  OPTIONAL        -               0.7             OK         -

---------------------
| Python Extentions |
---------------------

 hpmudext             IO-Extension                                                 REQUIRED        -               3.20.3          OK         -
 cupsext              CUPS-Extension                                               REQUIRED        -               3.20.3          OK         -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

device `hpaio:/usb/Deskjet_2540_series?serial=CN48B4FBHV0604' is a Hewlett-Packard Deskjet_2540_series all-in-one


--------------------------
| DISCOVERED USB DEVICES |
--------------------------

  Device URI                        Model                 
  --------------------------------  ----------------------
  hp:/usb/Deskjet_2540_series?seri  HP Deskjet 2540 series
  al=CN48B4FBHV0604                                       

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 
Deskjet-2540-series
-------------------
Type: Printer
Device URI: hp:/usb/Deskjet_2540_series?serial=CN48B4FBHV0604
PPD: /etc/cups/ppd/Deskjet-2540-series.ppd
PPD Description: HP Deskjet 2540 Series, hpcups 3.19.6
Printer status: la stampante Deskjet-2540-series è inattiva.  è stata abilitata da mer 15 apr 2020, 18:38:35
Communication status: Good

Deskjet_2540
------------
Type: Printer
Device URI: hp:/usb/Deskjet_2540_series?serial=CN48B4FBHV0604
PPD: /etc/cups/ppd/Deskjet_2540.ppd
PPD Description: HP Deskjet 2540 Series, hpcups 3.19.6
Printer status: la stampante Deskjet_2540 è inattiva.  è stata abilitata da mar 23 apr 2019, 14:55:05
Communication status: Good


--------------
| PERMISSION |
--------------

USB             Deskjet-2540-series            Required        -        -        OK       Node:'/dev/bus/usb/001/008' Perm:'  root  lp rw- rw- rw- rw- r--'
 

Checking for Configured Queues....
 
warning: 2 queues of same device Deskjet-2540-series is configured.
Remove unwanted queues.
 

Checking for HP Properitery Plugin's....
No plug-in printers are configured.
 
Diagnose completed...
In parole povere sembra tutto ok.

Roberto Pontecorvi
Rampante Reduce
Rampante Reduce
Messaggi: 5231
Iscrizione: mercoledì 20 maggio 2009, 22:48
Distribuzione: 18.4 mate - 20.4 mate
Sesso: Maschile
Località: Versilia

Re: Stampa PDF non centrata in A5

Messaggio da Roberto Pontecorvi » lunedì 22 giugno 2020, 14:56

Tu dici?
Plugins are not installed. Could not access file: File o directory non esistente
mancano i pugins per la stampante. Sempre da terminale dai il comando:

Codice: Seleziona tutto

hp-plugin -i
e segui le istruzioni.

Innerina
Prode Principiante
Messaggi: 133
Iscrizione: domenica 6 gennaio 2008, 17:52
Desktop: Mate (Cinnamon)
Distribuzione: Ubuntu Mate 19.10 - amd64
Sesso: Femminile

Re: Stampa PDF non centrata in A5

Messaggio da Innerina » lunedì 22 giugno 2020, 22:12

Mi dà questo output... Mi conviene aggiornare il sistema operativo e di conseguenza anche l'HPLIP con annesso plugin della stessa versione.
Se cancello le cartelle delle vecchie versioni Hplip, non succede niente, vero?
Cmq cos'altro va installato visto che tira in ballo Python?

Codice: Seleziona tutto

HP Linux Imaging and Printing System (ver. 3.20.3)
Plugin Download and Install Utility ver. 2.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Checking for network connection...
Downloading plug-in from: 
Receiving digital keys: /usr/bin/gpg --homedir /home/innerina/.hplip/.gnupg --no-permission-warning --keyserver pgp.mit.edu --recv-keys 0x4ABA2F66DBD5A95894910E0673D770CDA59047B9
Creating directory plugin_tmp
Verifying archive integrity... All good.
Uncompressing HPLIP 3.20.3 Plugin Self Extracting Archive.Extraction failed.
Terminated
error: Python gobject/dbus may be not installed
\
gzip: stdout: Broken pipe
error: Plug-in install failed.

Done.

Roberto Pontecorvi
Rampante Reduce
Rampante Reduce
Messaggi: 5231
Iscrizione: mercoledì 20 maggio 2009, 22:48
Distribuzione: 18.4 mate - 20.4 mate
Sesso: Maschile
Località: Versilia

Re: Stampa PDF non centrata in A5

Messaggio da Roberto Pontecorvi » martedì 23 giugno 2020, 11:04

Qui puoi trovare i plugin 3.20.3. Per l'installazione rifai il comando di prima, quando devi scegliere da dove caricare i plugins indichi da file e dai le indicazioni dove si trova il file -> https://www.openprinting.org/download/p ... P/plugins/

Innerina
Prode Principiante
Messaggi: 133
Iscrizione: domenica 6 gennaio 2008, 17:52
Desktop: Mate (Cinnamon)
Distribuzione: Ubuntu Mate 19.10 - amd64
Sesso: Femminile

Re: Stampa PDF non centrata in A5

Messaggio da Innerina » giovedì 25 giugno 2020, 2:21

Pessima idea aggiornare alla 20.04, al momento la distro non supporta ancora gli installer perché mancano ancora i supporti al Pyqt5 e Pyqt4... non trova i pacchetti richiesti -.-
Quanto ci vorrà prima che esca una release col fix in questione?! Non è possibile che si abbiano sempre questi problemi col Python, che poi non tutti sanno installare e configurare! Poi fanno casino con le loro versioni appunto. -.-
Ubuntu è supportato fino alla 19.10 per ora. E mi sa che ho installato una versione inutile del Python perché ho sia 2.7 che 3.8, quindi non so se eliminare i pacchetti inerenti della più vecchia... Per quello che ho capito, dei pacchetti richiesti chiama altre versioni come se fossero dei sinonimi che ho già installate, quindi dovrei teoricamente essere a posto.
Ho guardato tutti i possibili workaround ma non ci capisco na mazza... fatto sta che installando anche le gui di hplip non partono nemmeno... eh certo, se il python sottostante non funziona...
Se magari creassero una installazione alternativa tipo gtk o deb sarebbe tutto più semplice!

Allo stato attuale la stampante sembra installata ma ovviamente con la gui di sistema ci faccio ben poco, ho le cartelle sia della 3.20.3 che della 3.20.6 che cmq non dovrebbero confliggere perché in passato ne ho avute ben tre di cui era in uso l'ultima 3.20.3. Ho letto che della 3.20.5 non si porta annessi i plugin, la 3 mi sembra di aver capito che non viene più supportata e la 6 appunto ha problemi di dipendenze mancanti che non trova. Che faccio?! Dato che cmq c'é gente che è riuscita ad installarla e farla funzionare con qualche smanettamento... :muro:

Codice: Seleziona tutto

MISSING DEPENDENCIES
--------------------
Following dependencies are not installed. HPLIP will not work if all REQUIRED dependencies are not installed and some of the HPLIP features will not work if OPTIONAL dependencies are not installed.
Package-Name         Component            Required/Optional   
pyqt5-dbus           gui_qt5              OPTIONAL            
reportlab            fax                  OPTIONAL            
pyqt5                gui_qt5              REQUIRED            
python-notify        gui_qt5              OPTIONAL          

Innerina
Prode Principiante
Messaggi: 133
Iscrizione: domenica 6 gennaio 2008, 17:52
Desktop: Mate (Cinnamon)
Distribuzione: Ubuntu Mate 19.10 - amd64
Sesso: Femminile

Re: Stampa PDF non centrata in A5

Messaggio da Innerina » giovedì 25 giugno 2020, 6:22

Sembra che ho risolto smanettando un pò tra disinstallazioni e reinstallazioni dei pacchetti hplip da repository, dopo aver installato manualmente le ultime 3 versioni (perché ovviamente quelle automatiche non terminano a causa della mancanza dei suddetti pacchetti!) e sembra che quella vista dalla stampante funzionante sia proprio la cara vecchia 3.20.3... Anche i plugin omonimi sono andati a buon fine ma sembrano non esserci cambiamenti di sorta, ho dato un'occhiata alla cartella e c'é poca roba dato che supportano poche stampanti, quindi chiedo: cosa dovrebbe apparire? È tipo programmino come gli altri della suite o sono comandi integrati nei vari programmi nel pannello di stampa?

Devo ancora provare se effettivamente stampa correttamente tutto ma se è come penso non è cambiato nulla rispetto alla situazione iniziale, anche perché dalla pagina ufficiale risulta terminato il supporto alla mia stampante, nel senso che è pienamente funzionante: Full (End of support).

Esiste quindi un lettore pdf che fa stampare esattamente come vedi a schermo, nel senso che riesce a far rispettare la dicitura flaggata di stampare centrato a prescindere dal formato del foglio?

Roberto Pontecorvi
Rampante Reduce
Rampante Reduce
Messaggi: 5231
Iscrizione: mercoledì 20 maggio 2009, 22:48
Distribuzione: 18.4 mate - 20.4 mate
Sesso: Maschile
Località: Versilia

Re: Stampa PDF non centrata in A5

Messaggio da Roberto Pontecorvi » giovedì 25 giugno 2020, 19:37

Per la tua stampante ci sono sempre i vecchi hplip -> https://sourceforge.net/projects/hplip/files/hplip/.
dato un'occhiata alla cartella e c'é poca roba dato che supportano poche stampanti, quindi chiedo: cosa dovrebbe apparire? È tipo programmino come gli altri della suite o sono comandi integrati nei vari programmi nel pannello di stampa?
puoi essere più chiara? Non ho capito cosa cerchi. Come programma alternativo, secondo me, c'è -> Master PDF Editor 5. Se sei arrabbiata calmati, a tutto c'è una soluzione e se non c'è che ti arrabbi a fare.... Secondo il mio giudizio quando esce una nuova versione c'è sempre qualcosa che non và, è la legge dell'informatica. Come vedi dalla mia firma bisogna sempre tenere la vecchia funzionante, installare la nuova e cominciare a sudare fino a che il SO funziona secondo le nostre esigenze. Quando si raggiunge questo manteniamo la vecchia fino a che non ci serve spazio sul hdd

Innerina
Prode Principiante
Messaggi: 133
Iscrizione: domenica 6 gennaio 2008, 17:52
Desktop: Mate (Cinnamon)
Distribuzione: Ubuntu Mate 19.10 - amd64
Sesso: Femminile

Re: Stampa PDF non centrata in A5

Messaggio da Innerina » domenica 28 giugno 2020, 22:17

Roberto Pontecorvi ha scritto:
giovedì 25 giugno 2020, 19:37
Per la tua stampante ci sono sempre i vecchi hplip -> https://sourceforge.net/projects/hplip/files/hplip/.
dato un'occhiata alla cartella e c'é poca roba dato che supportano poche stampanti, quindi chiedo: cosa dovrebbe apparire? È tipo programmino come gli altri della suite o sono comandi integrati nei vari programmi nel pannello di stampa?
puoi essere più chiara? Non ho capito cosa cerchi. Come programma alternativo, secondo me, c'è -> Master PDF Editor 5.
In altre parole, come dovrebbero apparire i plugin? É un programmino come quelli della gestione stampante e del fax HP? Oppure sono funzionalità che compaiono dai menù interni della stampante o dei programmi? Questo volevo capire... Perché siccome al momento non ho trovato nulla, devo capire dove devo guardare che compaiono eventualmente...
Per il momento ho risolto con la 3.20.3, praticamente la versione di partenza. Non so bene neppure come abbia fatto, fatto sta che viene riconosciuta e stampa regolarmente, anche lo scanner funziona! Quindi in generale mi rode un pò che i pdf vengano stampati sfasati anziché automaticamente centrati come nel formato Word e simili, specie su A5. Non ho ancora verificato se è cambiato qualcosa con la nuova versione del SO, ma essendo quella la versione HP non credo... Non so se magari usando Master PDF che mi hai suggerito, risolvo... non ho capito se è un problema di interpretazione della stampante come quasi sicuramente penso, o se dipende dal programma da cui li stampo che le manda i comandi di formato e codifica sbagliati... Cmq aspetterò un pò che esca la nuova versione corretta per il 20.04, anche se essendo terminato il supporto dubito cambi qualcosa.

Roberto Pontecorvi
Rampante Reduce
Rampante Reduce
Messaggi: 5231
Iscrizione: mercoledì 20 maggio 2009, 22:48
Distribuzione: 18.4 mate - 20.4 mate
Sesso: Maschile
Località: Versilia

Re: Stampa PDF non centrata in A5

Messaggio da Roberto Pontecorvi » lunedì 29 giugno 2020, 15:28

Per i plugins basta scaricare quelli della versione hplip. Una volta scaricati avvii da terminale -> hp-plugin;
- nella finestra che ti appare seleziona la dicitura -> Seletct en install an exiting local copy of the plug-in file;
- poi premi su - > icona in fondo al campo vuoto quella con il disegno di una cartella;
- da qui ti compare un'altra finestra dove puoi scegliere il percorso dove si trova il file che hai scaricato:
- evidenzi il file;
- poi premi il tasto -> Apri .
Non so se ti conviene installare la 20.4 è ancora con qualche problema. Magari al momento ti posso consigliare al 18.4 che, se non sbaglio, è valida fino al 2023. Non penso che il problema sia dei pacchetti per la stampante o del SO, ma più semplicemente dalla configurazione del programma che usi per stampare i pdf. Il programma che ti ho suggerito serve anche a modificare i file pdf come un qualsiasi Editor di testo. Se vuoi usare un programma di "Desktop publishing", vedi su Wikipedia il significato, ti consiglio "Scribus" lo trovi nei repository di ubuntu, vecchia versione. Invece se vuoi ultima versione con relativi aggiornamenti fammelo sapere.

Innerina
Prode Principiante
Messaggi: 133
Iscrizione: domenica 6 gennaio 2008, 17:52
Desktop: Mate (Cinnamon)
Distribuzione: Ubuntu Mate 19.10 - amd64
Sesso: Femminile

Re: Stampa PDF non centrata in A5

Messaggio da Innerina » martedì 30 giugno 2020, 2:17

Quella procedura di hp-plugin l'ho già fatta, è regolarmente installata, semplicemente non ho capito come dovrebbero apparire questi benedetti plugin... sono funzionalità interne al menù della stampante o sono un programmino a parte avviabile come ad esempio il manager della stampante?
La 20.04 ora gira perfettamente, risolti tutti i problemi di post installazione, anche perché ho fatto installazione ex novo sulla partizione dedicata! =)
Per il resto ti ringrazio per tutti i consigli, Scribus lo provai e niente, forse un pochino complesso per i miei gusti.
Master PDF Edition non ha ancora l'installer per la 20.04, a quanto pare... dovrò aspettare...

Roberto Pontecorvi
Rampante Reduce
Rampante Reduce
Messaggi: 5231
Iscrizione: mercoledì 20 maggio 2009, 22:48
Distribuzione: 18.4 mate - 20.4 mate
Sesso: Maschile
Località: Versilia

Re: Stampa PDF non centrata in A5

Messaggio da Roberto Pontecorvi » martedì 30 giugno 2020, 7:57

Scusa forsse avevo capito male io la tua domanda sui plugin. Questi non sono altro, per cosi dire, che altri drive che agiugono funzioni al programma hplip. Son sono visibili o gestibili vengono gestiti da hplip.

Scrivi risposta

Ritorna a “Driver e periferiche”

Chi c’è in linea

Visualizzano questa sezione: barbamoto e 21 ospiti