brother ql-500 su Ubuntu 21.04

Riconoscimento, installazione e configurazione delle periferiche.
Scrivi risposta
Dig
Prode Principiante
Messaggi: 246
Iscrizione: domenica 2 dicembre 2007, 14:58

brother ql-500 su Ubuntu 21.04

Messaggio da Dig »

Salve,
ho una stampante etichettatrice Brother Ql-500 la uso da diversi anni e in questo momento funziona correttamente sul mio portatile con installato ubuntu mate:

Codice: Seleziona tutto

alvin@alvin-K50IN:~$ lsb_release -a 
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 20.04.2 LTS
Release:	20.04
Codename:	focal
alvin@alvin-K50IN:~$ dpkg -l | grep Brother
ii  brscan-skey                           0.2.4-1                             amd64        Brother Linux scanner S-KEY tool
ii  brscan4                               0.4.8-1                             amd64        Brother Scanner Driver
ii  mfcj5910dwcupswrapper:i386            3.0.0-1                             i386         Brother CUPS Inkjet Printer Definitions
ii  mfcj5910dwlpr:i386                    3.0.0-1                             i386         Brother lpr Inkjet Printer Definitions
ii  printer-driver-brlaser                6-1build1                           amd64        printer driver for (some) Brother laser printers
ii  printer-driver-ptouch                 1.4.2-3                             amd64        printer driver Brother P-touch label printers
ii  ql550lpr:i386                         1.0.1                               i386         Brother lpr Ptouch Printer Definitions
alvin@alvin-K50IN:~$ 
Nel mio ufficio ho installato Ubuntu mate 21.04 e non riesco a farla funzionare:

Codice: Seleziona tutto

alvin@alvin-EB1007:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 21.04
Release:	21.04
Codename:	hirsute
alvin@alvin-EB1007:~$ dpkg -l | grep Brother
ii  printer-driver-brlaser                   6-1build1                                                            amd64        printer driver for (some) Brother laser printers
ii  printer-driver-ptouch                    1.5.1-2                                                              amd64        printer driver Brother P-touch label printers
ii  ql550cupswrapper:i386                    1.0.1                                                                i386         Brother CUPS PTouch Printer Definitions
ii  ql550lpr:i386                            1.0.1                                                                i386         Brother lpr Ptouch Printer Definitions
alvin@alvin-EB1007:~$ lsusb
Bus 001 Device 006: ID 03f0:be2a HP, Inc HP LaserJet M14-M17
Bus 001 Device 004: ID 05e3:0727 Genesys Logic, Inc. microSD Reader/Writer
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 10c4:8105 Silicon Labs USB OPTICAL MOUSE
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 003: ID 04f3:0103 Elan Microelectronics Corp. ActiveJet K-2024 Multimedia Keyboard
Bus 003 Device 006: ID 04f9:2015 Brother Industries, Ltd QL-500 label printer
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
alvin@alvin-EB1007:~$ 

Ovviamente ho scaricato i pacchetti deb dal sito ufficiale brother e ho provato a mettere le stesse impostazioni.
Quando provo a fare una stampa la Brother lampeggia un errore.
Cosa mi sfugge? Posso fare qualche altro controllo?
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 22650
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: Xubuntu
Distribuzione: Ubuntu 20.04 LTS x86_64
Località: Pisa

Re: brother ql-500 su Ubuntu 21.04

Messaggio da magozurlinux »

Salve,

che errore lampeggia?

con la stampante Brother QL-500 accesa, da terminale postami questi comandi:

Codice: Seleziona tutto

dmesg | grep usb

Codice: Seleziona tutto

cat /var/log/cups/error_log
Xubuntu 20.04 LTS amd64 :ciao:
Dig
Prode Principiante
Messaggi: 246
Iscrizione: domenica 2 dicembre 2007, 14:58

Re: brother ql-500 su Ubuntu 21.04

Messaggio da Dig »

Codice: Seleziona tutto

root@alvin-EB1007:/home/alvin# dmesg | grep usb
[    0.415035] usbcore: registered new interface driver usbfs
[    0.415035] usbcore: registered new interface driver hub
[    0.415035] usbcore: registered new device driver usb
[    1.994423] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 5.11
[    1.994435] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.994442] usb usb1: Product: EHCI Host Controller
[    1.994447] usb usb1: Manufacturer: Linux 5.11.0-16-generic ehci_hcd
[    1.994453] usb usb1: SerialNumber: 0000:00:1d.7
[    1.996534] usb usb2: New USB device found, idVendor=1d6b, idProduct=0001, bcdDevice= 5.11
[    1.996545] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.996552] usb usb2: Product: UHCI Host Controller
[    1.996558] usb usb2: Manufacturer: Linux 5.11.0-16-generic uhci_hcd
[    1.996563] usb usb2: SerialNumber: 0000:00:1d.0
[    1.998131] usb usb3: New USB device found, idVendor=1d6b, idProduct=0001, bcdDevice= 5.11
[    1.998144] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.998182] usb usb3: Product: UHCI Host Controller
[    1.998192] usb usb3: Manufacturer: Linux 5.11.0-16-generic uhci_hcd
[    1.998201] usb usb3: SerialNumber: 0000:00:1d.1
[    1.999688] usb usb4: New USB device found, idVendor=1d6b, idProduct=0001, bcdDevice= 5.11
[    1.999699] usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.999706] usb usb4: Product: UHCI Host Controller
[    1.999711] usb usb4: Manufacturer: Linux 5.11.0-16-generic uhci_hcd
[    1.999716] usb usb4: SerialNumber: 0000:00:1d.2
[    2.001246] usb usb5: New USB device found, idVendor=1d6b, idProduct=0001, bcdDevice= 5.11
[    2.001258] usb usb5: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    2.001265] usb usb5: Product: UHCI Host Controller
[    2.001270] usb usb5: Manufacturer: Linux 5.11.0-16-generic uhci_hcd
[    2.001275] usb usb5: SerialNumber: 0000:00:1d.3
[    2.534212] usb 3-1: new full-speed USB device number 2 using uhci_hcd
[    2.740258] usb 3-1: New USB device found, idVendor=04f9, idProduct=2015, bcdDevice= 1.00
[    2.740278] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    2.740288] usb 3-1: Product: QL-500
[    2.740295] usb 3-1: Manufacturer: Brother
[    2.740303] usb 3-1: SerialNumber: C6Z489960
[    3.602262] usb 3-2: new low-speed USB device number 3 using uhci_hcd
[    3.780208] usb 3-2: New USB device found, idVendor=04f3, idProduct=0103, bcdDevice= 1.07
[    3.780225] usb 3-2: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    3.850882] usbcore: registered new interface driver usbhid
[    3.850896] usbhid: USB HID core driver
[    3.868430] input: HID 04f3:0103 as /devices/pci0000:00/0000:00:1d.1/usb3/3-2/3-2:1.0/0003:04F3:0103.0001/input/input5
[    3.869299] hid-generic 0003:04F3:0103.0001: input,hidraw0: USB HID v1.11 Keyboard [HID 04f3:0103] on usb-0000:00:1d.1-2/input0
[    3.872566] input: HID 04f3:0103 Consumer Control as /devices/pci0000:00/0000:00:1d.1/usb3/3-2/3-2:1.1/0003:04F3:0103.0002/input/input6
[    3.874743] input: HID 04f3:0103 System Control as /devices/pci0000:00/0000:00:1d.1/usb3/3-2/3-2:1.1/0003:04F3:0103.0002/input/input7
[    3.875236] hid-generic 0003:04F3:0103.0002: input,hidraw1: USB HID v1.11 Device [HID 04f3:0103] on usb-0000:00:1d.1-2/input1
[    3.990209] usb 1-6: new high-speed USB device number 4 using ehci-pci
[    4.154862] usb 1-6: New USB device found, idVendor=05e3, idProduct=0727, bcdDevice= 2.06
[    4.154879] usb 1-6: New USB device strings: Mfr=3, Product=4, SerialNumber=2
[    4.154886] usb 1-6: Product: USB Storage
[    4.154892] usb 1-6: Manufacturer: Generic
[    4.154897] usb 1-6: SerialNumber: 000000000206
[    4.626184] usb 5-1: new low-speed USB device number 2 using uhci_hcd
[    4.823211] usb 5-1: New USB device found, idVendor=10c4, idProduct=8105, bcdDevice= 0.00
[    4.823224] usb 5-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    4.823231] usb 5-1: Product: USB OPTICAL MOUSE
[    4.823236] usb 5-1: Manufacturer: YSPRINGTECH
[    4.841400] input: YSPRINGTECH USB OPTICAL MOUSE as /devices/pci0000:00/0000:00:1d.3/usb5/5-1/5-1:1.0/0003:10C4:8105.0003/input/input8
[    4.841985] hid-generic 0003:10C4:8105.0003: input,hidraw2: USB HID v1.11 Mouse [YSPRINGTECH USB OPTICAL MOUSE] on usb-0000:00:1d.3-1/input0
[    5.042208] usb 1-8: new high-speed USB device number 6 using ehci-pci
[    5.199070] usb 1-8: New USB device found, idVendor=03f0, idProduct=be2a, bcdDevice= 1.00
[    5.199084] usb 1-8: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    5.199091] usb 1-8: Product: HP LaserJet M14-M17
[    5.199097] usb 1-8: Manufacturer: HP
[    5.199102] usb 1-8: SerialNumber: XXXXXXXXXX
[    5.664446] usb-storage 1-6:1.0: USB Mass Storage device detected
[    5.665057] scsi host4: usb-storage 1-6:1.0
[    5.665596] usbcore: registered new interface driver usb-storage
[    5.674923] usbcore: registered new interface driver uas
[   23.626639] usblp 3-1:1.0: usblp0: USB Bidirectional printer dev 2 if 0 alt 0 proto 2 vid 0x04F9 pid 0x2015
[   23.638442] usblp 1-8:1.0: usblp1: USB Bidirectional printer dev 6 if 0 alt 0 proto 2 vid 0x03F0 pid 0xBE2A
[   23.638644] usbcore: registered new interface driver usblp
[   43.470451] usblp1: removed
[   43.474609] usblp 1-8:1.0: usblp1: USB Bidirectional printer dev 6 if 0 alt 0 proto 2 vid 0x03F0 pid 0xBE2A
[   43.478536] usblp0: removed
[   43.538898] usblp 3-1:1.0: usblp0: USB Bidirectional printer dev 2 if 0 alt 0 proto 2 vid 0x04F9 pid 0x2015
[   44.330335] usblp1: removed
[ 2190.560081] usblp0: removed
[ 2194.120922] usblp 3-1:1.0: usblp0: USB Bidirectional printer dev 2 if 0 alt 0 proto 2 vid 0x04F9 pid 0x2015
root@alvin-EB1007:/home/alvin# cat /var/log/cups/error_log
W [05/May/2021:09:08:05 +0200] [Job 48] Grayscale/monochrome printing requested for this job but Poppler is not able to convert to grayscale/monochrome PostScript.
W [05/May/2021:09:08:05 +0200] [Job 48] Use \"pdftops-renderer\" option (see cups-filters README file) to use Ghostscript or MuPDF for the PDF -> PostScript conversion.
root@alvin-EB1007:/home/alvin# 
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 22650
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: Xubuntu
Distribuzione: Ubuntu 20.04 LTS x86_64
Località: Pisa

Re: brother ql-500 su Ubuntu 21.04

Messaggio da magozurlinux »

Da terminale postami questo comando:

Codice: Seleziona tutto

dpkg -l | grep cups

Codice: Seleziona tutto

dpkg -l | grep lib

Codice: Seleziona tutto

dpkg -l | grep poppler

Codice: Seleziona tutto

dpkg -l | grep ghostscript 

Codice: Seleziona tutto

dpkg -l | grep postscript
Xubuntu 20.04 LTS amd64 :ciao:
Dig
Prode Principiante
Messaggi: 246
Iscrizione: domenica 2 dicembre 2007, 14:58

Re: brother ql-500 su Ubuntu 21.04

Messaggio da Dig »

grep cups

Codice: Seleziona tutto

lvin@alvin-EB1007:~$ dpkg -l | grep cups
ii  bluez-cups                               5.56-0ubuntu4                                                        amd64        Bluetooth printer driver for CUPS
ii  cups                                     2.3.3op2-3ubuntu3                                                    amd64        Common UNIX Printing System(tm) - PPD/driver support, web interface
ii  cups-browsed                             1.28.8-0ubuntu1                                                      amd64        OpenPrinting CUPS Filters - cups-browsed
ii  cups-bsd                                 2.3.3op2-3ubuntu3                                                    amd64        Common UNIX Printing System(tm) - BSD commands
ii  cups-client                              2.3.3op2-3ubuntu3                                                    amd64        Common UNIX Printing System(tm) - client programs (SysV)
ii  cups-common                              2.3.3op2-3ubuntu3                                                    all          Common UNIX Printing System(tm) - common files
ii  cups-core-drivers                        2.3.3op2-3ubuntu3                                                    amd64        Common UNIX Printing System(tm) - driverless printing
ii  cups-daemon                              2.3.3op2-3ubuntu3                                                    amd64        Common UNIX Printing System(tm) - daemon
ii  cups-filters                             1.28.8-0ubuntu1                                                      amd64        OpenPrinting CUPS Filters - Main Package
ii  cups-filters-core-drivers                1.28.8-0ubuntu1                                                      amd64        OpenPrinting CUPS Filters - Driverless printing
ii  cups-ipp-utils                           2.3.3op2-3ubuntu3                                                    amd64        Common UNIX Printing System(tm) - IPP developer/admin utilities
ii  cups-pk-helper                           0.2.6-1ubuntu3                                                       amd64        PolicyKit helper to configure cups with fine-grained privileges
ii  cups-ppdc                                2.3.3op2-3ubuntu3                                                    amd64        Common UNIX Printing System(tm) - PPD manipulation utilities
ii  cups-server-common                       2.3.3op2-3ubuntu3                                                    all          Common UNIX Printing System(tm) - server common files
ii  libcups2:amd64                           2.3.3op2-3ubuntu3                                                    amd64        Common UNIX Printing System(tm) - Core library
ii  libcupsfilters1:amd64                    1.28.8-0ubuntu1                                                      amd64        OpenPrinting CUPS Filters - Shared library
ii  libcupsimage2:amd64                      2.3.3op2-3ubuntu3                                                    amd64        Common UNIX Printing System(tm) - Raster image library
ii  printer-driver-hpcups                    3.21.2+dfsg1-2                                                       amd64        HP Linux Printing and Imaging - CUPS Raster driver (hpcups)
ii  python3-cups:amd64                       2.0.1-4build1                                                        amd64        Python3 bindings for CUPS
ii  python3-cupshelpers                      1.5.15-0ubuntu1                                                      all          Python utility modules around the CUPS printing system
ii  ql550cupswrapper:i386                    1.0.1                                                                i386         Brother CUPS PTouch Printer Definitions
alvin@alvin-EB1007:~$ 
dpkg -l | grep lib

Codice: Seleziona tutto

ii  libyelp0:amd64                           40.stable-1                                                          amd64        Library for the GNOME help browser
ii  libytnef0:amd64                          1.9.3-3                                                              amd64        improved decoder for application/ms-tnef attachments
ii  libzen0v5:amd64                          0.4.38-1                                                             amd64        ZenLib C++ utility library -- runtime
ii  libzip4:amd64                            1.7.3-1ubuntu1                                                       amd64        library for reading, creating, and modifying zip archives (runtime)
ii  libzmq5:amd64                            4.3.4-1                                                              amd64        lightweight messaging kernel (shared library)
ii  libzstd1:amd64                           1.4.8+dfsg-2build2                                                   amd64        fast lossless compression algorithm
ii  libzvbi-common                           0.2.35-18                                                            all          Vertical Blanking Interval decoder (VBI) - common files
ii  libzvbi0:amd64                           0.2.35-18                                                            amd64        Vertical Blanking Interval decoder (VBI) - runtime files
ii  linux-libc-dev:amd64                     5.11.0-16.17                                                         amd64        Linux Kernel Headers for development
ii  ltrace                                   0.7.3-6.1ubuntu2                                                     amd64        Tracks runtime library calls in dynamically linked programs
ii  lz4                                      1.9.3-1build1                                                        amd64        Fast LZ compression algorithm library - tool
ii  ocl-icd-libopencl1:amd64                 2.2.14-2                                                             amd64        Generic OpenCL ICD Loader
ii  pkg-config                               0.29.2-1ubuntu1                                                      amd64        manage compile and link flags for libraries
ii  poppler-data                             0.4.10-1                                                             all          encoding data for the poppler PDF rendering library
ii  python-apt-common                        2.1.7ubuntu2                                                         all          Python interface to libapt-pkg (locales)
ii  python3-apport                           2.20.11-0ubuntu65                                                    all          Python 3 library for Apport crash report handling
ii  python3-apt                              2.1.7ubuntu2                                                         amd64        Python 3 interface to libapt-pkg
ii  python3-bcrypt                           3.1.7-4                                                              amd64        password hashing library for Python 3
ii  python3-blinker                          1.4+dfsg1-0.3ubuntu2                                                 all          fast, simple object-to-object and broadcast signaling library
ii  python3-cairo:amd64                      1.16.2-4build2                                                       amd64        Python3 bindings for the Cairo vector graphics library
ii  python3-cryptography                     3.3.2-1                                                              amd64        Python library exposing cryptographic recipes and primitives (Python 3)
ii  python3-gi                               3.38.0-4                                                             amd64        Python 3 bindings for gobject-introspection libraries
ii  python3-gi-cairo                         3.38.0-4                                                             amd64        Python 3 Cairo bindings for the GObject library
ii  python3-gpg                              1.14.0-1ubuntu3                                                      amd64        Python interface to the GPGME GnuPG encryption library (Python 3)
ii  python3-httplib2                         0.18.1-3                                                             all          comprehensive HTTP client library written for Python3
ii  python3-launchpadlib                     1.10.13-1                                                            all          Launchpad web services client library (Python 3)
ii  python3-lazr.uri                         1.0.5-1                                                              all          library for parsing, manipulating, and generating URIs
ii  python3-lib2to3                          3.9.4-0ubuntu1                                                       all          Interactive high-level object-oriented language (lib2to3)
ii  python3-lockfile                         1:0.12.2-2.2                                                         all          file locking library for Python — Python 3 library
ii  python3-louis                            3.16.0-1                                                             all          Python bindings for liblouis
ii  python3-markupsafe                       1.1.1-1build2                                                        amd64        HTML/XHTML/XML string library for Python 3
ii  python3-mediainfodll                     20.09+dfsg-1                                                         all          library for reading metadata from media files -- shared library
ii  python3-nacl                             1.4.0-1build1                                                        amd64        Python bindings to libsodium (Python 3)
ii  python3-oauthlib                         3.1.0-2                                                              all          generic, spec-compliant implementation of OAuth for Python3
ii  python3-pam                              0.4.2-13.4build1                                                     amd64        Python interface to the PAM library
ii  python3-problem-report                   2.20.11-0ubuntu65                                                    all          Python 3 library to handle problem reports
ii  python3-pymacaroons                      0.13.0-4                                                             all          Macaroon library for Python 3
ii  python3-reportlab                        3.5.66-1                                                             all          ReportLab library to create PDF documents using Python3
ii  python3-requests                         2.25.1+dfsg-2                                                        all          elegant and simple HTTP library for Python3, built for human beings
ii  python3-six                              1.15.0-2                                                             all          Python 2 and 3 compatibility library (Python 3 interface)
ii  python3-urllib3                          1.26.2-1ubuntu1                                                      all          HTTP library with thread-safe connection pooling for Python3
ii  python3-wadllib                          1.3.5-1                                                              all          Python 3 library for navigating WADL files
ii  python3-xdg                              0.27-2                                                               all          Python 3 library to access freedesktop.org standards
ii  python3-xkit                             0.5.0ubuntu4                                                         all          library for the manipulation of xorg.conf files (Python 3)
ii  python3-xlib                             0.29-1                                                               all          interface for Python 3 to the X11 protocol
ii  readline-common                          8.1-1                                                                all          GNU readline and history libraries, common files
ii  samba-libs:amd64                         2:4.13.3+dfsg-1ubuntu2.1                                             amd64        Samba core libraries
ii  sane-utils                               1.0.32-0ubuntu2                                                      amd64        API library for scanners -- utilities
ii  uno-libs-private                         1:7.1.2~rc2-0ubuntu2                                                 amd64        LibreOffice UNO runtime environment -- private libraries used by public ones
ii  uuid-runtime                             2.36.1-7ubuntu2                                                      amd64        runtime components for the Universally Unique ID library
ii  xserver-xorg-input-libinput              0.30.0-1ubuntu1                                                      amd64        X.Org X server -- libinput input driver
ii  zlib1g:amd64                             1:1.2.11.dfsg-2ubuntu6                                               amd64        compression library - runtime
alvin@alvin-EB1007:~$ 
grep poppler

Codice: Seleziona tutto

alvin@alvin-EB1007:~$ dpkg -l | grep poppler
ii  libpoppler-cpp0v5:amd64                  21.02.0-1                                                            amd64        PDF rendering library (CPP shared library)
ii  libpoppler-glib8:amd64                   21.02.0-1                                                            amd64        PDF rendering library (GLib-based shared library)
ii  libpoppler107:amd64                      21.02.0-1                                                            amd64        PDF rendering library
ii  poppler-data                             0.4.10-1                                                             all          encoding data for the poppler PDF rendering library
ii  poppler-utils                            21.02.0-1                                                            amd64        PDF utilities (based on Poppler)
alvin@alvin-EB1007:~$ 
grep ghostscript

Codice: Seleziona tutto

alvin@alvin-EB1007:~$ dpkg -l | grep ghostscript 
ii  ghostscript                              9.53.3~dfsg-7                                                        amd64        interpreter for the PostScript language and for PDF
ii  ghostscript-x                            9.53.3~dfsg-7                                                        amd64        interpreter for the PostScript language and for PDF - X11 support
alvin@alvin-EB1007:~$ 
grep postscript

Codice: Seleziona tutto

alvin@alvin-EB1007:~$ dpkg -l | grep postscript
ii  printer-driver-postscript-hp             3.21.2+dfsg1-2                                                       amd64        HP Printers PostScript Descriptions
alvin@alvin-EB1007:~$ 
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 22650
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: Xubuntu
Distribuzione: Ubuntu 20.04 LTS x86_64
Località: Pisa

Re: brother ql-500 su Ubuntu 21.04

Messaggio da magozurlinux »

Connesso ad Internet, da terminale dai questi comandi:

Codice: Seleziona tutto

sudo apt-get update -y

Codice: Seleziona tutto

sudo apt-get install -y foomatic-filters

Codice: Seleziona tutto

sudo service cups restart
prova la stampante.
Xubuntu 20.04 LTS amd64 :ciao:
Dig
Prode Principiante
Messaggi: 246
Iscrizione: domenica 2 dicembre 2007, 14:58

Re: brother ql-500 su Ubuntu 21.04

Messaggio da Dig »

Codice: Seleziona tutto

alvin@alvin-EB1007:~$ sudo apt-get update -y

[sudo] password di alvin: 
Scaricamento di:1 http://it.archive.ubuntu.com/ubuntu hirsute InRelease [269 kB]
Trovato:2 http://deb.anydesk.com all InRelease                                 
Scaricamento di:3 http://security.ubuntu.com/ubuntu hirsute-security InRelease [101 kB]
Scaricamento di:4 http://it.archive.ubuntu.com/ubuntu hirsute-updates InRelease [109 kB]
Trovato:5 http://it.archive.ubuntu.com/ubuntu hirsute-backports InRelease
Scaricamento di:6 http://it.archive.ubuntu.com/ubuntu hirsute-updates/main amd64 Packages [66,2 kB]
Scaricamento di:7 http://it.archive.ubuntu.com/ubuntu hirsute-updates/main i386 Packages [34,8 kB]
Scaricamento di:8 http://it.archive.ubuntu.com/ubuntu hirsute-updates/main Translation-en [19,1 kB]
Scaricamento di:9 http://it.archive.ubuntu.com/ubuntu hirsute-updates/main amd64 c-n-f Metadata [1.884 B]
Scaricamento di:10 http://it.archive.ubuntu.com/ubuntu hirsute-updates/universe amd64 Packages [174 kB]
Scaricamento di:11 http://it.archive.ubuntu.com/ubuntu hirsute-updates/universe i386 Packages [164 kB]
Scaricamento di:12 http://it.archive.ubuntu.com/ubuntu hirsute-updates/universe Translation-en [23,7 kB]
Scaricamento di:13 http://it.archive.ubuntu.com/ubuntu hirsute-updates/universe amd64 c-n-f Metadata [3.256 B]
Recuperati 966 kB in 6s (161 kB/s)                          
Lettura elenco dei pacchetti... Fatto
alvin@alvin-EB1007:~$ sudo apt-get install -y foomatic-filters
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze... Fatto
Lettura informazioni sullo stato... Fatto   
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  cups-browsed cups-core-drivers cups-daemon cups-filters-core-drivers cups-ipp-utils cups-server-common hplip-data libcupsimage2 libfontembed1 libgutenprint-common libgutenprint9 libhpmud0 libimagequant0
  liblouisutdml-bin liblouisutdml-data liblouisutdml9 libpoppler-cpp0v5 libqpdf28 libsane-hpaio printer-driver-postscript-hp python3-olefile python3-pil python3-renderpm python3-reportlab
  python3-reportlab-accel ssl-cert
Usare "sudo apt autoremove" per rimuoverli.
Pacchetti raccomandati:
  paps | cups | enscript | a2ps
I seguenti pacchetti saranno RIMOSSI:
  bluez-cups cups cups-filters hplip printer-driver-gutenprint printer-driver-hpcups printer-driver-splix
I seguenti pacchetti NUOVI saranno installati:
  foomatic-filters
0 aggiornati, 1 installati, 7 da rimuovere e 13 non aggiornati.
È necessario scaricare 89,7 kB di archivi.
Dopo quest'operazione, verranno liberati 5.493 kB di spazio su disco.
Scaricamento di:1 http://it.archive.ubuntu.com/ubuntu hirsute/universe amd64 foomatic-filters amd64 4.0.17-12 [89,7 kB]
Recuperati 89,7 kB in 0s (185 kB/s)   
Preconfigurazione dei pacchetti in corso
(Lettura del database... 279939 file e directory attualmente installati.)
Rimozione di bluez-cups (5.56-0ubuntu4)...
Rimozione di printer-driver-splix (2.0.0+svn315-7fakesync1build1)...
Rimozione di hplip (3.21.2+dfsg1-2)...
Rimozione di printer-driver-hpcups (3.21.2+dfsg1-2)...
Rimozione di printer-driver-gutenprint (5.3.3-4)...
Rimozione di cups (2.3.3op2-3ubuntu3)...
dpkg: cups-filters: problemi con le dipendenze, ma viene rimosso comunque:
 printer-driver-pxljr dipende da cups-filters (>= 1.0.42) | foomatic-filters (>= 4.0.0~bzr156); tuttavia:
  Il pacchetto cups-filters sta per essere rimosso.
  Il pacchetto foomatic-filters non è installato.
  Il pacchetto cups-filters che fornisce foomatic-filters sta per essere rimosso.
 printer-driver-m2300w dipende da cups-filters (>= 1.0.42) | foomatic-filters (>= 4.0.0~bzr156); tuttavia:
  Il pacchetto cups-filters sta per essere rimosso.
  Il pacchetto foomatic-filters non è installato.
  Il pacchetto cups-filters che fornisce foomatic-filters sta per essere rimosso.
 printer-driver-foo2zjs dipende da cups-filters | foomatic-filters; tuttavia:
  Il pacchetto cups-filters sta per essere rimosso.
  Il pacchetto foomatic-filters non è installato.
  Il pacchetto cups-filters che fornisce foomatic-filters sta per essere rimosso.
 printer-driver-pxljr dipende da cups-filters (>= 1.0.42) | foomatic-filters (>= 4.0.0~bzr156); tuttavia:
  Il pacchetto cups-filters sta per essere rimosso.
  Il pacchetto foomatic-filters non è installato.
  Il pacchetto cups-filters che fornisce foomatic-filters sta per essere rimosso.
 printer-driver-m2300w dipende da cups-filters (>= 1.0.42) | foomatic-filters (>= 4.0.0~bzr156); tuttavia:
  Il pacchetto cups-filters sta per essere rimosso.
  Il pacchetto foomatic-filters non è installato.
  Il pacchetto cups-filters che fornisce foomatic-filters sta per essere rimosso.
 printer-driver-foo2zjs dipende da cups-filters | foomatic-filters; tuttavia:
  Il pacchetto cups-filters sta per essere rimosso.
  Il pacchetto foomatic-filters non è installato.
  Il pacchetto cups-filters che fornisce foomatic-filters sta per essere rimosso.

Rimozione di cups-filters (1.28.8-0ubuntu1)...
Selezionato il pacchetto foomatic-filters non precedentemente selezionato.
(Lettura del database... 279649 file e directory attualmente installati.)
Preparativi per estrarre .../foomatic-filters_4.0.17-12_amd64.deb...
Estrazione di foomatic-filters (4.0.17-12)...
Configurazione di foomatic-filters (4.0.17-12)...
WARNING: tempfile is deprecated; consider using mktemp instead.

Creating config file /etc/foomatic/filter.conf with new version
Elaborazione dei trigger per dbus (1.12.20-1ubuntu3)...
Elaborazione dei trigger per man-db (2.9.4-2)...
alvin@alvin-EB1007:~$ sudo service cups restart
alvin@alvin-EB1007:~$ 

non va e non funziona nemmeno l'HP che prima funzionava.

cat /var/log/cups/error_log

Codice: Seleziona tutto

alvin@alvin-EB1007:~$ cat /var/log/cups/error_log
W [06/May/2021:12:40:13 +0200] Notifier for subscription 111 (dbus://) went away, retrying!
W [06/May/2021:12:40:13 +0200] Notifier for subscription 116 (dbus://) went away, retrying!
W [06/May/2021:15:50:56 +0200] CreateProfile failed: org.freedesktop.ColorManager.AlreadyExists:profile id \'Brother_HL_1210W_series_server_System_Product_Name-Gray..\' already exists
W [06/May/2021:15:50:56 +0200] CreateProfile failed: org.freedesktop.ColorManager.AlreadyExists:profile id \'Brother_HL_1210W_series_server_System_Product_Name-DeviceN..\' already exists
W [06/May/2021:15:50:57 +0200] CreateProfile failed: org.freedesktop.ColorManager.AlreadyExists:profile id \'MFCJ5910DW_server_System_Product_Name-Gray..\' already exists
W [06/May/2021:15:50:57 +0200] CreateProfile failed: org.freedesktop.ColorManager.AlreadyExists:profile id \'MFCJ5910DW_server_System_Product_Name-DeviceN..\' already exists
W [06/May/2021:15:50:58 +0200] CreateProfile failed: org.freedesktop.ColorManager.AlreadyExists:profile id \'Brother_MFC_J5910DW-Gray..\' already exists
W [06/May/2021:15:50:58 +0200] CreateProfile failed: org.freedesktop.ColorManager.AlreadyExists:profile id \'Brother_MFC_J5910DW-DeviceN..\' already exists
E [06/May/2021:19:45:16 +0200] HP-HP-LaserJet-M14-M17: Il file \"/usr/lib/cups/filter/hpcups\" non è disponibile: No such file or directory
W [06/May/2021:19:48:16 +0200] Notifier for subscription 119 (dbus://) went away, retrying!
E [06/May/2021:19:48:17 +0200] Filter \"rastertopwg\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"rastertopwg\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"gstopdf\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"gstoraster\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"gstoraster\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"gstoraster\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"texttopdf\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"texttopdf\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"texttopdf\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"texttopdf\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"texttopdf\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"texttopdf\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"bannertopdf\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:48:17 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:48:17 +0200] cupsdLoadBanners: Unable to open banner directory "/usr/share/cups/banners": No such file or directory
E [06/May/2021:19:48:17 +0200] HP-HP-LaserJet-M14-M17: Il file \"/usr/lib/cups/filter/hpcups\" non è disponibile: No such file or directory
E [06/May/2021:19:52:09 +0200] Brother-QL-500: Il file \"/usr/lib/cups/backend/usb\" non è disponibile: No such file or directory
E [06/May/2021:19:52:09 +0200] [Job 50] Stopping job because the sheduler could not execute the backend.
E [06/May/2021:19:52:24 +0200] Il file \"/usr/lib/cups/daemon/cups-deviced\" non è disponibile: No such file or directory
E [06/May/2021:19:52:24 +0200] [Client 117] Returning IPP server-error-internal-error for CUPS-Get-Devices (no URI) from localhost.
E [06/May/2021:19:52:29 +0200] Il file \"/usr/lib/cups/daemon/cups-deviced\" non è disponibile: No such file or directory
E [06/May/2021:19:52:29 +0200] [Client 132] Returning IPP server-error-internal-error for CUPS-Get-Devices (no URI) from localhost.
E [06/May/2021:19:52:59 +0200] Unable to remove /run/cups/certs/0!
E [06/May/2021:19:52:59 +0200] Unable to remove /run/cups/certs/0!
E [06/May/2021:19:54:04 +0200] Filter \"rastertopwg\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"rastertopwg\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"gstopdf\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"gstoraster\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"gstoraster\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"gstoraster\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"texttopdf\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"texttopdf\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"texttopdf\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"texttopdf\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"texttopdf\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"texttopdf\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"bannertopdf\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:54:04 +0200] Filter \"imagetoraster\" not found.
E [06/May/2021:19:54:05 +0200] cupsdLoadBanners: Unable to open banner directory "/usr/share/cups/banners": No such file or directory
E [06/May/2021:19:54:05 +0200] HP-HP-LaserJet-M14-M17: Il file \"/usr/lib/cups/filter/hpcups\" non è disponibile: No such file or directory
E [06/May/2021:19:54:14 +0200] Il file \"/usr/lib/cups/daemon/cups-deviced\" non è disponibile: No such file or directory
E [06/May/2021:19:54:14 +0200] [Client 4] Returning IPP server-error-internal-error for CUPS-Get-Devices (no URI) from localhost.
E [06/May/2021:19:57:43 +0200] Brother-QL-500: Il file \"/usr/lib/cups/backend/usb\" non è disponibile: No such file or directory
E [06/May/2021:19:57:43 +0200] [Job 50] Stopping job because the sheduler could not execute the backend.
alvin@alvin-EB1007:~$ 
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 22650
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: Xubuntu
Distribuzione: Ubuntu 20.04 LTS x86_64
Località: Pisa

Re: brother ql-500 su Ubuntu 21.04

Messaggio da magozurlinux »

Se sapevo che quei comandi rimuovessero CUPS non li avrei consigliati.

Da terminale connesso ad Internet dai questo comando:

Codice: Seleziona tutto

sudo apt install cups-browsed cups-core-drivers cups-daemon cups-filters-core-drivers cups-ipp-utils cups-server-common hplip-data libcupsimage2 libfontembed1 libgutenprint-common libgutenprint9 libhpmud0 libimagequant0
  liblouisutdml-bin liblouisutdml-data liblouisutdml9 libpoppler-cpp0v5 libqpdf28 libsane-hpaio printer-driver-postscript-hp python3-olefile python3-pil python3-renderpm python3-reportlab
  python3-reportlab-accel ssl-cert
Xubuntu 20.04 LTS amd64 :ciao:
Dig
Prode Principiante
Messaggi: 246
Iscrizione: domenica 2 dicembre 2007, 14:58

Re: brother ql-500 su Ubuntu 21.04

Messaggio da Dig »

CUPS reinstallato. L'HP ha ripreso regolarmente a funzionare.
L'etichettatrice è tornata a lampeggiare al momento di stampa

Codice: Seleziona tutto

alvin@alvin-EB1007:~$ cat /var/log/cups/error_log
W [08/May/2021:09:23:24 +0200] [Job 55] Grayscale/monochrome printing requested for this job but Poppler is not able to convert to grayscale/monochrome PostScript.
W [08/May/2021:09:23:24 +0200] [Job 55] Use \"pdftops-renderer\" option (see cups-filters README file) to use Ghostscript or MuPDF for the PDF -> PostScript conversion.
alvin@alvin-EB1007:~$ 

Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 22650
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: Xubuntu
Distribuzione: Ubuntu 20.04 LTS x86_64
Località: Pisa

Re: brother ql-500 su Ubuntu 21.04

Messaggio da magozurlinux »

Dig ha scritto:
sabato 8 maggio 2021, 10:23
CUPS reinstallato. L'HP ha ripreso regolarmente a funzionare.
L'etichettatrice è tornata a lampeggiare al momento di stampa

alvin@alvin-EB1007:~$ cat /var/log/cups/error_log
W [08/May/2021:09:23:24 +0200] [Job 55] Grayscale/monochrome printing requested for this job but Poppler is not able to convert to grayscale/monochrome PostScript.
W [08/May/2021:09:23:24 +0200] [Job 55] Use \"pdftops-renderer\" option (see cups-filters README file) to use Ghostscript or MuPDF for the PDF -> PostScript conversion.
Prova a dare questo comando da terminale:

Codice: Seleziona tutto

lpadmin -p printer -R pdftops-renderer-default
oppure

Codice: Seleziona tutto

lpadmin -p printer -o pdftops-renderer-default=gs
Xubuntu 20.04 LTS amd64 :ciao:
Dig
Prode Principiante
Messaggi: 246
Iscrizione: domenica 2 dicembre 2007, 14:58

Re: brother ql-500 su Ubuntu 21.04

Messaggio da Dig »

Codice: Seleziona tutto

alvin@alvin-EB1007:~$ cat /var/log/cups/error_log
W [11/May/2021:08:57:26 +0200] Notifier for subscription 165 (dbus://) went away, retrying!
W [11/May/2021:08:57:26 +0200] Notifier for subscription 170 (dbus://) went away, retrying!
W [11/May/2021:08:57:26 +0200] Notifier for subscription 175 (dbus://) went away, retrying!
W [11/May/2021:08:57:36 +0200] Bad resolution "Normal" for printer QL-550.
W [11/May/2021:08:57:36 +0200] Notifier for subscription 165 (dbus://) went away, retrying!
W [11/May/2021:08:57:36 +0200] Notifier for subscription 170 (dbus://) went away, retrying!
W [11/May/2021:08:57:36 +0200] Notifier for subscription 175 (dbus://) went away, retrying!
W [11/May/2021:09:00:45 +0200] [Job 61] Grayscale/monochrome printing requested for this job but Poppler is not able to convert to grayscale/monochrome PostScript.
W [11/May/2021:09:00:45 +0200] [Job 61] Use \"pdftops-renderer\" option (see cups-filters README file) to use Ghostscript or MuPDF for the PDF -> PostScript conversion.
alvin@alvin-EB1007:~$ 
Dig
Prode Principiante
Messaggi: 246
Iscrizione: domenica 2 dicembre 2007, 14:58

Re: brother ql-500 su Ubuntu 21.04

Messaggio da Dig »

Ho trovato questa discussione, mi pare sia attinente:

https://bugs.debian.org/cgi-bin/bugrepo ... bug=950690

può essere d'aiuto? Tra inglese e comandi per me avanzati non ci capisco molto
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 22650
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: Xubuntu
Distribuzione: Ubuntu 20.04 LTS x86_64
Località: Pisa

Re: brother ql-500 su Ubuntu 21.04

Messaggio da magozurlinux »

Sì, ho visto, è un bug, è la prima volta che vedo un errore di quel tipo, io avrei preferito installare la 20.04 LTS che è supportata per 5 anni, che la 21.04: a ottobre dovrai aggiornare alla 21.10. :D

Da terminale postami questo comando:

Codice: Seleziona tutto

dpkg -l | grep mupdf
Xubuntu 20.04 LTS amd64 :ciao:
Dig
Prode Principiante
Messaggi: 246
Iscrizione: domenica 2 dicembre 2007, 14:58

Re: brother ql-500 su Ubuntu 21.04

Messaggio da Dig »

Il comando non da segni.

Codice: Seleziona tutto

alvin@alvin-EB1007:~$ dpkg -l | grep mupdf
alvin@alvin-EB1007:~$ dpkg -l | grep mupdf
alvin@alvin-EB1007:~$ 
Sul pc principale girano sempre le versioni di Ubuntu vecchie finché non cambio HD o qualche altro hardware. Dovrò aggiornare per forza?
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 22650
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: Xubuntu
Distribuzione: Ubuntu 20.04 LTS x86_64
Località: Pisa

Re: brother ql-500 su Ubuntu 21.04

Messaggio da magozurlinux »

Se hai installato la 21.04 a fine ottobre non riceverai più aggiornamenti.
Xubuntu 20.04 LTS amd64 :ciao:
Scrivi risposta

Ritorna a “Driver e periferiche”

Chi c’è in linea

Visualizzano questa sezione: Bing [Bot] e 7 ospiti