[Risolto] web-cam non funzionante su ubuntu 22.04 LTS

Riconoscimento, installazione e configurazione delle periferiche.
Avatar utente
dalca
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 372
Iscrizione: martedì 30 dicembre 2008, 23:01
Desktop: GNOME
Distribuzione: Ubuntu 22.04 LTS X86_64
Sesso: Maschile

[Risolto] web-cam non funzionante su ubuntu 22.04 LTS

Messaggio da dalca »

Buonasera a tutti,
mi sono accorto che la webcam non funziona. Ho un laptop HP Elitebook 840 G7 con installato Ubuntu 22.04 LTS,
Ho letto un po' di notizie sul forum ed ho seguito il suggerimento di installare guvcview in quanto sembra che gestisca meglio le webcam, ma anche con guvcview lo schermo è nero.
A questo punto penso siano problemi di driver ma sinceramente non saprei come procedere per sistemare.
Qualcuno a qualche idea? Se vi serve qualche altra informazione chiedete.
Grazie in anticipo.
Ultima modifica di dalca il giovedì 9 maggio 2024, 20:26, modificato 1 volta in totale.
Avatar utente
GjMan78
Rampante Reduce
Rampante Reduce
Messaggi: 5819
Iscrizione: mercoledì 22 novembre 2006, 19:15
Desktop: KdePlasma
Distribuzione: EndeavourOS
Sesso: Maschile
Località: ~/Italia/Lazio/Viterbo/

Re: web-cam non funzionante su ubuntu 22.04 LTS

Messaggio da GjMan78 »

Inizia postando il risultato di

Codice: Seleziona tutto

lsusb
MacBook Pro - Intel i5-3210 - 16 Gbyte Ram DDR3 - SSD 500 Gbyte x 2
»»» 𝗙𝗮𝗶 𝗶𝗹 𝗕𝗮𝗰𝗸𝘂𝗽! ¯\_(ツ)_/¯
Avatar utente
dalca
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 372
Iscrizione: martedì 30 dicembre 2008, 23:01
Desktop: GNOME
Distribuzione: Ubuntu 22.04 LTS X86_64
Sesso: Maschile

Re: web-cam non funzionante su ubuntu 22.04 LTS

Messaggio da dalca »

GjMan grazie per la risposta.
Ecco di seguito il risultato del comando lsusb:

Codice: Seleziona tutto

fausto@fausto-hp-elitebook-840-g7:~$ lsusb
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 30c9:000f Luxvisions Innotech Limited HP HD Camera
Bus 001 Device 003: ID 8087:0026 Intel Corp. AX201 Bluetooth
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Avatar utente
GjMan78
Rampante Reduce
Rampante Reduce
Messaggi: 5819
Iscrizione: mercoledì 22 novembre 2006, 19:15
Desktop: KdePlasma
Distribuzione: EndeavourOS
Sesso: Maschile
Località: ~/Italia/Lazio/Viterbo/

Re: web-cam non funzionante su ubuntu 22.04 LTS

Messaggio da GjMan78 »

Posta

Codice: Seleziona tutto

lsmod | grep uvc
MacBook Pro - Intel i5-3210 - 16 Gbyte Ram DDR3 - SSD 500 Gbyte x 2
»»» 𝗙𝗮𝗶 𝗶𝗹 𝗕𝗮𝗰𝗸𝘂𝗽! ¯\_(ツ)_/¯
Avatar utente
dalca
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 372
Iscrizione: martedì 30 dicembre 2008, 23:01
Desktop: GNOME
Distribuzione: Ubuntu 22.04 LTS X86_64
Sesso: Maschile

Re: web-cam non funzionante su ubuntu 22.04 LTS

Messaggio da dalca »

Ecco il risultato:

Codice: Seleziona tutto

fausto@fausto-hp-elitebook-840-g7:~$ lsmod | grep uvc
uvcvideo              135168  0
videobuf2_vmalloc      20480  1 uvcvideo
uvc                    12288  1 uvcvideo
videobuf2_v4l2         40960  1 uvcvideo
videodev              364544  2 videobuf2_v4l2,uvcvideo
videobuf2_common       86016  4 videobuf2_vmalloc,videobuf2_v4l2,uvcvideo,videobuf2_memops
mc                     86016  4 videodev,videobuf2_v4l2,uvcvideo,videobuf2_common
Avatar utente
GjMan78
Rampante Reduce
Rampante Reduce
Messaggi: 5819
Iscrizione: mercoledì 22 novembre 2006, 19:15
Desktop: KdePlasma
Distribuzione: EndeavourOS
Sesso: Maschile
Località: ~/Italia/Lazio/Viterbo/

Re: web-cam non funzionante su ubuntu 22.04 LTS

Messaggio da GjMan78 »

In linea teorica la webcam dovrebbe essere riconosciuta e funzionante tramite il driver contenuto nel kernel, ma in realtà le cose non vanno così.

I probes su linux-hardware rispecchiano la tua situazione: la webcam viene riconosciuta ma non funziona, a parte un singolo report dove sembra che funzioni con Fedora 38, ma stranamente non con le versioni successive.

https://linux-hardware.org/?id=usb:30c9-000f

Ho cercato qualche repository con i driver da installare ma purtroppo senza esito.

In breve per quelle che sono le mie competenze non penso ci sia una soluzione, mi dispiace.

Spero per te che qualcun'altro proponga un'alternativa...

:ciao:
MacBook Pro - Intel i5-3210 - 16 Gbyte Ram DDR3 - SSD 500 Gbyte x 2
»»» 𝗙𝗮𝗶 𝗶𝗹 𝗕𝗮𝗰𝗸𝘂𝗽! ¯\_(ツ)_/¯
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 23506
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 23.10 e 24.04 (dev)
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: web-cam non funzionante su ubuntu 22.04 LTS

Messaggio da trekfan1 »

Provare a scaricare l'ultimo kernel da mainline? http://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 24944
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: xubuntu
Distribuzione: Xubuntu 22.04.3 LTS x86_64
Sesso: Maschile
Località: Pisa

Re: web-cam non funzionante su ubuntu 22.04 LTS

Messaggio da magozurlinux »

Da terminale posta questi comandi:

Codice: Seleziona tutto

usb-devices

Codice: Seleziona tutto

sudo dmesg | grep usb
Ubuntu 22.04 LTS - saluti da magozurlinux a tutti gli utenti del forum :ciao:
Avatar utente
GjMan78
Rampante Reduce
Rampante Reduce
Messaggi: 5819
Iscrizione: mercoledì 22 novembre 2006, 19:15
Desktop: KdePlasma
Distribuzione: EndeavourOS
Sesso: Maschile
Località: ~/Italia/Lazio/Viterbo/

Re: web-cam non funzionante su ubuntu 22.04 LTS

Messaggio da GjMan78 »

trekfan1 ha scritto:
mercoledì 24 aprile 2024, 18:51
Provare a scaricare l'ultimo kernel da mainline? http://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D
Ci avevo pensato ma tra i vari probes su linux-hardware c'è anche Arch, e la webcam non funziona nemmeno con il kernel 6.7
https://linux-hardware.org/?probe=6f09cb7800

Ma un tentativo in fondo non guasta.
MacBook Pro - Intel i5-3210 - 16 Gbyte Ram DDR3 - SSD 500 Gbyte x 2
»»» 𝗙𝗮𝗶 𝗶𝗹 𝗕𝗮𝗰𝗸𝘂𝗽! ¯\_(ツ)_/¯
Avatar utente
dalca
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 372
Iscrizione: martedì 30 dicembre 2008, 23:01
Desktop: GNOME
Distribuzione: Ubuntu 22.04 LTS X86_64
Sesso: Maschile

Re: web-cam non funzionante su ubuntu 22.04 LTS

Messaggio da dalca »

magozurlinux ha scritto:
mercoledì 24 aprile 2024, 19:03
Da terminale posta questi comandi:

Codice: Seleziona tutto

usb-devices

Codice: Seleziona tutto

sudo dmesg | grep usb
Grazie magozrlinux, ecco i risultati:

Codice: Seleziona tutto

fausto@fausto-hp-elitebook-840-g7:~$ usb-devices

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh=12
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev=06.05
S:  Manufacturer=Linux 6.5.0-28-generic xhci-hcd
S:  Product=xHCI Host Controller
S:  SerialNumber=0000:00:14.0
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=01 Lev=01 Prnt=01 Port=09 Cnt=01 Dev#=  3 Spd=12  MxCh= 0
D:  Ver= 2.01 Cls=e0(wlcon) Sub=01 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=8087 ProdID=0026 Rev=00.02
C:  #Ifs= 2 Cfg#= 1 Atr=e0 MxPwr=100mA
I:  If#= 0 Alt= 0 #EPs= 3 Cls=e0(wlcon) Sub=01 Prot=01 Driver=btusb
E:  Ad=02(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=81(I) Atr=03(Int.) MxPS=  64 Ivl=1ms
E:  Ad=82(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
I:  If#= 1 Alt= 0 #EPs= 2 Cls=e0(wlcon) Sub=01 Prot=01 Driver=btusb
E:  Ad=03(O) Atr=01(Isoc) MxPS=   0 Ivl=1ms
E:  Ad=83(I) Atr=01(Isoc) MxPS=   0 Ivl=1ms

T:  Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=10000 MxCh= 6
D:  Ver= 3.10 Cls=09(hub  ) Sub=00 Prot=03 MxPS= 9 #Cfgs=  1
P:  Vendor=1d6b ProdID=0003 Rev=06.05
S:  Manufacturer=Linux 6.5.0-28-generic xhci-hcd
S:  Product=xHCI Host Controller
S:  SerialNumber=0000:00:14.0
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=03 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh= 2
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev=06.05
S:  Manufacturer=Linux 6.5.0-28-generic xhci-hcd
S:  Product=xHCI Host Controller
S:  SerialNumber=0000:37:00.0
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=04 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=10000 MxCh= 2
D:  Ver= 3.10 Cls=09(hub  ) Sub=00 Prot=03 MxPS= 9 #Cfgs=  1
P:  Vendor=1d6b ProdID=0003 Rev=06.05
S:  Manufacturer=Linux 6.5.0-28-generic xhci-hcd
S:  Product=xHCI Host Controller
S:  SerialNumber=0000:37:00.0
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

Codice: Seleziona tutto

fausto@fausto-hp-elitebook-840-g7:~$ sudo dmesg | grep usb
[sudo] password di fausto: 
[    0.621780] usbcore: registered new interface driver usbfs
[    0.621780] usbcore: registered new interface driver hub
[    0.621780] usbcore: registered new device driver usb
[    1.607653] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 6.05
[    1.607656] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.607658] usb usb1: Product: xHCI Host Controller
[    1.607659] usb usb1: Manufacturer: Linux 6.5.0-28-generic xhci-hcd
[    1.607661] usb usb1: SerialNumber: 0000:00:14.0
[    1.616537] usb usb2: New USB device found, idVendor=1d6b, idProduct=0003, bcdDevice= 6.05
[    1.616543] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.616546] usb usb2: Product: xHCI Host Controller
[    1.616549] usb usb2: Manufacturer: Linux 6.5.0-28-generic xhci-hcd
[    1.616551] usb usb2: SerialNumber: 0000:00:14.0
[    1.623442] usb: port power management may be unreliable
[    1.628776] usb usb3: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 6.05
[    1.628780] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.628783] usb usb3: Product: xHCI Host Controller
[    1.628786] usb usb3: Manufacturer: Linux 6.5.0-28-generic xhci-hcd
[    1.628788] usb usb3: SerialNumber: 0000:37:00.0
[    1.630989] usb usb4: New USB device found, idVendor=1d6b, idProduct=0003, bcdDevice= 6.05
[    1.630995] usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.630998] usb usb4: Product: xHCI Host Controller
[    1.631001] usb usb4: Manufacturer: Linux 6.5.0-28-generic xhci-hcd
[    1.631003] usb usb4: SerialNumber: 0000:37:00.0
[    1.881804] usb 1-2: new high-speed USB device number 2 using xhci_hcd
[    2.138893] usb 1-2: New USB device found, idVendor=30c9, idProduct=000f, bcdDevice= 0.08
[    2.138908] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    2.138914] usb 1-2: Product: HP HD Camera
[    2.138919] usb 1-2: Manufacturer: SunplusIT Inc
[    2.138923] usb 1-2: SerialNumber: 01.00.00
[    2.285802] usb 1-10: new full-speed USB device number 3 using xhci_hcd
[    2.436551] usb 1-10: New USB device found, idVendor=8087, idProduct=0026, bcdDevice= 0.02
[    2.436566] usb 1-10: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    4.200841] usbcore: registered new interface driver btusb
[    4.226254] usb 1-2: Found UVC 1.50 device HP HD Camera (30c9:000f)
[    4.333368] usb 1-2: Found UVC 1.50 device HP HD Camera (30c9:000f)
[    4.356108] usbcore: registered new interface driver uvcvideo
Grazie trekfan1 e GjMan per il consiglio di provare l'ultimo kernel ma non sono pratico e non saprei come fare. In altenativa vorrei provare domani ad installare la nuova versione 24.04.
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 24944
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: xubuntu
Distribuzione: Xubuntu 22.04.3 LTS x86_64
Sesso: Maschile
Località: Pisa

Re: web-cam non funzionante su ubuntu 22.04 LTS

Messaggio da magozurlinux »

dalca ha scritto:
mercoledì 24 aprile 2024, 20:46

Grazie magozurlinux, ecco i risultati:

Codice: Seleziona tutto

usb-devices

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh=12
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev=06.05
S:  Manufacturer=Linux 6.5.0-28-generic xhci-hcd
S:  Product=xHCI Host Controller
S:  SerialNumber=0000:00:14.0
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=01 Lev=01 Prnt=01 Port=09 Cnt=01 Dev#=  3 Spd=12  MxCh= 0
D:  Ver= 2.01 Cls=e0(wlcon) Sub=01 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=8087 ProdID=0026 Rev=00.02
C:  #Ifs= 2 Cfg#= 1 Atr=e0 MxPwr=100mA
I:  If#= 0 Alt= 0 #EPs= 3 Cls=e0(wlcon) Sub=01 Prot=01 Driver=btusb
E:  Ad=02(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=81(I) Atr=03(Int.) MxPS=  64 Ivl=1ms
E:  Ad=82(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
I:  If#= 1 Alt= 0 #EPs= 2 Cls=e0(wlcon) Sub=01 Prot=01 Driver=btusb
E:  Ad=03(O) Atr=01(Isoc) MxPS=   0 Ivl=1ms
E:  Ad=83(I) Atr=01(Isoc) MxPS=   0 Ivl=1ms

T:  Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=10000 MxCh= 6
D:  Ver= 3.10 Cls=09(hub  ) Sub=00 Prot=03 MxPS= 9 #Cfgs=  1
P:  Vendor=1d6b ProdID=0003 Rev=06.05
S:  Manufacturer=Linux 6.5.0-28-generic xhci-hcd
S:  Product=xHCI Host Controller
S:  SerialNumber=0000:00:14.0
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=03 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh= 2
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev=06.05
S:  Manufacturer=Linux 6.5.0-28-generic xhci-hcd
S:  Product=xHCI Host Controller
S:  SerialNumber=0000:37:00.0
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=04 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=10000 MxCh= 2
D:  Ver= 3.10 Cls=09(hub  ) Sub=00 Prot=03 MxPS= 9 #Cfgs=  1
P:  Vendor=1d6b ProdID=0003 Rev=06.05
S:  Manufacturer=Linux 6.5.0-28-generic xhci-hcd
S:  Product=xHCI Host Controller
S:  SerialNumber=0000:37:00.0
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms
sudo dmesg | grep usb
[sudo] password di fausto:
[ 1.881804] usb 1-2: new high-speed USB device number 2 using xhci_hcd
[ 2.138893] usb 1-2: New USB device found, idVendor=30c9, idProduct=000f, bcdDevice= 0.08
[ 2.138908] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2.138914] usb 1-2: Product: HP HD Camera
[ 2.138919] usb 1-2: Manufacturer: SunplusIT Inc
[ 2.138923] usb 1-2: SerialNumber: 01.00.00

[ 2.285802] usb 1-10: new full-speed USB device number 3 using xhci_hcd
[ 2.436551] usb 1-10: New USB device found, idVendor=8087, idProduct=0026, bcdDevice= 0.02
[ 2.436566] usb 1-10: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 4.200841] usbcore: registered new interface driver btusb
[ 4.226254] usb 1-2: Found UVC 1.50 device HP HD Camera (30c9:000f)
[ 4.333368] usb 1-2: Found UVC 1.50 device HP HD Camera (30c9:000f)
[ 4.356108] usbcore: registered new interface driver uvcvideo



Grazie trekfan1 e GjMan per il consiglio di provare l'ultimo kernel ma non sono pratico e non saprei come fare. In altenativa vorrei provare domani ad installare la nuova versione 24.04.
Dal comando usb-devices non evidenzia la webcam, è possibile che tu abbia saltato un pezzo di output.
Ubuntu 22.04 LTS - saluti da magozurlinux a tutti gli utenti del forum :ciao:
Avatar utente
dalca
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 372
Iscrizione: martedì 30 dicembre 2008, 23:01
Desktop: GNOME
Distribuzione: Ubuntu 22.04 LTS X86_64
Sesso: Maschile

Re: web-cam non funzionante su ubuntu 22.04 LTS

Messaggio da dalca »

Ho ridato il comando usb-devices e questo che riporto è l'output che mi ha dato:

Codice: Seleziona tutto

fausto@fausto-hp-elitebook-840-g7:~$ usb-devices

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh=12
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev=06.05
S:  Manufacturer=Linux 6.5.0-28-generic xhci-hcd
S:  Product=xHCI Host Controller
S:  SerialNumber=0000:00:14.0
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=01 Lev=01 Prnt=01 Port=09 Cnt=01 Dev#=  3 Spd=12  MxCh= 0
D:  Ver= 2.01 Cls=e0(wlcon) Sub=01 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=8087 ProdID=0026 Rev=00.02
C:  #Ifs= 2 Cfg#= 1 Atr=e0 MxPwr=100mA
I:  If#= 0 Alt= 0 #EPs= 3 Cls=e0(wlcon) Sub=01 Prot=01 Driver=btusb
E:  Ad=02(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=81(I) Atr=03(Int.) MxPS=  64 Ivl=1ms
E:  Ad=82(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
I:  If#= 1 Alt= 0 #EPs= 2 Cls=e0(wlcon) Sub=01 Prot=01 Driver=btusb
E:  Ad=03(O) Atr=01(Isoc) MxPS=   0 Ivl=1ms
E:  Ad=83(I) Atr=01(Isoc) MxPS=   0 Ivl=1ms

T:  Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=10000 MxCh= 6
D:  Ver= 3.10 Cls=09(hub  ) Sub=00 Prot=03 MxPS= 9 #Cfgs=  1
P:  Vendor=1d6b ProdID=0003 Rev=06.05
S:  Manufacturer=Linux 6.5.0-28-generic xhci-hcd
S:  Product=xHCI Host Controller
S:  SerialNumber=0000:00:14.0
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=03 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh= 2
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev=06.05
S:  Manufacturer=Linux 6.5.0-28-generic xhci-hcd
S:  Product=xHCI Host Controller
S:  SerialNumber=0000:37:00.0
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=04 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=10000 MxCh= 2
D:  Ver= 3.10 Cls=09(hub  ) Sub=00 Prot=03 MxPS= 9 #Cfgs=  1
P:  Vendor=1d6b ProdID=0003 Rev=06.05
S:  Manufacturer=Linux 6.5.0-28-generic xhci-hcd
S:  Product=xHCI Host Controller
S:  SerialNumber=0000:37:00.0
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms
fausto@fausto-hp-elitebook-840-g7:~$ 
Avatar utente
GjMan78
Rampante Reduce
Rampante Reduce
Messaggi: 5819
Iscrizione: mercoledì 22 novembre 2006, 19:15
Desktop: KdePlasma
Distribuzione: EndeavourOS
Sesso: Maschile
Località: ~/Italia/Lazio/Viterbo/

Re: web-cam non funzionante su ubuntu 22.04 LTS

Messaggio da GjMan78 »

dalca ha scritto:
mercoledì 24 aprile 2024, 20:46
Grazie trekfan1 e GjMan per il consiglio di provare l'ultimo kernel ma non sono pratico e non saprei come fare. In altenativa vorrei provare domani ad installare la nuova versione 24.04.
Per verificare il funzionamento della webcam non serve nemmeno installare la nuova versione ti basta provarla in live.

Ma prima direi di aspettare le verifiche di @magozurlinux, spesso riesce a fare miracoli. ;)
MacBook Pro - Intel i5-3210 - 16 Gbyte Ram DDR3 - SSD 500 Gbyte x 2
»»» 𝗙𝗮𝗶 𝗶𝗹 𝗕𝗮𝗰𝗸𝘂𝗽! ¯\_(ツ)_/¯
Avatar utente
dalca
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 372
Iscrizione: martedì 30 dicembre 2008, 23:01
Desktop: GNOME
Distribuzione: Ubuntu 22.04 LTS X86_64
Sesso: Maschile

Re: web-cam non funzionante su ubuntu 22.04 LTS

Messaggio da dalca »

Essendo il laptop in dualboot con Windows, ho provato con "Fotocamera", un programma di Windows per usare la webcam, ma anche con questo non funziona. Per cui penso che sia guasta la webcam.
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 23506
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 23.10 e 24.04 (dev)
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: web-cam non funzionante su ubuntu 22.04 LTS

Messaggio da trekfan1 »

Eh sì, se non funziona anche con windows a questo punto è così
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 24944
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: xubuntu
Distribuzione: Xubuntu 22.04.3 LTS x86_64
Sesso: Maschile
Località: Pisa

Re: web-cam non funzionante su ubuntu 22.04 LTS

Messaggio da magozurlinux »

GjMan78 ha scritto:
giovedì 25 aprile 2024, 10:38

Per verificare il funzionamento della webcam non serve nemmeno installare la nuova versione ti basta provarla in live.

Ma prima direi di aspettare le verifiche di @magozurlinux, spesso riesce a fare miracoli. ;)
dalca ha scritto:
giovedì 25 aprile 2024, 20:17
Essendo il laptop in dualboot con Windows, ho provato con "Fotocamera", un programma di Windows per usare la webcam, ma anche con questo non funziona. Per cui penso che sia guasta la webcam.
E' possibile che si sia sganciato il connettore della webcam dai pin saldati sulla porta usb, per questo non funziona.

Con Windows, sei andato su Gestione dispositivi per vedere se la webcam ha il driver?
Ubuntu 22.04 LTS - saluti da magozurlinux a tutti gli utenti del forum :ciao:
Avatar utente
dalca
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 372
Iscrizione: martedì 30 dicembre 2008, 23:01
Desktop: GNOME
Distribuzione: Ubuntu 22.04 LTS X86_64
Sesso: Maschile

Re: web-cam non funzionante su ubuntu 22.04 LTS

Messaggio da dalca »

Ho controllato su windows il driver ed è installato, ho provato ad aggiornarlo ma mi è uscito il messaggio che quello installato è il miglio driver.
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 23506
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 23.10 e 24.04 (dev)
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: web-cam non funzionante su ubuntu 22.04 LTS

Messaggio da trekfan1 »

@magozurlinux se il problema è la webcam integrata sul portatile ho paura che la porta usb non 'entri nulla.... purtroppo bisogna aprire il portatile e verificare che non sia qualche filo rotto e se non ci sono fili rotti allora bisogna o cambiare la webcam o mette una webcam usb....
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 24944
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: xubuntu
Distribuzione: Xubuntu 22.04.3 LTS x86_64
Sesso: Maschile
Località: Pisa

Re: web-cam non funzionante su ubuntu 22.04 LTS

Messaggio da magozurlinux »

dalca ha scritto:
venerdì 26 aprile 2024, 20:16
Ho controllato su windows il driver ed è installato, ho provato ad aggiornarlo ma mi è uscito il messaggio che quello installato è il miglio driver.
Ciao.

Da terminale postami questo comando:

Codice: Seleziona tutto

dpkg -l | grep v4l
Ubuntu 22.04 LTS - saluti da magozurlinux a tutti gli utenti del forum :ciao:
Avatar utente
dalca
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 372
Iscrizione: martedì 30 dicembre 2008, 23:01
Desktop: GNOME
Distribuzione: Ubuntu 22.04 LTS X86_64
Sesso: Maschile

Re: web-cam non funzionante su ubuntu 22.04 LTS

Messaggio da dalca »

Ti posto di seguito il comando:

Codice: Seleziona tutto

fausto@fausto-HP-EliteBook-840-G7-Notebook-PC:~$ dpkg -l | grep v4l
ii  libv4l-0t64:amd64                             1.26.1-4build3                           amd64        Collection of video4linux support libraries
ii  libv4lconvert0t64:amd64                       1.26.1-4build3                           amd64        Video4linux frame format conversion library
fausto@fausto-HP-EliteBook-840-G7-Notebook-PC:~$ 
Scrivi risposta

Ritorna a “Driver e periferiche”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 9 ospiti